MediaCmd: MediaCmd SDK

  • Main Page
  • Data Structures
  • Files
  • Related Pages

MediaCmd SDK

0

Introduction

The Drastic MediaCmd SDK is the mechanism by which all the elements of Drastic's DDRs communicate with one and other. This includes:

Controlling VVW DDR Servers, QuickClip locally, and QuickClip with network option remotely Controlling 9 pin serial VTRs and Servers via Sony, Odetics or VDCP protocol Receiving commands from 9 pin serial controller via Sony, Odetics or VDCP protocol Receiving commands from Drastic GUIs, servers and controllers Building HTML/Ajax status and control pages

MediaCmd is the commincation method used within Drastic's DDR products. Any operation you see in a Drastic interface is available to your application through MediaCmd.

Overview

MediaCmd is a simple structure that supports a small, well defined set of commands for communicating transport, status and setup information between components in Drastic's DDR software. There are a number of fields in the stucture, but the important fields are:

ctCmd – the primary command of this packet (Play, Pause, Stop, Record, etc) lSpeed – the transport speed for any play commands (integer where 65520 = normal forward play) dwPosition – the frame position for any play, pause or record commands dwStart – the starting frame for any play or record commands (inclusive) dwEnd – the ending frame for any play or record commands (exclusive) arbID – clip name, file name or other string/binary data for the command cfFlags – denotes which fields above are valid and their meaning

With the standard initialization of the structure, you can quickly build commands in this structure by changing a few members and sending it. The primary motion commands are ctPlay, ctPause, ctStop, ctRecStop, ctRecord, ctEject and ctTransfer. To get the current state (position, speed, start and end, current clip), the command ctGetState will return a filled in MediaCmd. For setup and less common status (e.g. video input, audio rms level, genlock) there is ctGetValue and ctSetValue. This is documented in the Low Level Header Docs.

Hopefully, you will not have to deal with the MediaCmd structure directly. The SDK includes a series of simple commands that should provide 99% of what your application needs. These functions are simply wrappers that create and send MediaCmd structures. The source for all these functions is provided in the SDK under SRC/General/vvwIF.cpp in case you need to modify or create new commands. The commands have slightly different names depending on which interface you use, but have the same root name, such as: Play(), PlayFromTo(), Stop(), Pause(), Seek(), Record() and UpdateStatus(). Commands are also included for getting clip lists (GetNextClip()) and EDL elements from VTR_TC time code spaces (EDLResetToStart(), EDLGetEdit()). A selection of the most common settings are also included (SetVideoInput(), SetAudioInput(), SetVideoGenlock(), GetAudioPeakRMS(), etc). This interface is documented in the MediaCmd Documentation (previously called “VVW Interface Specification”).

Installation

To properly work with the MediaCmd SDK, you should have a copy of the QuickClip software installed on your development system. Even if you target application will only use a part of the QuickClip software, it should all be installed for the development phase. Before proceeding with the SDK you should familarize your self with QuickClip's operation and toolset. All the elements available within QuickClip are the same elements available to your application through the SDK. Once you have QuickClip installed, you should install the MediaCmd SDK. This will install the headers, libraries and source needed to control QuickClip from your application.

Choosing An Access Method

The SDK access method you should use depends on what you you would like your application to do, what programming language you are using and how involved you would like to/need to get in the low level MediaCmd structures. No matter which method you choose, the MediaCmd structure packets are exactly the same. Here are the main access method, with their pros and cons:

ActiveX
Type: Microsoft ActiveX/COM access method
Pros: Easy to program, 1:1 relationship with QuickClip/XO interface.
Cons: Uses same config as QuickClip/XO. Requires a local copy of QuickClip.
Setup: Register VVW.DLL using RegSvr32.exe in the QuickClip installation directory.
Issues: Difficult to use when communicating via TCP/IP within the same machine. Can be overcome by using the default pipe communication system, but this requires changes for remote network control.

Direct Link
Type: Direct link to VVW.DLL
Pros: No ActiveX layer, code compatible with Linux, Irix, Mac OS-X.
Cons: Uses default config from QuickClip/XO, application must be run in QuickClip directory. Requires a local copy of QuickClip.
Setup: Link to vvw.lib, include vvw.h. Copy application into the QuickClip directory before running
Issues: Needs access to VVW.dll and all its support DLLs/D1Xs. Still needs to be setup by LocalConfig.exe or QuickClip/XO

Network DLL
Type: Direct line to vvwNet2.dll
Pros: Consistant interface between local/remote and various OSs. Does not require a local copy of QuickClip.
Cons: Requires vvwNet2.dll and support dlls
Setup: Link to vvwNet2.lib, include vvwNet2.h. Copy dll set from SDK/bin directory with your application
Issues: Use the netOpenLocal function to avoid QuickClip configuration issues. Requires a few dlls to be added to you application installations. Does not run the client software automatically, so you application may need to start it, depending on what your application is doing.

Network Direct
Type: Direct compile of network sources in your app or your dll.
Pros: No extra dlls. Easy to customize and modify. Lots of comands already written.
Cons: You app needs to handle setup and may need to run QuickClip.exe/VVWServer.exe/QCRun.exe.
Setup: Copy source files from vvwNet2 into you project, modify and compile
Issues: Does not run the client software automatically, so you application may need to start it, depending on what your application is doing.

Manual
Type: Use the structures and defines to write your own communication and control layer.
Pros: This is required if you are using an unsupported development platform like PHP.
Cons: Everything has to be built and tested from the ground up.
Setup: None.
Issues: Unless you absolutely have to, this method is not recommended.

SDK Structure

The location of the SDK directories will depend on the location you choose during the installation, but the directories within there will always be the same:

/BIN – Copies of the minimum dll set from a QuickClip installation. /LIB – Libraries required to link the vvwNet2.dll, examples and your application /INC – Header files required to compile vvwNet2.dll, examples and your application /Src/vwwNet2 – The source to our vvwNet2.dll from QuickClip /Src/General – Useful source files that do not compile into examples directly. The most important would be vvwIF.cpp that is the code behind the SDK functions described below. /Sample – Broken down into sub directories based on access type o /ActiveX – Examples that use the ActiveX control o /Direct – Examples that link directly to DLLs o /Java – Java based examples o /HTTP – Ajax based examples (must use QuickClip HTTP server to run)

Main Documentation Links

PDF version of the MediaCmd Documentation http://www.drastictech.com/manuals/VVW%20Interface%20Specification.pdf

Online version of the MediaCmd Documentation http://www.drastictech.com/manuals/VVW%20Interface%20Specification.html

Low Level Header Documentation Links

Windows CHM help file version of the MediaCmd headers http://www.drastictech.com/manuals/MediaCmd.chm

Online version of the MediaCmd headers http://www.drastictech.com/manuals/mediacmd/

HTTP XML AJAX Documentation Links

Wikki area for HTTP XML MediaCmd http://www.drasticpreview.org/wakka.php?wakka=DrasticHttpCommands&v=d9c
Generated on Wed May 17 15:52:30 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: File Index

  • Related Pages
  • File List
  • Globals

MediaCmd File List

Here is a list of all files with brief descriptions:
mediacmd.h [code]
timecode.h [code]
vvw.h [code]
vvwtypes.h [code]
Generated on Wed May 17 15:52:30 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: mediacmd.h File Reference

  • File List
  • Globals

mediacmd.h File Reference

Go to the source code of this file.

Data Structures

struct | MEDIACMD
#define | GS_CLIPMODE_ILLEGAL 0xFFFFFFFF
Known file types.
#define | GS_CLIPMODE_CLIPSPACE 0
#define | GS_CLIPMODE_TCSPACE 1
#define | GS_CLIPMODE_SINGLE 2
#define | GS_CLIPMODE_FILM 3
enum cmdGetSetValue {
gsTc = 1, gsUb, gsLtcTc, gsLtcUb,
gsVitcTc, gsVitcUb, gsTcSource, gsTcType,
gsStart, gsEnd, gsIn, gsLastIn,
gsOut, gsLastOut, gsEditOn, gsEditOff,
gsPreroll, gsPostroll, gsAutoMode, gsPlayDelay,
gsLtcTcPreset, gsLtcUbPreset, gsVitcTcPreset, gsVitcUbPreset,
gsFrameData, gsGetNextClip = 90, gsFirstClip, gsNextClip,
gsTCSGetTLClipState, gsTCSGetTLClipInfo, gsClipInfo, gsClipCopy,
gsAudChan = 100, gsVidChan, gsInfChan, gsAudSelect,
gsVidSelect, gsInfSelect, gsAudEdit, gsVidEdit,
gsInfEdit, gsEditMode, gsMetaData = 150, gsMetaDataDirectory,
gsMetaDataVolume, gsMetaDataCurrentUser, gsMetaDataLocalMachine, gsMetaDataGlobal,
gsAudInSelect = 200, gsAudOutSelect, gsAudInputLevel, gsAudOutputLevel,
gsAudAdvanceLevel, gsAudOutPhase, gsAudOutAdvancePhase, gsAudCrossFadeTime,
gsAudLtcEnable, gsAudInLtcChannel, gsAudOutLtcChannel, gsAudDtmfEnable,
gsAudInDtmfChannel, gsAudOutDtmfChannel, gsAudWavePeakRMS, gsAudInputBitRate,
gsAudInputSampleRate, gsAudInputMode, gsAudInputHeadRoom, gsAudInputOriginal,
gsAudInputErrorProtect, gsAudInputCopyright, gsAudInputSlave, gsAudInputBass,
gsAudInputTreble, gsVidFreeze = 300, gsVidPreReadMode, gsVidEditField,
gsVidRecFrame, gsVidPlayFrame, gsVidNoEE, gsVidSuperimpose,
gsVidAnalogMonitorSDType, gsVidAnalogMonitorHDType, gsVidAnalogMonitorMethod, gsVidAnalogMonitorUpMode,
gsVidAnalogMonitorDownMode, gsVidInSelect = 400, gsVidInLockType, gsVidInSetup,
gsVidInVideo, gsVidInHue, gsVidInChroma, gsVidInUChroma,
gsVidInVChroma, gsVidInColorKiller, gsVidInAGC, gsVidInBandwidth,
gsVidInBlack, gsVidInWhite, gsVidInCoring, gsVidInPeaking,
gsVidInSharpness, gsVidInGamma, gsVidInSignalFormat, gsVidSetup = 500,
gsVidVideo, gsVidHue, gsVidChroma, gsVidUChroma,
gsVidVChroma, gsVidBandwidth, gsVidBlackSetup, gsVidColor,
gsVidOutSelect = 600, gsVidOutGenlock, gsVidOutGenlockSource, gsVidOutLockType,
gsVidOutHPhase, gsVidOutSubCarrier, gsVidOutCoring, gsVidOutPeaking,
gsVidOutAdjust1, gsVidOutAdjust2, gsVidOutGenlockDelay, gsVidOutLockSignalFormat,
gsCompChVerticalRes = 700, gsMpegVerticalRes = gsCompChVerticalRes, gsCompChHorizontalRes, gsMpegHorizontalRes = gsCompChHorizontalRes,
gsCompChChromaFormat, gsMpegChromaFormat = gsCompChChromaFormat, gsCompChDCPrecision, gsMpegDCPrecision = gsCompChDCPrecision,
gsCompChAspectRatio, gsMpegAspectRatio = gsCompChAspectRatio, gsCompChStandard, gsMpegStandard = gsCompChStandard,
gsCompChLanguageCode, gsMpegLanguageCode = gsCompChLanguageCode, gsCompChCCFormat, gsMpegCCFormat = gsCompChCCFormat,
gsCompChConcealmentVector, gsMpegConcealmentVector = gsCompChConcealmentVector, gsCompChClosedGop, gsMpegClosedGop = gsCompChClosedGop,
gsCompChAdjustGopTC, gsMpegAdjustGopTC = gsCompChAdjustGopTC, gsCompChAltCoEffTable, gsMpegAltCoEffTable = gsCompChAltCoEffTable,
gsCompChNonLinearQuant, gsMpegNonLinearQuant = gsCompChNonLinearQuant, gsCompChMuxRate, gsMpegMuxRate = gsCompChMuxRate,
gsCompChAudPacketSize, gsMpegAudPacketSize = gsCompChAudPacketSize, gsCompChVidPacketSize, gsMpegVidPacketSize = gsCompChVidPacketSize,
gsCompChAudioStreamID, gsMpegAudioStreamID = gsCompChAudioStreamID, gsCompChVideoStreamID, gsMpegVideoStreamID = gsCompChVideoStreamID,
gsCompChAudioStreamPID, gsMpegAudioStreamPID = gsCompChAudioStreamPID, gsCompChVideoStreamPID, gsMpegVideoStreamPID = gsCompChVideoStreamPID,
gsCompChAllowSettings, gsMpegAllowSettings = gsCompChAllowSettings, gsCompChFourCC, gsCompChBitCount,
gsCompChSizeImage, gsCompChRate, gsCompChScale, gsCompChPitch,
gsVideoEncodeFormat, gsAudioEncodeFormat, gsCompChannelChangeMs, gsAlphaChromaSource,
gsCompressionType, gsVideoStandard, gsResetChannel, gsEnableHDSDFormat,
gsVBlankEnable, gsLUTEnable, gsSignalFormat = 900, gsCompType,
gsCompRateSize, gsCompRateRatio, gsCompRatePercent, gsCompGOPSize,
gsCompIFactor, gsCompBFactor, gsCompPFactor, gsCompRefPeriod,
gsTotalStorageAvail, gsTotalStorageFree, gsTotalTimeAvail, gsTotalTimeFree,
gsVtrType, gsLocal = 1000, gsSupportedFileTypes, gsIgnoreFileTypes,
gsRecInhibit, gsRecDrive, gsRecFileName, gsRecRate,
gsRecFileFormat, gsRecAudFileFormat, gsDelInhibit, gsInsInhibit,
gsConvertFileFormat, gsConvertAudFileFormat, gsDefStillLen, gsSysTime,
gsDSyncMs, gsHwPort, gsPBEE, gsServoRefSelect,
gsHeadSelect, gsColorFrame, gsVidRefDisable, gsPlayCountDelay,
gsEmulateEditBumping, cmdaltNearestKeyFrame, cmdaltNextKeyFrame, cmdaltPrevKeyFrame,
cmdaltStartOfMessage, gsVidInputValid, gsVidGenlockValid, gsErrorLog = 10000,
gsErrorLogName, gsErrorLogStartMs, gsErrorLogCurrentMs, gsErrorLogLastChange,
gsErrorLogMessage, gsSysBufferLevel = 20000, gsSysMemoryUsage, gsSysCPUUsage,
gsProxyMode = 50000, gsProxyStatus, gsGetNextProxy, gsAddProxy,
gsPromoteProxy, gsRemoveProxy, gsProxyCPUUsage, gsVVWVersion = 60000,
gsMEVersion, gsVVWType, gsVVWChannelType, gsVVWChannelName,
gsMonitor = 64000, gsMonitorHwnds, gsHwnds = gsMonitorHwnds, gsMonitorDisplay,
gsMonitorGrab, gsDirGetList = 64250, gsDirGetInfo, gsDirGetFileInfo,
gsDirGetFileGrab, gsChannelsExist = 65536, gsClipMode, gsRecOffset,
gsChanCapabilities, gsLastChangeMs, gsGPIIn, gsGPIOut,
gsCurrentMs, gsSaveCurrent = 100000, gsLoadClipSpace, gsLoadTCSpace,
gsLoadFilmSpace, gsUserLogIn = 900000, gsUserLastChangeMs, gsUserList,
gsUserAdd, gsUserDel, gsUserRights, gsUserPasswd,
gsPiconFrame = 1000000, gsJpegFrame, gsImageDirectory, gsVVWService = 1100000,
gsInsertQueue, gsXlatQueue
}
#define | GS_USERRIGHTS_NONE 0x0000
#define | GS_USERRIGHTS_READ 0x0001
#define | GS_USERRIGHTS_MODIFY 0x0002
#define | GS_USERRIGHTS_WRITE 0x0004
#define | GS_USERRIGHTS_SETUP 0x0008
#define | GS_USERRIGHTS_PLAY 0x0010
#define | GS_USERRIGHTS_RECORD 0x0020
#define | GS_USERRIGHTS_ADD 0x0100
#define | GS_USERRIGHTS_DELETE 0x0200
#define | GS_USERRIGHTS_FULL 0x7FFF
#define | GS_USERRIGHTS_ADMIN 0x8000
#define | GS_SUPFILE_AVI 0x00000001
#define | GS_SUPFILE_ODML 0x00000002
#define | GS_SUPFILE_QT 0x00000004
#define | GS_SUPFILE_OMFI 0x00000008
#define | GS_SUPFILE_FIX 0x00000100
#define | GS_SUPFILE_AUDONLY 0x00010000
#define | GS_SUPFILE_STILLS 0x00100000
#define | GS_SUPFILE_UNK 0x40000000
#define | GS_SUPFILE_ANY 0x80000000
enum cmdVidChan {
vidChan0 = 1, vidChan1 = 1 << 1, vidChan2 = 1 << 2, vidChan3 = 1 << 3,
vidChan4 = 1 << 4, vidChan5 = 1 << 5, vidChan6 = 1 << 6, vidChan7 = 1 << 7,
vidChan8 = 1 << 8, vidChan9 = 1 << 9, vidChan10 = 1 << 10, vidChan11 = 1 << 11,
vidChan12 = 1 << 12, vidChan13 = 1 << 13, vidChan14 = 1 << 14, vidChan15 = 1 << 15,
vidChan16 = 1 << 16, vidChan17 = 1 << 17, vidChan18 = 1 << 18, vidChan19 = 1 << 19,
vidChan20 = 1 << 20, vidChan21 = 1 << 21, vidChan22 = 1 << 22, vidChan23 = 1 << 23,
vidChan24 = 1 << 24, vidChan25 = 1 << 25, vidChan26 = 1 << 26, vidChan27 = 1 << 27,
vidChan28 = 1 << 28, vidChan29 = 1 << 29, vidChan30 = 1 << 30, vidChan31 = 1UL << 31UL,
vidChanAll
}
enum cmdAudChan {
audChan0 = 1, audChan1 = 1 << 1, audChan2 = 1 << 2, audChan3 = 1 << 3,
audChan4 = 1 << 4, audChan5 = 1 << 5, audChan6 = 1 << 6, audChan7 = 1 << 7,
audChan8 = 1 << 8, audChan9 = 1 << 9, audChan10 = 1 << 10, audChan11 = 1 << 11,
audChan12 = 1 << 12, audChan13 = 1 << 13, audChan14 = 1 << 14, audChan15 = 1 << 15,
audChan16 = 1 << 16, audChan17 = 1 << 17, audChan18 = 1 << 18, audChan19 = 1 << 19,
audChan20 = 1 << 20, audChan21 = 1 << 21, audChan22 = 1 << 22, audChan23 = 1 << 23,
audChan24 = 1 << 24, audChan25 = 1 << 25, audChan26 = 1 << 26, audChan27 = 1 << 27,
audChan28 = 1 << 28, audChan29 = 1 << 29, audChan30 = 1 << 30, audChan31 = 1UL << 31UL,
audChanAll
}

Defines

#define | MEDIACMD_VERSION_MAJOR 0x0101UL
Major command versioning for upgrades to the command set. see MEDIACMD::dwCmdID.
#define | MEDIACMD_VERSION_MINOR 0x0003UL
Minor command versioning for upgrades to the command set. see MEDIACMD::dwCmdID.
#define | MEDIACMD_VERSION_MASK 0xFFFFUL
Mask for checking the command set version. see MEDIACMD::dwCmdID.
#define | MEDIACMD_CHECK_VER 0xFA250000UL
Permanent magic number of command id. see MEDIACMD::dwCmdID.
#define | MEDIACMD_CHECK_MASK 0xFFFF0000UL
Mask for permanent magic number of command id. see MEDIACMD::dwCmdID.
#define | MEDIACMD_CURRENT (MEDIACMD_VERSION_MAJOR | MEDIACMD_VERSION_MINOR | MEDIACMD_CHECK_VER)
Current version and magic number. Place in MEDIACMD::dwCmdID.
#define | SPD_FWD_PLAY 65520L
Forward play speed (normal) in VVW (65520) see MEDIACMD::lSpeed.
#define | SPD_PAUSE 0L
Pause speed (0%) in VVW (0) see MEDIACMD::lSpeed.
#define | SPD_REV_PLAY (-SPD_FWD_PLAY)
Reverse play speed (-100%) in VVW (-65520) see MEDIACMD::lSpeed.
#define | SPD_FWD_MAX 5896800
Maximum possible play speed in VVW see MEDIACMD::lSpeed.
#define | SPD_REV_MAX (-SPD_FWD_MAX)
Minimum possible play speed in VVW see MEDIACMD::lSpeed.
#define | SPD_FAST_BUMP 114660L
MAx speed for bumping.
#define | SPD_SLOW_BUMP 32760l
Min Sped for buimping.
#define | SPD_ILLEGAL 2147483647L
Illegal speed, set MEDIACMD::lSpeed to this value if not used.
#define | TC_ILLEGAL 0xFFFFFFFFUL
Illegal time code reference, set MEDIACMD::dwPosition, MEDIACMD::dwStart, MEDIACMD::dwEnd to this if not used.
#define | CHAN_ILLEGAL 0xFFFFFFFFUL
Illegal channel, or All Channels. Set MEDIACMD::dwAudioChannels, MEDIACMD::dwVideoChannels, MEDIACMD::dwInfoChannels to this if not used.
#define | CMD_MAX_CLIP_ID_LEN (260+8)
#define | vidChanAll 0xFFFFFFFF
#define | audChanAll 0xFFFFFFFF
#define | infChanAll 0xFFFFFFFF
#define | GS_TCSOURCE_LTC 1
For cmdGetSetValue::gsTcSource - Using LTC.
#define | GS_TCSOURCE_VITC 2
For cmdGetSetValue::gsTcSource - Using VITC.
#define | GS_TCSOURCE_CTL 4
For cmdGetSetValue::gsTcSource - Using CTL.
#define | GS_TCSOURCE_CLIP 7
For cmdGetSetValue::gsTcSource - Using absolute clip.
#define | GS_FRAMEDATA_UNKNOWN 0x00000
No data, unknown data for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.
#define | GS_FRAMEDATA_ASCII 0x00001
Ascii data (all printable) for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.
#define | GS_FRAMEDATA_HEX 0x00002
Binary (hex) data for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.
#define | GS_FRAMEDATA_TELECINE 0x10001
Telecine RP-215 / DPX Data for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.
#define | GS_FRAMEDATA_CC_TTEXT 0x10002
Close caption/teletext for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.
#define | GS_FRAMEDATA_NAVY 0x10003
Navy telemtry data for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.
#define | GS_INSERT_EDIT 0x01
Set cmdGetSetValue::gsEditMode for an insert edit.
#define | GS_ASSEMBLE_EDIT 0x02
Set cmdGetSetValue::gsEditMode for an assemble edit.
#define | GS_AUDSELECT_UNBALANCED_10 0x001
Audio in/out unbalanced (RCA connector) high impedence at -10db (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_UNBALANCED_4 0x002
Audio in/out unbalanced (RCA connector) high impedence at -4db (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_BALANCED_10 0x010
Audio in/out balanced (XLR connector) 600ohm impedence at -10db (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_BALANCED_4 0x020
Audio in/out balanced (XLR connector) 600ohm impedence at +4db (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_SPDIF 0x100
Audio in/out digital single wire (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_AES_EBU 0x200
Audio in/out digital balanced with clock (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_EMBEDDED 0x400
Audio in/out embedded in SDI or HD-SDI video signal (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_AES_EBU_PRO 0x800
Audio in/out digital balanced with clock (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_NONE 0
No audio in/out available, or cannot be configured (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).
#define | GS_AUDSELECT_SILENT 0x040
No Audio Selected leave silent.
#define | GS_AUD_BIT_RATE_32000 0x0001
#define | GS_AUD_BIT_RATE_41100 0x0002
#define | GS_AUD_BIT_RATE_48000 0x0004
#define | GS_AUD_BIT_RATE_56000 0x0008
#define | GS_AUD_BIT_RATE_64000 0x0010
#define | GS_AUD_BIT_RATE_80000 0x0020
#define | GS_AUD_BIT_RATE_96000 0x0040
#define | GS_AUD_BIT_RATE_112000 0x0080
#define | GS_AUD_BIT_RATE_128000 0x0100
#define | GS_AUD_BIT_RATE_160000 0x0200
#define | GS_AUD_BIT_RATE_192000 0x0400
#define | GS_AUD_BIT_RATE_224000 0x0800
#define | GS_AUD_BIT_RATE_256000 0x1000
#define | GS_AUD_BIT_RATE_320000 0x2000
#define | GS_AUD_BIT_RATE_384000 0x4000
#define | GS_AUD_STEREO 0x001
#define | GS_AUD_JOINT_STEREO 0x002
#define | GS_AUD_DUAL 0x004
#define | GS_AUD_SINGLE 0x008
#define | GS_AUD_MULTIPLE 0x010
#define | GS_AUD_HEADROOM_18 0x01
#define | GS_AUD_HEADROOM_20 0x02
#define | GS_VIDFREEZE_NOT_FROZEN 0
Freeze - no freeze (cmdGetSetValue::gsVidFreeze).
#define | GS_VIDFREEZE_FIELD0 1
Freeze - first (0) field (cmdGetSetValue::gsVidFreeze).
#define | GS_VIDFREEZE_FIELD1 2
Freeze - second (1) field (cmdGetSetValue::gsVidFreeze).
#define | GS_VIDFREEZE_FRAME 3
Freeze - both fields (cmdGetSetValue::gsVidFreeze).
#define | GS_VIDSELECT_COMPOSITE 0x001
Standard NTSC or PAL composite video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_SVIDEO 0x002
SVHS/S-Video four wire NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPOSITE_2 0x004
Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPOSITE_3 0x008
third NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect)
#define | GS_VIDSELECT_COMPONENT_YUV 0x010
BetaCam level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPONENT_YUV_M2 0x020
Panasonic M2 level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPONENT_YUV_SMPTE 0x040
SMPTE standard level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPONENT_RGB 0x080
RGB at video standard rate (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_D1_SERIAL 0x100
D1 Serial Digital or HDSDI video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_D1_PARALLEL 0x200
D1 Serial Parallel video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_SDTI 0x400
SDTI/SDI including high speed transfer video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPOSITE_4 0x800
#define | GS_VIDSELECT_SVIDEO_2 0x1000
Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPONENT_YUV_2 0x2000
Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_D1_SERIAL_2 0x4000
Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPOSITE_JAPAN 0x8000
Standard NTSC or PAL composite video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_SVIDEO_JAPAN 0x10000
SVHS/S-Video four wire NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPONENT_YUV_JAPAN 0x20000
BetaCam level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_COMPONENT_YUV_SMPTE_JAPAN 0x40000
SMPTE standard level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDSELECT_XVID_RGB 0x80000
xVGA compatible analog RGB
#define | GS_VIDSELECT_NONE 0
No video available or no configuratable settings (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).
#define | GS_VIDLOCKTYPE_VTR 1
VTR (unruly hsync) lock for cmdGetSetValue::gsVidInLockType cmdGetSetValue::gsVidOutLockType cmdGetSetValue::gsVidOutLockType.
#define | GS_VIDLOCKTYPE_BROADCAST 2
Perfect lock for cmdGetSetValue::gsVidInLockType cmdGetSetValue::gsVidOutLockType cmdGetSetValue::gsVidOutLockType.
#define | GS_VIDBAND_STANDARD 0x01
Allow normal bandwidth (gsGetSetValue::gsVidInBandwidth gsGetSetValue::gsVidBandwidth).
#define | GS_VIDBAND_MEDIUM 0x02
Allow medium bandwidth (gsGetSetValue::gsVidInBandwidth gsGetSetValue::gsVidBandwidth).
#define | GS_VIDBAND_HIGH 0x04
Allow high bandwidth (gsGetSetValue::gsVidInBandwidth gsGetSetValue::gsVidBandwidth).
#define | GS_VIDBAND_NOTCH 0x08
Impose notch filter on bandwidth (gsGetSetValue::gsVidInBandwidth gsGetSetValue::gsVidBandwidth).
#define | GS_VIDBLACK_SETUP 0x01
Black at normal level (7.5 IRE NTSC, 0 IRE PAL) gsGetSetValue::gsVidBlackSetup gsGetSetValue::gsVidInBlack.
#define | GS_VIDBLACK_CRYSTAL 0x02
Crystal black level (0 IRE NTSC, 0 IRE PAL) gsGetSetValue::gsVidBlackSetup gsGetSetValue::gsVidInBlack.
#define | GS_VIDBLACK_SUPER 0x04
Super black level (0 > IRE NTSC/PAL) gsGetSetValue::gsVidBlackSetup gsGetSetValue::gsVidInBlack.
#define | GS_VIDWHITE_CLAMP 0x01
Whites are clamped or 100 IRE (gsGetSetValue::gsVidInWhite).
#define | GS_VIDWHITE_SCALE 0x02
Whites are scaled automatically from black level to 100 IRE (gsGetSetValue::gsVidInWhite).
#define | GS_VIDWHITE_FREE 0x04
Whites are allowed to be greater then 100 IRE (gsGetSetValue::gsVidInWhite).
#define | GS_LOCKSRC_NONE 0x0001
No external genlock source (free running on internal clock) (gsGetSetValue::gsVidOutGenlockSource).
#define | GS_LOCKSRC_EXTIN 0x0002
External ref in is genlock source (gsGetSetValue::gsVidOutGenlockSource).
#define | GS_LOCKSRC_INPUT 0x0004
Current input is genlock source (gsGetSetValue::gsVidOutGenlockSource).
#define | GS_LOCKSRC_CVBS 0x0008
Composite (CVBS) input is genlock source (gsGetSetValue::gsVidOutGenlockSource).
#define | GS_LOCKSRC_SVIDEO 0x0010
S-Video (SVHS) input is genlock source (gsGetSetValue::gsVidOutGenlockSource).
#define | GS_LOCKSRC_IN_Y 0x0020
Component Y input is genlock source (gsGetSetValue::gsVidOutGenlockSource).
#define | GS_LOCKSRC_SDI 0x0040
SDI serial digital input is genlock source (gsGetSetValue::gsVidOutGenlockSource).
#define | GS_ANALOGMONITORMETHOD_DIRECT 0x0000
Keep analog monitor in line with digital (hd=hd, sd=sd).
#define | GS_ANALOGMONITORMETHOD_SD 0x0001
Convert everything to the nearest SD type.
#define | GS_ANALOGMONITORMETHOD_HD720 0x0002
Convert everything to the nearest 720 HD type.
#define | GS_ANALOGMONITORMETHOD_HD1080 0x0003
Convert everything to the nearest 1080 HD type.
#define | GS_ANALOGMONITORMETHOD_FLIP720 0x0004
SD->HD720 and HD->SD.
#define | GS_ANALOGMONITORMETHOD_FLIP1080 0x0005
SD->HD720 and HD->SD.
#define | GS_UPCONVERT_ANAMORPHIC 0x0000
Upconvert to whole screen.
#define | GS_UPCONVERT_PILLARBOX 0x0001
Upconvert with bars.
#define | GS_UPCONVERT_ZOOM14x9 0x0002
Upconvert with some zoom.
#define | GS_UPCONVERT_LETTERBOX 0x0004
Upconvert to letter box.
#define | GS_UPCONVERT_ZOOMWIDE 0x0005
Upconvert to wide zoom.
#define | GS_DOWNCONVERT_LETTERBOX 0x0000
Down convert with top/bottom black bars.
#define | GS_DOWNCONVERT_CROP 0x0001
Down convert and crop image.
#define | GS_DOWNCONVERT_ANAMORPHIC 0x0002
Down convert to whole screen.
#define | GS_MPEG_RESOLUTION_120 0x001
Standard MPEG resolution 120x60.
#define | GS_MPEG_RESOLUTION_240 0x002
#define | GS_MPEG_RESOLUTION_288 0x004
#define | GS_MPEG_RESOLUTION_352 0x008
#define | GS_MPEG_RESOLUTION_480 0x010
#define | GS_MPEG_RESOLUTION_512 0x020
#define | GS_MPEG_RESOLUTION_544 0x040
#define | GS_MPEG_RESOLUTION_576 0x080
#define | GS_MPEG_RESOLUTION_608 0x100
#define | GS_MPEG_RESOLUTION_704 0x200
#define | GS_MPEG_RESOLUTION_720 0x400
#define | GS_CHROMA_FORMAT_420 0x1
#define | GS_CHROMA_FORMAT_422 0x2
#define | GS_CHROMA_FORMAT_444 0x4
#define | GS_CHROMA_FORMAT_411 0x8
#define | GS_MPEG_CHROMA_FORMAT_420 GS_CHROMA_FORMAT_420
#define | GS_MPEG_CHROMA_FORMAT_422 GS_CHROMA_FORMAT_422
#define | GS_MPEG_CHROMA_FORMAT_444 GS_CHROMA_FORMAT_444
#define | GS_MPEG_DC_PRECISION_8 0x1
#define | GS_MPEG_DC_PRECISION_9 0x2
#define | GS_MPEG_DC_PRECISION_10 0x4
#define | GS_MPEG_DC_PRECISION_11 0x8
#define | GS_ASPECT_RATIO_SQUARE 0x1
#define | GS_ASPECT_RATIO_4x3 0x2
#define | GS_ASPECT_RATIO_16x9 0x4
#define | GS_ASPECT_RATIO_2_21x1 0x8
#define | GS_MPEG_ASPECT_RATIO_SQUARE GS_ASPECT_RATIO_SQUARE
#define | GS_MPEG_ASPECT_RATIO_4x3 GS_ASPECT_RATIO_4x3
#define | GS_MPEG_ASPECT_RATIO_16x9 GS_ASPECT_RATIO_16x9
#define | GS_MPEG_ASPECT_RATIO_2_21x1 GS_ASPECT_RATIO_2_21x1
#define | GS_MPEG_STANDARD_SYSTEM 0x1
#define | GS_MPEG_STANDARD_PROGRAM 0x2
#define | GS_MPEG_STANDARD_TRANSPORT 0x4
#define | GS_MPEG_STANDARD_ELEMENTARY 0x8
#define | GS_MPEG_STANDARD_ELEMENTRY GS_MPEG_STANDARD_ELEMENTARY
#define | GS_MPEG_LANGAUGE_ENGLISH 0x0001
#define | GS_MPEG_LANGAUGE_SPANISH 0x0002
#define | GS_MPEG_LANGAUGE_FRENCH 0x0004
#define | GS_MPEG_LANGAUGE_GERMAN 0x0008
#define | GS_MPEG_LANGAUGE_JAPANESE 0x0010
#define | GS_MPEG_LANGAUGE_DUTCH 0x0020
#define | GS_MPEG_LANGAUGE_DANISH 0x0040
#define | GS_MPEG_LANGAUGE_FINNISH 0x0080
#define | GS_MPEG_LANGAUGE_ITALIAN 0x0100
#define | GS_MPEG_LANGAUGE_GREEK 0x0200
#define | GS_MPEG_LANGAUGE_PORTUGUESE 0x0400
#define | GS_MPEG_LANGAUGE_SWEDISH 0x0800
#define | GS_MPEG_LANGAUGE_RUSSIAN 0x1000
#define | GS_MPEG_LANGAUGE_CHINESE 0x2000
#define | GS_MPEG_CC_FORMAT_CCUBE 0x1
#define | GS_MPEG_CC_FORMAT_ATSC 0x2
#define | GS_MPEG_CC_FORMAT_CCUBE_REORDER 0x4
#define | GS_MPEG_CC_FORMAT_ATSC_REORDER 0x8
#define | GS_MPEG_ONE_FRAMES 0x0001
#define | GS_MPEG_TWO_FRAMES 0x0002
#define | GS_MPEG_THREE_FRAMES 0x0004
#define | GS_MPEG_FOUR_FRAMES 0x0008
#define | GS_MPEG_FIVE_FRAMES 0x0010
#define | GS_MPEG_SIX_FRAMES 0x0020
#define | GS_MPEG_SEVEN_FRAMES 0x0040
#define | GS_MPEG_EIGHT_FRAMES 0x0080
#define | GS_MPEG_NINE_FRAMES 0x0100
#define | GS_MPEG_TEN_FRAMES 0x0200
#define | GS_MPEG_ELEVEN_FRAMES 0x0400
#define | GS_MPEG_TWELVE_FRAMES 0x0800
#define | GS_MPEG_THIRTEEN_FRAMES 0x1000
#define | GS_MPEG_FOURTEEN_FRAMES 0x2000
#define | GS_MPEG_FIFTEEN_FRAMES 0x4000
#define | GS_MPEG_SIXTEEN_FRAMES 0x8000
#define | VIDEOWRITETYPE_AVI 0x00000001
#define | VIDEOWRITETYPE_MOV 0x00000002
#define | VIDEOWRITETYPE_WMV 0x00000004
#define | VIDEOWRITETYPE_GEN 0x00000008
#define | VIDEOWRITETYPE_JS 0x00000010
#define | VIDEOWRITETYPE_DVS 0x00000020
#define | VIDEOWRITETYPE_IHSS 0x00000040
#define | VIDEOWRITETYPE_HDR 0x00000080
#define | VIDEOWRITETYPE_YUV 0x00000100
#define | VIDEOWRITETYPE_RAW 0x00000200
#define | VIDEOWRITETYPE_TGA 0x00000400
#define | VIDEOWRITETYPE_BMP 0x00000800
#define | VIDEOWRITETYPE_TIFF 0x00001000
#define | VIDEOWRITETYPE_CIN 0x00002000
#define | VIDEOWRITETYPE_DPX 0x00004000
#define | VIDEOWRITETYPE_MPG 0x00008000
#define | VIDEOWRITETYPE_4224 0x00010000
#define | GS_MONITORGRAB_NONE 0x0000
Turn off monitor.
#define | GS_MONITORGRAB_TYPE_MASK 0x00F0
Type mask (jpg, bmp).
#define | GS_MONITORGRAB_TYPE_BMP 0x0000
Use BMP format for image.
#define | GS_MONITORGRAB_TYPE_JPG 0x0010
Use JPEG format for image.
#define | GS_MONITORGRAB_SIZE_MASK 0x000F
Size mask (full, half, quarter).
#define | GS_MONITORGRAB_SIZE_FULL 0x0001
Full size image captured.
#define | GS_MONITORGRAB_SIZE_HALF 0x0002
Half size image captured.
#define | GS_MONITORGRAB_SIZE_QUARTER 0x0004
Quarter size image captured.
#define | GS_MONITORGRAB_TARGET_MASK 0x0F00
Target/To mask.
#define | GS_MONITORGRAB_TO_MEMORY 0x0100
Use the arbID area.
#define | GS_MONITORGRAB_TO_UNC_PATH 0x0200
Save image to a UNC path.
#define | GS_MONITORGRAB_TO_HTTP 0x0400
Save image to web server (use name sent in arbID).
#define | GS_MONITORGRAB_TO_NETWORK 0x0800
Save image through 'to be announced' network transport.
#define | GS_SIGFORMMASK_FRAMERATE 0x000001ff
Frame rate mask (portion of return for frame rate).
#define | GS_SIGFORMSHIFT_FRAMERATE 0
Shift frame rate to 0.
#define | GS_SIGFORMMASK_HORIZONTAL 0x000ffe00
Horizontal / 8 mask (portion of return for frame rate).
#define | GS_SIGFORMSHIFT_HORIZONTAL 9
Horizontal / 8 shift to 0.
#define | GS_SIGFORMMASK_VERTICAL 0x0ff00000
Vertical / 8 mask (portion of return for frame rate).
#define | GS_SIGFORMSHIFT_VERTICAL 20
Vertical / 8 shift to 0.
#define | GS_SIGFORMMASK_FRAMETYPE 0xF0000000
Frame type mask (portion of return for frame rate).
#define | GS_SIGFORMSHIFT_FRAMETYPE 28
Frame type shift to 0.
#define | GS_SIGFORMFRAMERATE_5 5
#define | GS_SIGFORMFRAMERATE_6 6
#define | GS_SIGFORMFRAMERATE_7_5 7
#define | GS_SIGFORMFRAMERATE_10 10
#define | GS_SIGFORMFRAMERATE_14_98 14
#define | GS_SIGFORMFRAMERATE_15 15
#define | GS_SIGFORMFRAMERATE_23_98 23
#define | GS_SIGFORMFRAMERATE_24 24
#define | GS_SIGFORMFRAMERATE_25 25
#define | GS_SIGFORMFRAMERATE_29_97 29
#define | GS_SIGFORMFRAMERATE_30 30
#define | GS_SIGFORMFRAMERATE_47_95 47
#define | GS_SIGFORMFRAMERATE_48 48
#define | GS_SIGFORMFRAMERATE_50 50
#define | GS_SIGFORMFRAMERATE_59_94 59
#define | GS_SIGFORMFRAMERATE_60 60
#define | GS_SIGFORMFRAMERATE_71_93 71
#define | GS_SIGFORMFRAMERATE_72 72
#define | GS_SIGFORMFRAMERATE_100 100
#define | GS_SIGFORMFRAMERATE_119_88 119
#define | GS_SIGFORMFRAMERATE_CUSTOM 0x100
#define | GS_SIGFORMSIZE_240 0x01
#define | GS_SIGFORMSIZE_243 0x02
#define | GS_SIGFORMSIZE_288 0x03
#define | GS_SIGFORMSIZE_320 0x08
#define | GS_SIGFORMSIZE_352 0x09
#define | GS_SIGFORMSIZE_360 0x0a
#define | GS_SIGFORMSIZE_480 0x10
#define | GS_SIGFORMSIZE_483 0x11
#define | GS_SIGFORMSIZE_486 0x12
#define | GS_SIGFORMSIZE_496 0x14
#define | GS_SIGFORMSIZE_504 0x16
#define | GS_SIGFORMSIZE_512 0x17
#define | GS_SIGFORMSIZE_576 0x1a
#define | GS_SIGFORMSIZE_600 0x1b
#define | GS_SIGFORMSIZE_608 0x1c
#define | GS_SIGFORMSIZE_640 0x20
#define | GS_SIGFORMSIZE_720 0x21
#define | GS_SIGFORMSIZE_768 0x22
#define | GS_SIGFORMSIZE_800 0x23
#define | GS_SIGFORMSIZE_864 0x24
#define | GS_SIGFORMSIZE_988 0x25
#define | GS_SIGFORMSIZE_857 0x26
#define | GS_SIGFORMSIZE_960 0x28
#define | GS_SIGFORMSIZE_968 0x29
#define | GS_SIGFORMSIZE_778 0x2A
#define | GS_SIGFORMSIZE_872 0x2B
#define | GS_SIGFORMSIZE_1024 0x30
#define | GS_SIGFORMSIZE_1035 0x31
#define | GS_SIGFORMSIZE_1044 0x32
#define | GS_SIGFORMSIZE_1052 0x33
#define | GS_SIGFORMSIZE_1050 0x34
#define | GS_SIGFORMSIZE_1080 0x38
#define | GS_SIGFORMSIZE_1088 0x39
#define | GS_SIGFORMSIZE_1096 0x3a
#define | GS_SIGFORMSIZE_1102 0x3E
#define | GS_SIGFORMSIZE_1152 0x40
#define | GS_SIGFORMSIZE_1200 0x41
#define | GS_SIGFORMSIZE_1234 0x43
#define | GS_SIGFORMSIZE_1280 0x48
#define | GS_SIGFORMSIZE_1332 0x49
#define | GS_SIGFORMSIZE_1400 0x4B
#define | GS_SIGFORMSIZE_1440 0x4C
#define | GS_SIGFORMSIZE_1536 0x50
#define | GS_SIGFORMSIZE_1556 0x51
#define | GS_SIGFORMSIZE_1588 0x52
#define | GS_SIGFORMSIZE_1828 0x56
#define | GS_SIGFORMSIZE_1714 0x57
#define | GS_SIGFORMSIZE_1600 0x58
#define | GS_SIGFORMSIZE_1920 0x59
#define | GS_SIGFORMSIZE_2048 0x60
#define | GS_SIGFORMSIZE_2650 0x68
#define | GS_SIGFORMSIZE_3112 0x6b
#define | GS_SIGFORMSIZE_4096 0x80
#define | GS_SIGFORMSIZE_640x480 ((GS_SIGFORMSIZE_640 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_480 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_640x576 ((GS_SIGFORMSIZE_640 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_720x480 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_480 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_720x483 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_483 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_720x486 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_486 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_720x512 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_512 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_720x576 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_720x608 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_608 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_720x504 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_504 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_800x600 ((GS_SIGFORMSIZE_800 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_600 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_960x486 ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_486 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_960x576 ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_960x504 ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_504 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1024x768 ((GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_768 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1024x1024 ((GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1152x864 ((GS_SIGFORMSIZE_1152 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_864 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1280x1024 ((GS_SIGFORMSIZE_1280 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1400x1050 ((GS_SIGFORMSIZE_1400 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1050 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1600x1200 ((GS_SIGFORMSIZE_1600 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1200 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1280x720 ((GS_SIGFORMSIZE_1280 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1828x778 ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_778 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1828x988 ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_988 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1828x1102 ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1102 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1828x1332 ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1332 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1920x1035 ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1035 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1920x1080 ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_1920x1088 ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1088 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_2560x1080 ((GS_SIGFORMSIZE_2650 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_2048x857 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_857 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_2048x872 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_872 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_2048x1102 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1102 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_2048x1234 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1234 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_2048x1080 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_2048x1536 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1536 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_2048x1556 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1556 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_4096x1714 ((GS_SIGFORMSIZE_4096 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1714 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMSIZE_4096x3112 ((GS_SIGFORMSIZE_4096 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_3112 << GS_SIGFORMSHIFT_VERTICAL))
#define | GS_SIGFORMTYPE_UNKNOWN (0)
#define | GS_SIGFORMTYPE_INTERLACED (1 << GS_SIGFORMSHIFT_FRAMETYPE)
#define | GS_SIGFORMTYPE_PROGRESSIVE (2 << GS_SIGFORMSHIFT_FRAMETYPE)
#define | GS_SIGFORMTYPE_SEGMENTEDFRAME (4 << GS_SIGFORMSHIFT_FRAMETYPE)
#define | GS_SIGFORM_NTSC (GS_SIGFORMSIZE_640x480 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
Signal format NTSC square pixel (320x240 or 640x480) @ 29.97 or 30 fps gsGetSetValue::gsSignalFormat.
#define | GS_SIGFORM_PAL (GS_SIGFORMSIZE_640x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)
Signal format PAL square pixel (320x288 or 640x576) @ 25 fps gsGetSetValue::gsSignalFormat.
#define | GS_SIGFORM_CCIR_NTSC (GS_SIGFORMSIZE_720x486 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
Signal format NTSC square pixel (360/352x243/240 or 720/704x486/480) @ 29.97 or 30 fps gsGetSetValue::gsSignalFormat.
#define | GS_SIGFORM_CCIR_NTSC_P483 (GS_SIGFORMSIZE_720x483 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)
Signal format NTSC square pixel (360/352x243/240 or 720/704x486/480) @ 29.97 or 30 fps gsGetSetValue::gsSignalFormat.
#define | GS_SIGFORM_CCIR_PAL (GS_SIGFORMSIZE_720x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)
Signal format PAL square pixel (360/352x288 or 720/704x576) @ 25 fps gsGetSetValue::gsSignalFormat.
#define | GS_SIGFORM_CCIR_PNTSC_30 (GS_SIGFORMSIZE_720x486 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)
Signal format NTSC at 30 hz Progressive.
#define | GS_SIGFORM_CCIR_PPAL_25 (GS_SIGFORMSIZE_720x576 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)
Signal format PAL at 25 hz Progressive.
#define | GS_SIGFORM_HD360 (GS_SIGFORMSIZE_960x504 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
Signal format compressed HD 960x504 29.97.
#define | GS_SIGFORM_ALT_NTSC (GS_SIGFORMSIZE_960x486 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
Signal format NTSC High Res (960x486).
#define | GS_SIGFORM_ALT_PAL (GS_SIGFORMSIZE_960x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)
Signal format PAL High Res (960x576).
#define | GS_SIGFORM_1035i_30_260M (GS_SIGFORMSIZE_1920x1035 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)
2200x1125 raster, 1920x1035 production aperture (1888x1017 clean) @ 30 fps gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1035i_30X_260M (GS_SIGFORMSIZE_1920x1035 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
2200x1125 raster, 1920x1035 production aperture (1888x1017 clean) @ 29.97 fp gsGetSetValue::gsSignalFormats
#define | GS_SIGFORM_1080i_30 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)
1920x1080i (274M-1997 Table1 System 4) @ 29.97 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080i_30X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
1920x1080i (274M-1997 Table1 System 4) @ 30 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080i_25 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)
1920x1080i (274M-1997 Table1 System 4) @ 25 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080sf_24 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)
1920x1080sf (274M-1997 Table1 System 4) @ 24 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080i_24 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_1080sf_24X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)
1920x1080sf (274M-1997 Table1 System 4) @ 23.98 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080i_24X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_1080_30 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)
1920x1080P (274M-1997 Table1 System 4) @ 30 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080_30X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)
1920x1080P (274M-1997 Table1 System 4) @ 29.97 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080_25 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)
1920x1080P (274M-1997 Table1 System 4) @ 25 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080_24 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
1920x1080P (274M-1997 Table1 System 4) @ 24 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080_24X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
1920x1080P (274M-1997 Table1 System 4) @ 23.98 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_1080_60 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_60)
1920x1080P 60 (Dual P30)
#define | GS_SIGFORM_1080_60X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_59_94)
1920x1080P 59.94 (Dual P29.97)
#define | GS_SIGFORM_1080_50 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_50)
1920x1080P 50 (Dual 25)
#define | GS_SIGFORM_720_60 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_60)
1650x750 raster, 1280x720 production aperture (1248x702 clean): @ 60 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_720_60X (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_59_94)
1650x750 raster, 1280x720 production aperture (1248x702 clean): @ 59.97 gsGetSetValue::gsSignalFormat
#define | GS_SIGFORM_720_50 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_50)
50 Hz DVS, IRT
#define | GS_SIGFORM_720_30 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)
Half frame rate 720/60.
#define | GS_SIGFORM_720_30X (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)
Half frame rate 720/59.94.
#define | GS_SIGFORM_720_25 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)
Half 50 Hz DVS, IRT.
#define | GS_SIGFORM_720_24 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_VESA_640_72 (GS_SIGFORMSIZE_640x480 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)
#define | GS_SIGFORM_VESA_800_71X (GS_SIGFORMSIZE_800x600 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)
#define | GS_SIGFORM_VESA_800_72 (GS_SIGFORMSIZE_800x600 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)
#define | GS_SIGFORM_VESA_1024_71X (GS_SIGFORMSIZE_1024x768 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)
#define | GS_SIGFORM_VESA_1024_72 (GS_SIGFORMSIZE_1024x768 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)
#define | GS_SIGFORM_VESA_1280_24 (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_VESA_1280i_30 (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)
#define | GS_SIGFORM_VESA_1280_71X (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)
#define | GS_SIGFORM_VESA_1280_72 (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)
#define | GS_SIGFORM_VESA_1600i_30 (GS_SIGFORMSIZE_1600x1200 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)
#define | GS_SIGFORM_DVI_1400_1050_24 (GS_SIGFORMSIZE_1400x1050 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_DVI_1400_1050_25 (GS_SIGFORMSIZE_1400x1050 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_DCIN_2048_25 (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_DCIN_2048sf_24X (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_DCIN_2048sf_24 (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_DCIN_2048_24X (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_DCIN_2048_24 (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_1828_778_24 (GS_SIGFORMSIZE_1828x778 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_1828_778_25 (GS_SIGFORMSIZE_1828x778 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_FILM_1828_988_24 (GS_SIGFORMSIZE_1828x988 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_1828_988_25 (GS_SIGFORMSIZE_1828x988 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_FILM_1828_1102_24 (GS_SIGFORMSIZE_1828x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_1828_1102_25 (GS_SIGFORMSIZE_1828x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_FILM_1828_1332_24 (GS_SIGFORMSIZE_1828x1332 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_1828_1332_25 (GS_SIGFORMSIZE_1828x1332 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_FILM_2048_857_24 (GS_SIGFORMSIZE_2048x857 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_2048_857_25 (GS_SIGFORMSIZE_2048x857 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_FILM_2048_872_24 (GS_SIGFORMSIZE_2048x872 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_2048_872_25 (GS_SIGFORMSIZE_2048x872 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_FILM_2048_1102_24 (GS_SIGFORMSIZE_2048x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_2048_1102_25 (GS_SIGFORMSIZE_2048x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_FILM_2048_1234_24 (GS_SIGFORMSIZE_2048x1234 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_2048_1234_25 (GS_SIGFORMSIZE_2048x1234 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
#define | GS_SIGFORM_FILM_2048_15X (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_14_98)
#define | GS_SIGFORM_FILM_2048_14 GS_SIGFORM_FILM_2048_15X
#define | GS_SIGFORM_FILM_2048_15 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_15)
#define | GS_SIGFORM_FILM_2048sf_15X (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_14_98)
#define | GS_SIGFORM_FILM_2048sf_15 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_15)
#define | GS_SIGFORM_FILM_2048_24X (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_FILM_2048_24 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_2048sf_24X (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_FILM_2048sf_24 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_2048_48 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_48)
#define | GS_SIGFORM_FILM_2048_1536_15X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_14_98)
#define | GS_SIGFORM_FILM_2048_1536_15 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_15)
#define | GS_SIGFORM_FILM_2048_1536sf_15X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_14_98)
#define | GS_SIGFORM_FILM_2048_1536sf_15 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_15)
#define | GS_SIGFORM_FILM_2048_1536_24X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_FILM_2048_1536_24 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_2048_1536sf_24X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_FILM_2048_1536sf_24 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_2048_1536_48X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_47_95)
#define | GS_SIGFORM_FILM_2048_1536_48 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_48)
#define | GS_SIGFORM_FILM_4096_1714_24 (GS_SIGFORMSIZE_4096x1714 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_4096_1714_24X (GS_SIGFORMSIZE_4096x1714 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_FILM_4096_3112sf_5 (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_5)
#define | GS_SIGFORM_FILM_4096_3112_24 (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
#define | GS_SIGFORM_FILM_4096_3112_24X (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
#define | GS_SIGFORM_CUSTOM 0xFFFFFFFF
All non video rate types (eg. 15fps, 10fps, 37fps) gsGetSetValue::gsSignalFormat.
#define | GS_SIGFORM_NOT_PRESENT 0xFFFFFFFF
For input and genlock status returns.
#define | GS_SIGFORM_SUPPORTS_NTSC 0x00000001
#define | GS_SIGFORM_SUPPORTS_PAL 0x00000002
#define | GS_SIGFORM_SUPPORTS_HR 0x00000004
#define | GS_SIGFORM_SUPPORTS_360 0x00000008
#define | GS_SIGFORM_SUPPORTS_720 0x00000010
#define | GS_SIGFORM_SUPPORTS_1035 0x00000020
#define | GS_SIGFORM_SUPPORTS_1080 0x00000040
#define | GS_SIGFORM_SUPPORTS_EXTRA8 0x00000080
#define | GS_SIGFORM_SUPPORTS_1536 0x00000100
#define | GS_SIGFORM_SUPPORTS_1556 0x00000200
#define | GS_SIGFORM_SUPPORTS_DCIN 0x00000400
#define | GS_SIGFORM_SUPPORTS_1400 0x00000800
#define | GS_SIGFORM_SUPPORTS_V480 0x00010000
#define | GS_SIGFORM_SUPPORTS_V600 0x00020000
#define | GS_SIGFORM_SUPPORTS_V768 0x00040000
#define | GS_SIGFORM_SUPPORTS_V1024 0x00080000
#define | GS_SIGFORM_SUPPORTS_V1200 0x00100000
#define | GS_SIGFORM_SUPPORTS_V1600 0x00200000
#define | GS_SIGFORM_SUPPORTS_X2 0x20000000
#define | GS_SIGFORM_SUPPORTS_X3 0x40000000
#define | GS_SIGFORM_SUPPORTS_X4 0x80000000
#define | GS_COMPTYPE_SOFTWARE 0x00000001
Software passed codec on main processor (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_MJPEG 0x00000002
Motion JPEG hardware codec (LSI, Zoran, C-Cube, etc) (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_WAVELET 0x00000008
Wavelet hardware codec (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_MPEG1 0x00000010
MPEG 1 hardware compatible codec (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_MPEG2 0x00000020
MPEG 2 hardware compatible codec (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_MPEG2I 0x00000040
Editable MPEG 2 I Frame Only compatible codec (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_MPEG2IBP 0x00000080
MPEG 2 long gop hardware compatible codec (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_DV25 0x00000100
Hardware DV25, DVCPRO. DVCPRO25 (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_DV50 0x00000200
Hardware DV50, DVCPRO50 (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_DVSD 0x00000400
Hardware Standard DV Bluebook, DVPRO, DVSD (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_DV100 0x00000800
High Def DV codec (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_UN8BIT 0x00001000
8Bit Y'CrCb uncompressed video (gsGetSetValue::gsCompType)
#define | GS_COMPTYPE_UN10BIT 0x00002000
10Bit Y'CrCb uncompressed video (gsGetSetValue::gsCompType)
#define | GS_COMPTYPE_HDPAN 0x00010000
Panasonic HD to SDI codec (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_HDSONY 0x00020000
Sony HD to SDI codec (gsGetSetValue::gsCompType).
#define | GS_COMPTYPE_BGRA_INVERT 0x00040000
Inverted 32 bit TGA.
#define | GS_COMPTYPE_ARGB 0x00100000
Uncompressed RGB (DVS).
#define | GS_COMPTYPE_RGBA 0x00200000
Uncompressed RGBA (DVS).
#define | GS_COMPTYPE_RGB 0x00300000
Uncompressed RGB 24 Bit.
#define | GS_COMPTYPE_ABGR 0x00400000
Uncompressed A BGR - TIFF.
#define | GS_COMPTYPE_BGRA 0x00800000
Uncompressed BGR A - BMP/TGA.
#define | GS_COMPTYPE_BGR 0x00C00000
Uncompressed BGR 24 Bit.
#define | GS_COMPTYPE_YCRCB_422 0x01000000
Uncompressed Y'CrCb 4:2:2 (DVS, VG).
#define | GS_COMPTYPE_YCRCB_422A 0x02000000
Uncompressed Y'CrCb 4:2:2A (DVS, Dual VG).
#define | GS_COMPTYPE_YCRCB_444 0x04000000
Uncompressed Y'CrCb 4:4:4 (DVS, Dual VG).
#define | GS_COMPTYPE_YCRCB_444A 0x08000000
Uncompressed Y'CrCb 4:4:4A (DVS, Dual VG).
#define | GS_COMPTYPE_YCRCB_422_STEREO 0x10000000
Uncompressed Y'CrCb 4:4:4A (DVS, Dual VG).
#define | GS_COMPTYPE_YCRCB_420 0x20000000
Uncompressed Y'CrCb 4:2:0.
#define | GS_PBEE_AUTO 0x00000000
Allow playback or edit to edit output as necassary (gsGetSetValue::gsPBEE).
#define | GS_PBEE_PB 0x00000001
Allow playback only output - no passthough (gsGetSetValue::gsPBEE).
#define | GS_PBEE_DEFAULT 0x000000FF
Device dependant output (gsGetSetValue::gsPBEE).
#define | GS_SERVOREF_AUTO 0x00000000
Video servo reference auto (gsGetSetValue::gsServoRefSelect).
#define | GS_SERVOREF_EXT 0x00000001
Video servo reference external only (gsGetSetValue::gsServoRefSelect).
#define | GS_SERVOREF_DEFAULT 0x000000FF
Video servo reference device default (gsGetSetValue::gsServoRefSelect).
#define | GS_HEADSEL_RECPLAY 0x00000000
Use record/play head (gsGetSetValue::gsHeadSelect).
#define | GS_HEADSEL_PLAY 0x00000001
Use play head (gsGetSetValue::gsHeadSelect).
#define | GS_HEADSEL_DEFAULT 0x000000FF
(gsGetSetValue::gsHeadSelect)
#define | GS_CLRFRM_2FLD 0x00000000
Edit colour frame 2 field (gsGetSetValue::gsColorFrame).
#define | GS_CLRFRM_4FLD 0x00000001
Edit colour frame 4 field (gsGetSetValue::gsColorFrame).
#define | GS_CLRFRM_8FLD 0x00000002
Edit colour frame 8 field (gsGetSetValue::gsColorFrame).
#define | GS_CLRFRM_DEFAULT 0x000000FF
Edit colour frame device default (gsGetSetValue::gsColorFrame).
#define | GS_VIDREF_DISABLE 0x00000000
Disable video reference (gsGetSetValue::gsVidRefDisable).
#define | GS_VIDREF_ENABLE 0x00000001
Enable video reference (gsGetSetValue::gsVidRefDisable).
#define | GS_CHANCAP_PLAY 0x00000001
Channel can play (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_REVPLAY 0x00000002
Channel can reverse play (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_PAUSE 0x00000004
Channel can pause and display frame (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_JOG 0x00000008
Channel can jog below play speed (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_SHUTTLE 0x00000010
Channel can shuttle above play speed (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_SEEK 0x00000020
Channel can seek to any point (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_PREVIEW 0x00000040
Channel can preview from in to out (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_STOP 0x00001000
Channel has a stop mode (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_ETOE 0x00002000
Channel can pass through video (in stop) (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_RECORD 0x00004000
Channel can record (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_EDIT 0x00008000
Channel can edit from in to out (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_RECSTOP 0x00010000
Channel can set clip name and prep record (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_SELECTPRESET 0x00020000
Channel can select recording channels (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_EJECT 0x00040000
Channel can eject the media (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_LOOP 0x00100000
Channel can play in a loop (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_VGAPREVIEW 0x00200000
Channel can display a vga preview (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_AUDPREVIEW 0x00200000
Channel can preview audio on a multi media card (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_FILE 0x01000000
Channel can play from a file (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_NET 0x02000000
Channel can play from a network feed (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_CLIPSPACE 0x10000000
Channel can act like a clip space (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_TCSPACE 0x20000000
Channel can act like a vtr time code space (video or audio or both) (gsGetSetValue::gsChanCapabilities).
#define | GS_CHANCAP_MPEG_ENC 0x40000000
#define | GS_CHANCAP_ERROR 0x80000000
Do not use this bit - indicates error.
#define | GS_CHANCAP_ALL 0x3FFFFFFF
Channel can do anything except MPEG_ENC (by default this should not be).
#define | GS_PROXYMODE_NOTHING 0x000000
#define | GS_PROXYMODE_EVERYTHING 0x000002
#define | GS_PROXYMODE_RECORD 0x000001
#define | GS_PROXYMODE_AFTERRECORD 0x000010
#define | GS_NOT_SUPPORTED 0xFFFFFFFF
Command is not supported see cmdType::ctGetValue, cmdType::ctSetValue, cmdType::ctValueSupported.
#define | GS_BAD_PARAM 0xFFFFFFFE
#define | GS_FALSE 0x00
#define | GS_TRUE 0x01
#define | GS_DISABLE 0x00
#define | GS_ENABLE 0x01
#define | GS_DEFAULT 0xFF
#define | GS_FIELD 0x00
Use field cmdType::ctGetValue, cmdType::ctSetValue (for pause/freeze as opposed to frame).
#define | GS_FIELD1 0x01
Use field 1 cmdType::ctGetValue, cmdType::ctSetValue (for record/playback starts and edits).
#define | GS_FIELD2 0x02
Use field 2 cmdType::ctGetValue, cmdType::ctSetValue (for record/playback starts and edits).
#define | GS_FRAME 0x03
Use frame cmdType::ctGetValue, cmdType::ctSetValue (for pause/freeze as opposed to field).
#define | GS_UNITY 0xFFFFFFFF
Set value to unity (levels, tbc) or default (compression type, amount).
#define | GS_ALPHACHROMA_SINGLE 0x01
#define | GS_ALPHACHROMA_ALPHA 0x02
#define | GS_ALPHACHROMA_DUAL 0x04
#define | GS_BITCOUNT_8 0x01
#define | GS_BITCOUNT_10 0x02
#define | GS_BITCOUNT_24 0x04
#define | GS_BITCOUNT_30 0x08
#define | GS_BITCOUNT_32 0x10
#define | GS_BITCOUNT_12 0x20
#define | CmdQueueElem MEDIACMD
Old name, use MEDIACMD instead.
#define | pCmdQueueElem PMEDIACMD
Old name, use PMEDIACMD instead.
#define | DECLARE_MEDIACMD(__mCmd_)
Declare a media cmd structure to all pause.
#define | INIT_MEDIACMD(__mCmd_)
Initailize a media cmd structure to all illegal (no command).
#define | INIT_PMEDIACMD(__mCmd_)
Initailize a media cmd pointer to all illegal (no command).
#define | CMD_QUEUE_ELEMSIZE ((size_t)(&((pCmdQueueElem)(0))->arbID[0]))
SizeOf a command queue without the arbID.
#define | SIZEOF_MEDIACMD_BASE CMD_QUEUE_ELEMSIZE
SizeOf basic mediacmd structure without any clip id.
#define | SIZEOF_MEDIACMD_CLIPID (CMD_QUEUE_ELEMSIZE + 9)
SizeOf mediacmd structure with a 8 byte clip id and terminating 0.
#define | SIZEOF_MEDIACMD sizeof(MEDIACMD)
SizeOf a complete mediacmd structure.

Typedefs

typedef struct MEDIACMD * | PMEDIACMD

Enumerations

enum cmdType {
ctStop, ctPause, ctPlay, ctRecord,
ctRecStop, ctEject, ctTransfer, ctInsert,
ctBlank, ctDelete, ctTrim, ctChanSelect,
ctGetState, ctSetState, ctGetValue, ctSetValue,
ctValueSupported, ctError, ctTerminate, ctAbort
}
enum cmdFlags {
cfDeferred = 1, cfOverideDeferred = 1 << 30, cfTimeMs = 1 << 1, cfTimeTarget = 1 << 2,
cfTimeHouseClock = 1 << 3, cfUseSpeed = 1 << 4, cfUsePresets = 1 << 5, cfUsePosition = 1 << 6,
cfUsePositionOffset = 1 << 7, cfUseStart = 1 << 8, cfUseStartOffset = 1 << 9, cfUseEnd = 1 << 10,
cfUseEndOffset = 1 << 11, cfUseAllIDs = 1 << 12, cfUseClipID = 1 << 13, cfCopy = 1 << 14,
cfNoClipFiles = cfCopy, cfConvert = 1 << 15, cfNoTCSpaces = cfConvert, cfUseCmdAlt = 1 << 16,
cfIsShuttle = 1 << 17, cfUsingCurrent = 1 << 18, cfUseFrameCount = 1 << 19, cfFields = 1 << 20,
cfRipple = 1 << 21, cfLoop = 1 << 22, cfTrigger = 1 << 23, cfPreview = 1 << 24,
cfInvert = 1 << 28, cfTest = 1 << 29, cfNoReturn = 1UL << 31UL
}
enum cmdinf {
infLtc = 1, infVitc = 1 << 1, infSrcCtl = 1 << 2, infSrcLtc = 1 << 3,
infSrcVitc = 1 << 4, infRecTime = 1 << 5, infRecDate = 1 << 6, infCC = 1 << 7,
infAuth = 1 << 8, infCopyright = 1 << 9, infOwner = 1 << 10, infSourceName = 1 << 11,
infProxyName = 1 << 12, inf13 = 1 << 13, inf14 = 1 << 14, inf15 = 1 << 15,
inf16 = 1 << 16, inf17 = 1 << 17, inf18 = 1 << 18, inf19 = 1 << 19,
inf20 = 1 << 20, inf21 = 1 << 21, infVB0 = 1 << 22, infVB1 = 1 << 23,
infVB2 = 1 << 24, infVB3 = 1 << 25, infVB4 = 1 << 26, infVB5 = 1 << 27,
infVB6 = 1 << 28, infVB7 = 1 << 29, infVB8 = 1 << 30, infVB9 = 1UL << 31UL,
infChanAll
}

Define Documentation

#define audChanAll 0xFFFFFFFF

#define CHAN_ILLEGAL 0xFFFFFFFFUL

Illegal channel, or All Channels. Set MEDIACMD::dwAudioChannels, MEDIACMD::dwVideoChannels, MEDIACMD::dwInfoChannels to this if not used.

#define CMD_MAX_CLIP_ID_LEN (260+8)

Maximum clip id length in the DEFAULT MEDIACMD structure. Larger versions may be allocated and are legal. Smaller versions should not have less than 10 bytes with zero padding for clip names (8 bytes + NULL) and file name (NULL). Note that the array is actually allocated as CMD_MAX_CLIP_ID_LEN+2+2 260+8+2+2 = 270 bytes (DWORD aligned) CLIP 8 Bytes NULL 1 Byte File 260 Bytes (_MAX_PATH) NULL 1 Byte 2 Alignment padding

#define CMD_QUEUE_ELEMSIZE ((size_t)(&((pCmdQueueElem)(0))->arbID[0]))

SizeOf a command queue without the arbID.

#define CmdQueueElem MEDIACMD

Old name, use MEDIACMD instead.

#define DECLARE_MEDIACMD ( __mCmd_ )

Value:

MEDIACMD __mCmd_ =      \
        {NULL, NULL, NULL,                                                                      \
        MEDIACMD_CURRENT, (DWORD)sizeof(MEDIACMD), CHAN_ILLEGAL,        \
        ctPause, 0UL, SPD_ILLEGAL,                                                      \
        (DWORD)vidChanAll, (DWORD)audChanAll,                           \
        (DWORD)infChanAll, (DWORD)gsNextClip,                           \
        (DWORD)TC_ILLEGAL, (DWORD)TC_ILLEGAL, (DWORD)TC_ILLEGAL,        \
        {0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,        \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
                                                                                \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
        0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,            \
        }};
Declare a media cmd structure to all pause.

#define GS_ALPHACHROMA_ALPHA 0x02

#define GS_ALPHACHROMA_DUAL 0x04

#define GS_ALPHACHROMA_SINGLE 0x01

#define GS_ANALOGMONITORMETHOD_DIRECT 0x0000

Keep analog monitor in line with digital (hd=hd, sd=sd).

#define GS_ANALOGMONITORMETHOD_FLIP1080 0x0005

SD->HD720 and HD->SD.

#define GS_ANALOGMONITORMETHOD_FLIP720 0x0004

SD->HD720 and HD->SD.

#define GS_ANALOGMONITORMETHOD_HD1080 0x0003

Convert everything to the nearest 1080 HD type.

#define GS_ANALOGMONITORMETHOD_HD720 0x0002

Convert everything to the nearest 720 HD type.

#define GS_ANALOGMONITORMETHOD_SD 0x0001

Convert everything to the nearest SD type.

#define GS_ASPECT_RATIO_16x9 0x4

#define GS_ASPECT_RATIO_2_21x1 0x8

#define GS_ASPECT_RATIO_4x3 0x2

#define GS_ASPECT_RATIO_SQUARE 0x1

#define GS_ASSEMBLE_EDIT 0x02

Set cmdGetSetValue::gsEditMode for an assemble edit.

#define GS_AUD_BIT_RATE_112000 0x0080

#define GS_AUD_BIT_RATE_128000 0x0100

#define GS_AUD_BIT_RATE_160000 0x0200

#define GS_AUD_BIT_RATE_192000 0x0400

#define GS_AUD_BIT_RATE_224000 0x0800

#define GS_AUD_BIT_RATE_256000 0x1000

#define GS_AUD_BIT_RATE_32000 0x0001

#define GS_AUD_BIT_RATE_320000 0x2000

#define GS_AUD_BIT_RATE_384000 0x4000

#define GS_AUD_BIT_RATE_41100 0x0002

#define GS_AUD_BIT_RATE_48000 0x0004

#define GS_AUD_BIT_RATE_56000 0x0008

#define GS_AUD_BIT_RATE_64000 0x0010

#define GS_AUD_BIT_RATE_80000 0x0020

#define GS_AUD_BIT_RATE_96000 0x0040

#define GS_AUD_DUAL 0x004

#define GS_AUD_HEADROOM_18 0x01

#define GS_AUD_HEADROOM_20 0x02

#define GS_AUD_JOINT_STEREO 0x002

#define GS_AUD_MULTIPLE 0x010

#define GS_AUD_SINGLE 0x008

#define GS_AUD_STEREO 0x001

#define GS_AUDSELECT_AES_EBU 0x200

Audio in/out digital balanced with clock (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_AUDSELECT_AES_EBU_PRO 0x800

Audio in/out digital balanced with clock (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_AUDSELECT_BALANCED_10 0x010

Audio in/out balanced (XLR connector) 600ohm impedence at -10db (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_AUDSELECT_BALANCED_4 0x020

Audio in/out balanced (XLR connector) 600ohm impedence at +4db (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_AUDSELECT_EMBEDDED 0x400

Audio in/out embedded in SDI or HD-SDI video signal (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_AUDSELECT_NONE 0

No audio in/out available, or cannot be configured (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_AUDSELECT_SILENT 0x040

No Audio Selected leave silent.

#define GS_AUDSELECT_SPDIF 0x100

Audio in/out digital single wire (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_AUDSELECT_UNBALANCED_10 0x001

Audio in/out unbalanced (RCA connector) high impedence at -10db (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_AUDSELECT_UNBALANCED_4 0x002

Audio in/out unbalanced (RCA connector) high impedence at -4db (cmdGetSetValue::gsAudInSelect cmdGetSetValue::gsAudOutSelect).

#define GS_BAD_PARAM 0xFFFFFFFE

Parameter is bad see cmdType::ctGetValue, cmdType::ctSetValue, cmdType::ctValueSupported and MEDIACMD::dwPosition, MEDIACMD::dwStart and MEDIACMD::dwEnd

#define GS_BITCOUNT_10 0x02

#define GS_BITCOUNT_12 0x20

#define GS_BITCOUNT_24 0x04

#define GS_BITCOUNT_30 0x08

#define GS_BITCOUNT_32 0x10

#define GS_BITCOUNT_8 0x01

#define GS_CHANCAP_ALL 0x3FFFFFFF

Channel can do anything except MPEG_ENC (by default this should not be).

#define GS_CHANCAP_AUDPREVIEW 0x00200000

Channel can preview audio on a multi media card (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_CLIPSPACE 0x10000000

Channel can act like a clip space (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_EDIT 0x00008000

Channel can edit from in to out (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_EJECT 0x00040000

Channel can eject the media (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_ERROR 0x80000000

Do not use this bit - indicates error.

#define GS_CHANCAP_ETOE 0x00002000

Channel can pass through video (in stop) (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_FILE 0x01000000

Channel can play from a file (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_JOG 0x00000008

Channel can jog below play speed (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_LOOP 0x00100000

Channel can play in a loop (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_MPEG_ENC 0x40000000

Channel can be configures as MPEG -- opens whole bunch of settings on the options (specifically for Argus board right now).

#define GS_CHANCAP_NET 0x02000000

Channel can play from a network feed (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_PAUSE 0x00000004

Channel can pause and display frame (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_PLAY 0x00000001

Channel can play (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_PREVIEW 0x00000040

Channel can preview from in to out (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_RECORD 0x00004000

Channel can record (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_RECSTOP 0x00010000

Channel can set clip name and prep record (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_REVPLAY 0x00000002

Channel can reverse play (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_SEEK 0x00000020

Channel can seek to any point (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_SELECTPRESET 0x00020000

Channel can select recording channels (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_SHUTTLE 0x00000010

Channel can shuttle above play speed (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_STOP 0x00001000

Channel has a stop mode (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_TCSPACE 0x20000000

Channel can act like a vtr time code space (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHANCAP_VGAPREVIEW 0x00200000

Channel can display a vga preview (video or audio or both) (gsGetSetValue::gsChanCapabilities).

#define GS_CHROMA_FORMAT_411 0x8

#define GS_CHROMA_FORMAT_420 0x1

#define GS_CHROMA_FORMAT_422 0x2

#define GS_CHROMA_FORMAT_444 0x4

#define GS_CLIPMODE_CLIPSPACE 0

#define GS_CLIPMODE_FILM 3

#define GS_CLIPMODE_ILLEGAL 0xFFFFFFFF

Known file types.

#define GS_CLIPMODE_SINGLE 2

#define GS_CLIPMODE_TCSPACE 1

#define GS_CLRFRM_2FLD 0x00000000

Edit colour frame 2 field (gsGetSetValue::gsColorFrame).

#define GS_CLRFRM_4FLD 0x00000001

Edit colour frame 4 field (gsGetSetValue::gsColorFrame).

#define GS_CLRFRM_8FLD 0x00000002

Edit colour frame 8 field (gsGetSetValue::gsColorFrame).

#define GS_CLRFRM_DEFAULT 0x000000FF

Edit colour frame device default (gsGetSetValue::gsColorFrame).

#define GS_COMPTYPE_ABGR 0x00400000

Uncompressed A BGR - TIFF.

#define GS_COMPTYPE_ARGB 0x00100000

Uncompressed RGB (DVS).

#define GS_COMPTYPE_BGR 0x00C00000

Uncompressed BGR 24 Bit.

#define GS_COMPTYPE_BGRA 0x00800000

Uncompressed BGR A - BMP/TGA.

#define GS_COMPTYPE_BGRA_INVERT 0x00040000

Inverted 32 bit TGA.

#define GS_COMPTYPE_DV100 0x00000800

High Def DV codec (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_DV25 0x00000100

Hardware DV25, DVCPRO. DVCPRO25 (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_DV50 0x00000200

Hardware DV50, DVCPRO50 (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_DVSD 0x00000400

Hardware Standard DV Bluebook, DVPRO, DVSD (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_HDPAN 0x00010000

Panasonic HD to SDI codec (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_HDSONY 0x00020000

Sony HD to SDI codec (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_MJPEG 0x00000002

Motion JPEG hardware codec (LSI, Zoran, C-Cube, etc) (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_MPEG1 0x00000010

MPEG 1 hardware compatible codec (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_MPEG2 0x00000020

MPEG 2 hardware compatible codec (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_MPEG2I 0x00000040

Editable MPEG 2 I Frame Only compatible codec (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_MPEG2IBP 0x00000080

MPEG 2 long gop hardware compatible codec (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_RGB 0x00300000

Uncompressed RGB 24 Bit.

#define GS_COMPTYPE_RGBA 0x00200000

Uncompressed RGBA (DVS).

#define GS_COMPTYPE_SOFTWARE 0x00000001

Software passed codec on main processor (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_UN10BIT 0x00002000

10Bit Y'CrCb uncompressed video (gsGetSetValue::gsCompType)

#define GS_COMPTYPE_UN8BIT 0x00001000

8Bit Y'CrCb uncompressed video (gsGetSetValue::gsCompType)

#define GS_COMPTYPE_WAVELET 0x00000008

Wavelet hardware codec (gsGetSetValue::gsCompType).

#define GS_COMPTYPE_YCRCB_420 0x20000000

Uncompressed Y'CrCb 4:2:0.

#define GS_COMPTYPE_YCRCB_422 0x01000000

Uncompressed Y'CrCb 4:2:2 (DVS, VG).

#define GS_COMPTYPE_YCRCB_422_STEREO 0x10000000

Uncompressed Y'CrCb 4:4:4A (DVS, Dual VG).

#define GS_COMPTYPE_YCRCB_422A 0x02000000

Uncompressed Y'CrCb 4:2:2A (DVS, Dual VG).

#define GS_COMPTYPE_YCRCB_444 0x04000000

Uncompressed Y'CrCb 4:4:4 (DVS, Dual VG).

#define GS_COMPTYPE_YCRCB_444A 0x08000000

Uncompressed Y'CrCb 4:4:4A (DVS, Dual VG).

#define GS_DEFAULT 0xFF

Default for cmdType::ctGetValue, cmdType::ctSetValue (usually in relation to VTR setup)

#define GS_DISABLE 0x00

Disable a feature or command

#define GS_DOWNCONVERT_ANAMORPHIC 0x0002

Down convert to whole screen.

#define GS_DOWNCONVERT_CROP 0x0001

Down convert and crop image.

#define GS_DOWNCONVERT_LETTERBOX 0x0000

Down convert with top/bottom black bars.

#define GS_ENABLE 0x01

Enable a feature or command

#define GS_FALSE 0x00

False for boolean cmdType::ctGetValue, cmdType::ctSetValue

#define GS_FIELD 0x00

Use field cmdType::ctGetValue, cmdType::ctSetValue (for pause/freeze as opposed to frame).

#define GS_FIELD1 0x01

Use field 1 cmdType::ctGetValue, cmdType::ctSetValue (for record/playback starts and edits).

#define GS_FIELD2 0x02

Use field 2 cmdType::ctGetValue, cmdType::ctSetValue (for record/playback starts and edits).

#define GS_FRAME 0x03

Use frame cmdType::ctGetValue, cmdType::ctSetValue (for pause/freeze as opposed to field).

#define GS_FRAMEDATA_ASCII 0x00001

Ascii data (all printable) for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.

#define GS_FRAMEDATA_CC_TTEXT 0x10002

Close caption/teletext for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.

#define GS_FRAMEDATA_HEX 0x00002

Binary (hex) data for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.

#define GS_FRAMEDATA_NAVY 0x10003

Navy telemtry data for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.

#define GS_FRAMEDATA_TELECINE 0x10001

Telecine RP-215 / DPX Data for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.

#define GS_FRAMEDATA_UNKNOWN 0x00000

No data, unknown data for cmdGetSetValue::gsFrameData, cmdType::ctSetValue/cmdTypectGetValue.

#define GS_HEADSEL_DEFAULT 0x000000FF

(gsGetSetValue::gsHeadSelect)

#define GS_HEADSEL_PLAY 0x00000001

Use play head (gsGetSetValue::gsHeadSelect).

#define GS_HEADSEL_RECPLAY 0x00000000

Use record/play head (gsGetSetValue::gsHeadSelect).

#define GS_INSERT_EDIT 0x01

Set cmdGetSetValue::gsEditMode for an insert edit.

#define GS_LOCKSRC_CVBS 0x0008

Composite (CVBS) input is genlock source (gsGetSetValue::gsVidOutGenlockSource).

#define GS_LOCKSRC_EXTIN 0x0002

External ref in is genlock source (gsGetSetValue::gsVidOutGenlockSource).

#define GS_LOCKSRC_IN_Y 0x0020

Component Y input is genlock source (gsGetSetValue::gsVidOutGenlockSource).

#define GS_LOCKSRC_INPUT 0x0004

Current input is genlock source (gsGetSetValue::gsVidOutGenlockSource).

#define GS_LOCKSRC_NONE 0x0001

No external genlock source (free running on internal clock) (gsGetSetValue::gsVidOutGenlockSource).

#define GS_LOCKSRC_SDI 0x0040

SDI serial digital input is genlock source (gsGetSetValue::gsVidOutGenlockSource).

#define GS_LOCKSRC_SVIDEO 0x0010

S-Video (SVHS) input is genlock source (gsGetSetValue::gsVidOutGenlockSource).

#define GS_MONITORGRAB_NONE 0x0000

Turn off monitor.

#define GS_MONITORGRAB_SIZE_FULL 0x0001

Full size image captured.

#define GS_MONITORGRAB_SIZE_HALF 0x0002

Half size image captured.

#define GS_MONITORGRAB_SIZE_MASK 0x000F

Size mask (full, half, quarter).

#define GS_MONITORGRAB_SIZE_QUARTER 0x0004

Quarter size image captured.

#define GS_MONITORGRAB_TARGET_MASK 0x0F00

Target/To mask.

#define GS_MONITORGRAB_TO_HTTP 0x0400

Save image to web server (use name sent in arbID).

#define GS_MONITORGRAB_TO_MEMORY 0x0100

Use the arbID area.

#define GS_MONITORGRAB_TO_NETWORK 0x0800

Save image through 'to be announced' network transport.

#define GS_MONITORGRAB_TO_UNC_PATH 0x0200

Save image to a UNC path.

#define GS_MONITORGRAB_TYPE_BMP 0x0000

Use BMP format for image.

#define GS_MONITORGRAB_TYPE_JPG 0x0010

Use JPEG format for image.

#define GS_MONITORGRAB_TYPE_MASK 0x00F0

Type mask (jpg, bmp).

#define GS_MPEG_ASPECT_RATIO_16x9 GS_ASPECT_RATIO_16x9

#define GS_MPEG_ASPECT_RATIO_2_21x1 GS_ASPECT_RATIO_2_21x1

#define GS_MPEG_ASPECT_RATIO_4x3 GS_ASPECT_RATIO_4x3

#define GS_MPEG_ASPECT_RATIO_SQUARE GS_ASPECT_RATIO_SQUARE

#define GS_MPEG_CC_FORMAT_ATSC 0x2

#define GS_MPEG_CC_FORMAT_ATSC_REORDER 0x8

#define GS_MPEG_CC_FORMAT_CCUBE 0x1

#define GS_MPEG_CC_FORMAT_CCUBE_REORDER 0x4

#define GS_MPEG_CHROMA_FORMAT_420 GS_CHROMA_FORMAT_420

#define GS_MPEG_CHROMA_FORMAT_422 GS_CHROMA_FORMAT_422

#define GS_MPEG_CHROMA_FORMAT_444 GS_CHROMA_FORMAT_444

#define GS_MPEG_DC_PRECISION_10 0x4

#define GS_MPEG_DC_PRECISION_11 0x8

#define GS_MPEG_DC_PRECISION_8 0x1

#define GS_MPEG_DC_PRECISION_9 0x2

#define GS_MPEG_EIGHT_FRAMES 0x0080

#define GS_MPEG_ELEVEN_FRAMES 0x0400

#define GS_MPEG_FIFTEEN_FRAMES 0x4000

#define GS_MPEG_FIVE_FRAMES 0x0010

#define GS_MPEG_FOUR_FRAMES 0x0008

#define GS_MPEG_FOURTEEN_FRAMES 0x2000

#define GS_MPEG_LANGAUGE_CHINESE 0x2000

#define GS_MPEG_LANGAUGE_DANISH 0x0040

#define GS_MPEG_LANGAUGE_DUTCH 0x0020

#define GS_MPEG_LANGAUGE_ENGLISH 0x0001

#define GS_MPEG_LANGAUGE_FINNISH 0x0080

#define GS_MPEG_LANGAUGE_FRENCH 0x0004

#define GS_MPEG_LANGAUGE_GERMAN 0x0008

#define GS_MPEG_LANGAUGE_GREEK 0x0200

#define GS_MPEG_LANGAUGE_ITALIAN 0x0100

#define GS_MPEG_LANGAUGE_JAPANESE 0x0010

#define GS_MPEG_LANGAUGE_PORTUGUESE 0x0400

#define GS_MPEG_LANGAUGE_RUSSIAN 0x1000

#define GS_MPEG_LANGAUGE_SPANISH 0x0002

#define GS_MPEG_LANGAUGE_SWEDISH 0x0800

#define GS_MPEG_NINE_FRAMES 0x0100

#define GS_MPEG_ONE_FRAMES 0x0001

#define GS_MPEG_RESOLUTION_120 0x001

Standard MPEG resolution 120x60.

#define GS_MPEG_RESOLUTION_240 0x002

#define GS_MPEG_RESOLUTION_288 0x004

#define GS_MPEG_RESOLUTION_352 0x008

#define GS_MPEG_RESOLUTION_480 0x010

#define GS_MPEG_RESOLUTION_512 0x020

#define GS_MPEG_RESOLUTION_544 0x040

#define GS_MPEG_RESOLUTION_576 0x080

#define GS_MPEG_RESOLUTION_608 0x100

#define GS_MPEG_RESOLUTION_704 0x200

#define GS_MPEG_RESOLUTION_720 0x400

#define GS_MPEG_SEVEN_FRAMES 0x0040

#define GS_MPEG_SIX_FRAMES 0x0020

#define GS_MPEG_SIXTEEN_FRAMES 0x8000

#define GS_MPEG_STANDARD_ELEMENTARY 0x8

#define GS_MPEG_STANDARD_ELEMENTRY GS_MPEG_STANDARD_ELEMENTARY

#define GS_MPEG_STANDARD_PROGRAM 0x2

#define GS_MPEG_STANDARD_SYSTEM 0x1

#define GS_MPEG_STANDARD_TRANSPORT 0x4

#define GS_MPEG_TEN_FRAMES 0x0200

#define GS_MPEG_THIRTEEN_FRAMES 0x1000

#define GS_MPEG_THREE_FRAMES 0x0004

#define GS_MPEG_TWELVE_FRAMES 0x0800

#define GS_MPEG_TWO_FRAMES 0x0002

#define GS_NOT_SUPPORTED 0xFFFFFFFF

Command is not supported see cmdType::ctGetValue, cmdType::ctSetValue, cmdType::ctValueSupported.

#define GS_PBEE_AUTO 0x00000000

Allow playback or edit to edit output as necassary (gsGetSetValue::gsPBEE).

#define GS_PBEE_DEFAULT 0x000000FF

Device dependant output (gsGetSetValue::gsPBEE).

#define GS_PBEE_PB 0x00000001

Allow playback only output - no passthough (gsGetSetValue::gsPBEE).

#define GS_PROXYMODE_AFTERRECORD 0x000010

#define GS_PROXYMODE_EVERYTHING 0x000002

#define GS_PROXYMODE_NOTHING 0x000000

#define GS_PROXYMODE_RECORD 0x000001

#define GS_SERVOREF_AUTO 0x00000000

Video servo reference auto (gsGetSetValue::gsServoRefSelect).

#define GS_SERVOREF_DEFAULT 0x000000FF

Video servo reference device default (gsGetSetValue::gsServoRefSelect).

#define GS_SERVOREF_EXT 0x00000001

Video servo reference external only (gsGetSetValue::gsServoRefSelect).

#define GS_SIGFORM_1035i_30_260M (GS_SIGFORMSIZE_1920x1035 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)

2200x1125 raster, 1920x1035 production aperture (1888x1017 clean) @ 30 fps gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1035i_30X_260M (GS_SIGFORMSIZE_1920x1035 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)

2200x1125 raster, 1920x1035 production aperture (1888x1017 clean) @ 29.97 fp gsGetSetValue::gsSignalFormats

#define GS_SIGFORM_1080_24 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

1920x1080P (274M-1997 Table1 System 4) @ 24 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080_24X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)

1920x1080P (274M-1997 Table1 System 4) @ 23.98 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080_25 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)

1920x1080P (274M-1997 Table1 System 4) @ 25 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080_30 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)

1920x1080P (274M-1997 Table1 System 4) @ 30 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080_30X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)

1920x1080P (274M-1997 Table1 System 4) @ 29.97 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080_50 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_50)

1920x1080P 50 (Dual 25)

#define GS_SIGFORM_1080_60 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_60)

1920x1080P 60 (Dual P30)

#define GS_SIGFORM_1080_60X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_59_94)

1920x1080P 59.94 (Dual P29.97)

#define GS_SIGFORM_1080i_24 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_1080i_24X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_23_98)

#define GS_SIGFORM_1080i_25 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)

1920x1080i (274M-1997 Table1 System 4) @ 25 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080i_30 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)

1920x1080i (274M-1997 Table1 System 4) @ 29.97 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080i_30X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)

1920x1080i (274M-1997 Table1 System 4) @ 30 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080sf_24 (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)

1920x1080sf (274M-1997 Table1 System 4) @ 24 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_1080sf_24X (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)

1920x1080sf (274M-1997 Table1 System 4) @ 23.98 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_720_24 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_720_25 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)

Half 50 Hz DVS, IRT.

#define GS_SIGFORM_720_30 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)

Half frame rate 720/60.

#define GS_SIGFORM_720_30X (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)

Half frame rate 720/59.94.

#define GS_SIGFORM_720_50 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_50)

50 Hz DVS, IRT

#define GS_SIGFORM_720_60 (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_60)

1650x750 raster, 1280x720 production aperture (1248x702 clean): @ 60 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_720_60X (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_59_94)

1650x750 raster, 1280x720 production aperture (1248x702 clean): @ 59.97 gsGetSetValue::gsSignalFormat

#define GS_SIGFORM_ALT_NTSC (GS_SIGFORMSIZE_960x486 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)

Signal format NTSC High Res (960x486).

#define GS_SIGFORM_ALT_PAL (GS_SIGFORMSIZE_960x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)

Signal format PAL High Res (960x576).

#define GS_SIGFORM_CCIR_NTSC (GS_SIGFORMSIZE_720x486 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)

Signal format NTSC square pixel (360/352x243/240 or 720/704x486/480) @ 29.97 or 30 fps gsGetSetValue::gsSignalFormat.

#define GS_SIGFORM_CCIR_NTSC_P483 (GS_SIGFORMSIZE_720x483 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)

Signal format NTSC square pixel (360/352x243/240 or 720/704x486/480) @ 29.97 or 30 fps gsGetSetValue::gsSignalFormat.

#define GS_SIGFORM_CCIR_PAL (GS_SIGFORMSIZE_720x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)

Signal format PAL square pixel (360/352x288 or 720/704x576) @ 25 fps gsGetSetValue::gsSignalFormat.

#define GS_SIGFORM_CCIR_PNTSC_30 (GS_SIGFORMSIZE_720x486 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)

Signal format NTSC at 30 hz Progressive.

#define GS_SIGFORM_CCIR_PPAL_25 (GS_SIGFORMSIZE_720x576 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)

Signal format PAL at 25 hz Progressive.

#define GS_SIGFORM_CUSTOM 0xFFFFFFFF

All non video rate types (eg. 15fps, 10fps, 37fps) gsGetSetValue::gsSignalFormat.

#define GS_SIGFORM_DCIN_2048_24 (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_DCIN_2048_24X (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)

#define GS_SIGFORM_DCIN_2048_25 (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_DCIN_2048sf_24 (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_DCIN_2048sf_24X (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)

Digital cinema 2048x1080

#define GS_SIGFORM_DVI_1400_1050_24 (GS_SIGFORMSIZE_1400x1050 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

Presentation res

#define GS_SIGFORM_DVI_1400_1050_25 (GS_SIGFORMSIZE_1400x1050 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_1828_1102_24 (GS_SIGFORMSIZE_1828x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_1828_1102_25 (GS_SIGFORMSIZE_1828x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_1828_1332_24 (GS_SIGFORMSIZE_1828x1332 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_1828_1332_25 (GS_SIGFORMSIZE_1828x1332 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_1828_778_24 (GS_SIGFORMSIZE_1828x778 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_1828_778_25 (GS_SIGFORMSIZE_1828x778 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_1828_988_24 (GS_SIGFORMSIZE_1828x988 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_1828_988_25 (GS_SIGFORMSIZE_1828x988 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_2048_1102_24 (GS_SIGFORMSIZE_2048x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_2048_1102_25 (GS_SIGFORMSIZE_2048x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_2048_1234_24 (GS_SIGFORMSIZE_2048x1234 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_2048_1234_25 (GS_SIGFORMSIZE_2048x1234 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_2048_14 GS_SIGFORM_FILM_2048_15X

#define GS_SIGFORM_FILM_2048_15 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_15)

#define GS_SIGFORM_FILM_2048_1536_15 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_15)

#define GS_SIGFORM_FILM_2048_1536_15X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_14_98)

#define GS_SIGFORM_FILM_2048_1536_24 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_2048_1536_24X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)

#define GS_SIGFORM_FILM_2048_1536_48 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_48)

#define GS_SIGFORM_FILM_2048_1536_48X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_47_95)

#define GS_SIGFORM_FILM_2048_1536sf_15 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_15)

#define GS_SIGFORM_FILM_2048_1536sf_15X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_14_98)

#define GS_SIGFORM_FILM_2048_1536sf_24 (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_2048_1536sf_24X (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)

#define GS_SIGFORM_FILM_2048_15X (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_14_98)

Film transfer

#define GS_SIGFORM_FILM_2048_24 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_2048_24X (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)

#define GS_SIGFORM_FILM_2048_48 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_48)

#define GS_SIGFORM_FILM_2048_857_24 (GS_SIGFORMSIZE_2048x857 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_2048_857_25 (GS_SIGFORMSIZE_2048x857 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_2048_872_24 (GS_SIGFORMSIZE_2048x872 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_2048_872_25 (GS_SIGFORMSIZE_2048x872 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)

#define GS_SIGFORM_FILM_2048sf_15 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_15)

#define GS_SIGFORM_FILM_2048sf_15X (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_14_98)

#define GS_SIGFORM_FILM_2048sf_24 (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_2048sf_24X (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)

#define GS_SIGFORM_FILM_4096_1714_24 (GS_SIGFORMSIZE_4096x1714 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_4096_1714_24X (GS_SIGFORMSIZE_4096x1714 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)

#define GS_SIGFORM_FILM_4096_3112_24 (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_FILM_4096_3112_24X (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)

#define GS_SIGFORM_FILM_4096_3112sf_5 (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_5)

#define GS_SIGFORM_HD360 (GS_SIGFORMSIZE_960x504 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)

Signal format compressed HD 960x504 29.97.

#define GS_SIGFORM_NOT_PRESENT 0xFFFFFFFF

For input and genlock status returns.

#define GS_SIGFORM_NTSC (GS_SIGFORMSIZE_640x480 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)

Signal format NTSC square pixel (320x240 or 640x480) @ 29.97 or 30 fps gsGetSetValue::gsSignalFormat.

#define GS_SIGFORM_PAL (GS_SIGFORMSIZE_640x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)

Signal format PAL square pixel (320x288 or 640x576) @ 25 fps gsGetSetValue::gsSignalFormat.

#define GS_SIGFORM_SUPPORTS_1035 0x00000020

#define GS_SIGFORM_SUPPORTS_1080 0x00000040

#define GS_SIGFORM_SUPPORTS_1400 0x00000800

#define GS_SIGFORM_SUPPORTS_1536 0x00000100

#define GS_SIGFORM_SUPPORTS_1556 0x00000200

#define GS_SIGFORM_SUPPORTS_360 0x00000008

#define GS_SIGFORM_SUPPORTS_720 0x00000010

#define GS_SIGFORM_SUPPORTS_DCIN 0x00000400

#define GS_SIGFORM_SUPPORTS_EXTRA8 0x00000080

#define GS_SIGFORM_SUPPORTS_HR 0x00000004

#define GS_SIGFORM_SUPPORTS_NTSC 0x00000001

Supported formats

#define GS_SIGFORM_SUPPORTS_PAL 0x00000002

#define GS_SIGFORM_SUPPORTS_V1024 0x00080000

#define GS_SIGFORM_SUPPORTS_V1200 0x00100000

#define GS_SIGFORM_SUPPORTS_V1600 0x00200000

#define GS_SIGFORM_SUPPORTS_V480 0x00010000

#define GS_SIGFORM_SUPPORTS_V600 0x00020000

#define GS_SIGFORM_SUPPORTS_V768 0x00040000

#define GS_SIGFORM_SUPPORTS_X2 0x20000000

#define GS_SIGFORM_SUPPORTS_X3 0x40000000

#define GS_SIGFORM_SUPPORTS_X4 0x80000000

#define GS_SIGFORM_VESA_1024_71X (GS_SIGFORMSIZE_1024x768 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)

#define GS_SIGFORM_VESA_1024_72 (GS_SIGFORMSIZE_1024x768 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)

#define GS_SIGFORM_VESA_1280_24 (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)

#define GS_SIGFORM_VESA_1280_71X (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)

#define GS_SIGFORM_VESA_1280_72 (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)

#define GS_SIGFORM_VESA_1280i_30 (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)

#define GS_SIGFORM_VESA_1600i_30 (GS_SIGFORMSIZE_1600x1200 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)

#define GS_SIGFORM_VESA_640_72 (GS_SIGFORMSIZE_640x480 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)

VGA res

#define GS_SIGFORM_VESA_800_71X (GS_SIGFORMSIZE_800x600 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)

#define GS_SIGFORM_VESA_800_72 (GS_SIGFORMSIZE_800x600 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)

#define GS_SIGFORMFRAMERATE_10 10

#define GS_SIGFORMFRAMERATE_100 100

#define GS_SIGFORMFRAMERATE_119_88 119

#define GS_SIGFORMFRAMERATE_14_98 14

#define GS_SIGFORMFRAMERATE_15 15

#define GS_SIGFORMFRAMERATE_23_98 23

#define GS_SIGFORMFRAMERATE_24 24

#define GS_SIGFORMFRAMERATE_25 25

#define GS_SIGFORMFRAMERATE_29_97 29

#define GS_SIGFORMFRAMERATE_30 30

#define GS_SIGFORMFRAMERATE_47_95 47

#define GS_SIGFORMFRAMERATE_48 48

#define GS_SIGFORMFRAMERATE_5 5

#define GS_SIGFORMFRAMERATE_50 50

#define GS_SIGFORMFRAMERATE_59_94 59

#define GS_SIGFORMFRAMERATE_6 6

#define GS_SIGFORMFRAMERATE_60 60

#define GS_SIGFORMFRAMERATE_71_93 71

#define GS_SIGFORMFRAMERATE_72 72

#define GS_SIGFORMFRAMERATE_7_5 7

#define GS_SIGFORMFRAMERATE_CUSTOM 0x100

#define GS_SIGFORMMASK_FRAMERATE 0x000001ff

Frame rate mask (portion of return for frame rate).

#define GS_SIGFORMMASK_FRAMETYPE 0xF0000000

Frame type mask (portion of return for frame rate).

#define GS_SIGFORMMASK_HORIZONTAL 0x000ffe00

Horizontal / 8 mask (portion of return for frame rate).

#define GS_SIGFORMMASK_VERTICAL 0x0ff00000

Vertical / 8 mask (portion of return for frame rate).

#define GS_SIGFORMSHIFT_FRAMERATE 0

Shift frame rate to 0.

#define GS_SIGFORMSHIFT_FRAMETYPE 28

Frame type shift to 0.

#define GS_SIGFORMSHIFT_HORIZONTAL 9

Horizontal / 8 shift to 0.

#define GS_SIGFORMSHIFT_VERTICAL 20

Vertical / 8 shift to 0.

#define GS_SIGFORMSIZE_1024 0x30

#define GS_SIGFORMSIZE_1024x1024 ((GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1024x768 ((GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_768 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1035 0x31

#define GS_SIGFORMSIZE_1044 0x32

#define GS_SIGFORMSIZE_1050 0x34

#define GS_SIGFORMSIZE_1052 0x33

#define GS_SIGFORMSIZE_1080 0x38

#define GS_SIGFORMSIZE_1088 0x39

#define GS_SIGFORMSIZE_1096 0x3a

#define GS_SIGFORMSIZE_1102 0x3E

#define GS_SIGFORMSIZE_1152 0x40

#define GS_SIGFORMSIZE_1152x864 ((GS_SIGFORMSIZE_1152 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_864 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1200 0x41

#define GS_SIGFORMSIZE_1234 0x43

#define GS_SIGFORMSIZE_1280 0x48

#define GS_SIGFORMSIZE_1280x1024 ((GS_SIGFORMSIZE_1280 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1280x720 ((GS_SIGFORMSIZE_1280 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1332 0x49

#define GS_SIGFORMSIZE_1400 0x4B

#define GS_SIGFORMSIZE_1400x1050 ((GS_SIGFORMSIZE_1400 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1050 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1440 0x4C

#define GS_SIGFORMSIZE_1536 0x50

#define GS_SIGFORMSIZE_1556 0x51

#define GS_SIGFORMSIZE_1588 0x52

#define GS_SIGFORMSIZE_1600 0x58

#define GS_SIGFORMSIZE_1600x1200 ((GS_SIGFORMSIZE_1600 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1200 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1714 0x57

#define GS_SIGFORMSIZE_1828 0x56

#define GS_SIGFORMSIZE_1828x1102 ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1102 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1828x1332 ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1332 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1828x778 ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_778 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1828x988 ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_988 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1920 0x59

#define GS_SIGFORMSIZE_1920x1035 ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1035 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1920x1080 ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_1920x1088 ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1088 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_2048 0x60

#define GS_SIGFORMSIZE_2048x1080 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_2048x1102 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1102 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_2048x1234 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1234 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_2048x1536 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1536 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_2048x1556 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1556 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_2048x857 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_857 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_2048x872 ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_872 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_240 0x01

#define GS_SIGFORMSIZE_243 0x02

#define GS_SIGFORMSIZE_2560x1080 ((GS_SIGFORMSIZE_2650 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_2650 0x68

#define GS_SIGFORMSIZE_288 0x03

#define GS_SIGFORMSIZE_3112 0x6b

#define GS_SIGFORMSIZE_320 0x08

#define GS_SIGFORMSIZE_352 0x09

#define GS_SIGFORMSIZE_360 0x0a

#define GS_SIGFORMSIZE_4096 0x80

#define GS_SIGFORMSIZE_4096x1714 ((GS_SIGFORMSIZE_4096 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1714 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_4096x3112 ((GS_SIGFORMSIZE_4096 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_3112 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_480 0x10

#define GS_SIGFORMSIZE_483 0x11

#define GS_SIGFORMSIZE_486 0x12

#define GS_SIGFORMSIZE_496 0x14

#define GS_SIGFORMSIZE_504 0x16

#define GS_SIGFORMSIZE_512 0x17

#define GS_SIGFORMSIZE_576 0x1a

#define GS_SIGFORMSIZE_600 0x1b

#define GS_SIGFORMSIZE_608 0x1c

#define GS_SIGFORMSIZE_640 0x20

#define GS_SIGFORMSIZE_640x480 ((GS_SIGFORMSIZE_640 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_480 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_640x576 ((GS_SIGFORMSIZE_640 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_720 0x21

#define GS_SIGFORMSIZE_720x480 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_480 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_720x483 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_483 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_720x486 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_486 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_720x504 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_504 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_720x512 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_512 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_720x576 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_720x608 ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_608 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_768 0x22

#define GS_SIGFORMSIZE_778 0x2A

#define GS_SIGFORMSIZE_800 0x23

#define GS_SIGFORMSIZE_800x600 ((GS_SIGFORMSIZE_800 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_600 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_857 0x26

#define GS_SIGFORMSIZE_864 0x24

#define GS_SIGFORMSIZE_872 0x2B

#define GS_SIGFORMSIZE_960 0x28

#define GS_SIGFORMSIZE_960x486 ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_486 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_960x504 ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_504 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_960x576 ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))

#define GS_SIGFORMSIZE_968 0x29

#define GS_SIGFORMSIZE_988 0x25

#define GS_SIGFORMTYPE_INTERLACED (1 << GS_SIGFORMSHIFT_FRAMETYPE)

#define GS_SIGFORMTYPE_PROGRESSIVE (2 << GS_SIGFORMSHIFT_FRAMETYPE)

#define GS_SIGFORMTYPE_SEGMENTEDFRAME (4 << GS_SIGFORMSHIFT_FRAMETYPE)

#define GS_SIGFORMTYPE_UNKNOWN (0)

#define GS_SUPFILE_ANY 0x80000000

Any supported mediareactor format (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_SUPFILE_AUDONLY 0x00010000

Audio only or separate audio formats (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_SUPFILE_AVI 0x00000001

Standard Windows AVI container (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_SUPFILE_FIX 0x00000100

Drastic Fixed Frame container (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_SUPFILE_ODML 0x00000002

OpenDML AVI container (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_SUPFILE_OMFI 0x00000008

Avid Open Media Format container (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_SUPFILE_QT 0x00000004

Quicktime Mov/MooV container (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_SUPFILE_STILLS 0x00100000

Series of still file formats (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_SUPFILE_UNK 0x40000000

Other unspecified formats (gsGetSetValue::gsSupportedFileTypes gsGetSetValue::gsIgnoreFileTypes) gsGetSetValue::gsRecFileFormat gsGetSetValue::gsRecAudFileFormat gsGetSetValue::gsConvertFileFormat gsGetSetValue::gsConvertAudFileFormat

#define GS_TCSOURCE_CLIP 7

For cmdGetSetValue::gsTcSource - Using absolute clip.

#define GS_TCSOURCE_CTL 4

For cmdGetSetValue::gsTcSource - Using CTL.

#define GS_TCSOURCE_LTC 1

For cmdGetSetValue::gsTcSource - Using LTC.

#define GS_TCSOURCE_VITC 2

For cmdGetSetValue::gsTcSource - Using VITC.

#define GS_TRUE 0x01

True for boolean cmdType::ctGetValue, cmdType::ctSetValue

#define GS_UNITY 0xFFFFFFFF

Set value to unity (levels, tbc) or default (compression type, amount).

#define GS_UPCONVERT_ANAMORPHIC 0x0000

Upconvert to whole screen.

#define GS_UPCONVERT_LETTERBOX 0x0004

Upconvert to letter box.

#define GS_UPCONVERT_PILLARBOX 0x0001

Upconvert with bars.

#define GS_UPCONVERT_ZOOM14x9 0x0002

Upconvert with some zoom.

#define GS_UPCONVERT_ZOOMWIDE 0x0005

Upconvert to wide zoom.

#define GS_USERRIGHTS_ADD 0x0100

#define GS_USERRIGHTS_ADMIN 0x8000

#define GS_USERRIGHTS_DELETE 0x0200

#define GS_USERRIGHTS_FULL 0x7FFF

#define GS_USERRIGHTS_MODIFY 0x0002

#define GS_USERRIGHTS_NONE 0x0000

#define GS_USERRIGHTS_PLAY 0x0010

#define GS_USERRIGHTS_READ 0x0001

#define GS_USERRIGHTS_RECORD 0x0020

#define GS_USERRIGHTS_SETUP 0x0008

#define GS_USERRIGHTS_WRITE 0x0004

#define GS_VIDBAND_HIGH 0x04

Allow high bandwidth (gsGetSetValue::gsVidInBandwidth gsGetSetValue::gsVidBandwidth).

#define GS_VIDBAND_MEDIUM 0x02

Allow medium bandwidth (gsGetSetValue::gsVidInBandwidth gsGetSetValue::gsVidBandwidth).

#define GS_VIDBAND_NOTCH 0x08

Impose notch filter on bandwidth (gsGetSetValue::gsVidInBandwidth gsGetSetValue::gsVidBandwidth).

#define GS_VIDBAND_STANDARD 0x01

Allow normal bandwidth (gsGetSetValue::gsVidInBandwidth gsGetSetValue::gsVidBandwidth).

#define GS_VIDBLACK_CRYSTAL 0x02

Crystal black level (0 IRE NTSC, 0 IRE PAL) gsGetSetValue::gsVidBlackSetup gsGetSetValue::gsVidInBlack.

#define GS_VIDBLACK_SETUP 0x01

Black at normal level (7.5 IRE NTSC, 0 IRE PAL) gsGetSetValue::gsVidBlackSetup gsGetSetValue::gsVidInBlack.

#define GS_VIDBLACK_SUPER 0x04

Super black level (0 > IRE NTSC/PAL) gsGetSetValue::gsVidBlackSetup gsGetSetValue::gsVidInBlack.

#define GS_VIDFREEZE_FIELD0 1

Freeze - first (0) field (cmdGetSetValue::gsVidFreeze).

#define GS_VIDFREEZE_FIELD1 2

Freeze - second (1) field (cmdGetSetValue::gsVidFreeze).

#define GS_VIDFREEZE_FRAME 3

Freeze - both fields (cmdGetSetValue::gsVidFreeze).

#define GS_VIDFREEZE_NOT_FROZEN 0

Freeze - no freeze (cmdGetSetValue::gsVidFreeze).

#define GS_VIDLOCKTYPE_BROADCAST 2

Perfect lock for cmdGetSetValue::gsVidInLockType cmdGetSetValue::gsVidOutLockType cmdGetSetValue::gsVidOutLockType.

#define GS_VIDLOCKTYPE_VTR 1

VTR (unruly hsync) lock for cmdGetSetValue::gsVidInLockType cmdGetSetValue::gsVidOutLockType cmdGetSetValue::gsVidOutLockType.

#define GS_VIDREF_DISABLE 0x00000000

Disable video reference (gsGetSetValue::gsVidRefDisable).

#define GS_VIDREF_ENABLE 0x00000001

Enable video reference (gsGetSetValue::gsVidRefDisable).

#define GS_VIDSELECT_COMPONENT_RGB 0x080

RGB at video standard rate (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPONENT_YUV 0x010

BetaCam level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPONENT_YUV_2 0x2000

Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPONENT_YUV_JAPAN 0x20000

BetaCam level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPONENT_YUV_M2 0x020

Panasonic M2 level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPONENT_YUV_SMPTE 0x040

SMPTE standard level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPONENT_YUV_SMPTE_JAPAN 0x40000

SMPTE standard level YCrCb NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPOSITE 0x001

Standard NTSC or PAL composite video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPOSITE_2 0x004

Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_COMPOSITE_3 0x008

third NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect)

#define GS_VIDSELECT_COMPOSITE_4 0x800

Extra fro Digital Rapids--order is screwed up but as long as it works I guess Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect)

#define GS_VIDSELECT_COMPOSITE_JAPAN 0x8000

Standard NTSC or PAL composite video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_D1_PARALLEL 0x200

D1 Serial Parallel video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_D1_SERIAL 0x100

D1 Serial Digital or HDSDI video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_D1_SERIAL_2 0x4000

Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_NONE 0

No video available or no configuratable settings (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_SDTI 0x400

SDTI/SDI including high speed transfer video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_SVIDEO 0x002

SVHS/S-Video four wire NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_SVIDEO_2 0x1000

Secondary NTSC or PAL video (often monitor selection) (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_SVIDEO_JAPAN 0x10000

SVHS/S-Video four wire NTSC or PAL video (cmdGetSetValue::gsVidInSelect cmdGetSetValue::gsVidOutSelect).

#define GS_VIDSELECT_XVID_RGB 0x80000

xVGA compatible analog RGB

#define GS_VIDWHITE_CLAMP 0x01

Whites are clamped or 100 IRE (gsGetSetValue::gsVidInWhite).

#define GS_VIDWHITE_FREE 0x04

Whites are allowed to be greater then 100 IRE (gsGetSetValue::gsVidInWhite).

#define GS_VIDWHITE_SCALE 0x02

Whites are scaled automatically from black level to 100 IRE (gsGetSetValue::gsVidInWhite).

#define infChanAll 0xFFFFFFFF

#define INIT_MEDIACMD ( __mCmd_ )

Value:

{                                               \
        memset(&__mCmd_,0, sizeof(MEDIACMD));                           \
        __mCmd_.dwCmdID = MEDIACMD_CURRENT;                                     \
        __mCmd_.dwStructSize = sizeof(MEDIACMD);                        \
        __mCmd_.dwChannel = CHAN_ILLEGAL;                                       \
        __mCmd_.lSpeed = SPD_ILLEGAL;                                           \
        __mCmd_.dwVideoChannels = (DWORD)vidChanAll;            \
        __mCmd_.dwAudioChannels = (DWORD)audChanAll;            \
        __mCmd_.dwInfoChannels = (DWORD)infChanAll;                     \
        __mCmd_.dwCmdAlt = 0;                                                           \
        __mCmd_.dwPosition = TC_ILLEGAL;                                        \
        __mCmd_.dwStart = TC_ILLEGAL;                                           \
        __mCmd_.dwEnd = TC_ILLEGAL;     }
Initailize a media cmd structure to all illegal (no command).

#define INIT_PMEDIACMD ( __mCmd_ )

Value:

{                                                       \
        memset(__mCmd_, 0,sizeof(MEDIACMD));                                    \
        ((PMEDIACMD)__mCmd_)->dwCmdID = MEDIACMD_CURRENT;               \
        ((PMEDIACMD)__mCmd_)->dwStructSize = sizeof(MEDIACMD);  \
        ((PMEDIACMD)__mCmd_)->dwChannel = CHAN_ILLEGAL;                 \
        ((PMEDIACMD)__mCmd_)->lSpeed = SPD_ILLEGAL;                             \
        ((PMEDIACMD)__mCmd_)->dwVideoChannels = (DWORD)vidChanAll;              \
        ((PMEDIACMD)__mCmd_)->dwAudioChannels = (DWORD)audChanAll;              \
        ((PMEDIACMD)__mCmd_)->dwInfoChannels = (DWORD)infChanAll;               \
        ((PMEDIACMD)__mCmd_)->dwCmdAlt = CHAN_ILLEGAL;                  \
        ((PMEDIACMD)__mCmd_)->dwPosition = TC_ILLEGAL;                  \
        ((PMEDIACMD)__mCmd_)->dwStart = TC_ILLEGAL;                             \
        ((PMEDIACMD)__mCmd_)->dwEnd = TC_ILLEGAL;       }
Initailize a media cmd pointer to all illegal (no command).

#define MEDIACMD_CHECK_MASK 0xFFFF0000UL

Mask for permanent magic number of command id. see MEDIACMD::dwCmdID.

#define MEDIACMD_CHECK_VER 0xFA250000UL

Permanent magic number of command id. see MEDIACMD::dwCmdID.

#define MEDIACMD_CURRENT (MEDIACMD_VERSION_MAJOR | MEDIACMD_VERSION_MINOR | MEDIACMD_CHECK_VER)

Current version and magic number. Place in MEDIACMD::dwCmdID.

#define MEDIACMD_VERSION_MAJOR 0x0101UL

Major command versioning for upgrades to the command set. see MEDIACMD::dwCmdID.

#define MEDIACMD_VERSION_MASK 0xFFFFUL

Mask for checking the command set version. see MEDIACMD::dwCmdID.

#define MEDIACMD_VERSION_MINOR 0x0003UL

Minor command versioning for upgrades to the command set. see MEDIACMD::dwCmdID.

#define pCmdQueueElem PMEDIACMD

Old name, use PMEDIACMD instead.

#define SIZEOF_MEDIACMD sizeof(MEDIACMD)

SizeOf a complete mediacmd structure.

#define SIZEOF_MEDIACMD_BASE CMD_QUEUE_ELEMSIZE

SizeOf basic mediacmd structure without any clip id.

#define SIZEOF_MEDIACMD_CLIPID (CMD_QUEUE_ELEMSIZE + 9)

SizeOf mediacmd structure with a 8 byte clip id and terminating 0.

#define SPD_FAST_BUMP 114660L

MAx speed for bumping.

#define SPD_FWD_MAX 5896800

Maximum possible play speed in VVW see MEDIACMD::lSpeed.

#define SPD_FWD_PLAY 65520L

Forward play speed (normal) in VVW (65520) see MEDIACMD::lSpeed.

#define SPD_ILLEGAL 2147483647L

Illegal speed, set MEDIACMD::lSpeed to this value if not used.

#define SPD_PAUSE 0L

Pause speed (0%) in VVW (0) see MEDIACMD::lSpeed.

#define SPD_REV_MAX (-SPD_FWD_MAX)

Minimum possible play speed in VVW see MEDIACMD::lSpeed.

#define SPD_REV_PLAY (-SPD_FWD_PLAY)

Reverse play speed (-100%) in VVW (-65520) see MEDIACMD::lSpeed.

#define SPD_SLOW_BUMP 32760l

Min Sped for buimping.

#define TC_ILLEGAL 0xFFFFFFFFUL

Illegal time code reference, set MEDIACMD::dwPosition, MEDIACMD::dwStart, MEDIACMD::dwEnd to this if not used.

#define vidChanAll 0xFFFFFFFF

#define VIDEOWRITETYPE_4224 0x00010000

#define VIDEOWRITETYPE_AVI 0x00000001

#define VIDEOWRITETYPE_BMP 0x00000800

#define VIDEOWRITETYPE_CIN 0x00002000

#define VIDEOWRITETYPE_DPX 0x00004000

#define VIDEOWRITETYPE_DVS 0x00000020

#define VIDEOWRITETYPE_GEN 0x00000008

#define VIDEOWRITETYPE_HDR 0x00000080

#define VIDEOWRITETYPE_IHSS 0x00000040

#define VIDEOWRITETYPE_JS 0x00000010

#define VIDEOWRITETYPE_MOV 0x00000002

#define VIDEOWRITETYPE_MPG 0x00008000

#define VIDEOWRITETYPE_RAW 0x00000200

#define VIDEOWRITETYPE_TGA 0x00000400

#define VIDEOWRITETYPE_TIFF 0x00001000

#define VIDEOWRITETYPE_WMV 0x00000004

#define VIDEOWRITETYPE_YUV 0x00000100

Typedef Documentation

typedef struct MEDIACMD * PMEDIACMD

Enumeration Type Documentation

enum cmdAudChan

Audio channel bit array for MEDIACMD::dwAudioChannels

Enumerator:
audChan0
audChan1
audChan2
audChan3
audChan4
audChan5
audChan6
audChan7
audChan8
audChan9
audChan10
audChan11
audChan12
audChan13
audChan14
audChan15
audChan16
audChan17
audChan18
audChan19
audChan20
audChan21
audChan22
audChan23
audChan24
audChan25
audChan26
audChan27
audChan28
audChan29
audChan30
audChan31
audChanAll

enum cmdFlags

Flags that modify cmdType in the MEDIACMD structure. Mostly used to specify which fields in the structure are valid.

Enumerator:
cfDeferred Delay this command until the end of the previous one. This is the method for playing back clips non-linearly. Send one clip to play, then send each clip after it with this flag set and they will play seemlessly back to back.
In the case of ctInsert, the deferred indicates that the clip to be inserted will be translated from its current location to the current record directory and then added to the bin/tcspace.
cfOverideDeferred Delay the command, as in cfDeferred, but kill any other waiting commands and use this command as soon as the current command completes.
cfTimeMs Time is in milliseconds. Applies only to the MEDIACMD::dwCmdAlt member. The millisecond reference is derived from the performance counter (or one extremely old machines timeGetTime()) via vsynceGetCurMs() which is implemented in DSync.dll for user and kernal modes. The defualt timing without this flags set is in video frames.
cfTimeTarget Time is set for event occurance. This means the command will occur when the time specified is reached. If this flag is not set and cfTimeMs is set, then the time indicates the time the command was recieved and may be used for a deterministic offset. May be in frames (default) or milliseconds cfTimeMs, requires cfUseCmdAlt.
cfTimeHouseClock Time reference is the system clock (time of day) not the performance clock. This is used to sync network or serial based communication where there is no relationship between performance clocks. For proper operation, the two devices must be genlocked to the same video source, which VVW will interpolate with the correcte system clock to keep everything together. Note: This is only as accurate as the genlock readers an LTC or Network time transport connected to BOTH machines. In general, a pair of VVWs are accurate to 1 field, which is ample for editing and broadcast insertion
cfUseSpeed Means the MEDIACMD::lSpeed member is valid.
cfUsePresets Means the MEDIACMD::dwVideoChannels, MEDIACMD::dwAudioChannels and MEDIACMD::dwInfoChannels members are valid.
cfUsePosition Means the MEDIACMD::dwPosition member is valid.
cfUsePositionOffset Means the MEDIACMD::dwPosition member is valid and should be used as a long (signed) against the current channel position counter.
cfUseStart Means the MEDIACMD::dwStart member is valid.
cfUseStartOffset Means the MEDIACMD::dwStart member is valid and should be used as a long (signed) against the current channel position counter.
cfUseEnd Means the MEDIACMD::dwEnd member is valid.
cfUseEndOffset Means the MEDIACMD::dwEnd member is valid and should be used as a long (signed) against the current channel position counter.
cfUseAllIDs Causes the command to act on all IDs in the system. Used for clipspace to delete all ids quickly.
cfUseClipID Means the MEDIACMD::arbID member is valid.
cfCopy Copy the media to the current record folder when inserting
cfNoClipFiles Means the command should not be used on any clip or clip spaces
cfConvert Convert the media to the current record folder when inserting
cfNoTCSpaces Means the command should not be used on any clip within or the TCSpace itself
cfUseCmdAlt Means the MEDIACMD::dwCmdAlt is valid
cfIsShuttle Sent by shuttle/jog/var controllers for drivers that require a special play state that take too much time to get into. If this flag is true, the command is a shuttle and true play does not need to be used
cfUsingCurrent If set then elements that are not illegal are current at the reception of the command
If cfUsePosition and cfUsePositionOffset are NOT set and MEDIACMD::dwPosition is not TC_ILLEGAL, then it is the current position when the command was recieved
If cfUseStart and cfUseStartOffset are NOT set and MEDIACMD::dwStart is not TC_ILLEGAL, then it is the current start location when the command was recieved
If cfUseEnd and cfUseEndOffset are NOT set and MEDIACMD::dwEnd is not TC_ILLEGAL, then it is the current end time when the command was recieved
If cfUseSpeed is set are NOT set and MEDIACMD::lSpeed is not SPD_ILLEGAL, then it is the current speed when the command was recieved
If cfUsePresets is NOT set and MEDIACMD::dwAudioChannels, MEDIACMD::dwVideoChannels and MEDIACMD::dwInfoChannels are not 0xFFFFFFFF, then they are the current presets when the command was recieved
If cfUseClipID is NOT set and MEDIACMD::arbID[0] is not equal to NULL (""), then it is the current clip id when the command was recieved. If MEDIACMD::arbID[9] is not equal to NULL ("") then it is the current file name when the command was recieved.
cfUseFrameCount If set then MEDIACMD::dwPosition, MEDIACMD::dwStart and MEDIACMD::dwEnd are absolute (0 based) frame counts, else they are the current type (CTL/CLIP(frame count) of LTC/VITC(time code offset)).
cfFields If set then MEDIACMD::dwPosition, MEDIACMD::dwStart and MEDIACMD::dwEnd should be interpreted as fields, not frames, if they are valid
cfRipple Close up any holes created by this command. Most importantly cmdType::ctDelete, cmdType::ctBlank, cmdType::ctInsert and cmdType::ctTrim.
cfLoop Command should be looped. Mostly used for loop playback where an start and end are specified. The play will begin at the start, proceed to the end, and once reached loop back to the start again.
cfTrigger INTERNAL - Allows one channel to setup a DSync trigger with another. Use cmdType::ctTransfer instead as this is very inefficient for non local command transports.
cfPreview This command is part of a preview. Either it notes a channel change (pass through to emulate an edit) or that the playback does not have to be consistant and frame accurate. Also returned if the channel can only produce preview quality playback (eg. VGA playback of HDTV media without hardware assist).
cfInvert For cmdType::ctTransfer, invert the source and target. Use to allow an external device (such as a VTR) to always master the transfer procedure. Because of the high latency and poor ballistics of all VTRs, the internal transfer slaves to it regardless of whether it is is the source of target of the transfer.
cfTest Means do not act on this command, but return GS_NOT_SUPPORTED in dwPosition if you cannot handle it. Used to determine basic capabilities of the channel. For instance, if its an MPEG2 playback channel, it can't record but if it has a passthrough, it may be able to stop. Using cfTest with cmdType::ctRecord, cmdType::ctStop will tell the caller this so the interface may be adjusted accordingly.
Caution: This flag has not been tested with all transport types. Avoid for now.
cfNoReturn Instucts the channel that no return is required. The channel then has the option of remembering the command and acting on it within a reasonable time. This means the caller does not know if the command completed successfully at return time, but the status should be monitored anyways to figure that out. Especially when long time functions like a VTR seek will return that the command was successfully initiated, but not wait for the completion of the seek, regardless of this flag.

enum cmdGetSetValue

Enum sent in MEDIACMD::dwCmdAlt for the commands cmdType::ctGetValue, cmdType::ctSetValue, cmdType::ctValueSupported.
ctGetValue will return information in the mediacmd per this document
ctSetValue will change the state of the channel using the members of mediacmd per this document
ctValueSupport will return GS_NOT_SUPPORTED in MEDIACMD::dwPosition if it NOT supported. If it is supported, MEDIACMD::dwPosition will be set to some other value

NOTE:
  • 'nada' is spanish for nothing and is used here to indicate that the command is not supported.
  • Time Code - There are three main time code types, each with their own user bit information. The 0 based absolute time code is refered to by 'Tc' and 'Ub'. The LTC (longitudinal time code or SMPTE time code often sent via audio) is refered to by 'LtcTc' and 'LtcUb'. The VITC (vertical interval time code, usually encoded in the vertical blank area of the video signal) is refered to by 'VitcTc' and VitcUb'. Not all devices will support all types or the user bits value for some types. Use value supported to determin support
Enumerator:
gsTc Current internal time - control or clip absolute zero based time code (0..total frames exclusive)
  • cmdType::ctSetValue
    nada
  • cmdType::ctGetValue
    MEDIACMD::dwPosition
gsUb Current internal user bits
  • cmdType::ctSetValue
    nada
  • cmdType::ctGetValue
    MEDIACMD::dwPosition
gsLtcTc Current LTC time
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - to set vitc generator for next gen (record) if in preset mod
  • cmdType::ctGetValue
    MEDIACMD::dwPosition
gsLtcUb Current LTC user bits
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - to set ltc generator
  • cmdType::ctGetValue
    MEDIACMD::dwPosition
gsVitcTc Current VITC time
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - to set ltc generator
  • cmdType::ctGetValue
    MEDIACMD::dwPosition
gsVitcUb Current VITC user bits
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - to set vitc generator
  • cmdType::ctGetValue
    MEDIACMD::dwPosition
gsTcSource Current time code source
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_TCSOURCE_LTC, GS_TCSOURCE_VITC, GS_TCSOURCE_CTL or GS_TCSOURCE_CLIP
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_TCSOURCE_LTC, GS_TCSOURCE_VITC, GS_TCSOURCE_CTL or GS_TCSOURCE_CLIP
    MEDIACMD::dwStart - supported types using bit array of above
gsTcType Current time code type
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TC2_TCTYPE_FILM, TC2_TCTYPE_NDF, TC2_TCTYPE_DF, TC2_TCTYPE_PAL, TC2_TCTYPE_50, TC2_TCTYPE_5994, TC2_TCTYPE_60, TC2_TCTYPE_NTSCFILM, TC2_TCTYPE_2398, TC2_TCTYPE_100
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - TC2_TCTYPE_FILM, TC2_TCTYPE_NDF, TC2_TCTYPE_DF, TC2_TCTYPE_PAL, TC2_TCTYPE_50, TC2_TCTYPE_5994, TC2_TCTYPE_60, TC2_TCTYPE_NTSCFILM, TC2_TCTYPE_2398, TC2_TCTYPE_100
    MEDIACMD::dwStart - supported types using bit array of above
gsStart Lowest possible time code frame
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New minimum value
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current minimum value
    MEDIACMD::dwStart - Absolute minimum possible value (usually 0)
gsEnd Highest possible time code frame plus 1 (out is never included)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New maximum value + 1
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current maximum value + 1
    MEDIACMD::dwStart - Absolute maximum possible value (usually clip end + 1)
gsIn Current mark in time set by any caller
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New in time
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current in time
gsLastIn Previous (currently non active) mark in time set by RS-422 protocol
  • cmdType::ctSetValue
    - not supported (internal)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - last known in time
gsOut Current mark out time set by any caller
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New out time
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current out time
gsLastOut Previous (currently non active) mark out time set by RS-422 protocol
  • cmdType::ctSetValue
    - not supported (internal)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - last known out time
gsEditOn Number of frames from edit on command to start of record (usually 4~7)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New number of frames
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current number of frames
gsEditOff Number of frames from edit off command to end of record (usually 4~7) should match gsEditOn in most cases
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New number of frames
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current number of frames
gsPreroll Number of frames to preroll before in point for an edit
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New number of frames
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current number of frames
gsPostroll Number of frames to postroll after an out point for an edit
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New number of frames
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current number of frames
gsAutoMode Switch from normal mode to auto mode. For sony vtr emulation it sets up Pioneed dual head emulation. For Louth and Odetics enables preview play look ahead for seemless clip playback
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_TRUE or GS_FALSE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current auto mode state as above
gsPlayDelay Number of frames from recieving play command to actual play
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New number of frames
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current number of frames
gsLtcTcPreset LTC time code preset (generator preset)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - to set generator for the next next record. Will be used not in regen mode.
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - returns the current generator preset.
gsLtcUbPreset LTC user bit preset (generator preset)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - to set generator for the next next record. Will be used not in regen mode.
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - returns the current generator preset.
gsVitcTcPreset VITC time code preset (generator preset)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - to set generator for the next next record. Will be used not in regen mode.
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - returns the current generator preset.
gsVitcUbPreset VITC time code preset (generator preset)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - to set generator for the next next record. Will be used not in regen mode.
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - returns the current generator preset.
gsFrameData Returns the block of data for a frame
  • cmdType::ctSetValue
    Not really used at this point
  • cmdType::ctGetValue
    MEDIACMD::arbID - The data block
    MEDIACMD::dwEnd - The size of the data block (0..n)
    MEDIACMD::dwPosition - The expected type of data
gsGetNextClip Return the next clip in the current clip space. If the previous clip is set to NULL then return the first clip in the list.
  • cmdType::ctSetValue
    - not supported
  • cmdType::ctGetValue
    -in- MEDIACMD::arbID - Last returned clip id or 8 NULLs for first clip
    -out- MEDIACMD::arbID - Next 8 character id or 8 NULLs if clip list complete
    for MCMD2 -out- MEDIACMD::arbID - Next 8 character id and unc file path seperated by NULL or 8 NULLs if clip list complete
    MEDIACMD::dwPosition - Current position in the clip
    MEDIACMD::dwStart - First frame of clip
    MEDIACMD::dwEnd - Last frame of clip
gsFirstClip Obsolete - use gsGetNextClip
  • cmdType::ctSetValue
    - not supported in new drivers
  • cmdType::ctGetValue
    - not supported in new drivers
gsNextClip Obsolete - use gsGetNextClip
  • cmdType::ctSetValue
    - not supported in new drivers
  • cmdType::ctGetValue
    - not supported in new drivers
gsTCSGetTLClipState Return the next state info when working through a time code space time line to retrieve all the edits in order. The state uses MEDIACMD::dwPosition, MEDIACMD::dwVideoChannels, MEDIACMD::dwAudioChannels, MEDIACMD::dwInfoChannels to maintain the state (Please note that MEDIACMD::arbID is reserved and must be maintained between calls). The dwPosition describes the current position in the time line and the channel bits are set for channels already returned. See gsTCSGetTLNextClip for more info
  • cmdType::ctSetValue
    - not supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current time line position
    MEDIACMD::dwVideoChannels - Video channels used so far
    MEDIACMD::dwAudioChannels - Audio channels used so far
    MEDIACMD::dwInfoChannels - Info channels used so far
gsTCSGetTLClipInfo CALL Pos Start End V A I arbID gsTCSGetTLClipInfo 0 x x 0 0 0 x - Restart at 0 Rtn 0 0 300 1 2 0 file1 - 10 sec VA2 from file1 gsTCSGetTLNextState 0 0 0 0 - First state 0 Rtn 0 1 2 0 - First clip channels ( Copy prev gsTCSGetTLNextState into gsTCSGetTLClipInfo before sending ) gsTCSGetTLClipInfo 0 1 2 0 - Last get state Rtn 0 0 150 0 1 0 file2 - 5 sec A1 from file2 ( Use last gsTCSGetTLNextState for this call ) gsTCSGetTLNextState 0 1 2 0 - Use last state to get next Rtn 0 1 3 0 - Channels used so far ( Copy prev gsTCSGetTLNextState into gsTCSGetTLClipInfo before sending ) gsTCSGetTLClipInfo 0 1 3 0 - Last get state Rtn 150 150 210 0 1 0 file3 - 2 sec A1 from file3 ( Use last gsTCSGetTLNextState for this call ) gsTCSGetTLNextState 0 1 3 0 - Use last state to get next Rtn 150 0 1 0 - Channels used so far Take the MEDIACMD struct returned from gsTCSGetTLClipState and find the next active clip. For the first clip in time line, send all zeroes. Other then the first call, all calls should include the position/channel bits from the previous gsTCSGetTLNextState call and (other then first call) gsTCSGetTLNextState should be call immeadiately before gsTCSGetTLClipInfo.
  • cmdType::ctSetValue
    - not supported
  • cmdType::ctGetValue
    MEDIACMD::arbID - Clip ID
    for MCMD2 -out- MEDIACMD::arbID - Next 8 character id and unc file path seperated by NULL or 8 NULLs if clip list complete
    MEDIACMD::dwPosition - Reference time code for time line
    MEDIACMD::dwStart - First frame of clip
    MEDIACMD::dwEnd - Last frame of clip
    MEDIACMD::dwVideoChannels - Channels this clip exists in for the dwStart/dwEnd range
    MEDIACMD::dwAudioChannels - Channels this clip exists in for the dwStart/dwEnd range
    MEDIACMD::dwInfoChannels - Channels this clip exists in for the dwStart/dwEnd range
gsClipInfo Get or change the information on a clip (currently for clip space only)
  • cmdType::ctSetValue
    - not supported
  • cmdType::ctGetValue
    MEDIACMD::arbID - Last returned clip id or 8 NULLs for first clip
    for MCMD2 -out- MEDIACMD::arbID - Next 8 character id and unc file path seperated by NULL or 8 NULLs if clip list complete
    MEDIACMD::dwPosition - Starting timecode if known, else First frame of clip
    MEDIACMD::dwStart - First frame of clip
    MEDIACMD::dwEnd - Last frame of clip
    MEDIACMD::dwVideoChannels - Channels this clip exists in for the dwStart/dwEnd range
    MEDIACMD::dwAudioChannels - Channels this clip exists in for the dwStart/dwEnd range
    MEDIACMD::dwInfoChannels - Channels this clip exists in for the dwStart/dwEnd range
gsClipCopy Create a virtual copy of a clip from a current clip. Must change at least name to succeed. To affect the source clip, use gsClipInfo
  • cmdType::ctSetValue
    Requires MEDIACMD::cfFlags set to affect stored clip info for each member
    MEDIACMD::arbID - Source ClipID[8 bytes], NULL, New ClipID[8 bytes] - min size 17 bytes.
    MEDIACMD::dwStart - First frame of new clip (referenced from source clip)
    MEDIACMD::dwEnd - Last frame of new clip (referenced from source clip)
    MEDIACMD::dwVideoChannels - Channels this clip exists in for the dwStart/dwEnd range
    MEDIACMD::dwAudioChannels - Channels this clip exists in for the dwStart/dwEnd range
    MEDIACMD::dwInfoChannels - Channels this clip exists in for the dwStart/dwEnd range
  • cmdType::ctGetValue
    - no supported
gsAudChan Returns the available audio channels (read only)
  • cmdType::ctSetValue
    - no supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Available channels
gsVidChan Returns the available video channels (read only)
  • cmdType::ctSetValue
    - no supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Available channels
gsInfChan Returns the available information channels (read only)
  • cmdType::ctSetValue
    - no supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Available channels
gsAudSelect Return or set the selected audio channels
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New channel selection
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently selected channels
    MEDIACMD::dwStart - Available channels for selection
gsVidSelect Return or set the selected video channels
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New channel selection
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently selected channels
    MEDIACMD::dwStart - Available channels for selection
gsInfSelect Return or set the selected information channels
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New channel selection
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently selected channels
    MEDIACMD::dwStart - Available channels for selection
gsAudEdit Return or set the audio channels for the next edit
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New channel edit selection
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently selected edit channels
    MEDIACMD::dwStart - Available channels for edit
gsVidEdit Return or set the video channels for the next edit
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New channel edit selection
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently selected edit channels
    MEDIACMD::dwStart - Available channels for edit
gsInfEdit Return or set the information channels for the next edit
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New channel edit selection
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently selected edit channels
    MEDIACMD::dwStart - Available channels for edit
gsEditMode Return or set the information channels for the next edit
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New channel edit selection
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently selected edit channels
    MEDIACMD::dwStart - Available channels for edit
gsMetaData Access one meta data element for the current media.
See the enum vvwInfoMetaTypes in vwwTypes.h
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwEnd - GS_TRUE if the element exists, GS_NOT_SUPPORTED if not
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwEnd - GS_TRUE if the element exists, GS_NOT_SUPPORTED if not
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
gsMetaDataDirectory Access one meta data element for the directory of the current media (./Default.xml).
See the enum vvwInfoMetaTypes in vwwTypes.h
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
gsMetaDataVolume Access one meta data element for the drive/volume of the current media (/Default.xml).
See the enum vvwInfoMetaTypes in vwwTypes.h
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
gsMetaDataCurrentUser Access one meta data element for the defult metadata of the current user (HKEY_CURRENT_USER windows, /home/user/default.xml unix).
See the enum vvwInfoMetaTypes in vwwTypes.h
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
gsMetaDataLocalMachine Access one meta data element for the defult metadata of the current user (HKEY_LOCAL_MACHINE windows, /var/metadata/default.xml unix).
See the enum vvwInfoMetaTypes in vwwTypes.h
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
gsMetaDataGlobal Access one meta data element for the defult metadata for the facility (Requires group or facility media proxy and database).
See the enum vvwInfoMetaTypes in vwwTypes.h
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - ID = vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::dwStart - value for vvwInfoMetaTypes::vvwiTimeCode .. vvwInfoMetaTypes::vvwiGamma1000
    MEDIACMD::arbID - value for vvwInfoMetaTypes::vvwiFileName .. vvwInfoMetaTypes::vvwiFrameAttribute
gsAudInSelect Audio input select
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New audio input GS_AUDSELECT_UNBALANCED_10 GS_AUDSELECT_UNBALANCED_4 GS_AUDSELECT_BALANCED_10 GS_AUDSELECT_BALANCED_4 GS_AUDSELECT_SPDIF GS_AUDSELECT_AES_EBU GS_AUDSELECT_EMBEDDED
    MEDIACMD::dwAudioChannels - Channels effected
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current input GS_AUDSELECT_UNBALANCED_10 GS_AUDSELECT_UNBALANCED_4 GS_AUDSELECT_BALANCED_10 GS_AUDSELECT_BALANCED_4 GS_AUDSELECT_SPDIF GS_AUDSELECT_AES_EBU GS_AUDSELECT_EMBEDDED
    MEDIACMD::dwStart - Bit array of available inputs, see above or GS_AUDSELECT_NONE
    MEDIACMD::dwAudioChannels - Channels requested
gsAudOutSelect Audio output select (in general all outputs are active)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New audio output GS_AUDSELECT_UNBALANCED_10 GS_AUDSELECT_UNBALANCED_4 GS_AUDSELECT_BALANCED_10 GS_AUDSELECT_BALANCED_4 GS_AUDSELECT_SPDIF GS_AUDSELECT_AES_EBU GS_AUDSELECT_EMBEDDED
    MEDIACMD::dwAudioChannels - Channels effected
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current output GS_AUDSELECT_UNBALANCED_10 GS_AUDSELECT_UNBALANCED_4 GS_AUDSELECT_BALANCED_10 GS_AUDSELECT_BALANCED_4 GS_AUDSELECT_SPDIF GS_AUDSELECT_AES_EBU GS_AUDSELECT_EMBEDDED
    MEDIACMD::dwStart - Bit array of available outputs, see above or GS_AUDSELECT_NONE
    MEDIACMD::dwAudioChannels - Channels requested
gsAudInputLevel Audio input level (gain)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Level (0-65535)
    MEDIACMD::dwAudioChannels - Channels affected
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Level (0-65535)
    MEDIACMD::dwStart - Minimum level (usually 0)
    MEDIACMD::dwEnd - Maximum level (usually 65535)
    MEDIACMD::dwAudioChannels - Channels effected
gsAudOutputLevel Audio output level (master)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Level (0-65535)
    MEDIACMD::dwAudioChannels - Channels affected
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Level (0-65535)
    MEDIACMD::dwStart - Minimum level (usually 0)
    MEDIACMD::dwEnd - Maximum level (usually 65535)
    MEDIACMD::dwAudioChannels - Channels effected
gsAudAdvanceLevel Audio advance level (advanced cue head master) - Not Supported
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Level (0-65535)
    MEDIACMD::dwAudioChannels - Channels affected
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Level (0-65535)
    MEDIACMD::dwStart - Minimum level (usually 0)
    MEDIACMD::dwEnd - Maximum level (usually 65535)
    MEDIACMD::dwAudioChannels - Channels effected
gsAudOutPhase Audio output phase
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Phase offset (default = 0) (0-65520 = degrees * 182)
    MEDIACMD::dwAudioChannels - Channels affected
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Phase offset (0-65520 = degrees * 182)
    MEDIACMD::dwStart - Minimum phase available (usually 0)
    MEDIACMD::dwEnd - Maximum phase available (usually 65520 = 360 * 182)
    MEDIACMD::dwAudioChannels - Channels effected
gsAudOutAdvancePhase Audio advance phase (advanced cue head master) - Not Supported
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Phase offset (default = 0) (0-65520 = degrees * 182)
    MEDIACMD::dwAudioChannels - Channels affected
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Phase offset (0-65520 = degrees * 182)
    MEDIACMD::dwStart - Minimum phase available (usually 0)
    MEDIACMD::dwEnd - Maximum phase available (usually 65520 = 360 * 182)
    MEDIACMD::dwAudioChannels - Channels effected
gsAudCrossFadeTime Audio crossfade time (clip effect overlap) - Not Supported
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Length of crossfade in milliseconds
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Length of crossfade in milliseconds
    MEDIACMD::dwStart - Minimum crossfade length (usually 0 = cut)
    MEDIACMD::dwEnd - Maximum crossfade length (depends on device)
gsAudLtcEnable Enable Ltc on an audio channel
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_ENABLE or GS_DISABLE
    MEDIACMD::dwAudioChannels - Bit for channel to use for LTC
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Is LTC enabled
gsAudInLtcChannel Set audio channel to use for LTC input if enabled. Currently will set LTC output to same channel on all VVW drivers.

  • cmdType::ctSetValue
    MEDIACMD::dwAudioChannels - Bit for channel to use for LTC
  • cmdType::ctGetValue
    MEDIACMD::dwAudioChannels - Bit channel is using for LTC
gsAudOutLtcChannel Set audio channel to use for LTC output if enabled. Currently will set LTC input to same channel on all VVW drivers.

  • cmdType::ctSetValue
    MEDIACMD::dwAudioChannels - Bit for channel to use for LTC
  • cmdType::ctGetValue
    MEDIACMD::dwAudioChannels - Bit channel is using for LTC
gsAudDtmfEnable Enable Dtmf on an audio channel
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_ENABLE or GS_DISABLE
    MEDIACMD::dwAudioChannels - Bit for channel to use for DTMF
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Is DTMF enabled
gsAudInDtmfChannel Set audio channel to use for DTMF input if enabled. Currently will set DTMF output to same channel on all VVW drivers.

  • cmdType::ctSetValue
    MEDIACMD::dwAudioChannels - Bit for channel to use for DTMF
  • cmdType::ctGetValue
    MEDIACMD::dwAudioChannels - Bit channel is using for DTMF
gsAudOutDtmfChannel Set audio channel to use for DTMF output if enabled. Currently will set DTMF input to same channel on all VVW drivers.

  • cmdType::ctSetValue
    MEDIACMD::dwAudioChannels - Bit for channel to use for DTMF
  • cmdType::ctGetValue
    MEDIACMD::dwAudioChannels - Bit channel is using for DTMF
gsAudWavePeakRMS Return the last known RMS and peak value of the audio output. Max 2 channels returned per call. 2 channels should always be requested
  • cmdType::ctSetValue
    - Not Supported
  • cmdType::ctGetValue
    -in- MEDIACMD::dwAudioChannels - Requested channels to check
    MEDIACMD::dwStart - HIWORD=RMS channel +1, LOWORD=RMS channel +0 (range 0-65535)
    MEDIACMD::dwEnd - HIWORD=Peak channel +1, LOWORD=Peak channel +0 (range 0-65535)
    MEDIACMD::dwPosition - duplicates MEDIACMD::dwStart
gsAudInputBitRate Get / Set the current bit rate for recording audio per call
  • cmdType::ctSetValue
    - Not Supported
  • cmdType::ctGetValue
    -in- MEDIACMD::dwAudioChannels - Requested channels to check
gsAudInputSampleRate Set the audio input sample rate
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New sample rate (typically 48000 or 96000)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current sample rate (use cmdType::ctValueSupported to get list)
    MEDIACMD::dwStart - Lowest supported sample rate
    MEDIACMD::dwEnd - Highest supported sample rate
gsAudInputMode Audio input mode
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - See sony defines
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - See sony defines
gsAudInputHeadRoom Audio input head room
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Set required headroom
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current headroom
    MEDIACMD::dwStart - Min headroom
    MEDIACMD::dwEnd - Max Headroom ;)
gsAudInputOriginal Audio input original - see sony def
  • cmdType::ctSetValue
    MEDIACMD::dwPosition -
  • cmdType::ctGetValue
    MEDIACMD::dwPosition -
gsAudInputErrorProtect Enable and disable audio input error protection
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_TRUE protection enabled, else GS_FALSE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_TRUE protection enabled, else GS_FALSE
gsAudInputCopyright Does the audio input bit stream contain a copyright flag
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_TRUE copyright flag is set, else GS_FALSE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_TRUE copyright flag is set, else GS_FALSE
gsAudInputSlave Audio input is in slave mode
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_TRUE if in slave mode, else GS_FALSE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_TRUE if in slave mode, else GS_FALSE
gsAudInputBass Audio bass setting, hardware dependant
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 0..65536, 32768 being nominal and -1 being default
    MEDIACMD::dwAudioChannels - Bit(s) in use
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 0..65536, 32768 being nominal and -1 being not supported
    MEDIACMD::dwAudioChannels - Bit(s) in use
gsAudInputTreble Audio treble setting, hardware dependant
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 0..65536, 32768 being nominal and -1 being default
    MEDIACMD::dwAudioChannels - Bit(s) in use
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 0..65536, 32768 being nominal and -1 being not supported
    MEDIACMD::dwAudioChannels - Bit(s) in use
gsVidFreeze Freeze the video output
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Freeze type GS_VIDFREEZE_NOT_FROZEN, GS_VIDFREEZE_FIELD0, GS_VIDFREEZE_FIELD1, GS_VIDFREEZE_FRAME
    MEDIACMD::dwVideoChannels - Bit(s) for the channel(s) to freeze
  • cmdType::ctGetValue
    MEDIACMD::dwAudioChannels - Bit(s) for the channel(s) currently frozen
gsVidPreReadMode Set DDR into pre read (read before write) mode - requires 2 or more channels
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Channel to use as output
    MEDIACMD::dwStart - GS_ENABLE or GS_DISABLE
    MEDIACMD::dwVideoChannels - Channels to record
    MEDIACMD::dwAudioChannels - Channels to record
    MEDIACMD::dwInfoChannels - Channels to record
  • cmdType::ctGetValue
    MEDIACMD::dwStart - GS_ENABLE or GS_DISABLE - if not enabled, the rest does not matter
    MEDIACMD::dwPosition - Channel in use as output
    MEDIACMD::dwVideoChannels - Channels recording
    MEDIACMD::dwAudioChannels - Channels recording
    MEDIACMD::dwInfoChannels - Channels recording
gsVidEditField First field recorded in edit
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Edit start field (GS_FIELD2 for second, else first)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Edit start field (GS_FIELD2 for second, else first)
gsVidRecFrame Record frames or fields
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_FIELD record single field, else record frames (default - frames (both fields))
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_FIELD recording single field, else recording frames (default - frames (both fields))
gsVidPlayFrame Play frames or fields
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_FIELD play single field, else play frames (default - frames (both fields))
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_FIELD recording fields, else recording frames (default - frames (both fields))
gsVidNoEE Disable video edit to edit passthrough
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_TRUE Always in playback mode, else if GS_FALSE then will passthough video
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_TRUE Always in playback mode, else if GS_FALSE then will passthough video
gsVidSuperimpose Enable superimposed tc/state/menu output in video
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_TRUE Superimpose, else normal video
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_TRUE Superimpose, GS_TRUE Normal Video, GS_NOT_SUPPORTED cannot superimpose
gsVidAnalogMonitorSDType Set the type of up down convert to do
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_ANALOGMONITORMETHOD_DIRECT, GS_ANALOGMONITORMETHOD_SD, GS_ANALOGMONITORMETHOD_HD720, GS_ANALOGMONITORMETHOD_HD1080, GS_ANALOGMONITORMETHOD_FLIP720, GS_ANALOGMONITORMETHOD_FLIP1080
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_ANALOGMONITORMETHOD_DIRECT, GS_ANALOGMONITORMETHOD_SD, GS_ANALOGMONITORMETHOD_HD720, GS_ANALOGMONITORMETHOD_HD1080, GS_ANALOGMONITORMETHOD_FLIP720, GS_ANALOGMONITORMETHOD_FLIP1080 or GS_NOT_SUPPORTED
gsVidAnalogMonitorHDType Select the output type of the analog SD (Composite, SMPTE, RGB)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition -
  • cmdType::ctGetValue
    MEDIACMD::dwPosition -
gsVidAnalogMonitorMethod Select the output type of the analog HD (RGB, SMPTE, xVidRGB)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition -
  • cmdType::ctGetValue
    MEDIACMD::dwPosition -
gsVidAnalogMonitorUpMode Select the method for up converting to HD
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_UPCONVERT_ANAMORPHIC, GS_UPCONVERT_PILLARBOX, GS_UPCONVERT_ZOOM14x9, GS_UPCONVERT_LETTERBOX, GS_UPCONVERT_ZOOMWIDE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_UPCONVERT_ANAMORPHIC, GS_UPCONVERT_PILLARBOX, GS_UPCONVERT_ZOOM14x9, GS_UPCONVERT_LETTERBOX, GS_UPCONVERT_ZOOMWIDE
gsVidAnalogMonitorDownMode Select the method for down converting to SD
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_DOWNCONVERT_LETTERBOX, GS_DOWNCONVERT_CROP, GS_DOWNCONVERT_ANAMORPHIC
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_DOWNCONVERT_LETTERBOX, GS_DOWNCONVERT_CROP, GS_DOWNCONVERT_ANAMORPHIC
gsVidInSelect Select video input
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video input to use GS_VIDSELECT_COMPOSITE, GS_VIDSELECT_COMPOSITE_2, GS_VIDSELECT_SVIDEO, GS_VIDSELECT_COMPONENT_YUV, GS_VIDSELECT_COMPONENT_YUV_M2, GS_VIDSELECT_COMPONENT_YUV_SMPTE, GS_VIDSELECT_COMPONENT_RGB, GS_VIDSELECT_D1_SERIAL, GS_VIDSELECT_D1_PARALLEL, GS_VIDSELECT_SDTI, GS_VIDSELECT_NONE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video input to use GS_VIDSELECT_COMPOSITE, GS_VIDSELECT_COMPOSITE_2, GS_VIDSELECT_SVIDEO, GS_VIDSELECT_COMPONENT_YUV, GS_VIDSELECT_COMPONENT_YUV_M2, GS_VIDSELECT_COMPONENT_YUV_SMPTE, GS_VIDSELECT_COMPONENT_RGB, GS_VIDSELECT_D1_SERIAL, GS_VIDSELECT_D1_PARALLEL, GS_VIDSELECT_SDTI, GS_VIDSELECT_NONE
    MEDIACMD::dwStart - Supported video inputs (bit array using defines from dwPosition)
gsVidInLockType Select video input genlock type
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video input lock type use GS_VIDLOCKTYPE_VTR or GS_VIDLOCKTYPE_BROADCAST
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video input lock type use GS_VIDLOCKTYPE_VTR or GS_VIDLOCKTYPE_BROADCAST
    MEDIACMD::dwStart - Supported video inputs (bit array using defines from dwPosition)
gsVidInSetup Input TBC - Setup (~brightness) Normal range: 0-65535 (0x0000-0xffff)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video input TBC Setup
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video input TBC Setup
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidInVideo Input TBC - Video (~contrast) Normal range: 0-65535 (0x0000-0xffff)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video input TBC Video
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video input TBC Video
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidInHue Input TBC - Hue (~color angle) degrees * 182. Normal range: 0-65520 (0x0000-0xfff0)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video input TBC Hue
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video input TBC Hue
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65520)
gsVidInChroma Input TBC - Chroma (~saturation) Normal range: 0-65535 (0x0000-0xffff)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video input TBC Chroma
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video input TBC Chroma
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidInUChroma Input TBC - U Chroma or Cb or Y'CrCb Normal range: 0-65535 (0x0000-0xffff) Normally only effects the component video or D1 Serial inputs.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video input TBC U (Cb) Chroma
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video input TBC U (Cb) Chroma
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidInVChroma Input TBC - V Chroma or Cr or Y'CrCb Normal range: 0-65535 (0x0000-0xffff) Normally only effects the component video or D1 Serial inputs.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video input TBC V (Cr) Chroma
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video input TBC V (Cr) Chroma
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidInColorKiller Remove color from input signal (black and white luminance data only)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - If 1, signal will have no chroma, if 0, normal signal
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - If 1, signal will have no chroma, if 0, normal signal
gsVidInAGC Automatic gain control
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - If 1, signal adjust gain automatically, if 0, will us cmdGetSetValue::gsVidInSetup and cmdGetSetValue::gsVidInVideo
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - If 1, signal adjust gain automatically, if 0, will us cmdGetSetValue::gsVidInSetup and cmdGetSetValue::gsVidInVideo
gsVidInBandwidth Maximum input bandwidth setting
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Uses GS_VIDBAND_STANDARD, GS_VIDBAND_MEDIUM, GS_VIDBAND_HIGH, GS_VIDBAND_NOTCH
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Uses GS_VIDBAND_STANDARD, GS_VIDBAND_MEDIUM, GS_VIDBAND_HIGH, GS_VIDBAND_NOTCH
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above
gsVidInBlack Black type (NTSC only)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Uses GS_VIDBLACK_SETUP, GS_VIDBLACK_CRYSTAL, GS_VIDBLACK_SUPER
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Uses GS_VIDBLACK_SETUP, GS_VIDBLACK_CRYSTAL, GS_VIDBLACK_SUPER
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above
gsVidInWhite White type (NTSC only)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Uses GS_VIDWHITE_CLAMP, GS_VIDWHITE_SCALE, GS_VIDWHITE_FREE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Uses GS_VIDWHITE_CLAMP, GS_VIDWHITE_SCALE, GS_VIDWHITE_FREE
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above
gsVidInCoring Input digital signal coring. Removal of low order bits to remove DAC aliasing
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Remove bottom 0, 1 or 2 bits of digitized signal
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Remove bottom 0, 1 or 2 bits of digitized signal
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above (0 always supported)
gsVidInPeaking Remove (smooth) 100% signal spikes
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 0 leave signal intact, 1 smooth
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 0 leave signal intact, 1 smooth
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above (0 always supported)
gsVidInSharpness Set video transition sharpness
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Depends on cmdType::ctGetValue-MEDIACMDdwStart->MEDIACMD::dwEnd (typically 0-7, 0-100, 0-65535)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video digitizing sharpness
    MEDIACMD::dwStart - Lowest possible sharpness
    MEDIACMD::dwEnd - Highest possible sharpness
gsVidInGamma Set video gamma curve
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Depends on cmdType::ctGetValue-MEDIACMDdwStart->MEDIACMD::dwEnd (typically -32768->+32768)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Gamma curve weighting or offset
    MEDIACMD::dwStart - Lowest possible sharpness
    MEDIACMD::dwEnd - Highest possible sharpness
gsVidInSignalFormat Video input signal format. May be incorrect depending on some hardware setups.
  • cmdType::ctSetValue
    - Not supported, please use gsSignalFormat to set channel format to match input
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_SIGFORM_NTSC GS_SIGFORM_PAL GS_SIGFORM_CCIR_NTSC GS_SIGFORM_CCIR_PAL GS_SIGFORM_1035i_30_260M GS_SIGFORM_1035i_30X_260M GS_SIGFORM_1080i_30 GS_SIGFORM_1080i_30X GS_SIGFORM_1080i_25 GS_SIGFORM_1080i_24 GS_SIGFORM_1080i_24X GS_SIGFORM_1080_30 GS_SIGFORM_1080_30X GS_SIGFORM_1080_25 GS_SIGFORM_1080_24 GS_SIGFORM_1080_24X GS_SIGFORM_720_60 GS_SIGFORM_720_60X GS_SIGFORM_NOT_PRESENT
gsVidSetup Main TBC - Setup (~brightness) Normal range: 0-65535 (0x0000-0xffff)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TBC Setup
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - TBC Setup
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidVideo Main TBC - Video (~contrast) Normal range: 0-65535 (0x0000-0xffff)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TBC Video
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - TBC Video
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidHue Main TBC - Hue (~color angle) degrees * 182. Normal range: 0-65520 (0x0000-0xfff0)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TBC Hue
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Hue
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65520)
gsVidChroma Main TBC - Chroma (~saturation) Normal range: 0-65535 (0x0000-0xffff)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TBC Chroma
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - TBC Chroma
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidUChroma Main TBC - U Chroma or Cb or Y'CrCb Normal range: 0-65535 (0x0000-0xffff) Normally only effects the component video or D1 Serial paths.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TBC U (Cb) Chroma
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - TBC U (Cb) Chroma
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidVChroma Main TBC - V Chroma or Cr or Y'CrCb Normal range: 0-65535 (0x0000-0xffff) Normally only effects the component video or D1 Serial paths.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TBC V (Cr) Chroma
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - TBC V (Cr) Chroma
    MEDIACMD::dwStart - Lowest possible value (usually 0)
    MEDIACMD::dwEnd - Highest possible value (usually 65535)
gsVidBandwidth Maximum channel bandwidth setting
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Uses GS_VIDBAND_STANDARD, GS_VIDBAND_MEDIUM, GS_VIDBAND_HIGH, GS_VIDBAND_NOTCH
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Uses GS_VIDBAND_STANDARD, GS_VIDBAND_MEDIUM, GS_VIDBAND_HIGH, GS_VIDBAND_NOTCH
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above
gsVidBlackSetup Black type (NTSC only)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Uses GS_VIDBLACK_SETUP, GS_VIDBLACK_CRYSTAL, GS_VIDBLACK_SUPER
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Uses GS_VIDBLACK_SETUP, GS_VIDBLACK_CRYSTAL, GS_VIDBLACK_SUPER
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above
gsVidColor Remove color from signal path (black and white luminance data only)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - If 1, signal will have no chroma, if 0, normal signal
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - If 1, signal will have no chroma, if 0, normal signal
gsVidOutSelect Select video output
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video output to use GS_VIDSELECT_COMPOSITE, GS_VIDSELECT_COMPOSITE_2, GS_VIDSELECT_SVIDEO, GS_VIDSELECT_COMPONENT_YUV, GS_VIDSELECT_COMPONENT_YUV_M2, GS_VIDSELECT_COMPONENT_YUV_SMPTE, GS_VIDSELECT_COMPONENT_RGB, GS_VIDSELECT_D1_SERIAL, GS_VIDSELECT_D1_PARALLEL, GS_VIDSELECT_SDTI, GS_VIDSELECT_NONE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current video output GS_VIDSELECT_COMPOSITE, GS_VIDSELECT_COMPOSITE_2, GS_VIDSELECT_SVIDEO, GS_VIDSELECT_COMPONENT_YUV, GS_VIDSELECT_COMPONENT_YUV_M2, GS_VIDSELECT_COMPONENT_YUV_SMPTE, GS_VIDSELECT_COMPONENT_RGB, 7GS_VIDSELECT_D1_SERIAL, GS_VIDSELECT_D1_PARALLEL, GS_VIDSELECT_SDTI, GS_VIDSELECT_NONE
    MEDIACMD::dwStart - Supported video inputs (bit array using defines from dwPosition)
gsVidOutGenlock Enable genlock (video black timing signal)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 1 using external ref genlock, 0 free running on internal clock (see gsGetSetCmdValue::gsVidOutGenlockSource)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 1 using external ref genlock, 0 free running on internal clock (see gsGetSetCmdValue::gsVidOutGenlockSource)
    MEDIACMD::dwStart - If 1, external genlock supported
gsVidOutGenlockSource Select genlock (video black timing signal) source
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Genlock source to use GS_LOCKSRC_NONE, GS_LOCKSRC_EXTIN, GS_LOCKSRC_INPUT, GS_LOCKSRC_CVBS (composite video), GS_LOCKSRC_SVIDEO (svhs), GS_LOCKSRC_IN_Y (y of component in), GS_LOCKSRC_SDI (D1 Digital In)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Genlock source to use GS_LOCKSRC_NONE, GS_LOCKSRC_EXTIN, GS_LOCKSRC_INPUT, GS_LOCKSRC_CVBS (composite video), GS_LOCKSRC_SVIDEO (svhs), GS_LOCKSRC_IN_Y (y of component in), GS_LOCKSRC_SDI (D1 Digital In)
    MEDIACMD::dwStart - Supported genlock inputs (bit array using defines from dwPosition)
gsVidOutLockType Select genlock type (quality)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Genlock lock type use GS_VIDLOCKTYPE_VTR or GS_VIDLOCKTYPE_BROADCAST
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Genlock lock type use GS_VIDLOCKTYPE_VTR or GS_VIDLOCKTYPE_BROADCAST
    MEDIACMD::dwStart - Supported video inputs (bit array using defines from dwPosition)
gsVidOutHPhase Horizontal output phase
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Depends on cmdType::ctGetValue-MEDIACMDdwStart->MEDIACMD::dwEnd (typically 0->65535 or -32768->32768)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Horizontal phase setting
    MEDIACMD::dwStart - Lowest possible horizontal phase
    MEDIACMD::dwEnd - Highest possible horizontal phase
gsVidOutSubCarrier Video genlock subcarrier phase timing
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Depends on cmdType::ctGetValue-MEDIACMDdwStart->MEDIACMD::dwEnd (typically 0->65520 == degrees * 182)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Sub carrier phase setting
    MEDIACMD::dwStart - Lowest possible sub carrier phase
    MEDIACMD::dwEnd - Highest possible sub carrier phase
gsVidOutCoring Digital output signal coring. Removal of low order bits to remove DAC aliasing
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Remove bottom 0, 1 or 2 bits of digitized signal
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Remove bottom 0, 1 or 2 bits of digitized signal
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above (0 always supported)
gsVidOutPeaking Remove (smooth) 100% signal spikes on output
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 0 leave signal intact, 1 smooth
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 0 leave signal intact, 1 smooth
    MEDIACMD::dwStart - Bit array of allowable values as defined for dwPosition above (0 always supported)
gsVidOutAdjust1 Generic advanced adjustment 1 (hardware dependant)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Depends on cmdType::ctGetValue-MEDIACMDdwStart->MEDIACMD::dwEnd (typically 0->65535 or -32768->32768)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Adjust 1 setting
    MEDIACMD::dwStart - Lowest possible adjust 1 setting
    MEDIACMD::dwEnd - Highest possible adjust 1 setting
gsVidOutAdjust2 Generic advanced adjustment 2 (hardware dependant)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Depends on cmdType::ctGetValue-MEDIACMDdwStart->MEDIACMD::dwEnd (typically 0->65535 or -32768->32768)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Adjust 2 setting
    MEDIACMD::dwStart - Lowest possible adjust 2 setting
    MEDIACMD::dwEnd - Highest possible adjust 2 setting
gsVidOutGenlockDelay Genlock output delay (not currently used)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Depends on cmdType::ctGetValue-MEDIACMDdwStart->MEDIACMD::dwEnd (typically 0->65535 or -32768->32768)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Genlock timing delay
    MEDIACMD::dwStart - Lowest possible delay
    MEDIACMD::dwEnd - Highest possible delay
gsVidOutLockSignalFormat Video output genlock input signal format. May be incorrect depending on some hardware setups.
  • cmdType::ctSetValue
    - Not supported, please use gsSignalFormat to set channel format to match input
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_SIGFORM_NTSC GS_SIGFORM_PAL GS_SIGFORM_CCIR_NTSC GS_SIGFORM_CCIR_PAL GS_SIGFORM_1035i_30_260M GS_SIGFORM_1035i_30X_260M GS_SIGFORM_1080i_30 GS_SIGFORM_1080i_30X GS_SIGFORM_1080i_25 GS_SIGFORM_1080i_24 GS_SIGFORM_1080i_24X GS_SIGFORM_1080_30 GS_SIGFORM_1080_30X GS_SIGFORM_1080_25 GS_SIGFORM_1080_24 GS_SIGFORM_1080_24X GS_SIGFORM_720_60 GS_SIGFORM_720_60X GS_SIGFORM_NOT_PRESENT
gsCompChVerticalRes Size of picture Y (Vertical)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Vertical size of video frame
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Vertical size of video frame
gsMpegVerticalRes | Alias for gsCompChVerticalRes.
gsCompChHorizontalRes Size of picture X (Horizontal)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Horizontal size of video frame
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Horizontal size of video frame
gsMpegHorizontalRes | Alias for gsCompChHorizontalRes.
gsCompChChromaFormat Chroma type 4:0:0, 4:2:0, 4:2:2, 4:4:4
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - One of GS_MPEG_CHROMA_FORMAT_420, GS_MPEG_CHROMA_FORMAT_422, GS_MPEG_CHROMA_FORMAT_444
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - One of GS_MPEG_CHROMA_FORMAT_420, GS_MPEG_CHROMA_FORMAT_422, GS_MPEG_CHROMA_FORMAT_444
gsMpegChromaFormat | Alias for gsCompChChromaFormat.
gsCompChDCPrecision DC Precision (mostly MPEG) 8..12
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_MPEG_DC_PRECISION_8, GS_MPEG_DC_PRECISION_9, GS_MPEG_DC_PRECISION_10, GS_MPEG_DC_PRECISION_11
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_MPEG_DC_PRECISION_8, GS_MPEG_DC_PRECISION_9, GS_MPEG_DC_PRECISION_10, GS_MPEG_DC_PRECISION_11
gsMpegDCPrecision | Alias for gsCompChDCPrecision.
gsCompChAspectRatio Video signal aspect ratio
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_ASPECT_RATIO_SQUARE, GS_ASPECT_RATIO_4x3, GS_ASPECT_RATIO_16x9, GS_ASPECT_RATIO_2_21x1
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_ASPECT_RATIO_SQUARE, GS_ASPECT_RATIO_4x3, GS_ASPECT_RATIO_16x9, GS_ASPECT_RATIO_2_21x1
gsMpegAspectRatio | Alias for gsCompChAspectRatio.
gsCompChStandard MPEG file stream standard
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_MPEG_STANDARD_SYSTEM, GS_MPEG_STANDARD_PROGRAM, GS_MPEG_STANDARD_TRANSPORT, GS_MPEG_STANDARD_ELEMENTARY
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_MPEG_STANDARD_SYSTEM, GS_MPEG_STANDARD_PROGRAM, GS_MPEG_STANDARD_TRANSPORT, GS_MPEG_STANDARD_ELEMENTARY
gsMpegStandard | Alias for gsCompChStandard.
gsCompChLanguageCode Video/Audio Language Code
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_MPEG_LANGAUGE_ENGLISH, etc
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_MPEG_LANGAUGE_ENGLISH, etc
gsMpegLanguageCode | Alias for gsCompChLanguageCode.
gsCompChCCFormat Closed Captioning Format
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_MPEG_CC_FORMAT_CCUBE, GS_MPEG_CC_FORMAT_ATSC, GS_MPEG_CC_FORMAT_CCUBE_REORDER, GS_MPEG_CC_FORMAT_ATSC_REORDER
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_MPEG_CC_FORMAT_CCUBE, GS_MPEG_CC_FORMAT_ATSC, GS_MPEG_CC_FORMAT_CCUBE_REORDER, GS_MPEG_CC_FORMAT_ATSC_REORDER
gsMpegCCFormat | Alias for gsCompChCCFormat.
gsCompChConcealmentVector MPEG Concealment Vector
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Not sure - Argus Encoder
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Not sure - Argus Encoder
gsMpegConcealmentVector | Alias for gsCompChConcealmentVector.
gsCompChClosedGop Set encoding to closed gop or open gop
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 0 = open gop, 1 = closed gop
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 0 = open gop, 1 = closed gop
gsMpegClosedGop | Alias for gsCompChClosedGop.
gsCompChAdjustGopTC Set the next GOP start time code value
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Time code in frames (used def tctype)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Time code in frames (used def tctype)
gsMpegAdjustGopTC | Alias for gsCompChAdjustGopTC.
gsCompChAltCoEffTable Set MPEG encoder to use alternate co-efficent tables
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 1/0
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 1/0
gsMpegAltCoEffTable | Alias for gsCompChAltCoEffTable.
gsCompChNonLinearQuant Set encoder to use non linear quantization
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 1/0
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 1/0
gsMpegNonLinearQuant | Alias for gsCompChNonLinearQuant.
gsCompChMuxRate Set the multiplexer (overall) bit rate
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Bits per second
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Bits per second
gsMpegMuxRate | Alias for gsCompChMuxRate.
gsCompChAudPacketSize Audio packet size
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Size of an audio packet in bytes
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Size of an audio packet in bytes
gsMpegAudPacketSize | Alias for gsCompChAudPacketSize.
gsCompChVidPacketSize Video packet size
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Size of a video packet in bytes
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Size of a video packet in bytes
gsMpegVidPacketSize | Alias for gsCompChVidPacketSize.
gsCompChAudioStreamID Stream ID for AUDIO 0xc0 (0x1c0)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Audio Strean ID
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Audio Stream ID
gsMpegAudioStreamID | Alias for gsCompChVideoStreamID.
gsCompChVideoStreamID Stream ID for VIDEO 0xe0 (0x1e0)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video Stream ID
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video Stream ID
gsMpegVideoStreamID | Alias for gsCompChVideoStreamID.
gsCompChAudioStreamPID Program ID of the video stream within a transport container
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Video program id (PID)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Video program id (PID)
gsMpegAudioStreamPID | Alias for gsCompChAudioStreamPID.
gsCompChVideoStreamPID Program ID of the audio stream within a transport container
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Audio program id (PID)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Audio program id (PID)
gsMpegVideoStreamPID | Alias for gsCompChVideoStreamPID.
gsCompChAllowSettings Allow settings to be changed. Used to determine if settings can be changed (on the fly, without restart),
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 0 disable changes, 1 allow changes
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 0 disable changes, 1 allow changes
gsMpegAllowSettings | Alias for gsCompChAllowSettings.
gsCompChFourCC Fourcc code for compression. Set one video or audio channel set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsCompChBitCount bit count for compression 8 / 10 / 24 / 32 set to return bit count in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsCompChSizeImage Size of each image in bytes set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsCompChRate rate of frame set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsCompChScale Scale for frame rate set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsCompChPitch Bytes per video line set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsVideoEncodeFormat Encoding compression format ie avi mov dpx set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsAudioEncodeFormat Encoding compression format ie wav aiff set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsCompChannelChangeMs last compression change ms for updating hte clip bin set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsAlphaChromaSource single link, dual link or alpha set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsCompressionType RGBA BGRA ycbcr set to return fourcc code in dwPosition
  • cmdType::ctSetValue - See fccDef.h for know fourcc
  • cmdType::ctGetValue - See fccDef.h for know fourcc
gsVideoStandard
gsResetChannel
gsEnableHDSDFormat
gsVBlankEnable
gsLUTEnable
gsSignalFormat Channel Compression format
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_SIGFORM_CCIR_NTSC GS_SIGFORM_CCIR_PAL GS_SIGFORM_1035i_30_260M GS_SIGFORM_1035i_30X_260M GS_SIGFORM_1080i_30 GS_SIGFORM_1080i_30X GS_SIGFORM_1080i_25 GS_SIGFORM_1080i_24 GS_SIGFORM_1080i_24X GS_SIGFORM_1080_30 GS_SIGFORM_1080_30X GS_SIGFORM_1080_25 GS_SIGFORM_1080_24 GS_SIGFORM_1080_24X GS_SIGFORM_720_60 GS_SIGFORM_720_60X GS_SIGFORM_CUSTOM
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_SIGFORM_NTSC GS_SIGFORM_PAL GS_SIGFORM_CCIR_NTSC GS_SIGFORM_CCIR_PAL GS_SIGFORM_1035i_30_260M GS_SIGFORM_1035i_30X_260M GS_SIGFORM_1080i_30 GS_SIGFORM_1080i_30X GS_SIGFORM_1080i_25 GS_SIGFORM_1080i_24 GS_SIGFORM_1080i_24X GS_SIGFORM_1080_30 GS_SIGFORM_1080_30X GS_SIGFORM_1080_25 GS_SIGFORM_1080_24 GS_SIGFORM_1080_24X GS_SIGFORM_720_60 GS_SIGFORM_720_60X GS_SIGFORM_CUSTOM
    MEDIACMD::dwStart - Bit array of supported types
gsCompType Channel Compression format/type
  • cmdType::ctSetValue
    MEDIACMD::dwPosition -
    GS_COMPTYPE_SOFTWARE Software passed codec on main processor
    GS_COMPTYPE_MJPEG Motion JPEG hardware codec (LSI, Zoran, C-Cube, etc)
    GS_COMPTYPE_WAVELET Wavelet hardware codec
    GS_COMPTYPE_MPEG1 MPEG 1 hardware compatible codec
    GS_COMPTYPE_MPEG2 MPEG 2 hardware compatible codec
    GS_COMPTYPE_MPEG2I Editable MPEG 2 I Frame Only compatible codec
    GS_COMPTYPE_MPEG2IBP MPEG 2 long gop hardware compatible codec
    GS_COMPTYPE_DV25 Hardware DV25, DVCPRO, DVCPRO25
    GS_COMPTYPE_DV50 Hardware DV50, DVCPRO50
    GS_COMPTYPE_DVSD Hardware Standard DV Bluebook, DVPRO, DVSD
    GS_COMPTYPE_DV100 High Def DV codec
    GS_COMPTYPE_UN8BIT 8Bit Y'CrCb uncompressed video
    GS_COMPTYPE_UN10BIT 10Bit Y'CrCb uncompressed video
    GS_COMPTYPE_HDPAN Panasonic HD to SDI codec
    GS_COMPTYPE_HDSONY Sony HD to SDI codec
  • cmdType::ctGetValue
    MEDIACMD::dwPosition -
    GS_COMPTYPE_SOFTWARE Software passed codec on main processor
    GS_COMPTYPE_MJPEG Motion JPEG hardware codec (LSI, Zoran, C-Cube, etc)
    GS_COMPTYPE_WAVELET Wavelet hardware codec
    GS_COMPTYPE_MPEG1 MPEG 1 hardware compatible codec
    GS_COMPTYPE_MPEG2 MPEG 2 hardware compatible codec
    GS_COMPTYPE_MPEG2I Editable MPEG 2 I Frame Only compatible codec
    GS_COMPTYPE_MPEG2IBP MPEG 2 long gop hardware compatible codec
    GS_COMPTYPE_DV25 Hardware DV25, DVCPRO, DVCPRO25
    GS_COMPTYPE_DV50 Hardware DV50, DVCPRO50
    GS_COMPTYPE_DVSD Hardware Standard DV Bluebook, DVPRO, DVSD
    GS_COMPTYPE_DV100 High Def DV codec
    GS_COMPTYPE_UN8BIT 8Bit Y'CrCb uncompressed video
    GS_COMPTYPE_UN10BIT 10Bit Y'CrCb uncompressed video
    GS_COMPTYPE_HDPAN Panasonic HD to SDI codec
    GS_COMPTYPE_HDSONY Sony HD to SDI codec
    MEDIACMD::dwStart - Bit array of supported types
gsCompRateSize Compression setting by total throughput
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Size of compressed stream in kilobytes per second
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Size of compressed stream in kilobytes per second
    MEDIACMD::dwStart - Smallest size possible
    MEDIACMD::dwEnd - Largest size possible
gsCompRateRatio Compression setting by compression ratio
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Ratio * 100 (eg 2:1 = 200)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Ratio * 100 (eg 2:1 = 200)
    MEDIACMD::dwStart - Smallest available ration * 100
    MEDIACMD::dwEnd - Largest available ration * 100
gsCompRatePercent Compression setting by compression percentage of original size
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Percentage * 100 (eg 50% compression = 5000)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Percentage * 100 (eg 50% compression = 5000)
    MEDIACMD::dwStart - Smallest available percentage (usually 0)
    MEDIACMD::dwEnd - Largest available percentage (usually 10000)
gsCompGOPSize Number of frames per 'group of pictures'. For MPEG compression as well as defining keyframe interval for Cinepac, Indeo, MPEG-4, etc.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Number of frames between keyframes of MPEG 'GOP' frame length
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Number of frames between keyframes of MPEG 'GOP' frame length
    MEDIACMD::dwStart - Minimum possible size of group of pictures (usually 0)
    MEDIACMD::dwEnd - Largest possible size of group of pictures (up to 10000 for MPEG 4)
gsCompIFactor Number of I Frame elements per GOP
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Kilobytes available on drive
gsCompBFactor Number of B Frame elements per GOP
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Kilobytes available on drive
gsCompPFactor Number of P Frame elements per GOP
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Kilobytes available on drive
gsCompRefPeriod Refence period to determine amount and order of P and B frames
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Kilobytes available on drive
gsTotalStorageAvail Total storage available on current recording drive in kilobytes
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Kilobytes available on drive
gsTotalStorageFree Total storage free on current recording drive in kilobytes
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Kilobytes free on drive
gsTotalTimeAvail Total recording time available on current recording drive at current compression level
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Number of frames available to record to
gsTotalTimeFree Total recording time free on current recording drive at current compression level
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Number of frames free to record to
gsVtrType VTR emulation ID type
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Any WORD VTR ID - See Control key in registry docs and LocalConfig.exe
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Any WORD VTR ID - See Control key in registry docs and LocalConfig.exe
gsLocal Front panel/GUI Interface Local Mode
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - If 1 then local control available, else remote only
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - If 1 then local control available, else remote only
gsSupportedFileTypes Supported read/write file types
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Currently GS_SUPFILE_AVI, GS_SUPFILE_ODML, GS_SUPFILE_QT, GS_SUPFILE_OMFI, GS_SUPFILE_FIX, GS_SUPFILE_AUDONLY, GS_SUPFILE_STILLS, GS_SUPFILE_UNK, GS_SUPFILE_ANY
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently GS_SUPFILE_AVI, GS_SUPFILE_ODML, GS_SUPFILE_QT, GS_SUPFILE_OMFI, GS_SUPFILE_FIX, GS_SUPFILE_AUDONLY, GS_SUPFILE_STILLS, GS_SUPFILE_UNK, GS_SUPFILE_ANY
    MEDIACMD::dwStart - Bit array of supported types per dwPosition above.
gsIgnoreFileTypes File types for this channel to ignore
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Currently GS_SUPFILE_AVI, GS_SUPFILE_ODML, GS_SUPFILE_QT, GS_SUPFILE_OMFI, GS_SUPFILE_FIX, GS_SUPFILE_AUDONLY, GS_SUPFILE_STILLS, GS_SUPFILE_UNK, GS_SUPFILE_ANY
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Currently GS_SUPFILE_AVI, GS_SUPFILE_ODML, GS_SUPFILE_QT, GS_SUPFILE_OMFI, GS_SUPFILE_FIX, GS_SUPFILE_AUDONLY, GS_SUPFILE_STILLS, GS_SUPFILE_UNK, GS_SUPFILE_ANY
gsRecInhibit Disable recording on this channel or this channel does not support recording.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 1 to disable recording, or 0 to enable
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 1 to disable recording, or 0 to enable (play only channels always return 1)
gsRecDrive Select recording drive
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Bit representing drive where 0=C:, 1=D: etc
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Bit representing drive where 0=C:, 1=D: etc
    MEDIACMD::dwStart - Bit array of available drives
gsRecFileName Change the defual record filename
  • cmdType::ctSetValue
    MEDIACMD::arbID - New next record filename
    MEDIACMD::cfFlags - must be set to cfUseClipID
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - gsTrue/gsFalse
    MEDIACMD::arbID - Next record filename
    MEDIACMD::cfFlags - must be set to cfUseClipID
gsRecRate Recording rate by throughput in kilobytes per second
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Target size of recorded stream in kilobytes per second
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Target size of recorded stream in kilobytes per second
    MEDIACMD::dwStart - Smallest size possible
    MEDIACMD::dwEnd - Largest size possible
gsRecFileFormat Default video/stream record file type
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Uses mftXXX enum from MediaReactorTypes.h
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Uses mftXXX enum from MediaReactorTypes.h
gsRecAudFileFormat Default audio record file type
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Uses mftXXX enum from MediaReactorTypes.h
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Uses mftXXX enum from MediaReactorTypes.h
gsDelInhibit Disable file deletion on this channel
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 1 to disable delete command, or 0 to enable
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 1 to disable delete command, or 0 to enable
gsInsInhibit Allows/Inhiibits clips being Deleted from Bin or TC Space
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TRUE/FALSE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - TRUE/FALSE
gsConvertFileFormat Allows/Inhiibits clips being added to Bin or TC Space
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - TRUE/FALSE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - TRUE/FALSE
gsConvertAudFileFormat Default audio conversion file type
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Uses mftXXX enum from MediaReactorTypes.h
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Uses mftXXX enum from MediaReactorTypes.h
gsDefStillLen Default length, in frames, for a still graphics file being added as a clip
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Duration in frames
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Duration in frames
gsSysTime Current reference system time for house VITC or house LTC if available, if not then from system clock interpolated with performanace counter.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Current time code position
    MEDIACMD::dwStart - Current milliseconds position
    MEDIACMD::dwEnd - Current date
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current time code position
    MEDIACMD::dwStart - Current milliseconds position
    MEDIACMD::dwEnd - Current date
gsDSyncMs Current reference system time for house VITC or house LTC if available, if not then from system clock interpolated with performanace counter.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Current dysnc milliseconds
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current dysnc milliseconds
gsHwPort Current hardware port used by channel. Mostly for COMx: port selection of CTL and EXT channels.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - New com port
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current com port
    MEDIACMD::dwStart - Available com ports as bit array
gsPBEE Playback only output or allow edit to edit
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_PBEE_AUTO (playback or e to e), GS_PBEE_PB (playback only)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_PBEE_AUTO (playback or e to e), GS_PBEE_PB (playback only), GS_PBEE_DEFAULT (device default read only)
    MEDIACMD::dwStart - Bit array of available commands per dwPosition settings above
gsServoRefSelect Video reference for servo select
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_SERVOREF_AUTO (ext is avail, else int), GS_SERVOREF_EXT (always external)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_SERVOREF_AUTO (ext is avail, else int), GS_SERVOREF_EXT (always external), GS_SERVOREF_DEFAULT (device default read only)
    MEDIACMD::dwStart - Bit array of available commands per dwPosition settings above
gsHeadSelect Head select
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_HEADSEL_RECPLAY, GS_HEADSEL_PLAY
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_HEADSEL_RECPLAY, GS_HEADSEL_PLAY, GS_HEADSEL_DEFAULT (device default read only)
    MEDIACMD::dwStart - Bit array of available commands per dwPosition settings above
gsColorFrame Colour frame select
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_CLRFRM_2FLD, GS_CLRFRM_4FLD, GS_CLRFRM_8FLD
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_CLRFRM_2FLD, GS_CLRFRM_4FLD, GS_CLRFRM_8FLD, GS_CLRFRM_DEFAULT
    MEDIACMD::dwStart - Bit array of available commands per dwPosition settings above
gsVidRefDisable Video reference disable
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_VIDREF_DISABLE, GS_VIDREF_ENABLE
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_VIDREF_DISABLE, GS_VIDREF_ENABLE
    MEDIACMD::dwStart - Bit array of available commands per dwPosition settings above
gsPlayCountDelay Get Play count delay for the VTR interp
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition stores the value 7 for default
gsEmulateEditBumping Use fake edit mode for MPEG bumping. Basically, all non play speed commands will be emulated, and once a play (lock) is reached the card will be synced to that time and play. Dangerous if sync does not happen quickly...
  • cmdType::ctSetValue
    MEDIACMD::dwPosition 1 turns on fake edit, 0 turns off
  • cmdType::ctGetValue
    MEDIACMD::dwPosition 1 fake edit on, 0 fake edit of
cmdaltNearestKeyFrame Special command alt value for position requests, goes to key frame nearest to requested frame
  • cmdType::ctPause, cmdType::ctPlay
    MEDIACMD::dwPosition Target Position
cmdaltNextKeyFrame Special command alt value for position requests, goes to key frame after to requested frame
  • cmdType::ctPause, cmdType::ctPlay
    MEDIACMD::dwPosition Target Position
cmdaltPrevKeyFrame Special command alt value for position requests, goes to key frame before to requested frame
  • cmdType::ctPause, cmdType::ctPlay
    MEDIACMD::dwPosition Target Position
cmdaltStartOfMessage Special command alt value for position requests, goes to first frame of actual (non-black) video after the requested frame
  • cmdType::ctPause, cmdType::ctPlay
    MEDIACMD::dwPosition Target Position
gsVidInputValid Special command is video input valid GS_TRUE / GS_FALSE

MEDIACMD::dwPosition -True / False is input Valid
MEDIACMD::dwStart -signal format of the input

gsVidGenlockValid Special command is genlock input valid GS_TRUE / GS_FALSE

MEDIACMD::dwPosition -True / False is genlock Valid
MEDIACMD::dwStart -signal format of the genlock signal

gsErrorLog Enable/Disable/Flush error log
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 1 Enable, 0 Disable, -1 Flush
    MEDIACMD::dwStart - Start messages
    MEDIACMD::dwEnd - Maximum messages
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 1 Enable, 0 Disable
    MEDIACMD::dwStart - Total messages
    MEDIACMD::dwEnd - Maximum messages
gsErrorLogName Get/Set Error Log Name
  • cmdType::ctSetValue
    MEDIACMD::arbID - New Log Name
  • cmdType::ctGetValue
    MEDIACMD::arbID - Current Log Name
gsErrorLogStartMs Gets the starting ms value in message units
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - First message ms (ever)
gsErrorLogCurrentMs Gets current ms time per log entries (for relative and date absolute)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current ms
gsErrorLogLastChange Gets the last change value, modified with each new entry.
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Last change value
    MEDIACMD::dwStart - First available message number
gsErrorLogMessage Gets/Set an error message to/from the log
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Send -1 for first num, send last returned number to get next, Return num
    MEDIACMD::lSpeed - Send format type
    MEDIACMD::dwStart - Error Code
    MEDIACMD::dwCmdAlt - Time of message ms
    MEDIACMD::cfFlags - cfPreview causes RAW return
    MEDIACMD::dwStart - First available message number
  • cmdType::ctSetValue
    MEDIACMD::dwStart - Error Code
    MEDIACMD::arbID - Raw message
gsSysBufferLevel Buffer levels for playback/record (real time)
  • cmdType::ctSetValue
    Not supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Buffers stored in board
    MEDIACMD::dwStart - Buffers in queue to board
    MEDIACMD::dwEnd - Buffers in queue from disk
    . MEDIACMD:;dwInfoChannels - total system buffers available in board + memory / system frame size
    MEDIACMD::dwVideoChannels - Selected channel for buffer request
    MEDIACMD::dwAudioChannels - Selected channel for buffer request
gsSysMemoryUsage Memory usage
  • cmdType::ctSetValue
    Not supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Memory we are using
    MEDIACMD::dwStart - Memory used in system
    MEDIACMD::dwEnd - Total memory in system
gsSysCPUUsage CPU usage
  • cmdType::ctSetValue
    Not supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - CPU we are using
    MEDIACMD::dwStart - CPU used in system
    MEDIACMD::dwEnd - Portion of CPU in kernel mode
gsProxyMode Sets/Returns auto proxy mode
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Proxy mode 0=disabled,
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Proxy mode 0=disabled,
gsProxyStatus Returns the status of any proxy generation
  • MEDIACMD::ctCmd -
  • cmdType::ctPlay - creating a proxy from file on disk
  • cmdType::ctRecord - creating a proxy from a recording file
  • MEDIACMD::dwCmdAlt - Last change in list ms
  • MEDIACMD::dwPosition - Current encode frame
  • MEDIACMD::dwEnd - current length of file
  • MEDIACMD::dwStart - current processor percentage
  • MEDIACMD::arbID - current encode path + name
gsGetNextProxy Return the next proxy source file name. If the previous name is set to NULL then return the first clip in the list.
  • cmdType::ctSetValue
    - not supported
  • cmdType::ctGetValue
    -in- MEDIACMD::arbID - Last returned file name or NULL
    -out- MEDIACMD::arbID - Next file name in proxy list
    MEDIACMD::dwPosition - Not used yet
    MEDIACMD::dwStart - Not used yet
    MEDIACMD::dwEnd - Not used yet
gsAddProxy Add a new proxy file to the list
  • MEDIACMD::arbID - File name to proxy
  • MEDIACMD::dwStart - Start frame of proxy
  • MEDIACMD::dwEnd - End frame of proxy
gsPromoteProxy Set a proxy file to next in list
  • MEDIACMD::arbID - File to promote
gsRemoveProxy Remove a proxy file from the list
  • MEDIACMD::arbID - File to remove
gsProxyCPUUsage Get Set the max cpu percentage
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 0 No CPU limit, 1..100 max cpu usage
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Current cpu usage
    MEDIACMD::dwStart - Current MAX cpu useage
    MEDIACMD::dwEnd - Default CPU Max Usage
gsVVWVersion Get VVW version number
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::arbID - Zero terminated ansi string with version number
gsMEVersion Get MediaReactor version number
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::arbID - Zero terminated ansi string with version number
gsVVWType Get VVW type description
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::arbID - Zero terminated ansi string with VVW machine type
gsVVWChannelType Get VVW channel type
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::arbID - Zero terminated ansi string with channel type
gsVVWChannelName Get/Set VVW channel name
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 0 Get Current, 1 Get Default
    MEDIACMD::arbID - Zero terminated ansi string with desired channel name
  • cmdType::ctGetValue
    MEDIACMD::arbID - Zero terminated ansi string with current channel name
gsMonitor Setup on screen monitor (VGA Monitor)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - 1 to enable, 0 to disable
    MEDIACMD::dwEnd - Left corner
    MEDIACMD::dwStart - Top corner
    MEDIACMD::dwCmdAlt - Size (0 = Default, 1 = Full, 2 = Half, 3 = Quarter)
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 1 to enable, 0 to disable
    MEDIACMD::dwEnd - Left corner
    MEDIACMD::dwStart - Top corner
    MEDIACMD::dwCmdAlt - Size (0 = Default, 1 = Full, 2 = Half, 3 = Quarter)
gsMonitorHwnds Set handles to windows
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Handle to target window or -1
    MEDIACMD::dwEnd - Handle to owner application window
    MEDIACMD::dwStart - Window flags
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Handle to target window
    MEDIACMD::dwEnd - Handle to owner application window or -1
    MEDIACMD::dwStart - Window flags
gsHwnds | Alias for gsMonitorHwnds for older apps.
gsMonitorDisplay Turns VGA display on / off without killing to he window Can use this later to set refresh rates - aspect ratios or what not
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_TRUE, GS_FALSE
    MEDIACMD::dwEnd -
    MEDIACMD::dwStart -
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_TRUE, GS_FALSE
    MEDIACMD::dwEnd -
    MEDIACMD::dwStart
gsMonitorGrab Get a capture of the current output (input passthrough or current clip output). Use cmdType::ctGetValue to get a preview.
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Type of capture that is going to be used
    MEDIACMD::arbID - Optional, depends on dwPosition
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Preview type GS_MONITORGRAB_NONE, GS_MONITORGRAB_TYPE_BMP, GS_MONITORGRAB_TYPE_JPG, GS_MONITORGRAB_SIZE_FULL, GS_MONITORGRAB_SIZE_HALF, GS_MONITORGRAB_SIZE_QUARTER, GS_MONITORGRAB_TO_MEMORY, GS_MONITORGRAB_TO_UNC_PATH, GS_MONITORGRAB_TO_HTTP, GS_MONITORGRAB_TO_NETWORK
    MEDIACMD::arbID - Image data, if returned not saved
    To create a grab type, combine on type (bmp, jpg) with a size (full, half, quarter) and a target (memory, path, http, network).
    Depending on target, the arbID member will be filled in as follows:
  • GS_MONITORGRAB_TO_MEMORY - arbID not used
  • GS_MONITORGRAB_TO_UNC_PATH - arbID unified naming conventions (UNC) path
  • GS_MONITORGRAB_TO_HTTP - arbID contains the name
  • GS_MONITORGRAB_TO_NETWORK - Not implemented
gsDirGetList
gsDirGetInfo
gsDirGetFileInfo
gsDirGetFileGrab
gsChannelsExist Check if channels exist
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwVideoChannels - Possible Video Channels
    MEDIACMD::dwAudioChannels - Possible Audio Channels
    MEDIACMD::dwInfoChannels - Possible Info Channels
gsClipMode Get/Set clip mode state (else time code mode)
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - GS_CLIPMODE_CLIPSPACE, GS_CLIPMODE_TCSPACE, GS_CLIPMODE_SINGLE, GS_CLIPMODE_FILM current types
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - GS_CLIPMODE_CLIPSPACE, GS_CLIPMODE_TCSPACE, GS_CLIPMODE_SINGLE, GS_CLIPMODE_FILM current types
gsRecOffset Get/Set record offset for VVW3x00 replay mode
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - Time code offset or 0 to reset
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Time code offset or 0 to reset
gsChanCapabilities Get channel capabilities
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Bitwise array GS_CHANCAP_PLAY, GS_CHANCAP_REVPLAY, GS_CHANCAP_PAUSE, GS_CHANCAP_JOG, GS_CHANCAP_SHUTTLE, GS_CHANCAP_SEEK, GS_CHANCAP_PREVIEW, GS_CHANCAP_STOP, GS_CHANCAP_ETOE, GS_CHANCAP_RECORD, GS_CHANCAP_EDIT, GS_CHANCAP_RECSTOP, GS_CHANCAP_SELECTPRESET, GS_CHANCAP_EJECT, GS_CHANCAP_LOOP, GS_CHANCAP_VGAPREVIEW, GS_CHANCAP_AUDPREVIEW, GS_CHANCAP_FILE, GS_CHANCAP_NET, GS_CHANCAP_CLIPSPACE, GS_CHANCAP_TCSPACE, GS_CHANCAP_ALL
gsLastChangeMs Get last change millisecond time from clip space, tc space or file
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - last change in ms aligned with Dsync
gsGPIIn Get the state of the GPI ins, reset them with set
  • cmdType::ctSetValue - reset in events to nothing
    MEDIACMD::dwVideoChannels - GPI A-H (0-7 / 1-8)
    MEDIACMD::dwAudioChannels - GPI I-P (8-15 / 9-16)
    MEDIACMD::dwInfoChannels - GPI Q-X (16-23/ 17-24)
  • cmdType::ctGetValue
    MEDIACMD::dwVideoChannels - GPI A-H (0-7 / 1-8)
    MEDIACMD::dwAudioChannels - GPI I-P (8-15 / 9-16)
    MEDIACMD::dwInfoChannels - GPI Q-X (16-23/ 17-24)
    MEDIACMD::dwPosition - last change in ms aligned with Dsync
gsGPIOut Get the state of the GPI outs,
  • cmdType::ctSetValue - set the GPIs up or down or pulse
    MEDIACMD::dwVideoChannels - GPI A-H (0-7 / 1-8)
    MEDIACMD::dwAudioChannels - GPI I-P (8-15 / 9-16)
    MEDIACMD::dwInfoChannels - GPI Q-X (16-23/ 17-24)
    MEDIACMD::dwPosition - Type of set (0=low, 1=high, 2=pulse)
  • cmdType::ctGetValue - get the current gpi output state.
    MEDIACMD::dwVideoChannels - GPI A-H (0-7 / 1-8)
    MEDIACMD::dwAudioChannels - GPI I-P (8-15 / 9-16)
    MEDIACMD::dwInfoChannels - GPI Q-X (16-23/ 17-24)
    MEDIACMD::dwPosition - Last Change Ms
    A 1 in the GPI bitwise array means on or triggered, 0 is down or off.
gsCurrentMs Get the current millisecond counter on the maching (NOT aligned ot anything). NOTE: This is handled directly for network channels on server side
  • cmdType::ctSetValue
    Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - the current millisecond counter
gsSaveCurrent Save the current parameters to the registry
  • cmdType::ctSetValue
    No Parameters
  • cmdType::ctGetValue
    Not Used
gsLoadClipSpace Load a new clip space (or new if file does not exist)
  • cmdType::ctSetValue
    MEDIACMD::arbID - File name of new or existing clip space
  • cmdType::ctGetValue
    MEDIACMD::arbID - returns current file name of clip space
gsLoadTCSpace Load a new tc space (or new if file does not exist)
  • cmdType::ctSetValue
    MEDIACMD::arbID - File name of new or existing tc space
  • cmdType::ctGetValue
    MEDIACMD::arbID - returns current file name of tc space
gsLoadFilmSpace Load a new film (or new if file does not exist)
  • cmdType::ctSetValue
    MEDIACMD::arbID - File name of new or existing film
  • cmdType::ctGetValue
    MEDIACMD::arbID - returns current file name of film
gsUserLogIn Log in user (must have rights on the local machine)
  • cmdType::ctSetValue
    MEDIACMD::arbID - User name zero terminated followed by password zero terminated.
  • cmdType::ctGetValue
    MEDIACMD::arbID - Returns user name zero terminated.
gsUserLastChangeMs Last change in user status
  • cmdType::ctSetValue Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - Last change in users (status or number)
gsUserList Return a list of currently logged in users
  • cmdType::ctSetValue Not Supported
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - 0..max user
    MEDIACMD::arbID - User name zero terminated, location info zero terminated
    MEDIACMD::dwStart - User rights NULL when all users have been returnd
gsUserAdd Allow a user access to the unit - ONLY AVAILABLE ON LOCAL MACHINE
  • cmdType::ctSetValue
    MEDIACMD::arbID - User name zero terminated, password zero terminated
    MEDIACMD::dwStart - User Rights
  • cmdType::ctGetValue Not Supported
gsUserDel Remove a users access to the unit - ONLY AVAILABLE ON LOCAL MACHINE
  • cmdType::ctSetValue
    MEDIACMD::arbID - User name zero terminated.
  • cmdType::ctGetValue Not Supported
gsUserRights Change a users rights - ONLY AVAILABLE ON LOCAL MACHINE
  • cmdType::ctSetValue
    MEDIACMD::arbID - User name zero terminated.
    MEDIACMD::dwPosition - the user rights
  • cmdType::ctGetValue
    MEDIACMD::arbID - User name zero terminated (current if NULL)
    MEDIACMD::dwPosition - the user rights
gsUserPasswd Change current users password (must be logged in)
  • cmdType::ctSetValue
    MEDIACMD::arbID - new password zero terminated new password zero terminated.
  • cmdType::ctGetValue Not Supported
gsPiconFrame
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - frame number
    MEDIACMD::arbID - file and directory
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - (GS_TRUE | GS_FALSE) is set picon
    MEDIACMD::arbID - file and directory
gsJpegFrame
  • cmdType::ctSetValue
    MEDIACMD::dwPosition - frame number
    MEDIACMD::arbID - file and directory
  • cmdType::ctGetValue
    MEDIACMD::dwPosition - (GS_TRUE | GS_FALSE) is set jpeg
    MEDIACMD::arbID - file and directory
gsImageDirectory
  • cmdType::ctSetValue
    MEDIACMD::arbID - directory to use (NULL = Use Network Directory)
  • cmdType::ctGetValue
    MEDIACMD::arbID - directory using for images
gsVVWService
gsInsertQueue
gsXlatQueue

enum cmdinf

Info channel bit array for MEDIACMD::dwInfoChannels

Enumerator:
infLtc | LTC time code user bit channel.
infVitc | VITC time code user bit channel.
infSrcCtl | Incoming source control time code.
infSrcLtc | Incoming source LTC time code user bits.
infSrcVitc | Incoming source VITC time code user bits.
infRecTime | Record time of day.
infRecDate | Record Data.
infCC | Close caption infomation.
infAuth | Authorization information.
infCopyright | Copyright information.
infOwner | Ownership information.
infSourceName | Source media name.
infProxyName | Source proxy name (if any).
inf13 | Unused inf13 - inf21.
inf14
inf15
inf16
inf17
inf18
inf19
inf20
inf21
infVB0
infVB1
infVB2
infVB3
infVB4
infVB5
infVB6
infVB7
infVB8
infVB9
infChanAll

enum cmdType

The legal commands for a MEDIACMD structure. Set MEDIACMD::ctCmd to one of these values and expect it to be set to one of these values on a valid return

Enumerator:
ctStop Stop - Stop all playback, and normally place all channels into passthrough
ctPause Pause - Halt all channels. Display current video frame and silence audio
Seek - With cmdFlags::cfUsePosition and MEDICMD::dwPosition, goto that frame and Pause
ctPlay Play - Play all channels. May be modified by (cmdFlags::cfUseSpeed + MEDIACMD::lSpeed) and
((cmdFlags::cfUsePosition or cmdFlags::cfUsePositionOffset) and MEDIACMD::dwPosition) or
((cmdFlags::cfUseStart or cmdFlags::cfUseStartOffset) and MEDIACMD::dwStart) or
((cmdFlags::cfUseEnd or cmdFlags::cfUseEndOffset) and MEDIACMD::dwEnd) as well as
MEDIACMD::dwCmdAlt with certain cmdFlags to play from-top, at speed or combinations of the above.
ctRecord Record - Record one or a combination of video/audio/info to disk. May be modified, as with ctPlay by flags and structure members such as
((cmdFlags::cfUsePosition or cmdFlags::cfUsePositionOffset) and MEDIACMD::dwPosition) or
((cmdFlags::cfUseStart or cmdFlags::cfUseStartOffset) and MEDIACMD::dwStart) or
((cmdFlags::cfUseEnd or cmdFlags::cfUseEndOffset) and MEDIACMD::dwEnd) as well as
(cmdFlags::cfUseClipID and MEDIACMD::arbID) or
(cmdFlags::cfDeferred or cmdFlags::cfOverideDeferred) or MEDIACMD::dwCmdAlt with certain cmdFlags to record from-top, at speed or combinations of the above.
ctRecStop Record Stop - Set the channel into a record ready state, normally passthrough with the recording file preallocated, and possible pass start end and name information. See
(cmdFlags::cfUseStart cmdFlags::cfUseStartOffset and MEDIACMD::dwStart)
(cmdFlags::cfUseEnd cmdFlags::cfUseEndOffset and MEDIACMD::dwEnd)
(cmdFlags::cfUseClipID and MEDIACMD::arbID) for record setups.
ctEject Eject - Stop the channel and unload removable media, if possible, else same as stop
ctTransfer Transfer - Transfer media from one channel to another. Normally used to transfer internal media to or from an external tape device.
ctInsert Insert Clip or Timecode Area - Used in time code space (TCSpace.h) and Clip Space (ClipSpace.h) to add new clips or areas. Inserted media is defined by (cmdFlags::cfUseStart - MEDIACMD::dwStart, cmdFlags::cfUseEnd - MEDIACMD::dwEnd) for clip being added and cmdFlags::cfUsePosition - MEDIACMD::dwPosition for target. Also (cmdFlags::cfUseClipID and MEDIACMD::arbID) may be used to specify a file name. cmdFlags::cfUsePresets and MEDIACMD::dwVideoChannels, MEDIACMD::dwAudioChannels, MEDIACMD::dwInfoChannels are also respected if set. cmdFlags::cfRipple may also be used to insert over
NOTE - The ctTransfer command is ALWAYS sent to the target with the SOURCE channel in the MEDIACMD::dwCmdAlt member and cmdFlags::cfUseCmdAlt set UNLESS one of the devices is slow/high latency/sloppy (read VTR), in which case it always recieves the command so it can master the transfer and the cmdFlags::cfInvert is used to set the direction.
ctBlank Blank a Timecode Area - Used in time code space (TCSpace.h) to set an area to black and silent audio. (cmdFlags::cfUseStart - MEDIACMD::dwStart, cmdFlags::cfUseEnd - MEDIACMD::dwEnd) set the area to be blanked. cmdFlags::cfUsePresets and MEDIACMD::dwVideoChannels, MEDIACMD::dwAudioChannels, MEDIACMD::dwInfoChannels are also respected if set. cmdFlags::cfRipple may also be used to remove blank area. With this command, no media is removed from storage.
ctDelete Delete a clip (ClipSpace.h) or an area (TCSpace.h). Deletes the media from storage and from the current space. For ClipSpace, cmdFlags::cfUseClipID and MEDIACMD::arbID must be specified, and if any sub clip or super clips exist, the id will be removed but the media will not be deleted. For TCSpace, cmdFlags::cfUseStart and MEDIACMD::dwStart with cmdFlags::cfUseEnd and MEDIACMD::dwEnd should be used to specify the time code segment to be deleted. cmdFlags::cfUsePresets and MEDIACMD::dwVideoChannels, MEDIACMD::dwAudioChannels, MEDIACMD::dwInfoChannels may also be used to delete specific channels. If cmdFlags::cfRipple is set, then the TCSpace will close over the deleted material, changing all timecode location beyond the deletion point by minus the size of the deletion.
ctTrim Trim a clip or area - Currently not implemented. Use cmdType::ctSetValue and cmdGetSetValue::gsClipInfo to trim a clip, or a combination of cmdType::ctInsert, cmdType::ctDelete, cmdType::ctBlank to trim a tcspace area.
ctChanSelect Channel select - select active channels, preview passthrough channels (to preview and edit) recording channels (to create a split edit ala CMX) Requires cmdFlags::cfUsePresets and MEDIACMD::dwVideoChannels, MEDIACMD::dwAudioChannels, MEDIACMD::dwInfoChannels
ctGetState Get the current state of the controlled channel(s) - Fills the user supplied MEDIACMD structure with the current state. Look for cmdType::ctError, cmdType::ctStop, cmdType::ctEject, cmdType::ctPause, cmdType::ctPlay, cmdType::ctRecStop, cmdType::ctRecord for basic state. For valid fields, check
  • cmdFlags::cfDeferred : we have a deferred clip
  • cmdFlags::cfTimeMs : MEDIACMD::dwCmdAlt has millisecond performance counter info
  • cmdFlags::cfUseSpeed : MEDIACMD::lSpeed has the valid current speed
  • cmdFlags::cfUsePresets : MEDIACMD::dwVideoChannels, MEDIACMD::dwAudioChannels, MEDIACMD::dwInfoChannels contain preset information
  • cmdFlags::cfUsePosition : MEDIACMD::dwPosition contains current position
  • cmdFlags::cfUseStart : MEDIACMD::dwStart has starting frame position
  • cmdFlags::cfUseEnd : MEDIACMD::dwEnd has end frame postion (+1 the out is never included)
  • cmdFlags::cfUseClipID : MEDIACMD::arbID has current clip name (8 char for louth and odetics)
  • cmdFlags::cfFields : MEDIACMD::dwPosition, MEDIACMD::dwStart and MEDIACMD::dwEnd are in fields if they are valid
  • cmdFlags::cfNoReturn : return is invalid.
ctSetState Set the current state - Used for control type channels such as Serial 422 control (vvwCtl.h) and network control (vvwNet.h). Tells the controller or user what our current state is. The state should be reported honestly, as it is the receivers responsibility to transition states in an appropriate way for its controller. For actual channels (vvwInt.h, vvwExt.h, vvwNet.h-as controller, vvwDS2.h, etc), the state should be set by using one of the transport commands (cmdType::ctPlay etc) above.
ctGetValue Get a non transport setting - Used for one time setups on channel. Includes audio levels, video proc amps, audio/video input, compression type and level and many others See: cmdGetSetValue for possible commands
ctSetValue Set a non transport setting - Used for one time setups on channel. Includes audio levels, video proc amps, audio/video input, compression type and level and many others See: cmdGetSetValue for possible commands
ctValueSupported Check support for a non transport setting - Used for one time setups on channel. Includes audio levels, video proc amps, audio/video input, compression type and level and many others See: cmdGetSetValue for possible commands
ctError Indicates the an error in the channel has occurred. Return only. See MEDIACMD::dwCmdAlt for error code and MEDIACMD::arbID for message if any. These members will be valid if cmdFlags::cfUseCmdAlt and cmdFlags::cfUseClipID are set
ctTerminate Terminate Close A Channel - Only used by remote devices that cannot close the channel directly such as vvwNet.h. Channel may not actually close when this is called, but the communications pipe will be closed and wait for another connection.
ctAbort Abort the current operation - Use to abort operations that would normally ignore extraneous commands such as non-linear playback sequences, records or if the channel just seems to be stuck. Makes a good panic button.

enum cmdVidChan

Video channel bit array for MEDIACMD::dwVideoChannels

Enumerator:
vidChan0
vidChan1
vidChan2
vidChan3
vidChan4
vidChan5
vidChan6
vidChan7
vidChan8
vidChan9
vidChan10
vidChan11
vidChan12
vidChan13
vidChan14
vidChan15
vidChan16
vidChan17
vidChan18
vidChan19
vidChan20
vidChan21
vidChan22
vidChan23
vidChan24
vidChan25
vidChan26
vidChan27
vidChan28
vidChan29
vidChan30
vidChan31
vidChanAll

Generated on Wed May 17 15:52:32 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: timecode.h File Reference

  • File List
  • Globals

timecode.h File Reference

Go to the source code of this file.

Defines

#define | TC2_MIN_STRING_SIZE 14
#define | TC2_TCTYPE_MASK 0x000000FF
Mask to retrieve time code type from dwFlags.
#define | TC2_TCTYPE_FILM 0x00000001
Film 24 FPS time code.
#define | TC2_MARK_FILM '-'
#define | TC2_CHAR_FILM 'F'
#define | TC2_TCTYPE_NDF 0x00000002
Non Drop Frame 30 FPS time code.
#define | TC2_MARK_NDF ':'
#define | TC2_CHAR_NDF 'N'
#define | TC2_TCTYPE_DF 0x00000004
Drop Frame 29.97 FPS time code.
#define | TC2_MARK_DF ';'
#define | TC2_CHAR_DF 'D'
#define | TC2_TCTYPE_PAL 0x00000008
PAL 25 FPS time code.
#define | TC2_MARK_PAL '.'
#define | TC2_CHAR_PAL 'P'
#define | TC2_TCTYPE_50 0x00000010
Double PAL 50 FPS.
#define | TC2_MARK_50 0x27
#define | TC2_CHAR_50 'p'
#define | TC2_TCTYPE_5994 0x00000020
720p DROP 59.94 FPS
#define | TC2_MARK_5994 ','
#define | TC2_CHAR_5994 'd'
#define | TC2_TCTYPE_60 0x00000040
720p 60 FPS
#define | TC2_MARK_60 '='
#define | TC2_CHAR_60 'n'
#define | TC2_TCTYPE_NTSCFILM 0x00000080
23.98 FILM for NTSC 23.98 FPS (This is actually 24)
#define | TC2_MARK_NTSCFILM '_'
#define | TC2_CHAR_NTSCFILM 'f'
#define | TC2_TCTYPE_2398 0x00000084
23.98 TRUE (actual 23.98 drop per Avid)
#define | TC2_MARK_2398 '+'
#define | TC2_CHAR_2398 't'
#define | TC2_TCTYPE_100 0x00000044
Hundredths of a second HH:MM:SS:/100 100 FPS effective.
#define | TC2_MARK_100 '^'
#define | TC2_CHAR_100 '0'
#define | TC2_FTYPE_FIELD 0x10000000
Frame conversion to/from time code is in fields.
#define | TC2_STRTYPE_MASK 0x00000F00
Basic sting tc representation types area in dwFlags.
#define | TC2_STRTYPE_ASCII 0x00000100
ANSI ASCII values (human readable).
#define | TC2_STRTYPE_BCD 0x00000200
Binary Coded Decimal (RS-422 style).
#define | TC2_STRTYPE_HEX 0x00000400
Hexadecimal pack in DWORD 0xHHMMSSFF.
#define | TC2_STRTYPE_GOP 0x00000800
MPEG GOP time code encoded.
#define | TC2_STRTYPE_INVERT 0x00001000
Invert the order from HHMMSSFF to FFSSMMHH.
#define | TC2_STRTYPE_OVER_24_HOUR 0x00002000
Allow time codes larger then 24 hours - 1 frame.
#define | TC2_STREXT_MASK 0xFFFF0000
Extended string handling area in dwTypes.
#define | TC2_STREXT_MARKS 0x00010000
Add ':' marks between hours, minutes, seconds, frames in ASCII strings.
#define | TC2_STREXT_LEADING 0x00020000
Fill in the leading zeros for time code less then 10 hours.
#define | TC2_STREXT_TYPE 0x00040000
Add a single letter type ID at the end of the string ' N', ' D', ' P' or ' F'.
#define | TC2_STREXT_ALLCOLON 0x00080000
Use only colons. Normally type is indicated by the second/frames seperator.
#define | TC2_STREXT_FLAG 0x00100000
Add Drop Frame flags for BCD time codes.
#define | TC2_STREXT_CF 0x00200000
Add color frame flag for BCD time codes.
#define | TC2_STREXT_MAX30 0x00400000
Do not allow frame values greater then 29 (24 in PAL).
#define | TC2_STREXT_REVERSE 0x00800000
If generating LTC/VITC, are we playing in reverse.
#define | TC2_STREXT_ISBSTR 0x01000000
Is the ASCII string a BSTR (ActiveX, VB).
#define | TC2_STREXT_SHIFT7 0x40000000
Is it a GOP tc that will insert directly into a string?
#define | TC2_STREXT_SAVEBITS 0x80000000
Do we need to save the non time code bits when writing GOP tc.
#define | TC2_GOP25TC_TO_HEXINVERT(__dwGOP25Bit_) (((__dwGOP25Bit_ & 0xF80000) << 5) | ((__dwGOP25Bit_ & 0x07E000) << 3) | ((__dwGOP25Bit_ & 0x000FC0) << 2) | (__dwGOP25Bit_ & 0x00003F));
#define | TC2_GOP25TC_TO_HEXINVERT_ADD_DF(__dwGOP25Bit_) (__dwGOP25Bit_ | 0x20000000)
#define | TC2_HEXINVERT_TO_GOP25TC(__dwHEXInvert_) (((__dwHEXInvert_ & 0x1F000000) >> 5) | ((__dwHEXInvert_ & 0x003F0000) >> 3) | ((__dwHEXInvert_ & 0x00003F00) >> 2) | (__dwHEXInvert_ & 0x000000003F) | 0x01001000)
#define | TC2_HEXINVERT_TO_GOP25TC_ADD_DF(__dwGOP25Bit_) (__dwGOP25Bit_ | 0x1000000)
#define | TC2_ILLEGAL 0xFFFFFFFF
Illegal time code for invalid requests.

Functions

DWORD __stdcall | tc2Maximum (DWORD dwFlags)
DWORD __stdcall | tc2String (DWORD dwTcIn, DWORD dwFlags, LPSTR pszTcOut)
DWORD __stdcall | tc2Frame (LPSTR pszTcIn, DWORD dwFlags, DWORD *pdwTcOut)
DWORD __stdcall | ub2String (DWORD dwUbIn, DWORD dwFlags, LPSTR pszUbOut)
DWORD __stdcall | ub2Value (LPSTR pszUbIn, DWORD dwFlags, DWORD *pdwUbOut)

Define Documentation

#define TC2_CHAR_100 '0'

#define TC2_CHAR_2398 't'

#define TC2_CHAR_50 'p'

#define TC2_CHAR_5994 'd'

#define TC2_CHAR_60 'n'

#define TC2_CHAR_DF 'D'

#define TC2_CHAR_FILM 'F'

#define TC2_CHAR_NDF 'N'

#define TC2_CHAR_NTSCFILM 'f'

#define TC2_CHAR_PAL 'P'

#define TC2_FTYPE_FIELD 0x10000000

Frame conversion to/from time code is in fields.

#define TC2_GOP25TC_TO_HEXINVERT ( __dwGOP25Bit_ ) (((__dwGOP25Bit_ & 0xF80000) << 5) | ((__dwGOP25Bit_ & 0x07E000) << 3) | ((__dwGOP25Bit_ & 0x000FC0) << 2) | (__dwGOP25Bit_ & 0x00003F));

Convert a 25 bit GOP time code to an inverted hexidecimal time code

#define TC2_GOP25TC_TO_HEXINVERT_ADD_DF ( __dwGOP25Bit_ ) (__dwGOP25Bit_ | 0x20000000)

Convert a 25 bit GOP time code to an inverted hexidecimal time code with the drop frame flag.

#define TC2_HEXINVERT_TO_GOP25TC ( __dwHEXInvert_ ) (((__dwHEXInvert_ & 0x1F000000) >> 5) | ((__dwHEXInvert_ & 0x003F0000) >> 3) | ((__dwHEXInvert_ & 0x00003F00) >> 2) | (__dwHEXInvert_ & 0x000000003F) | 0x01001000)

Convert an inverted hexidecimal time code to a 25 bit GOP time code

#define TC2_HEXINVERT_TO_GOP25TC_ADD_DF ( __dwGOP25Bit_ ) (__dwGOP25Bit_ | 0x1000000)

Convert an inverted hexidecimal time code to a 25 bit GOP time code with the drop frame flag set

#define TC2_ILLEGAL 0xFFFFFFFF

Illegal time code for invalid requests.

#define TC2_MARK_100 '^'

#define TC2_MARK_2398 '+'

#define TC2_MARK_50 0x27

#define TC2_MARK_5994 ','

#define TC2_MARK_60 '='

#define TC2_MARK_DF ';'

#define TC2_MARK_FILM '-'

#define TC2_MARK_NDF ':'

#define TC2_MARK_NTSCFILM '_'

#define TC2_MARK_PAL '.'

#define TC2_MIN_STRING_SIZE 14

Minimum required size of a timecode string
HH:MM:SS:XX D/0

#define TC2_STREXT_ALLCOLON 0x00080000

Use only colons. Normally type is indicated by the second/frames seperator.

#define TC2_STREXT_CF 0x00200000

Add color frame flag for BCD time codes.

#define TC2_STREXT_FLAG 0x00100000

Add Drop Frame flags for BCD time codes.

#define TC2_STREXT_ISBSTR 0x01000000

Is the ASCII string a BSTR (ActiveX, VB).

#define TC2_STREXT_LEADING 0x00020000

Fill in the leading zeros for time code less then 10 hours.

#define TC2_STREXT_MARKS 0x00010000

Add ':' marks between hours, minutes, seconds, frames in ASCII strings.

#define TC2_STREXT_MASK 0xFFFF0000

Extended string handling area in dwTypes.

#define TC2_STREXT_MAX30 0x00400000

Do not allow frame values greater then 29 (24 in PAL).

#define TC2_STREXT_REVERSE 0x00800000

If generating LTC/VITC, are we playing in reverse.

#define TC2_STREXT_SAVEBITS 0x80000000

Do we need to save the non time code bits when writing GOP tc.

#define TC2_STREXT_SHIFT7 0x40000000

Is it a GOP tc that will insert directly into a string?

#define TC2_STREXT_TYPE 0x00040000

Add a single letter type ID at the end of the string ' N', ' D', ' P' or ' F'.

#define TC2_STRTYPE_ASCII 0x00000100

ANSI ASCII values (human readable).

#define TC2_STRTYPE_BCD 0x00000200

Binary Coded Decimal (RS-422 style).

#define TC2_STRTYPE_GOP 0x00000800

MPEG GOP time code encoded.

#define TC2_STRTYPE_HEX 0x00000400

Hexadecimal pack in DWORD 0xHHMMSSFF.

#define TC2_STRTYPE_INVERT 0x00001000

Invert the order from HHMMSSFF to FFSSMMHH.

#define TC2_STRTYPE_MASK 0x00000F00

Basic sting tc representation types area in dwFlags.

#define TC2_STRTYPE_OVER_24_HOUR 0x00002000

Allow time codes larger then 24 hours - 1 frame.

#define TC2_TCTYPE_100 0x00000044

Hundredths of a second HH:MM:SS:/100 100 FPS effective.

#define TC2_TCTYPE_2398 0x00000084

23.98 TRUE (actual 23.98 drop per Avid)

#define TC2_TCTYPE_50 0x00000010

Double PAL 50 FPS.

#define TC2_TCTYPE_5994 0x00000020

720p DROP 59.94 FPS

#define TC2_TCTYPE_60 0x00000040

720p 60 FPS

#define TC2_TCTYPE_DF 0x00000004

Drop Frame 29.97 FPS time code.

#define TC2_TCTYPE_FILM 0x00000001

Film 24 FPS time code.

#define TC2_TCTYPE_MASK 0x000000FF

Mask to retrieve time code type from dwFlags.

#define TC2_TCTYPE_NDF 0x00000002

Non Drop Frame 30 FPS time code.

#define TC2_TCTYPE_NTSCFILM 0x00000080

23.98 FILM for NTSC 23.98 FPS (This is actually 24)

#define TC2_TCTYPE_PAL 0x00000008

PAL 25 FPS time code.

Function Documentation

DWORD __stdcall tc2Frame | ( | LPSTR | pszTcIn,
 |  | DWORD | dwFlags,
 |  | DWORD * | pdwTcOut
 | ) |

Convert the string pszTcIn to a numeric count pdwTcOut as specified by dwFlags

DWORD __stdcall tc2Maximum ( DWORD dwFlags )

Return the maximum possible value for flag combination for a day (24 hours)

DWORD __stdcall tc2String | ( | DWORD | dwTcIn,
 |  | DWORD | dwFlags,
 |  | LPSTR | pszTcOut
 | ) |

Convert the numeric count dwTcIn to the string pszTcOut as specified by dwFlags

DWORD __stdcall ub2String | ( | DWORD | dwUbIn,
 |  | DWORD | dwFlags,
 |  | LPSTR | pszUbOut
 | ) |

Convert the numeric count dwUbIn to the string pszUbOut as specified by dwFlags

DWORD __stdcall ub2Value | ( | LPSTR | pszUbIn,
 |  | DWORD | dwFlags,
 |  | DWORD * | pdwUbOut
 | ) |

Convert the string pszUbIn to a numeric count pdwUbOut as specified by dwFlags

Generated on Wed May 17 15:52:33 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: vvw.h File Reference

  • File List
  • Globals

vvw.h File Reference

Go to the source code of this file.

Defines

#define | _VVW_H_MAINHEADER_INCLUDED
#define | VVWHANDLE DWORD
Opaque handle to a channel.
#define | _VVW_STANDARD_PIPE_NAME "vvwMediaCmd{7D682107-A9F6-40a2-9508-DC02CEF1AA9B}"

Typedefs

typedef DWORD(__stdcall * | FCN_VVW_INIT )(void)
Function Pointer: vvwInit().
typedef DWORD(__stdcall * | FCN_VVW_START )(void)
Function Pointer: vvwStart().
typedef DWORD(__stdcall * | FCN_VVW_QUIT )(void)
Function Pointer: vvwQuit().
typedef DWORD(__stdcall * | FCN_VVW_INIT_INT )(void)
Function Pointer: vvwInitInt() - internal.
typedef DWORD(__stdcall * | FCN_VVW_OPEN )(DWORD dwChannelIndex)
Function Pointer: vvwOpen().
typedef DWORD(__stdcall * | FCN_VVW_CONFIGURE )(DWORD dwChannelIndex, HANDLE hWnd)
Function Pointer: vvwConfigure().
typedef DWORD(__stdcall * | FCN_VVW_CMD )(DWORD hVVW, PMEDIACMD pCmd)
Function Pointer: vvwCmd().
typedef DWORD(__stdcall * | FCN_VVW_CLOSE )(DWORD hVVW)
Function Pointer: vvwClose().
typedef DWORD(__stdcall * | FCN_VVW_SETMEDIACMD )(void *pCtlRx, FCN_VVW_CMD pVvwCmd)
Function Pointer: vvwSetMediaCmd() - internal.

Functions

void *__stdcall | vvwChannelToHandle (long lChannel)
long __stdcall | vvwHandleToChannel (void *hVvw)
long __stdcall | vvwEnableChannels (long lInternal0_31, long lInternal32_63, long lExternal64_95, long lExternal96_127, long lNetwork128_159, long lNetwork160_191)
long __stdcall | vvwReleaseChannels (void)
long __stdcall | vvwGetMaxChannels (void)
long __stdcall | vvwGetChannelName (long lChannel, char *szChannelName)
long __stdcall | vvwGetChannelType (long lChannel)
long __stdcall | vvwShowConfigDialog (long lChannel, long hWnd)
long __stdcall | vvwPlay (long lChannel)
long __stdcall | vvwPlayAtSpeed (long lChannel, long lVVWSpeed)
long __stdcall | vvwPlayFromTo (long lChannel, long lFrom, long lTo, BOOL fDeferred)
long __stdcall | vvwLoadClip (long lChannel, char *sz8CharClipName, long lStartFrame)
long __stdcall | vvwPlayClip (long lChannel, char *sz8CharClipName, BOOL fDeferred)
long __stdcall | vvwPlayClipFromTo (long lChannel, char *sz8CharClipName, long lFrom, long lTo, BOOL fDeferred)
long __stdcall | vvwFastForward (long lChannel)
long __stdcall | vvwFastRewind (long lChannel)
long __stdcall | vvwPause (long lChannel)
long __stdcall | vvwSeek (long lChannel, long lFrame)
long __stdcall | vvwSeekRelative (long lChannel, long lFrameOffset)
long __stdcall | vvwStop (long lChannel)
long __stdcall | vvwRecord (long lChannel)
long __stdcall | vvwRecordFromTo (long lChannel, long lFrom, long lTo)
long __stdcall | vvwRecordStop (long lChannel, char *sz8CharClipName, long lDuration)
long __stdcall | vvwSetRecordPresets (long lChannel, long lVidEdit, long lAudEdit, long lInfEdit)
long __stdcall | vvwEject (long lChannel)
long __stdcall | vvwMediaCmd (long lChannel, void *pMediaCmd)
long __stdcall | vvwTransfer (long lChannel, long lTargetChannel, long lPosition, long lStart, long lEnd, long lVidEdit, long lAudEdit, long lInfEdit, char *szClipName, BOOL fToTape)
long __stdcall | vvwUpdateStatus (long lChannel)
long __stdcall | vvwGetState (long lChannel)
long __stdcall | vvwGetFlags (long lChannel)
long __stdcall | vvwGetSpeed (long lChannel)
long __stdcall | vvwGetPosition (long lChannel)
long __stdcall | vvwGetLastMs (long lChannel)
long __stdcall | vvwGetStart (long lChannel)
long __stdcall | vvwGetEnd (long lChannel)
long __stdcall | vvwGetClipName (long lChannel, char *sz8CharClipName)
long __stdcall | vvwGetFileName (long lChannel, char *sz260CharFileName)
long __stdcall | vvwGetCurTC (long lChannel, char *sz14ByteTC)
long __stdcall | vvwGetCurState (long lChannel, char *sz14ByteState)
char *__stdcall | vvwGetNextClip (long lChannel, char *sz8CharLastClipCurClip)
long __stdcall | vvwGetClipInfo (long lChannel, char *sz8CharClipName, long *lStart, long *lEnd, long *lVidEdit, long *lAudEdit, long *lInfEdit, char *szFileName)
long __stdcall | vvwGetNextClipEx (long lChannel, char *sz8CharClipName, long *lCreation, long *lLastModification, long *lFileSize, long *lDiskFragments)
long __stdcall | vvwCopyClip (long lChannel, char *szSourceClip, char *szDestClip, long lStart, long lEnd)
long __stdcall | vvwEDLResetToStart (long lChannel)
long __stdcall | vvwEDLGetEdit (long lChannel, long *lRecordIn, long *lPlayIn, long *lPlayOut, long *lVidEdit, long *lAudEdit, long *lInfEdit, char *sz8CharClipName, char *sz260CharFileName)
long __stdcall | vvwGetLastChangeXferMs (long lChannel)
long __stdcall | vvwGetLastChangeMs (long lChannel)
long __stdcall | vvwInsert (long lChannel, char *szClipName, char *szFileName, long lPosition, long lStart, long lEnd, long lVidEdit, long lAudEdit, long lInfEdit, BOOL fRipple)
long __stdcall | vvwBlank (long lChannel, char *szClipName, long lStart, long lEnd, long lVidEdit, long lAudEdit, long lInfEdit, BOOL fRipple)
long __stdcall | vvwDelete (long lChannel, char *szClipName, long lStart, long lEnd, long lVidEdit, long lAudEdit, long lInfEdit, BOOL fRipple)
long __stdcall | vvwTrim (long lChannel, long lPosition, long lStartOffset, long lEndOffset, long lVidEdit, long lAudEdit, long lInfEdit, BOOL fRipple)
long __stdcall | vvwValueSupported (long lChannel, long lValueType)
long __stdcall | vvwValueGet (long lChannel, long lValueType, long *plMin, long *plMax)
long __stdcall | vvwValueSet (long lChannel, long lValueType, long lSetting)
long __stdcall | vvwValueSet2 (long lChannel, long lValueType, long lSetting, long lStart, long lEnd, long lVidChan, long lAudChan, long lInfChan)
long __stdcall | vvwGetClipMode (long lChannel)
long __stdcall | vvwSetClipMode (long lChannel, long lSetting)
long __stdcall | vvwGetTCType (long lChannel)
long __stdcall | vvwSetTCType (long lChannel, long lSetting)
long __stdcall | vvwGetTCSource (long lChannel)
long __stdcall | vvwSetTCSource (long lChannel, long lSetting)
long __stdcall | vvwGetAutoMode (long lChannel)
long __stdcall | vvwSetAutoMode (long lChannel, long lSetting)
long __stdcall | vvwGetAvailablePresets (long lChannel, long *plVidEdit, long *plAudEdit, long *plInfEdit)
long __stdcall | vvwGetAudioInput (long lChannel)
long __stdcall | vvwSetAudioInput (long lChannel, long lSetting)
long __stdcall | vvwGetAudioInputLevel (long lChannel)
long __stdcall | vvwSetAudioInputLevel (long lChannel, long lSetting)
long __stdcall | vvwGetAudioOutput (long lChannel)
long __stdcall | vvwSetAudioOutput (long lChannel, long lSetting)
long __stdcall | vvwGetAudioOutputLevel (long lChannel)
long __stdcall | vvwSetAudioOutputLevel (long lChannel, long lSetting)
long __stdcall | vvwGetAudioPeakRMS (long lChannel, long lAudEdit, long *plPeaks)
long __stdcall | vvwGetVideoInput (long lChannel)
long __stdcall | vvwSetVideoInput (long lChannel, long lSetting)
long __stdcall | vvwGetVideoOutput (long lChannel)
long __stdcall | vvwSetVideoOutput (long lChannel, long lSetting)
long __stdcall | vvwGetVideoInputSetup (long lChannel)
long __stdcall | vvwSetVideoInputSetup (long lChannel, long lSetting)
long __stdcall | vvwGetVideoInputVideo (long lChannel)
long __stdcall | vvwSetVideoInputVideo (long lChannel, long lSetting)
long __stdcall | vvwGetVideoInputHue (long lChannel)
long __stdcall | vvwSetVideoInputHue (long lChannel, long lSetting)
long __stdcall | vvwGetVideoInputChroma (long lChannel)
long __stdcall | vvwSetVideoInputChroma (long lChannel, long lSetting)
long __stdcall | vvwGetVideoTBCSetup (long lChannel)
long __stdcall | vvwSetVideoTBCSetup (long lChannel, long lSetting)
long __stdcall | vvwGetVideoTBCVideo (long lChannel)
long __stdcall | vvwSetVideoTBCVideo (long lChannel, long lSetting)
long __stdcall | vvwGetVideoTBCHue (long lChannel)
long __stdcall | vvwSetVideoTBCHue (long lChannel, long lSetting)
long __stdcall | vvwGetVideoTBCChroma (long lChannel)
long __stdcall | vvwSetVideoTBCChroma (long lChannel, long lSetting)
long __stdcall | vvwGetVideoGenlock (long lChannel)
long __stdcall | vvwSetVideoGenlock (long lChannel, long lSetting)
long __stdcall | vvwGetVideoGenlockSource (long lChannel)
long __stdcall | vvwSetVideoGenlockSource (long lChannel, long lSetting)
long __stdcall | vvwGetCompressionRate (long lChannel)
long __stdcall | vvwSetCompressionRate (long lChannel, long lSetting)
long __stdcall | vvwGetSuperImpose (long lChannel)
long __stdcall | vvwSetSuperImpose (long lChannel, long lSetting)
long __stdcall | vvwGetErrorLogMs ()
long __stdcall | vvwSetErrorLog (long lSetting)
long __stdcall | vvwGetErrorLength (long *plLastError, long *plErrorLength)
long __stdcall | vvwGetError (long *plLastError, long *plSeverity, char *szError)
long __stdcall | vvwGetTotalTime (long lChannel)
long __stdcall | vvwGetFreeTime (long lChannel)
long __stdcall | vvwGetTotalStorage (long lChannel)
long __stdcall | vvwGetFreeStorage (long lChannel)
long __stdcall | vvwGetCurMs (long lChannel)
long __stdcall | vvwGetChannelCapabilities (long lChannel)
char *__stdcall | vvwGetVVWVersion ()
char *__stdcall | vvwGetMRVersion ()
char *__stdcall | vvwGetVVWType (long lChannel)
long __stdcall | vvwGetPiconName (char *szFileName)
void __stdcall | vvwFreeString (char *szString)
DWORD __stdcall | vvwInit (void)
DWORD __stdcall | vvwInitInt (void)
DWORD __stdcall | vvwStart (void)
DWORD __stdcall | vvwQuit (void)
DWORD __stdcall | vvwOpen (DWORD dwChannelIndex)
DWORD __stdcall | vvwCmd (DWORD hVVW, PMEDIACMD pCmd)
DWORD __stdcall | vvwConfigure (DWORD dwChannelIndex, HANDLE hWnd)
DWORD __stdcall | vvwClose (DWORD hVVW)
DWORD __stdcall | __vvwInitService (void)
Internal: Do not call.
DWORD __stdcall | __vvwQuitService (void)
Internal: Do not call.
DWORD __stdcall | vvwStartService (void)
Internal: Do not call.
DWORD __stdcall | vvwStopService (void)
Internal: Do not call.
DWORD __stdcall | vvwSaveRegistry (char *szFileName)
Internal: Do not call.
DWORD __stdcall | vvwSaveVVWRegistry (char *szFileName)
Internal: Do not call.
DWORD __stdcall | vvwSaveWindowsRegistry (char *szFileName)
Internal: Do not call.
DWORD __stdcall | vvwLoadRegistry (char *szFileName)
Internal: Do not call.
DWORD __stdcall | vvvwLoadDefaultRegistry (void)
Internal: Do not call.

Define Documentation

#define _VVW_H_MAINHEADER_INCLUDED

#define _VVW_STANDARD_PIPE_NAME "vvwMediaCmd{7D682107-A9F6-40a2-9508-DC02CEF1AA9B}"

#define VVWHANDLE DWORD

Opaque handle to a channel.

Typedef Documentation

typedef DWORD(__stdcall * FCN_VVW_CLOSE)(DWORD hVVW)

Function Pointer: vvwClose().

typedef DWORD(__stdcall * FCN_VVW_CMD)(DWORD hVVW, PMEDIACMD pCmd)

Function Pointer: vvwCmd().

typedef DWORD(__stdcall * FCN_VVW_CONFIGURE)(DWORD dwChannelIndex, HANDLE hWnd)

Function Pointer: vvwConfigure().

typedef DWORD(__stdcall * FCN_VVW_INIT)(void)

Function Pointer: vvwInit().

typedef DWORD(__stdcall * FCN_VVW_INIT_INT)(void)

Function Pointer: vvwInitInt() - internal.

typedef DWORD(__stdcall * FCN_VVW_OPEN)(DWORD dwChannelIndex)

Function Pointer: vvwOpen().

typedef DWORD(__stdcall * FCN_VVW_QUIT)(void)

Function Pointer: vvwQuit().

typedef DWORD(__stdcall * FCN_VVW_SETMEDIACMD)(void *pCtlRx, FCN_VVW_CMD pVvwCmd)

Function Pointer: vvwSetMediaCmd() - internal.

typedef DWORD(__stdcall * FCN_VVW_START)(void)

Function Pointer: vvwStart().

Function Documentation

DWORD __stdcall __vvwInitService ( void )

Internal: Do not call.

DWORD __stdcall __vvwQuitService ( void )

Internal: Do not call.

DWORD __stdcall vvvwLoadDefaultRegistry ( void )

Internal: Do not call.

long __stdcall vvwBlank | ( | long | lChannel,
 |  | char * | szClipName,
 |  | long | lStart,
 |  | long | lEnd,
 |  | long | lVidEdit,
 |  | long | lAudEdit,
 |  | long | lInfEdit,
 |  | BOOL | fRipple
 | ) |

void* __stdcall vvwChannelToHandle ( long lChannel )

Convert a 0..3 channel to 0, 64, 65536 Mostly internal Undocumented

DWORD __stdcall vvwClose ( DWORD hVVW )

DWORD __stdcall vvwCmd | ( | DWORD | hVVW,
 |  | PMEDIACMD | pCmd
 | ) |

Send a media command at the VVW channel

DWORD __stdcall vvwConfigure | ( | DWORD | dwChannelIndex,
 |  | HANDLE | hWnd
 | ) |

Open the selected VVW channel

long __stdcall vvwCopyClip | ( | long | lChannel,
 |  | char * | szSourceClip,
 |  | char * | szDestClip,
 |  | long | lStart,
 |  | long | lEnd
 | ) |

Create a virtual copy of a clip, changing the in and out points if necessary. To use the whole clip, set lStart to 0 and the end to –1. Returns 0 if successful, else an error code.

long __stdcall vvwDelete | ( | long | lChannel,
 |  | char * | szClipName,
 |  | long | lStart,
 |  | long | lEnd,
 |  | long | lVidEdit,
 |  | long | lAudEdit,
 |  | long | lInfEdit,
 |  | BOOL | fRipple
 | ) |

long __stdcall vvwEDLGetEdit | ( | long | lChannel,
 |  | long * | lRecordIn,
 |  | long * | lPlayIn,
 |  | long * | lPlayOut,
 |  | long * | lVidEdit,
 |  | long * | lAudEdit,
 |  | long * | lInfEdit,
 |  | char * | sz8CharClipName,
 |  | char * | sz260CharFileName
 | ) |

Returns an edit line from the VTR space of an internal channel. The function will continue to return the next edit in the timecode space until the last edit is returned, after which an error will be returned. To reset to the start of the Edl use EDLResetToStart. Returns 0 if successfule else an Error code.

long __stdcall vvwEDLResetToStart ( long lChannel )

Reset the edl returns in VTR mode to the first element of the list.

long __stdcall vvwEject ( long lChannel )

Eject the current media if it is removable. Normally only used with VTRs. Returns 0 if successful, else an error code.

long __stdcall vvwEnableChannels | ( | long | lInternal0_31,
 |  | long | lInternal32_63,
 |  | long | lExternal64_95,
 |  | long | lExternal96_127,
 |  | long | lNetwork128_159,
 |  | long | lNetwork160_191
 | ) |

Enable or disable channels based on the bit array supplied. VVW can contain up to 256 channels per access point. Channels 193-255 are disabled by default. The remaining channels may be enabled (if the corresponding bit is set to 1) or disabled (if the corresponding bit is set to 0) with this call. The first 64 channels (0 through 63) are reserved for internal ddr channels. Then next 64 channels (64 through 127) are reserved for VTR or DDR devices controlled via serial, Odetics or Louth protocol. The remaining channels are for controlling other devices through the network. Please note that a network channel controls all the channels on the network server box, so disabling one network connection may disable more than one channel. Always call GetMaxChannels() after setting the bits to make sure all the channels you expect exist actually exist. This should be the first call made to the activex component.

long __stdcall vvwFastForward ( long lChannel )

Set the channel into its fastest possible forward motion state. Returns 0 if successful, else an error code.

long __stdcall vvwFastRewind ( long lChannel )

Set the channel into its fastest possible reverse motion state. Returns 0 if successful, else an error code.

void __stdcall vvwFreeString ( char * szString )

Free a string value returned by the channel.

long __stdcall vvwGetAudioInput ( long lChannel )

ADD FUNCTION lAudIn Get the current audio input. GS_AUDSELECT_UNBALANCED_10 GS_AUDSELECT_UNBALANCED_4 GS_AUDSELECT_BALANCED_10 GS_AUDSELECT_BALANCED_4 GS_AUDSELECT_SPDIF GS_AUDSELECT_AES_EBU GS_AUDSELECT_EMBEDDED

long __stdcall vvwGetAudioInputLevel ( long lChannel )

Get the current audio input level

long __stdcall vvwGetAudioOutput ( long lChannel )

Get the current audio Output – See Get/SetAudioInput GS_AUDSELECT_UNBALANCED_10 GS_AUDSELECT_UNBALANCED_4 GS_AUDSELECT_BALANCED_10 GS_AUDSELECT_BALANCED_4 GS_AUDSELECT_SPDIF GS_AUDSELECT_AES_EBU GS_AUDSELECT_EMBEDDED

long __stdcall vvwGetAudioOutputLevel ( long lChannel )

Get the current audio output level.

long __stdcall vvwGetAudioPeakRMS | ( | long | lChannel,
 |  | long | lAudEdit,
 |  | long * | plPeaks
 | ) |

Returns the RMS and Peak audio levels of the input (stop/record) or output (play/pause).

long __stdcall vvwGetAutoMode ( long lChannel )

Calls ValueXXX with gsAutoMode. Required for play lists, deferred commands and auto edit commands on VTRs.

long __stdcall vvwGetAvailablePresets | ( | long | lChannel,
 |  | long * | plVidEdit,
 |  | long * | plAudEdit,
 |  | long * | plInfEdit
 | ) |

ADD FUNCTIONS lVidEdit, lAudEdit, lInfEdit Returns the supported audio, video and info presets for a channel.

long __stdcall vvwGetChannelCapabilities ( long lChannel )

Get the available commands for a channel.

long __stdcall vvwGetChannelName | ( | long | lChannel,
 |  | char * | szChannelName
 | ) |

Get the name of the current channel. For unix and dll access, pass a null to get the channel name size, then pass in a pointer that points to a memory size of at least that many bytes (ANSI characters only).

long __stdcall vvwGetChannelType ( long lChannel )

Returns the basic type of the channel (VTR, Internal, User, House) VVW_CHANTYPE_HOUSE 0x1 1 VVW_CHANTYPE_INTERNAL 0x2 2 VVW_CHANTYPE_VTR_DDR 0x4 4 VVW_CHANTYPE_UNKNOWN 0xFFFFFFFF -1

long __stdcall vvwGetClipInfo | ( | long | lChannel,
 |  | char * | sz8CharClipName,
 |  | long * | lStart,
 |  | long * | lEnd,
 |  | long * | lVidEdit,
 |  | long * | lAudEdit,
 |  | long * | lInfEdit,
 |  | char * | szFileName
 | ) |

Retuns the basic information from szClip. The information is located in lStart, lEnd, lVidEdit, lAudEdit and szFileName as the in point, out point, number of video channels, number of audio channels, and the file name respectively. Returns 0 if successful, else an error code.

long __stdcall vvwGetClipMode ( long lChannel )

Calls ValueXXX with gsClipMode. If equal to 1 then the channel is in clip mode, if 0 the channel is in VTR mode.

long __stdcall vvwGetClipName | ( | long | lChannel,
 |  | char * | sz8CharClipName
 | ) |

Only supported in clip Mode. Returns the current clip name, if any. For dll access, the memory must be at least 9 bytes long (8 character bytes + NULL) and is always ANSI.

long __stdcall vvwGetCompressionRate ( long lChannel )

Get the current compression rate

long __stdcall vvwGetCurMs ( long lChannel )

Get the current millisecond time.

long __stdcall vvwGetCurState | ( | long | lChannel,
 |  | char * | sz14ByteState
 | ) |

Returns the current state as a string (e.g. “Play”). For dll access, the memory must always be at least 15 bytes long (14 byte state + NULL) and is always ANSI.

long __stdcall vvwGetCurTC | ( | long | lChannel,
 |  | char * | sz14ByteTC
 | ) |

Returns the current time code as a string (e.g. “00:01:00:00”). For dll access, the memory must always be at least 15 bytes long (14 byte time code plus id + NULL) and is always ANSI.

long __stdcall vvwGetEnd ( long lChannel )

Return the current end point or out point if cfUseEnd is set.

long __stdcall vvwGetError | ( | long * | plLastError,
 |  | long * | plSeverity,
 |  | char * | szError
 | ) |

Get the current error. Sets pointer to the next one automatically

long __stdcall vvwGetErrorLength | ( | long * | plLastError,
 |  | long * | plErrorLength
 | ) |

Get the length of the current error string

long __stdcall vvwGetErrorLogMs ( )

Get the ms time the last error was added to the error log

long __stdcall vvwGetFileName | ( | long | lChannel,
 |  | char * | sz260CharFileName
 | ) |

Returns the current file name, if any. For dll access, the memory must be at lease 261 bytes long (260 bytes max path + NULL) and is always ANSI.

long __stdcall vvwGetFlags ( long lChannel )

Returns the current flags

cfDeferred = 1, // 0x00000001 This is a delayed cfOverideDeferred = 1 << 30,// 0x40000000 Overide all previous deferred commands cfTimeMs = 1 << 1, // 0x00000002 Use Millisecond time for delayed time, not fields cfTimeTarget = 1 << 2, // 0x00000004 Delayed time is offset from current time code cfTimeHouseClock = 1 << 3, // 0x00000008 Delayed time is based on absolute (real) time cfUseSpeed = 1 << 4, // 0x00000010 Set the new speed cfUsePresets = 1 << 5, // 0x00000020 Use video and audio edit presets cfUsePosition = 1 << 6, // 0x00000040 Use the position setting cfUsePositionOffset = 1 << 7, // 0x00000080 Position is an offset cfUseStart = 1 << 8, // 0x00000100 Start a new timecode cfUseStartOffset = 1 << 9, // 0x00000200 Start is an offset from current tc cfUseEnd = 1 << 10, // 0x00000400 End command as specified cfUseEndOffset = 1 << 11, // 0x00000800 End is and offset from current tc cfUseAllIDs = 1 << 12, // 0x00001000 Use all clip IDs cfUseClipID = 1 << 13, // 0x00002000 Use new clip ID, otherwise use last or none cfNoClipFiles = 1 << 14, // 0x00004000 Use new clip ID, otherwise use last or none cfNoTCSpaces = 1 << 15, // 0x00008000 Use new clip ID, otherwise use last or none cfUseCmdAlt = 1 << 16, // 0x00010000 Use the dwCmdAlt cfIsShuttle = 1 << 17, // 0x00020000 Use speed in play for shuttle cfFields = 1 << 20, // 0x00100000 Position, start and end are fields, not frames cfRipple = 1 << 21, // 0x00200000 Ripple for insert or delete cfLoop = 1 << 22, // 0x00400000 Loop the clip or in out cfTrigger = 1 << 23, // 0x00800000 Trigger using dsync class cfPreview = 1 << 24, // 0x01000000 Preview set (EE, non rt play) cfInvert = 1 << 28, // 0x10000000 Invert a transfer cfTest = 1 << 29, // 0x20000000 See if the command exists cfNoReturn = 1 << 31, // 0x80000000 No return mediacmd is required

long __stdcall vvwGetFreeStorage ( long lChannel )

Returns the amount of available storage for recording in megabytes.

long __stdcall vvwGetFreeTime ( long lChannel )

Returns the remaining number of frames of storage available at current compression rate.

long __stdcall vvwGetLastChangeMs ( long lChannel )

Returns the millisecond time of the last change in the current mode (clip or vtr).

long __stdcall vvwGetLastChangeXferMs ( long lChannel )

Returns the millisecond time of the last change in the transfer queue

long __stdcall vvwGetLastMs ( long lChannel )

Returns the millisecond time the last status occurred (time of the last vertical blank).

long __stdcall vvwGetMaxChannels ( void )

Returns the maximum number of channels available for control. Channels start at 0 and end at max channels – 1. This return is one greater than the largest value available for SetCurChannel(), GetCurChannel() and the lChannel parameter for the DLL interface.

char* __stdcall vvwGetMRVersion ( )

Returns the version string of the MediaReactor subsystem.

char* __stdcall vvwGetNextClip | ( | long | lChannel,
 |  | char * | sz8CharLastClipCurClip
 | ) |

Clip Mode Only. Returns the next clip identifier. To get the first clip, szLastClip should be an empty string. Once the last clip available has been returned, GetNextClip will return an error or NULL for unix/dll access. Please note: For unix/dll access, the sz8CharLastClipCurClip memory area is used for the new clip. The previous clip name is therefore lost and the memory is not allocated by the vvw. Returns 0 if successful, else an error code.

long __stdcall vvwGetNextClipEx | ( | long | lChannel,
 |  | char * | sz8CharClipName,
 |  | long * | lCreation,
 |  | long * | lLastModification,
 |  | long * | lFileSize,
 |  | long * | lDiskFragments
 | ) |

Retuns the extended information from szClip. The information is located in lStart, lEnd, lVidEdit, lAudEdit and szFileName as time of creation, last modified date, the file size, and the number of fragments in the file respectively.

long __stdcall vvwGetPiconName ( char * szFileName )

Get the name of a picon file from the media file's name

long __stdcall vvwGetPosition ( long lChannel )

Returns the current position if the cfUsePosition flag is set, otherwise invalid.

long __stdcall vvwGetSpeed ( long lChannel )

Returns the current VVW speed if the cfUseSpeed flag is set, otherwise pause or full play speed. VVW speeds are based on 65520 as the play speed. To translate to decimal number where 1.0 represents play, use the following formula: D1Speed = ((double)VVWSpeed / 65520.0) For percentages, where 100.0 represents play speed, use the following formula: Dpercent = (((double)VVWSpeed * 100.0) / 65520.0) = ((double)VVWSpeed / 655.2) XML: See <MediaCmd> root element, <Speed> sub-element

Typical VVW speeds (note speeds are linear): Pause 0% 0 Play 100% 65520 Half Play 50% 32760 Rev Play -100% -65520 Rev 2 x Play-200% 131040 10 x Play 1000% 655200 Max Play 90000% 5896800 Max Rev -90000-5896800

long __stdcall vvwGetStart ( long lChannel )

Returns the current start or in point if the cfUseStart flag is set.

long __stdcall vvwGetState ( long lChannel )

Returns the current state

ctStop 0 // Stop all action ctPause 1 // Pause, Seek ctPlay 2 // Play at specified speed (includes pause) ctRecord 3 // Record at specified speed ctRecStop 4 // Stop ready for recording ctEject 5 // Eject the current media ctError 17 // An error has occurred ctAbort 19 // Abort any queued commands

long __stdcall vvwGetSuperImpose ( long lChannel )

Get the status of the super imposed time code overlay

long __stdcall vvwGetTCSource ( long lChannel )

Calls ValueXXX with gsTcSource (VITC, LTC, Control, Clip). GS_TCSOURCE_LTC, GS_TCSOURCE_VITC, GS_TCSOURCE_CTL or GS_TCSOURCE_CLIP

long __stdcall vvwGetTCType ( long lChannel )

Calls ValueXXX with gsTcType (drop frame, non drop frame, pal). TC2_TCTYPE_FILM, TC2_TCTYPE_NDF, TC2_TCTYPE_DF, TC2_TCTYPE_PAL, TC2_TCTYPE_50, TC2_TCTYPE_5994, TC2_TCTYPE_60, TC2_TCTYPE_NTSCFILM, TC2_TCTYPE_2398, TC2_TCTYPE_100

long __stdcall vvwGetTotalStorage ( long lChannel )

Returns the total storage connected in megabytes.

long __stdcall vvwGetTotalTime ( long lChannel )

Returns the total number of frames of storage available at current compression rate if the storage space was empty.

long __stdcall vvwGetVideoGenlock ( long lChannel )

Turn the house/reference lock on or off

long __stdcall vvwGetVideoGenlockSource ( long lChannel )

Set the genlock source to input or external reference

long __stdcall vvwGetVideoInput ( long lChannel )

Get the current video input. GS_VIDSELECT_COMPOSITE, GS_VIDSELECT_COMPOSITE_2, GS_VIDSELECT_SVIDEO, GS_VIDSELECT_COMPONENT_YUV, GS_VIDSELECT_COMPONENT_YUV_M2, GS_VIDSELECT_COMPONENT_YUV_SMPTE, GS_VIDSELECT_COMPONENT_RGB, GS_VIDSELECT_D1_SERIAL, GS_VIDSELECT_D1_PARALLEL, GS_VIDSELECT_SDTI, GS_VIDSELECT_NONE

long __stdcall vvwGetVideoInputChroma ( long lChannel )

Get the current video input’s ‘Chroma’ TBC setting.

long __stdcall vvwGetVideoInputHue ( long lChannel )

Get the current video input’s ‘Hue’ TBC setting.

long __stdcall vvwGetVideoInputSetup ( long lChannel )

Get the current video input’s ‘Setup’ TBC setting.

long __stdcall vvwGetVideoInputVideo ( long lChannel )

Get the current video input’s ‘Video’ TBC setting.

long __stdcall vvwGetVideoOutput ( long lChannel )

Get the current video output. See Get/SetVideoInput for settings. GS_VIDSELECT_COMPOSITE, GS_VIDSELECT_COMPOSITE_2, GS_VIDSELECT_SVIDEO, GS_VIDSELECT_COMPONENT_YUV, GS_VIDSELECT_COMPONENT_YUV_M2, GS_VIDSELECT_COMPONENT_YUV_SMPTE, GS_VIDSELECT_COMPONENT_RGB, GS_VIDSELECT_D1_SERIAL, GS_VIDSELECT_D1_PARALLEL, GS_VIDSELECT_SDTI, GS_VIDSELECT_NONE

long __stdcall vvwGetVideoTBCChroma ( long lChannel )

Get the current global TBC’s ‘Chroma’ setting.

long __stdcall vvwGetVideoTBCHue ( long lChannel )

Get the current global TBC’s ‘Hue’ setting.

long __stdcall vvwGetVideoTBCSetup ( long lChannel )

Get the current global TBC’s ‘Setup’ setting.

long __stdcall vvwGetVideoTBCVideo ( long lChannel )

Get the current global TBC’s ‘Video’ setting.

char* __stdcall vvwGetVVWType ( long lChannel )

Returns the type string of the VVW channel.

char* __stdcall vvwGetVVWVersion ( )

Returns the version string of the VVW subsystem.

long __stdcall vvwHandleToChannel ( void * hVvw )

Convert a 0, 64, 65536 to 0..3 Mostly internal Undocumented

DWORD __stdcall vvwInit ( void )

Init - called to initialize the subsystem before any Start, Load, Open, Cmd, Configure or Close Called once for the entire system

DWORD __stdcall vvwInitInt ( void )

Init - called to initialize the subsystem before any Start, Load, Open, Cmd, Configure or Close Called once for the entire system

long __stdcall vvwInsert | ( | long | lChannel,
 |  | char * | szClipName,
 |  | char * | szFileName,
 |  | long | lPosition,
 |  | long | lStart,
 |  | long | lEnd,
 |  | long | lVidEdit,
 |  | long | lAudEdit,
 |  | long | lInfEdit,
 |  | BOOL | fRipple
 | ) |

long __stdcall vvwLoadClip | ( | long | lChannel,
 |  | char * | sz8CharClipName,
 |  | long | lStartFrame
 | ) |

Clip Mode Only. Load a clip into the channel and display the lStartFrame. Returns 0 if successful, else an error code.

DWORD __stdcall vvwLoadRegistry ( char * szFileName )

Internal: Do not call.

long __stdcall vvwMediaCmd | ( | long | lChannel,
 |  | void * | pMediaCmd
 | ) |

MediaCmd direct access

DWORD __stdcall vvwOpen ( DWORD dwChannelIndex )

Open the selected VVW channel

long __stdcall vvwPause ( long lChannel )

Stop playback and display the current frame. Returns 0 if successful, else an error code.

long __stdcall vvwPlay ( long lChannel )

Play at normal speed. Returns 0 if successful, else an error code.

long __stdcall vvwPlayAtSpeed | ( | long | lChannel,
 |  | long | lVVWSpeed
 | ) |

Play at a particular VVW speed. VVW speeds use a base play speed of 65520. This means that play = 65520, reverse play = -65520, four times play = 262080, half play speed = 32760. Percentage play speeds may be converted to VVW speeds using the PercentageToVVWSpeed() function. For Speed calculations please see GetSpeed() below. Returns 0 if successful, else an error code.

long __stdcall vvwPlayClip | ( | long | lChannel,
 |  | char * | sz8CharClipName,
 |  | BOOL | fDeferred
 | ) |

Clip Mode Only. Play the entire clip specified by clip name. If the deferred flag is true, clip playback will only occur once the currently playing clip has finished. If there is no currently playing clip, playback will occur immediately. Returns 0 if successful, else an error code.

long __stdcall vvwPlayClipFromTo | ( | long | lChannel,
 |  | char * | sz8CharClipName,
 |  | long | lFrom,
 |  | long | lTo,
 |  | BOOL | fDeferred
 | ) |

Clip Mode Only. Play the specified portion of the clip specified by clip name. If the deferred flag is true, clip playback will only occur once the currently playing clip has finished. If there is no clip currently playing, playback will occur immediately. Returns 0 if successful, else an error code.

long __stdcall vvwPlayFromTo | ( | long | lChannel,
 |  | long | lFrom,
 |  | long | lTo,
 |  | BOOL | fDeferred
 | ) |

Play from a frame to another frame. As with editing systems, the ‘from’ point is included and will be displayed but the to point is NOT included and will not be displayed. This means that the last frame displayed will be lFrom – 1. The deferred flag allows

PlayFromTos to be stacked so that they will play back to back. The deferred flag in the status return should be false before another deferred command is added. Returns 0 if successful, else an error code.

DWORD __stdcall vvwQuit ( void )

Quit - called just before the DLL is unloaded. All channels should be closed and the operations complete before this is called. If the application crashes, DllMain should close all open channels before calling this function on the unload

long __stdcall vvwRecord ( long lChannel )

Start the channel recording. In clip mode a default clip name will be used with a duration set to infinity. The record will stop on any transport command or at the point that the disk is full. Returns 0 if successful, else an error code.

long __stdcall vvwRecordFromTo | ( | long | lChannel,
 |  | long | lFrom,
 |  | long | lTo
 | ) |

Record from a frame value to a frame value. As with editing systems, the ‘from’ point is included and will be recorded but the to point is NOT included and will not be recorded. This means that the last frame recorded will be lFrom – 1. Returns 0 if successful, else an error code.

long __stdcall vvwRecordStop | ( | long | lChannel,
 |  | char * | sz8CharClipName,
 |  | long | lDuration
 | ) |

Clip Mode Only. Set the clip name and length of time to record in frames. The record will not actually start until Record() is called. If the lDuration is set to –1 the record will continue until Stop() is called or the channel runs out of space. Returns 0 if successful, else an error code.

long __stdcall vvwReleaseChannels ( void )

Release memory allocated to channels

DWORD __stdcall vvwSaveRegistry ( char * szFileName )

Internal: Do not call.

DWORD __stdcall vvwSaveVVWRegistry ( char * szFileName )

Internal: Do not call.

DWORD __stdcall vvwSaveWindowsRegistry ( char * szFileName )

Internal: Do not call.

long __stdcall vvwSeek | ( | long | lChannel,
 |  | long | lFrame
 | ) |

Seek to a particular frame and display it to the user. This call will return before the seek is complete. Once the Position return in the status reaches the lFrame, the seek is complete. Returns 0 if successful, else an error code.

long __stdcall vvwSeekRelative | ( | long | lChannel,
 |  | long | lFrameOffset
 | ) |

Seek a certain number of frames from the current position. Positive offsets imply forward direction, negative offset imply reverse.

long __stdcall vvwSetAudioInput | ( | long | lChannel,
 |  | long | lSetting
 | ) |

ADD FUNCTION lAudIn Set the current audio input. GS_AUDSELECT_UNBALANCED_10 GS_AUDSELECT_UNBALANCED_4 GS_AUDSELECT_BALANCED_10 GS_AUDSELECT_BALANCED_4 GS_AUDSELECT_SPDIF GS_AUDSELECT_AES_EBU GS_AUDSELECT_EMBEDDED

long __stdcall vvwSetAudioInputLevel | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Get the current audio input level

long __stdcall vvwSetAudioOutput | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current audio Output – See Get/SetAudioInput GS_AUDSELECT_UNBALANCED_10 GS_AUDSELECT_UNBALANCED_4 GS_AUDSELECT_BALANCED_10 GS_AUDSELECT_BALANCED_4 GS_AUDSELECT_SPDIF GS_AUDSELECT_AES_EBU GS_AUDSELECT_EMBEDDED

long __stdcall vvwSetAudioOutputLevel | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Get the current audio output level.

long __stdcall vvwSetAutoMode | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Calls ValueXXX with gsAutoMode. Required for play lists, deferred commands and auto edit commands on VTRs.

long __stdcall vvwSetClipMode | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Calls ValueXXX with gsClipMode. If equal to 1 then the channel is in clip mode, if 0 the channel is in VTR mode.

long __stdcall vvwSetCompressionRate | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current compression rate

long __stdcall vvwSetErrorLog ( long lSetting )

Set the error log pointer to the message you want

long __stdcall vvwSetRecordPresets | ( | long | lChannel,
 |  | long | lVidEdit,
 |  | long | lAudEdit,
 |  | long | lInfEdit
 | ) |

Set the channels to record. Using –1 values implies that the Preset should be set to all available channels. Record Presets will remain set until the user changes them. Returns 0 if successful, else an error code.

long __stdcall vvwSetSuperImpose | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the status of the super imposed time code overlay

long __stdcall vvwSetTCSource | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Calls ValueXXX with gsTcSource (VITC, LTC, Control, Clip). GS_TCSOURCE_LTC, GS_TCSOURCE_VITC, GS_TCSOURCE_CTL or GS_TCSOURCE_CLIP

long __stdcall vvwSetTCType | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Calls ValueXXX with gsTcType (drop frame, non drop frame, pal). TC2_TCTYPE_FILM, TC2_TCTYPE_NDF, TC2_TCTYPE_DF, TC2_TCTYPE_PAL, TC2_TCTYPE_50, TC2_TCTYPE_5994, TC2_TCTYPE_60, TC2_TCTYPE_NTSCFILM, TC2_TCTYPE_2398, TC2_TCTYPE_100

long __stdcall vvwSetVideoGenlock | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Turn the house/reference lock on or off

long __stdcall vvwSetVideoGenlockSource | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the genlock source to input or external reference

long __stdcall vvwSetVideoInput | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current video input. GS_VIDSELECT_COMPOSITE, GS_VIDSELECT_COMPOSITE_2, GS_VIDSELECT_SVIDEO, GS_VIDSELECT_COMPONENT_YUV, GS_VIDSELECT_COMPONENT_YUV_M2, GS_VIDSELECT_COMPONENT_YUV_SMPTE, GS_VIDSELECT_COMPONENT_RGB, GS_VIDSELECT_D1_SERIAL, GS_VIDSELECT_D1_PARALLEL, GS_VIDSELECT_SDTI, GS_VIDSELECT_NONE

long __stdcall vvwSetVideoInputChroma | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current video input’s ‘Chroma’ TBC setting.

long __stdcall vvwSetVideoInputHue | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current video input’s ‘Hue’ TBC setting.

long __stdcall vvwSetVideoInputSetup | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current video input’s ‘Setup’ TBC setting.

long __stdcall vvwSetVideoInputVideo | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current video input’s ‘Video’ TBC setting.

long __stdcall vvwSetVideoOutput | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current video output. See Get/SetVideoInput for settings. GS_VIDSELECT_COMPOSITE, GS_VIDSELECT_COMPOSITE_2, GS_VIDSELECT_SVIDEO, GS_VIDSELECT_COMPONENT_YUV, GS_VIDSELECT_COMPONENT_YUV_M2, GS_VIDSELECT_COMPONENT_YUV_SMPTE, GS_VIDSELECT_COMPONENT_RGB, GS_VIDSELECT_D1_SERIAL, GS_VIDSELECT_D1_PARALLEL, GS_VIDSELECT_SDTI, GS_VIDSELECT_NONE

long __stdcall vvwSetVideoTBCChroma | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current global TBC’s ‘Chroma’ setting.

long __stdcall vvwSetVideoTBCHue | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current global TBC’s ‘Hue’ setting.

long __stdcall vvwSetVideoTBCSetup | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current global TBC’s ‘Setup’ setting.

long __stdcall vvwSetVideoTBCVideo | ( | long | lChannel,
 |  | long | lSetting
 | ) |

Set the current global TBC’s ‘Video’ setting.

long __stdcall vvwShowConfigDialog | ( | long | lChannel,
 |  | long | hWnd
 | ) |

Show the configuration dialog box for the current channel. If the channel does not have a configuration dialog, this function will return an error. It is not available in Java or unix as the dialog only shows up on the local machine, and cannot be seem through the network.

DWORD __stdcall vvwStart ( void )

Start - called once after all local channels are opened to complete any processing or start any global threads

DWORD __stdcall vvwStartService ( void )

Internal: Do not call.

long __stdcall vvwStop ( long lChannel )

Stop the output of the controlled channel and display the input video (not supported on all devices). On unsupported devices stop will be the same as a pause. Returns 0 if successful, else an error code.

DWORD __stdcall vvwStopService ( void )

Internal: Do not call.

long __stdcall vvwTransfer | ( | long | lChannel,
 |  | long | lTargetChannel,
 |  | long | lPosition,
 |  | long | lStart,
 |  | long | lEnd,
 |  | long | lVidEdit,
 |  | long | lAudEdit,
 |  | long | lInfEdit,
 |  | char * | szClipName,
 |  | BOOL | fToTape
 | ) |

Transfer media from one channel to another. Only supported by VTR channels. Currently only implemented for VTR to internal channels or internal channels to VTR channels. To record media from a VTR, the fToTape should be false, to record media onto a VTR the fToTape should be true. The start and end point are from the playback device. The edit will occur at the current timecode location on the recorder. Returns 0 if successful, else an error code.

long __stdcall vvwTrim | ( | long | lChannel,
 |  | long | lPosition,
 |  | long | lStartOffset,
 |  | long | lEndOffset,
 |  | long | lVidEdit,
 |  | long | lAudEdit,
 |  | long | lInfEdit,
 |  | BOOL | fRipple
 | ) |

long __stdcall vvwUpdateStatus ( long lChannel )

Retrieve the current status from the controlled device. The status is automatically updated by the interface, but this call ensures that the status is current when you are checking it. Returns 0 if successful, else an error code.

long __stdcall vvwValueGet | ( | long | lChannel,
 |  | long | lValueType,
 |  | long * | plMin,
 |  | long * | plMax
 | ) |

Returns the current setting for a get/set value.

long __stdcall vvwValueSet | ( | long | lChannel,
 |  | long | lValueType,
 |  | long | lSetting
 | ) |

Sets the get/set value to setting.

long __stdcall vvwValueSet2 | ( | long | lChannel,
 |  | long | lValueType,
 |  | long | lSetting,
 |  | long | lStart,
 |  | long | lEnd,
 |  | long | lVidChan,
 |  | long | lAudChan,
 |  | long | lInfChan
 | ) |

Sets the get/set value to setting with extended parameters. Please set unused parameters to NULL.

long __stdcall vvwValueSupported | ( | long | lChannel,
 |  | long | lValueType
 | ) |

Returns the supported attributes of a get/set value (gsClipMode, gsTcSource, etc) or –1 for not supported.

Generated on Wed May 17 15:52:33 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: vvwtypes.h File Reference

  • File List
  • Globals

vvwtypes.h File Reference

#include "mediacmd.h"

Go to the source code of this file.

Data Structures

struct | RECT16
struct | FRAME_INFO
struct | DRASTIC_CHANNEL
struct | DCLIP
struct | DFRAME
struct | VVWSYSTEM
struct | VVWVIDEO
struct | VVWAUDIO
struct | VVWINFO
#define | MB_FILE_EXT_LEN 200
Maximum length for the supported file extensions string (fmt: *.xxx;*.yyy;*.ttt).
#define | MB_FILE_SHORT_LEN 64
Maximum length for the base or short description (used in drop down).
#define | MB_FILE_DESC_LEN 255
Maximum length for the long description.
#define | MB_CODEC_SHORT_LEN 64
Maximum length for the short codec name.
#define | MB_CODEC_DESC_LEN 255
Maximum length for the full (long) codec description.
#define | _VVW_DSYNC_CHANNEL 65536
#define | _VVW_DSYNC_LTC_CHANNEL _VVW_DSYNC_CHANNEL + 1
#define | _VVW_CONTROL_START_LOCAL 0
#define | _VVW_CONTROL_MAX_LOCAL 64U
#define | _VVW_CONTROL_START_EXTERNAL _VVW_CONTROL_MAX_LOCAL
#define | _VVW_CONTROL_MAX_EXTERNAL 64U
Maximum number of external channels (63..127).
#define | _VVW_CONTROL_START_NETWORK (_VVW_CONTROL_MAX_EXTERNAL + _VVW_CONTROL_MAX_EXTERNAL)
#define | _VVW_CONTROL_MAX_NETWORK 128U
Maximum number of network channels (128..255).
#define | _VVW_CONTROL_MAX_CONTROL _VVW_CONTROL_MAX_LOCAL
This is the maximum number of control inputs available.
#define | _VVW_ABS_MAX_CHANNELS 256
Abs Max Channels on any system.

Defines

#define | _VVW_TYPES_HAVE_ALREADY_BEEN_INCLUDED
#define | DTVVW_PREVIEW 0x80000000
#define | VVW_INVALID_FRAME 0xFFFFFFFF
No frame exists - is the same as TC_ILLEGAL - careful, only valid when tc cannot go negative, else it means -1.
#define | VVW_ABS_MAX_FRAME 10692000
Absolute maximum timecode in a time code space (99:59:59:29 NDF) - Actual max is usually 23:59:59:x9 depending on type (see tc2Maximum()).
#define | _MAX_CLIP_NAME_SIZE 9
The size of a clip name string (8 char plus NULL term) (1 for safety) - This is for odetics/louth compatibility.
#define | pFI_DataAreaPtr dwVITCAux
Alternate name for dwVITCAux.
#define | dwFI_DataAreaSize dwCCData
Alternate name for dwCCData.
#define | DECLARE_DRASTIC_CHANNEL(__x_)
Declare and initialize a DRASTIC_CHANNEL.
#define | INIT_DRASTIC_CHANNEL(__x_)
Initialize a DRASTIC_CHANNEL.
#define | INIT_PDRASTIC_CHANNEL(__x_)
Initialize a memory area allocated as a DRASTIC_CHANNEL.
#define | DFRAME_TYPE_RECORD 0x00000001
This frame was recorded into (normally by AvHAL) see DFRAME::dwType.
#define | DFRAME_TYPE_PLAY 0x00000002
This frame should be played out (normally by AvHAL) see DFRAME::dwType.
#define | DFRAME_TYPE_PAUSE (0x00000004 | DFRAME_TYPE_PLAY)
This frame was aquired while in pause and is most likely a seek (normally by AvHAL) see DFRAME::dwType.
#define | DFRAME_TYPE_NOTPHYSHEAP 0x00001000
This indicates PhysHeap did NOT allocate the dframe (not pheap or local heap).
#define | DFRAME_TYPE_FI_PTR_DATA 0x00008000
This indicates that fi.dwVITCAux points to a data area and dwCCData contains its size.
#define | DFRAME_TYPE_AUDIO 0x00010000
This frame contains audio data see DFRAME::dwType.
#define | DFRAME_TYPE_VIDEO 0x00020000
This frame contains video data see DFRAME::dwType.
#define | DFRAME_PROGRESSIVE 0x00100000
The contents of the frame are progressive (as opposed to interlaced) see DFRAME::dwType.
#define | DFRAME_FIELD_INVERT 0x00200000
The fields in the frame are inverted (jaggies) see DFRAME::dwType.
#define | DFRAME_TIME_INVERT 0x00400000
The fields in the frame are temporally inverts (jumps back and forth) see DFRAME::dwType.
#define | DFRAME_ORIENTATION_INVERT 0x00800000
The contents of the frame are inverted.
#define | DFRAME_LARGE_AUDIO 0x01000000
The frame contains a large chunk of audio (allows for optimization in AvHAL) see DFRAME::dwType.
#define | DFRAME_NEW_FORMAT 0x08000000
This frame starts a new format that is different from the ones previous. Please get the new format and adjust before displaying see DFRAME::dwType.
#define | DFRAME_TYPE_KEYFRAME 0x10000000
This frame is independant of other frames for decode see DFRAME::dwType.
#define | DFRAME_TYPE_KEYFRAME_I 0x10000000
This frame is independant of other frames for decode (an MPEG I Frame) see DFRAME::dwType.
#define | DFRAME_TYPE_KEYFRAME_P 0x00000000
This frame requires previous keyframe(s) (for MPEG a P Frame) see DFRAME::dwType.
#define | DFRAME_TYPE_KEYFRAME_B 0x20000000
This frame requires more than one frame to decode (for MPEG a B Frame) see DFRAME::dwType.
#define | DFRAME_SKIP_FRAME 0x40000000
This frame should be skipped (decoded, but not displayed) - Used to reach seek frame on a non key frame from key frame see DFRAME::dwType.
#define | DTVHDR_DONE 0x00000001
internal to AvHAL Set by the device driver to indicate it is finished with the data buffer and is returning the buffer to the client. see DFRAME::dwFlags
#define | DTVHDR_PREPARED 0x00000002
internal to AvHAL Indicates whether or not the buffer has been prepared for use. See DVM_STREAM_PREPAREHEADER. see DFRAME::dwFlags
#define | DTVHDR_INQUEUE 0x00000004
internal to AvHAL Set by the driver to indicate the buffer is in the driver’s buffer queue. see DFRAME::dwFlags
#define | DTVHDR_KEYFRAME 0x00000008
internal to AvHAL Set by the device driver to indicate a key frame. see DFRAME::dwFlags
#define | DTWHDR_DONE 0x00000001
Set by the device driver to indicate that it is finished with the buffer and is returning it to the application. see DFRAME::dwFlags.
#define | DTWHDR_PREPARED 0x00000002
internal to AvHAL Set by Windows to indicate that the buffer has been prepared with the waveInPrepareHeader or waveOutPrepareHeader function. see DFRAME::dwFlags
#define | DTWHDR_BEGINLOOP 0x00000004
internal to AvHAL This buffer is the first buffer in a loop. This flag is used only with output buffers. see DFRAME::dwFlags
#define | DTWHDR_ENDLOOP 0x00000008
internal to AvHAL This buffer is the last buffer in a loop. This flag is used only with output buffers. see DFRAME::dwFlags
#define | DTWHDR_INQUEUE 0x00000010
internal to AvHAL Set by Windows to indicate that the buffer is queued for playback. see DFRAME::dwFlags
#define | _PDFRAMEFLAGS_CLIPSTILL 0x00000001
This is a single frame clip (implies progressive) that needs to be play for the duration of the clip see DFRAME::dwFlags.
#define | _PDFRAMEFLAGS_CLIPSTART 0x00000002
This is the first frame of a new clip see DFRAME::dwFlags.
#define | _PDFRAMEFLAGS_CLIPEND 0x00000004
This is the last frame of the current clip see DFRAME::dwFlags.
#define | _PDFRAMEFLAGS_FIRSTFRAME 0x00000002
Alias for _PDFRAMEFLAGS_CLIPSTART see DFRAME::dwFlags.
#define | _PDFRAMEFLAGS_LASTFRAME 0x00000004
Alias for _PDFRAMEFLAGS_CLIPEND see DFRAME::dwFlags.
#define | SIZEOFDFRAME (((sizeof(DFRAME) >> 2) + 1) << 2)
The DWORD aligned size of a DFRAME, used for more effecient memory allocations.
#define | _VVWXXX_RESERVED_SIZE 256
The size of the reserved area (in DWORDs) within VVWSYSTEM, VVWVIDEO, VVWAUDIO and VVWINFO.
#define | _VVWXXX_NAME_SIZE 64
The size of the name area (in chars) within VVWSYSTEM, VVWVIDEO, VVWAUDIO and VVWINFO.
#define | _VVW_IS_VVWSYSTEM 0x0000
The flag indicating the structure is a VVWSYSTEM structure within a union.
#define | VVWSYS_SET(__pvvwsys_, __pvvwvid_, __pvvwaud_, _granularity, _frames)
Set a VVWSYSTEM structure pointer from VVWVIDEO pointer, VVWAUDIO pointer, a granularity size and number of frames.
#define | VVWSYS_SETVIDONLY(__pvvwsys_, __pvvwvid_, _granularity, _frames)
Set a VVWSYSTEM structure pointer from VVWVIDEO pointer, a granularity size and number of frames.
#define | VVWSYS_SETAUDONLY(__pvvwsys_, __pvvwaud_, _granularity, _frames)
Set a VVWSYSTEM structure pointer from VVWAUDIO pointer, a granularity size and number of frames.
#define | VVWSYS_CLR(__pvvwsys_)
Clear a important 0 of a VVWVIDEO structure pointer.
#define | VVWXXX_SETSAMPLETOLENGTH(__pvvw_, _length) { (__pvvw_)->dwLength = _length * (__pvvw_)->dwScale; }
This macro is incorrect.
#define | VVWXXX_GETSAMPLEFROMLENGTH(__pvvw_) ((__pvvw_)->dwLength / (__pvvw_)->dwScale)
This macro is incorrect.
#define | _VVW_IS_VVWVIDEO 0x0010
The flag indicating the structure is a VVWVIDEO structure within a union.
#define | MASK___DRFLAGS_FIELD 0x00000001
Field dominance MASK for VVWVIDEO::dwDrFlags.
#define | DRFLAGS_ZERO_FIELD_DOMINANT 0x00000000
Zero (Second) Field Dominant in VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FIRST_FIELD_DOMINANT 0x00000001
First Field Dominant in VVWVIDEO::dwDrFlags.
#define | DRFLAGS_NOT_QUICKCLIP 0x00000002
Preview to QuickclipXO.
#define | MASK___DRFLAGS_KEYFRAME 0x00000010
KeyFrame MASK for VVWVIDEO::dwDrFlags.
#define | DRFLAGS_HAS_KEYFRAMES 0x00000010
Stream has key frames, else all key frames VVWVIDEO::dwDrFlags.
#define | MASK___DRFLAGS_VTYPE 0x00000700
Frame type mask (1=interlaced,2=progressive,4=segmentedframe).
#define | DRFLAGS_VTYPE_INTERLACED 0x00000100
Interlaced video frames.
#define | DRFLAGS_VTYPE_PROGRESSIVE 0x00000200
Progressive video frames.
#define | DRFLAGS_VTYPE_SEGMENTEDFRAME 0x00000400
Segmented Frame video frames.
#define | MASK___FCCMODIFIERS 0x00FF0000
Fourcc modifiers MASK for VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FCC_MJPG_DIGISUITE 0x00000000
Stream is DigiSuite MJPG see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FCC_MJPG_DCx0 0x00010000
Stream is Miro DC50 MJPG see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FCC_MJPG_DSEDIT 0x00020000
Stream is DigiSuite Edit MJPG see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FCC_MJPG_JPGDIB 0x00040000
Stream is MJPG MS-Dib variant see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FCC_MJPG_JFIF 0x00080000
Stream is JFIF jpeg see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FCC_USE_INTERN 0x00100000
Stream should use internal codecs see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FCC_USE_QT 0x00400000
Stream should use quicktime codecs see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_FCC_USE_ICM 0x00800000
Stream should use windows icm/vfw codecs see VVWVIDEO::dwDrFlags.
#define | MASK__CODECPRIVATEDATA 0x0F000000
Private Data MASK see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_CODECPRIVATEDATA_AVI 0x01000000
Private data format is AVI see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_CODECPRIVATEDATA_MOV 0x02000000
Private data format is MOV see VVWVIDEO::dwDrFlags.
#define | DRFLAGS_CODECPRIVATEDATA_OMF 0x04000000
Private data format is OMF see VVWVIDEO::dwDrFlags.
#define | MASK___PREVIEW 0xF0000000
MASK Room for current DTVVW_PREVIEW and more if nec see VVWVIDEO::dwDrFlags.
#define | VVWVID_PITCHALIGN1(__pvvwvid_) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+ 7) / 8 ); }
Set VVWVIDEO::biPitch member to 1 byte alignment based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.
#define | VVWVID_PITCHALIGN4(__pvvwvid_) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+ 31) / 32) * 4; }
Set VVWVIDEO::biPitch member to 4 byte (DWORD) alignment based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.
#define | VVWVID_PITCHALIGN8(__pvvwvid_) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+ 63) / 64) * 8; }
Set VVWVIDEO::biPitch member to 8 byte alignment based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.
#define | VVWVID_PITCHALIGN16(__pvvwvid_) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+127) / 128) * 16; }
Set VVWVIDEO::biPitch member to 16 byte alignment based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.
#define | VVWVID_PITCHALIGNANY(__pvvwvid_, _align_1_4_8_16) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+((_align_1_4_8_16 * 8) - 1)) / (_align_1_4_8_16 * 8)) * _align_1_4_8_16; }
Set VVWVIDEO::biPitch member to alignment specified based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.
#define | VVWVID_PITCHMODULO(__pvvwvid_) ((__pvvwvid_)->biPitch - ((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount + 7) / 8)
Set pitch to 1-0 alignment ?
#define | VVWVID_SIZEIMAGE(__pvvwvid_) { if(!(__pvvwvid_)->biPitch) VVWVID_PITCHALIGN1((__pvvwvid_)); (__pvvwvid_)->biSizeImage = (__pvvwvid_)->biPitch * abs((__pvvwvid_)->biHeight); }
Set the VVWVIDEO::biSizeImage based on VVWVIDEO::biWidth, VVWVIDEO::biHeight and VVWVIDEO::biBitCount.
#define | VVWVID_SUGGESTEDBUFFERSIZE(__pvvwvid_) { if(!(__pvvwvid_)->biPitch) VVWVID_PITCHALIGN1((__pvvwvid_)); (__pvvwvid_)->dwSuggestedBufferSize = (__pvvwvid_)->biPitch * (abs((__pvvwvid_)->biHeight) + (abs((__pvvwvid_)->biHeight) >> 2)); }
Set the VVWVIDEO::dwSuggestedBufferSize based on VVWVIDEO::biWidth, VVWVIDEO::biHeight and VVWVIDEO::biBitCount.
#define | VVWVID_RATESCALE_NTSC_AVI(__pvvwvid_) { (__pvvwvid_)->dwScale = 1001; (__pvvwvid_)->dwRate = 30000; }
Set the VVWVIDEO::dwRate and VVWVIDEO::dwScale for 30000/1001 (NTSC).
#define | VVWVID_RATESCALE_NTSC(__pvvwvid_) { (__pvvwvid_)->dwScale = 100; (__pvvwvid_)->dwRate = 2997; }
Set the VVWVIDEO::dwRate and VVWVIDEO::dwScale for 2997/100 (NTSC).
#define | VVWVID_RATESCALE_PAL(__pvvwvid_) { (__pvvwvid_)->dwScale = 1; (__pvvwvid_)->dwRate = 25; }
Set the VVWVIDEO::dwRate and VVWVIDEO::dwScale for 25/1 (PAL).
#define | VVWVID_RATESCALE_FILM(__pvvwvid_) { (__pvvwvid_)->dwScale = 1; (__pvvwvid_)->dwRate = 24; }
Set the VVWVIDEO::dwRate and VVWVIDEO::dwScale for 24/1 (FILM).
#define | VVWVID_SET(__pvvwvid_, _bitcount, _width, _height, _pitch_align_1_4_8_16, _fcccodec, _scale, _rate, _frames)
Basic setup of a VVWVIDEO pointer from width, height, align, codec, scale, rate and length in frames.
#define | VVWVID_SETCLR(__pvvwvid_, _bitcount, _width, _height, _pitch_align_1_4_8_16, _fcccodec, _scale, _rate, _frames)
Clean and do basic setup of a VVWVIDEO pointer from width, height, align, codec, scale, rate and length in frames.
#define | _VVW_IS_VVWAUDIO 0x0100
The flag indicating the structure is a VVWAUDIO structure within a union.
#define | DTWAVE_FORMAT_PCM 1
PCM Wave Type, see fccDef.h for other possible types.
#define | VVWAUD_RECALC(__pvvwaud_)
#define | VVWAUD_SET(__pvvwaud_, _formattag, _channels, _samplespersec, _bitspersample, _samples)
Set the VVWAUDIO structure pointer from formattag, channels, samples per sec, bits per sample and number of samples.
#define | VVWAUD_SETCLR(__pvvwaud_, _formattag, _channels, _samplespersec, _bitspersample, _samples)
Clean and set the VVWAUDIO structure pointer from formattag, channels, samples per sec, bits per sample and number of samples.
#define | _VVW_IS_VVWINFO 0x1000
The flag indicating the structure is a VVWINFO structure within a union.
#define | VVWINFOTAG_woVideoWidth "Width"
#define | VVWINFOTAG_woHeight "Height"
#define | VVWINFOTAG_woPlanes "Planes"
#define | VVWINFOTAG_woBitCount "BitCount"
#define | VVWINFOTAG_woCompression "Compression"
#define | VVWINFOTAG_woSizeImage "SizeImage"
#define | VVWINFOTAG_woXPelsPerMeter "XPelsPerMeter"
#define | VVWINFOTAG_woYPelsPerMeter "YPelsPerMeter"
#define | VVWINFOTAG_woClrUsed "ClrUsed"
#define | VVWINFOTAG_woClrImportant "ClrImportant"
#define | VVWINFOTAG_woReserved "Reserved"
#define | VVWINFOTAG_woFccType "FccType"
#define | VVWINFOTAG_woFccHandler "FccHandler"
#define | VVWINFOTAG_woFlags "Flags"
#define | VVWINFOTAG_woCaps "Caps"
#define | VVWINFOTAG_woPriority "Priority"
#define | VVWINFOTAG_woLanguage "Language"
#define | VVWINFOTAG_woScale "Scale"
#define | VVWINFOTAG_woRate "Rate"
#define | VVWINFOTAG_woStart "Start"
#define | VVWINFOTAG_woLength "Length"
#define | VVWINFOTAG_woInitialFrames "InitialFrames"
#define | VVWINFOTAG_woSuggestedBufferSize "SuggestedBufferSize"
#define | VVWINFOTAG_woQuality "Quality"
#define | VVWINFOTAG_woSampleSize "SampleSize"
#define | VVWINFOTAG_woEditCount "EditCount"
#define | VVWINFOTAG_woFormatChangeCount "FormatChangeCount"
#define | VVWINFOTAG_woPitch "Pitch"
#define | VVWINFOTAG_woDrFlags "DrFlags"
#define | VVWINFOTAG_woFileType "FileType"
#define | VVWINFOTAG_woResDrastic "ResDrastic"
#define | VVWINFOTAG_szFileName "FileName"
XML tag name for VVWINFO::szFileName.
#define | VVWINFOTAG_szNativeLocator "NativeLocator"
XML tag name for VVWINFO::szNativeLocator.
#define | VVWINFOTAG_szUniversalName "UniversalLocator"
XML tag name for VVWINFO::szUniversalLocator.
#define | VVWINFOTAG_szIP "TCP-IPAddress"
XML tag name for VVWINFO::szIP.
#define | VVWINFOTAG_szSourceLocator "SourceLocator"
XML tag name for VVWINFO::szSourceLocator.
#define | VVWINFOTAG_szChannel "ChannelIdentifier"
XML tag name for VVWINFO::szChannelIdentifier.
#define | VVWINFOTAG_szChannelName "ChannelName"
XML tag name for VVWINFO::szChannelName.
#define | VVWINFOTAG_szChannelDescription "ChannelDescription"
XML tag name for VVWINFO::szChannelDescription.
#define | VVWINFOTAG_szTitle "Title"
XML tag name for VVWINFO::szTitle.
#define | VVWINFOTAG_szSubject "Subject"
XML tag name for VVWINFO::szSubject.
#define | VVWINFOTAG_szCategory "Category"
XML tag name for VVWINFO::szCategory.
#define | VVWINFOTAG_szKeywords "Keywords"
XML tag name for VVWINFO::szKeywords.
#define | VVWINFOTAG_szRatings "Ratings"
XML tag name for VVWINFO::szRatings.
#define | VVWINFOTAG_szComments "Comments"
XML tag name for VVWINFO::szComments.
#define | VVWINFOTAG_szDoNotUse "DoNotUse"
XML tag name for VVWINFO::szDoNotUse.
#define | VVWINFOTAG_szOwner "Owner"
XML tag name for VVWINFO::szOwner.
#define | VVWINFOTAG_szEditor "Editor"
XML tag name for VVWINFO::szEditor.
#define | VVWINFOTAG_szSupplier "Supplier"
XML tag name for VVWINFO::szSupplier.
#define | VVWINFOTAG_szSource "Source"
XML tag name for VVWINFO::szSource.
#define | VVWINFOTAG_szProject "Project"
XML tag name for VVWINFO::szProject.
#define | VVWINFOTAG_szStatus "Status"
XML tag name for VVWINFO::szStatus.
#define | VVWINFOTAG_szAuthor "Author"
XML tag name for VVWINFO::szAuthor.
#define | VVWINFOTAG_szRevisionNumber "RevisionNumber"
XML tag name for VVWINFO::szRevisionNumber.
#define | VVWINFOTAG_szProduced "Produced"
XML tag name for VVWINFO::szProduced.
#define | VVWINFOTAG_szAlbum "Album"
XML tag name for VVWINFO::szAlbum.
#define | VVWINFOTAG_szArtist "Artist"
XML tag name for VVWINFO::szArtist.
#define | VVWINFOTAG_szComposer "Composer"
XML tag name for VVWINFO::szComposer.
#define | VVWINFOTAG_szCopyright "Copyright"
XML tag name for VVWINFO::szCopyright.
#define | VVWINFOTAG_szCreationData "CreationData"
XML tag name for VVWINFO::szCreationData.
#define | VVWINFOTAG_szDescription "Description"
XML tag name for VVWINFO::szDescription.
#define | VVWINFOTAG_szDirector "Director"
XML tag name for VVWINFO::szDirector.
#define | VVWINFOTAG_szDisclaimer "Disclaimer"
XML tag name for VVWINFO::szDisclaimer.
#define | VVWINFOTAG_szEncodedBy "EncodedBy"
XML tag name for VVWINFO::szEncodedBy.
#define | VVWINFOTAG_szFullName "FullName"
XML tag name for VVWINFO::szFullName.
#define | VVWINFOTAG_szGenre "Genre"
XML tag name for VVWINFO::szGenre.
#define | VVWINFOTAG_szHostComputer "HostComputer"
XML tag name for VVWINFO::szHostComputer.
#define | VVWINFOTAG_szInformation "Information"
XML tag name for VVWINFO::szInformation.
#define | VVWINFOTAG_szMake "Make"
XML tag name for VVWINFO::szMake.
#define | VVWINFOTAG_szModel "Model"
XML tag name for VVWINFO::szModel.
#define | VVWINFOTAG_szOriginalArtist "OriginalArtist"
XML tag name for VVWINFO::szOriginalArtist.
#define | VVWINFOTAG_szOriginalFormat "OriginalFormat"
XML tag name for VVWINFO::szOriginalFormat.
#define | VVWINFOTAG_szPerformers "Performers"
XML tag name for VVWINFO::szPerformers.
#define | VVWINFOTAG_szProducer "Producer"
XML tag name for VVWINFO::szProducer.
#define | VVWINFOTAG_szProduct "Product"
XML tag name for VVWINFO::szProduct.
#define | VVWINFOTAG_szSoftware "Software"
XML tag name for VVWINFO::szSoftware.
#define | VVWINFOTAG_szSpecialPlaybackRequirements "SpecialPlaybackRequirements"
XML tag name for VVWINFO::szSpecialPlaybackRequirements.
#define | VVWINFOTAG_szTrack "Track"
XML tag name for VVWINFO::szTrack.
#define | VVWINFOTAG_szWarning "Warning"
XML tag name for VVWINFO::szWarning.
#define | VVWINFOTAG_szURLLink "URL"
XML tag name for VVWINFO::szURLLink.
#define | VVWINFOTAG_szEditData1 "EditData1"
XML tag name for VVWINFO::szEditData1.
#define | VVWINFOTAG_szEditData2 "EditData2"
XML tag name for VVWINFO::szEditData2.
#define | VVWINFOTAG_szEditData3 "EditData3"
XML tag name for VVWINFO::szEditData3.
#define | VVWINFOTAG_szEditData4 "EditData4"
XML tag name for VVWINFO::szEditData4.
#define | VVWINFOTAG_szEditData5 "EditData5"
XML tag name for VVWINFO::szEditData5.
#define | VVWINFOTAG_szEditData6 "EditData6"
XML tag name for VVWINFO::szEditData6.
#define | VVWINFOTAG_szEditData7 "EditData7"
XML tag name for VVWINFO::szEditData7.
#define | VVWINFOTAG_szEditData8 "EditData8"
XML tag name for VVWINFO::szEditData8.
#define | VVWINFOTAG_szEditData9 "EditData9"
XML tag name for VVWINFO::szEditData9.
#define | VVWINFOTAG_szVersionString "VersionString"
XML tag name for VVWINFO::szVersionString.
#define | VVWINFOTAG_szManufacturer "Manufacturer"
XML tag name for VVWINFO::szManufacturer.
#define | VVWINFOTAG_szLanguage "Language"
XML tag name for VVWINFO::szLanguage.
#define | VVWINFOTAG_szFormat "Format"
XML tag name for VVWINFO::szFormat.
#define | VVWINFOTAG_szInputDevice "InputDevice"
XML tag name for VVWINFO::szInputDevice.
#define | VVWINFOTAG_szDeviceModelNum "DeviceModelNum"
XML tag name for VVWINFO::szDeviceModelNum.
#define | VVWINFOTAG_szDeviceSerialNum "DeviceSerialNum"
XML tag name for VVWINFO::szDeviceSerialNum.
#define | VVWINFOTAG_szReel "Reel"
XML tag name for VVWINFO::szReel.
#define | VVWINFOTAG_szShot "Shot"
XML tag name for VVWINFO::szShot.
#define | VVWINFOTAG_szTake "Take"
XML tag name for VVWINFO::szTake.
#define | VVWINFOTAG_szSlateInfo "SlateInfo"
XML tag name for VVWINFO::szSlateInfo.
#define | VVWINFOTAG_szFrameAttribute "FrameAttribute"
XML tag name for VVWINFO::szFrameAttibute.
#define | VVWINFOTAG_szEpisode "Episode"
XML tag name for VVWINFO::szEpisode.
#define | VVWINFOTAG_szScene "Scene"
XML tag name for VVWINFO::szScene.
#define | VVWINFOTAG_szDailyRoll "DailyRoll"
XML tag name for VVWINFO::szDailyRoll.
#define | VVWINFOTAG_szCamRoll "CamRoll"
XML tag name for VVWINFO::szCamRoll.
#define | VVWINFOTAG_szSoundRoll "SoundRoll"
XML tag name for VVWINFO::szSoundRoll.
#define | VVWINFOTAG_szLabRoll "LabRoll"
XML tag name for VVWINFO::szLabRoll.
#define | VVWINFOTAG_szKeyNumberPrefix "KeyNumberPrefix"
XML tag name for VVWINFO::szKeyNumberPrefix.
#define | VVWINFOTAG_szInkNumberPrefix "InkNumberPrefix"
XML tag name for VVWINFO::szInkNumberPrefix.
#define | VVWINFOTAG_szPictureIcon "PictureIcon"
XML tag name for VVWINFO::szPictureIcon.
#define | VVWINFOTAG_szProxyFile "ProxyFile"
XML tag name for VVWINFO::szProxyFile.
#define | VVWINFOTAG_szNU_81 "NotUsed_81"
XML tag name for VVWINFO::szNU_81.
#define | VVWINFOTAG_szNU_82 "NotUsed_82"
XML tag name for VVWINFO::szNU_82.
#define | VVWINFOTAG_szNU_83 "NotUsed_83"
XML tag name for VVWINFO::szNU_83.
#define | VVWINFOTAG_szNU_84 "NotUsed_84"
XML tag name for VVWINFO::szNU_84.
#define | VVWINFOTAG_szNU_85 "NotUsed_85"
XML tag name for VVWINFO::szNU_85.
#define | VVWINFOTAG_szNU_86 "NotUsed_86"
XML tag name for VVWINFO::szNU_86.
#define | VVWINFOTAG_szNU_87 "NotUsed_87"
XML tag name for VVWINFO::szNU_87.
#define | VVWINFOTAG_szNU_88 "NotUsed_88"
XML tag name for VVWINFO::szNU_88.
#define | VVWINFOTAG_szNU_89 "NotUsed_89"
XML tag name for VVWINFO::szNU_89.
#define | VVWINFOTAG_szNU_90 "NotUsed_90"
XML tag name for VVWINFO::szNU_90.
#define | VVWINFOTAG_szNU_91 "NotUsed_91"
XML tag name for VVWINFO::szNU_91.
#define | VVWINFOTAG_szNU_92 "NotUsed_92"
XML tag name for VVWINFO::szNU_92.
#define | VVWINFOTAG_szNU_93 "NotUsed_93"
XML tag name for VVWINFO::szNU_93.
#define | VVWINFOTAG_szNU_94 "NotUsed_94"
XML tag name for VVWINFO::szNU_94.
#define | VVWINFOTAG_szNU_95 "NotUsed_95"
XML tag name for VVWINFO::szNU_95.
#define | VVWINFOTAG_szNU_96 "NotUsed_96"
XML tag name for VVWINFO::szNU_96.
#define | VVWINFOTAG_szNU_97 "NotUsed_97"
XML tag name for VVWINFO::szNU_97.
#define | VVWINFOTAG_szNU_98 "NotUsed_98"
XML tag name for VVWINFO::szNU_98.
#define | VVWINFOTAG_szNU_99 "NotUsed_99"
XML tag name for VVWINFO::szNU_99.
#define | VVWINFOTAG_dwTimeCode "TimeCode"
XML tag name for VVWINFO::dwTimeCode.
#define | VVWINFOTAG_dwUserBits "UserBits"
XML tag name for VVWINFO::dwUserBits.
#define | VVWINFOTAG_dwVITCTimeCode "VITCTimeCode"
XML tag name for VVWINFO::dwVITCTimeCode.
#define | VVWINFOTAG_dwVITCUserBits "VITCUserBits"
XML tag name for VVWINFO::dwVITCUserBits.
#define | VVWINFOTAG_dwVITCLine3 "VITCExtraData"
XML tag name for VVWINFO::dwVICTLine3.
#define | VVWINFOTAG_dwPosterFrame "PosterFrame"
XML tag name for VVWINFO::dwPosterFrame.
#define | VVWINFOTAG_dwAFrame "A-Frame"
XML tag name for VVWINFO::dwAFrame.
#define | VVWINFOTAG_dwAspectRatio "AspectRatio"
XML tag name for VVWINFO::dwAspectRatio.
#define | VVWINFOTAG_dwOriginalRate "OriginalRate"
XML tag name for VVWINFO::dwOriginalRate.
#define | VVWINFOTAG_dwOriginalScale "OriginalScale"
XML tag name for VVWINFO::dwOriginalScale.
#define | VVWINFOTAG_dwConversions "TotalConversions"
XML tag name for VVWINFO::dwTotalConversions.
#define | VVWINFOTAG_dwVersionNumber "VersionNumber"
XML tag name for VVWINFO::dwVersionNumber.
#define | VVWINFOTAG_dwFileSize "FileSize"
XML tag name for VVWINFO::dwFileSize.
#define | VVWINFOTAG_dwFileDate "FileDate"
XML tag name for VVWINFO::dwFileDate.
#define | VVWINFOTAG_dwFileTime "FileTime"
XML tag name for VVWINFO::dwFileTime.
#define | VVWINFOTAG_dwSequenceNumber "SequenceNumber"
XML tag name for VVWINFO::dwSequenceNumber.
#define | VVWINFOTAG_dwTotalStreams "TotalStreams"
XML tag name for VVWINFO::dwTotalStreams.
#define | VVWINFOTAG_dwTotalLength "TotalLength"
XML tag name for VVWINFO::dwTotalLength.
#define | VVWINFOTAG_dwFilmManufacturerCode "FilmManufacturerCode"
XML tag name for VVWINFO::dwFilmManufacturerCode.
#define | VVWINFOTAG_dwFilmTypeCode "FilmTypeCode"
XML tag name for VVWINFO::dwFilmTypeCode.
#define | VVWINFOTAG_dwWhitePoint "WhitePoint"
XML tag name for VVWINFO::dwWhitePoint.
#define | VVWINFOTAG_dwBlackPoint "BlackPoint"
XML tag name for VVWINFO::dwBlackPoint.
#define | VVWINFOTAG_dwBlackGain "BlackGain"
XML tag name for VVWINFO::dwBlackGain.
#define | VVWINFOTAG_dwBreakPoint "BreakPoint"
XML tag name for VVWINFO::dwBreakPoint.
#define | VVWINFOTAG_dwGamma1000 "Gamma1000"
XML tag name for VVWINFO::dwGamma1000.
#define | VVWINFOTAG_dwTagNumber "TagNumber"
XML tag name for VVWINFO::dwTagNumber.
#define | VVWINFOTAG_dwFlags "Flags"
XML tag name for VVWINFO::dwFlags.
#define | VVWINFOTAG_dwTimeCodeType "TimeCodeType"
XML tag name for VVWINFO::dwTimeCodeType.
#define | VVWINFOTAG_dwLTCTimeCodeType "LTCTimeCodeType"
XML tag name for VVWINFO::dwLTCTimeCodeType.
#define | VVWINFOTAG_dwVITCTimeCodeType "VITCTimeCodeType"
XML tag name for VVWINFO::dwVITCTimeCodeType.
#define | VVWINFOTAG_dwNU_31 "NumericNotUsed_31"
XML tag name for VVWINFO::dwNU_31.
#define | VVWINFOTAG_dwNU_32 "NumericNotUsed_32"
XML tag name for VVWINFO::dwNU_32.
#define | VVWINFOTAG_dwNU_33 "NumericNotUsed_33"
XML tag name for VVWINFO::dwNU_33.
#define | VVWINFOTAG_dwNU_34 "NumericNotUsed_34"
XML tag name for VVWINFO::dwNU_34.
#define | VVWINFOTAG_dwNU_35 "NumericNotUsed_35"
XML tag name for VVWINFO::dwNU_35.
#define | VVWINFOTAG_dwNU_36 "NumericNotUsed_36"
XML tag name for VVWINFO::dwNU_36.
#define | VVWINFOTAG_dwNU_37 "NumericNotUsed_37"
XML tag name for VVWINFO::dwNU_37.
#define | VVWINFOTAG_dwNU_38 "NumericNotUsed_38"
XML tag name for VVWINFO::dwNU_38.
#define | VVWINFOTAG_dwNU_39 "NumericNotUsed_39"
XML tag name for VVWINFO::dwNU_39.
#define | VVWINFOTAG_dwNU_40 "NumericNotUsed_40"
XML tag name for VVWINFO::dwNU_40.
#define | VVWINFOTAG_dwNU_41 "NumericNotUsed_41"
XML tag name for VVWINFO::dwNU_41.
#define | VVWINFOTAG_dwNU_42 "NumericNotUsed_42"
XML tag name for VVWINFO::dwNU_42.
#define | VVWINFOTAG_dwNU_43 "NumericNotUsed_43"
XML tag name for VVWINFO::dwNU_43.
#define | VVWINFOTAG_dwNU_44 "NumericNotUsed_44"
XML tag name for VVWINFO::dwNU_44.
#define | VVWINFOTAG_dwNU_45 "NumericNotUsed_45"
XML tag name for VVWINFO::dwNU_45.
#define | VVWINFOTAG_dwNU_46 "NumericNotUsed_46"
XML tag name for VVWINFO::dwNU_46.
#define | VVWINFOTAG_dwNU_47 "NumericNotUsed_47"
XML tag name for VVWINFO::dwNU_47.
#define | VVWINFOTAG_dwNU_48 "NumericNotUsed_48"
XML tag name for VVWINFO::dwNU_48.
#define | VVWINFOTAG_dwNU_49 "NumericNotUsed_49"
XML tag name for VVWINFO::dwNU_49.
#define | GetAudio 0x00000000
#define | GetVideo 0x00000001
Flag for mediafile/avhal to get video dframe.
#define | GetInf 0x00000002
Flag for mediafile/avhal to get info (VVWINFO).
#define | PutAudio GetAudio
Flag for mediafile/avhal to put audio dframe.
#define | PutVideo GetVideo
Flag for mediafile/avhal to put audio dframe.
#define | PutInf GetInf
Flag for mediafile/avhal to get info (VVWINFO).
#define | GetNoFail 0x00000100
Flag for getting second copy or other non queue critical frames.
#define | GetCurrent 0x00000000
Flag for avhal to get the current FRAME_INFO.
#define | GetQueued 0x00000010
Flag for avhal to get the last queued FRAME_INFO.

Typedefs

typedef struct FRAME_INFO * | pFRAME_INFO
typedef struct DRASTIC_CHANNEL * | pDRASTIC_CHANNEL
typedef struct DCLIP * | PDCLIP
typedef struct DFRAME * | PDFRAME
typedef struct VVWSYSTEM * | pVVWSYSTEM
typedef struct VVWVIDEO * | pVVWVIDEO
typedef struct VVWAUDIO * | pVVWAUDIO
typedef struct VVWINFO * | pVVWINFO

Enumerations

enum vvwInfoMetaTypes {
vvwiFileName, vvwiNativeLocator, vvwiUniversalName, vvwiIP,
vvwiSourceLocator, vvwiChannel, vvwiChannelName, vvwiChannelDescription,
vvwiTitle, vvwiSubject, vvwiCategory, vvwiKeywords,
vvwiRatings, vvwiComments, vvwiOwner, vvwiEditor,
vvwiSupplier, vvwiSource, vvwiProject, vvwiStatus,
vvwiAuthor, vvwiRevisionNumber, vvwiProduced, vvwiAlbum,
vvwiArtist, vvwiComposer, vvwiCopyright, vvwiCreationData,
vvwiDescription, vvwiDirector, vvwiDisclaimer, vvwiEncodedBy,
vvwiFullName, vvwiGenre, vvwiHostComputer, vvwiInformation,
vvwiMake, vvwiModel, vvwiOriginalArtist, vvwiOriginalFormat,
vvwiPerformers, vvwiProducer, vvwiProduct, vvwiSoftware,
vvwiSpecialPlaybackRequirements, vvwiTrack, vvwiWarning, vvwiURLLink,
vvwiEditData1, vvwiEditData2, vvwiEditData3, vvwiEditData4,
vvwiEditData5, vvwiEditData6, vvwiEditData7, vvwiEditData8,
vvwiEditData9, vvwiVersionString, vvwiManufacturer, vvwiLanguage,
vvwiFormat, vvwiInputDevice, vvwiDeviceModelNum, vvwiDeviceSerialNum,
vvwiReel, vvwiShot, vvwiTake, vvwiSlateInfo,
vvwiFrameAttribute, vvwiEpisode, vvwiScene, vvwiDailyRoll,
vvwiCamRoll, vvwiSoundRoll, vvwiLabRoll, vvwiKeyNumberPrefix,
vvwiInkNumberPrefix, vvwiPictureIcon, vvwiProxyFile, vvwiEND_OF_STRINGS,
vvwiNumericStart = 0x1000, vvwiTimeCode, vvwiUserBits, vvwiVITCTimeCode,
vvwiVITCUserBits, vvwiVITCLine3, vvwiPosterFrame, vvwiAFrame,
vvwiAspectRatio, vvwiOriginalRate, vvwiOriginalScale, vvwiConversions,
vvwiVersionNumber, vvwiFileSize, vvwiFileDate, vvwiFileTime,
vvwiSequenceNumber, vvwiTotalStreams, vvwiTotalLength, vvwiFilmManufacturerCode,
vvwiFilmTypeCode, vvwiWhitePoint, vvwiBlackPoint, vvwiBlackGain,
vvwiBreakPoint, vvwiGamma1000, vvwiTagNumber, vvwiFlags,
vvwiTimeCodeType, vvwiLTCTimeCodeType, vvwiVITCTimeCodeType, vvwiEND_OF_DWORD_V2,
vvwiVideoWidth = 0x10000, vvwiVideoHeight, vvwiVideoPlanes, vvwiVideoBitCount,
vvwiVideoCompression, vvwiVideoSizeImage, vvwiVideoXPelsPerMeter, vvwiVideoYPelsPeMeter,
vvwiVideoClrUsed, vvwiVideoClrImportant, vvwiVideoReserved, vvwiVideoFccType,
vvwiVideoFccHandler, vvwiVideoFlags, vvwiVideoCaps, vvwiVideoPriority,
vvwiVideoLanguage, vvwiVideoScale, vvwiVideoRate, vvwiVideoStart,
vvwiVideoLength, vvwiVideoInitialFrames, vvwiVideoSuggestedBufferSize, vvwiVideoQuality,
vvwiVideoSampleSize, vvwiVideoEditCount, vvwiVideoFormatChangeCount, vvwiVideoPitch,
vvwiVideoDrFlags, vvwiVideoFileType, vvwiVideoResDrastic, vvwiLastElementPlus1
}

Define Documentation

#define _MAX_CLIP_NAME_SIZE 9

The size of a clip name string (8 char plus NULL term) (1 for safety) - This is for odetics/louth compatibility.

#define _PDFRAMEFLAGS_CLIPEND 0x00000004

This is the last frame of the current clip see DFRAME::dwFlags.

#define _PDFRAMEFLAGS_CLIPSTART 0x00000002

This is the first frame of a new clip see DFRAME::dwFlags.

#define _PDFRAMEFLAGS_CLIPSTILL 0x00000001

This is a single frame clip (implies progressive) that needs to be play for the duration of the clip see DFRAME::dwFlags.

#define _PDFRAMEFLAGS_FIRSTFRAME 0x00000002

Alias for _PDFRAMEFLAGS_CLIPSTART see DFRAME::dwFlags.

#define _PDFRAMEFLAGS_LASTFRAME 0x00000004

Alias for _PDFRAMEFLAGS_CLIPEND see DFRAME::dwFlags.

#define _VVW_ABS_MAX_CHANNELS 256

Abs Max Channels on any system.

#define _VVW_CONTROL_MAX_CONTROL _VVW_CONTROL_MAX_LOCAL

This is the maximum number of control inputs available.

#define _VVW_CONTROL_MAX_EXTERNAL 64U

Maximum number of external channels (63..127).

#define _VVW_CONTROL_MAX_LOCAL 64U

This is the maximum number of channels that may exist on a machine locally. They are numbered from 0..63 inclusive to the controlling software

#define _VVW_CONTROL_MAX_NETWORK 128U

Maximum number of network channels (128..255).

#define _VVW_CONTROL_START_EXTERNAL _VVW_CONTROL_MAX_LOCAL

This is the maximum number of local serial control channels, LTC, VITC or any other info/control channels that may exist on a single machine. The are numbered 64..127

#define _VVW_CONTROL_START_LOCAL 0

First real channel

#define _VVW_CONTROL_START_NETWORK (_VVW_CONTROL_MAX_EXTERNAL + _VVW_CONTROL_MAX_EXTERNAL)

This is the maximum number of of network control channels. Each of the other channels exports a network server and may be connected to any of these channels as the user wishes They are numbered 128..255

#define _VVW_DSYNC_CHANNEL 65536

Special sync channel

#define _VVW_DSYNC_LTC_CHANNEL _VVW_DSYNC_CHANNEL + 1

First ltc channel

#define _VVW_IS_VVWAUDIO 0x0100

The flag indicating the structure is a VVWAUDIO structure within a union.

#define _VVW_IS_VVWINFO 0x1000

The flag indicating the structure is a VVWINFO structure within a union.

#define _VVW_IS_VVWSYSTEM 0x0000

The flag indicating the structure is a VVWSYSTEM structure within a union.

#define _VVW_IS_VVWVIDEO 0x0010

The flag indicating the structure is a VVWVIDEO structure within a union.

#define _VVW_TYPES_HAVE_ALREADY_BEEN_INCLUDED

#define _VVWXXX_NAME_SIZE 64

The size of the name area (in chars) within VVWSYSTEM, VVWVIDEO, VVWAUDIO and VVWINFO.

#define _VVWXXX_RESERVED_SIZE 256

The size of the reserved area (in DWORDs) within VVWSYSTEM, VVWVIDEO, VVWAUDIO and VVWINFO.

#define DECLARE_DRASTIC_CHANNEL ( __x_ )

Value:

{ 0xFFFFFFFF, 0, 0, 0, 0, 0, 0, 0,                      \
        &__x_.dwFrame, 1, 3, ctStop, 0,         \
        0, 0xFFFFFFFF, &__x_, 0};
Declare and initialize a DRASTIC_CHANNEL.

#define DFRAME_FIELD_INVERT 0x00200000

The fields in the frame are inverted (jaggies) see DFRAME::dwType.

#define DFRAME_LARGE_AUDIO 0x01000000

The frame contains a large chunk of audio (allows for optimization in AvHAL) see DFRAME::dwType.

#define DFRAME_NEW_FORMAT 0x08000000

This frame starts a new format that is different from the ones previous. Please get the new format and adjust before displaying see DFRAME::dwType.

#define DFRAME_ORIENTATION_INVERT 0x00800000

The contents of the frame are inverted.

#define DFRAME_PROGRESSIVE 0x00100000

The contents of the frame are progressive (as opposed to interlaced) see DFRAME::dwType.

#define DFRAME_SKIP_FRAME 0x40000000

This frame should be skipped (decoded, but not displayed) - Used to reach seek frame on a non key frame from key frame see DFRAME::dwType.

#define DFRAME_TIME_INVERT 0x00400000

The fields in the frame are temporally inverts (jumps back and forth) see DFRAME::dwType.

#define DFRAME_TYPE_AUDIO 0x00010000

This frame contains audio data see DFRAME::dwType.

#define DFRAME_TYPE_FI_PTR_DATA 0x00008000

This indicates that fi.dwVITCAux points to a data area and dwCCData contains its size.

#define DFRAME_TYPE_KEYFRAME 0x10000000

This frame is independant of other frames for decode see DFRAME::dwType.

#define DFRAME_TYPE_KEYFRAME_B 0x20000000

This frame requires more than one frame to decode (for MPEG a B Frame) see DFRAME::dwType.

#define DFRAME_TYPE_KEYFRAME_I 0x10000000

This frame is independant of other frames for decode (an MPEG I Frame) see DFRAME::dwType.

#define DFRAME_TYPE_KEYFRAME_P 0x00000000

This frame requires previous keyframe(s) (for MPEG a P Frame) see DFRAME::dwType.

#define DFRAME_TYPE_NOTPHYSHEAP 0x00001000

This indicates PhysHeap did NOT allocate the dframe (not pheap or local heap).

#define DFRAME_TYPE_PAUSE (0x00000004 | DFRAME_TYPE_PLAY)

This frame was aquired while in pause and is most likely a seek (normally by AvHAL) see DFRAME::dwType.

#define DFRAME_TYPE_PLAY 0x00000002

This frame should be played out (normally by AvHAL) see DFRAME::dwType.

#define DFRAME_TYPE_RECORD 0x00000001

This frame was recorded into (normally by AvHAL) see DFRAME::dwType.

#define DFRAME_TYPE_VIDEO 0x00020000

This frame contains video data see DFRAME::dwType.

#define DRFLAGS_CODECPRIVATEDATA_AVI 0x01000000

Private data format is AVI see VVWVIDEO::dwDrFlags.

#define DRFLAGS_CODECPRIVATEDATA_MOV 0x02000000

Private data format is MOV see VVWVIDEO::dwDrFlags.

#define DRFLAGS_CODECPRIVATEDATA_OMF 0x04000000

Private data format is OMF see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FCC_MJPG_DCx0 0x00010000

Stream is Miro DC50 MJPG see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FCC_MJPG_DIGISUITE 0x00000000

Stream is DigiSuite MJPG see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FCC_MJPG_DSEDIT 0x00020000

Stream is DigiSuite Edit MJPG see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FCC_MJPG_JFIF 0x00080000

Stream is JFIF jpeg see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FCC_MJPG_JPGDIB 0x00040000

Stream is MJPG MS-Dib variant see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FCC_USE_ICM 0x00800000

Stream should use windows icm/vfw codecs see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FCC_USE_INTERN 0x00100000

Stream should use internal codecs see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FCC_USE_QT 0x00400000

Stream should use quicktime codecs see VVWVIDEO::dwDrFlags.

#define DRFLAGS_FIRST_FIELD_DOMINANT 0x00000001

First Field Dominant in VVWVIDEO::dwDrFlags.

#define DRFLAGS_HAS_KEYFRAMES 0x00000010

Stream has key frames, else all key frames VVWVIDEO::dwDrFlags.

#define DRFLAGS_NOT_QUICKCLIP 0x00000002

Preview to QuickclipXO.

#define DRFLAGS_VTYPE_INTERLACED 0x00000100

Interlaced video frames.

#define DRFLAGS_VTYPE_PROGRESSIVE 0x00000200

Progressive video frames.

#define DRFLAGS_VTYPE_SEGMENTEDFRAME 0x00000400

Segmented Frame video frames.

#define DRFLAGS_ZERO_FIELD_DOMINANT 0x00000000

Zero (Second) Field Dominant in VVWVIDEO::dwDrFlags.

#define DTVHDR_DONE 0x00000001

internal to AvHAL Set by the device driver to indicate it is finished with the data buffer and is returning the buffer to the client. see DFRAME::dwFlags

#define DTVHDR_INQUEUE 0x00000004

internal to AvHAL Set by the driver to indicate the buffer is in the driver’s buffer queue. see DFRAME::dwFlags

#define DTVHDR_KEYFRAME 0x00000008

internal to AvHAL Set by the device driver to indicate a key frame. see DFRAME::dwFlags

#define DTVHDR_PREPARED 0x00000002

internal to AvHAL Indicates whether or not the buffer has been prepared for use. See DVM_STREAM_PREPAREHEADER. see DFRAME::dwFlags

#define DTVVW_PREVIEW 0x80000000

The universal preview flag - Top bit of a flag DWORD. This bit should not be used for other purposes as the whole system should know if we are in preview. Main places it is used: intPreviewOpen(dwFlags) avOpen(dwFlags) mfOpen(dwOpenFlags) codecOpen(fccFlags) - I think

#define DTWAVE_FORMAT_PCM 1

PCM Wave Type, see fccDef.h for other possible types.

#define DTWHDR_BEGINLOOP 0x00000004

internal to AvHAL This buffer is the first buffer in a loop. This flag is used only with output buffers. see DFRAME::dwFlags

#define DTWHDR_DONE 0x00000001

Set by the device driver to indicate that it is finished with the buffer and is returning it to the application. see DFRAME::dwFlags.

#define DTWHDR_ENDLOOP 0x00000008

internal to AvHAL This buffer is the last buffer in a loop. This flag is used only with output buffers. see DFRAME::dwFlags

#define DTWHDR_INQUEUE 0x00000010

internal to AvHAL Set by Windows to indicate that the buffer is queued for playback. see DFRAME::dwFlags

#define DTWHDR_PREPARED 0x00000002

internal to AvHAL Set by Windows to indicate that the buffer has been prepared with the waveInPrepareHeader or waveOutPrepareHeader function. see DFRAME::dwFlags

#define dwFI_DataAreaSize dwCCData

Alternate name for dwCCData.

#define GetAudio 0x00000000

Flag for mediafile/avhal to get audio dframe

#define GetCurrent 0x00000000

Flag for avhal to get the current FRAME_INFO.

#define GetInf 0x00000002

Flag for mediafile/avhal to get info (VVWINFO).

#define GetNoFail 0x00000100

Flag for getting second copy or other non queue critical frames.

#define GetQueued 0x00000010

Flag for avhal to get the last queued FRAME_INFO.

#define GetVideo 0x00000001

Flag for mediafile/avhal to get video dframe.

#define INIT_DRASTIC_CHANNEL ( __x_ )

Value:

{ ZeroMemory(&__x_, sizeof(DRASTIC_CHANNEL));   \
        __x_.pdwFrame = &__x_.dwFrame;                                  \
        __x_.ctCmd = ctStop;                                                    \
        __x_.pOwnerHandle = &__x_; };
Initialize a DRASTIC_CHANNEL.

#define INIT_PDRASTIC_CHANNEL ( __x_ )

Value:

{ ZeroMemory(__x_, sizeof(DRASTIC_CHANNEL));    \
        __x_->pdwFrame = &__x_->dwFrame;                                \
        __x_->ctCmd = ctStop;                                                   \
        __x_->pOwnerHandle = &__x_; };
Initialize a memory area allocated as a DRASTIC_CHANNEL.

#define MASK___DRFLAGS_FIELD 0x00000001

Field dominance MASK for VVWVIDEO::dwDrFlags.

#define MASK___DRFLAGS_KEYFRAME 0x00000010

KeyFrame MASK for VVWVIDEO::dwDrFlags.

#define MASK___DRFLAGS_VTYPE 0x00000700

Frame type mask (1=interlaced,2=progressive,4=segmentedframe).

#define MASK___FCCMODIFIERS 0x00FF0000

Fourcc modifiers MASK for VVWVIDEO::dwDrFlags.

#define MASK___PREVIEW 0xF0000000

MASK Room for current DTVVW_PREVIEW and more if nec see VVWVIDEO::dwDrFlags.

#define MASK__CODECPRIVATEDATA 0x0F000000

Private Data MASK see VVWVIDEO::dwDrFlags.

#define MB_CODEC_DESC_LEN 255

Maximum length for the full (long) codec description.

#define MB_CODEC_SHORT_LEN 64

Maximum length for the short codec name.

#define MB_FILE_DESC_LEN 255

Maximum length for the long description.

#define MB_FILE_EXT_LEN 200

Maximum length for the supported file extensions string (fmt: *.xxx;*.yyy;*.ttt).

#define MB_FILE_SHORT_LEN 64

Maximum length for the base or short description (used in drop down).

#define pFI_DataAreaPtr dwVITCAux

Alternate name for dwVITCAux.

#define PutAudio GetAudio

Flag for mediafile/avhal to put audio dframe.

#define PutInf GetInf

Flag for mediafile/avhal to get info (VVWINFO).

#define PutVideo GetVideo

Flag for mediafile/avhal to put audio dframe.

#define SIZEOFDFRAME (((sizeof(DFRAME) >> 2) + 1) << 2)

The DWORD aligned size of a DFRAME, used for more effecient memory allocations.

#define VVW_ABS_MAX_FRAME 10692000

Absolute maximum timecode in a time code space (99:59:59:29 NDF) - Actual max is usually 23:59:59:x9 depending on type (see tc2Maximum()).

#define VVW_INVALID_FRAME 0xFFFFFFFF

No frame exists - is the same as TC_ILLEGAL - careful, only valid when tc cannot go negative, else it means -1.

#define VVWAUD_RECALC ( __pvvwaud_ )

Value:

{       \
        if((__pvvwaud_)->wFormatTag == DTWAVE_FORMAT_PCM) {     \
                (__pvvwaud_)->nBlockAlign = ((__pvvwaud_)->nChannels * (((__pvvwaud_)->wBitsPerSample + 7) >> 3));      \
                (__pvvwaud_)->nAvgBytesPerSec = (__pvvwaud_)->nBlockAlign * (__pvvwaud_)->nSamplesPerSec;       \
                (__pvvwaud_)->dwSuggestedBufferSize = (__pvvwaud_)->nAvgBytesPerSec >> 1;       \
                (__pvvwaud_)->dwSampleSize = (__pvvwaud_)->nBlockAlign; \
                (__pvvwaud_)->dwScale = (__pvvwaud_)->nBlockAlign;      \
                (__pvvwaud_)->dwRate = (__pvvwaud_)->nAvgBytesPerSec;   \
        }       \
        }
Recalculate audio structure: Uses VVWAUDIO::nChannels, VVWAUDIO::wBitsPerSample and VVWAUDIO::nSamplesPerSec to caclulate the VVWAUDIO::nBlockAlign, VVWAUDIO::nAvgBytesPerSec, VVWAUDIO::dwSuggestedBufferSize, VVWAUDIO::dwSampleSize, VVWAUDIO::dwScale and VVWAUDIO::dwRate members - Only valid of PCM uncompressed audio streams. NOTE: nBlockAlign = nChannels * ((wBitsPerSample + 7) >> 3) gives the minimum container size for the bit size. In our write and intenal cases, we always use 32 bits for 20 and 24. This calc return 24 for 20 and 24. We need this for the read side, so make sure any write size stuff is caught.

#define VVWAUD_SET | ( | __pvvwaud_,
 |  | _formattag,
 |  | _channels,
 |  | _samplespersec,
 |  | _bitspersample,
 |  | _samples | )

Value:

{       \
        (__pvvwaud_)->wFormatTag = _formattag;  \
        (__pvvwaud_)->fccHandler = _formattag;  \
        (__pvvwaud_)->nChannels = _channels;    \
        (__pvvwaud_)->nSamplesPerSec = _samplespersec;  \
        (__pvvwaud_)->wBitsPerSample = _bitspersample;  \
        (__pvvwaud_)->dwLength = _samples;      \
        VVWAUD_RECALC((__pvvwaud_));    \
        }
Set the VVWAUDIO structure pointer from formattag, channels, samples per sec, bits per sample and number of samples.

#define VVWAUD_SETCLR | ( | __pvvwaud_,
 |  | _formattag,
 |  | _channels,
 |  | _samplespersec,
 |  | _bitspersample,
 |  | _samples | )

Value:

{       \
        VVWAUD_SET((__pvvwaud_), _formattag, _channels, _samplespersec, _bitspersample, _samples); \
        ZeroMemory((__pvvwaud_)->dwReserved, _VVWXXX_RESERVED_SIZE);    \
        (__pvvwaud_)->fccType = streamtypeAUDIO;        \
        (__pvvwaud_)->dwFlags = 0;      \
        (__pvvwaud_)->dwCaps = 0;       \
        (__pvvwaud_)->wPriority = 0;    \
        (__pvvwaud_)->wLanguage = 0;    \
        (__pvvwaud_)->dwStart = 0;      \
        (__pvvwaud_)->dwInitialFrames = 0;      \
        (__pvvwaud_)->dwQuality = 0xFFFFFFFF;   \
        (__pvvwaud_)->dwEditCount = 0;  \
        (__pvvwaud_)->dwFormatChangeCount = 0;  \
        ZeroMemory((__pvvwaud_)->szName, _VVWXXX_NAME_SIZE);    \
        (__pvvwaud_)->dwDrFlags = 0;    \
        (__pvvwaud_)->dwResDrastic = 0; \
        }
Clean and set the VVWAUDIO structure pointer from formattag, channels, samples per sec, bits per sample and number of samples.

#define VVWINFOTAG_dwAFrame "A-Frame"

XML tag name for VVWINFO::dwAFrame.

#define VVWINFOTAG_dwAspectRatio "AspectRatio"

XML tag name for VVWINFO::dwAspectRatio.

#define VVWINFOTAG_dwBlackGain "BlackGain"

XML tag name for VVWINFO::dwBlackGain.

#define VVWINFOTAG_dwBlackPoint "BlackPoint"

XML tag name for VVWINFO::dwBlackPoint.

#define VVWINFOTAG_dwBreakPoint "BreakPoint"

XML tag name for VVWINFO::dwBreakPoint.

#define VVWINFOTAG_dwConversions "TotalConversions"

XML tag name for VVWINFO::dwTotalConversions.

#define VVWINFOTAG_dwFileDate "FileDate"

XML tag name for VVWINFO::dwFileDate.

#define VVWINFOTAG_dwFileSize "FileSize"

XML tag name for VVWINFO::dwFileSize.

#define VVWINFOTAG_dwFileTime "FileTime"

XML tag name for VVWINFO::dwFileTime.

#define VVWINFOTAG_dwFilmManufacturerCode "FilmManufacturerCode"

XML tag name for VVWINFO::dwFilmManufacturerCode.

#define VVWINFOTAG_dwFilmTypeCode "FilmTypeCode"

XML tag name for VVWINFO::dwFilmTypeCode.

#define VVWINFOTAG_dwFlags "Flags"

XML tag name for VVWINFO::dwFlags.

#define VVWINFOTAG_dwGamma1000 "Gamma1000"

XML tag name for VVWINFO::dwGamma1000.

#define VVWINFOTAG_dwLTCTimeCodeType "LTCTimeCodeType"

XML tag name for VVWINFO::dwLTCTimeCodeType.

#define VVWINFOTAG_dwNU_31 "NumericNotUsed_31"

XML tag name for VVWINFO::dwNU_31.

#define VVWINFOTAG_dwNU_32 "NumericNotUsed_32"

XML tag name for VVWINFO::dwNU_32.

#define VVWINFOTAG_dwNU_33 "NumericNotUsed_33"

XML tag name for VVWINFO::dwNU_33.

#define VVWINFOTAG_dwNU_34 "NumericNotUsed_34"

XML tag name for VVWINFO::dwNU_34.

#define VVWINFOTAG_dwNU_35 "NumericNotUsed_35"

XML tag name for VVWINFO::dwNU_35.

#define VVWINFOTAG_dwNU_36 "NumericNotUsed_36"

XML tag name for VVWINFO::dwNU_36.

#define VVWINFOTAG_dwNU_37 "NumericNotUsed_37"

XML tag name for VVWINFO::dwNU_37.

#define VVWINFOTAG_dwNU_38 "NumericNotUsed_38"

XML tag name for VVWINFO::dwNU_38.

#define VVWINFOTAG_dwNU_39 "NumericNotUsed_39"

XML tag name for VVWINFO::dwNU_39.

#define VVWINFOTAG_dwNU_40 "NumericNotUsed_40"

XML tag name for VVWINFO::dwNU_40.

#define VVWINFOTAG_dwNU_41 "NumericNotUsed_41"

XML tag name for VVWINFO::dwNU_41.

#define VVWINFOTAG_dwNU_42 "NumericNotUsed_42"

XML tag name for VVWINFO::dwNU_42.

#define VVWINFOTAG_dwNU_43 "NumericNotUsed_43"

XML tag name for VVWINFO::dwNU_43.

#define VVWINFOTAG_dwNU_44 "NumericNotUsed_44"

XML tag name for VVWINFO::dwNU_44.

#define VVWINFOTAG_dwNU_45 "NumericNotUsed_45"

XML tag name for VVWINFO::dwNU_45.

#define VVWINFOTAG_dwNU_46 "NumericNotUsed_46"

XML tag name for VVWINFO::dwNU_46.

#define VVWINFOTAG_dwNU_47 "NumericNotUsed_47"

XML tag name for VVWINFO::dwNU_47.

#define VVWINFOTAG_dwNU_48 "NumericNotUsed_48"

XML tag name for VVWINFO::dwNU_48.

#define VVWINFOTAG_dwNU_49 "NumericNotUsed_49"

XML tag name for VVWINFO::dwNU_49.

#define VVWINFOTAG_dwOriginalRate "OriginalRate"

XML tag name for VVWINFO::dwOriginalRate.

#define VVWINFOTAG_dwOriginalScale "OriginalScale"

XML tag name for VVWINFO::dwOriginalScale.

#define VVWINFOTAG_dwPosterFrame "PosterFrame"

XML tag name for VVWINFO::dwPosterFrame.

#define VVWINFOTAG_dwSequenceNumber "SequenceNumber"

XML tag name for VVWINFO::dwSequenceNumber.

#define VVWINFOTAG_dwTagNumber "TagNumber"

XML tag name for VVWINFO::dwTagNumber.

#define VVWINFOTAG_dwTimeCode "TimeCode"

XML tag name for VVWINFO::dwTimeCode.

#define VVWINFOTAG_dwTimeCodeType "TimeCodeType"

XML tag name for VVWINFO::dwTimeCodeType.

#define VVWINFOTAG_dwTotalLength "TotalLength"

XML tag name for VVWINFO::dwTotalLength.

#define VVWINFOTAG_dwTotalStreams "TotalStreams"

XML tag name for VVWINFO::dwTotalStreams.

#define VVWINFOTAG_dwUserBits "UserBits"

XML tag name for VVWINFO::dwUserBits.

#define VVWINFOTAG_dwVersionNumber "VersionNumber"

XML tag name for VVWINFO::dwVersionNumber.

#define VVWINFOTAG_dwVITCLine3 "VITCExtraData"

XML tag name for VVWINFO::dwVICTLine3.

#define VVWINFOTAG_dwVITCTimeCode "VITCTimeCode"

XML tag name for VVWINFO::dwVITCTimeCode.

#define VVWINFOTAG_dwVITCTimeCodeType "VITCTimeCodeType"

XML tag name for VVWINFO::dwVITCTimeCodeType.

#define VVWINFOTAG_dwVITCUserBits "VITCUserBits"

XML tag name for VVWINFO::dwVITCUserBits.

#define VVWINFOTAG_dwWhitePoint "WhitePoint"

XML tag name for VVWINFO::dwWhitePoint.

#define VVWINFOTAG_szAlbum "Album"

XML tag name for VVWINFO::szAlbum.

#define VVWINFOTAG_szArtist "Artist"

XML tag name for VVWINFO::szArtist.

#define VVWINFOTAG_szAuthor "Author"

XML tag name for VVWINFO::szAuthor.

#define VVWINFOTAG_szCamRoll "CamRoll"

XML tag name for VVWINFO::szCamRoll.

#define VVWINFOTAG_szCategory "Category"

XML tag name for VVWINFO::szCategory.

#define VVWINFOTAG_szChannel "ChannelIdentifier"

XML tag name for VVWINFO::szChannelIdentifier.

#define VVWINFOTAG_szChannelDescription "ChannelDescription"

XML tag name for VVWINFO::szChannelDescription.

#define VVWINFOTAG_szChannelName "ChannelName"

XML tag name for VVWINFO::szChannelName.

#define VVWINFOTAG_szComments "Comments"

XML tag name for VVWINFO::szComments.

#define VVWINFOTAG_szComposer "Composer"

XML tag name for VVWINFO::szComposer.

#define VVWINFOTAG_szCopyright "Copyright"

XML tag name for VVWINFO::szCopyright.

#define VVWINFOTAG_szCreationData "CreationData"

XML tag name for VVWINFO::szCreationData.

#define VVWINFOTAG_szDailyRoll "DailyRoll"

XML tag name for VVWINFO::szDailyRoll.

#define VVWINFOTAG_szDescription "Description"

XML tag name for VVWINFO::szDescription.

#define VVWINFOTAG_szDeviceModelNum "DeviceModelNum"

XML tag name for VVWINFO::szDeviceModelNum.

#define VVWINFOTAG_szDeviceSerialNum "DeviceSerialNum"

XML tag name for VVWINFO::szDeviceSerialNum.

#define VVWINFOTAG_szDirector "Director"

XML tag name for VVWINFO::szDirector.

#define VVWINFOTAG_szDisclaimer "Disclaimer"

XML tag name for VVWINFO::szDisclaimer.

#define VVWINFOTAG_szDoNotUse "DoNotUse"

XML tag name for VVWINFO::szDoNotUse.

#define VVWINFOTAG_szEditData1 "EditData1"

XML tag name for VVWINFO::szEditData1.

#define VVWINFOTAG_szEditData2 "EditData2"

XML tag name for VVWINFO::szEditData2.

#define VVWINFOTAG_szEditData3 "EditData3"

XML tag name for VVWINFO::szEditData3.

#define VVWINFOTAG_szEditData4 "EditData4"

XML tag name for VVWINFO::szEditData4.

#define VVWINFOTAG_szEditData5 "EditData5"

XML tag name for VVWINFO::szEditData5.

#define VVWINFOTAG_szEditData6 "EditData6"

XML tag name for VVWINFO::szEditData6.

#define VVWINFOTAG_szEditData7 "EditData7"

XML tag name for VVWINFO::szEditData7.

#define VVWINFOTAG_szEditData8 "EditData8"

XML tag name for VVWINFO::szEditData8.

#define VVWINFOTAG_szEditData9 "EditData9"

XML tag name for VVWINFO::szEditData9.

#define VVWINFOTAG_szEditor "Editor"

XML tag name for VVWINFO::szEditor.

#define VVWINFOTAG_szEncodedBy "EncodedBy"

XML tag name for VVWINFO::szEncodedBy.

#define VVWINFOTAG_szEpisode "Episode"

XML tag name for VVWINFO::szEpisode.

#define VVWINFOTAG_szFileName "FileName"

XML tag name for VVWINFO::szFileName.

#define VVWINFOTAG_szFormat "Format"

XML tag name for VVWINFO::szFormat.

#define VVWINFOTAG_szFrameAttribute "FrameAttribute"

XML tag name for VVWINFO::szFrameAttibute.

#define VVWINFOTAG_szFullName "FullName"

XML tag name for VVWINFO::szFullName.

#define VVWINFOTAG_szGenre "Genre"

XML tag name for VVWINFO::szGenre.

#define VVWINFOTAG_szHostComputer "HostComputer"

XML tag name for VVWINFO::szHostComputer.

#define VVWINFOTAG_szInformation "Information"

XML tag name for VVWINFO::szInformation.

#define VVWINFOTAG_szInkNumberPrefix "InkNumberPrefix"

XML tag name for VVWINFO::szInkNumberPrefix.

#define VVWINFOTAG_szInputDevice "InputDevice"

XML tag name for VVWINFO::szInputDevice.

#define VVWINFOTAG_szIP "TCP-IPAddress"

XML tag name for VVWINFO::szIP.

#define VVWINFOTAG_szKeyNumberPrefix "KeyNumberPrefix"

XML tag name for VVWINFO::szKeyNumberPrefix.

#define VVWINFOTAG_szKeywords "Keywords"

XML tag name for VVWINFO::szKeywords.

#define VVWINFOTAG_szLabRoll "LabRoll"

XML tag name for VVWINFO::szLabRoll.

#define VVWINFOTAG_szLanguage "Language"

XML tag name for VVWINFO::szLanguage.

#define VVWINFOTAG_szMake "Make"

XML tag name for VVWINFO::szMake.

#define VVWINFOTAG_szManufacturer "Manufacturer"

XML tag name for VVWINFO::szManufacturer.

#define VVWINFOTAG_szModel "Model"

XML tag name for VVWINFO::szModel.

#define VVWINFOTAG_szNativeLocator "NativeLocator"

XML tag name for VVWINFO::szNativeLocator.

#define VVWINFOTAG_szNU_81 "NotUsed_81"

XML tag name for VVWINFO::szNU_81.

#define VVWINFOTAG_szNU_82 "NotUsed_82"

XML tag name for VVWINFO::szNU_82.

#define VVWINFOTAG_szNU_83 "NotUsed_83"

XML tag name for VVWINFO::szNU_83.

#define VVWINFOTAG_szNU_84 "NotUsed_84"

XML tag name for VVWINFO::szNU_84.

#define VVWINFOTAG_szNU_85 "NotUsed_85"

XML tag name for VVWINFO::szNU_85.

#define VVWINFOTAG_szNU_86 "NotUsed_86"

XML tag name for VVWINFO::szNU_86.

#define VVWINFOTAG_szNU_87 "NotUsed_87"

XML tag name for VVWINFO::szNU_87.

#define VVWINFOTAG_szNU_88 "NotUsed_88"

XML tag name for VVWINFO::szNU_88.

#define VVWINFOTAG_szNU_89 "NotUsed_89"

XML tag name for VVWINFO::szNU_89.

#define VVWINFOTAG_szNU_90 "NotUsed_90"

XML tag name for VVWINFO::szNU_90.

#define VVWINFOTAG_szNU_91 "NotUsed_91"

XML tag name for VVWINFO::szNU_91.

#define VVWINFOTAG_szNU_92 "NotUsed_92"

XML tag name for VVWINFO::szNU_92.

#define VVWINFOTAG_szNU_93 "NotUsed_93"

XML tag name for VVWINFO::szNU_93.

#define VVWINFOTAG_szNU_94 "NotUsed_94"

XML tag name for VVWINFO::szNU_94.

#define VVWINFOTAG_szNU_95 "NotUsed_95"

XML tag name for VVWINFO::szNU_95.

#define VVWINFOTAG_szNU_96 "NotUsed_96"

XML tag name for VVWINFO::szNU_96.

#define VVWINFOTAG_szNU_97 "NotUsed_97"

XML tag name for VVWINFO::szNU_97.

#define VVWINFOTAG_szNU_98 "NotUsed_98"

XML tag name for VVWINFO::szNU_98.

#define VVWINFOTAG_szNU_99 "NotUsed_99"

XML tag name for VVWINFO::szNU_99.

#define VVWINFOTAG_szOriginalArtist "OriginalArtist"

XML tag name for VVWINFO::szOriginalArtist.

#define VVWINFOTAG_szOriginalFormat "OriginalFormat"

XML tag name for VVWINFO::szOriginalFormat.

#define VVWINFOTAG_szOwner "Owner"

XML tag name for VVWINFO::szOwner.

#define VVWINFOTAG_szPerformers "Performers"

XML tag name for VVWINFO::szPerformers.

#define VVWINFOTAG_szPictureIcon "PictureIcon"

XML tag name for VVWINFO::szPictureIcon.

#define VVWINFOTAG_szProduced "Produced"

XML tag name for VVWINFO::szProduced.

#define VVWINFOTAG_szProducer "Producer"

XML tag name for VVWINFO::szProducer.

#define VVWINFOTAG_szProduct "Product"

XML tag name for VVWINFO::szProduct.

#define VVWINFOTAG_szProject "Project"

XML tag name for VVWINFO::szProject.

#define VVWINFOTAG_szProxyFile "ProxyFile"

XML tag name for VVWINFO::szProxyFile.

#define VVWINFOTAG_szRatings "Ratings"

XML tag name for VVWINFO::szRatings.

#define VVWINFOTAG_szReel "Reel"

XML tag name for VVWINFO::szReel.

#define VVWINFOTAG_szRevisionNumber "RevisionNumber"

XML tag name for VVWINFO::szRevisionNumber.

#define VVWINFOTAG_szScene "Scene"

XML tag name for VVWINFO::szScene.

#define VVWINFOTAG_szShot "Shot"

XML tag name for VVWINFO::szShot.

#define VVWINFOTAG_szSlateInfo "SlateInfo"

XML tag name for VVWINFO::szSlateInfo.

#define VVWINFOTAG_szSoftware "Software"

XML tag name for VVWINFO::szSoftware.

#define VVWINFOTAG_szSoundRoll "SoundRoll"

XML tag name for VVWINFO::szSoundRoll.

#define VVWINFOTAG_szSource "Source"

XML tag name for VVWINFO::szSource.

#define VVWINFOTAG_szSourceLocator "SourceLocator"

XML tag name for VVWINFO::szSourceLocator.

#define VVWINFOTAG_szSpecialPlaybackRequirements "SpecialPlaybackRequirements"

XML tag name for VVWINFO::szSpecialPlaybackRequirements.

#define VVWINFOTAG_szStatus "Status"

XML tag name for VVWINFO::szStatus.

#define VVWINFOTAG_szSubject "Subject"

XML tag name for VVWINFO::szSubject.

#define VVWINFOTAG_szSupplier "Supplier"

XML tag name for VVWINFO::szSupplier.

#define VVWINFOTAG_szTake "Take"

XML tag name for VVWINFO::szTake.

#define VVWINFOTAG_szTitle "Title"

XML tag name for VVWINFO::szTitle.

#define VVWINFOTAG_szTrack "Track"

XML tag name for VVWINFO::szTrack.

#define VVWINFOTAG_szUniversalName "UniversalLocator"

XML tag name for VVWINFO::szUniversalLocator.

#define VVWINFOTAG_szURLLink "URL"

XML tag name for VVWINFO::szURLLink.

#define VVWINFOTAG_szVersionString "VersionString"

XML tag name for VVWINFO::szVersionString.

#define VVWINFOTAG_szWarning "Warning"

XML tag name for VVWINFO::szWarning.

#define VVWINFOTAG_woBitCount "BitCount"

#define VVWINFOTAG_woCaps "Caps"

#define VVWINFOTAG_woClrImportant "ClrImportant"

#define VVWINFOTAG_woClrUsed "ClrUsed"

#define VVWINFOTAG_woCompression "Compression"

#define VVWINFOTAG_woDrFlags "DrFlags"

#define VVWINFOTAG_woEditCount "EditCount"

#define VVWINFOTAG_woFccHandler "FccHandler"

#define VVWINFOTAG_woFccType "FccType"

#define VVWINFOTAG_woFileType "FileType"

#define VVWINFOTAG_woFlags "Flags"

#define VVWINFOTAG_woFormatChangeCount "FormatChangeCount"

#define VVWINFOTAG_woHeight "Height"

#define VVWINFOTAG_woInitialFrames "InitialFrames"

#define VVWINFOTAG_woLanguage "Language"

#define VVWINFOTAG_woLength "Length"

#define VVWINFOTAG_woPitch "Pitch"

#define VVWINFOTAG_woPlanes "Planes"

#define VVWINFOTAG_woPriority "Priority"

#define VVWINFOTAG_woQuality "Quality"

#define VVWINFOTAG_woRate "Rate"

#define VVWINFOTAG_woResDrastic "ResDrastic"

#define VVWINFOTAG_woReserved "Reserved"

#define VVWINFOTAG_woSampleSize "SampleSize"

#define VVWINFOTAG_woScale "Scale"

#define VVWINFOTAG_woSizeImage "SizeImage"

#define VVWINFOTAG_woStart "Start"

#define VVWINFOTAG_woSuggestedBufferSize "SuggestedBufferSize"

#define VVWINFOTAG_woVideoWidth "Width"

#define VVWINFOTAG_woXPelsPerMeter "XPelsPerMeter"

#define VVWINFOTAG_woYPelsPerMeter "YPelsPerMeter"

#define VVWSYS_CLR ( __pvvwsys_ )

Value:

{       \
        (__pvvwsys_)->dwFlags = 0;      \
        (__pvvwsys_)->dwInitialFrames = 0;      \
        (__pvvwsys_)->dwReserved[0] = 0;        \
        (__pvvwsys_)->dwReserved[1] = 0;        \
        (__pvvwsys_)->dwReserved[2] = 0;        \
        (__pvvwsys_)->dwReserved[3] = 0;        \
        (__pvvwsys_)->dwCaps = 0;       \
        (__pvvwsys_)->dwEditCount = 0;  \
        (__pvvwsys_)->dwType = 0;       \
        (__pvvwsys_)->dwMfCaps = 0;     \
        (__pvvwsys_)->dwVidStandard = 0;        \
        (__pvvwsys_)->dwDrFlags = 0;    \
        (__pvvwsys_)->dwResDrastic = 0; \
        }
Clear a important 0 of a VVWVIDEO structure pointer.

#define VVWSYS_SET | ( | __pvvwsys_,
 |  | __pvvwvid_,
 |  | __pvvwaud_,
 |  | _granularity,
 |  | _frames | )

Value:

{       \
        (__pvvwsys_)->dwMicroSecPerFrame = (DWORD)(1000000.0 / ((double)(__pvvwvid_)->dwRate / (double)(__pvvwvid_)->dwScale)); \
        (__pvvwsys_)->dwMaxBytesPerSec = ((__pvvwvid_)->biSizeImage * (__pvvwvid_)->dwScale / (__pvvwvid_)->dwRate) + (__pvvwaud_)->nAvgBytesPerSec;    \
        (__pvvwsys_)->dwPaddingGranularity = _granularity;      \
        (__pvvwsys_)->dwTotalFrames = _frames;  \
        (__pvvwsys_)->dwSuggestedBufferSize = (__pvvwvid_)->dwSuggestedBufferSize + (__pvvwaud_)->dwSuggestedBufferSize;        \
        (__pvvwsys_)->dwWidth = (__pvvwvid_)->biWidth;  \
        if((__pvvwvid_)->biHeight < 0) (__pvvwsys_)->dwHeight = -(long)(__pvvwvid_)->biHeight; else (__pvvwsys_)->dwHeight = (__pvvwvid_)->biHeight;    \
        (__pvvwsys_)->dwScale = (__pvvwvid_)->dwScale;  \
        (__pvvwsys_)->dwRate = (__pvvwvid_)->dwRate;    \
        (__pvvwsys_)->dwLength= (__pvvwvid_)->dwLength; \
        }
Set a VVWSYSTEM structure pointer from VVWVIDEO pointer, VVWAUDIO pointer, a granularity size and number of frames.

#define VVWSYS_SETAUDONLY | ( | __pvvwsys_,
 |  | __pvvwaud_,
 |  | _granularity,
 |  | _frames | )

Value:

{       \
        (__pvvwsys_)->dwMicroSecPerFrame = (DWORD)(1000000.0 / ((double)(__pvvwaud_)->dwRate / (double)(__pvvwaud_)->dwScale)); \
        (__pvvwsys_)->dwMaxBytesPerSec = (__pvvwaud_)->nAvgBytesPerSec; \
        (__pvvwsys_)->dwPaddingGranularity = _granularity;      \
        (__pvvwsys_)->dwTotalFrames = _frames;  \
        (__pvvwsys_)->dwSuggestedBufferSize = (__pvvwaud_)->dwSuggestedBufferSize;      \
        (__pvvwsys_)->dwWidth = 0;      \
        (__pvvwsys_)->dwHeight = 0;     \
        (__pvvwsys_)->dwScale = (__pvvwaud_)->dwScale;  \
        (__pvvwsys_)->dwRate = (__pvvwaud_)->dwRate;    \
        (__pvvwsys_)->dwLength= (__pvvwaud_)->dwLength; \
        }
Set a VVWSYSTEM structure pointer from VVWAUDIO pointer, a granularity size and number of frames.

#define VVWSYS_SETVIDONLY | ( | __pvvwsys_,
 |  | __pvvwvid_,
 |  | _granularity,
 |  | _frames | )

Value:

{       \
        (__pvvwsys_)->dwMicroSecPerFrame = (DWORD)(1000000.0 / ((double)(__pvvwvid_)->dwRate / (double)(__pvvwvid_)->dwScale)); \
        (__pvvwsys_)->dwMaxBytesPerSec = ((__pvvwvid_)->biSizeImage * (__pvvwvid_)->dwScale / (__pvvwvid_)->dwRate);    \
        (__pvvwsys_)->dwPaddingGranularity = _granularity;      \
        (__pvvwsys_)->dwTotalFrames = _frames;  \
        (__pvvwsys_)->dwSuggestedBufferSize = (__pvvwvid_)->dwSuggestedBufferSize;      \
        (__pvvwsys_)->dwWidth = (__pvvwvid_)->biWidth;  \
        if((__pvvwvid_)->biHeight < 0) (__pvvwsys_)->dwHeight = -(long)(__pvvwvid_)->biHeight; else (__pvvwsys_)->dwHeight = (__pvvwvid_)->biHeight;    \
        (__pvvwsys_)->dwScale = (__pvvwvid_)->dwScale;  \
        (__pvvwsys_)->dwRate = (__pvvwvid_)->dwRate;    \
        (__pvvwsys_)->dwLength= (__pvvwvid_)->dwLength; \
        }
Set a VVWSYSTEM structure pointer from VVWVIDEO pointer, a granularity size and number of frames.

#define VVWVID_PITCHALIGN1 ( __pvvwvid_ ) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+ 7) / 8 ); }

Set VVWVIDEO::biPitch member to 1 byte alignment based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.

#define VVWVID_PITCHALIGN16 ( __pvvwvid_ ) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+127) / 128) * 16; }

Set VVWVIDEO::biPitch member to 16 byte alignment based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.

#define VVWVID_PITCHALIGN4 ( __pvvwvid_ ) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+ 31) / 32) * 4; }

Set VVWVIDEO::biPitch member to 4 byte (DWORD) alignment based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.

#define VVWVID_PITCHALIGN8 ( __pvvwvid_ ) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+ 63) / 64) * 8; }

Set VVWVIDEO::biPitch member to 8 byte alignment based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.

#define VVWVID_PITCHALIGNANY | ( | __pvvwvid_,
 |  | _align_1_4_8_16 | ) | { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+((_align_1_4_8_16 * 8) - 1)) / (_align_1_4_8_16 * 8)) * _align_1_4_8_16; }

Set VVWVIDEO::biPitch member to alignment specified based on VVWVIDEO::biWidth and VVWVIDEO::biBitCount.

#define VVWVID_PITCHMODULO ( __pvvwvid_ ) ((__pvvwvid_)->biPitch - ((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount + 7) / 8)

Set pitch to 1-0 alignment ?

#define VVWVID_RATESCALE_FILM ( __pvvwvid_ ) { (__pvvwvid_)->dwScale = 1; (__pvvwvid_)->dwRate = 24; }

Set the VVWVIDEO::dwRate and VVWVIDEO::dwScale for 24/1 (FILM).

#define VVWVID_RATESCALE_NTSC ( __pvvwvid_ ) { (__pvvwvid_)->dwScale = 100; (__pvvwvid_)->dwRate = 2997; }

Set the VVWVIDEO::dwRate and VVWVIDEO::dwScale for 2997/100 (NTSC).

#define VVWVID_RATESCALE_NTSC_AVI ( __pvvwvid_ ) { (__pvvwvid_)->dwScale = 1001; (__pvvwvid_)->dwRate = 30000; }

Set the VVWVIDEO::dwRate and VVWVIDEO::dwScale for 30000/1001 (NTSC).

#define VVWVID_RATESCALE_PAL ( __pvvwvid_ ) { (__pvvwvid_)->dwScale = 1; (__pvvwvid_)->dwRate = 25; }

Set the VVWVIDEO::dwRate and VVWVIDEO::dwScale for 25/1 (PAL).

#define VVWVID_SET | ( | __pvvwvid_,
 |  | _bitcount,
 |  | _width,
 |  | _height,
 |  | _pitch_align_1_4_8_16,
 |  | _fcccodec,
 |  | _scale,
 |  | _rate,
 |  | _frames | )

Value:

{       \
        (__pvvwvid_)->biBitCount = _bitcount;   \
        if((long)_height < 0) { (__pvvwvid_)->biHeight = -(long)_height; } else { (__pvvwvid_)->biHeight = (long)_height; }     \
        (__pvvwvid_)->biWidth = _width; \
        (__pvvwvid_)->biCompression = _fcccodec;        \
        VVWVID_PITCHALIGNANY(__pvvwvid_, _pitch_align_1_4_8_16);        \
        VVWVID_SIZEIMAGE((__pvvwvid_)); \
        VVWVID_SUGGESTEDBUFFERSIZE((__pvvwvid_));       \
        (__pvvwvid_)->dwScale = _scale; (__pvvwvid_)->dwRate = _rate;   \
        VVWXXX_SETSAMPLETOLENGTH((__pvvwvid_), _frames);        \
        (__pvvwvid_)->fccHandler = (__pvvwvid_)->biCompression; \
        (__pvvwvid_)->rcFrame.top = 0;  \
        (__pvvwvid_)->rcFrame.bottom = abs((__pvvwvid_)->biHeight);     \
        (__pvvwvid_)->rcFrame.left = 0; \
        (__pvvwvid_)->rcFrame.right = (__pvvwvid_)->biWidth;    \
        }
Basic setup of a VVWVIDEO pointer from width, height, align, codec, scale, rate and length in frames.

#define VVWVID_SETCLR | ( | __pvvwvid_,
 |  | _bitcount,
 |  | _width,
 |  | _height,
 |  | _pitch_align_1_4_8_16,
 |  | _fcccodec,
 |  | _scale,
 |  | _rate,
 |  | _frames | )

Value:

{       \
        VVWVID_SET((__pvvwvid_), _bitcount, _width, _height, _pitch_align_1_4_8_16, _fcccodec, _scale, _rate, _frames); \
        (__pvvwvid_)->biSize = sizeof(BITMAPINFOHEADER);        \
        (__pvvwvid_)->biPlanes = 1;     \
        (__pvvwvid_)->biXPelsPerMeter = 0;      \
        (__pvvwvid_)->biYPelsPerMeter = 0;      \
        (__pvvwvid_)->biClrUsed = 0;    \
        (__pvvwvid_)->biClrImportant = 0;       \
        ZeroMemory((__pvvwvid_)->dwReserved, _VVWXXX_RESERVED_SIZE);    \
        (__pvvwvid_)->fccType = streamtypeVIDEO;        \
        (__pvvwvid_)->dwFlags = 0;      \
        (__pvvwvid_)->dwCaps = 0;       \
        (__pvvwvid_)->wPriority = 0;    \
        (__pvvwvid_)->wLanguage = 0;    \
        (__pvvwvid_)->dwStart = 0;      \
        (__pvvwvid_)->dwInitialFrames = 0;      \
        (__pvvwvid_)->dwQuality = 0xFFFFFFFF;   \
        (__pvvwvid_)->dwSampleSize = 0; \
        (__pvvwvid_)->dwEditCount = 0;  \
        (__pvvwvid_)->dwFormatChangeCount = 0;  \
        ZeroMemory((__pvvwvid_)->szName, _VVWXXX_NAME_SIZE);    \
        (__pvvwvid_)->dwDrFlags = 0;    \
        (__pvvwvid_)->dwResDrastic = 0; \
        }
Clean and do basic setup of a VVWVIDEO pointer from width, height, align, codec, scale, rate and length in frames.

#define VVWVID_SIZEIMAGE ( __pvvwvid_ ) { if(!(__pvvwvid_)->biPitch) VVWVID_PITCHALIGN1((__pvvwvid_)); (__pvvwvid_)->biSizeImage = (__pvvwvid_)->biPitch * abs((__pvvwvid_)->biHeight); }

Set the VVWVIDEO::biSizeImage based on VVWVIDEO::biWidth, VVWVIDEO::biHeight and VVWVIDEO::biBitCount.

#define VVWVID_SUGGESTEDBUFFERSIZE ( __pvvwvid_ ) { if(!(__pvvwvid_)->biPitch) VVWVID_PITCHALIGN1((__pvvwvid_)); (__pvvwvid_)->dwSuggestedBufferSize = (__pvvwvid_)->biPitch * (abs((__pvvwvid_)->biHeight) + (abs((__pvvwvid_)->biHeight) >> 2)); }

Set the VVWVIDEO::dwSuggestedBufferSize based on VVWVIDEO::biWidth, VVWVIDEO::biHeight and VVWVIDEO::biBitCount.

#define VVWXXX_GETSAMPLEFROMLENGTH ( __pvvw_ ) ((__pvvw_)->dwLength / (__pvvw_)->dwScale)

This macro is incorrect.

Todo:
Find and remove

#define VVWXXX_SETSAMPLETOLENGTH | ( | __pvvw_,
 |  | _length | ) | { (__pvvw_)->dwLength = _length * (__pvvw_)->dwScale; }

This macro is incorrect.

Todo:
Find and remove

Typedef Documentation

typedef struct DCLIP * PDCLIP

typedef struct DFRAME * PDFRAME

typedef struct DRASTIC_CHANNEL * pDRASTIC_CHANNEL

typedef struct FRAME_INFO * pFRAME_INFO

typedef struct VVWAUDIO * pVVWAUDIO

typedef struct VVWINFO * pVVWINFO

typedef struct VVWSYSTEM * pVVWSYSTEM

typedef struct VVWVIDEO * pVVWVIDEO

Enumeration Type Documentation

enum vvwInfoMetaTypes

Numeric values for all the metadata information types available in MR and VVW

Enumerator:
vvwiFileName | see VVWINFO::szFileName
vvwiNativeLocator | see VVWINFO::szNativeLocator
vvwiUniversalName | see VVWINFO::szUniversalName
vvwiIP | see VVWINFO::szIP
vvwiSourceLocator | see VVWINFO::szSourceLocator
vvwiChannel | see VVWINFO::szChannel
vvwiChannelName | see VVWINFO::szChannelName
vvwiChannelDescription | see VVWINFO::szChannelDescription
vvwiTitle | see VVWINFO::szTitle
vvwiSubject | see VVWINFO::szSubject
vvwiCategory | see VVWINFO::szCategory
vvwiKeywords | see VVWINFO::szKeywords
vvwiRatings | see VVWINFO::szRatings
vvwiComments | see VVWINFO::szComments
vvwiOwner | see VVWINFO::szOwner
vvwiEditor | see VVWINFO::szEditor
vvwiSupplier | see VVWINFO::szSupplier
vvwiSource | see VVWINFO::szSource
vvwiProject | see VVWINFO::szProject
vvwiStatus | see VVWINFO::szStatus
vvwiAuthor | see VVWINFO::szAuthor
vvwiRevisionNumber | see VVWINFO::szRevisionNumber
vvwiProduced | see VVWINFO::szProduced
vvwiAlbum | see VVWINFO::szAlbum
vvwiArtist | see VVWINFO::szArtist
vvwiComposer | see VVWINFO::szComposer
vvwiCopyright | see VVWINFO::szCopyright
vvwiCreationData | see VVWINFO::szCreationData
vvwiDescription | see VVWINFO::szDescription
vvwiDirector | see VVWINFO::szDirector
vvwiDisclaimer | see VVWINFO::szDisclaimer
vvwiEncodedBy | see VVWINFO::szEncodedBy
vvwiFullName | see VVWINFO::szFullName
vvwiGenre | see VVWINFO::szGenre
vvwiHostComputer | see VVWINFO::szHostComputer
vvwiInformation | see VVWINFO::szInformation
vvwiMake | see VVWINFO::szMake
vvwiModel | see VVWINFO::szModel
vvwiOriginalArtist | see VVWINFO::szOriginalArtist
vvwiOriginalFormat | see VVWINFO::szOriginalFormat
vvwiPerformers | see VVWINFO::szPerformers
vvwiProducer | see VVWINFO::szProducer
vvwiProduct | see VVWINFO::szProduct
vvwiSoftware | see VVWINFO::szSoftware
vvwiSpecialPlaybackRequirements | see VVWINFO::szSpecialPlaybackRequirements
vvwiTrack | see VVWINFO::szTrack
vvwiWarning | see VVWINFO::szWarning
vvwiURLLink | see VVWINFO::szURLLink
vvwiEditData1 | see VVWINFO::szEditData1
vvwiEditData2 | see VVWINFO::szEditData2
vvwiEditData3 | see VVWINFO::szEditData3
vvwiEditData4 | see VVWINFO::szEditData4
vvwiEditData5 | see VVWINFO::szEditData5
vvwiEditData6 | see VVWINFO::szEditData6
vvwiEditData7 | see VVWINFO::szEditData7
vvwiEditData8 | see VVWINFO::szEditData8
vvwiEditData9 | see VVWINFO::szEditData9
vvwiVersionString | see VVWINFO::szVersionString
vvwiManufacturer | see VVWINFO::szManufacturer
vvwiLanguage | see VVWINFO::szLanguage
vvwiFormat | see VVWINFO::szFormat
vvwiInputDevice | see VVWINFO::szInputDevice
vvwiDeviceModelNum | see VVWINFO::szDeviceModelNum
vvwiDeviceSerialNum | see VVWINFO::szDeviceSerialNum
vvwiReel | see VVWINFO::szReel
vvwiShot | see VVWINFO::szShot
vvwiTake | see VVWINFO::szTake
vvwiSlateInfo | see VVWINFO::szSlateInfo
vvwiFrameAttribute | see VVWINFO::szFrameAttribute
vvwiEpisode | see VVWINFO::szEpisode
vvwiScene | see VVWINFO::szScene
vvwiDailyRoll | see VVWINFO::szDailyRoll
vvwiCamRoll | see VVWINFO::szCamRoll
vvwiSoundRoll | see VVWINFO::szSoundRoll
vvwiLabRoll | see VVWINFO::szLabRoll
vvwiKeyNumberPrefix | see VVWINFO::szKeyNumberPrefix
vvwiInkNumberPrefix | see VVWINFO::szInkNumberPrefix
vvwiPictureIcon | see VVWINFO::szPictureIcon
vvwiProxyFile | see VVWINFO::szProxyFile
vvwiEND_OF_STRINGS
vvwiNumericStart
vvwiTimeCode | see VVWINFO::dwTimeCode
vvwiUserBits | see VVWINFO::dwUserBits
vvwiVITCTimeCode | see VVWINFO::dwVITCTimeCode
vvwiVITCUserBits | see VVWINFO::dwVITCUserBits
vvwiVITCLine3 | see VVWINFO::dwVITCLine3
vvwiPosterFrame | see VVWINFO::dwPosterFrame
vvwiAFrame | see VVWINFO::dwAFrame
vvwiAspectRatio | see VVWINFO::dwAspectRatio
vvwiOriginalRate | see VVWINFO::dwOriginalRate
vvwiOriginalScale | see VVWINFO::dwOriginalScale
vvwiConversions | see VVWINFO::dwConversions
vvwiVersionNumber | see VVWINFO::dwVersionNumber
vvwiFileSize | see VVWINFO::dwFileSize
vvwiFileDate | see VVWINFO::dwFileDate
vvwiFileTime | see VVWINFO::dwFileTime
vvwiSequenceNumber | see VVWINFO::dwSequenceNumber
vvwiTotalStreams | see VVWINFO::dwTotalStreams
vvwiTotalLength | see VVWINFO::dwTotalLength
vvwiFilmManufacturerCode | see VVWINFO::dwFilmManufacturerCode
vvwiFilmTypeCode | see VVWINFO::dwFilmTypeCode
vvwiWhitePoint | see VVWINFO::dwWhitePoint
vvwiBlackPoint | see VVWINFO::dwBlackPoint
vvwiBlackGain | see VVWINFO::dwBlackGain
vvwiBreakPoint | see VVWINFO::dwBreakPoint
vvwiGamma1000 | see VVWINFO::dwGamma1000
vvwiTagNumber | see VVWINFO::dwTagNumber
vvwiFlags | see VVWINFO::dwFlags
vvwiTimeCodeType | see VVWINFO::dwTimeCodeType
vvwiLTCTimeCodeType | see VVWINFO::dwLTCTimeCodeType
vvwiVITCTimeCodeType | see VVWINFO::dwVITCTimeCodeType
vvwiEND_OF_DWORD_V2
vvwiVideoWidth | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoHeight | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoPlanes | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoBitCount | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoCompression | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoSizeImage | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoXPelsPerMeter | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoYPelsPeMeter | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoClrUsed | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoClrImportant | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoReserved | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoFccType | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoFccHandler | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoFlags | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoCaps | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoPriority | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoLanguage | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoScale | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoRate | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoStart | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoLength | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoInitialFrames | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoSuggestedBufferSize | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoQuality | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoSampleSize | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoEditCount | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoFormatChangeCount | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoPitch | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoDrFlags | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoFileType | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiVideoResDrastic | INTERNAL: Auto generated for XML output from VVWVIDEO/VVWAUDIO.
vvwiLastElementPlus1 | XML tag name for reserved drastic array of dwords.

Generated on Wed May 17 15:52:34 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Structures

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaCmd Data Structures

Here are the data structures with brief descriptions:
DCLIP
DFRAME
DRASTIC_CHANNEL
FRAME_INFO
MEDIACMD
RECT16
VVWAUDIO
VVWINFO
VVWSYSTEM
VVWVIDEO
Generated on Wed May 17 15:52:35 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: DCLIP Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DCLIP Struct Reference

#include <vvwtypes.h>

Data Fields

DWORD | dwClipIn
Clip In - user defined start of clip, trimmed from dwClipStart.
DWORD | dwClipOut
Clip In - user defined end of clip, trimmed from dwClipStart, max == Clip End (the outpoint is never included).
DWORD | dwClipStart
Clip Start - the actual physical start of a clip (normally 0).
DWORD | dwClipEnd
Clip End - the actual physical end of a clip + 1 (the outpoint is never included).
DWORD | dwClipAux
Clip Auxillary - used to denote picon frame, internal key frame, or other dependant on clip type.
DWORD | dwClipID
A Numeric Clip or Reel ID - Normally a reel id, but could also be a take or other info.
DWORD | dwVidChan
Available video channels bit array.
DWORD | dwAudChan
Available audio channels bit array.
DWORD | dwInfChan
Available information channels bit array.
char * | szClipName
The Clip Name - For louth/odetics compatibility, this should be 8 characters + 0 terminator long.
char * | szName
The full name - Usually the file name of the media on disk.
char * | szComment
User comment connected to this file. Free form, may contain other key information.
char * | szReel
Reel ID or string denoting source tape or media.

Detailed Description

This is the basis of all our clip handling. If is used in tcspace, clipspace, clipctrl, edlxlat and most other clip handling areas. It includes info on the clip, trim points, its position within a container, channels available, name, comment and reel.

Field Documentation

DWORD DCLIP::dwAudChan

Available audio channels bit array.

DWORD DCLIP::dwClipAux

Clip Auxillary - used to denote picon frame, internal key frame, or other dependant on clip type.

DWORD DCLIP::dwClipEnd

Clip End - the actual physical end of a clip + 1 (the outpoint is never included).

DWORD DCLIP::dwClipID

A Numeric Clip or Reel ID - Normally a reel id, but could also be a take or other info.

DWORD DCLIP::dwClipIn

Clip In - user defined start of clip, trimmed from dwClipStart.

DWORD DCLIP::dwClipOut

Clip In - user defined end of clip, trimmed from dwClipStart, max == Clip End (the outpoint is never included).

DWORD DCLIP::dwClipStart

Clip Start - the actual physical start of a clip (normally 0).

DWORD DCLIP::dwInfChan

Available information channels bit array.

DWORD DCLIP::dwVidChan

Available video channels bit array.

char* DCLIP::szClipName

The Clip Name - For louth/odetics compatibility, this should be 8 characters + 0 terminator long.

char* DCLIP::szComment

User comment connected to this file. Free form, may contain other key information.

char* DCLIP::szName

The full name - Usually the file name of the media on disk.

char* DCLIP::szReel

Reel ID or string denoting source tape or media.

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: DFRAME Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DFRAME Struct Reference

#include <vvwtypes.h>

Data Fields

void * | pPrev
Copy From D_LNODE - DO NOT MODIFY.
void * | pNext
Copy From D_LNODE - DO NOT MODIFY.
void * | pList
Copy From D_LNODE - DO NOT MODIFY.
DWORD | dwSize
size of this structure (+ extra data at end if required)
DWORD | dwType
DWORD | dwReps
Number of repeats of this frame. Uses to create slow motion effects, or save memory on still images.
FRAME_INFO fi
The external timing info for this frame (LTC/VITC/CTL timecode/userbits - See FRAME_INFO).
DWORD | dwRepIndex
Internal - Count down for rep usage in slow motion (AvHAL exclusive).
DWORD | dwSpeed
The VVW Speed (65520 based) at which this frame is supposed to play. Always forward?? Should be long probably.
DWORD | dwExpireMS
Internal - The expected time that this frame may be safely released and deallocated.
DWORD | dwPresentationMS
Used to determine the time to display the frame to the viewer, also dwTimeCaptured in AvHal::VfW.
LPBYTE | lpData
DWORD | dwBufferLength
DWORD | dwBytesUsed
DWORD | dwUser
User var for VfW/Wave driver - internal - do not use.
DWORD | dwFlags
DWORD | dwReserved [4]
Internal - Do not use, hardware specific.
WORD | resdata
Filler for alignment or extended user data.

Detailed Description

The DFRAME - A container/marker for a frame of information in memory

This type holds the internal timing, memory allocation, frame flags and dlist elements for one frame of video, audio or information being processed by VVW or MEDIAREACTOR. It should always be allocated by the PhysMem.DLL for maximum speed of memory manipulation. It is used just about everywhere and should not be changed without extremely careful consideration.

Field Documentation

DWORD DFRAME::dwBufferLength

The maximum length of the buffer pointed to by DFRAME::lpData This should set by PhysHeap.dll and left alone by the user. If more memory is required, allocate a new DFRAME and copy the current data into it. Should always be aligned to disk sector size or 4096 (whichever is greater).

DWORD DFRAME::dwBytesUsed

The current number of valid bytes pointed to by DFRAME::lpData. Must be less than DFRAME::dwBufferLength. User adjustable as nec.

DWORD DFRAME::dwExpireMS

Internal - The expected time that this frame may be safely released and deallocated.

DWORD DFRAME::dwFlags

Flags including external flags _PDFRAMEFLAGS_CLIPSTILL, _PDFRAMEFLAGS_CLIPSTART, _PDFRAMEFLAGS_CLIPEND, _PDFRAMEFLAGS_FIRSTFRAME, _PDFRAMEFLAGS_LASTFRAME and AvHAL internal flags (stripped in AvHAL) DTWHDR_DONE, DTWHDR_PREPARED, DTWHDR_ENDLOOP, DTWHDR_INQUEUE and DTVHDR_DONE, DTVHDR_PREPARED, DTVHDR_INQUEUE, DTVHDR_KEYFRAME

DWORD DFRAME::dwPresentationMS

Used to determine the time to display the frame to the viewer, also dwTimeCaptured in AvHal::VfW.

DWORD DFRAME::dwRepIndex

Internal - Count down for rep usage in slow motion (AvHAL exclusive).

DWORD DFRAME::dwReps

Number of repeats of this frame. Uses to create slow motion effects, or save memory on still images.

DWORD DFRAME::dwReserved[4]

Internal - Do not use, hardware specific.

DWORD DFRAME::dwSize

size of this structure (+ extra data at end if required)

DWORD DFRAME::dwSpeed

The VVW Speed (65520 based) at which this frame is supposed to play. Always forward?? Should be long probably.

DWORD DFRAME::dwType

Any combination of the DFRAME_ flags including DFRAME_TYPE_RECORD, DFRAME_TYPE_PLAY, DFRAME_TYPE_AUDIO, DFRAME_TYPE_VIDEO, DFRAME_PROGRESSIVE, DFRAME_FIELD_INVERT, DFRAME_TIME_INVERT, DFRAME_LARGE_AUDIO, DFRAME_NEW_FORMAT, DFRAME_TYPE_KEYFRAME, DFRAME_TYPE_KEYFRAME_I, DFRAME_TYPE_KEYFRAME_P, DFRAME_TYPE_KEYFRAME_B, DFRAME_SKIP_FRAME

DWORD DFRAME::dwUser

User var for VfW/Wave driver - internal - do not use.

FRAME_INFO DFRAME::fi

The external timing info for this frame (LTC/VITC/CTL timecode/userbits - See FRAME_INFO).

LPBYTE DFRAME::lpData

Start - taken from VIDEOHDR, WAVEHEADER This is actually a WAVEHDR - VideoHdr includes a dwTimeCaptured atfter the dwBytes used member! Leave it alone as we use the WAVEHDR directly with win32 wave... functions

void* DFRAME::pList

Copy From D_LNODE - DO NOT MODIFY.

void* DFRAME::pNext

Copy From D_LNODE - DO NOT MODIFY.

void* DFRAME::pPrev

Copy From D_LNODE - DO NOT MODIFY.

WORD DFRAME::resdata

Filler for alignment or extended user data.

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: DRASTIC_CHANNEL Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

DRASTIC_CHANNEL Struct Reference

#include <vvwtypes.h>

Data Fields

DWORD | dwLastUpdate
Last update time in ms per the local performance close (vsyncGetCurMs()).
FRAME_INFO fi
The current ctl/ltc/vitc frame/userbits and other per frame data.
MEDIACMD mCmd
The current state of the channel as a MEDIACMD structure.
DWORD * | pdwFrame
This will always point at one of the frame counts in the frame_info structure above.
void * | pOwnerHandle
A handle to used by the owner of this struct (usually its base class address).
DWORD | dwChannelID
The channel ID (numeric 0-255) of this structure.

Detailed Description

A channel memory area - This is the basis of the DSync system It is used to provide inter and intra channel information on current state in a timely fashion. Most importantly, it is used for the ctTransfer command to move media to and from external vtrs. This allows the transfering channel to get information on the other channel as quickly as possible. It was designed to operate effeciently when both channels are running on the same machine, but also to provide a single interface when a network or other transport is between the two channels.

Field Documentation

DWORD DRASTIC_CHANNEL::dwChannelID

The channel ID (numeric 0-255) of this structure.

DWORD DRASTIC_CHANNEL::dwLastUpdate

Last update time in ms per the local performance close (vsyncGetCurMs()).

FRAME_INFO DRASTIC_CHANNEL::fi

The current ctl/ltc/vitc frame/userbits and other per frame data.

MEDIACMD DRASTIC_CHANNEL::mCmd

The current state of the channel as a MEDIACMD structure.

DWORD* DRASTIC_CHANNEL::pdwFrame

This will always point at one of the frame counts in the frame_info structure above.

void* DRASTIC_CHANNEL::pOwnerHandle

A handle to used by the owner of this struct (usually its base class address).

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: FRAME_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

FRAME_INFO Struct Reference

#include <vvwtypes.h>

Data Fields

DWORD | dwFrame
Current time code, Control (CTL), our internal time code.
DWORD | dwLtcFrame
Current LTC time code from original tape or internal generation.
DWORD | dwLtcUb
Current LTC user Bits from original tape or internal generation.
DWORD | dwVitcFrame
Current VITC time code from original tape or internal generation.
DWORD | dwVitcUb
Current VITC user bits from original tape or internal generation.
DWORD | dwVitcAux
DWORD | dwCCData

Detailed Description

A Frame Info Packet - Part of the DFrame structure maintained with each memory frame passed through the MR or VVW system DFrame maintains the memory and internal timing info for the system, whereas frame_info maintains the external meta data from the original source.

Field Documentation

DWORD FRAME_INFO::dwCCData

Captured close caption data from line 21 or if DFRAME_TYPE_FI_PTR_DATA then this contains the size of the data area pointed to by dwVitcAux.

DWORD FRAME_INFO::dwFrame

Current time code, Control (CTL), our internal time code.

DWORD FRAME_INFO::dwLtcFrame

Current LTC time code from original tape or internal generation.

DWORD FRAME_INFO::dwLtcUb

Current LTC user Bits from original tape or internal generation.

DWORD FRAME_INFO::dwVitcAux

Current VITC aux for extra vitc time code (3 line) or other info, or if DFRAME_TYPE_FI_PTR_DATA is dwType of PDFRAME is set, then this is a pointer to the extended data area. This are should exist at the end of the DFRAME structure.

DWORD FRAME_INFO::dwVitcFrame

Current VITC time code from original tape or internal generation.

DWORD FRAME_INFO::dwVitcUb

Current VITC user bits from original tape or internal generation.

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: MEDIACMD Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MEDIACMD Struct Reference

#include <mediacmd.h>

Data Fields

void * | pPrev
INTERNAL dlist.dll Link List Pointers - do not use.
void * | pNext
INTERNAL dlist.dll Link List Pointers - do not use.
void * | pList
INTERNAL dlist.dll Link List Pointers - do not use.
DWORD | dwCmdID
DWORD | dwStructSize
DWORD | dwChannel
enum cmdType | ctCmd
DWORD | cfFlags
LONG | lSpeed
DWORD | dwVideoChannels
DWORD | dwAudioChannels
DWORD | dwInfoChannels
DWORD | dwCmdAlt
DWORD | dwPosition
DWORD | dwStart
DWORD | dwEnd
BYTE | arbID [(260+8)+2+2]

Field Documentation

BYTE MEDIACMD::arbID[(260+8)+2+2]

Free form memory area mostly used for string and clip handling. Valid if the cfFlags member includes cmdFlags::cfUseClipID Basic Clip Name: first 8 BYTES alpha number, may include spaces, terminated by 0
Two Clip Names: 'Basic Clip Name' followed immeadiately by another 'Basic Clip Name' Clip+File Name: 'Basic Clip Name' followed by a null terminated file/path name. String: Null terminated ANSI string.

DWORD MEDIACMD::cfFlags

The cfFlags member contains flags that modify the operation of the other structure members. These flags are of the type cmdFlags. The flags normally specify which other members are to be used for the command as well as modifiers for delaying or otherwise augmented commands. Basic flags include: cmdFlags::cfDeferred, cmdFlags::cfUseSpeed, cmdFlags::cfUsePosition, cmdFlags::cfUseStart, cmdFlags::cfUseEnd, cmdFlags::cfUsePositionOffset, cmdFlags::cfUseClipID.

enum cmdType MEDIACMD::ctCmd

The ctCmd member contains the basic or overall command. It is of the type cmdType. It includes transport and setup commands that may be immediate or delayed depending on the rest of the structure. Basic commands include: cmdType::ctPlay, cmdType::ctStop, cmdType::ctPause (or seek), cmdType::ctRecord, cmdType::ctGetState, cmdType::ctGetValue and cmdType::ctSetValue.

DWORD MEDIACMD::dwAudioChannels

AUDIO Bit array of channels where
1 = first channel
2 = second channel
4 = third channel
8 = fourth channel
Also, cmdAudChan enum may be used

DWORD MEDIACMD::dwChannel

The target channel. For direct connect channels (eg. in the same machine) this member is ignored. For serial/network/piped channels, this allows a single transport to access multiple channels. It is also used for kernel<->user mode commands for DComCtrl.sys and vvwCtl.dll as well as vvwNet.dll.

DWORD MEDIACMD::dwCmdAlt

This member may have many meaning depending on the rest of the MEDIACMD structure.
if ctCmd is cmdType::ctGetValue, cmdType::ctSetValue or cmdType::ctValueSupported then it contains the cmdGetSetValue to use if ctCmd is cmdType::ctTransfer it contains the source channel for the transfer (the command is always set to the target) if cfFlags includes cmdFlags::cfUseCmdAlt and cmdFlags::cfTimeMs is contains a millisecond version of the performance clock if ctCmd is cmdType::ctRecord then it may be used as a millisecond offset to start of record if ctCmd is cmdType::ctPlay then it may be used as a millisecond offset to start of playback

DWORD MEDIACMD::dwCmdID

The command identifier is used to confirm that the command is properly formatted and of a version that the receiver understands. This member should always be set to MEDIACMD_CURRENT

DWORD MEDIACMD::dwEnd

For most commands, this will be the ending frame counter position for the command.
Check of cmdFlags::cfUseEnd or cmdFlags::cfUseEndOffset (becomes long against current position) to make sure this member is valid.
For cmdType::ctGetValue, cmdType::ctSetValue or cmdType::ctValueSupported this is secondary set and return member.

DWORD MEDIACMD::dwInfoChannels

INFO Bit array if channels. See cmdinf for possible channels including cmdinf::Ltc, cmdinf::Vitc, cmdinf::Copyright, etc.

DWORD MEDIACMD::dwPosition

For most commands, this will be the current or target frame counter position for the command.
Check of cmdFlags::cfUsePosition or cmdFlags::cfUsePositionOffset (becomes long against current position) to make sure this member is valid.
For cmdType::ctGetValue, cmdType::ctSetValue or cmdType::ctValueSupported this is primary set and return member.

DWORD MEDIACMD::dwStart

For most commands, this will be the starting frame counter position for the command.
Check of cmdFlags::cfUseStart or cmdFlags::cfUseStartOffset (becomes long against current position) to make sure this member is valid.
For cmdType::ctGetValue, cmdType::ctSetValue or cmdType::ctValueSupported this is secondary set and return member.

DWORD MEDIACMD::dwStructSize

This member contains the entire size of the structure being sent. Certain commands may not require all fields to be completely understood. Most commands will send the bulk of the structure and remove only unused parts of arbID[], though this should not be counted on. It may be assumed that all commands will include the pPrev, pNext, pList, dwCmdID, dwStructSize, dwChannel, ctCmd, and cfFlags members with every command so dwStructSize must be at least 32 bytes in length.

DWORD MEDIACMD::dwVideoChannels

VIDEO Bit array of channels where
1 = first channel
2 = second channel
4 = third channel
8 = fourth channel
Also, cmdVidChan enum may be used

LONG MEDIACMD::lSpeed

This member controls the speed of a command. Normally it is used with cmdType::ctPlay and required cmdFlags::cfUseSpeed to be set in the cfFlags member to be used. The defines SPD_FWD_PLAY, SPD_PAUSE, SPD_REV_PLAY, SPD_FWD_MAX, SPD_REV_MAX can be used, or any other valid speed. This table outlines the basic linear speed changes.

    SPD_REV_MAX     SPD_REV_PLAY    SPD_PAUSE       SPD_FWD_PLAY    SPD_FWD_MAX
    -5896800        -65520          0               65520           5896800
    -90x            -1x             0               1x              90x
    -9000%          -100%           0               100%            90000%
    -90.0           -1.0            0               1.0             90.0

    Some Normal Speeds (for reverse, set to minus)
    10 times play   10.0    1000%   655200
    5 times play    5.0     500%    327600
    2 times Play    2.0     200%    131040
    Play Normal     1.0     100%    65520
    Two Third       0.66    66%     43680
    Half Play       0.5     50%     32760
    One Third       0.33    33%     21840

    note:  Speed table is linear (log like serial control must be converted)

void* MEDIACMD::pList

INTERNAL dlist.dll Link List Pointers - do not use.

void* MEDIACMD::pNext

INTERNAL dlist.dll Link List Pointers - do not use.

void* MEDIACMD::pPrev

INTERNAL dlist.dll Link List Pointers - do not use.

The documentation for this struct was generated from the following file:
  • mediacmd.h


MediaCmd: RECT16 Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

RECT16 Struct Reference

#include <vvwtypes.h>

Data Fields

SHORT | left
left side of rect - see microsoft RECT struct
SHORT | top
top of rect - see microsoft RECT struct
SHORT | right
right side of rect - see microsoft RECT struct
SHORT | bottom
bottom of rect - see microsoft RECT struct

Detailed Description

Those stupid idiots at Microsoft forgot to change this structure when making the VfW headers for Win32. The result is that the AVIStreamHeader is correct in 16-bit Windows, but the 32-bit headers define RECT as LONGs instead of SHORTs. This creates invalid AVI files!!!!

Field Documentation

SHORT RECT16::bottom

bottom of rect - see microsoft RECT struct

SHORT RECT16::left

left side of rect - see microsoft RECT struct

SHORT RECT16::right

right side of rect - see microsoft RECT struct

SHORT RECT16::top

top of rect - see microsoft RECT struct

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: VVWAUDIO Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VVWAUDIO Struct Reference

#include <vvwtypes.h>

Data Fields

WORD | wFormatTag
Format of audio data, uncompressed == DTWAVE_FORMAT_PCM (windows WAVE_FORMAT_PCM) == 1.
WORD | nChannels
Number of channels in this stream. Usually 1 or 2.
DWORD | nSamplesPerSec
Number of samples per second. eg. 44100, 22050, 48000 etc.
DWORD | nAvgBytesPerSec
Average Bytes Per Second (see also VVWAUDIO::dwRate) == nBlockAlign * nSamplesPerSec.
WORD | nBlockAlign
Size of a sample group. == to nChannels * (wBitsPerSample / 8) eg. Stereo 16bit = 4, Mono 16bit = 2, Stereo 8Bit = 2.
WORD | wBitsPerSample
Number of bits per sample, normally 8 or 16.
WORD | cbSize
Size of the dwReserved area used. For PCM this will be zero. For other compressors, it may be anything < 256 DWORDs.
DWORD | dwReserved [256]
Extra info storage for audio codecs.
DWORD | fccType
For VVWAUDIO structure this is always streamtypeAUDIO == 'auds'.
DWORD | fccHandler
Codec type, see fccDef.h Normally the same as VVWAUDIO::wFormatTag but not always.
DWORD | dwFlags
DWORD | dwCaps
Not sure. See VVWSYSTEM::dwCaps for possible interp if something is set. MS Doc: currently unused.
WORD | wPriority
Priority of stream (<-MSDoc in relation to other streams in the file I suppose).
WORD | wLanguage
Language of stream (<-MSDoc but no language id defines).
DWORD | dwScale
For PCM == to VVWAUDIO::nBlockAlign. See VVSYSTEM::dwScale for more info and table example.
DWORD | dwRate
For PCM == to VVWAUDIO::nAvgBytesPerSec. See VVSYSTEM::dwRate for more info and table example.
DWORD | dwStart
DWORD | dwLength
DWORD | dwInitialFrames
DWORD | dwSuggestedBufferSize
DWORD | dwQuality
DWORD | dwSampleSize
RECT | rcFrame
DWORD | dwEditCount
Number of times the stream has been edited. The stream handler maintains this count.
DWORD | dwFormatChangeCount
Number of times the stream format has changed. The stream handler maintains this count.
char | szName [64]
Null-terminated string containing a description of the stream.
LONG | biUnused
No used currenly.
DWORD | dwDrFlags
DWORD | dwFileType
Source File Type.
DWORD | dwResDrastic
Reserved, init to zero and leave alone.

Detailed Description

The audio structure is a combination of a WAVEFORMATEX and a AVISTREAMINFO structure. The top half should be treated as a WAVEFORMATEX and the bottom as a related but independant structure. These are as they appear in an AVI file and are manipulated to fill other file types like OMF and MOV.

Field Documentation

LONG VVWAUDIO::biUnused

No used currenly.

WORD VVWAUDIO::cbSize

Size of the dwReserved area used. For PCM this will be zero. For other compressors, it may be anything < 256 DWORDs.

DWORD VVWAUDIO::dwCaps

Not sure. See VVWSYSTEM::dwCaps for possible interp if something is set. MS Doc: currently unused.

DWORD VVWAUDIO::dwDrFlags

Our internal flags including: DRFLAGS_HAS_KEYFRAMES, DRFLAGS_FCC_USE_INTERN, DRFLAGS_FCC_USE_QT, DRFLAGS_FCC_USE_ICM, DRFLAGS_CODECPRIVATEDATA_AVI, DRFLAGS_CODECPRIVATEDATA_MOV, DRFLAGS_CODECPRIVATEDATA_OMF, DTVVW_PREVIEW

DWORD VVWAUDIO::dwEditCount

Number of times the stream has been edited. The stream handler maintains this count.

DWORD VVWAUDIO::dwFileType

Source File Type.

DWORD VVWAUDIO::dwFlags

DWORD VVWAUDIO::dwFormatChangeCount

Number of times the stream format has changed. The stream handler maintains this count.

DWORD VVWAUDIO::dwInitialFrames

Amount of audio in the file before video commences. For offset files, typically 0.75 sec converted to units per VVWAUDIO::dwRate/VVWAUDIOdwScale. For high end files, always zero as audio and video are sent without scew (except premiere, which uses 'rec ' chunks and audio skew)

DWORD VVWAUDIO::dwLength

Length of the video stream in units per VVWAUDIO::dwRate/VVWAUDIOdwScale (for video - frames)

DWORD VVWAUDIO::dwQuality

Quality used by the compressor. Between 0 and 10,000 or -1 if default quality. For some compressors, the -1 can also mean the quality info is encoded into the frame or in the dwReserved or other private data area.

DWORD VVWAUDIO::dwRate

For PCM == to VVWAUDIO::nAvgBytesPerSec. See VVSYSTEM::dwRate for more info and table example.

DWORD VVWAUDIO::dwResDrastic

Reserved, init to zero and leave alone.

DWORD VVWAUDIO::dwReserved[256]

Extra info storage for audio codecs.

DWORD VVWAUDIO::dwSampleSize

Size, in bytes, of a single data sample. If the value of this member is zero, the samples can vary in size and each data sample (such as a video frame) must be in a separate chunk. A nonzero value indicates that multiple samples of data can be grouped into a single chunk within the file. For video streams, this number is typically zero, although it can be nonzero if all video frames are the same size. For audio streams, this number should be the same as the nBlockAlign member of the WAVEFORMAT or WAVEFORMATEX structure describing the audio.

DWORD VVWAUDIO::dwScale

For PCM == to VVWAUDIO::nBlockAlign. See VVSYSTEM::dwScale for more info and table example.

DWORD VVWAUDIO::dwStart

Delay in units per VVWAUDIO::dwRate/VVWAUDIOdwScale (for video - frames) for this stream to start in the playback of the file. NOTE AVI v1.0 and simple avi readers will choke or play incorrectly if this is not 0, so be careful.

DWORD VVWAUDIO::dwSuggestedBufferSize

Recommended buffer size based on the largest single chunk in the file. Set by writer, so often incorrect or 0.

DWORD VVWAUDIO::fccHandler

Codec type, see fccDef.h Normally the same as VVWAUDIO::wFormatTag but not always.

DWORD VVWAUDIO::fccType

For VVWAUDIO structure this is always streamtypeAUDIO == 'auds'.

DWORD VVWAUDIO::nAvgBytesPerSec

Average Bytes Per Second (see also VVWAUDIO::dwRate) == nBlockAlign * nSamplesPerSec.

WORD VVWAUDIO::nBlockAlign

Size of a sample group. == to nChannels * (wBitsPerSample / 8) eg. Stereo 16bit = 4, Mono 16bit = 2, Stereo 8Bit = 2.

WORD VVWAUDIO::nChannels

Number of channels in this stream. Usually 1 or 2.

DWORD VVWAUDIO::nSamplesPerSec

Number of samples per second. eg. 44100, 22050, 48000 etc.

RECT VVWAUDIO::rcFrame

NOT USED BY VVWAUDIO. Dimensions of the video destination rectangle. The values represent the coordinates of upper left corner, the height, and the width of the rectangle.

char VVWAUDIO::szName[64]

Null-terminated string containing a description of the stream.

WORD VVWAUDIO::wBitsPerSample

Number of bits per sample, normally 8 or 16.

WORD VVWAUDIO::wFormatTag

Format of audio data, uncompressed == DTWAVE_FORMAT_PCM (windows WAVE_FORMAT_PCM) == 1.

WORD VVWAUDIO::wLanguage

Language of stream (<-MSDoc but no language id defines).

WORD VVWAUDIO::wPriority

Priority of stream (<-MSDoc in relation to other streams in the file I suppose).

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: VVWINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VVWINFO Struct Reference

#include <vvwtypes.h>

Data Fields

char * | szFileName
char * | szNativeLocator
char * | szUniversalName
char * | szIP
char * | szSourceLocator
char * | szChannel
char * | szChannelName
char * | szChannelDescription
char * | szTitle
char * | szSubject
char * | szCategory
char * | szKeywords
char * | szRatings
char * | szComments
char * | szDoNotUse
char * | szOwner
char * | szEditor
char * | szSupplier
char * | szSource
char * | szProject
char * | szStatus
char * | szAuthor
char * | szRevisionNumber
char * | szProduced
char * | szAlbum
char * | szArtist
char * | szComposer
char * | szCopyright
char * | szCreationData
char * | szDescription
char * | szDirector
char * | szDisclaimer
char * | szEncodedBy
char * | szFullName
char * | szGenre
char * | szHostComputer
char * | szInformation
char * | szMake
char * | szModel
char * | szOriginalArtist
char * | szOriginalFormat
char * | szPerformers
char * | szProducer
char * | szProduct
char * | szSoftware
char * | szSpecialPlaybackRequirements
char * | szTrack
char * | szWarning
char * | szURLLink
char * | szEditData1
char * | szEditData2
char * | szEditData3
char * | szEditData4
char * | szEditData5
char * | szEditData6
char * | szEditData7
char * | szEditData8
char * | szEditData9
char * | szVersionString
char * | szManufacturer
char * | szLanguage
char * | szFormat
char * | szInputDevice
char * | szDeviceModelNum
char * | szDeviceSerialNum
char * | szReel
char * | szShot
char * | szTake
char * | szSlateInfo
char * | szFrameAttribute
char * | szEpisode
char * | szScene
char * | szDailyRoll
char * | szCamRoll
char * | szSoundRoll
char * | szLabRoll
char * | szKeyNumberPrefix
char * | szInkNumberPrefix
char * | szPictureIcon
char * | szProxyFile
char * | szNU_81
char * | szNU_82
char * | szNU_83
char * | szNU_84
char * | szNU_85
char * | szNU_86
char * | szNU_87
char * | szNU_88
char * | szNU_89
char * | szNU_90
char * | szNU_91
char * | szNU_92
char * | szNU_93
char * | szNU_94
char * | szNU_95
char * | szNU_96
char * | szNU_97
char * | szNU_98
char * | szNU_99
DWORD | dwReservedMustBe0
DWORD | dwTimeCode
DWORD | dwUserBits
DWORD | dwVITCTimeCode
DWORD | dwVITCUserBits
DWORD | dwVITCLine3
DWORD | dwPosterFrame
DWORD | dwAFrame
DWORD | dwAspectRatio
DWORD | dwOriginalRate
DWORD | dwOriginalScale
DWORD | dwConversions
DWORD | dwVersionNumber
DWORD | dwFileSize
DWORD | dwFileDate
DWORD | dwFileTime
DWORD | dwSequenceNumber
DWORD | dwTotalStreams
DWORD | dwTotalLength
DWORD | dwFilmManufacturerCode
DWORD | dwFilmTypeCode
DWORD | dwWhitePoint
DWORD | dwBlackPoint
DWORD | dwBlackGain
DWORD | dwBreakPoint
DWORD | dwGamma1000
DWORD | dwTagNumber
DWORD | dwFlags
DWORD | dwTimeCodeType
DWORD | dwLTCTimeCodeType
DWORD | dwVITCTimeCodeType
DWORD | dwNU_31
DWORD | dwNU_32
DWORD | dwNU_33
DWORD | dwNU_34
DWORD | dwNU_35
DWORD | dwNU_36
DWORD | dwNU_37
DWORD | dwNU_38
DWORD | dwNU_39
DWORD | dwNU_40
DWORD | dwNU_41
DWORD | dwNU_42
DWORD | dwNU_43
DWORD | dwNU_44
DWORD | dwNU_45
DWORD | dwNU_46
DWORD | dwNU_47
DWORD | dwNU_48
DWORD | dwNU_49
DWORD | dwFileType
Source File Type.
DWORD | dwResDrastic
Set to 0 on allocate and leave alone.

Detailed Description

The info structure is used to hold the metadata for one clip It is a combination of a custom info identifiers from all the file types we currently support. It is always written as a side bar xml file, and also insert into/read from the actual file whenever possible. NOTE: There are other fields included in the xml that are not contained here. There are contained in VVWSYSTEM, VVWVIDEO or VVWAUDIO.

Meta Data Rules (needs updating)

  • --- LOCATOR STRINGS
  • File Name (base name+ext)
  • Native Locator
  • Universal Name Convention Locator
  • IP
  • Source Locator (Universal)
  • --- Inferred
  • Channel
  • Channel Length
  • Channel Name
  • Channel Description
  • Channel Poster Frame
  • --- STRINGS
  • Title W (AAF:Name) (TIF:DocumentName)
  • Subject W
  • Category W
  • Keywords W
  • Rating AVI
  • Comments W QT
  • Owner AVI
  • Editor AVI
  • Supplier AVI
  • Source W
  • Project AVI
  • Status
    AVI Other, Final, Proof, Review, Edit, In Progress, Draft, Preliminary, New Normal
  • Author W QT
  • Revision Number W
  • Produced AVI
  • Album QT
  • Artist QT TIF
  • Composer QT
  • Copyright QT TIF
  • Creation Data QT
  • Description QT AAF (TIF:ImageDescription)
  • Director QT
  • Disclaimer QT
  • Encoded By QT
  • Full Name QT
  • Genre QT
  • Host Computer QT TIF
  • Information QT
  • Make QT TIF
  • Model QT TIF
  • Original Artist QT
  • Original Format QT
  • Original Source QT
  • Performers QT
  • Producer QT
  • Product QT
  • Software QT TIF
  • Special Playback Requirements QT
  • Track QT
  • Warning QT
  • URL Link QT
  • Edit Data 1..9 QT
  • Version String AAF
  • Manufacturer AAF
  • Language DublinCore.org
  • Format DublinCore.org
  • Numeric Entries
  • Timecode (LTC)
  • UserBits (LTC)
  • VITC Timecode
  • VITC Userbits
  • VITC Line 3
  • Poster Frame
  • 'A' Frame
  • Aspect Ratio
  • OrginalScale
  • OrginalRate
  • Conversions
  • Version Number AAF
  • File Size (64 Bits)
  • File Date TIF
  • File Time TIF
  • Sequence Number AVI

Field Documentation

DWORD VVWINFO::dwAFrame

A-Frame if 2/3 else 0
XML tag <A-Frame>

DWORD VVWINFO::dwAspectRatio

Upperword/LowerWord (e.g. 0x00040003 = 4/3)
XML tag <AspectRatio>

DWORD VVWINFO::dwBlackGain

Log capture Black gain
XML tag <BlackGain>

DWORD VVWINFO::dwBlackPoint

Log captured Black point (also CCIR black for 8/10 YCbCr)
XML tag <BlackPoint>

DWORD VVWINFO::dwBreakPoint

Log captured break point
XML tag <BreakPoint>

DWORD VVWINFO::dwConversions

Number of conversion
XML tag <TotalConversions>

DWORD VVWINFO::dwFileDate

Date stamp of file
XML tag <FileDate>

DWORD VVWINFO::dwFileSize

Size of file
XML tag <FileSize>

DWORD VVWINFO::dwFileTime

Time of file
XML tag <FileTime>

DWORD VVWINFO::dwFileType

Source File Type.

DWORD VVWINFO::dwFilmManufacturerCode

Film manufacturer's code
XML tag <FileManufacturerCode>

DWORD VVWINFO::dwFilmTypeCode

Film type code
XML tag <FileTypeCode>

DWORD VVWINFO::dwFlags

TBD

DWORD VVWINFO::dwGamma1000

Gamma * 1000 (e.g. 1.7 == 17000)
XML tag <Gamma1000>

DWORD VVWINFO::dwLTCTimeCodeType

LTC Time code type for the counter/ctl NDF/30, DF/29, PAL/24, FILM/24, NTSCFILM/23

DWORD VVWINFO::dwNU_31

TBD

DWORD VVWINFO::dwNU_32

TBD

DWORD VVWINFO::dwNU_33

TBD

DWORD VVWINFO::dwNU_34

TBD

DWORD VVWINFO::dwNU_35

TBD

DWORD VVWINFO::dwNU_36

TBD

DWORD VVWINFO::dwNU_37

TBD

DWORD VVWINFO::dwNU_38

TBD

DWORD VVWINFO::dwNU_39

TBD

DWORD VVWINFO::dwNU_40

TBD

DWORD VVWINFO::dwNU_41

TBD

DWORD VVWINFO::dwNU_42

TBD

DWORD VVWINFO::dwNU_43

TBD

DWORD VVWINFO::dwNU_44

TBD

DWORD VVWINFO::dwNU_45

TBD

DWORD VVWINFO::dwNU_46

TBD

DWORD VVWINFO::dwNU_47

TBD

DWORD VVWINFO::dwNU_48

TBD

DWORD VVWINFO::dwNU_49

TBD

DWORD VVWINFO::dwOriginalRate

Original file rate
XML tag <OriginalFileRate>

DWORD VVWINFO::dwOriginalScale

Original file scale
XML tag <OriginalFileScale>

DWORD VVWINFO::dwPosterFrame

Poster (picon) frame number
XML tag <PosterFrame>

DWORD VVWINFO::dwResDrastic

Set to 0 on allocate and leave alone.

DWORD VVWINFO::dwReservedMustBe0

Special reserved place holder for end of strings

DWORD VVWINFO::dwSequenceNumber

Sequnce number
XML tag <SequenceNumber>

DWORD VVWINFO::dwTagNumber

TBD

DWORD VVWINFO::dwTimeCode

Starting time code (LTC)
XML tag <TimeCode>

DWORD VVWINFO::dwTimeCodeType

Time code type for the counter/ctl NDF/30, DF/29, PAL/24, FILM/24, NTSCFILM/23

DWORD VVWINFO::dwTotalLength

Total frames of longest stream in file
XML tag <TotalLength>

DWORD VVWINFO::dwTotalStreams

Total number of streams in file
XML tag <TotalStreams>

DWORD VVWINFO::dwUserBits

Starting user bits (LTC)
XML tag <UserBits>

DWORD VVWINFO::dwVersionNumber

Version number
XML tag <VersionNumber>

DWORD VVWINFO::dwVITCLine3

Extra VITC data
XML tag <VITCExtraData>

DWORD VVWINFO::dwVITCTimeCode

Starting VITC time code
XML tag <VITCTimeCode>

DWORD VVWINFO::dwVITCTimeCodeType

VITC Time code type for the counter/ctl NDF/30, DF/29, PAL/24, FILM/24, NTSCFILM/23

DWORD VVWINFO::dwVITCUserBits

Starting VITC user bits
XML tag <VITCUserBits>

DWORD VVWINFO::dwWhitePoint

Log captured White point (also CCIR white for 8/10 YCbCr)
XML tag <WhitePoint>

char* VVWINFO::szAlbum

Album Name
XML tag <Album>

char* VVWINFO::szArtist

Artist Name
XML tag <Artist>

char* VVWINFO::szAuthor

REG Default Author's name
XML tag <Author>

char* VVWINFO::szCamRoll

RP-215 camera roll namd/id

char* VVWINFO::szCategory

Category of media (AVI/Mov Format)
XML tag <Category>

char* VVWINFO::szChannel

Channel identifier
XML tag <ChannelIdentifier>

char* VVWINFO::szChannelDescription

Description of channel
XML tag <ChannelDescription>

char* VVWINFO::szChannelName

Name of channel
XML tag <ChannelName>

char* VVWINFO::szComments

Free form comments
XML tag <Comments>

char* VVWINFO::szComposer

Composer's Name
XML tag <Composer>

char* VVWINFO::szCopyright

REG Default Copyright message
XML tag <Copyright>

char* VVWINFO::szCreationData

Creation Data
XML tag <CreationData>

char* VVWINFO::szDailyRoll

RP-215 daily roll namd/id

char* VVWINFO::szDescription

Description of contents
XML tag <Description>

char* VVWINFO::szDeviceModelNum

Input device Model (32 char)
XML tag <DeviceModelNum>

char* VVWINFO::szDeviceSerialNum

Input device serial number (32 char)
XML tag <DeviceSerialNum>

char* VVWINFO::szDirector

Director's Name
XML tag <Director>

char* VVWINFO::szDisclaimer

Disclaimer
XML tag <Disclaimer>

char* VVWINFO::szDoNotUse

??? - This was (sz)SequenceNumber which was in conflict with (dw)SequenceNumber below. Leave empty for compatibility
XML tag <DoNotUse>

char* VVWINFO::szEditData1

User Data
XML tag <EditData1>

char* VVWINFO::szEditData2

User Data
XML tag <EditData2>

char* VVWINFO::szEditData3

User Data
XML tag <EditData3>

char* VVWINFO::szEditData4

User Data
XML tag <EditData4>

char* VVWINFO::szEditData5

User Data
XML tag <EditData5>

char* VVWINFO::szEditData6

User Data
XML tag <EditData6>

char* VVWINFO::szEditData7

User Data
XML tag <EditData7>

char* VVWINFO::szEditData8

User Data
XML tag <EditData8>

char* VVWINFO::szEditData9

User Data
XML tag <EditData9>

char* VVWINFO::szEditor

REG Default Editor of file
XML tag <Editor>

char* VVWINFO::szEncodedBy

REG Default Encoders Name
XML tag <Encoded By>

char* VVWINFO::szEpisode

RP-215 epsiode name

char* VVWINFO::szFileName

File Name and Extension (no path info) Created
XML tag <FileName>

char* VVWINFO::szFormat

File format
XML tag <Format>

char* VVWINFO::szFrameAttribute

Default frame attribute string for Cin/DPix (32 char)
XML tag <FrameAttribute>

char* VVWINFO::szFullName

Full name of media
XML tag <FullName>

char* VVWINFO::szGenre

Genre (type) of content
XML tag <Genre>

char* VVWINFO::szHostComputer

Computer hosting content
XML tag <HostComputer>

char* VVWINFO::szInformation

Free form information
XML tag <Information>

char* VVWINFO::szInkNumberPrefix

Prefix (0 feet) of the ink number from the film

char* VVWINFO::szInputDevice

Input device (Cin/DPix) telecine name (64 char)
XML tag <InputDevice>

char* VVWINFO::szIP

IP Address (192.168.0.3) Created
XML tag <TCP-IPAddress>

char* VVWINFO::szKeyNumberPrefix

Prefix (0 feet) of the key number from the film

char* VVWINFO::szKeywords

Search keywords
XML tag <Keywords>

char* VVWINFO::szLabRoll

RP-215 lab roll namd/id

char* VVWINFO::szLanguage

Language
XML tag <Language>

char* VVWINFO::szMake

Make - not used
XML tag <Make>

char* VVWINFO::szManufacturer

Manufacturer (DEF: Drastic Technologies Ltd)
XML tag <Manufacturer>

char* VVWINFO::szModel

Not Used
XML tag <Model>

char* VVWINFO::szNativeLocator

Native path + file + ext (C:/Test/Junk.avi) Created
XML tag <NativeLocator>

char* VVWINFO::szNU_81

TBD

char* VVWINFO::szNU_82

TBD

char* VVWINFO::szNU_83

TBD

char* VVWINFO::szNU_84

TBD

char* VVWINFO::szNU_85

TBD

char* VVWINFO::szNU_86

TBD

char* VVWINFO::szNU_87

TBD

char* VVWINFO::szNU_88

TBD

char* VVWINFO::szNU_89

TBD

char* VVWINFO::szNU_90

TBD

char* VVWINFO::szNU_91

TBD

char* VVWINFO::szNU_92

TBD

char* VVWINFO::szNU_93

TBD

char* VVWINFO::szNU_94

TBD

char* VVWINFO::szNU_95

TBD

char* VVWINFO::szNU_96

TBD

char* VVWINFO::szNU_97

TBD

char* VVWINFO::szNU_98

TBD

char* VVWINFO::szNU_99

TBD

char* VVWINFO::szOriginalArtist

Orginal artist's name
XML tag <OriginalArtist>

char* VVWINFO::szOriginalFormat

Original format of content
XML tag <OriginalFormat>

char* VVWINFO::szOwner

REG Default Owner of content
XML tag <Owner>

char* VVWINFO::szPerformers

Performers in content
XML tag <Performers>

char* VVWINFO::szPictureIcon

Small jpg frame capture

char* VVWINFO::szProduced

Producer company name
XML tag <Produced>

char* VVWINFO::szProducer

Producer's Name
XML tag <Producer>

char* VVWINFO::szProduct

Targeted associated product
XML tag <Product>

char* VVWINFO::szProject

REG Default Project Name
XML tag <Project>

char* VVWINFO::szProxyFile

Low res proxy file

char* VVWINFO::szRatings

Parental Ratings
XML tag <Ratings>

char* VVWINFO::szReel

Reel this was recorded to
XML tag <Reel>

char* VVWINFO::szRevisionNumber

Revision number as string
XML tag <RevisionNumber>

char* VVWINFO::szScene

RP-215 scene

char* VVWINFO::szShot

Shot name (or number in string)
XML tag <Shot>

char* VVWINFO::szSlateInfo

Info from the original slate (200 char)
XML tag <SlateInfo>

char* VVWINFO::szSoftware

Software in use (DEF: "MediaReactor")
XML tag <Software>

char* VVWINFO::szSoundRoll

RP-215 sound roll namd/id

char* VVWINFO::szSource

Source of file (VTR, Betacam, MPEG, Satellite)
XML tag <Source>

char* VVWINFO::szSourceLocator

Source locator (either szUnversalName, szNativeLocator, szFileName available in this order) Created
XML tag <SourceLocator>

char* VVWINFO::szSpecialPlaybackRequirements

Special playback requirements
XML tag <SpecialPlaybackRequirements>

char* VVWINFO::szStatus

Status
XML tag <Status>

char* VVWINFO::szSubject

Subject
XML tag <Subject>

char* VVWINFO::szSupplier

REG Default Supplier
XML tag <Supplier>

char* VVWINFO::szTake

Take name (or number in string)
XML tag <Take>

char* VVWINFO::szTitle

Title
XML tag <Title>

char* VVWINFO::szTrack

Track Name
XML tag <Track>

char* VVWINFO::szUniversalName

UNC (/TestBox/C/Test/Junk.avi) Created
XML tag <UniversalFileName>

char* VVWINFO::szURLLink

REG Default Link to site (http://www.drastictech.com)
XML tag <URL>

char* VVWINFO::szVersionString

Version string
XML tag <VersionString>

char* VVWINFO::szWarning

Warning info
XML tag <Warning>

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: VVWSYSTEM Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VVWSYSTEM Struct Reference

#include <vvwtypes.h>

Data Fields

DWORD | dwMicroSecPerFrame
DWORD | dwMaxBytesPerSec
DWORD | dwPaddingGranularity
DWORD | dwFlags
DWORD | dwTotalFrames
DWORD | dwInitialFrames
DWORD | dwStreams
DWORD | dwSuggestedBufferSize
DWORD | dwWidth
DWORD | dwHeight
DWORD | dwReserved [4]
DWORD | dwCaps
DWORD | dwScale
DWORD | dwRate
DWORD | dwLength
DWORD | dwEditCount
char | szFileType [64]
DWORD | dwType
DWORD | dwMfCaps
DWORD | dwVidStandard
DWORD | dwDrFlags
DWORD | dwFileType
Source File Type.
DWORD | dwResDrastic

Detailed Description

The VVWSYSTEM structure holds the overview of a media stream including basic time (rate/scale), number of tracks, buffering info, msperframe, width/height of one or more video streams, maximum length in frames and (rate/scale). It is binary compatible with the AVI sytem header, but translated as nec to OMF MOV or any other supported format. Testing has not been thorough enough to entirely trust this structure, but it is a good place to start.

Field Documentation

DWORD VVWSYSTEM::dwCaps

Capability flags from video for windows including:

     AVIFILECAPS_CANREAD            0x00000001 - File may be read
     AVIFILECAPS_CANWRITE           0x00000002 - File may be written to
     AVIFILECAPS_ALLKEYFRAMES       0x00000010 - File contains frames that do not require interframe data to decode (eg. JPEG)
     AVIFILECAPS_NOCOMPRESSION      0x00000020 - The frames in the file are uncompressed
Do not trust these flags. Look at the VVWVIDEO and VVWAUDIO areas to confirm types of streams.

DWORD VVWSYSTEM::dwDrFlags

Our internal flags including: DRFLAGS_ZERO_FIELD_DOMINANT, DRFLAGS_FIRST_FIELD_DOMINANT, DRFLAGS_HAS_KEYFRAMES, DRFLAGS_FCC_MJPG_DIGISUITE, DRFLAGS_FCC_MJPG_DCx0, DRFLAGS_FCC_MJPG_DSEDIT, DRFLAGS_FCC_MJPG_JPGDIB, DRFLAGS_FCC_MJPG_JFIF, DRFLAGS_FCC_USE_INTERN, DRFLAGS_FCC_USE_QT, DRFLAGS_FCC_USE_ICM, DRFLAGS_CODECPRIVATEDATA_AVI, DRFLAGS_CODECPRIVATEDATA_MOV, DRFLAGS_CODECPRIVATEDATA_OMF, DTVVW_PREVIEW

DWORD VVWSYSTEM::dwEditCount

The number of times this file has been edited. Intended for tracing QuickTime style edits within an AVI file, but good editing capabilities where never added to video for windows, so this is always 0, 1 or a random number with little or no meaning.

DWORD VVWSYSTEM::dwFileType

Source File Type.

DWORD VVWSYSTEM::dwFlags

AVIFILEINFO_ flags such as

        AVIFILEINFO_HASINDEX            0x00000010 - there is an index to the frames included in the file
        AVIFILEINFO_MUSTUSEINDEX        0x00000020 - index is required, normally means frames are out of order on disk
        AVIFILEINFO_ISINTERLEAVED       0x00000100 - includes multiple channels in same file (usually audio and video)
        AVIFILEINFO_WASCAPTUREFILE      0x00010000 - from live source, may not be optimally written in the heat of the moment (eg avicap)
        AVIFILEINFO_COPYRIGHTED         0x00020000 - early microsoft attempt at screwing us.  not used to my knowledge

DWORD VVWSYSTEM::dwHeight

Basic or largest height of a video stream within this file. Caution, for some media streams this value can be negative indicating the stream is vertically inverted. If a positive value is required, abs this before using. In theory, this value should always be positive, but it isn't.

DWORD VVWSYSTEM::dwInitialFrames

The initial number of frames that should be loaded or, esp if using 'rec ' index chunks, the number of pre-buffer audio frames before video appears (usually 10~25). We usually ignore this value as it will only help with extremely slow drives. It doesn't even appear to help with 10bT network connections significantly.

DWORD VVWSYSTEM::dwLength

Length of the longest stream in samples. This could be audio or video samples, but will always relate to Rate/Scale above. For streams with video, this is a frame count and should be the same as dwTotalFrames.

DWORD VVWSYSTEM::dwMaxBytesPerSec

The maximum bytes per second this media will generate. Should assume all channels active and in use. Should be set by writer, but often isn't. Not used internally, so regard with some suspicion.

DWORD VVWSYSTEM::dwMfCaps

MediaFile Capability flags. Not used currenly.

DWORD VVWSYSTEM::dwMicroSecPerFrame

Number of microseconds for a frame duration. Normally refers to video and will be set to values like 33367 (NTSC) or 40000 (PAL) or possibly 0 if not specified. When the system structure is used in AvHAL or elsewhere internally, this value must always be valid as some timing calculations are based on it. As good practice, make sure it is correct for media files as well. Related to VVWSYSTEM::dwRate and VVWSYSTEM::dwScale in that == 1000000 / (VVWSYSTEM::dwRate / VVWSYSTEM::dwScale)

DWORD VVWSYSTEM::dwPaddingGranularity

The size of pad used to write the file. With bad writers, this is set to 0/512/1024/2048/4096 and then the file is written without any regard for its setting. With decent writers, it is set to the disk sector size the writer is writing to and it is respected and correct at at least for video. With our writers, it is set to 4096 (largest general multiple of sector size and most common on NTFS systems) and we write to 4096. If the granularity is bad, we can usually still use sector aligned reads, by reading a little extra garbage and ignoring it, except for the last frame if we run out of file.

DWORD VVWSYSTEM::dwRate

Rate - the frame second length divided by VVWSYSTEM::dwScale to get the frame frame rate

   Scale   Rate    FrameRate   MsPerFrame
   1       25      25          40          (PAL)
   1001    30000   29.97       33.667      (NTSC)
   1       24      24          41.667      (FILM)
   66000   1000000 15.152      65.998      (NTSC->Multimedia)
   1       15      15          66.667      (MultiMedia)
   1       22050   22.050kHz   --          (Audio 22kHz 8 Bit Mono)
   4       176400  44.1kHz     --          (Audio 44.1kHz 16 Bit Stereo)
   2       48000   48kHz       --          (Audio 48kHz 16 Mono --OR-- 48kHz 8 Bit Stereo)

DWORD VVWSYSTEM::dwResDrastic

Reserved. Set to 0 on allocate and do not touch.

DWORD VVWSYSTEM::dwReserved[4]

As it says, reserved, do not touch.

DWORD VVWSYSTEM::dwScale

Scale - the frame divisor into VVWSYSTEM::dwRate to get the frame frame rate

   Scale   Rate    FrameRate   MsPerFrame
   1       25      25          40          (PAL)
   1001    30000   29.97       33.667      (NTSC)
   1       24      24          41.667      (FILM)
   66000   1000000 15.152      65.998      (NTSC->Multimedia)
   1       15      15          66.667      (MultiMedia)
   1       22050   22.050kHz   --          (Audio 22kHz 8 Bit Mono)
   4       176400  44.1kHz     --          (Audio 44.1kHz 16 Bit Stereo)
   2       48000   48kHz       --          (Audio 48kHz 16 Mono --OR-- 48kHz 8 Bit Stereo)

DWORD VVWSYSTEM::dwStreams

The total number of audio, video and information streams in the media file. This does not include channels within stereo audio streams which are considered to be one channel.

DWORD VVWSYSTEM::dwSuggestedBufferSize

Suggested buffer size is set by the writer and is supposed to be the size of the largest 'chunk' (audio or video) of data that will have to be read at once. More important in systems where memory is at a premium. With Win32 we only us this to determine the correct audio buffer size if it is greater than half a second of stereo audio at the audio streams sample rate and bit size.

DWORD VVWSYSTEM::dwTotalFrames

This is the total number of actual video frames (counted as a frame count) of the longest video stream in the file. If there is no video stream in the file, the audio will be broken up into frames per (VVWSYSTEM::dwRate / VVWSYSTEM::dwScale) and if they are set to 0 then, we normally fill it with and NTSC value of frames by default. This is the place we normally count on the be correct for conversion source length and clip length in VVW.

DWORD VVWSYSTEM::dwType

VVW and ME internal flags - Add Flags Here MF_TYPE_???, AVH_TYPE_???

DWORD VVWSYSTEM::dwVidStandard

Basic video standard. Was PAL/NTSC, but should now us GS_SIGFORM_NTSC defines in mediacmd.h

DWORD VVWSYSTEM::dwWidth

Basic or largest width of a video stream within this file.

char VVWSYSTEM::szFileType[64]

A marker for the time of media file or module that created this structure is Free form, used to present to user when problems occur.

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: VVWVIDEO Struct Reference

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

VVWVIDEO Struct Reference

#include <vvwtypes.h>

Data Fields

DWORD | biSize
Size of the BITMAPINFOHEADER portion of this structure (sizeof(BITMAPINFOHEADER) + any VVWVIDEO::dwReserved used).
LONG | biWidth
Width of the video frame.
LONG | biHeight
Height of the video frame. CAUTION: For vertically inverted frames this WILL be negative.
WORD | biPlanes
Number of RGB groups (like photoshop layers) - Always 1 for our purposes.
WORD | biBitCount
Number of bits per pixel (eg. YUV422=16, RGB=24, RGBA=32).
DWORD | biCompression
Compression - a fourcc usually, but not always equal to fccHandler. Denotes compression type of frame - see fccDef.h.
DWORD | biSizeImage
Size of the image. For uncompressed biWidth*abs(biHeight)*(biBitCount/8) in bytes. For compressed, variable.
LONG | biXPelsPerMeter
Horizontal picture elements per meter - normally 0.
LONG | biYPelsPerMeter
Vertical picture elements per meter - normally 0.
DWORD | biClrUsed
For colour tables in dwReserved, the number of RGBQUAD elements used.
DWORD | biClrImportant
For colour tables in dwReserved, the number of RGBQUAD elements that are critical to display (for windows pallette wars in < 256 colour mode).
DWORD | dwReserved [256]
DWORD | fccType
For VVWVIDEO structure this is always streamtypeVIDEO == 'vids'.
DWORD | fccHandler
Codec type, see fccDef.h Normally the same as VVWVIDEO::biCompression but not always.
DWORD | dwFlags
DWORD | dwCaps
Not sure. See VVWSYSTEM::dwCaps for possible interp if something is set. MS Doc: currently unused.
WORD | wPriority
Priority of stream (<-MSDoc in relation to other streams in the file I suppose).
WORD | wLanguage
Language of stream (<-MSDoc but no language id defines).
DWORD | dwScale
dwRate/dwScale = frame rate. See VVSYSTEM::dwScale for more info and table example
DWORD | dwRate
dwRate/dwScale = frame rate. See VVSYSTEM::dwRate for more info and table example
DWORD | dwStart
DWORD | dwLength
DWORD | dwInitialFrames
DWORD | dwSuggestedBufferSize
DWORD | dwQuality
DWORD | dwSampleSize
RECT | rcFrame
DWORD | dwEditCount
Number of times the stream has been edited. The stream handler maintains this count.
DWORD | dwFormatChangeCount
Number of times the stream format has changed. The stream handler maintains this count.
char | szName [64]
Null-terminated string containing a description of the stream.
LONG | biPitch
The number of bytes in a row of pixels. Allows for byte/word/dword alignment of lines as nec for format.
DWORD | dwDrFlags
DWORD | dwFileType
Source File Type.
DWORD | dwResDrastic
Reserved, init to zero and leave alone.

Detailed Description

The video structure is a combination of a BITMAPINFOHEADER and a AVISTREAMINFO structure. The top half should be treated as a BITMAPINOFHEADER and the bottom as a related but independant structure. These are as they appear in an AVI file and are manipulated to fill other file types like OMF and MOV.

Field Documentation

WORD VVWVIDEO::biBitCount

Number of bits per pixel (eg. YUV422=16, RGB=24, RGBA=32).

DWORD VVWVIDEO::biClrImportant

For colour tables in dwReserved, the number of RGBQUAD elements that are critical to display (for windows pallette wars in < 256 colour mode).

DWORD VVWVIDEO::biClrUsed

For colour tables in dwReserved, the number of RGBQUAD elements used.

DWORD VVWVIDEO::biCompression

Compression - a fourcc usually, but not always equal to fccHandler. Denotes compression type of frame - see fccDef.h.

LONG VVWVIDEO::biHeight

Height of the video frame. CAUTION: For vertically inverted frames this WILL be negative.

LONG VVWVIDEO::biPitch

The number of bytes in a row of pixels. Allows for byte/word/dword alignment of lines as nec for format.

WORD VVWVIDEO::biPlanes

Number of RGB groups (like photoshop layers) - Always 1 for our purposes.

DWORD VVWVIDEO::biSize

Size of the BITMAPINFOHEADER portion of this structure (sizeof(BITMAPINFOHEADER) + any VVWVIDEO::dwReserved used).

DWORD VVWVIDEO::biSizeImage

Size of the image. For uncompressed biWidth*abs(biHeight)*(biBitCount/8) in bytes. For compressed, variable.

LONG VVWVIDEO::biWidth

Width of the video frame.

LONG VVWVIDEO::biXPelsPerMeter

Horizontal picture elements per meter - normally 0.

LONG VVWVIDEO::biYPelsPerMeter

Vertical picture elements per meter - normally 0.

DWORD VVWVIDEO::dwCaps

Not sure. See VVWSYSTEM::dwCaps for possible interp if something is set. MS Doc: currently unused.

DWORD VVWVIDEO::dwDrFlags

Our internal flags including: DRFLAGS_ZERO_FIELD_DOMINANT, DRFLAGS_FIRST_FIELD_DOMINANT, DRFLAGS_HAS_KEYFRAMES, DRFLAGS_FCC_MJPG_DIGISUITE, DRFLAGS_FCC_MJPG_DCx0, DRFLAGS_FCC_MJPG_DSEDIT, DRFLAGS_FCC_MJPG_JPGDIB, DRFLAGS_FCC_MJPG_JFIF, DRFLAGS_FCC_USE_INTERN, DRFLAGS_FCC_USE_QT, DRFLAGS_FCC_USE_ICM, DRFLAGS_CODECPRIVATEDATA_AVI, DRFLAGS_CODECPRIVATEDATA_MOV, DRFLAGS_CODECPRIVATEDATA_OMF, DTVVW_PREVIEW

DWORD VVWVIDEO::dwEditCount

Number of times the stream has been edited. The stream handler maintains this count.

DWORD VVWVIDEO::dwFileType

Source File Type.

DWORD VVWVIDEO::dwFlags

DWORD VVWVIDEO::dwFormatChangeCount

Number of times the stream format has changed. The stream handler maintains this count.

DWORD VVWVIDEO::dwInitialFrames

Amount of audio in the file before video commences. For offset files, typically 0.75 sec converted to units per VVWVIDEO::dwRate/VVWVIDEOdwScale. For high end files, always zero as audio and video are sent without scew (except premiere, which uses 'rec ' chunks and audio skew)

DWORD VVWVIDEO::dwLength

Length of the video stream in units per VVWVIDEO::dwRate/VVWVIDEOdwScale (for video - frames)

DWORD VVWVIDEO::dwQuality

Quality used by the compressor. Between 0 and 10,000 or -1 if default quality. For some compressors, the -1 can also mean the quality info is encoded into the frame or in the dwReserved or other private data area.

DWORD VVWVIDEO::dwRate

dwRate/dwScale = frame rate. See VVSYSTEM::dwRate for more info and table example

DWORD VVWVIDEO::dwResDrastic

Reserved, init to zero and leave alone.

DWORD VVWVIDEO::dwReserved[256]

The dwReserved may hold many things. Whatever it holds, the amount used can be determined by subracting sizeof(BITMAPINFOHEADER) from VVWVIDEO::biSize. Here are some possible uses

                Table of struct RGBQUAD { BYTE rgbBlue, rgbGreen, rgbRed, rgbReserved; };

                typedef struct tagJPEGINFOHEADER {
                        // compression-specific fields
                        // these fields are defined for 'JPEG' and 'MJPG'
                        DWORD       JPEGSize;
                        DWORD       JPEGProcess;

                        // Process specific fields
                        DWORD       JPEGColorSpaceID;
                        DWORD       JPEGBitsPerSample;
                        DWORD       JPEGHSubSampling;
                        DWORD       JPEGVSubSampling;
                } JPEGINFOHEADER;

                typedef struct tagVIDEOINFOHEADER {

                        RECT            rcSource;          // The bit we really want to use
                        RECT            rcTarget;          // Where the video should go
                        DWORD           dwBitRate;         // Approximate bit data rate
                        DWORD           dwBitErrorRate;    // Bit error rate for this stream
                        REFERENCE_TIME  AvgTimePerFrame;   // Average time per frame (100ns units)

                        BITMAPINFOHEADER bmiHeader;

                } VIDEOINFOHEADER;

                typedef struct tagMPEG1VIDEOINFO {

                        VIDEOINFOHEADER hdr;                    // Compatible with VIDEOINFO
                        DWORD           dwStartTimeCode;        // 25-bit Group of pictures time code
                                                                                // at start of data
                        DWORD           cbSequenceHeader;       // Length in bytes of bSequenceHeader
                        BYTE            bSequenceHeader[1];     // Sequence header including
                                                                                // quantization matrices if any
                } MPEG1VIDEOINFO;

                typedef struct tagAnalogVideoInfo {
                        RECT            rcSource;           // Width max is 720, height varies w/ TransmissionStd
                        RECT            rcTarget;           // Where the video should go
                        DWORD           dwActiveWidth;      // Always 720 (CCIR-601 active samples per line)
                        DWORD           dwActiveHeight;     // 483 for NTSC, 575 for PAL/SECAM
                        REFERENCE_TIME  AvgTimePerFrame;    // Normal ActiveMovie units (100 nS)
                } ANALOGVIDEOINFO;

                typedef struct tagMPEG2VIDEOINFO {
                        VIDEOINFOHEADER2    hdr;
                        DWORD               dwStartTimeCode;        //  ?? not used for DVD ??
                        DWORD               cbSequenceHeader;       // is 0 for DVD (no sequence header)
                        DWORD               dwProfile;              // use enum MPEG2Profile
                        DWORD               dwLevel;                // use enum MPEG2Level
                        DWORD               dwFlags;                // use AMMPEG2_* defines.  Reject connection if undefined bits are not 0
                        DWORD               dwSequenceHeader[1];    // DWORD instead of Byte for alignment purposes
                                                                                //   For MPEG-2, if a sequence_header is included, the sequence_extension
                                                                                //   should also be included
                } MPEG2VIDEOINFO;

                typedef struct tagVIDEOINFOHEADER2 {
                        RECT                rcSource;
                        RECT                rcTarget;
                        DWORD               dwBitRate;
                        DWORD               dwBitErrorRate;
                        REFERENCE_TIME      AvgTimePerFrame;
                        DWORD               dwInterlaceFlags;   // use AMINTERLACE_* defines. Reject connection if undefined bits are not 0
                        DWORD               dwCopyProtectFlags; // use AMCOPYPROTECT_* defines. Reject connection if undefined bits are not 0
                        DWORD               dwPictAspectRatioX; // X dimension of picture aspect ratio, e.g. 16 for 16x9 display
                        DWORD               dwPictAspectRatioY; // Y dimension of picture aspect ratio, e.g.  9 for 16x9 display
                        DWORD               dwReserved1;        // must be 0; reject connection otherwise
                        DWORD               dwReserved2;        // must be 0; reject connection otherwise
                        BITMAPINFOHEADER    bmiHeader;
                } VIDEOINFOHEADER2;

DWORD VVWVIDEO::dwSampleSize

Size, in bytes, of a single data sample. If the value of this member is zero, the samples can vary in size and each data sample (such as a video frame) must be in a separate chunk. A nonzero value indicates that multiple samples of data can be grouped into a single chunk within the file. For video streams, this number is typically zero, although it can be nonzero if all video frames are the same size. For audio streams, this number should be the same as the nBlockAlign member of the WAVEFORMAT or WAVEFORMATEX structure describing the audio.

DWORD VVWVIDEO::dwScale

dwRate/dwScale = frame rate. See VVSYSTEM::dwScale for more info and table example

DWORD VVWVIDEO::dwStart

Delay in units per VVWVIDEO::dwRate/VVWVIDEOdwScale (for video - frames) for this stream to start in the playback of the file. NOTE AVI v1.0 and simple avi readers will choke or play incorrectly if this is not 0, so be careful.

DWORD VVWVIDEO::dwSuggestedBufferSize

Recommended buffer size based on the largest single chunk in the file. Set by writer, so often incorrect or 0.

DWORD VVWVIDEO::fccHandler

Codec type, see fccDef.h Normally the same as VVWVIDEO::biCompression but not always.

DWORD VVWVIDEO::fccType

For VVWVIDEO structure this is always streamtypeVIDEO == 'vids'.

RECT VVWVIDEO::rcFrame

Dimensions of the video destination rectangle. The values represent the coordinates of upper left corner, the height, and the width of the rectangle.

char VVWVIDEO::szName[64]

Null-terminated string containing a description of the stream.

WORD VVWVIDEO::wLanguage

Language of stream (<-MSDoc but no language id defines).

WORD VVWVIDEO::wPriority

Priority of stream (<-MSDoc in relation to other streams in the file I suppose).

The documentation for this struct was generated from the following file:
  • vvwtypes.h


MediaCmd: Hierarchical Index

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaCmd Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • DCLIP
  • DFRAME
  • DRASTIC_CHANNEL
  • FRAME_INFO
  • MEDIACMD
  • RECT16
  • VVWAUDIO
  • VVWINFO
  • VVWSYSTEM
  • VVWVIDEO


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • arbID : MEDIACMD


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • __vvwInitService() : vvw.h
  • __vvwQuitService() : vvw.h
  • _MAX_CLIP_NAME_SIZE : vvwtypes.h
  • _PDFRAMEFLAGS_CLIPEND : vvwtypes.h
  • _PDFRAMEFLAGS_CLIPSTART : vvwtypes.h
  • _PDFRAMEFLAGS_CLIPSTILL : vvwtypes.h
  • _PDFRAMEFLAGS_FIRSTFRAME : vvwtypes.h
  • _PDFRAMEFLAGS_LASTFRAME : vvwtypes.h
  • _VVW_ABS_MAX_CHANNELS : vvwtypes.h
  • _VVW_CONTROL_MAX_CONTROL : vvwtypes.h
  • _VVW_CONTROL_MAX_EXTERNAL : vvwtypes.h
  • _VVW_CONTROL_MAX_LOCAL : vvwtypes.h
  • _VVW_CONTROL_MAX_NETWORK : vvwtypes.h
  • _VVW_CONTROL_START_EXTERNAL : vvwtypes.h
  • _VVW_CONTROL_START_LOCAL : vvwtypes.h
  • _VVW_CONTROL_START_NETWORK : vvwtypes.h
  • _VVW_DSYNC_CHANNEL : vvwtypes.h
  • _VVW_DSYNC_LTC_CHANNEL : vvwtypes.h
  • _VVW_H_MAINHEADER_INCLUDED : vvw.h
  • _VVW_IS_VVWAUDIO : vvwtypes.h
  • _VVW_IS_VVWINFO : vvwtypes.h
  • _VVW_IS_VVWSYSTEM : vvwtypes.h
  • _VVW_IS_VVWVIDEO : vvwtypes.h
  • _VVW_STANDARD_PIPE_NAME : vvw.h
  • _VVW_TYPES_HAVE_ALREADY_BEEN_INCLUDED : vvwtypes.h
  • _VVWXXX_NAME_SIZE : vvwtypes.h
  • _VVWXXX_RESERVED_SIZE : vvwtypes.h


MediaCmd: Page Index

MediaCmd Related Pages

Here is a list of all related documentation pages:
  • MEDIACMD Fast Info Page
  • VVWTypes Fast Info Page
  • Todo List
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: MEDIACMD Fast Info Page

MEDIACMD Fast Info Page

MEDIACMD Introduction

This document covers inter-device communication protocol used for control and information exchange across a Drastic Media machine, Intranet (LAN) or Internet (WAN). This document does not include information concerning low-level file structures, raw data access, or hardware specific variations.

Drastic uses an inter-process piping metaphor to allow the implementation of media distribution and control over a small or large sized installation. A media distribution system normally includes the following components:
  • Receiving and interpreting external time code based instructions (Sony/SMPTE/VDR serial protocols)
  • Receiving and implementing external file or clip based instructions (Odetics/Alamar)
  • Configuration and local control (Graphical User Interface)
  • Storage management (Clip/File/Time Code/LTC/VITC/User)
  • Transport control (On time/Pre load/Pathing/QOS)
  • Hardware audio/video/compression control (Local/Effective Remote)

    Each of these components must be able to intercommunicate with one or more other components to maintain control and status information within the processes or systems. To allow transportation of these command elements across a local or wide area network, a protocol and transport method compatible with the running platforms and the networks connecting them must be used.

    Once the protocol is in place, each of the drivers within a machine or network must have an established command set to inter communicate. The object of each component of the system is to receive media commands, send media commands or control media based on those commands. This requirement is met by the drastic MediaCmd structure, which is used for communication between all devices.

    Physical Transport

    The physical mechanisms for transporting commands throughout a system are encapsulated in the Drastic VVWNet library. The connection is in some ways similar to a Unix or NT, but does not actually use pipes. The VVWNet provides a simple interface for sending command packets between drivers within the same machine or different machines attached by a network. The VVWNet may use any underlying network protocol, but currently supports TCP/IP and IPX.

MEDIACMD QuickLinks

The structure: MEDIACMD
The commands: cmdType
The Flags: cmdFlags
Channels: cmdVidChan, cmdAudChan, cmdinf
GetSet Commands cmdGetSetValue
Basic cmdGetSetValue::gsTc
Clip cmdGetSetValue::gsGetNextClip
Channel cmdGetSetValue::gsAudChan
Audio cmdGetSetValue::gsAudInSelect
Video General cmdGetSetValue::gsVidFreeze
Video Input cmdGetSetValue::gsVidInSelect
Video TBC cmdGetSetValue::gsVidSetup
Video Output cmdGetSetValue::gsVidOutSelect
Signal Type cmdGetSetValue::gsSignalFormat
Compression cmdGetSetValue::gsCompType
Storage cmdGetSetValue::gsTotalStorageAvail
Control cmdGetSetValue::gsLocal
Info cmdGetSetValue::gsVVWVersion
Internal cmdGetSetValue::gsSetHwnds
Mode+Info cmdGetSetValue::gsChannelExist
Returns GS_NOT_SUPPORTED
Declaration Local DECLARE_MEDIACMD
Init Local INIT_MEDIACMD
Init Pointer INIT_PMEDIACMD
Sizes SIZEOF_MEDIACMD_BASE

MEDIACMD Sample Commands

The following are sample commands as sent through media command. The samples are taken from the VVW series of products, and as such are guaranteed to work with them. Other OEMs and manufacturers supporting the MediaCmd interface may vary from this specification.

Simple Play
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 28
MEDIACMD::ctCmd = ctPlay<BR>
Simple Pause
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 28
MEDIACMD::ctCmd = ctPause<BR>
Simple Stop
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 28
MEDIACMD::ctCmd = ctStop<BR>
Play From-To
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctPlay<BR> MEDIACMD::cfFlags = cfUseStart | cfUseEnd<BR> MEDIACMD::dwStart = 1800 // 1 minute in frames NTSC NDF
MEDIACMD::dwEnd = 2100 // 1 minute 10 seconds NTSC NDF

Play DMC (Play at speed)
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 36
MEDIACMD::ctCmd = ctPlay<BR> MEDIACMD::cfFlags = cfUseSpeed<BR> MEDIACMD::lSpeed = 32760 // Half play speed forward

Record Edit
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctRecord<BR> MEDIACMD::cfFlags = cfUseStart | cfUseEnd | cfUsePresets<BR> MEDIACMD::dwVideoChannels = 0x01 // Record V
MEDIACMD::dwAudioChannels = 0x03 // Record A1 & A2 (AA)
MEDIACMD::dwInfoChannels = 0x00
MEDIACMD::dwStart = 3000
MEDIACMD::dwEnd = 3200

Play Two Segments
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctPlay<BR> MEDIACMD::cfFlags = cfUseStart | cfUseEnd<BR> MEDIACMD::dwStart = 2200
MEDIACMD::dwEnd = 2500

MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctPlay<BR> MEDIACMD::cfFlags = cfUseStart | cfUseEnd | cfDeferred<BR> MEDIACMD::dwStart = 5300
MEDIACMD::dwEnd = 5450

Play A Named Clip
Char szName = "C:\Adir\Afile.OMF"
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60 + strlen(szName)
MEDIACMD::ctCmd = ctPlay<BR> MEDIACMD::cfFlags = cfUseClipID<BR> strcpy( MEDIACMD::arbID , szName)

Seek To 1 Minute
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 48
MEDIACMD::ctCmd = ctPause<BR> MEDIACMD::cfFlags = cfUsePosition<BR> MEDIACMD::dwPosition = 1800 // Frames NTSC NDF

Step Reverse 1 Frame
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 48
MEDIACMD::ctCmd = ctPause<BR> MEDIACMD::cfFlags = cfUsePositionOffset<BR> MEDIACMD::dwPosition = (DWORD) -1

Record A 1 Minute Named Clip
Char szName = "C:\Adir\ArecordFile.MOV"
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60 + strlen(szName)
MEDIACMD::ctCmd = ctRecord<BR> MEDIACMD::cfFlags = cfUseClipID | cfUseEnd<BR> MEDIACMD::dwEnd = 1800
strcpy( MEDIACMD::arbID , szName)

Record An Odetics or Louth Clip (ext)
(Note: The stop command is required for accuracy on some DDRs)
Char szName = "THISCLIP" // Max 8 char
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60 + strlen(szName)
MEDIACMD::ctCmd = ctStop // Record ready
MEDIACMD::cfFlags = cfUseClipID<BR> strcpy( MEDIACMD::arbID , szName)

MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60 + strlen(szName)
MEDIACMD::ctCmd = ctRecord<BR> MEDIACMD::cfFlags = cfUseClipID<BR> strcpy( MEDIACMD::arbID , szName)

Eject The Current Media
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 28
MEDIACMD::ctCmd = ctEject<BR>
Setup The Video To Nominal
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctSetValue<BR> MEDIACMD::dwCmdAlt = gsVidSetup
MEDIACMD::dwStart = 0

MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctSetValue<BR> MEDIACMD::dwCmdAlt = gsVidVideo
MEDIACMD::dwStart = 0

MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctSetValue<BR> MEDIACMD::dwCmdAlt = gsVidHue
MEDIACMD::dwStart = 0

MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctSetValue<BR> MEDIACMD::dwCmdAlt = gsVidChroma
MEDIACMD::dwStart = 0

Check The Device Type
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctGetValue<BR> MEDIACMD::dwCmdAlt = gsVtrType
MEDIACMD::dwStart = 0
(Returns: Vtr/Ddr/Media type in .dwStart)

Change The Default TC Type To VITC
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctSetValue<BR> MEDIACMD::dwCmdAlt = gsVitcTc
MEDIACMD::dwStart = GS_DEFAULT

Transfer From External VTR To Internal Channel
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctTransfer<BR> MEDIACMD::cfFlags = cfUsePosition | cfUseStart | cfUseEnd | cfUsePresets<BR> MEDIACMD::dwVideoChannels = 0x01 // Cature Video
MEDIACMD::dwAudioChannels = 0x00 // No Audio
MEDIACMD::dwInfoChannels = 0x00
MEDIACMD::dwCmdAlt = hExternalChannel // The VTR channel
MEDIACMD::dwPosition = 2100 // Where to record to
MEDIACMD::dwStart = 10850 // Source In on VTR
MEDIACMD::dwEnd = 11000 // Source Out on VTR

Insert Media From File Over Current
Char szName = "C:\Adir\ArecordFile.MOV"
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60 + strlen(szName)
MEDIACMD::ctCmd = ctInsert<BR> MEDIACMD::cfFlags = cfUsePosition | cfUseStart | cfUseEnd | cfUseClipID<BR> MEDIACMD::dwPosition = 2100 // Insert @ on target channel
MEDIACMD::dwStart = 0 // Start on source file
MEDIACMD::dwEnd = 180 // End on source file
strcpy( MEDIACMD::arbID , szName) // Name of source file

Delete A Section Of Media (No Hole)
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctDelete<BR> MEDIACMD::cfFlags = cfUseStart | cfUseEnd | cfRipple // Remove cfRipple to leave hole
MEDIACMD::dwStart = 140500 // Start on target media
MEDIACMD::dwEnd = 150010 // End on target media

Trim A Clip
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 60
MEDIACMD::ctCmd = ctTrim<BR> MEDIACMD::cfFlags = cfUsePosition | cfUseStart | cfUseEnd
MEDIACMD::dwPosition = 2100 // Clip @ position
MEDIACMD::dwStart = +32 // Clip 32 frames from start
MEDIACMD::dwEnd = (DWORD) -12 // Clip 12 frame from end

Terminate Session (Restart At Default)
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 28
MEDIACMD::ctCmd = ctTerminate<BR>
Abort Current Command
MEDIACMD::dwCmdID = MEDIACMD_CURRENT<BR> MEDIACMD::dwStructSize = 28
MEDIACMD::ctCmd = ctAbort<BR>

MEDIACMD Sample Returns

Sample Returns

MEDIACMD::dwCmdID == MEDIACMD_CURRENT
MEDIACMD::dwStructSize == SIZEOF_MEDIACMD
MEDIACMD::ctCmd == cmdType::ctPlay
MEDIACMD::cfFlags == 0
Normal Play (100% Play Speed)

MEDIACMD::dwCmdID == MEDIACMD_CURRENT
MEDIACMD::dwStructSize == SIZEOF_MEDIACMD
MEDIACMD::ctCmd == cmdType::ctRecord
MEDIACMD::cfFlags == 0
Normal Record (Crash Record)


MediaCmd: VVWTypes Fast Info Page

VVWTypes Fast Info Page

Introduction

VVWTypes.h are internal types used to pass information between VVW/QuickClip/MediaReactor modules when a MEDIACMD is not possible or appropriate. These are provided as a part of the mediacmd sdk to fill in any holes or references not directly available in mediacmd.h.


MediaCmd: Todo List

Todo List

Global VVWXXX_GETSAMPLEFROMLENGTH
Find and remove

Global VVWXXX_SETSAMPLETOLENGTH
Find and remove
Generated on Wed May 17 15:52:35 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Alphabetical List

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields

MediaCmd Data Structure Index

D | F | M | R | V

D
DRASTIC_CHANNEL
M
RECT16 VVWINFO
DCLIP
F
MEDIACMD
V
VVWSYSTEM
DFRAME FRAME_INFO
R
VVWAUDIO VVWVIDEO

D | F | M | R | V


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • left : RECT16
  • lpData : DFRAME
  • lSpeed : MEDIACMD


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • mCmd : DRASTIC_CHANNEL


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • nAvgBytesPerSec : VVWAUDIO
  • nBlockAlign : VVWAUDIO
  • nChannels : VVWAUDIO
  • nSamplesPerSec : VVWAUDIO


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • biBitCount : VVWVIDEO
  • biClrImportant : VVWVIDEO
  • biClrUsed : VVWVIDEO
  • biCompression : VVWVIDEO
  • biHeight : VVWVIDEO
  • biPitch : VVWVIDEO
  • biPlanes : VVWVIDEO
  • biSize : VVWVIDEO
  • biSizeImage : VVWVIDEO
  • biUnused : VVWAUDIO
  • biWidth : VVWVIDEO
  • biXPelsPerMeter : VVWVIDEO
  • biYPelsPerMeter : VVWVIDEO
  • bottom : RECT16


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • cbSize : VVWAUDIO
  • cfFlags : MEDIACMD
  • ctCmd : MEDIACMD


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • dwAFrame : VVWINFO
  • dwAspectRatio : VVWINFO
  • dwAudChan : DCLIP
  • dwAudioChannels : MEDIACMD
  • dwBlackGain : VVWINFO
  • dwBlackPoint : VVWINFO
  • dwBreakPoint : VVWINFO
  • dwBufferLength : DFRAME
  • dwBytesUsed : DFRAME
  • dwCaps : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwCCData : FRAME_INFO
  • dwChannel : MEDIACMD
  • dwChannelID : DRASTIC_CHANNEL
  • dwClipAux : DCLIP
  • dwClipEnd : DCLIP
  • dwClipID : DCLIP
  • dwClipIn : DCLIP
  • dwClipOut : DCLIP
  • dwClipStart : DCLIP
  • dwCmdAlt : MEDIACMD
  • dwCmdID : MEDIACMD
  • dwConversions : VVWINFO
  • dwDrFlags : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwEditCount : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwEnd : MEDIACMD
  • dwExpireMS : DFRAME
  • dwFileDate : VVWINFO
  • dwFileSize : VVWINFO
  • dwFileTime : VVWINFO
  • dwFileType : VVWINFO, VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwFilmManufacturerCode : VVWINFO
  • dwFilmTypeCode : VVWINFO
  • dwFlags : VVWINFO, VVWAUDIO, VVWVIDEO, VVWSYSTEM, DFRAME
  • dwFormatChangeCount : VVWAUDIO, VVWVIDEO
  • dwFrame : FRAME_INFO
  • dwGamma1000 : VVWINFO
  • dwHeight : VVWSYSTEM
  • dwInfChan : DCLIP
  • dwInfoChannels : MEDIACMD
  • dwInitialFrames : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwLastUpdate : DRASTIC_CHANNEL
  • dwLength : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwLtcFrame : FRAME_INFO
  • dwLTCTimeCodeType : VVWINFO
  • dwLtcUb : FRAME_INFO
  • dwMaxBytesPerSec : VVWSYSTEM
  • dwMfCaps : VVWSYSTEM
  • dwMicroSecPerFrame : VVWSYSTEM
  • dwNU_31 : VVWINFO
  • dwNU_32 : VVWINFO
  • dwNU_33 : VVWINFO
  • dwNU_34 : VVWINFO
  • dwNU_35 : VVWINFO
  • dwNU_36 : VVWINFO
  • dwNU_37 : VVWINFO
  • dwNU_38 : VVWINFO
  • dwNU_39 : VVWINFO
  • dwNU_40 : VVWINFO
  • dwNU_41 : VVWINFO
  • dwNU_42 : VVWINFO
  • dwNU_43 : VVWINFO
  • dwNU_44 : VVWINFO
  • dwNU_45 : VVWINFO
  • dwNU_46 : VVWINFO
  • dwNU_47 : VVWINFO
  • dwNU_48 : VVWINFO
  • dwNU_49 : VVWINFO
  • dwOriginalRate : VVWINFO
  • dwOriginalScale : VVWINFO
  • dwPaddingGranularity : VVWSYSTEM
  • dwPosition : MEDIACMD
  • dwPosterFrame : VVWINFO
  • dwPresentationMS : DFRAME
  • dwQuality : VVWAUDIO, VVWVIDEO
  • dwRate : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwRepIndex : DFRAME
  • dwReps : DFRAME
  • dwResDrastic : VVWINFO, VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwReserved : VVWAUDIO, VVWVIDEO, VVWSYSTEM, DFRAME
  • dwReservedMustBe0 : VVWINFO
  • dwSampleSize : VVWAUDIO, VVWVIDEO
  • dwScale : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwSequenceNumber : VVWINFO
  • dwSize : DFRAME
  • dwSpeed : DFRAME
  • dwStart : VVWAUDIO, VVWVIDEO, MEDIACMD
  • dwStreams : VVWSYSTEM
  • dwStructSize : MEDIACMD
  • dwSuggestedBufferSize : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwTagNumber : VVWINFO
  • dwTimeCode : VVWINFO
  • dwTimeCodeType : VVWINFO
  • dwTotalFrames : VVWSYSTEM
  • dwTotalLength : VVWINFO
  • dwTotalStreams : VVWINFO
  • dwType : VVWSYSTEM, DFRAME
  • dwUser : DFRAME
  • dwUserBits : VVWINFO
  • dwVersionNumber : VVWINFO
  • dwVidChan : DCLIP
  • dwVideoChannels : MEDIACMD
  • dwVidStandard : VVWSYSTEM
  • dwVitcAux : FRAME_INFO
  • dwVitcFrame : FRAME_INFO
  • dwVITCLine3 : VVWINFO
  • dwVITCTimeCode : VVWINFO
  • dwVITCTimeCodeType : VVWINFO
  • dwVitcUb : FRAME_INFO
  • dwVITCUserBits : VVWINFO
  • dwWhitePoint : VVWINFO
  • dwWidth : VVWSYSTEM


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • fccHandler : VVWAUDIO, VVWVIDEO
  • fccType : VVWAUDIO, VVWVIDEO
  • fi : DFRAME, DRASTIC_CHANNEL


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • pdwFrame : DRASTIC_CHANNEL
  • pList : DFRAME, MEDIACMD
  • pNext : DFRAME, MEDIACMD
  • pOwnerHandle : DRASTIC_CHANNEL
  • pPrev : DFRAME, MEDIACMD


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • rcFrame : VVWAUDIO, VVWVIDEO
  • resdata : DFRAME
  • right : RECT16


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • szAlbum : VVWINFO
  • szArtist : VVWINFO
  • szAuthor : VVWINFO
  • szCamRoll : VVWINFO
  • szCategory : VVWINFO
  • szChannel : VVWINFO
  • szChannelDescription : VVWINFO
  • szChannelName : VVWINFO
  • szClipName : DCLIP
  • szComment : DCLIP
  • szComments : VVWINFO
  • szComposer : VVWINFO
  • szCopyright : VVWINFO
  • szCreationData : VVWINFO
  • szDailyRoll : VVWINFO
  • szDescription : VVWINFO
  • szDeviceModelNum : VVWINFO
  • szDeviceSerialNum : VVWINFO
  • szDirector : VVWINFO
  • szDisclaimer : VVWINFO
  • szDoNotUse : VVWINFO
  • szEditData1 : VVWINFO
  • szEditData2 : VVWINFO
  • szEditData3 : VVWINFO
  • szEditData4 : VVWINFO
  • szEditData5 : VVWINFO
  • szEditData6 : VVWINFO
  • szEditData7 : VVWINFO
  • szEditData8 : VVWINFO
  • szEditData9 : VVWINFO
  • szEditor : VVWINFO
  • szEncodedBy : VVWINFO
  • szEpisode : VVWINFO
  • szFileName : VVWINFO
  • szFileType : VVWSYSTEM
  • szFormat : VVWINFO
  • szFrameAttribute : VVWINFO
  • szFullName : VVWINFO
  • szGenre : VVWINFO
  • szHostComputer : VVWINFO
  • szInformation : VVWINFO
  • szInkNumberPrefix : VVWINFO
  • szInputDevice : VVWINFO
  • szIP : VVWINFO
  • szKeyNumberPrefix : VVWINFO
  • szKeywords : VVWINFO
  • szLabRoll : VVWINFO
  • szLanguage : VVWINFO
  • szMake : VVWINFO
  • szManufacturer : VVWINFO
  • szModel : VVWINFO
  • szName : VVWAUDIO, VVWVIDEO, DCLIP
  • szNativeLocator : VVWINFO
  • szNU_81 : VVWINFO
  • szNU_82 : VVWINFO
  • szNU_83 : VVWINFO
  • szNU_84 : VVWINFO
  • szNU_85 : VVWINFO
  • szNU_86 : VVWINFO
  • szNU_87 : VVWINFO
  • szNU_88 : VVWINFO
  • szNU_89 : VVWINFO
  • szNU_90 : VVWINFO
  • szNU_91 : VVWINFO
  • szNU_92 : VVWINFO
  • szNU_93 : VVWINFO
  • szNU_94 : VVWINFO
  • szNU_95 : VVWINFO
  • szNU_96 : VVWINFO
  • szNU_97 : VVWINFO
  • szNU_98 : VVWINFO
  • szNU_99 : VVWINFO
  • szOriginalArtist : VVWINFO
  • szOriginalFormat : VVWINFO
  • szOwner : VVWINFO
  • szPerformers : VVWINFO
  • szPictureIcon : VVWINFO
  • szProduced : VVWINFO
  • szProducer : VVWINFO
  • szProduct : VVWINFO
  • szProject : VVWINFO
  • szProxyFile : VVWINFO
  • szRatings : VVWINFO
  • szReel : VVWINFO, DCLIP
  • szRevisionNumber : VVWINFO
  • szScene : VVWINFO
  • szShot : VVWINFO
  • szSlateInfo : VVWINFO
  • szSoftware : VVWINFO
  • szSoundRoll : VVWINFO
  • szSource : VVWINFO
  • szSourceLocator : VVWINFO
  • szSpecialPlaybackRequirements : VVWINFO
  • szStatus : VVWINFO
  • szSubject : VVWINFO
  • szSupplier : VVWINFO
  • szTake : VVWINFO
  • szTitle : VVWINFO
  • szTrack : VVWINFO
  • szUniversalName : VVWINFO
  • szURLLink : VVWINFO
  • szVersionString : VVWINFO
  • szWarning : VVWINFO


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • top : RECT16


MediaCmd: Data Fields

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • wBitsPerSample : VVWAUDIO
  • wFormatTag : VVWAUDIO
  • wLanguage : VVWAUDIO, VVWVIDEO
  • wPriority : VVWAUDIO, VVWVIDEO


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- a -

  • arbID : MEDIACMD


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- l -

  • left : RECT16
  • lpData : DFRAME
  • lSpeed : MEDIACMD


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- m -

  • mCmd : DRASTIC_CHANNEL


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- n -

  • nAvgBytesPerSec : VVWAUDIO
  • nBlockAlign : VVWAUDIO
  • nChannels : VVWAUDIO
  • nSamplesPerSec : VVWAUDIO


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- b -

  • biBitCount : VVWVIDEO
  • biClrImportant : VVWVIDEO
  • biClrUsed : VVWVIDEO
  • biCompression : VVWVIDEO
  • biHeight : VVWVIDEO
  • biPitch : VVWVIDEO
  • biPlanes : VVWVIDEO
  • biSize : VVWVIDEO
  • biSizeImage : VVWVIDEO
  • biUnused : VVWAUDIO
  • biWidth : VVWVIDEO
  • biXPelsPerMeter : VVWVIDEO
  • biYPelsPerMeter : VVWVIDEO
  • bottom : RECT16


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- c -

  • cbSize : VVWAUDIO
  • cfFlags : MEDIACMD
  • ctCmd : MEDIACMD


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- d -

  • dwAFrame : VVWINFO
  • dwAspectRatio : VVWINFO
  • dwAudChan : DCLIP
  • dwAudioChannels : MEDIACMD
  • dwBlackGain : VVWINFO
  • dwBlackPoint : VVWINFO
  • dwBreakPoint : VVWINFO
  • dwBufferLength : DFRAME
  • dwBytesUsed : DFRAME
  • dwCaps : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwCCData : FRAME_INFO
  • dwChannel : MEDIACMD
  • dwChannelID : DRASTIC_CHANNEL
  • dwClipAux : DCLIP
  • dwClipEnd : DCLIP
  • dwClipID : DCLIP
  • dwClipIn : DCLIP
  • dwClipOut : DCLIP
  • dwClipStart : DCLIP
  • dwCmdAlt : MEDIACMD
  • dwCmdID : MEDIACMD
  • dwConversions : VVWINFO
  • dwDrFlags : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwEditCount : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwEnd : MEDIACMD
  • dwExpireMS : DFRAME
  • dwFileDate : VVWINFO
  • dwFileSize : VVWINFO
  • dwFileTime : VVWINFO
  • dwFileType : VVWINFO, VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwFilmManufacturerCode : VVWINFO
  • dwFilmTypeCode : VVWINFO
  • dwFlags : VVWINFO, VVWAUDIO, VVWVIDEO, VVWSYSTEM, DFRAME
  • dwFormatChangeCount : VVWAUDIO, VVWVIDEO
  • dwFrame : FRAME_INFO
  • dwGamma1000 : VVWINFO
  • dwHeight : VVWSYSTEM
  • dwInfChan : DCLIP
  • dwInfoChannels : MEDIACMD
  • dwInitialFrames : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwLastUpdate : DRASTIC_CHANNEL
  • dwLength : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwLtcFrame : FRAME_INFO
  • dwLTCTimeCodeType : VVWINFO
  • dwLtcUb : FRAME_INFO
  • dwMaxBytesPerSec : VVWSYSTEM
  • dwMfCaps : VVWSYSTEM
  • dwMicroSecPerFrame : VVWSYSTEM
  • dwNU_31 : VVWINFO
  • dwNU_32 : VVWINFO
  • dwNU_33 : VVWINFO
  • dwNU_34 : VVWINFO
  • dwNU_35 : VVWINFO
  • dwNU_36 : VVWINFO
  • dwNU_37 : VVWINFO
  • dwNU_38 : VVWINFO
  • dwNU_39 : VVWINFO
  • dwNU_40 : VVWINFO
  • dwNU_41 : VVWINFO
  • dwNU_42 : VVWINFO
  • dwNU_43 : VVWINFO
  • dwNU_44 : VVWINFO
  • dwNU_45 : VVWINFO
  • dwNU_46 : VVWINFO
  • dwNU_47 : VVWINFO
  • dwNU_48 : VVWINFO
  • dwNU_49 : VVWINFO
  • dwOriginalRate : VVWINFO
  • dwOriginalScale : VVWINFO
  • dwPaddingGranularity : VVWSYSTEM
  • dwPosition : MEDIACMD
  • dwPosterFrame : VVWINFO
  • dwPresentationMS : DFRAME
  • dwQuality : VVWAUDIO, VVWVIDEO
  • dwRate : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwRepIndex : DFRAME
  • dwReps : DFRAME
  • dwResDrastic : VVWINFO, VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwReserved : VVWAUDIO, VVWVIDEO, VVWSYSTEM, DFRAME
  • dwReservedMustBe0 : VVWINFO
  • dwSampleSize : VVWAUDIO, VVWVIDEO
  • dwScale : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwSequenceNumber : VVWINFO
  • dwSize : DFRAME
  • dwSpeed : DFRAME
  • dwStart : VVWAUDIO, VVWVIDEO, MEDIACMD
  • dwStreams : VVWSYSTEM
  • dwStructSize : MEDIACMD
  • dwSuggestedBufferSize : VVWAUDIO, VVWVIDEO, VVWSYSTEM
  • dwTagNumber : VVWINFO
  • dwTimeCode : VVWINFO
  • dwTimeCodeType : VVWINFO
  • dwTotalFrames : VVWSYSTEM
  • dwTotalLength : VVWINFO
  • dwTotalStreams : VVWINFO
  • dwType : VVWSYSTEM, DFRAME
  • dwUser : DFRAME
  • dwUserBits : VVWINFO
  • dwVersionNumber : VVWINFO
  • dwVidChan : DCLIP
  • dwVideoChannels : MEDIACMD
  • dwVidStandard : VVWSYSTEM
  • dwVitcAux : FRAME_INFO
  • dwVitcFrame : FRAME_INFO
  • dwVITCLine3 : VVWINFO
  • dwVITCTimeCode : VVWINFO
  • dwVITCTimeCodeType : VVWINFO
  • dwVitcUb : FRAME_INFO
  • dwVITCUserBits : VVWINFO
  • dwWhitePoint : VVWINFO
  • dwWidth : VVWSYSTEM


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- f -

  • fccHandler : VVWAUDIO, VVWVIDEO
  • fccType : VVWAUDIO, VVWVIDEO
  • fi : DFRAME, DRASTIC_CHANNEL


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- p -

  • pdwFrame : DRASTIC_CHANNEL
  • pList : DFRAME, MEDIACMD
  • pNext : DFRAME, MEDIACMD
  • pOwnerHandle : DRASTIC_CHANNEL
  • pPrev : DFRAME, MEDIACMD


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- r -

  • rcFrame : VVWAUDIO, VVWVIDEO
  • resdata : DFRAME
  • right : RECT16


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- s -

  • szAlbum : VVWINFO
  • szArtist : VVWINFO
  • szAuthor : VVWINFO
  • szCamRoll : VVWINFO
  • szCategory : VVWINFO
  • szChannel : VVWINFO
  • szChannelDescription : VVWINFO
  • szChannelName : VVWINFO
  • szClipName : DCLIP
  • szComment : DCLIP
  • szComments : VVWINFO
  • szComposer : VVWINFO
  • szCopyright : VVWINFO
  • szCreationData : VVWINFO
  • szDailyRoll : VVWINFO
  • szDescription : VVWINFO
  • szDeviceModelNum : VVWINFO
  • szDeviceSerialNum : VVWINFO
  • szDirector : VVWINFO
  • szDisclaimer : VVWINFO
  • szDoNotUse : VVWINFO
  • szEditData1 : VVWINFO
  • szEditData2 : VVWINFO
  • szEditData3 : VVWINFO
  • szEditData4 : VVWINFO
  • szEditData5 : VVWINFO
  • szEditData6 : VVWINFO
  • szEditData7 : VVWINFO
  • szEditData8 : VVWINFO
  • szEditData9 : VVWINFO
  • szEditor : VVWINFO
  • szEncodedBy : VVWINFO
  • szEpisode : VVWINFO
  • szFileName : VVWINFO
  • szFileType : VVWSYSTEM
  • szFormat : VVWINFO
  • szFrameAttribute : VVWINFO
  • szFullName : VVWINFO
  • szGenre : VVWINFO
  • szHostComputer : VVWINFO
  • szInformation : VVWINFO
  • szInkNumberPrefix : VVWINFO
  • szInputDevice : VVWINFO
  • szIP : VVWINFO
  • szKeyNumberPrefix : VVWINFO
  • szKeywords : VVWINFO
  • szLabRoll : VVWINFO
  • szLanguage : VVWINFO
  • szMake : VVWINFO
  • szManufacturer : VVWINFO
  • szModel : VVWINFO
  • szName : VVWAUDIO, VVWVIDEO, DCLIP
  • szNativeLocator : VVWINFO
  • szNU_81 : VVWINFO
  • szNU_82 : VVWINFO
  • szNU_83 : VVWINFO
  • szNU_84 : VVWINFO
  • szNU_85 : VVWINFO
  • szNU_86 : VVWINFO
  • szNU_87 : VVWINFO
  • szNU_88 : VVWINFO
  • szNU_89 : VVWINFO
  • szNU_90 : VVWINFO
  • szNU_91 : VVWINFO
  • szNU_92 : VVWINFO
  • szNU_93 : VVWINFO
  • szNU_94 : VVWINFO
  • szNU_95 : VVWINFO
  • szNU_96 : VVWINFO
  • szNU_97 : VVWINFO
  • szNU_98 : VVWINFO
  • szNU_99 : VVWINFO
  • szOriginalArtist : VVWINFO
  • szOriginalFormat : VVWINFO
  • szOwner : VVWINFO
  • szPerformers : VVWINFO
  • szPictureIcon : VVWINFO
  • szProduced : VVWINFO
  • szProducer : VVWINFO
  • szProduct : VVWINFO
  • szProject : VVWINFO
  • szProxyFile : VVWINFO
  • szRatings : VVWINFO
  • szReel : VVWINFO, DCLIP
  • szRevisionNumber : VVWINFO
  • szScene : VVWINFO
  • szShot : VVWINFO
  • szSlateInfo : VVWINFO
  • szSoftware : VVWINFO
  • szSoundRoll : VVWINFO
  • szSource : VVWINFO
  • szSourceLocator : VVWINFO
  • szSpecialPlaybackRequirements : VVWINFO
  • szStatus : VVWINFO
  • szSubject : VVWINFO
  • szSupplier : VVWINFO
  • szTake : VVWINFO
  • szTitle : VVWINFO
  • szTrack : VVWINFO
  • szUniversalName : VVWINFO
  • szURLLink : VVWINFO
  • szVersionString : VVWINFO
  • szWarning : VVWINFO


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- t -

  • top : RECT16


MediaCmd: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Class Hierarchy
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • f
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- w -

  • wBitsPerSample : VVWAUDIO
  • wFormatTag : VVWAUDIO
  • wLanguage : VVWAUDIO, VVWVIDEO
  • wPriority : VVWAUDIO, VVWVIDEO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • MASK___DRFLAGS_FIELD : vvwtypes.h
  • MASK___DRFLAGS_KEYFRAME : vvwtypes.h
  • MASK___DRFLAGS_VTYPE : vvwtypes.h
  • MASK___FCCMODIFIERS : vvwtypes.h
  • MASK___PREVIEW : vvwtypes.h
  • MASK__CODECPRIVATEDATA : vvwtypes.h
  • MB_CODEC_DESC_LEN : vvwtypes.h
  • MB_CODEC_SHORT_LEN : vvwtypes.h
  • MB_FILE_DESC_LEN : vvwtypes.h
  • MB_FILE_EXT_LEN : vvwtypes.h
  • MB_FILE_SHORT_LEN : vvwtypes.h
  • MEDIACMD_CHECK_MASK : mediacmd.h
  • MEDIACMD_CHECK_VER : mediacmd.h
  • MEDIACMD_CURRENT : mediacmd.h
  • MEDIACMD_VERSION_MAJOR : mediacmd.h
  • MEDIACMD_VERSION_MASK : mediacmd.h
  • MEDIACMD_VERSION_MINOR : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • audChan0 : mediacmd.h
  • audChan1 : mediacmd.h
  • audChan10 : mediacmd.h
  • audChan11 : mediacmd.h
  • audChan12 : mediacmd.h
  • audChan13 : mediacmd.h
  • audChan14 : mediacmd.h
  • audChan15 : mediacmd.h
  • audChan16 : mediacmd.h
  • audChan17 : mediacmd.h
  • audChan18 : mediacmd.h
  • audChan19 : mediacmd.h
  • audChan2 : mediacmd.h
  • audChan20 : mediacmd.h
  • audChan21 : mediacmd.h
  • audChan22 : mediacmd.h
  • audChan23 : mediacmd.h
  • audChan24 : mediacmd.h
  • audChan25 : mediacmd.h
  • audChan26 : mediacmd.h
  • audChan27 : mediacmd.h
  • audChan28 : mediacmd.h
  • audChan29 : mediacmd.h
  • audChan3 : mediacmd.h
  • audChan30 : mediacmd.h
  • audChan31 : mediacmd.h
  • audChan4 : mediacmd.h
  • audChan5 : mediacmd.h
  • audChan6 : mediacmd.h
  • audChan7 : mediacmd.h
  • audChan8 : mediacmd.h
  • audChan9 : mediacmd.h
  • audChanAll : mediacmd.h


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • cfConvert : mediacmd.h
  • cfCopy : mediacmd.h
  • cfDeferred : mediacmd.h
  • cfFields : mediacmd.h
  • cfInvert : mediacmd.h
  • cfIsShuttle : mediacmd.h
  • cfLoop : mediacmd.h
  • cfNoClipFiles : mediacmd.h
  • cfNoReturn : mediacmd.h
  • cfNoTCSpaces : mediacmd.h
  • cfOverideDeferred : mediacmd.h
  • cfPreview : mediacmd.h
  • cfRipple : mediacmd.h
  • cfTest : mediacmd.h
  • cfTimeHouseClock : mediacmd.h
  • cfTimeMs : mediacmd.h
  • cfTimeTarget : mediacmd.h
  • cfTrigger : mediacmd.h
  • cfUseAllIDs : mediacmd.h
  • cfUseClipID : mediacmd.h
  • cfUseCmdAlt : mediacmd.h
  • cfUseEnd : mediacmd.h
  • cfUseEndOffset : mediacmd.h
  • cfUseFrameCount : mediacmd.h
  • cfUsePosition : mediacmd.h
  • cfUsePositionOffset : mediacmd.h
  • cfUsePresets : mediacmd.h
  • cfUseSpeed : mediacmd.h
  • cfUseStart : mediacmd.h
  • cfUseStartOffset : mediacmd.h
  • cfUsingCurrent : mediacmd.h
  • CHAN_ILLEGAL : mediacmd.h
  • CMD_MAX_CLIP_ID_LEN : mediacmd.h
  • CMD_QUEUE_ELEMSIZE : mediacmd.h
  • cmdaltNearestKeyFrame : mediacmd.h
  • cmdaltNextKeyFrame : mediacmd.h
  • cmdaltPrevKeyFrame : mediacmd.h
  • cmdaltStartOfMessage : mediacmd.h
  • cmdAudChan : mediacmd.h
  • cmdFlags : mediacmd.h
  • cmdGetSetValue : mediacmd.h
  • cmdinf : mediacmd.h
  • CmdQueueElem : mediacmd.h
  • cmdType : mediacmd.h
  • cmdVidChan : mediacmd.h
  • ctAbort : mediacmd.h
  • ctBlank : mediacmd.h
  • ctChanSelect : mediacmd.h
  • ctDelete : mediacmd.h
  • ctEject : mediacmd.h
  • ctError : mediacmd.h
  • ctGetState : mediacmd.h
  • ctGetValue : mediacmd.h
  • ctInsert : mediacmd.h
  • ctPause : mediacmd.h
  • ctPlay : mediacmd.h
  • ctRecord : mediacmd.h
  • ctRecStop : mediacmd.h
  • ctSetState : mediacmd.h
  • ctSetValue : mediacmd.h
  • ctStop : mediacmd.h
  • ctTerminate : mediacmd.h
  • ctTransfer : mediacmd.h
  • ctTrim : mediacmd.h
  • ctValueSupported : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • DECLARE_DRASTIC_CHANNEL : vvwtypes.h
  • DECLARE_MEDIACMD : mediacmd.h
  • DFRAME_FIELD_INVERT : vvwtypes.h
  • DFRAME_LARGE_AUDIO : vvwtypes.h
  • DFRAME_NEW_FORMAT : vvwtypes.h
  • DFRAME_ORIENTATION_INVERT : vvwtypes.h
  • DFRAME_PROGRESSIVE : vvwtypes.h
  • DFRAME_SKIP_FRAME : vvwtypes.h
  • DFRAME_TIME_INVERT : vvwtypes.h
  • DFRAME_TYPE_AUDIO : vvwtypes.h
  • DFRAME_TYPE_FI_PTR_DATA : vvwtypes.h
  • DFRAME_TYPE_KEYFRAME : vvwtypes.h
  • DFRAME_TYPE_KEYFRAME_B : vvwtypes.h
  • DFRAME_TYPE_KEYFRAME_I : vvwtypes.h
  • DFRAME_TYPE_KEYFRAME_P : vvwtypes.h
  • DFRAME_TYPE_NOTPHYSHEAP : vvwtypes.h
  • DFRAME_TYPE_PAUSE : vvwtypes.h
  • DFRAME_TYPE_PLAY : vvwtypes.h
  • DFRAME_TYPE_RECORD : vvwtypes.h
  • DFRAME_TYPE_VIDEO : vvwtypes.h
  • DRFLAGS_CODECPRIVATEDATA_AVI : vvwtypes.h
  • DRFLAGS_CODECPRIVATEDATA_MOV : vvwtypes.h
  • DRFLAGS_CODECPRIVATEDATA_OMF : vvwtypes.h
  • DRFLAGS_FCC_MJPG_DCx0 : vvwtypes.h
  • DRFLAGS_FCC_MJPG_DIGISUITE : vvwtypes.h
  • DRFLAGS_FCC_MJPG_DSEDIT : vvwtypes.h
  • DRFLAGS_FCC_MJPG_JFIF : vvwtypes.h
  • DRFLAGS_FCC_MJPG_JPGDIB : vvwtypes.h
  • DRFLAGS_FCC_USE_ICM : vvwtypes.h
  • DRFLAGS_FCC_USE_INTERN : vvwtypes.h
  • DRFLAGS_FCC_USE_QT : vvwtypes.h
  • DRFLAGS_FIRST_FIELD_DOMINANT : vvwtypes.h
  • DRFLAGS_HAS_KEYFRAMES : vvwtypes.h
  • DRFLAGS_NOT_QUICKCLIP : vvwtypes.h
  • DRFLAGS_VTYPE_INTERLACED : vvwtypes.h
  • DRFLAGS_VTYPE_PROGRESSIVE : vvwtypes.h
  • DRFLAGS_VTYPE_SEGMENTEDFRAME : vvwtypes.h
  • DRFLAGS_ZERO_FIELD_DOMINANT : vvwtypes.h
  • DTVHDR_DONE : vvwtypes.h
  • DTVHDR_INQUEUE : vvwtypes.h
  • DTVHDR_KEYFRAME : vvwtypes.h
  • DTVHDR_PREPARED : vvwtypes.h
  • DTVVW_PREVIEW : vvwtypes.h
  • DTWAVE_FORMAT_PCM : vvwtypes.h
  • DTWHDR_BEGINLOOP : vvwtypes.h
  • DTWHDR_DONE : vvwtypes.h
  • DTWHDR_ENDLOOP : vvwtypes.h
  • DTWHDR_INQUEUE : vvwtypes.h
  • DTWHDR_PREPARED : vvwtypes.h
  • dwFI_DataAreaSize : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • FCN_VVW_CLOSE : vvw.h
  • FCN_VVW_CMD : vvw.h
  • FCN_VVW_CONFIGURE : vvw.h
  • FCN_VVW_INIT : vvw.h
  • FCN_VVW_INIT_INT : vvw.h
  • FCN_VVW_OPEN : vvw.h
  • FCN_VVW_QUIT : vvw.h
  • FCN_VVW_SETMEDIACMD : vvw.h
  • FCN_VVW_START : vvw.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • GetAudio : vvwtypes.h
  • GetCurrent : vvwtypes.h
  • GetInf : vvwtypes.h
  • GetNoFail : vvwtypes.h
  • GetQueued : vvwtypes.h
  • GetVideo : vvwtypes.h
  • GS_ALPHACHROMA_ALPHA : mediacmd.h
  • GS_ALPHACHROMA_DUAL : mediacmd.h
  • GS_ALPHACHROMA_SINGLE : mediacmd.h
  • GS_ANALOGMONITORMETHOD_DIRECT : mediacmd.h
  • GS_ANALOGMONITORMETHOD_FLIP1080 : mediacmd.h
  • GS_ANALOGMONITORMETHOD_FLIP720 : mediacmd.h
  • GS_ANALOGMONITORMETHOD_HD1080 : mediacmd.h
  • GS_ANALOGMONITORMETHOD_HD720 : mediacmd.h
  • GS_ANALOGMONITORMETHOD_SD : mediacmd.h
  • GS_ASPECT_RATIO_16x9 : mediacmd.h
  • GS_ASPECT_RATIO_2_21x1 : mediacmd.h
  • GS_ASPECT_RATIO_4x3 : mediacmd.h
  • GS_ASPECT_RATIO_SQUARE : mediacmd.h
  • GS_ASSEMBLE_EDIT : mediacmd.h
  • GS_AUD_BIT_RATE_112000 : mediacmd.h
  • GS_AUD_BIT_RATE_128000 : mediacmd.h
  • GS_AUD_BIT_RATE_160000 : mediacmd.h
  • GS_AUD_BIT_RATE_192000 : mediacmd.h
  • GS_AUD_BIT_RATE_224000 : mediacmd.h
  • GS_AUD_BIT_RATE_256000 : mediacmd.h
  • GS_AUD_BIT_RATE_32000 : mediacmd.h
  • GS_AUD_BIT_RATE_320000 : mediacmd.h
  • GS_AUD_BIT_RATE_384000 : mediacmd.h
  • GS_AUD_BIT_RATE_41100 : mediacmd.h
  • GS_AUD_BIT_RATE_48000 : mediacmd.h
  • GS_AUD_BIT_RATE_56000 : mediacmd.h
  • GS_AUD_BIT_RATE_64000 : mediacmd.h
  • GS_AUD_BIT_RATE_80000 : mediacmd.h
  • GS_AUD_BIT_RATE_96000 : mediacmd.h
  • GS_AUD_DUAL : mediacmd.h
  • GS_AUD_HEADROOM_18 : mediacmd.h
  • GS_AUD_HEADROOM_20 : mediacmd.h
  • GS_AUD_JOINT_STEREO : mediacmd.h
  • GS_AUD_MULTIPLE : mediacmd.h
  • GS_AUD_SINGLE : mediacmd.h
  • GS_AUD_STEREO : mediacmd.h
  • GS_AUDSELECT_AES_EBU : mediacmd.h
  • GS_AUDSELECT_AES_EBU_PRO : mediacmd.h
  • GS_AUDSELECT_BALANCED_10 : mediacmd.h
  • GS_AUDSELECT_BALANCED_4 : mediacmd.h
  • GS_AUDSELECT_EMBEDDED : mediacmd.h
  • GS_AUDSELECT_NONE : mediacmd.h
  • GS_AUDSELECT_SILENT : mediacmd.h
  • GS_AUDSELECT_SPDIF : mediacmd.h
  • GS_AUDSELECT_UNBALANCED_10 : mediacmd.h
  • GS_AUDSELECT_UNBALANCED_4 : mediacmd.h
  • GS_BAD_PARAM : mediacmd.h
  • GS_BITCOUNT_10 : mediacmd.h
  • GS_BITCOUNT_12 : mediacmd.h
  • GS_BITCOUNT_24 : mediacmd.h
  • GS_BITCOUNT_30 : mediacmd.h
  • GS_BITCOUNT_32 : mediacmd.h
  • GS_BITCOUNT_8 : mediacmd.h
  • GS_CHANCAP_ALL : mediacmd.h
  • GS_CHANCAP_AUDPREVIEW : mediacmd.h
  • GS_CHANCAP_CLIPSPACE : mediacmd.h
  • GS_CHANCAP_EDIT : mediacmd.h
  • GS_CHANCAP_EJECT : mediacmd.h
  • GS_CHANCAP_ERROR : mediacmd.h
  • GS_CHANCAP_ETOE : mediacmd.h
  • GS_CHANCAP_FILE : mediacmd.h
  • GS_CHANCAP_JOG : mediacmd.h
  • GS_CHANCAP_LOOP : mediacmd.h
  • GS_CHANCAP_MPEG_ENC : mediacmd.h
  • GS_CHANCAP_NET : mediacmd.h
  • GS_CHANCAP_PAUSE : mediacmd.h
  • GS_CHANCAP_PLAY : mediacmd.h
  • GS_CHANCAP_PREVIEW : mediacmd.h
  • GS_CHANCAP_RECORD : mediacmd.h
  • GS_CHANCAP_RECSTOP : mediacmd.h
  • GS_CHANCAP_REVPLAY : mediacmd.h
  • GS_CHANCAP_SEEK : mediacmd.h
  • GS_CHANCAP_SELECTPRESET : mediacmd.h
  • GS_CHANCAP_SHUTTLE : mediacmd.h
  • GS_CHANCAP_STOP : mediacmd.h
  • GS_CHANCAP_TCSPACE : mediacmd.h
  • GS_CHANCAP_VGAPREVIEW : mediacmd.h
  • GS_CHROMA_FORMAT_411 : mediacmd.h
  • GS_CHROMA_FORMAT_420 : mediacmd.h
  • GS_CHROMA_FORMAT_422 : mediacmd.h
  • GS_CHROMA_FORMAT_444 : mediacmd.h
  • GS_CLIPMODE_CLIPSPACE : mediacmd.h
  • GS_CLIPMODE_FILM : mediacmd.h
  • GS_CLIPMODE_ILLEGAL : mediacmd.h
  • GS_CLIPMODE_SINGLE : mediacmd.h
  • GS_CLIPMODE_TCSPACE : mediacmd.h
  • GS_CLRFRM_2FLD : mediacmd.h
  • GS_CLRFRM_4FLD : mediacmd.h
  • GS_CLRFRM_8FLD : mediacmd.h
  • GS_CLRFRM_DEFAULT : mediacmd.h
  • GS_COMPTYPE_ABGR : mediacmd.h
  • GS_COMPTYPE_ARGB : mediacmd.h
  • GS_COMPTYPE_BGR : mediacmd.h
  • GS_COMPTYPE_BGRA : mediacmd.h
  • GS_COMPTYPE_BGRA_INVERT : mediacmd.h
  • GS_COMPTYPE_DV100 : mediacmd.h
  • GS_COMPTYPE_DV25 : mediacmd.h
  • GS_COMPTYPE_DV50 : mediacmd.h
  • GS_COMPTYPE_DVSD : mediacmd.h
  • GS_COMPTYPE_HDPAN : mediacmd.h
  • GS_COMPTYPE_HDSONY : mediacmd.h
  • GS_COMPTYPE_MJPEG : mediacmd.h
  • GS_COMPTYPE_MPEG1 : mediacmd.h
  • GS_COMPTYPE_MPEG2 : mediacmd.h
  • GS_COMPTYPE_MPEG2I : mediacmd.h
  • GS_COMPTYPE_MPEG2IBP : mediacmd.h
  • GS_COMPTYPE_RGB : mediacmd.h
  • GS_COMPTYPE_RGBA : mediacmd.h
  • GS_COMPTYPE_SOFTWARE : mediacmd.h
  • GS_COMPTYPE_UN10BIT : mediacmd.h
  • GS_COMPTYPE_UN8BIT : mediacmd.h
  • GS_COMPTYPE_WAVELET : mediacmd.h
  • GS_COMPTYPE_YCRCB_420 : mediacmd.h
  • GS_COMPTYPE_YCRCB_422 : mediacmd.h
  • GS_COMPTYPE_YCRCB_422_STEREO : mediacmd.h
  • GS_COMPTYPE_YCRCB_422A : mediacmd.h
  • GS_COMPTYPE_YCRCB_444 : mediacmd.h
  • GS_COMPTYPE_YCRCB_444A : mediacmd.h
  • GS_DEFAULT : mediacmd.h
  • GS_DISABLE : mediacmd.h
  • GS_DOWNCONVERT_ANAMORPHIC : mediacmd.h
  • GS_DOWNCONVERT_CROP : mediacmd.h
  • GS_DOWNCONVERT_LETTERBOX : mediacmd.h
  • GS_ENABLE : mediacmd.h
  • GS_FALSE : mediacmd.h
  • GS_FIELD : mediacmd.h
  • GS_FIELD1 : mediacmd.h
  • GS_FIELD2 : mediacmd.h
  • GS_FRAME : mediacmd.h
  • GS_FRAMEDATA_ASCII : mediacmd.h
  • GS_FRAMEDATA_CC_TTEXT : mediacmd.h
  • GS_FRAMEDATA_HEX : mediacmd.h
  • GS_FRAMEDATA_NAVY : mediacmd.h
  • GS_FRAMEDATA_TELECINE : mediacmd.h
  • GS_FRAMEDATA_UNKNOWN : mediacmd.h
  • GS_HEADSEL_DEFAULT : mediacmd.h
  • GS_HEADSEL_PLAY : mediacmd.h
  • GS_HEADSEL_RECPLAY : mediacmd.h
  • GS_INSERT_EDIT : mediacmd.h
  • GS_LOCKSRC_CVBS : mediacmd.h
  • GS_LOCKSRC_EXTIN : mediacmd.h
  • GS_LOCKSRC_IN_Y : mediacmd.h
  • GS_LOCKSRC_INPUT : mediacmd.h
  • GS_LOCKSRC_NONE : mediacmd.h
  • GS_LOCKSRC_SDI : mediacmd.h
  • GS_LOCKSRC_SVIDEO : mediacmd.h
  • GS_MONITORGRAB_NONE : mediacmd.h
  • GS_MONITORGRAB_SIZE_FULL : mediacmd.h
  • GS_MONITORGRAB_SIZE_HALF : mediacmd.h
  • GS_MONITORGRAB_SIZE_MASK : mediacmd.h
  • GS_MONITORGRAB_SIZE_QUARTER : mediacmd.h
  • GS_MONITORGRAB_TARGET_MASK : mediacmd.h
  • GS_MONITORGRAB_TO_HTTP : mediacmd.h
  • GS_MONITORGRAB_TO_MEMORY : mediacmd.h
  • GS_MONITORGRAB_TO_NETWORK : mediacmd.h
  • GS_MONITORGRAB_TO_UNC_PATH : mediacmd.h
  • GS_MONITORGRAB_TYPE_BMP : mediacmd.h
  • GS_MONITORGRAB_TYPE_JPG : mediacmd.h
  • GS_MONITORGRAB_TYPE_MASK : mediacmd.h
  • GS_MPEG_ASPECT_RATIO_16x9 : mediacmd.h
  • GS_MPEG_ASPECT_RATIO_2_21x1 : mediacmd.h
  • GS_MPEG_ASPECT_RATIO_4x3 : mediacmd.h
  • GS_MPEG_ASPECT_RATIO_SQUARE : mediacmd.h
  • GS_MPEG_CC_FORMAT_ATSC : mediacmd.h
  • GS_MPEG_CC_FORMAT_ATSC_REORDER : mediacmd.h
  • GS_MPEG_CC_FORMAT_CCUBE : mediacmd.h
  • GS_MPEG_CC_FORMAT_CCUBE_REORDER : mediacmd.h
  • GS_MPEG_CHROMA_FORMAT_420 : mediacmd.h
  • GS_MPEG_CHROMA_FORMAT_422 : mediacmd.h
  • GS_MPEG_CHROMA_FORMAT_444 : mediacmd.h
  • GS_MPEG_DC_PRECISION_10 : mediacmd.h
  • GS_MPEG_DC_PRECISION_11 : mediacmd.h
  • GS_MPEG_DC_PRECISION_8 : mediacmd.h
  • GS_MPEG_DC_PRECISION_9 : mediacmd.h
  • GS_MPEG_EIGHT_FRAMES : mediacmd.h
  • GS_MPEG_ELEVEN_FRAMES : mediacmd.h
  • GS_MPEG_FIFTEEN_FRAMES : mediacmd.h
  • GS_MPEG_FIVE_FRAMES : mediacmd.h
  • GS_MPEG_FOUR_FRAMES : mediacmd.h
  • GS_MPEG_FOURTEEN_FRAMES : mediacmd.h
  • GS_MPEG_LANGAUGE_CHINESE : mediacmd.h
  • GS_MPEG_LANGAUGE_DANISH : mediacmd.h
  • GS_MPEG_LANGAUGE_DUTCH : mediacmd.h
  • GS_MPEG_LANGAUGE_ENGLISH : mediacmd.h
  • GS_MPEG_LANGAUGE_FINNISH : mediacmd.h
  • GS_MPEG_LANGAUGE_FRENCH : mediacmd.h
  • GS_MPEG_LANGAUGE_GERMAN : mediacmd.h
  • GS_MPEG_LANGAUGE_GREEK : mediacmd.h
  • GS_MPEG_LANGAUGE_ITALIAN : mediacmd.h
  • GS_MPEG_LANGAUGE_JAPANESE : mediacmd.h
  • GS_MPEG_LANGAUGE_PORTUGUESE : mediacmd.h
  • GS_MPEG_LANGAUGE_RUSSIAN : mediacmd.h
  • GS_MPEG_LANGAUGE_SPANISH : mediacmd.h
  • GS_MPEG_LANGAUGE_SWEDISH : mediacmd.h
  • GS_MPEG_NINE_FRAMES : mediacmd.h
  • GS_MPEG_ONE_FRAMES : mediacmd.h
  • GS_MPEG_RESOLUTION_120 : mediacmd.h
  • GS_MPEG_RESOLUTION_240 : mediacmd.h
  • GS_MPEG_RESOLUTION_288 : mediacmd.h
  • GS_MPEG_RESOLUTION_352 : mediacmd.h
  • GS_MPEG_RESOLUTION_480 : mediacmd.h
  • GS_MPEG_RESOLUTION_512 : mediacmd.h
  • GS_MPEG_RESOLUTION_544 : mediacmd.h
  • GS_MPEG_RESOLUTION_576 : mediacmd.h
  • GS_MPEG_RESOLUTION_608 : mediacmd.h
  • GS_MPEG_RESOLUTION_704 : mediacmd.h
  • GS_MPEG_RESOLUTION_720 : mediacmd.h
  • GS_MPEG_SEVEN_FRAMES : mediacmd.h
  • GS_MPEG_SIX_FRAMES : mediacmd.h
  • GS_MPEG_SIXTEEN_FRAMES : mediacmd.h
  • GS_MPEG_STANDARD_ELEMENTARY : mediacmd.h
  • GS_MPEG_STANDARD_ELEMENTRY : mediacmd.h
  • GS_MPEG_STANDARD_PROGRAM : mediacmd.h
  • GS_MPEG_STANDARD_SYSTEM : mediacmd.h
  • GS_MPEG_STANDARD_TRANSPORT : mediacmd.h
  • GS_MPEG_TEN_FRAMES : mediacmd.h
  • GS_MPEG_THIRTEEN_FRAMES : mediacmd.h
  • GS_MPEG_THREE_FRAMES : mediacmd.h
  • GS_MPEG_TWELVE_FRAMES : mediacmd.h
  • GS_MPEG_TWO_FRAMES : mediacmd.h
  • GS_NOT_SUPPORTED : mediacmd.h
  • GS_PBEE_AUTO : mediacmd.h
  • GS_PBEE_DEFAULT : mediacmd.h
  • GS_PBEE_PB : mediacmd.h
  • GS_PROXYMODE_AFTERRECORD : mediacmd.h
  • GS_PROXYMODE_EVERYTHING : mediacmd.h
  • GS_PROXYMODE_NOTHING : mediacmd.h
  • GS_PROXYMODE_RECORD : mediacmd.h
  • GS_SERVOREF_AUTO : mediacmd.h
  • GS_SERVOREF_DEFAULT : mediacmd.h
  • GS_SERVOREF_EXT : mediacmd.h
  • GS_SIGFORM_1035i_30_260M : mediacmd.h
  • GS_SIGFORM_1035i_30X_260M : mediacmd.h
  • GS_SIGFORM_1080_24 : mediacmd.h
  • GS_SIGFORM_1080_24X : mediacmd.h
  • GS_SIGFORM_1080_25 : mediacmd.h
  • GS_SIGFORM_1080_30 : mediacmd.h
  • GS_SIGFORM_1080_30X : mediacmd.h
  • GS_SIGFORM_1080_50 : mediacmd.h
  • GS_SIGFORM_1080_60 : mediacmd.h
  • GS_SIGFORM_1080_60X : mediacmd.h
  • GS_SIGFORM_1080i_24 : mediacmd.h
  • GS_SIGFORM_1080i_24X : mediacmd.h
  • GS_SIGFORM_1080i_25 : mediacmd.h
  • GS_SIGFORM_1080i_30 : mediacmd.h
  • GS_SIGFORM_1080i_30X : mediacmd.h
  • GS_SIGFORM_1080sf_24 : mediacmd.h
  • GS_SIGFORM_1080sf_24X : mediacmd.h
  • GS_SIGFORM_720_24 : mediacmd.h
  • GS_SIGFORM_720_25 : mediacmd.h
  • GS_SIGFORM_720_30 : mediacmd.h
  • GS_SIGFORM_720_30X : mediacmd.h
  • GS_SIGFORM_720_50 : mediacmd.h
  • GS_SIGFORM_720_60 : mediacmd.h
  • GS_SIGFORM_720_60X : mediacmd.h
  • GS_SIGFORM_ALT_NTSC : mediacmd.h
  • GS_SIGFORM_ALT_PAL : mediacmd.h
  • GS_SIGFORM_CCIR_NTSC : mediacmd.h
  • GS_SIGFORM_CCIR_NTSC_P483 : mediacmd.h
  • GS_SIGFORM_CCIR_PAL : mediacmd.h
  • GS_SIGFORM_CCIR_PNTSC_30 : mediacmd.h
  • GS_SIGFORM_CCIR_PPAL_25 : mediacmd.h
  • GS_SIGFORM_CUSTOM : mediacmd.h
  • GS_SIGFORM_DCIN_2048_24 : mediacmd.h
  • GS_SIGFORM_DCIN_2048_24X : mediacmd.h
  • GS_SIGFORM_DCIN_2048_25 : mediacmd.h
  • GS_SIGFORM_DCIN_2048sf_24 : mediacmd.h
  • GS_SIGFORM_DCIN_2048sf_24X : mediacmd.h
  • GS_SIGFORM_DVI_1400_1050_24 : mediacmd.h
  • GS_SIGFORM_DVI_1400_1050_25 : mediacmd.h
  • GS_SIGFORM_FILM_1828_1102_24 : mediacmd.h
  • GS_SIGFORM_FILM_1828_1102_25 : mediacmd.h
  • GS_SIGFORM_FILM_1828_1332_24 : mediacmd.h
  • GS_SIGFORM_FILM_1828_1332_25 : mediacmd.h
  • GS_SIGFORM_FILM_1828_778_24 : mediacmd.h
  • GS_SIGFORM_FILM_1828_778_25 : mediacmd.h
  • GS_SIGFORM_FILM_1828_988_24 : mediacmd.h
  • GS_SIGFORM_FILM_1828_988_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1102_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1102_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1234_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1234_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048_14 : mediacmd.h
  • GS_SIGFORM_FILM_2048_15 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_15 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_15X : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_24X : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_48 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_48X : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536sf_15 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536sf_15X : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536sf_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536sf_24X : mediacmd.h
  • GS_SIGFORM_FILM_2048_15X : mediacmd.h
  • GS_SIGFORM_FILM_2048_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_24X : mediacmd.h
  • GS_SIGFORM_FILM_2048_48 : mediacmd.h
  • GS_SIGFORM_FILM_2048_857_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_857_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048_872_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_872_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048sf_15 : mediacmd.h
  • GS_SIGFORM_FILM_2048sf_15X : mediacmd.h
  • GS_SIGFORM_FILM_2048sf_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048sf_24X : mediacmd.h
  • GS_SIGFORM_FILM_4096_1714_24 : mediacmd.h
  • GS_SIGFORM_FILM_4096_1714_24X : mediacmd.h
  • GS_SIGFORM_FILM_4096_3112_24 : mediacmd.h
  • GS_SIGFORM_FILM_4096_3112_24X : mediacmd.h
  • GS_SIGFORM_FILM_4096_3112sf_5 : mediacmd.h
  • GS_SIGFORM_HD360 : mediacmd.h
  • GS_SIGFORM_NOT_PRESENT : mediacmd.h
  • GS_SIGFORM_NTSC : mediacmd.h
  • GS_SIGFORM_PAL : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1035 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1080 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1400 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1536 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1556 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_360 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_720 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_DCIN : mediacmd.h
  • GS_SIGFORM_SUPPORTS_EXTRA8 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_HR : mediacmd.h
  • GS_SIGFORM_SUPPORTS_NTSC : mediacmd.h
  • GS_SIGFORM_SUPPORTS_PAL : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V1024 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V1200 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V1600 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V480 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V600 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V768 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_X2 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_X3 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_X4 : mediacmd.h
  • GS_SIGFORM_VESA_1024_71X : mediacmd.h
  • GS_SIGFORM_VESA_1024_72 : mediacmd.h
  • GS_SIGFORM_VESA_1280_24 : mediacmd.h
  • GS_SIGFORM_VESA_1280_71X : mediacmd.h
  • GS_SIGFORM_VESA_1280_72 : mediacmd.h
  • GS_SIGFORM_VESA_1280i_30 : mediacmd.h
  • GS_SIGFORM_VESA_1600i_30 : mediacmd.h
  • GS_SIGFORM_VESA_640_72 : mediacmd.h
  • GS_SIGFORM_VESA_800_71X : mediacmd.h
  • GS_SIGFORM_VESA_800_72 : mediacmd.h
  • GS_SIGFORMFRAMERATE_10 : mediacmd.h
  • GS_SIGFORMFRAMERATE_100 : mediacmd.h
  • GS_SIGFORMFRAMERATE_119_88 : mediacmd.h
  • GS_SIGFORMFRAMERATE_14_98 : mediacmd.h
  • GS_SIGFORMFRAMERATE_15 : mediacmd.h
  • GS_SIGFORMFRAMERATE_23_98 : mediacmd.h
  • GS_SIGFORMFRAMERATE_24 : mediacmd.h
  • GS_SIGFORMFRAMERATE_25 : mediacmd.h
  • GS_SIGFORMFRAMERATE_29_97 : mediacmd.h
  • GS_SIGFORMFRAMERATE_30 : mediacmd.h
  • GS_SIGFORMFRAMERATE_47_95 : mediacmd.h
  • GS_SIGFORMFRAMERATE_48 : mediacmd.h
  • GS_SIGFORMFRAMERATE_5 : mediacmd.h
  • GS_SIGFORMFRAMERATE_50 : mediacmd.h
  • GS_SIGFORMFRAMERATE_59_94 : mediacmd.h
  • GS_SIGFORMFRAMERATE_6 : mediacmd.h
  • GS_SIGFORMFRAMERATE_60 : mediacmd.h
  • GS_SIGFORMFRAMERATE_71_93 : mediacmd.h
  • GS_SIGFORMFRAMERATE_72 : mediacmd.h
  • GS_SIGFORMFRAMERATE_7_5 : mediacmd.h
  • GS_SIGFORMFRAMERATE_CUSTOM : mediacmd.h
  • GS_SIGFORMMASK_FRAMERATE : mediacmd.h
  • GS_SIGFORMMASK_FRAMETYPE : mediacmd.h
  • GS_SIGFORMMASK_HORIZONTAL : mediacmd.h
  • GS_SIGFORMMASK_VERTICAL : mediacmd.h
  • GS_SIGFORMSHIFT_FRAMERATE : mediacmd.h
  • GS_SIGFORMSHIFT_FRAMETYPE : mediacmd.h
  • GS_SIGFORMSHIFT_HORIZONTAL : mediacmd.h
  • GS_SIGFORMSHIFT_VERTICAL : mediacmd.h
  • GS_SIGFORMSIZE_1024 : mediacmd.h
  • GS_SIGFORMSIZE_1024x1024 : mediacmd.h
  • GS_SIGFORMSIZE_1024x768 : mediacmd.h
  • GS_SIGFORMSIZE_1035 : mediacmd.h
  • GS_SIGFORMSIZE_1044 : mediacmd.h
  • GS_SIGFORMSIZE_1050 : mediacmd.h
  • GS_SIGFORMSIZE_1052 : mediacmd.h
  • GS_SIGFORMSIZE_1080 : mediacmd.h
  • GS_SIGFORMSIZE_1088 : mediacmd.h
  • GS_SIGFORMSIZE_1096 : mediacmd.h
  • GS_SIGFORMSIZE_1102 : mediacmd.h
  • GS_SIGFORMSIZE_1152 : mediacmd.h
  • GS_SIGFORMSIZE_1152x864 : mediacmd.h
  • GS_SIGFORMSIZE_1200 : mediacmd.h
  • GS_SIGFORMSIZE_1234 : mediacmd.h
  • GS_SIGFORMSIZE_1280 : mediacmd.h
  • GS_SIGFORMSIZE_1280x1024 : mediacmd.h
  • GS_SIGFORMSIZE_1280x720 : mediacmd.h
  • GS_SIGFORMSIZE_1332 : mediacmd.h
  • GS_SIGFORMSIZE_1400 : mediacmd.h
  • GS_SIGFORMSIZE_1400x1050 : mediacmd.h
  • GS_SIGFORMSIZE_1440 : mediacmd.h
  • GS_SIGFORMSIZE_1536 : mediacmd.h
  • GS_SIGFORMSIZE_1556 : mediacmd.h
  • GS_SIGFORMSIZE_1588 : mediacmd.h
  • GS_SIGFORMSIZE_1600 : mediacmd.h
  • GS_SIGFORMSIZE_1600x1200 : mediacmd.h
  • GS_SIGFORMSIZE_1714 : mediacmd.h
  • GS_SIGFORMSIZE_1828 : mediacmd.h
  • GS_SIGFORMSIZE_1828x1102 : mediacmd.h
  • GS_SIGFORMSIZE_1828x1332 : mediacmd.h
  • GS_SIGFORMSIZE_1828x778 : mediacmd.h
  • GS_SIGFORMSIZE_1828x988 : mediacmd.h
  • GS_SIGFORMSIZE_1920 : mediacmd.h
  • GS_SIGFORMSIZE_1920x1035 : mediacmd.h
  • GS_SIGFORMSIZE_1920x1080 : mediacmd.h
  • GS_SIGFORMSIZE_1920x1088 : mediacmd.h
  • GS_SIGFORMSIZE_2048 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1080 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1102 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1234 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1536 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1556 : mediacmd.h
  • GS_SIGFORMSIZE_2048x857 : mediacmd.h
  • GS_SIGFORMSIZE_2048x872 : mediacmd.h
  • GS_SIGFORMSIZE_240 : mediacmd.h
  • GS_SIGFORMSIZE_243 : mediacmd.h
  • GS_SIGFORMSIZE_2560x1080 : mediacmd.h
  • GS_SIGFORMSIZE_2650 : mediacmd.h
  • GS_SIGFORMSIZE_288 : mediacmd.h
  • GS_SIGFORMSIZE_3112 : mediacmd.h
  • GS_SIGFORMSIZE_320 : mediacmd.h
  • GS_SIGFORMSIZE_352 : mediacmd.h
  • GS_SIGFORMSIZE_360 : mediacmd.h
  • GS_SIGFORMSIZE_4096 : mediacmd.h
  • GS_SIGFORMSIZE_4096x1714 : mediacmd.h
  • GS_SIGFORMSIZE_4096x3112 : mediacmd.h
  • GS_SIGFORMSIZE_480 : mediacmd.h
  • GS_SIGFORMSIZE_483 : mediacmd.h
  • GS_SIGFORMSIZE_486 : mediacmd.h
  • GS_SIGFORMSIZE_496 : mediacmd.h
  • GS_SIGFORMSIZE_504 : mediacmd.h
  • GS_SIGFORMSIZE_512 : mediacmd.h
  • GS_SIGFORMSIZE_576 : mediacmd.h
  • GS_SIGFORMSIZE_600 : mediacmd.h
  • GS_SIGFORMSIZE_608 : mediacmd.h
  • GS_SIGFORMSIZE_640 : mediacmd.h
  • GS_SIGFORMSIZE_640x480 : mediacmd.h
  • GS_SIGFORMSIZE_640x576 : mediacmd.h
  • GS_SIGFORMSIZE_720 : mediacmd.h
  • GS_SIGFORMSIZE_720x480 : mediacmd.h
  • GS_SIGFORMSIZE_720x483 : mediacmd.h
  • GS_SIGFORMSIZE_720x486 : mediacmd.h
  • GS_SIGFORMSIZE_720x504 : mediacmd.h
  • GS_SIGFORMSIZE_720x512 : mediacmd.h
  • GS_SIGFORMSIZE_720x576 : mediacmd.h
  • GS_SIGFORMSIZE_720x608 : mediacmd.h
  • GS_SIGFORMSIZE_768 : mediacmd.h
  • GS_SIGFORMSIZE_778 : mediacmd.h
  • GS_SIGFORMSIZE_800 : mediacmd.h
  • GS_SIGFORMSIZE_800x600 : mediacmd.h
  • GS_SIGFORMSIZE_857 : mediacmd.h
  • GS_SIGFORMSIZE_864 : mediacmd.h
  • GS_SIGFORMSIZE_872 : mediacmd.h
  • GS_SIGFORMSIZE_960 : mediacmd.h
  • GS_SIGFORMSIZE_960x486 : mediacmd.h
  • GS_SIGFORMSIZE_960x504 : mediacmd.h
  • GS_SIGFORMSIZE_960x576 : mediacmd.h
  • GS_SIGFORMSIZE_968 : mediacmd.h
  • GS_SIGFORMSIZE_988 : mediacmd.h
  • GS_SIGFORMTYPE_INTERLACED : mediacmd.h
  • GS_SIGFORMTYPE_PROGRESSIVE : mediacmd.h
  • GS_SIGFORMTYPE_SEGMENTEDFRAME : mediacmd.h
  • GS_SIGFORMTYPE_UNKNOWN : mediacmd.h
  • GS_SUPFILE_ANY : mediacmd.h
  • GS_SUPFILE_AUDONLY : mediacmd.h
  • GS_SUPFILE_AVI : mediacmd.h
  • GS_SUPFILE_FIX : mediacmd.h
  • GS_SUPFILE_ODML : mediacmd.h
  • GS_SUPFILE_OMFI : mediacmd.h
  • GS_SUPFILE_QT : mediacmd.h
  • GS_SUPFILE_STILLS : mediacmd.h
  • GS_SUPFILE_UNK : mediacmd.h
  • GS_TCSOURCE_CLIP : mediacmd.h
  • GS_TCSOURCE_CTL : mediacmd.h
  • GS_TCSOURCE_LTC : mediacmd.h
  • GS_TCSOURCE_VITC : mediacmd.h
  • GS_TRUE : mediacmd.h
  • GS_UNITY : mediacmd.h
  • GS_UPCONVERT_ANAMORPHIC : mediacmd.h
  • GS_UPCONVERT_LETTERBOX : mediacmd.h
  • GS_UPCONVERT_PILLARBOX : mediacmd.h
  • GS_UPCONVERT_ZOOM14x9 : mediacmd.h
  • GS_UPCONVERT_ZOOMWIDE : mediacmd.h
  • GS_USERRIGHTS_ADD : mediacmd.h
  • GS_USERRIGHTS_ADMIN : mediacmd.h
  • GS_USERRIGHTS_DELETE : mediacmd.h
  • GS_USERRIGHTS_FULL : mediacmd.h
  • GS_USERRIGHTS_MODIFY : mediacmd.h
  • GS_USERRIGHTS_NONE : mediacmd.h
  • GS_USERRIGHTS_PLAY : mediacmd.h
  • GS_USERRIGHTS_READ : mediacmd.h
  • GS_USERRIGHTS_RECORD : mediacmd.h
  • GS_USERRIGHTS_SETUP : mediacmd.h
  • GS_USERRIGHTS_WRITE : mediacmd.h
  • GS_VIDBAND_HIGH : mediacmd.h
  • GS_VIDBAND_MEDIUM : mediacmd.h
  • GS_VIDBAND_NOTCH : mediacmd.h
  • GS_VIDBAND_STANDARD : mediacmd.h
  • GS_VIDBLACK_CRYSTAL : mediacmd.h
  • GS_VIDBLACK_SETUP : mediacmd.h
  • GS_VIDBLACK_SUPER : mediacmd.h
  • GS_VIDFREEZE_FIELD0 : mediacmd.h
  • GS_VIDFREEZE_FIELD1 : mediacmd.h
  • GS_VIDFREEZE_FRAME : mediacmd.h
  • GS_VIDFREEZE_NOT_FROZEN : mediacmd.h
  • GS_VIDLOCKTYPE_BROADCAST : mediacmd.h
  • GS_VIDLOCKTYPE_VTR : mediacmd.h
  • GS_VIDREF_DISABLE : mediacmd.h
  • GS_VIDREF_ENABLE : mediacmd.h
  • GS_VIDSELECT_COMPONENT_RGB : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_2 : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_JAPAN : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_M2 : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_SMPTE : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_SMPTE_JAPAN : mediacmd.h
  • GS_VIDSELECT_COMPOSITE : mediacmd.h
  • GS_VIDSELECT_COMPOSITE_2 : mediacmd.h
  • GS_VIDSELECT_COMPOSITE_3 : mediacmd.h
  • GS_VIDSELECT_COMPOSITE_4 : mediacmd.h
  • GS_VIDSELECT_COMPOSITE_JAPAN : mediacmd.h
  • GS_VIDSELECT_D1_PARALLEL : mediacmd.h
  • GS_VIDSELECT_D1_SERIAL : mediacmd.h
  • GS_VIDSELECT_D1_SERIAL_2 : mediacmd.h
  • GS_VIDSELECT_NONE : mediacmd.h
  • GS_VIDSELECT_SDTI : mediacmd.h
  • GS_VIDSELECT_SVIDEO : mediacmd.h
  • GS_VIDSELECT_SVIDEO_2 : mediacmd.h
  • GS_VIDSELECT_SVIDEO_JAPAN : mediacmd.h
  • GS_VIDSELECT_XVID_RGB : mediacmd.h
  • GS_VIDWHITE_CLAMP : mediacmd.h
  • GS_VIDWHITE_FREE : mediacmd.h
  • GS_VIDWHITE_SCALE : mediacmd.h
  • gsAddProxy : mediacmd.h
  • gsAlphaChromaSource : mediacmd.h
  • gsAudAdvanceLevel : mediacmd.h
  • gsAudChan : mediacmd.h
  • gsAudCrossFadeTime : mediacmd.h
  • gsAudDtmfEnable : mediacmd.h
  • gsAudEdit : mediacmd.h
  • gsAudInDtmfChannel : mediacmd.h
  • gsAudInLtcChannel : mediacmd.h
  • gsAudInputBass : mediacmd.h
  • gsAudInputBitRate : mediacmd.h
  • gsAudInputCopyright : mediacmd.h
  • gsAudInputErrorProtect : mediacmd.h
  • gsAudInputHeadRoom : mediacmd.h
  • gsAudInputLevel : mediacmd.h
  • gsAudInputMode : mediacmd.h
  • gsAudInputOriginal : mediacmd.h
  • gsAudInputSampleRate : mediacmd.h
  • gsAudInputSlave : mediacmd.h
  • gsAudInputTreble : mediacmd.h
  • gsAudInSelect : mediacmd.h
  • gsAudioEncodeFormat : mediacmd.h
  • gsAudLtcEnable : mediacmd.h
  • gsAudOutAdvancePhase : mediacmd.h
  • gsAudOutDtmfChannel : mediacmd.h
  • gsAudOutLtcChannel : mediacmd.h
  • gsAudOutPhase : mediacmd.h
  • gsAudOutputLevel : mediacmd.h
  • gsAudOutSelect : mediacmd.h
  • gsAudSelect : mediacmd.h
  • gsAudWavePeakRMS : mediacmd.h
  • gsAutoMode : mediacmd.h
  • gsChanCapabilities : mediacmd.h
  • gsChannelsExist : mediacmd.h
  • gsClipCopy : mediacmd.h
  • gsClipInfo : mediacmd.h
  • gsClipMode : mediacmd.h
  • gsColorFrame : mediacmd.h
  • gsCompBFactor : mediacmd.h
  • gsCompChAdjustGopTC : mediacmd.h
  • gsCompChAllowSettings : mediacmd.h
  • gsCompChAltCoEffTable : mediacmd.h
  • gsCompChannelChangeMs : mediacmd.h
  • gsCompChAspectRatio : mediacmd.h
  • gsCompChAudioStreamID : mediacmd.h
  • gsCompChAudioStreamPID : mediacmd.h
  • gsCompChAudPacketSize : mediacmd.h
  • gsCompChBitCount : mediacmd.h
  • gsCompChCCFormat : mediacmd.h
  • gsCompChChromaFormat : mediacmd.h
  • gsCompChClosedGop : mediacmd.h
  • gsCompChConcealmentVector : mediacmd.h
  • gsCompChDCPrecision : mediacmd.h
  • gsCompChFourCC : mediacmd.h
  • gsCompChHorizontalRes : mediacmd.h
  • gsCompChLanguageCode : mediacmd.h
  • gsCompChMuxRate : mediacmd.h
  • gsCompChNonLinearQuant : mediacmd.h
  • gsCompChPitch : mediacmd.h
  • gsCompChRate : mediacmd.h
  • gsCompChScale : mediacmd.h
  • gsCompChSizeImage : mediacmd.h
  • gsCompChStandard : mediacmd.h
  • gsCompChVerticalRes : mediacmd.h
  • gsCompChVideoStreamID : mediacmd.h
  • gsCompChVideoStreamPID : mediacmd.h
  • gsCompChVidPacketSize : mediacmd.h
  • gsCompGOPSize : mediacmd.h
  • gsCompIFactor : mediacmd.h
  • gsCompPFactor : mediacmd.h
  • gsCompRatePercent : mediacmd.h
  • gsCompRateRatio : mediacmd.h
  • gsCompRateSize : mediacmd.h
  • gsCompRefPeriod : mediacmd.h
  • gsCompressionType : mediacmd.h
  • gsCompType : mediacmd.h
  • gsConvertAudFileFormat : mediacmd.h
  • gsConvertFileFormat : mediacmd.h
  • gsCurrentMs : mediacmd.h
  • gsDefStillLen : mediacmd.h
  • gsDelInhibit : mediacmd.h
  • gsDirGetFileGrab : mediacmd.h
  • gsDirGetFileInfo : mediacmd.h
  • gsDirGetInfo : mediacmd.h
  • gsDirGetList : mediacmd.h
  • gsDSyncMs : mediacmd.h
  • gsEditMode : mediacmd.h
  • gsEditOff : mediacmd.h
  • gsEditOn : mediacmd.h
  • gsEmulateEditBumping : mediacmd.h
  • gsEnableHDSDFormat : mediacmd.h
  • gsEnd : mediacmd.h
  • gsErrorLog : mediacmd.h
  • gsErrorLogCurrentMs : mediacmd.h
  • gsErrorLogLastChange : mediacmd.h
  • gsErrorLogMessage : mediacmd.h
  • gsErrorLogName : mediacmd.h
  • gsErrorLogStartMs : mediacmd.h
  • gsFirstClip : mediacmd.h
  • gsFrameData : mediacmd.h
  • gsGetNextClip : mediacmd.h
  • gsGetNextProxy : mediacmd.h
  • gsGPIIn : mediacmd.h
  • gsGPIOut : mediacmd.h
  • gsHeadSelect : mediacmd.h
  • gsHwnds : mediacmd.h
  • gsHwPort : mediacmd.h
  • gsIgnoreFileTypes : mediacmd.h
  • gsImageDirectory : mediacmd.h
  • gsIn : mediacmd.h
  • gsInfChan : mediacmd.h
  • gsInfEdit : mediacmd.h
  • gsInfSelect : mediacmd.h
  • gsInsertQueue : mediacmd.h
  • gsInsInhibit : mediacmd.h
  • gsJpegFrame : mediacmd.h
  • gsLastChangeMs : mediacmd.h
  • gsLastIn : mediacmd.h
  • gsLastOut : mediacmd.h
  • gsLoadClipSpace : mediacmd.h
  • gsLoadFilmSpace : mediacmd.h
  • gsLoadTCSpace : mediacmd.h
  • gsLocal : mediacmd.h
  • gsLtcTc : mediacmd.h
  • gsLtcTcPreset : mediacmd.h
  • gsLtcUb : mediacmd.h
  • gsLtcUbPreset : mediacmd.h
  • gsLUTEnable : mediacmd.h
  • gsMetaData : mediacmd.h
  • gsMetaDataCurrentUser : mediacmd.h
  • gsMetaDataDirectory : mediacmd.h
  • gsMetaDataGlobal : mediacmd.h
  • gsMetaDataLocalMachine : mediacmd.h
  • gsMetaDataVolume : mediacmd.h
  • gsMEVersion : mediacmd.h
  • gsMonitor : mediacmd.h
  • gsMonitorDisplay : mediacmd.h
  • gsMonitorGrab : mediacmd.h
  • gsMonitorHwnds : mediacmd.h
  • gsMpegAdjustGopTC : mediacmd.h
  • gsMpegAllowSettings : mediacmd.h
  • gsMpegAltCoEffTable : mediacmd.h
  • gsMpegAspectRatio : mediacmd.h
  • gsMpegAudioStreamID : mediacmd.h
  • gsMpegAudioStreamPID : mediacmd.h
  • gsMpegAudPacketSize : mediacmd.h
  • gsMpegCCFormat : mediacmd.h
  • gsMpegChromaFormat : mediacmd.h
  • gsMpegClosedGop : mediacmd.h
  • gsMpegConcealmentVector : mediacmd.h
  • gsMpegDCPrecision : mediacmd.h
  • gsMpegHorizontalRes : mediacmd.h
  • gsMpegLanguageCode : mediacmd.h
  • gsMpegMuxRate : mediacmd.h
  • gsMpegNonLinearQuant : mediacmd.h
  • gsMpegStandard : mediacmd.h
  • gsMpegVerticalRes : mediacmd.h
  • gsMpegVideoStreamID : mediacmd.h
  • gsMpegVideoStreamPID : mediacmd.h
  • gsMpegVidPacketSize : mediacmd.h
  • gsNextClip : mediacmd.h
  • gsOut : mediacmd.h
  • gsPBEE : mediacmd.h
  • gsPiconFrame : mediacmd.h
  • gsPlayCountDelay : mediacmd.h
  • gsPlayDelay : mediacmd.h
  • gsPostroll : mediacmd.h
  • gsPreroll : mediacmd.h
  • gsPromoteProxy : mediacmd.h
  • gsProxyCPUUsage : mediacmd.h
  • gsProxyMode : mediacmd.h
  • gsProxyStatus : mediacmd.h
  • gsRecAudFileFormat : mediacmd.h
  • gsRecDrive : mediacmd.h
  • gsRecFileFormat : mediacmd.h
  • gsRecFileName : mediacmd.h
  • gsRecInhibit : mediacmd.h
  • gsRecOffset : mediacmd.h
  • gsRecRate : mediacmd.h
  • gsRemoveProxy : mediacmd.h
  • gsResetChannel : mediacmd.h
  • gsSaveCurrent : mediacmd.h
  • gsServoRefSelect : mediacmd.h
  • gsSignalFormat : mediacmd.h
  • gsStart : mediacmd.h
  • gsSupportedFileTypes : mediacmd.h
  • gsSysBufferLevel : mediacmd.h
  • gsSysCPUUsage : mediacmd.h
  • gsSysMemoryUsage : mediacmd.h
  • gsSysTime : mediacmd.h
  • gsTc : mediacmd.h
  • gsTCSGetTLClipInfo : mediacmd.h
  • gsTCSGetTLClipState : mediacmd.h
  • gsTcSource : mediacmd.h
  • gsTcType : mediacmd.h
  • gsTotalStorageAvail : mediacmd.h
  • gsTotalStorageFree : mediacmd.h
  • gsTotalTimeAvail : mediacmd.h
  • gsTotalTimeFree : mediacmd.h
  • gsUb : mediacmd.h
  • gsUserAdd : mediacmd.h
  • gsUserDel : mediacmd.h
  • gsUserLastChangeMs : mediacmd.h
  • gsUserList : mediacmd.h
  • gsUserLogIn : mediacmd.h
  • gsUserPasswd : mediacmd.h
  • gsUserRights : mediacmd.h
  • gsVBlankEnable : mediacmd.h
  • gsVidAnalogMonitorDownMode : mediacmd.h
  • gsVidAnalogMonitorHDType : mediacmd.h
  • gsVidAnalogMonitorMethod : mediacmd.h
  • gsVidAnalogMonitorSDType : mediacmd.h
  • gsVidAnalogMonitorUpMode : mediacmd.h
  • gsVidBandwidth : mediacmd.h
  • gsVidBlackSetup : mediacmd.h
  • gsVidChan : mediacmd.h
  • gsVidChroma : mediacmd.h
  • gsVidColor : mediacmd.h
  • gsVidEdit : mediacmd.h
  • gsVidEditField : mediacmd.h
  • gsVideoEncodeFormat : mediacmd.h
  • gsVideoStandard : mediacmd.h
  • gsVidFreeze : mediacmd.h
  • gsVidGenlockValid : mediacmd.h
  • gsVidHue : mediacmd.h
  • gsVidInAGC : mediacmd.h
  • gsVidInBandwidth : mediacmd.h
  • gsVidInBlack : mediacmd.h
  • gsVidInChroma : mediacmd.h
  • gsVidInColorKiller : mediacmd.h
  • gsVidInCoring : mediacmd.h
  • gsVidInGamma : mediacmd.h
  • gsVidInHue : mediacmd.h
  • gsVidInLockType : mediacmd.h
  • gsVidInPeaking : mediacmd.h
  • gsVidInputValid : mediacmd.h
  • gsVidInSelect : mediacmd.h
  • gsVidInSetup : mediacmd.h
  • gsVidInSharpness : mediacmd.h
  • gsVidInSignalFormat : mediacmd.h
  • gsVidInUChroma : mediacmd.h
  • gsVidInVChroma : mediacmd.h
  • gsVidInVideo : mediacmd.h
  • gsVidInWhite : mediacmd.h
  • gsVidNoEE : mediacmd.h
  • gsVidOutAdjust1 : mediacmd.h
  • gsVidOutAdjust2 : mediacmd.h
  • gsVidOutCoring : mediacmd.h
  • gsVidOutGenlock : mediacmd.h
  • gsVidOutGenlockDelay : mediacmd.h
  • gsVidOutGenlockSource : mediacmd.h
  • gsVidOutHPhase : mediacmd.h
  • gsVidOutLockSignalFormat : mediacmd.h
  • gsVidOutLockType : mediacmd.h
  • gsVidOutPeaking : mediacmd.h
  • gsVidOutSelect : mediacmd.h
  • gsVidOutSubCarrier : mediacmd.h
  • gsVidPlayFrame : mediacmd.h
  • gsVidPreReadMode : mediacmd.h
  • gsVidRecFrame : mediacmd.h
  • gsVidRefDisable : mediacmd.h
  • gsVidSelect : mediacmd.h
  • gsVidSetup : mediacmd.h
  • gsVidSuperimpose : mediacmd.h
  • gsVidUChroma : mediacmd.h
  • gsVidVChroma : mediacmd.h
  • gsVidVideo : mediacmd.h
  • gsVitcTc : mediacmd.h
  • gsVitcTcPreset : mediacmd.h
  • gsVitcUb : mediacmd.h
  • gsVitcUbPreset : mediacmd.h
  • gsVtrType : mediacmd.h
  • gsVVWChannelName : mediacmd.h
  • gsVVWChannelType : mediacmd.h
  • gsVVWService : mediacmd.h
  • gsVVWType : mediacmd.h
  • gsVVWVersion : mediacmd.h
  • gsXlatQueue : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • inf13 : mediacmd.h
  • inf14 : mediacmd.h
  • inf15 : mediacmd.h
  • inf16 : mediacmd.h
  • inf17 : mediacmd.h
  • inf18 : mediacmd.h
  • inf19 : mediacmd.h
  • inf20 : mediacmd.h
  • inf21 : mediacmd.h
  • infAuth : mediacmd.h
  • infCC : mediacmd.h
  • infChanAll : mediacmd.h
  • infCopyright : mediacmd.h
  • infLtc : mediacmd.h
  • infOwner : mediacmd.h
  • infProxyName : mediacmd.h
  • infRecDate : mediacmd.h
  • infRecTime : mediacmd.h
  • infSourceName : mediacmd.h
  • infSrcCtl : mediacmd.h
  • infSrcLtc : mediacmd.h
  • infSrcVitc : mediacmd.h
  • infVB0 : mediacmd.h
  • infVB1 : mediacmd.h
  • infVB2 : mediacmd.h
  • infVB3 : mediacmd.h
  • infVB4 : mediacmd.h
  • infVB5 : mediacmd.h
  • infVB6 : mediacmd.h
  • infVB7 : mediacmd.h
  • infVB8 : mediacmd.h
  • infVB9 : mediacmd.h
  • infVitc : mediacmd.h
  • INIT_DRASTIC_CHANNEL : vvwtypes.h
  • INIT_MEDIACMD : mediacmd.h
  • INIT_PDRASTIC_CHANNEL : vvwtypes.h
  • INIT_PMEDIACMD : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • pCmdQueueElem : mediacmd.h
  • PDCLIP : vvwtypes.h
  • PDFRAME : vvwtypes.h
  • pDRASTIC_CHANNEL : vvwtypes.h
  • pFI_DataAreaPtr : vvwtypes.h
  • pFRAME_INFO : vvwtypes.h
  • PMEDIACMD : mediacmd.h
  • PutAudio : vvwtypes.h
  • PutInf : vvwtypes.h
  • PutVideo : vvwtypes.h
  • pVVWAUDIO : vvwtypes.h
  • pVVWINFO : vvwtypes.h
  • pVVWSYSTEM : vvwtypes.h
  • pVVWVIDEO : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • SIZEOF_MEDIACMD : mediacmd.h
  • SIZEOF_MEDIACMD_BASE : mediacmd.h
  • SIZEOF_MEDIACMD_CLIPID : mediacmd.h
  • SIZEOFDFRAME : vvwtypes.h
  • SPD_FAST_BUMP : mediacmd.h
  • SPD_FWD_MAX : mediacmd.h
  • SPD_FWD_PLAY : mediacmd.h
  • SPD_ILLEGAL : mediacmd.h
  • SPD_PAUSE : mediacmd.h
  • SPD_REV_MAX : mediacmd.h
  • SPD_REV_PLAY : mediacmd.h
  • SPD_SLOW_BUMP : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • TC2_CHAR_100 : timecode.h
  • TC2_CHAR_2398 : timecode.h
  • TC2_CHAR_50 : timecode.h
  • TC2_CHAR_5994 : timecode.h
  • TC2_CHAR_60 : timecode.h
  • TC2_CHAR_DF : timecode.h
  • TC2_CHAR_FILM : timecode.h
  • TC2_CHAR_NDF : timecode.h
  • TC2_CHAR_NTSCFILM : timecode.h
  • TC2_CHAR_PAL : timecode.h
  • TC2_FTYPE_FIELD : timecode.h
  • TC2_GOP25TC_TO_HEXINVERT : timecode.h
  • TC2_GOP25TC_TO_HEXINVERT_ADD_DF : timecode.h
  • TC2_HEXINVERT_TO_GOP25TC : timecode.h
  • TC2_HEXINVERT_TO_GOP25TC_ADD_DF : timecode.h
  • TC2_ILLEGAL : timecode.h
  • TC2_MARK_100 : timecode.h
  • TC2_MARK_2398 : timecode.h
  • TC2_MARK_50 : timecode.h
  • TC2_MARK_5994 : timecode.h
  • TC2_MARK_60 : timecode.h
  • TC2_MARK_DF : timecode.h
  • TC2_MARK_FILM : timecode.h
  • TC2_MARK_NDF : timecode.h
  • TC2_MARK_NTSCFILM : timecode.h
  • TC2_MARK_PAL : timecode.h
  • TC2_MIN_STRING_SIZE : timecode.h
  • TC2_STREXT_ALLCOLON : timecode.h
  • TC2_STREXT_CF : timecode.h
  • TC2_STREXT_FLAG : timecode.h
  • TC2_STREXT_ISBSTR : timecode.h
  • TC2_STREXT_LEADING : timecode.h
  • TC2_STREXT_MARKS : timecode.h
  • TC2_STREXT_MASK : timecode.h
  • TC2_STREXT_MAX30 : timecode.h
  • TC2_STREXT_REVERSE : timecode.h
  • TC2_STREXT_SAVEBITS : timecode.h
  • TC2_STREXT_SHIFT7 : timecode.h
  • TC2_STREXT_TYPE : timecode.h
  • TC2_STRTYPE_ASCII : timecode.h
  • TC2_STRTYPE_BCD : timecode.h
  • TC2_STRTYPE_GOP : timecode.h
  • TC2_STRTYPE_HEX : timecode.h
  • TC2_STRTYPE_INVERT : timecode.h
  • TC2_STRTYPE_MASK : timecode.h
  • TC2_STRTYPE_OVER_24_HOUR : timecode.h
  • TC2_TCTYPE_100 : timecode.h
  • TC2_TCTYPE_2398 : timecode.h
  • TC2_TCTYPE_50 : timecode.h
  • TC2_TCTYPE_5994 : timecode.h
  • TC2_TCTYPE_60 : timecode.h
  • TC2_TCTYPE_DF : timecode.h
  • TC2_TCTYPE_FILM : timecode.h
  • TC2_TCTYPE_MASK : timecode.h
  • TC2_TCTYPE_NDF : timecode.h
  • TC2_TCTYPE_NTSCFILM : timecode.h
  • TC2_TCTYPE_PAL : timecode.h
  • tc2Frame() : timecode.h
  • tc2Maximum() : timecode.h
  • tc2String() : timecode.h
  • TC_ILLEGAL : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • ub2String() : timecode.h
  • ub2Value() : timecode.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • f
  • g
  • i
  • m
  • p
  • s
  • t
  • u
  • v

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • vidChan0 : mediacmd.h
  • vidChan1 : mediacmd.h
  • vidChan10 : mediacmd.h
  • vidChan11 : mediacmd.h
  • vidChan12 : mediacmd.h
  • vidChan13 : mediacmd.h
  • vidChan14 : mediacmd.h
  • vidChan15 : mediacmd.h
  • vidChan16 : mediacmd.h
  • vidChan17 : mediacmd.h
  • vidChan18 : mediacmd.h
  • vidChan19 : mediacmd.h
  • vidChan2 : mediacmd.h
  • vidChan20 : mediacmd.h
  • vidChan21 : mediacmd.h
  • vidChan22 : mediacmd.h
  • vidChan23 : mediacmd.h
  • vidChan24 : mediacmd.h
  • vidChan25 : mediacmd.h
  • vidChan26 : mediacmd.h
  • vidChan27 : mediacmd.h
  • vidChan28 : mediacmd.h
  • vidChan29 : mediacmd.h
  • vidChan3 : mediacmd.h
  • vidChan30 : mediacmd.h
  • vidChan31 : mediacmd.h
  • vidChan4 : mediacmd.h
  • vidChan5 : mediacmd.h
  • vidChan6 : mediacmd.h
  • vidChan7 : mediacmd.h
  • vidChan8 : mediacmd.h
  • vidChan9 : mediacmd.h
  • vidChanAll : mediacmd.h
  • VIDEOWRITETYPE_4224 : mediacmd.h
  • VIDEOWRITETYPE_AVI : mediacmd.h
  • VIDEOWRITETYPE_BMP : mediacmd.h
  • VIDEOWRITETYPE_CIN : mediacmd.h
  • VIDEOWRITETYPE_DPX : mediacmd.h
  • VIDEOWRITETYPE_DVS : mediacmd.h
  • VIDEOWRITETYPE_GEN : mediacmd.h
  • VIDEOWRITETYPE_HDR : mediacmd.h
  • VIDEOWRITETYPE_IHSS : mediacmd.h
  • VIDEOWRITETYPE_JS : mediacmd.h
  • VIDEOWRITETYPE_MOV : mediacmd.h
  • VIDEOWRITETYPE_MPG : mediacmd.h
  • VIDEOWRITETYPE_RAW : mediacmd.h
  • VIDEOWRITETYPE_TGA : mediacmd.h
  • VIDEOWRITETYPE_TIFF : mediacmd.h
  • VIDEOWRITETYPE_WMV : mediacmd.h
  • VIDEOWRITETYPE_YUV : mediacmd.h
  • vvvwLoadDefaultRegistry() : vvw.h
  • VVW_ABS_MAX_FRAME : vvwtypes.h
  • VVW_INVALID_FRAME : vvwtypes.h
  • VVWAUD_RECALC : vvwtypes.h
  • VVWAUD_SET : vvwtypes.h
  • VVWAUD_SETCLR : vvwtypes.h
  • vvwBlank() : vvw.h
  • vvwChannelToHandle() : vvw.h
  • vvwClose() : vvw.h
  • vvwCmd() : vvw.h
  • vvwConfigure() : vvw.h
  • vvwCopyClip() : vvw.h
  • vvwDelete() : vvw.h
  • vvwEDLGetEdit() : vvw.h
  • vvwEDLResetToStart() : vvw.h
  • vvwEject() : vvw.h
  • vvwEnableChannels() : vvw.h
  • vvwFastForward() : vvw.h
  • vvwFastRewind() : vvw.h
  • vvwFreeString() : vvw.h
  • vvwGetAudioInput() : vvw.h
  • vvwGetAudioInputLevel() : vvw.h
  • vvwGetAudioOutput() : vvw.h
  • vvwGetAudioOutputLevel() : vvw.h
  • vvwGetAudioPeakRMS() : vvw.h
  • vvwGetAutoMode() : vvw.h
  • vvwGetAvailablePresets() : vvw.h
  • vvwGetChannelCapabilities() : vvw.h
  • vvwGetChannelName() : vvw.h
  • vvwGetChannelType() : vvw.h
  • vvwGetClipInfo() : vvw.h
  • vvwGetClipMode() : vvw.h
  • vvwGetClipName() : vvw.h
  • vvwGetCompressionRate() : vvw.h
  • vvwGetCurMs() : vvw.h
  • vvwGetCurState() : vvw.h
  • vvwGetCurTC() : vvw.h
  • vvwGetEnd() : vvw.h
  • vvwGetError() : vvw.h
  • vvwGetErrorLength() : vvw.h
  • vvwGetErrorLogMs() : vvw.h
  • vvwGetFileName() : vvw.h
  • vvwGetFlags() : vvw.h
  • vvwGetFreeStorage() : vvw.h
  • vvwGetFreeTime() : vvw.h
  • vvwGetLastChangeMs() : vvw.h
  • vvwGetLastChangeXferMs() : vvw.h
  • vvwGetLastMs() : vvw.h
  • vvwGetMaxChannels() : vvw.h
  • vvwGetMRVersion() : vvw.h
  • vvwGetNextClip() : vvw.h
  • vvwGetNextClipEx() : vvw.h
  • vvwGetPiconName() : vvw.h
  • vvwGetPosition() : vvw.h
  • vvwGetSpeed() : vvw.h
  • vvwGetStart() : vvw.h
  • vvwGetState() : vvw.h
  • vvwGetSuperImpose() : vvw.h
  • vvwGetTCSource() : vvw.h
  • vvwGetTCType() : vvw.h
  • vvwGetTotalStorage() : vvw.h
  • vvwGetTotalTime() : vvw.h
  • vvwGetVideoGenlock() : vvw.h
  • vvwGetVideoGenlockSource() : vvw.h
  • vvwGetVideoInput() : vvw.h
  • vvwGetVideoInputChroma() : vvw.h
  • vvwGetVideoInputHue() : vvw.h
  • vvwGetVideoInputSetup() : vvw.h
  • vvwGetVideoInputVideo() : vvw.h
  • vvwGetVideoOutput() : vvw.h
  • vvwGetVideoTBCChroma() : vvw.h
  • vvwGetVideoTBCHue() : vvw.h
  • vvwGetVideoTBCSetup() : vvw.h
  • vvwGetVideoTBCVideo() : vvw.h
  • vvwGetVVWType() : vvw.h
  • vvwGetVVWVersion() : vvw.h
  • VVWHANDLE : vvw.h
  • vvwHandleToChannel() : vvw.h
  • vvwiAFrame : vvwtypes.h
  • vvwiAlbum : vvwtypes.h
  • vvwiArtist : vvwtypes.h
  • vvwiAspectRatio : vvwtypes.h
  • vvwiAuthor : vvwtypes.h
  • vvwiBlackGain : vvwtypes.h
  • vvwiBlackPoint : vvwtypes.h
  • vvwiBreakPoint : vvwtypes.h
  • vvwiCamRoll : vvwtypes.h
  • vvwiCategory : vvwtypes.h
  • vvwiChannel : vvwtypes.h
  • vvwiChannelDescription : vvwtypes.h
  • vvwiChannelName : vvwtypes.h
  • vvwiComments : vvwtypes.h
  • vvwiComposer : vvwtypes.h
  • vvwiConversions : vvwtypes.h
  • vvwiCopyright : vvwtypes.h
  • vvwiCreationData : vvwtypes.h
  • vvwiDailyRoll : vvwtypes.h
  • vvwiDescription : vvwtypes.h
  • vvwiDeviceModelNum : vvwtypes.h
  • vvwiDeviceSerialNum : vvwtypes.h
  • vvwiDirector : vvwtypes.h
  • vvwiDisclaimer : vvwtypes.h
  • vvwiEditData1 : vvwtypes.h
  • vvwiEditData2 : vvwtypes.h
  • vvwiEditData3 : vvwtypes.h
  • vvwiEditData4 : vvwtypes.h
  • vvwiEditData5 : vvwtypes.h
  • vvwiEditData6 : vvwtypes.h
  • vvwiEditData7 : vvwtypes.h
  • vvwiEditData8 : vvwtypes.h
  • vvwiEditData9 : vvwtypes.h
  • vvwiEditor : vvwtypes.h
  • vvwiEncodedBy : vvwtypes.h
  • vvwiEND_OF_DWORD_V2 : vvwtypes.h
  • vvwiEND_OF_STRINGS : vvwtypes.h
  • vvwiEpisode : vvwtypes.h
  • vvwiFileDate : vvwtypes.h
  • vvwiFileName : vvwtypes.h
  • vvwiFileSize : vvwtypes.h
  • vvwiFileTime : vvwtypes.h
  • vvwiFilmManufacturerCode : vvwtypes.h
  • vvwiFilmTypeCode : vvwtypes.h
  • vvwiFlags : vvwtypes.h
  • vvwiFormat : vvwtypes.h
  • vvwiFrameAttribute : vvwtypes.h
  • vvwiFullName : vvwtypes.h
  • vvwiGamma1000 : vvwtypes.h
  • vvwiGenre : vvwtypes.h
  • vvwiHostComputer : vvwtypes.h
  • vvwiInformation : vvwtypes.h
  • vvwiInkNumberPrefix : vvwtypes.h
  • vvwiInputDevice : vvwtypes.h
  • vvwiIP : vvwtypes.h
  • vvwiKeyNumberPrefix : vvwtypes.h
  • vvwiKeywords : vvwtypes.h
  • vvwiLabRoll : vvwtypes.h
  • vvwiLanguage : vvwtypes.h
  • vvwiLastElementPlus1 : vvwtypes.h
  • vvwiLTCTimeCodeType : vvwtypes.h
  • vvwiMake : vvwtypes.h
  • vvwiManufacturer : vvwtypes.h
  • vvwiModel : vvwtypes.h
  • vvwiNativeLocator : vvwtypes.h
  • vvwInfoMetaTypes : vvwtypes.h
  • VVWINFOTAG_dwAFrame : vvwtypes.h
  • VVWINFOTAG_dwAspectRatio : vvwtypes.h
  • VVWINFOTAG_dwBlackGain : vvwtypes.h
  • VVWINFOTAG_dwBlackPoint : vvwtypes.h
  • VVWINFOTAG_dwBreakPoint : vvwtypes.h
  • VVWINFOTAG_dwConversions : vvwtypes.h
  • VVWINFOTAG_dwFileDate : vvwtypes.h
  • VVWINFOTAG_dwFileSize : vvwtypes.h
  • VVWINFOTAG_dwFileTime : vvwtypes.h
  • VVWINFOTAG_dwFilmManufacturerCode : vvwtypes.h
  • VVWINFOTAG_dwFilmTypeCode : vvwtypes.h
  • VVWINFOTAG_dwFlags : vvwtypes.h
  • VVWINFOTAG_dwGamma1000 : vvwtypes.h
  • VVWINFOTAG_dwLTCTimeCodeType : vvwtypes.h
  • VVWINFOTAG_dwNU_31 : vvwtypes.h
  • VVWINFOTAG_dwNU_32 : vvwtypes.h
  • VVWINFOTAG_dwNU_33 : vvwtypes.h
  • VVWINFOTAG_dwNU_34 : vvwtypes.h
  • VVWINFOTAG_dwNU_35 : vvwtypes.h
  • VVWINFOTAG_dwNU_36 : vvwtypes.h
  • VVWINFOTAG_dwNU_37 : vvwtypes.h
  • VVWINFOTAG_dwNU_38 : vvwtypes.h
  • VVWINFOTAG_dwNU_39 : vvwtypes.h
  • VVWINFOTAG_dwNU_40 : vvwtypes.h
  • VVWINFOTAG_dwNU_41 : vvwtypes.h
  • VVWINFOTAG_dwNU_42 : vvwtypes.h
  • VVWINFOTAG_dwNU_43 : vvwtypes.h
  • VVWINFOTAG_dwNU_44 : vvwtypes.h
  • VVWINFOTAG_dwNU_45 : vvwtypes.h
  • VVWINFOTAG_dwNU_46 : vvwtypes.h
  • VVWINFOTAG_dwNU_47 : vvwtypes.h
  • VVWINFOTAG_dwNU_48 : vvwtypes.h
  • VVWINFOTAG_dwNU_49 : vvwtypes.h
  • VVWINFOTAG_dwOriginalRate : vvwtypes.h
  • VVWINFOTAG_dwOriginalScale : vvwtypes.h
  • VVWINFOTAG_dwPosterFrame : vvwtypes.h
  • VVWINFOTAG_dwSequenceNumber : vvwtypes.h
  • VVWINFOTAG_dwTagNumber : vvwtypes.h
  • VVWINFOTAG_dwTimeCode : vvwtypes.h
  • VVWINFOTAG_dwTimeCodeType : vvwtypes.h
  • VVWINFOTAG_dwTotalLength : vvwtypes.h
  • VVWINFOTAG_dwTotalStreams : vvwtypes.h
  • VVWINFOTAG_dwUserBits : vvwtypes.h
  • VVWINFOTAG_dwVersionNumber : vvwtypes.h
  • VVWINFOTAG_dwVITCLine3 : vvwtypes.h
  • VVWINFOTAG_dwVITCTimeCode : vvwtypes.h
  • VVWINFOTAG_dwVITCTimeCodeType : vvwtypes.h
  • VVWINFOTAG_dwVITCUserBits : vvwtypes.h
  • VVWINFOTAG_dwWhitePoint : vvwtypes.h
  • VVWINFOTAG_szAlbum : vvwtypes.h
  • VVWINFOTAG_szArtist : vvwtypes.h
  • VVWINFOTAG_szAuthor : vvwtypes.h
  • VVWINFOTAG_szCamRoll : vvwtypes.h
  • VVWINFOTAG_szCategory : vvwtypes.h
  • VVWINFOTAG_szChannel : vvwtypes.h
  • VVWINFOTAG_szChannelDescription : vvwtypes.h
  • VVWINFOTAG_szChannelName : vvwtypes.h
  • VVWINFOTAG_szComments : vvwtypes.h
  • VVWINFOTAG_szComposer : vvwtypes.h
  • VVWINFOTAG_szCopyright : vvwtypes.h
  • VVWINFOTAG_szCreationData : vvwtypes.h
  • VVWINFOTAG_szDailyRoll : vvwtypes.h
  • VVWINFOTAG_szDescription : vvwtypes.h
  • VVWINFOTAG_szDeviceModelNum : vvwtypes.h
  • VVWINFOTAG_szDeviceSerialNum : vvwtypes.h
  • VVWINFOTAG_szDirector : vvwtypes.h
  • VVWINFOTAG_szDisclaimer : vvwtypes.h
  • VVWINFOTAG_szDoNotUse : vvwtypes.h
  • VVWINFOTAG_szEditData1 : vvwtypes.h
  • VVWINFOTAG_szEditData2 : vvwtypes.h
  • VVWINFOTAG_szEditData3 : vvwtypes.h
  • VVWINFOTAG_szEditData4 : vvwtypes.h
  • VVWINFOTAG_szEditData5 : vvwtypes.h
  • VVWINFOTAG_szEditData6 : vvwtypes.h
  • VVWINFOTAG_szEditData7 : vvwtypes.h
  • VVWINFOTAG_szEditData8 : vvwtypes.h
  • VVWINFOTAG_szEditData9 : vvwtypes.h
  • VVWINFOTAG_szEditor : vvwtypes.h
  • VVWINFOTAG_szEncodedBy : vvwtypes.h
  • VVWINFOTAG_szEpisode : vvwtypes.h
  • VVWINFOTAG_szFileName : vvwtypes.h
  • VVWINFOTAG_szFormat : vvwtypes.h
  • VVWINFOTAG_szFrameAttribute : vvwtypes.h
  • VVWINFOTAG_szFullName : vvwtypes.h
  • VVWINFOTAG_szGenre : vvwtypes.h
  • VVWINFOTAG_szHostComputer : vvwtypes.h
  • VVWINFOTAG_szInformation : vvwtypes.h
  • VVWINFOTAG_szInkNumberPrefix : vvwtypes.h
  • VVWINFOTAG_szInputDevice : vvwtypes.h
  • VVWINFOTAG_szIP : vvwtypes.h
  • VVWINFOTAG_szKeyNumberPrefix : vvwtypes.h
  • VVWINFOTAG_szKeywords : vvwtypes.h
  • VVWINFOTAG_szLabRoll : vvwtypes.h
  • VVWINFOTAG_szLanguage : vvwtypes.h
  • VVWINFOTAG_szMake : vvwtypes.h
  • VVWINFOTAG_szManufacturer : vvwtypes.h
  • VVWINFOTAG_szModel : vvwtypes.h
  • VVWINFOTAG_szNativeLocator : vvwtypes.h
  • VVWINFOTAG_szNU_81 : vvwtypes.h
  • VVWINFOTAG_szNU_82 : vvwtypes.h
  • VVWINFOTAG_szNU_83 : vvwtypes.h
  • VVWINFOTAG_szNU_84 : vvwtypes.h
  • VVWINFOTAG_szNU_85 : vvwtypes.h
  • VVWINFOTAG_szNU_86 : vvwtypes.h
  • VVWINFOTAG_szNU_87 : vvwtypes.h
  • VVWINFOTAG_szNU_88 : vvwtypes.h
  • VVWINFOTAG_szNU_89 : vvwtypes.h
  • VVWINFOTAG_szNU_90 : vvwtypes.h
  • VVWINFOTAG_szNU_91 : vvwtypes.h
  • VVWINFOTAG_szNU_92 : vvwtypes.h
  • VVWINFOTAG_szNU_93 : vvwtypes.h
  • VVWINFOTAG_szNU_94 : vvwtypes.h
  • VVWINFOTAG_szNU_95 : vvwtypes.h
  • VVWINFOTAG_szNU_96 : vvwtypes.h
  • VVWINFOTAG_szNU_97 : vvwtypes.h
  • VVWINFOTAG_szNU_98 : vvwtypes.h
  • VVWINFOTAG_szNU_99 : vvwtypes.h
  • VVWINFOTAG_szOriginalArtist : vvwtypes.h
  • VVWINFOTAG_szOriginalFormat : vvwtypes.h
  • VVWINFOTAG_szOwner : vvwtypes.h
  • VVWINFOTAG_szPerformers : vvwtypes.h
  • VVWINFOTAG_szPictureIcon : vvwtypes.h
  • VVWINFOTAG_szProduced : vvwtypes.h
  • VVWINFOTAG_szProducer : vvwtypes.h
  • VVWINFOTAG_szProduct : vvwtypes.h
  • VVWINFOTAG_szProject : vvwtypes.h
  • VVWINFOTAG_szProxyFile : vvwtypes.h
  • VVWINFOTAG_szRatings : vvwtypes.h
  • VVWINFOTAG_szReel : vvwtypes.h
  • VVWINFOTAG_szRevisionNumber : vvwtypes.h
  • VVWINFOTAG_szScene : vvwtypes.h
  • VVWINFOTAG_szShot : vvwtypes.h
  • VVWINFOTAG_szSlateInfo : vvwtypes.h
  • VVWINFOTAG_szSoftware : vvwtypes.h
  • VVWINFOTAG_szSoundRoll : vvwtypes.h
  • VVWINFOTAG_szSource : vvwtypes.h
  • VVWINFOTAG_szSourceLocator : vvwtypes.h
  • VVWINFOTAG_szSpecialPlaybackRequirements : vvwtypes.h
  • VVWINFOTAG_szStatus : vvwtypes.h
  • VVWINFOTAG_szSubject : vvwtypes.h
  • VVWINFOTAG_szSupplier : vvwtypes.h
  • VVWINFOTAG_szTake : vvwtypes.h
  • VVWINFOTAG_szTitle : vvwtypes.h
  • VVWINFOTAG_szTrack : vvwtypes.h
  • VVWINFOTAG_szUniversalName : vvwtypes.h
  • VVWINFOTAG_szURLLink : vvwtypes.h
  • VVWINFOTAG_szVersionString : vvwtypes.h
  • VVWINFOTAG_szWarning : vvwtypes.h
  • VVWINFOTAG_woBitCount : vvwtypes.h
  • VVWINFOTAG_woCaps : vvwtypes.h
  • VVWINFOTAG_woClrImportant : vvwtypes.h
  • VVWINFOTAG_woClrUsed : vvwtypes.h
  • VVWINFOTAG_woCompression : vvwtypes.h
  • VVWINFOTAG_woDrFlags : vvwtypes.h
  • VVWINFOTAG_woEditCount : vvwtypes.h
  • VVWINFOTAG_woFccHandler : vvwtypes.h
  • VVWINFOTAG_woFccType : vvwtypes.h
  • VVWINFOTAG_woFileType : vvwtypes.h
  • VVWINFOTAG_woFlags : vvwtypes.h
  • VVWINFOTAG_woFormatChangeCount : vvwtypes.h
  • VVWINFOTAG_woHeight : vvwtypes.h
  • VVWINFOTAG_woInitialFrames : vvwtypes.h
  • VVWINFOTAG_woLanguage : vvwtypes.h
  • VVWINFOTAG_woLength : vvwtypes.h
  • VVWINFOTAG_woPitch : vvwtypes.h
  • VVWINFOTAG_woPlanes : vvwtypes.h
  • VVWINFOTAG_woPriority : vvwtypes.h
  • VVWINFOTAG_woQuality : vvwtypes.h
  • VVWINFOTAG_woRate : vvwtypes.h
  • VVWINFOTAG_woResDrastic : vvwtypes.h
  • VVWINFOTAG_woReserved : vvwtypes.h
  • VVWINFOTAG_woSampleSize : vvwtypes.h
  • VVWINFOTAG_woScale : vvwtypes.h
  • VVWINFOTAG_woSizeImage : vvwtypes.h
  • VVWINFOTAG_woStart : vvwtypes.h
  • VVWINFOTAG_woSuggestedBufferSize : vvwtypes.h
  • VVWINFOTAG_woVideoWidth : vvwtypes.h
  • VVWINFOTAG_woXPelsPerMeter : vvwtypes.h
  • VVWINFOTAG_woYPelsPerMeter : vvwtypes.h
  • vvwInit() : vvw.h
  • vvwInitInt() : vvw.h
  • vvwInsert() : vvw.h
  • vvwiNumericStart : vvwtypes.h
  • vvwiOriginalArtist : vvwtypes.h
  • vvwiOriginalFormat : vvwtypes.h
  • vvwiOriginalRate : vvwtypes.h
  • vvwiOriginalScale : vvwtypes.h
  • vvwiOwner : vvwtypes.h
  • vvwiPerformers : vvwtypes.h
  • vvwiPictureIcon : vvwtypes.h
  • vvwiPosterFrame : vvwtypes.h
  • vvwiProduced : vvwtypes.h
  • vvwiProducer : vvwtypes.h
  • vvwiProduct : vvwtypes.h
  • vvwiProject : vvwtypes.h
  • vvwiProxyFile : vvwtypes.h
  • vvwiRatings : vvwtypes.h
  • vvwiReel : vvwtypes.h
  • vvwiRevisionNumber : vvwtypes.h
  • vvwiScene : vvwtypes.h
  • vvwiSequenceNumber : vvwtypes.h
  • vvwiShot : vvwtypes.h
  • vvwiSlateInfo : vvwtypes.h
  • vvwiSoftware : vvwtypes.h
  • vvwiSoundRoll : vvwtypes.h
  • vvwiSource : vvwtypes.h
  • vvwiSourceLocator : vvwtypes.h
  • vvwiSpecialPlaybackRequirements : vvwtypes.h
  • vvwiStatus : vvwtypes.h
  • vvwiSubject : vvwtypes.h
  • vvwiSupplier : vvwtypes.h
  • vvwiTagNumber : vvwtypes.h
  • vvwiTake : vvwtypes.h
  • vvwiTimeCode : vvwtypes.h
  • vvwiTimeCodeType : vvwtypes.h
  • vvwiTitle : vvwtypes.h
  • vvwiTotalLength : vvwtypes.h
  • vvwiTotalStreams : vvwtypes.h
  • vvwiTrack : vvwtypes.h
  • vvwiUniversalName : vvwtypes.h
  • vvwiURLLink : vvwtypes.h
  • vvwiUserBits : vvwtypes.h
  • vvwiVersionNumber : vvwtypes.h
  • vvwiVersionString : vvwtypes.h
  • vvwiVideoBitCount : vvwtypes.h
  • vvwiVideoCaps : vvwtypes.h
  • vvwiVideoClrImportant : vvwtypes.h
  • vvwiVideoClrUsed : vvwtypes.h
  • vvwiVideoCompression : vvwtypes.h
  • vvwiVideoDrFlags : vvwtypes.h
  • vvwiVideoEditCount : vvwtypes.h
  • vvwiVideoFccHandler : vvwtypes.h
  • vvwiVideoFccType : vvwtypes.h
  • vvwiVideoFileType : vvwtypes.h
  • vvwiVideoFlags : vvwtypes.h
  • vvwiVideoFormatChangeCount : vvwtypes.h
  • vvwiVideoHeight : vvwtypes.h
  • vvwiVideoInitialFrames : vvwtypes.h
  • vvwiVideoLanguage : vvwtypes.h
  • vvwiVideoLength : vvwtypes.h
  • vvwiVideoPitch : vvwtypes.h
  • vvwiVideoPlanes : vvwtypes.h
  • vvwiVideoPriority : vvwtypes.h
  • vvwiVideoQuality : vvwtypes.h
  • vvwiVideoRate : vvwtypes.h
  • vvwiVideoResDrastic : vvwtypes.h
  • vvwiVideoReserved : vvwtypes.h
  • vvwiVideoSampleSize : vvwtypes.h
  • vvwiVideoScale : vvwtypes.h
  • vvwiVideoSizeImage : vvwtypes.h
  • vvwiVideoStart : vvwtypes.h
  • vvwiVideoSuggestedBufferSize : vvwtypes.h
  • vvwiVideoWidth : vvwtypes.h
  • vvwiVideoXPelsPerMeter : vvwtypes.h
  • vvwiVideoYPelsPeMeter : vvwtypes.h
  • vvwiVITCLine3 : vvwtypes.h
  • vvwiVITCTimeCode : vvwtypes.h
  • vvwiVITCTimeCodeType : vvwtypes.h
  • vvwiVITCUserBits : vvwtypes.h
  • vvwiWarning : vvwtypes.h
  • vvwiWhitePoint : vvwtypes.h
  • vvwLoadClip() : vvw.h
  • vvwLoadRegistry() : vvw.h
  • vvwMediaCmd() : vvw.h
  • vvwOpen() : vvw.h
  • vvwPause() : vvw.h
  • vvwPlay() : vvw.h
  • vvwPlayAtSpeed() : vvw.h
  • vvwPlayClip() : vvw.h
  • vvwPlayClipFromTo() : vvw.h
  • vvwPlayFromTo() : vvw.h
  • vvwQuit() : vvw.h
  • vvwRecord() : vvw.h
  • vvwRecordFromTo() : vvw.h
  • vvwRecordStop() : vvw.h
  • vvwReleaseChannels() : vvw.h
  • vvwSaveRegistry() : vvw.h
  • vvwSaveVVWRegistry() : vvw.h
  • vvwSaveWindowsRegistry() : vvw.h
  • vvwSeek() : vvw.h
  • vvwSeekRelative() : vvw.h
  • vvwSetAudioInput() : vvw.h
  • vvwSetAudioInputLevel() : vvw.h
  • vvwSetAudioOutput() : vvw.h
  • vvwSetAudioOutputLevel() : vvw.h
  • vvwSetAutoMode() : vvw.h
  • vvwSetClipMode() : vvw.h
  • vvwSetCompressionRate() : vvw.h
  • vvwSetErrorLog() : vvw.h
  • vvwSetRecordPresets() : vvw.h
  • vvwSetSuperImpose() : vvw.h
  • vvwSetTCSource() : vvw.h
  • vvwSetTCType() : vvw.h
  • vvwSetVideoGenlock() : vvw.h
  • vvwSetVideoGenlockSource() : vvw.h
  • vvwSetVideoInput() : vvw.h
  • vvwSetVideoInputChroma() : vvw.h
  • vvwSetVideoInputHue() : vvw.h
  • vvwSetVideoInputSetup() : vvw.h
  • vvwSetVideoInputVideo() : vvw.h
  • vvwSetVideoOutput() : vvw.h
  • vvwSetVideoTBCChroma() : vvw.h
  • vvwSetVideoTBCHue() : vvw.h
  • vvwSetVideoTBCSetup() : vvw.h
  • vvwSetVideoTBCVideo() : vvw.h
  • vvwShowConfigDialog() : vvw.h
  • vvwStart() : vvw.h
  • vvwStartService() : vvw.h
  • vvwStop() : vvw.h
  • vvwStopService() : vvw.h
  • VVWSYS_CLR : vvwtypes.h
  • VVWSYS_SET : vvwtypes.h
  • VVWSYS_SETAUDONLY : vvwtypes.h
  • VVWSYS_SETVIDONLY : vvwtypes.h
  • vvwTransfer() : vvw.h
  • vvwTrim() : vvw.h
  • vvwUpdateStatus() : vvw.h
  • vvwValueGet() : vvw.h
  • vvwValueSet() : vvw.h
  • vvwValueSet2() : vvw.h
  • vvwValueSupported() : vvw.h
  • VVWVID_PITCHALIGN1 : vvwtypes.h
  • VVWVID_PITCHALIGN16 : vvwtypes.h
  • VVWVID_PITCHALIGN4 : vvwtypes.h
  • VVWVID_PITCHALIGN8 : vvwtypes.h
  • VVWVID_PITCHALIGNANY : vvwtypes.h
  • VVWVID_PITCHMODULO : vvwtypes.h
  • VVWVID_RATESCALE_FILM : vvwtypes.h
  • VVWVID_RATESCALE_NTSC : vvwtypes.h
  • VVWVID_RATESCALE_NTSC_AVI : vvwtypes.h
  • VVWVID_RATESCALE_PAL : vvwtypes.h
  • VVWVID_SET : vvwtypes.h
  • VVWVID_SETCLR : vvwtypes.h
  • VVWVID_SIZEIMAGE : vvwtypes.h
  • VVWVID_SUGGESTEDBUFFERSIZE : vvwtypes.h
  • VVWXXX_GETSAMPLEFROMLENGTH : vvwtypes.h
  • VVWXXX_SETSAMPLETOLENGTH : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- _ -

  • _MAX_CLIP_NAME_SIZE : vvwtypes.h
  • _PDFRAMEFLAGS_CLIPEND : vvwtypes.h
  • _PDFRAMEFLAGS_CLIPSTART : vvwtypes.h
  • _PDFRAMEFLAGS_CLIPSTILL : vvwtypes.h
  • _PDFRAMEFLAGS_FIRSTFRAME : vvwtypes.h
  • _PDFRAMEFLAGS_LASTFRAME : vvwtypes.h
  • _VVW_ABS_MAX_CHANNELS : vvwtypes.h
  • _VVW_CONTROL_MAX_CONTROL : vvwtypes.h
  • _VVW_CONTROL_MAX_EXTERNAL : vvwtypes.h
  • _VVW_CONTROL_MAX_LOCAL : vvwtypes.h
  • _VVW_CONTROL_MAX_NETWORK : vvwtypes.h
  • _VVW_CONTROL_START_EXTERNAL : vvwtypes.h
  • _VVW_CONTROL_START_LOCAL : vvwtypes.h
  • _VVW_CONTROL_START_NETWORK : vvwtypes.h
  • _VVW_DSYNC_CHANNEL : vvwtypes.h
  • _VVW_DSYNC_LTC_CHANNEL : vvwtypes.h
  • _VVW_H_MAINHEADER_INCLUDED : vvw.h
  • _VVW_IS_VVWAUDIO : vvwtypes.h
  • _VVW_IS_VVWINFO : vvwtypes.h
  • _VVW_IS_VVWSYSTEM : vvwtypes.h
  • _VVW_IS_VVWVIDEO : vvwtypes.h
  • _VVW_STANDARD_PIPE_NAME : vvw.h
  • _VVW_TYPES_HAVE_ALREADY_BEEN_INCLUDED : vvwtypes.h
  • _VVWXXX_NAME_SIZE : vvwtypes.h
  • _VVWXXX_RESERVED_SIZE : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- m -

  • MASK___DRFLAGS_FIELD : vvwtypes.h
  • MASK___DRFLAGS_KEYFRAME : vvwtypes.h
  • MASK___DRFLAGS_VTYPE : vvwtypes.h
  • MASK___FCCMODIFIERS : vvwtypes.h
  • MASK___PREVIEW : vvwtypes.h
  • MASK__CODECPRIVATEDATA : vvwtypes.h
  • MB_CODEC_DESC_LEN : vvwtypes.h
  • MB_CODEC_SHORT_LEN : vvwtypes.h
  • MB_FILE_DESC_LEN : vvwtypes.h
  • MB_FILE_EXT_LEN : vvwtypes.h
  • MB_FILE_SHORT_LEN : vvwtypes.h
  • MEDIACMD_CHECK_MASK : mediacmd.h
  • MEDIACMD_CHECK_VER : mediacmd.h
  • MEDIACMD_CURRENT : mediacmd.h
  • MEDIACMD_VERSION_MAJOR : mediacmd.h
  • MEDIACMD_VERSION_MASK : mediacmd.h
  • MEDIACMD_VERSION_MINOR : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- a -

  • audChanAll : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- c -

  • CHAN_ILLEGAL : mediacmd.h
  • CMD_MAX_CLIP_ID_LEN : mediacmd.h
  • CMD_QUEUE_ELEMSIZE : mediacmd.h
  • CmdQueueElem : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- d -

  • DECLARE_DRASTIC_CHANNEL : vvwtypes.h
  • DECLARE_MEDIACMD : mediacmd.h
  • DFRAME_FIELD_INVERT : vvwtypes.h
  • DFRAME_LARGE_AUDIO : vvwtypes.h
  • DFRAME_NEW_FORMAT : vvwtypes.h
  • DFRAME_ORIENTATION_INVERT : vvwtypes.h
  • DFRAME_PROGRESSIVE : vvwtypes.h
  • DFRAME_SKIP_FRAME : vvwtypes.h
  • DFRAME_TIME_INVERT : vvwtypes.h
  • DFRAME_TYPE_AUDIO : vvwtypes.h
  • DFRAME_TYPE_FI_PTR_DATA : vvwtypes.h
  • DFRAME_TYPE_KEYFRAME : vvwtypes.h
  • DFRAME_TYPE_KEYFRAME_B : vvwtypes.h
  • DFRAME_TYPE_KEYFRAME_I : vvwtypes.h
  • DFRAME_TYPE_KEYFRAME_P : vvwtypes.h
  • DFRAME_TYPE_NOTPHYSHEAP : vvwtypes.h
  • DFRAME_TYPE_PAUSE : vvwtypes.h
  • DFRAME_TYPE_PLAY : vvwtypes.h
  • DFRAME_TYPE_RECORD : vvwtypes.h
  • DFRAME_TYPE_VIDEO : vvwtypes.h
  • DRFLAGS_CODECPRIVATEDATA_AVI : vvwtypes.h
  • DRFLAGS_CODECPRIVATEDATA_MOV : vvwtypes.h
  • DRFLAGS_CODECPRIVATEDATA_OMF : vvwtypes.h
  • DRFLAGS_FCC_MJPG_DCx0 : vvwtypes.h
  • DRFLAGS_FCC_MJPG_DIGISUITE : vvwtypes.h
  • DRFLAGS_FCC_MJPG_DSEDIT : vvwtypes.h
  • DRFLAGS_FCC_MJPG_JFIF : vvwtypes.h
  • DRFLAGS_FCC_MJPG_JPGDIB : vvwtypes.h
  • DRFLAGS_FCC_USE_ICM : vvwtypes.h
  • DRFLAGS_FCC_USE_INTERN : vvwtypes.h
  • DRFLAGS_FCC_USE_QT : vvwtypes.h
  • DRFLAGS_FIRST_FIELD_DOMINANT : vvwtypes.h
  • DRFLAGS_HAS_KEYFRAMES : vvwtypes.h
  • DRFLAGS_NOT_QUICKCLIP : vvwtypes.h
  • DRFLAGS_VTYPE_INTERLACED : vvwtypes.h
  • DRFLAGS_VTYPE_PROGRESSIVE : vvwtypes.h
  • DRFLAGS_VTYPE_SEGMENTEDFRAME : vvwtypes.h
  • DRFLAGS_ZERO_FIELD_DOMINANT : vvwtypes.h
  • DTVHDR_DONE : vvwtypes.h
  • DTVHDR_INQUEUE : vvwtypes.h
  • DTVHDR_KEYFRAME : vvwtypes.h
  • DTVHDR_PREPARED : vvwtypes.h
  • DTVVW_PREVIEW : vvwtypes.h
  • DTWAVE_FORMAT_PCM : vvwtypes.h
  • DTWHDR_BEGINLOOP : vvwtypes.h
  • DTWHDR_DONE : vvwtypes.h
  • DTWHDR_ENDLOOP : vvwtypes.h
  • DTWHDR_INQUEUE : vvwtypes.h
  • DTWHDR_PREPARED : vvwtypes.h
  • dwFI_DataAreaSize : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- g -

  • GetAudio : vvwtypes.h
  • GetCurrent : vvwtypes.h
  • GetInf : vvwtypes.h
  • GetNoFail : vvwtypes.h
  • GetQueued : vvwtypes.h
  • GetVideo : vvwtypes.h
  • GS_ALPHACHROMA_ALPHA : mediacmd.h
  • GS_ALPHACHROMA_DUAL : mediacmd.h
  • GS_ALPHACHROMA_SINGLE : mediacmd.h
  • GS_ANALOGMONITORMETHOD_DIRECT : mediacmd.h
  • GS_ANALOGMONITORMETHOD_FLIP1080 : mediacmd.h
  • GS_ANALOGMONITORMETHOD_FLIP720 : mediacmd.h
  • GS_ANALOGMONITORMETHOD_HD1080 : mediacmd.h
  • GS_ANALOGMONITORMETHOD_HD720 : mediacmd.h
  • GS_ANALOGMONITORMETHOD_SD : mediacmd.h
  • GS_ASPECT_RATIO_16x9 : mediacmd.h
  • GS_ASPECT_RATIO_2_21x1 : mediacmd.h
  • GS_ASPECT_RATIO_4x3 : mediacmd.h
  • GS_ASPECT_RATIO_SQUARE : mediacmd.h
  • GS_ASSEMBLE_EDIT : mediacmd.h
  • GS_AUD_BIT_RATE_112000 : mediacmd.h
  • GS_AUD_BIT_RATE_128000 : mediacmd.h
  • GS_AUD_BIT_RATE_160000 : mediacmd.h
  • GS_AUD_BIT_RATE_192000 : mediacmd.h
  • GS_AUD_BIT_RATE_224000 : mediacmd.h
  • GS_AUD_BIT_RATE_256000 : mediacmd.h
  • GS_AUD_BIT_RATE_32000 : mediacmd.h
  • GS_AUD_BIT_RATE_320000 : mediacmd.h
  • GS_AUD_BIT_RATE_384000 : mediacmd.h
  • GS_AUD_BIT_RATE_41100 : mediacmd.h
  • GS_AUD_BIT_RATE_48000 : mediacmd.h
  • GS_AUD_BIT_RATE_56000 : mediacmd.h
  • GS_AUD_BIT_RATE_64000 : mediacmd.h
  • GS_AUD_BIT_RATE_80000 : mediacmd.h
  • GS_AUD_BIT_RATE_96000 : mediacmd.h
  • GS_AUD_DUAL : mediacmd.h
  • GS_AUD_HEADROOM_18 : mediacmd.h
  • GS_AUD_HEADROOM_20 : mediacmd.h
  • GS_AUD_JOINT_STEREO : mediacmd.h
  • GS_AUD_MULTIPLE : mediacmd.h
  • GS_AUD_SINGLE : mediacmd.h
  • GS_AUD_STEREO : mediacmd.h
  • GS_AUDSELECT_AES_EBU : mediacmd.h
  • GS_AUDSELECT_AES_EBU_PRO : mediacmd.h
  • GS_AUDSELECT_BALANCED_10 : mediacmd.h
  • GS_AUDSELECT_BALANCED_4 : mediacmd.h
  • GS_AUDSELECT_EMBEDDED : mediacmd.h
  • GS_AUDSELECT_NONE : mediacmd.h
  • GS_AUDSELECT_SILENT : mediacmd.h
  • GS_AUDSELECT_SPDIF : mediacmd.h
  • GS_AUDSELECT_UNBALANCED_10 : mediacmd.h
  • GS_AUDSELECT_UNBALANCED_4 : mediacmd.h
  • GS_BAD_PARAM : mediacmd.h
  • GS_BITCOUNT_10 : mediacmd.h
  • GS_BITCOUNT_12 : mediacmd.h
  • GS_BITCOUNT_24 : mediacmd.h
  • GS_BITCOUNT_30 : mediacmd.h
  • GS_BITCOUNT_32 : mediacmd.h
  • GS_BITCOUNT_8 : mediacmd.h
  • GS_CHANCAP_ALL : mediacmd.h
  • GS_CHANCAP_AUDPREVIEW : mediacmd.h
  • GS_CHANCAP_CLIPSPACE : mediacmd.h
  • GS_CHANCAP_EDIT : mediacmd.h
  • GS_CHANCAP_EJECT : mediacmd.h
  • GS_CHANCAP_ERROR : mediacmd.h
  • GS_CHANCAP_ETOE : mediacmd.h
  • GS_CHANCAP_FILE : mediacmd.h
  • GS_CHANCAP_JOG : mediacmd.h
  • GS_CHANCAP_LOOP : mediacmd.h
  • GS_CHANCAP_MPEG_ENC : mediacmd.h
  • GS_CHANCAP_NET : mediacmd.h
  • GS_CHANCAP_PAUSE : mediacmd.h
  • GS_CHANCAP_PLAY : mediacmd.h
  • GS_CHANCAP_PREVIEW : mediacmd.h
  • GS_CHANCAP_RECORD : mediacmd.h
  • GS_CHANCAP_RECSTOP : mediacmd.h
  • GS_CHANCAP_REVPLAY : mediacmd.h
  • GS_CHANCAP_SEEK : mediacmd.h
  • GS_CHANCAP_SELECTPRESET : mediacmd.h
  • GS_CHANCAP_SHUTTLE : mediacmd.h
  • GS_CHANCAP_STOP : mediacmd.h
  • GS_CHANCAP_TCSPACE : mediacmd.h
  • GS_CHANCAP_VGAPREVIEW : mediacmd.h
  • GS_CHROMA_FORMAT_411 : mediacmd.h
  • GS_CHROMA_FORMAT_420 : mediacmd.h
  • GS_CHROMA_FORMAT_422 : mediacmd.h
  • GS_CHROMA_FORMAT_444 : mediacmd.h
  • GS_CLIPMODE_CLIPSPACE : mediacmd.h
  • GS_CLIPMODE_FILM : mediacmd.h
  • GS_CLIPMODE_ILLEGAL : mediacmd.h
  • GS_CLIPMODE_SINGLE : mediacmd.h
  • GS_CLIPMODE_TCSPACE : mediacmd.h
  • GS_CLRFRM_2FLD : mediacmd.h
  • GS_CLRFRM_4FLD : mediacmd.h
  • GS_CLRFRM_8FLD : mediacmd.h
  • GS_CLRFRM_DEFAULT : mediacmd.h
  • GS_COMPTYPE_ABGR : mediacmd.h
  • GS_COMPTYPE_ARGB : mediacmd.h
  • GS_COMPTYPE_BGR : mediacmd.h
  • GS_COMPTYPE_BGRA : mediacmd.h
  • GS_COMPTYPE_BGRA_INVERT : mediacmd.h
  • GS_COMPTYPE_DV100 : mediacmd.h
  • GS_COMPTYPE_DV25 : mediacmd.h
  • GS_COMPTYPE_DV50 : mediacmd.h
  • GS_COMPTYPE_DVSD : mediacmd.h
  • GS_COMPTYPE_HDPAN : mediacmd.h
  • GS_COMPTYPE_HDSONY : mediacmd.h
  • GS_COMPTYPE_MJPEG : mediacmd.h
  • GS_COMPTYPE_MPEG1 : mediacmd.h
  • GS_COMPTYPE_MPEG2 : mediacmd.h
  • GS_COMPTYPE_MPEG2I : mediacmd.h
  • GS_COMPTYPE_MPEG2IBP : mediacmd.h
  • GS_COMPTYPE_RGB : mediacmd.h
  • GS_COMPTYPE_RGBA : mediacmd.h
  • GS_COMPTYPE_SOFTWARE : mediacmd.h
  • GS_COMPTYPE_UN10BIT : mediacmd.h
  • GS_COMPTYPE_UN8BIT : mediacmd.h
  • GS_COMPTYPE_WAVELET : mediacmd.h
  • GS_COMPTYPE_YCRCB_420 : mediacmd.h
  • GS_COMPTYPE_YCRCB_422 : mediacmd.h
  • GS_COMPTYPE_YCRCB_422_STEREO : mediacmd.h
  • GS_COMPTYPE_YCRCB_422A : mediacmd.h
  • GS_COMPTYPE_YCRCB_444 : mediacmd.h
  • GS_COMPTYPE_YCRCB_444A : mediacmd.h
  • GS_DEFAULT : mediacmd.h
  • GS_DISABLE : mediacmd.h
  • GS_DOWNCONVERT_ANAMORPHIC : mediacmd.h
  • GS_DOWNCONVERT_CROP : mediacmd.h
  • GS_DOWNCONVERT_LETTERBOX : mediacmd.h
  • GS_ENABLE : mediacmd.h
  • GS_FALSE : mediacmd.h
  • GS_FIELD : mediacmd.h
  • GS_FIELD1 : mediacmd.h
  • GS_FIELD2 : mediacmd.h
  • GS_FRAME : mediacmd.h
  • GS_FRAMEDATA_ASCII : mediacmd.h
  • GS_FRAMEDATA_CC_TTEXT : mediacmd.h
  • GS_FRAMEDATA_HEX : mediacmd.h
  • GS_FRAMEDATA_NAVY : mediacmd.h
  • GS_FRAMEDATA_TELECINE : mediacmd.h
  • GS_FRAMEDATA_UNKNOWN : mediacmd.h
  • GS_HEADSEL_DEFAULT : mediacmd.h
  • GS_HEADSEL_PLAY : mediacmd.h
  • GS_HEADSEL_RECPLAY : mediacmd.h
  • GS_INSERT_EDIT : mediacmd.h
  • GS_LOCKSRC_CVBS : mediacmd.h
  • GS_LOCKSRC_EXTIN : mediacmd.h
  • GS_LOCKSRC_IN_Y : mediacmd.h
  • GS_LOCKSRC_INPUT : mediacmd.h
  • GS_LOCKSRC_NONE : mediacmd.h
  • GS_LOCKSRC_SDI : mediacmd.h
  • GS_LOCKSRC_SVIDEO : mediacmd.h
  • GS_MONITORGRAB_NONE : mediacmd.h
  • GS_MONITORGRAB_SIZE_FULL : mediacmd.h
  • GS_MONITORGRAB_SIZE_HALF : mediacmd.h
  • GS_MONITORGRAB_SIZE_MASK : mediacmd.h
  • GS_MONITORGRAB_SIZE_QUARTER : mediacmd.h
  • GS_MONITORGRAB_TARGET_MASK : mediacmd.h
  • GS_MONITORGRAB_TO_HTTP : mediacmd.h
  • GS_MONITORGRAB_TO_MEMORY : mediacmd.h
  • GS_MONITORGRAB_TO_NETWORK : mediacmd.h
  • GS_MONITORGRAB_TO_UNC_PATH : mediacmd.h
  • GS_MONITORGRAB_TYPE_BMP : mediacmd.h
  • GS_MONITORGRAB_TYPE_JPG : mediacmd.h
  • GS_MONITORGRAB_TYPE_MASK : mediacmd.h
  • GS_MPEG_ASPECT_RATIO_16x9 : mediacmd.h
  • GS_MPEG_ASPECT_RATIO_2_21x1 : mediacmd.h
  • GS_MPEG_ASPECT_RATIO_4x3 : mediacmd.h
  • GS_MPEG_ASPECT_RATIO_SQUARE : mediacmd.h
  • GS_MPEG_CC_FORMAT_ATSC : mediacmd.h
  • GS_MPEG_CC_FORMAT_ATSC_REORDER : mediacmd.h
  • GS_MPEG_CC_FORMAT_CCUBE : mediacmd.h
  • GS_MPEG_CC_FORMAT_CCUBE_REORDER : mediacmd.h
  • GS_MPEG_CHROMA_FORMAT_420 : mediacmd.h
  • GS_MPEG_CHROMA_FORMAT_422 : mediacmd.h
  • GS_MPEG_CHROMA_FORMAT_444 : mediacmd.h
  • GS_MPEG_DC_PRECISION_10 : mediacmd.h
  • GS_MPEG_DC_PRECISION_11 : mediacmd.h
  • GS_MPEG_DC_PRECISION_8 : mediacmd.h
  • GS_MPEG_DC_PRECISION_9 : mediacmd.h
  • GS_MPEG_EIGHT_FRAMES : mediacmd.h
  • GS_MPEG_ELEVEN_FRAMES : mediacmd.h
  • GS_MPEG_FIFTEEN_FRAMES : mediacmd.h
  • GS_MPEG_FIVE_FRAMES : mediacmd.h
  • GS_MPEG_FOUR_FRAMES : mediacmd.h
  • GS_MPEG_FOURTEEN_FRAMES : mediacmd.h
  • GS_MPEG_LANGAUGE_CHINESE : mediacmd.h
  • GS_MPEG_LANGAUGE_DANISH : mediacmd.h
  • GS_MPEG_LANGAUGE_DUTCH : mediacmd.h
  • GS_MPEG_LANGAUGE_ENGLISH : mediacmd.h
  • GS_MPEG_LANGAUGE_FINNISH : mediacmd.h
  • GS_MPEG_LANGAUGE_FRENCH : mediacmd.h
  • GS_MPEG_LANGAUGE_GERMAN : mediacmd.h
  • GS_MPEG_LANGAUGE_GREEK : mediacmd.h
  • GS_MPEG_LANGAUGE_ITALIAN : mediacmd.h
  • GS_MPEG_LANGAUGE_JAPANESE : mediacmd.h
  • GS_MPEG_LANGAUGE_PORTUGUESE : mediacmd.h
  • GS_MPEG_LANGAUGE_RUSSIAN : mediacmd.h
  • GS_MPEG_LANGAUGE_SPANISH : mediacmd.h
  • GS_MPEG_LANGAUGE_SWEDISH : mediacmd.h
  • GS_MPEG_NINE_FRAMES : mediacmd.h
  • GS_MPEG_ONE_FRAMES : mediacmd.h
  • GS_MPEG_RESOLUTION_120 : mediacmd.h
  • GS_MPEG_RESOLUTION_240 : mediacmd.h
  • GS_MPEG_RESOLUTION_288 : mediacmd.h
  • GS_MPEG_RESOLUTION_352 : mediacmd.h
  • GS_MPEG_RESOLUTION_480 : mediacmd.h
  • GS_MPEG_RESOLUTION_512 : mediacmd.h
  • GS_MPEG_RESOLUTION_544 : mediacmd.h
  • GS_MPEG_RESOLUTION_576 : mediacmd.h
  • GS_MPEG_RESOLUTION_608 : mediacmd.h
  • GS_MPEG_RESOLUTION_704 : mediacmd.h
  • GS_MPEG_RESOLUTION_720 : mediacmd.h
  • GS_MPEG_SEVEN_FRAMES : mediacmd.h
  • GS_MPEG_SIX_FRAMES : mediacmd.h
  • GS_MPEG_SIXTEEN_FRAMES : mediacmd.h
  • GS_MPEG_STANDARD_ELEMENTARY : mediacmd.h
  • GS_MPEG_STANDARD_ELEMENTRY : mediacmd.h
  • GS_MPEG_STANDARD_PROGRAM : mediacmd.h
  • GS_MPEG_STANDARD_SYSTEM : mediacmd.h
  • GS_MPEG_STANDARD_TRANSPORT : mediacmd.h
  • GS_MPEG_TEN_FRAMES : mediacmd.h
  • GS_MPEG_THIRTEEN_FRAMES : mediacmd.h
  • GS_MPEG_THREE_FRAMES : mediacmd.h
  • GS_MPEG_TWELVE_FRAMES : mediacmd.h
  • GS_MPEG_TWO_FRAMES : mediacmd.h
  • GS_NOT_SUPPORTED : mediacmd.h
  • GS_PBEE_AUTO : mediacmd.h
  • GS_PBEE_DEFAULT : mediacmd.h
  • GS_PBEE_PB : mediacmd.h
  • GS_PROXYMODE_AFTERRECORD : mediacmd.h
  • GS_PROXYMODE_EVERYTHING : mediacmd.h
  • GS_PROXYMODE_NOTHING : mediacmd.h
  • GS_PROXYMODE_RECORD : mediacmd.h
  • GS_SERVOREF_AUTO : mediacmd.h
  • GS_SERVOREF_DEFAULT : mediacmd.h
  • GS_SERVOREF_EXT : mediacmd.h
  • GS_SIGFORM_1035i_30_260M : mediacmd.h
  • GS_SIGFORM_1035i_30X_260M : mediacmd.h
  • GS_SIGFORM_1080_24 : mediacmd.h
  • GS_SIGFORM_1080_24X : mediacmd.h
  • GS_SIGFORM_1080_25 : mediacmd.h
  • GS_SIGFORM_1080_30 : mediacmd.h
  • GS_SIGFORM_1080_30X : mediacmd.h
  • GS_SIGFORM_1080_50 : mediacmd.h
  • GS_SIGFORM_1080_60 : mediacmd.h
  • GS_SIGFORM_1080_60X : mediacmd.h
  • GS_SIGFORM_1080i_24 : mediacmd.h
  • GS_SIGFORM_1080i_24X : mediacmd.h
  • GS_SIGFORM_1080i_25 : mediacmd.h
  • GS_SIGFORM_1080i_30 : mediacmd.h
  • GS_SIGFORM_1080i_30X : mediacmd.h
  • GS_SIGFORM_1080sf_24 : mediacmd.h
  • GS_SIGFORM_1080sf_24X : mediacmd.h
  • GS_SIGFORM_720_24 : mediacmd.h
  • GS_SIGFORM_720_25 : mediacmd.h
  • GS_SIGFORM_720_30 : mediacmd.h
  • GS_SIGFORM_720_30X : mediacmd.h
  • GS_SIGFORM_720_50 : mediacmd.h
  • GS_SIGFORM_720_60 : mediacmd.h
  • GS_SIGFORM_720_60X : mediacmd.h
  • GS_SIGFORM_ALT_NTSC : mediacmd.h
  • GS_SIGFORM_ALT_PAL : mediacmd.h
  • GS_SIGFORM_CCIR_NTSC : mediacmd.h
  • GS_SIGFORM_CCIR_NTSC_P483 : mediacmd.h
  • GS_SIGFORM_CCIR_PAL : mediacmd.h
  • GS_SIGFORM_CCIR_PNTSC_30 : mediacmd.h
  • GS_SIGFORM_CCIR_PPAL_25 : mediacmd.h
  • GS_SIGFORM_CUSTOM : mediacmd.h
  • GS_SIGFORM_DCIN_2048_24 : mediacmd.h
  • GS_SIGFORM_DCIN_2048_24X : mediacmd.h
  • GS_SIGFORM_DCIN_2048_25 : mediacmd.h
  • GS_SIGFORM_DCIN_2048sf_24 : mediacmd.h
  • GS_SIGFORM_DCIN_2048sf_24X : mediacmd.h
  • GS_SIGFORM_DVI_1400_1050_24 : mediacmd.h
  • GS_SIGFORM_DVI_1400_1050_25 : mediacmd.h
  • GS_SIGFORM_FILM_1828_1102_24 : mediacmd.h
  • GS_SIGFORM_FILM_1828_1102_25 : mediacmd.h
  • GS_SIGFORM_FILM_1828_1332_24 : mediacmd.h
  • GS_SIGFORM_FILM_1828_1332_25 : mediacmd.h
  • GS_SIGFORM_FILM_1828_778_24 : mediacmd.h
  • GS_SIGFORM_FILM_1828_778_25 : mediacmd.h
  • GS_SIGFORM_FILM_1828_988_24 : mediacmd.h
  • GS_SIGFORM_FILM_1828_988_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1102_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1102_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1234_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1234_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048_14 : mediacmd.h
  • GS_SIGFORM_FILM_2048_15 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_15 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_15X : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_24X : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_48 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536_48X : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536sf_15 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536sf_15X : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536sf_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_1536sf_24X : mediacmd.h
  • GS_SIGFORM_FILM_2048_15X : mediacmd.h
  • GS_SIGFORM_FILM_2048_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_24X : mediacmd.h
  • GS_SIGFORM_FILM_2048_48 : mediacmd.h
  • GS_SIGFORM_FILM_2048_857_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_857_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048_872_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048_872_25 : mediacmd.h
  • GS_SIGFORM_FILM_2048sf_15 : mediacmd.h
  • GS_SIGFORM_FILM_2048sf_15X : mediacmd.h
  • GS_SIGFORM_FILM_2048sf_24 : mediacmd.h
  • GS_SIGFORM_FILM_2048sf_24X : mediacmd.h
  • GS_SIGFORM_FILM_4096_1714_24 : mediacmd.h
  • GS_SIGFORM_FILM_4096_1714_24X : mediacmd.h
  • GS_SIGFORM_FILM_4096_3112_24 : mediacmd.h
  • GS_SIGFORM_FILM_4096_3112_24X : mediacmd.h
  • GS_SIGFORM_FILM_4096_3112sf_5 : mediacmd.h
  • GS_SIGFORM_HD360 : mediacmd.h
  • GS_SIGFORM_NOT_PRESENT : mediacmd.h
  • GS_SIGFORM_NTSC : mediacmd.h
  • GS_SIGFORM_PAL : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1035 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1080 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1400 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1536 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_1556 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_360 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_720 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_DCIN : mediacmd.h
  • GS_SIGFORM_SUPPORTS_EXTRA8 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_HR : mediacmd.h
  • GS_SIGFORM_SUPPORTS_NTSC : mediacmd.h
  • GS_SIGFORM_SUPPORTS_PAL : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V1024 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V1200 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V1600 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V480 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V600 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_V768 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_X2 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_X3 : mediacmd.h
  • GS_SIGFORM_SUPPORTS_X4 : mediacmd.h
  • GS_SIGFORM_VESA_1024_71X : mediacmd.h
  • GS_SIGFORM_VESA_1024_72 : mediacmd.h
  • GS_SIGFORM_VESA_1280_24 : mediacmd.h
  • GS_SIGFORM_VESA_1280_71X : mediacmd.h
  • GS_SIGFORM_VESA_1280_72 : mediacmd.h
  • GS_SIGFORM_VESA_1280i_30 : mediacmd.h
  • GS_SIGFORM_VESA_1600i_30 : mediacmd.h
  • GS_SIGFORM_VESA_640_72 : mediacmd.h
  • GS_SIGFORM_VESA_800_71X : mediacmd.h
  • GS_SIGFORM_VESA_800_72 : mediacmd.h
  • GS_SIGFORMFRAMERATE_10 : mediacmd.h
  • GS_SIGFORMFRAMERATE_100 : mediacmd.h
  • GS_SIGFORMFRAMERATE_119_88 : mediacmd.h
  • GS_SIGFORMFRAMERATE_14_98 : mediacmd.h
  • GS_SIGFORMFRAMERATE_15 : mediacmd.h
  • GS_SIGFORMFRAMERATE_23_98 : mediacmd.h
  • GS_SIGFORMFRAMERATE_24 : mediacmd.h
  • GS_SIGFORMFRAMERATE_25 : mediacmd.h
  • GS_SIGFORMFRAMERATE_29_97 : mediacmd.h
  • GS_SIGFORMFRAMERATE_30 : mediacmd.h
  • GS_SIGFORMFRAMERATE_47_95 : mediacmd.h
  • GS_SIGFORMFRAMERATE_48 : mediacmd.h
  • GS_SIGFORMFRAMERATE_5 : mediacmd.h
  • GS_SIGFORMFRAMERATE_50 : mediacmd.h
  • GS_SIGFORMFRAMERATE_59_94 : mediacmd.h
  • GS_SIGFORMFRAMERATE_6 : mediacmd.h
  • GS_SIGFORMFRAMERATE_60 : mediacmd.h
  • GS_SIGFORMFRAMERATE_71_93 : mediacmd.h
  • GS_SIGFORMFRAMERATE_72 : mediacmd.h
  • GS_SIGFORMFRAMERATE_7_5 : mediacmd.h
  • GS_SIGFORMFRAMERATE_CUSTOM : mediacmd.h
  • GS_SIGFORMMASK_FRAMERATE : mediacmd.h
  • GS_SIGFORMMASK_FRAMETYPE : mediacmd.h
  • GS_SIGFORMMASK_HORIZONTAL : mediacmd.h
  • GS_SIGFORMMASK_VERTICAL : mediacmd.h
  • GS_SIGFORMSHIFT_FRAMERATE : mediacmd.h
  • GS_SIGFORMSHIFT_FRAMETYPE : mediacmd.h
  • GS_SIGFORMSHIFT_HORIZONTAL : mediacmd.h
  • GS_SIGFORMSHIFT_VERTICAL : mediacmd.h
  • GS_SIGFORMSIZE_1024 : mediacmd.h
  • GS_SIGFORMSIZE_1024x1024 : mediacmd.h
  • GS_SIGFORMSIZE_1024x768 : mediacmd.h
  • GS_SIGFORMSIZE_1035 : mediacmd.h
  • GS_SIGFORMSIZE_1044 : mediacmd.h
  • GS_SIGFORMSIZE_1050 : mediacmd.h
  • GS_SIGFORMSIZE_1052 : mediacmd.h
  • GS_SIGFORMSIZE_1080 : mediacmd.h
  • GS_SIGFORMSIZE_1088 : mediacmd.h
  • GS_SIGFORMSIZE_1096 : mediacmd.h
  • GS_SIGFORMSIZE_1102 : mediacmd.h
  • GS_SIGFORMSIZE_1152 : mediacmd.h
  • GS_SIGFORMSIZE_1152x864 : mediacmd.h
  • GS_SIGFORMSIZE_1200 : mediacmd.h
  • GS_SIGFORMSIZE_1234 : mediacmd.h
  • GS_SIGFORMSIZE_1280 : mediacmd.h
  • GS_SIGFORMSIZE_1280x1024 : mediacmd.h
  • GS_SIGFORMSIZE_1280x720 : mediacmd.h
  • GS_SIGFORMSIZE_1332 : mediacmd.h
  • GS_SIGFORMSIZE_1400 : mediacmd.h
  • GS_SIGFORMSIZE_1400x1050 : mediacmd.h
  • GS_SIGFORMSIZE_1440 : mediacmd.h
  • GS_SIGFORMSIZE_1536 : mediacmd.h
  • GS_SIGFORMSIZE_1556 : mediacmd.h
  • GS_SIGFORMSIZE_1588 : mediacmd.h
  • GS_SIGFORMSIZE_1600 : mediacmd.h
  • GS_SIGFORMSIZE_1600x1200 : mediacmd.h
  • GS_SIGFORMSIZE_1714 : mediacmd.h
  • GS_SIGFORMSIZE_1828 : mediacmd.h
  • GS_SIGFORMSIZE_1828x1102 : mediacmd.h
  • GS_SIGFORMSIZE_1828x1332 : mediacmd.h
  • GS_SIGFORMSIZE_1828x778 : mediacmd.h
  • GS_SIGFORMSIZE_1828x988 : mediacmd.h
  • GS_SIGFORMSIZE_1920 : mediacmd.h
  • GS_SIGFORMSIZE_1920x1035 : mediacmd.h
  • GS_SIGFORMSIZE_1920x1080 : mediacmd.h
  • GS_SIGFORMSIZE_1920x1088 : mediacmd.h
  • GS_SIGFORMSIZE_2048 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1080 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1102 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1234 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1536 : mediacmd.h
  • GS_SIGFORMSIZE_2048x1556 : mediacmd.h
  • GS_SIGFORMSIZE_2048x857 : mediacmd.h
  • GS_SIGFORMSIZE_2048x872 : mediacmd.h
  • GS_SIGFORMSIZE_240 : mediacmd.h
  • GS_SIGFORMSIZE_243 : mediacmd.h
  • GS_SIGFORMSIZE_2560x1080 : mediacmd.h
  • GS_SIGFORMSIZE_2650 : mediacmd.h
  • GS_SIGFORMSIZE_288 : mediacmd.h
  • GS_SIGFORMSIZE_3112 : mediacmd.h
  • GS_SIGFORMSIZE_320 : mediacmd.h
  • GS_SIGFORMSIZE_352 : mediacmd.h
  • GS_SIGFORMSIZE_360 : mediacmd.h
  • GS_SIGFORMSIZE_4096 : mediacmd.h
  • GS_SIGFORMSIZE_4096x1714 : mediacmd.h
  • GS_SIGFORMSIZE_4096x3112 : mediacmd.h
  • GS_SIGFORMSIZE_480 : mediacmd.h
  • GS_SIGFORMSIZE_483 : mediacmd.h
  • GS_SIGFORMSIZE_486 : mediacmd.h
  • GS_SIGFORMSIZE_496 : mediacmd.h
  • GS_SIGFORMSIZE_504 : mediacmd.h
  • GS_SIGFORMSIZE_512 : mediacmd.h
  • GS_SIGFORMSIZE_576 : mediacmd.h
  • GS_SIGFORMSIZE_600 : mediacmd.h
  • GS_SIGFORMSIZE_608 : mediacmd.h
  • GS_SIGFORMSIZE_640 : mediacmd.h
  • GS_SIGFORMSIZE_640x480 : mediacmd.h
  • GS_SIGFORMSIZE_640x576 : mediacmd.h
  • GS_SIGFORMSIZE_720 : mediacmd.h
  • GS_SIGFORMSIZE_720x480 : mediacmd.h
  • GS_SIGFORMSIZE_720x483 : mediacmd.h
  • GS_SIGFORMSIZE_720x486 : mediacmd.h
  • GS_SIGFORMSIZE_720x504 : mediacmd.h
  • GS_SIGFORMSIZE_720x512 : mediacmd.h
  • GS_SIGFORMSIZE_720x576 : mediacmd.h
  • GS_SIGFORMSIZE_720x608 : mediacmd.h
  • GS_SIGFORMSIZE_768 : mediacmd.h
  • GS_SIGFORMSIZE_778 : mediacmd.h
  • GS_SIGFORMSIZE_800 : mediacmd.h
  • GS_SIGFORMSIZE_800x600 : mediacmd.h
  • GS_SIGFORMSIZE_857 : mediacmd.h
  • GS_SIGFORMSIZE_864 : mediacmd.h
  • GS_SIGFORMSIZE_872 : mediacmd.h
  • GS_SIGFORMSIZE_960 : mediacmd.h
  • GS_SIGFORMSIZE_960x486 : mediacmd.h
  • GS_SIGFORMSIZE_960x504 : mediacmd.h
  • GS_SIGFORMSIZE_960x576 : mediacmd.h
  • GS_SIGFORMSIZE_968 : mediacmd.h
  • GS_SIGFORMSIZE_988 : mediacmd.h
  • GS_SIGFORMTYPE_INTERLACED : mediacmd.h
  • GS_SIGFORMTYPE_PROGRESSIVE : mediacmd.h
  • GS_SIGFORMTYPE_SEGMENTEDFRAME : mediacmd.h
  • GS_SIGFORMTYPE_UNKNOWN : mediacmd.h
  • GS_SUPFILE_ANY : mediacmd.h
  • GS_SUPFILE_AUDONLY : mediacmd.h
  • GS_SUPFILE_AVI : mediacmd.h
  • GS_SUPFILE_FIX : mediacmd.h
  • GS_SUPFILE_ODML : mediacmd.h
  • GS_SUPFILE_OMFI : mediacmd.h
  • GS_SUPFILE_QT : mediacmd.h
  • GS_SUPFILE_STILLS : mediacmd.h
  • GS_SUPFILE_UNK : mediacmd.h
  • GS_TCSOURCE_CLIP : mediacmd.h
  • GS_TCSOURCE_CTL : mediacmd.h
  • GS_TCSOURCE_LTC : mediacmd.h
  • GS_TCSOURCE_VITC : mediacmd.h
  • GS_TRUE : mediacmd.h
  • GS_UNITY : mediacmd.h
  • GS_UPCONVERT_ANAMORPHIC : mediacmd.h
  • GS_UPCONVERT_LETTERBOX : mediacmd.h
  • GS_UPCONVERT_PILLARBOX : mediacmd.h
  • GS_UPCONVERT_ZOOM14x9 : mediacmd.h
  • GS_UPCONVERT_ZOOMWIDE : mediacmd.h
  • GS_USERRIGHTS_ADD : mediacmd.h
  • GS_USERRIGHTS_ADMIN : mediacmd.h
  • GS_USERRIGHTS_DELETE : mediacmd.h
  • GS_USERRIGHTS_FULL : mediacmd.h
  • GS_USERRIGHTS_MODIFY : mediacmd.h
  • GS_USERRIGHTS_NONE : mediacmd.h
  • GS_USERRIGHTS_PLAY : mediacmd.h
  • GS_USERRIGHTS_READ : mediacmd.h
  • GS_USERRIGHTS_RECORD : mediacmd.h
  • GS_USERRIGHTS_SETUP : mediacmd.h
  • GS_USERRIGHTS_WRITE : mediacmd.h
  • GS_VIDBAND_HIGH : mediacmd.h
  • GS_VIDBAND_MEDIUM : mediacmd.h
  • GS_VIDBAND_NOTCH : mediacmd.h
  • GS_VIDBAND_STANDARD : mediacmd.h
  • GS_VIDBLACK_CRYSTAL : mediacmd.h
  • GS_VIDBLACK_SETUP : mediacmd.h
  • GS_VIDBLACK_SUPER : mediacmd.h
  • GS_VIDFREEZE_FIELD0 : mediacmd.h
  • GS_VIDFREEZE_FIELD1 : mediacmd.h
  • GS_VIDFREEZE_FRAME : mediacmd.h
  • GS_VIDFREEZE_NOT_FROZEN : mediacmd.h
  • GS_VIDLOCKTYPE_BROADCAST : mediacmd.h
  • GS_VIDLOCKTYPE_VTR : mediacmd.h
  • GS_VIDREF_DISABLE : mediacmd.h
  • GS_VIDREF_ENABLE : mediacmd.h
  • GS_VIDSELECT_COMPONENT_RGB : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_2 : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_JAPAN : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_M2 : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_SMPTE : mediacmd.h
  • GS_VIDSELECT_COMPONENT_YUV_SMPTE_JAPAN : mediacmd.h
  • GS_VIDSELECT_COMPOSITE : mediacmd.h
  • GS_VIDSELECT_COMPOSITE_2 : mediacmd.h
  • GS_VIDSELECT_COMPOSITE_3 : mediacmd.h
  • GS_VIDSELECT_COMPOSITE_4 : mediacmd.h
  • GS_VIDSELECT_COMPOSITE_JAPAN : mediacmd.h
  • GS_VIDSELECT_D1_PARALLEL : mediacmd.h
  • GS_VIDSELECT_D1_SERIAL : mediacmd.h
  • GS_VIDSELECT_D1_SERIAL_2 : mediacmd.h
  • GS_VIDSELECT_NONE : mediacmd.h
  • GS_VIDSELECT_SDTI : mediacmd.h
  • GS_VIDSELECT_SVIDEO : mediacmd.h
  • GS_VIDSELECT_SVIDEO_2 : mediacmd.h
  • GS_VIDSELECT_SVIDEO_JAPAN : mediacmd.h
  • GS_VIDSELECT_XVID_RGB : mediacmd.h
  • GS_VIDWHITE_CLAMP : mediacmd.h
  • GS_VIDWHITE_FREE : mediacmd.h
  • GS_VIDWHITE_SCALE : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- i -

  • infChanAll : mediacmd.h
  • INIT_DRASTIC_CHANNEL : vvwtypes.h
  • INIT_MEDIACMD : mediacmd.h
  • INIT_PDRASTIC_CHANNEL : vvwtypes.h
  • INIT_PMEDIACMD : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- p -

  • pCmdQueueElem : mediacmd.h
  • pFI_DataAreaPtr : vvwtypes.h
  • PutAudio : vvwtypes.h
  • PutInf : vvwtypes.h
  • PutVideo : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- s -

  • SIZEOF_MEDIACMD : mediacmd.h
  • SIZEOF_MEDIACMD_BASE : mediacmd.h
  • SIZEOF_MEDIACMD_CLIPID : mediacmd.h
  • SIZEOFDFRAME : vvwtypes.h
  • SPD_FAST_BUMP : mediacmd.h
  • SPD_FWD_MAX : mediacmd.h
  • SPD_FWD_PLAY : mediacmd.h
  • SPD_ILLEGAL : mediacmd.h
  • SPD_PAUSE : mediacmd.h
  • SPD_REV_MAX : mediacmd.h
  • SPD_REV_PLAY : mediacmd.h
  • SPD_SLOW_BUMP : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- t -

  • TC2_CHAR_100 : timecode.h
  • TC2_CHAR_2398 : timecode.h
  • TC2_CHAR_50 : timecode.h
  • TC2_CHAR_5994 : timecode.h
  • TC2_CHAR_60 : timecode.h
  • TC2_CHAR_DF : timecode.h
  • TC2_CHAR_FILM : timecode.h
  • TC2_CHAR_NDF : timecode.h
  • TC2_CHAR_NTSCFILM : timecode.h
  • TC2_CHAR_PAL : timecode.h
  • TC2_FTYPE_FIELD : timecode.h
  • TC2_GOP25TC_TO_HEXINVERT : timecode.h
  • TC2_GOP25TC_TO_HEXINVERT_ADD_DF : timecode.h
  • TC2_HEXINVERT_TO_GOP25TC : timecode.h
  • TC2_HEXINVERT_TO_GOP25TC_ADD_DF : timecode.h
  • TC2_ILLEGAL : timecode.h
  • TC2_MARK_100 : timecode.h
  • TC2_MARK_2398 : timecode.h
  • TC2_MARK_50 : timecode.h
  • TC2_MARK_5994 : timecode.h
  • TC2_MARK_60 : timecode.h
  • TC2_MARK_DF : timecode.h
  • TC2_MARK_FILM : timecode.h
  • TC2_MARK_NDF : timecode.h
  • TC2_MARK_NTSCFILM : timecode.h
  • TC2_MARK_PAL : timecode.h
  • TC2_MIN_STRING_SIZE : timecode.h
  • TC2_STREXT_ALLCOLON : timecode.h
  • TC2_STREXT_CF : timecode.h
  • TC2_STREXT_FLAG : timecode.h
  • TC2_STREXT_ISBSTR : timecode.h
  • TC2_STREXT_LEADING : timecode.h
  • TC2_STREXT_MARKS : timecode.h
  • TC2_STREXT_MASK : timecode.h
  • TC2_STREXT_MAX30 : timecode.h
  • TC2_STREXT_REVERSE : timecode.h
  • TC2_STREXT_SAVEBITS : timecode.h
  • TC2_STREXT_SHIFT7 : timecode.h
  • TC2_STREXT_TYPE : timecode.h
  • TC2_STRTYPE_ASCII : timecode.h
  • TC2_STRTYPE_BCD : timecode.h
  • TC2_STRTYPE_GOP : timecode.h
  • TC2_STRTYPE_HEX : timecode.h
  • TC2_STRTYPE_INVERT : timecode.h
  • TC2_STRTYPE_MASK : timecode.h
  • TC2_STRTYPE_OVER_24_HOUR : timecode.h
  • TC2_TCTYPE_100 : timecode.h
  • TC2_TCTYPE_2398 : timecode.h
  • TC2_TCTYPE_50 : timecode.h
  • TC2_TCTYPE_5994 : timecode.h
  • TC2_TCTYPE_60 : timecode.h
  • TC2_TCTYPE_DF : timecode.h
  • TC2_TCTYPE_FILM : timecode.h
  • TC2_TCTYPE_MASK : timecode.h
  • TC2_TCTYPE_NDF : timecode.h
  • TC2_TCTYPE_NTSCFILM : timecode.h
  • TC2_TCTYPE_PAL : timecode.h
  • TC_ILLEGAL : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • d
  • g
  • i
  • m
  • p
  • s
  • t
  • v

- v -

  • vidChanAll : mediacmd.h
  • VIDEOWRITETYPE_4224 : mediacmd.h
  • VIDEOWRITETYPE_AVI : mediacmd.h
  • VIDEOWRITETYPE_BMP : mediacmd.h
  • VIDEOWRITETYPE_CIN : mediacmd.h
  • VIDEOWRITETYPE_DPX : mediacmd.h
  • VIDEOWRITETYPE_DVS : mediacmd.h
  • VIDEOWRITETYPE_GEN : mediacmd.h
  • VIDEOWRITETYPE_HDR : mediacmd.h
  • VIDEOWRITETYPE_IHSS : mediacmd.h
  • VIDEOWRITETYPE_JS : mediacmd.h
  • VIDEOWRITETYPE_MOV : mediacmd.h
  • VIDEOWRITETYPE_MPG : mediacmd.h
  • VIDEOWRITETYPE_RAW : mediacmd.h
  • VIDEOWRITETYPE_TGA : mediacmd.h
  • VIDEOWRITETYPE_TIFF : mediacmd.h
  • VIDEOWRITETYPE_WMV : mediacmd.h
  • VIDEOWRITETYPE_YUV : mediacmd.h
  • VVW_ABS_MAX_FRAME : vvwtypes.h
  • VVW_INVALID_FRAME : vvwtypes.h
  • VVWAUD_RECALC : vvwtypes.h
  • VVWAUD_SET : vvwtypes.h
  • VVWAUD_SETCLR : vvwtypes.h
  • VVWHANDLE : vvw.h
  • VVWINFOTAG_dwAFrame : vvwtypes.h
  • VVWINFOTAG_dwAspectRatio : vvwtypes.h
  • VVWINFOTAG_dwBlackGain : vvwtypes.h
  • VVWINFOTAG_dwBlackPoint : vvwtypes.h
  • VVWINFOTAG_dwBreakPoint : vvwtypes.h
  • VVWINFOTAG_dwConversions : vvwtypes.h
  • VVWINFOTAG_dwFileDate : vvwtypes.h
  • VVWINFOTAG_dwFileSize : vvwtypes.h
  • VVWINFOTAG_dwFileTime : vvwtypes.h
  • VVWINFOTAG_dwFilmManufacturerCode : vvwtypes.h
  • VVWINFOTAG_dwFilmTypeCode : vvwtypes.h
  • VVWINFOTAG_dwFlags : vvwtypes.h
  • VVWINFOTAG_dwGamma1000 : vvwtypes.h
  • VVWINFOTAG_dwLTCTimeCodeType : vvwtypes.h
  • VVWINFOTAG_dwNU_31 : vvwtypes.h
  • VVWINFOTAG_dwNU_32 : vvwtypes.h
  • VVWINFOTAG_dwNU_33 : vvwtypes.h
  • VVWINFOTAG_dwNU_34 : vvwtypes.h
  • VVWINFOTAG_dwNU_35 : vvwtypes.h
  • VVWINFOTAG_dwNU_36 : vvwtypes.h
  • VVWINFOTAG_dwNU_37 : vvwtypes.h
  • VVWINFOTAG_dwNU_38 : vvwtypes.h
  • VVWINFOTAG_dwNU_39 : vvwtypes.h
  • VVWINFOTAG_dwNU_40 : vvwtypes.h
  • VVWINFOTAG_dwNU_41 : vvwtypes.h
  • VVWINFOTAG_dwNU_42 : vvwtypes.h
  • VVWINFOTAG_dwNU_43 : vvwtypes.h
  • VVWINFOTAG_dwNU_44 : vvwtypes.h
  • VVWINFOTAG_dwNU_45 : vvwtypes.h
  • VVWINFOTAG_dwNU_46 : vvwtypes.h
  • VVWINFOTAG_dwNU_47 : vvwtypes.h
  • VVWINFOTAG_dwNU_48 : vvwtypes.h
  • VVWINFOTAG_dwNU_49 : vvwtypes.h
  • VVWINFOTAG_dwOriginalRate : vvwtypes.h
  • VVWINFOTAG_dwOriginalScale : vvwtypes.h
  • VVWINFOTAG_dwPosterFrame : vvwtypes.h
  • VVWINFOTAG_dwSequenceNumber : vvwtypes.h
  • VVWINFOTAG_dwTagNumber : vvwtypes.h
  • VVWINFOTAG_dwTimeCode : vvwtypes.h
  • VVWINFOTAG_dwTimeCodeType : vvwtypes.h
  • VVWINFOTAG_dwTotalLength : vvwtypes.h
  • VVWINFOTAG_dwTotalStreams : vvwtypes.h
  • VVWINFOTAG_dwUserBits : vvwtypes.h
  • VVWINFOTAG_dwVersionNumber : vvwtypes.h
  • VVWINFOTAG_dwVITCLine3 : vvwtypes.h
  • VVWINFOTAG_dwVITCTimeCode : vvwtypes.h
  • VVWINFOTAG_dwVITCTimeCodeType : vvwtypes.h
  • VVWINFOTAG_dwVITCUserBits : vvwtypes.h
  • VVWINFOTAG_dwWhitePoint : vvwtypes.h
  • VVWINFOTAG_szAlbum : vvwtypes.h
  • VVWINFOTAG_szArtist : vvwtypes.h
  • VVWINFOTAG_szAuthor : vvwtypes.h
  • VVWINFOTAG_szCamRoll : vvwtypes.h
  • VVWINFOTAG_szCategory : vvwtypes.h
  • VVWINFOTAG_szChannel : vvwtypes.h
  • VVWINFOTAG_szChannelDescription : vvwtypes.h
  • VVWINFOTAG_szChannelName : vvwtypes.h
  • VVWINFOTAG_szComments : vvwtypes.h
  • VVWINFOTAG_szComposer : vvwtypes.h
  • VVWINFOTAG_szCopyright : vvwtypes.h
  • VVWINFOTAG_szCreationData : vvwtypes.h
  • VVWINFOTAG_szDailyRoll : vvwtypes.h
  • VVWINFOTAG_szDescription : vvwtypes.h
  • VVWINFOTAG_szDeviceModelNum : vvwtypes.h
  • VVWINFOTAG_szDeviceSerialNum : vvwtypes.h
  • VVWINFOTAG_szDirector : vvwtypes.h
  • VVWINFOTAG_szDisclaimer : vvwtypes.h
  • VVWINFOTAG_szDoNotUse : vvwtypes.h
  • VVWINFOTAG_szEditData1 : vvwtypes.h
  • VVWINFOTAG_szEditData2 : vvwtypes.h
  • VVWINFOTAG_szEditData3 : vvwtypes.h
  • VVWINFOTAG_szEditData4 : vvwtypes.h
  • VVWINFOTAG_szEditData5 : vvwtypes.h
  • VVWINFOTAG_szEditData6 : vvwtypes.h
  • VVWINFOTAG_szEditData7 : vvwtypes.h
  • VVWINFOTAG_szEditData8 : vvwtypes.h
  • VVWINFOTAG_szEditData9 : vvwtypes.h
  • VVWINFOTAG_szEditor : vvwtypes.h
  • VVWINFOTAG_szEncodedBy : vvwtypes.h
  • VVWINFOTAG_szEpisode : vvwtypes.h
  • VVWINFOTAG_szFileName : vvwtypes.h
  • VVWINFOTAG_szFormat : vvwtypes.h
  • VVWINFOTAG_szFrameAttribute : vvwtypes.h
  • VVWINFOTAG_szFullName : vvwtypes.h
  • VVWINFOTAG_szGenre : vvwtypes.h
  • VVWINFOTAG_szHostComputer : vvwtypes.h
  • VVWINFOTAG_szInformation : vvwtypes.h
  • VVWINFOTAG_szInkNumberPrefix : vvwtypes.h
  • VVWINFOTAG_szInputDevice : vvwtypes.h
  • VVWINFOTAG_szIP : vvwtypes.h
  • VVWINFOTAG_szKeyNumberPrefix : vvwtypes.h
  • VVWINFOTAG_szKeywords : vvwtypes.h
  • VVWINFOTAG_szLabRoll : vvwtypes.h
  • VVWINFOTAG_szLanguage : vvwtypes.h
  • VVWINFOTAG_szMake : vvwtypes.h
  • VVWINFOTAG_szManufacturer : vvwtypes.h
  • VVWINFOTAG_szModel : vvwtypes.h
  • VVWINFOTAG_szNativeLocator : vvwtypes.h
  • VVWINFOTAG_szNU_81 : vvwtypes.h
  • VVWINFOTAG_szNU_82 : vvwtypes.h
  • VVWINFOTAG_szNU_83 : vvwtypes.h
  • VVWINFOTAG_szNU_84 : vvwtypes.h
  • VVWINFOTAG_szNU_85 : vvwtypes.h
  • VVWINFOTAG_szNU_86 : vvwtypes.h
  • VVWINFOTAG_szNU_87 : vvwtypes.h
  • VVWINFOTAG_szNU_88 : vvwtypes.h
  • VVWINFOTAG_szNU_89 : vvwtypes.h
  • VVWINFOTAG_szNU_90 : vvwtypes.h
  • VVWINFOTAG_szNU_91 : vvwtypes.h
  • VVWINFOTAG_szNU_92 : vvwtypes.h
  • VVWINFOTAG_szNU_93 : vvwtypes.h
  • VVWINFOTAG_szNU_94 : vvwtypes.h
  • VVWINFOTAG_szNU_95 : vvwtypes.h
  • VVWINFOTAG_szNU_96 : vvwtypes.h
  • VVWINFOTAG_szNU_97 : vvwtypes.h
  • VVWINFOTAG_szNU_98 : vvwtypes.h
  • VVWINFOTAG_szNU_99 : vvwtypes.h
  • VVWINFOTAG_szOriginalArtist : vvwtypes.h
  • VVWINFOTAG_szOriginalFormat : vvwtypes.h
  • VVWINFOTAG_szOwner : vvwtypes.h
  • VVWINFOTAG_szPerformers : vvwtypes.h
  • VVWINFOTAG_szPictureIcon : vvwtypes.h
  • VVWINFOTAG_szProduced : vvwtypes.h
  • VVWINFOTAG_szProducer : vvwtypes.h
  • VVWINFOTAG_szProduct : vvwtypes.h
  • VVWINFOTAG_szProject : vvwtypes.h
  • VVWINFOTAG_szProxyFile : vvwtypes.h
  • VVWINFOTAG_szRatings : vvwtypes.h
  • VVWINFOTAG_szReel : vvwtypes.h
  • VVWINFOTAG_szRevisionNumber : vvwtypes.h
  • VVWINFOTAG_szScene : vvwtypes.h
  • VVWINFOTAG_szShot : vvwtypes.h
  • VVWINFOTAG_szSlateInfo : vvwtypes.h
  • VVWINFOTAG_szSoftware : vvwtypes.h
  • VVWINFOTAG_szSoundRoll : vvwtypes.h
  • VVWINFOTAG_szSource : vvwtypes.h
  • VVWINFOTAG_szSourceLocator : vvwtypes.h
  • VVWINFOTAG_szSpecialPlaybackRequirements : vvwtypes.h
  • VVWINFOTAG_szStatus : vvwtypes.h
  • VVWINFOTAG_szSubject : vvwtypes.h
  • VVWINFOTAG_szSupplier : vvwtypes.h
  • VVWINFOTAG_szTake : vvwtypes.h
  • VVWINFOTAG_szTitle : vvwtypes.h
  • VVWINFOTAG_szTrack : vvwtypes.h
  • VVWINFOTAG_szUniversalName : vvwtypes.h
  • VVWINFOTAG_szURLLink : vvwtypes.h
  • VVWINFOTAG_szVersionString : vvwtypes.h
  • VVWINFOTAG_szWarning : vvwtypes.h
  • VVWINFOTAG_woBitCount : vvwtypes.h
  • VVWINFOTAG_woCaps : vvwtypes.h
  • VVWINFOTAG_woClrImportant : vvwtypes.h
  • VVWINFOTAG_woClrUsed : vvwtypes.h
  • VVWINFOTAG_woCompression : vvwtypes.h
  • VVWINFOTAG_woDrFlags : vvwtypes.h
  • VVWINFOTAG_woEditCount : vvwtypes.h
  • VVWINFOTAG_woFccHandler : vvwtypes.h
  • VVWINFOTAG_woFccType : vvwtypes.h
  • VVWINFOTAG_woFileType : vvwtypes.h
  • VVWINFOTAG_woFlags : vvwtypes.h
  • VVWINFOTAG_woFormatChangeCount : vvwtypes.h
  • VVWINFOTAG_woHeight : vvwtypes.h
  • VVWINFOTAG_woInitialFrames : vvwtypes.h
  • VVWINFOTAG_woLanguage : vvwtypes.h
  • VVWINFOTAG_woLength : vvwtypes.h
  • VVWINFOTAG_woPitch : vvwtypes.h
  • VVWINFOTAG_woPlanes : vvwtypes.h
  • VVWINFOTAG_woPriority : vvwtypes.h
  • VVWINFOTAG_woQuality : vvwtypes.h
  • VVWINFOTAG_woRate : vvwtypes.h
  • VVWINFOTAG_woResDrastic : vvwtypes.h
  • VVWINFOTAG_woReserved : vvwtypes.h
  • VVWINFOTAG_woSampleSize : vvwtypes.h
  • VVWINFOTAG_woScale : vvwtypes.h
  • VVWINFOTAG_woSizeImage : vvwtypes.h
  • VVWINFOTAG_woStart : vvwtypes.h
  • VVWINFOTAG_woSuggestedBufferSize : vvwtypes.h
  • VVWINFOTAG_woVideoWidth : vvwtypes.h
  • VVWINFOTAG_woXPelsPerMeter : vvwtypes.h
  • VVWINFOTAG_woYPelsPerMeter : vvwtypes.h
  • VVWSYS_CLR : vvwtypes.h
  • VVWSYS_SET : vvwtypes.h
  • VVWSYS_SETAUDONLY : vvwtypes.h
  • VVWSYS_SETVIDONLY : vvwtypes.h
  • VVWVID_PITCHALIGN1 : vvwtypes.h
  • VVWVID_PITCHALIGN16 : vvwtypes.h
  • VVWVID_PITCHALIGN4 : vvwtypes.h
  • VVWVID_PITCHALIGN8 : vvwtypes.h
  • VVWVID_PITCHALIGNANY : vvwtypes.h
  • VVWVID_PITCHMODULO : vvwtypes.h
  • VVWVID_RATESCALE_FILM : vvwtypes.h
  • VVWVID_RATESCALE_NTSC : vvwtypes.h
  • VVWVID_RATESCALE_NTSC_AVI : vvwtypes.h
  • VVWVID_RATESCALE_PAL : vvwtypes.h
  • VVWVID_SET : vvwtypes.h
  • VVWVID_SETCLR : vvwtypes.h
  • VVWVID_SIZEIMAGE : vvwtypes.h
  • VVWVID_SUGGESTEDBUFFERSIZE : vvwtypes.h
  • VVWXXX_GETSAMPLEFROMLENGTH : vvwtypes.h
  • VVWXXX_SETSAMPLETOLENGTH : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • cmdAudChan : mediacmd.h
  • cmdFlags : mediacmd.h
  • cmdGetSetValue : mediacmd.h
  • cmdinf : mediacmd.h
  • cmdType : mediacmd.h
  • cmdVidChan : mediacmd.h
  • vvwInfoMetaTypes : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • g
  • i
  • v

- a -

  • audChan0 : mediacmd.h
  • audChan1 : mediacmd.h
  • audChan10 : mediacmd.h
  • audChan11 : mediacmd.h
  • audChan12 : mediacmd.h
  • audChan13 : mediacmd.h
  • audChan14 : mediacmd.h
  • audChan15 : mediacmd.h
  • audChan16 : mediacmd.h
  • audChan17 : mediacmd.h
  • audChan18 : mediacmd.h
  • audChan19 : mediacmd.h
  • audChan2 : mediacmd.h
  • audChan20 : mediacmd.h
  • audChan21 : mediacmd.h
  • audChan22 : mediacmd.h
  • audChan23 : mediacmd.h
  • audChan24 : mediacmd.h
  • audChan25 : mediacmd.h
  • audChan26 : mediacmd.h
  • audChan27 : mediacmd.h
  • audChan28 : mediacmd.h
  • audChan29 : mediacmd.h
  • audChan3 : mediacmd.h
  • audChan30 : mediacmd.h
  • audChan31 : mediacmd.h
  • audChan4 : mediacmd.h
  • audChan5 : mediacmd.h
  • audChan6 : mediacmd.h
  • audChan7 : mediacmd.h
  • audChan8 : mediacmd.h
  • audChan9 : mediacmd.h
  • audChanAll : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • g
  • i
  • v

- c -

  • cfConvert : mediacmd.h
  • cfCopy : mediacmd.h
  • cfDeferred : mediacmd.h
  • cfFields : mediacmd.h
  • cfInvert : mediacmd.h
  • cfIsShuttle : mediacmd.h
  • cfLoop : mediacmd.h
  • cfNoClipFiles : mediacmd.h
  • cfNoReturn : mediacmd.h
  • cfNoTCSpaces : mediacmd.h
  • cfOverideDeferred : mediacmd.h
  • cfPreview : mediacmd.h
  • cfRipple : mediacmd.h
  • cfTest : mediacmd.h
  • cfTimeHouseClock : mediacmd.h
  • cfTimeMs : mediacmd.h
  • cfTimeTarget : mediacmd.h
  • cfTrigger : mediacmd.h
  • cfUseAllIDs : mediacmd.h
  • cfUseClipID : mediacmd.h
  • cfUseCmdAlt : mediacmd.h
  • cfUseEnd : mediacmd.h
  • cfUseEndOffset : mediacmd.h
  • cfUseFrameCount : mediacmd.h
  • cfUsePosition : mediacmd.h
  • cfUsePositionOffset : mediacmd.h
  • cfUsePresets : mediacmd.h
  • cfUseSpeed : mediacmd.h
  • cfUseStart : mediacmd.h
  • cfUseStartOffset : mediacmd.h
  • cfUsingCurrent : mediacmd.h
  • cmdaltNearestKeyFrame : mediacmd.h
  • cmdaltNextKeyFrame : mediacmd.h
  • cmdaltPrevKeyFrame : mediacmd.h
  • cmdaltStartOfMessage : mediacmd.h
  • ctAbort : mediacmd.h
  • ctBlank : mediacmd.h
  • ctChanSelect : mediacmd.h
  • ctDelete : mediacmd.h
  • ctEject : mediacmd.h
  • ctError : mediacmd.h
  • ctGetState : mediacmd.h
  • ctGetValue : mediacmd.h
  • ctInsert : mediacmd.h
  • ctPause : mediacmd.h
  • ctPlay : mediacmd.h
  • ctRecord : mediacmd.h
  • ctRecStop : mediacmd.h
  • ctSetState : mediacmd.h
  • ctSetValue : mediacmd.h
  • ctStop : mediacmd.h
  • ctTerminate : mediacmd.h
  • ctTransfer : mediacmd.h
  • ctTrim : mediacmd.h
  • ctValueSupported : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • g
  • i
  • v

- g -

  • gsAddProxy : mediacmd.h
  • gsAlphaChromaSource : mediacmd.h
  • gsAudAdvanceLevel : mediacmd.h
  • gsAudChan : mediacmd.h
  • gsAudCrossFadeTime : mediacmd.h
  • gsAudDtmfEnable : mediacmd.h
  • gsAudEdit : mediacmd.h
  • gsAudInDtmfChannel : mediacmd.h
  • gsAudInLtcChannel : mediacmd.h
  • gsAudInputBass : mediacmd.h
  • gsAudInputBitRate : mediacmd.h
  • gsAudInputCopyright : mediacmd.h
  • gsAudInputErrorProtect : mediacmd.h
  • gsAudInputHeadRoom : mediacmd.h
  • gsAudInputLevel : mediacmd.h
  • gsAudInputMode : mediacmd.h
  • gsAudInputOriginal : mediacmd.h
  • gsAudInputSampleRate : mediacmd.h
  • gsAudInputSlave : mediacmd.h
  • gsAudInputTreble : mediacmd.h
  • gsAudInSelect : mediacmd.h
  • gsAudioEncodeFormat : mediacmd.h
  • gsAudLtcEnable : mediacmd.h
  • gsAudOutAdvancePhase : mediacmd.h
  • gsAudOutDtmfChannel : mediacmd.h
  • gsAudOutLtcChannel : mediacmd.h
  • gsAudOutPhase : mediacmd.h
  • gsAudOutputLevel : mediacmd.h
  • gsAudOutSelect : mediacmd.h
  • gsAudSelect : mediacmd.h
  • gsAudWavePeakRMS : mediacmd.h
  • gsAutoMode : mediacmd.h
  • gsChanCapabilities : mediacmd.h
  • gsChannelsExist : mediacmd.h
  • gsClipCopy : mediacmd.h
  • gsClipInfo : mediacmd.h
  • gsClipMode : mediacmd.h
  • gsColorFrame : mediacmd.h
  • gsCompBFactor : mediacmd.h
  • gsCompChAdjustGopTC : mediacmd.h
  • gsCompChAllowSettings : mediacmd.h
  • gsCompChAltCoEffTable : mediacmd.h
  • gsCompChannelChangeMs : mediacmd.h
  • gsCompChAspectRatio : mediacmd.h
  • gsCompChAudioStreamID : mediacmd.h
  • gsCompChAudioStreamPID : mediacmd.h
  • gsCompChAudPacketSize : mediacmd.h
  • gsCompChBitCount : mediacmd.h
  • gsCompChCCFormat : mediacmd.h
  • gsCompChChromaFormat : mediacmd.h
  • gsCompChClosedGop : mediacmd.h
  • gsCompChConcealmentVector : mediacmd.h
  • gsCompChDCPrecision : mediacmd.h
  • gsCompChFourCC : mediacmd.h
  • gsCompChHorizontalRes : mediacmd.h
  • gsCompChLanguageCode : mediacmd.h
  • gsCompChMuxRate : mediacmd.h
  • gsCompChNonLinearQuant : mediacmd.h
  • gsCompChPitch : mediacmd.h
  • gsCompChRate : mediacmd.h
  • gsCompChScale : mediacmd.h
  • gsCompChSizeImage : mediacmd.h
  • gsCompChStandard : mediacmd.h
  • gsCompChVerticalRes : mediacmd.h
  • gsCompChVideoStreamID : mediacmd.h
  • gsCompChVideoStreamPID : mediacmd.h
  • gsCompChVidPacketSize : mediacmd.h
  • gsCompGOPSize : mediacmd.h
  • gsCompIFactor : mediacmd.h
  • gsCompPFactor : mediacmd.h
  • gsCompRatePercent : mediacmd.h
  • gsCompRateRatio : mediacmd.h
  • gsCompRateSize : mediacmd.h
  • gsCompRefPeriod : mediacmd.h
  • gsCompressionType : mediacmd.h
  • gsCompType : mediacmd.h
  • gsConvertAudFileFormat : mediacmd.h
  • gsConvertFileFormat : mediacmd.h
  • gsCurrentMs : mediacmd.h
  • gsDefStillLen : mediacmd.h
  • gsDelInhibit : mediacmd.h
  • gsDirGetFileGrab : mediacmd.h
  • gsDirGetFileInfo : mediacmd.h
  • gsDirGetInfo : mediacmd.h
  • gsDirGetList : mediacmd.h
  • gsDSyncMs : mediacmd.h
  • gsEditMode : mediacmd.h
  • gsEditOff : mediacmd.h
  • gsEditOn : mediacmd.h
  • gsEmulateEditBumping : mediacmd.h
  • gsEnableHDSDFormat : mediacmd.h
  • gsEnd : mediacmd.h
  • gsErrorLog : mediacmd.h
  • gsErrorLogCurrentMs : mediacmd.h
  • gsErrorLogLastChange : mediacmd.h
  • gsErrorLogMessage : mediacmd.h
  • gsErrorLogName : mediacmd.h
  • gsErrorLogStartMs : mediacmd.h
  • gsFirstClip : mediacmd.h
  • gsFrameData : mediacmd.h
  • gsGetNextClip : mediacmd.h
  • gsGetNextProxy : mediacmd.h
  • gsGPIIn : mediacmd.h
  • gsGPIOut : mediacmd.h
  • gsHeadSelect : mediacmd.h
  • gsHwnds : mediacmd.h
  • gsHwPort : mediacmd.h
  • gsIgnoreFileTypes : mediacmd.h
  • gsImageDirectory : mediacmd.h
  • gsIn : mediacmd.h
  • gsInfChan : mediacmd.h
  • gsInfEdit : mediacmd.h
  • gsInfSelect : mediacmd.h
  • gsInsertQueue : mediacmd.h
  • gsInsInhibit : mediacmd.h
  • gsJpegFrame : mediacmd.h
  • gsLastChangeMs : mediacmd.h
  • gsLastIn : mediacmd.h
  • gsLastOut : mediacmd.h
  • gsLoadClipSpace : mediacmd.h
  • gsLoadFilmSpace : mediacmd.h
  • gsLoadTCSpace : mediacmd.h
  • gsLocal : mediacmd.h
  • gsLtcTc : mediacmd.h
  • gsLtcTcPreset : mediacmd.h
  • gsLtcUb : mediacmd.h
  • gsLtcUbPreset : mediacmd.h
  • gsLUTEnable : mediacmd.h
  • gsMetaData : mediacmd.h
  • gsMetaDataCurrentUser : mediacmd.h
  • gsMetaDataDirectory : mediacmd.h
  • gsMetaDataGlobal : mediacmd.h
  • gsMetaDataLocalMachine : mediacmd.h
  • gsMetaDataVolume : mediacmd.h
  • gsMEVersion : mediacmd.h
  • gsMonitor : mediacmd.h
  • gsMonitorDisplay : mediacmd.h
  • gsMonitorGrab : mediacmd.h
  • gsMonitorHwnds : mediacmd.h
  • gsMpegAdjustGopTC : mediacmd.h
  • gsMpegAllowSettings : mediacmd.h
  • gsMpegAltCoEffTable : mediacmd.h
  • gsMpegAspectRatio : mediacmd.h
  • gsMpegAudioStreamID : mediacmd.h
  • gsMpegAudioStreamPID : mediacmd.h
  • gsMpegAudPacketSize : mediacmd.h
  • gsMpegCCFormat : mediacmd.h
  • gsMpegChromaFormat : mediacmd.h
  • gsMpegClosedGop : mediacmd.h
  • gsMpegConcealmentVector : mediacmd.h
  • gsMpegDCPrecision : mediacmd.h
  • gsMpegHorizontalRes : mediacmd.h
  • gsMpegLanguageCode : mediacmd.h
  • gsMpegMuxRate : mediacmd.h
  • gsMpegNonLinearQuant : mediacmd.h
  • gsMpegStandard : mediacmd.h
  • gsMpegVerticalRes : mediacmd.h
  • gsMpegVideoStreamID : mediacmd.h
  • gsMpegVideoStreamPID : mediacmd.h
  • gsMpegVidPacketSize : mediacmd.h
  • gsNextClip : mediacmd.h
  • gsOut : mediacmd.h
  • gsPBEE : mediacmd.h
  • gsPiconFrame : mediacmd.h
  • gsPlayCountDelay : mediacmd.h
  • gsPlayDelay : mediacmd.h
  • gsPostroll : mediacmd.h
  • gsPreroll : mediacmd.h
  • gsPromoteProxy : mediacmd.h
  • gsProxyCPUUsage : mediacmd.h
  • gsProxyMode : mediacmd.h
  • gsProxyStatus : mediacmd.h
  • gsRecAudFileFormat : mediacmd.h
  • gsRecDrive : mediacmd.h
  • gsRecFileFormat : mediacmd.h
  • gsRecFileName : mediacmd.h
  • gsRecInhibit : mediacmd.h
  • gsRecOffset : mediacmd.h
  • gsRecRate : mediacmd.h
  • gsRemoveProxy : mediacmd.h
  • gsResetChannel : mediacmd.h
  • gsSaveCurrent : mediacmd.h
  • gsServoRefSelect : mediacmd.h
  • gsSignalFormat : mediacmd.h
  • gsStart : mediacmd.h
  • gsSupportedFileTypes : mediacmd.h
  • gsSysBufferLevel : mediacmd.h
  • gsSysCPUUsage : mediacmd.h
  • gsSysMemoryUsage : mediacmd.h
  • gsSysTime : mediacmd.h
  • gsTc : mediacmd.h
  • gsTCSGetTLClipInfo : mediacmd.h
  • gsTCSGetTLClipState : mediacmd.h
  • gsTcSource : mediacmd.h
  • gsTcType : mediacmd.h
  • gsTotalStorageAvail : mediacmd.h
  • gsTotalStorageFree : mediacmd.h
  • gsTotalTimeAvail : mediacmd.h
  • gsTotalTimeFree : mediacmd.h
  • gsUb : mediacmd.h
  • gsUserAdd : mediacmd.h
  • gsUserDel : mediacmd.h
  • gsUserLastChangeMs : mediacmd.h
  • gsUserList : mediacmd.h
  • gsUserLogIn : mediacmd.h
  • gsUserPasswd : mediacmd.h
  • gsUserRights : mediacmd.h
  • gsVBlankEnable : mediacmd.h
  • gsVidAnalogMonitorDownMode : mediacmd.h
  • gsVidAnalogMonitorHDType : mediacmd.h
  • gsVidAnalogMonitorMethod : mediacmd.h
  • gsVidAnalogMonitorSDType : mediacmd.h
  • gsVidAnalogMonitorUpMode : mediacmd.h
  • gsVidBandwidth : mediacmd.h
  • gsVidBlackSetup : mediacmd.h
  • gsVidChan : mediacmd.h
  • gsVidChroma : mediacmd.h
  • gsVidColor : mediacmd.h
  • gsVidEdit : mediacmd.h
  • gsVidEditField : mediacmd.h
  • gsVideoEncodeFormat : mediacmd.h
  • gsVideoStandard : mediacmd.h
  • gsVidFreeze : mediacmd.h
  • gsVidGenlockValid : mediacmd.h
  • gsVidHue : mediacmd.h
  • gsVidInAGC : mediacmd.h
  • gsVidInBandwidth : mediacmd.h
  • gsVidInBlack : mediacmd.h
  • gsVidInChroma : mediacmd.h
  • gsVidInColorKiller : mediacmd.h
  • gsVidInCoring : mediacmd.h
  • gsVidInGamma : mediacmd.h
  • gsVidInHue : mediacmd.h
  • gsVidInLockType : mediacmd.h
  • gsVidInPeaking : mediacmd.h
  • gsVidInputValid : mediacmd.h
  • gsVidInSelect : mediacmd.h
  • gsVidInSetup : mediacmd.h
  • gsVidInSharpness : mediacmd.h
  • gsVidInSignalFormat : mediacmd.h
  • gsVidInUChroma : mediacmd.h
  • gsVidInVChroma : mediacmd.h
  • gsVidInVideo : mediacmd.h
  • gsVidInWhite : mediacmd.h
  • gsVidNoEE : mediacmd.h
  • gsVidOutAdjust1 : mediacmd.h
  • gsVidOutAdjust2 : mediacmd.h
  • gsVidOutCoring : mediacmd.h
  • gsVidOutGenlock : mediacmd.h
  • gsVidOutGenlockDelay : mediacmd.h
  • gsVidOutGenlockSource : mediacmd.h
  • gsVidOutHPhase : mediacmd.h
  • gsVidOutLockSignalFormat : mediacmd.h
  • gsVidOutLockType : mediacmd.h
  • gsVidOutPeaking : mediacmd.h
  • gsVidOutSelect : mediacmd.h
  • gsVidOutSubCarrier : mediacmd.h
  • gsVidPlayFrame : mediacmd.h
  • gsVidPreReadMode : mediacmd.h
  • gsVidRecFrame : mediacmd.h
  • gsVidRefDisable : mediacmd.h
  • gsVidSelect : mediacmd.h
  • gsVidSetup : mediacmd.h
  • gsVidSuperimpose : mediacmd.h
  • gsVidUChroma : mediacmd.h
  • gsVidVChroma : mediacmd.h
  • gsVidVideo : mediacmd.h
  • gsVitcTc : mediacmd.h
  • gsVitcTcPreset : mediacmd.h
  • gsVitcUb : mediacmd.h
  • gsVitcUbPreset : mediacmd.h
  • gsVtrType : mediacmd.h
  • gsVVWChannelName : mediacmd.h
  • gsVVWChannelType : mediacmd.h
  • gsVVWService : mediacmd.h
  • gsVVWType : mediacmd.h
  • gsVVWVersion : mediacmd.h
  • gsXlatQueue : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • g
  • i
  • v

- i -

  • inf13 : mediacmd.h
  • inf14 : mediacmd.h
  • inf15 : mediacmd.h
  • inf16 : mediacmd.h
  • inf17 : mediacmd.h
  • inf18 : mediacmd.h
  • inf19 : mediacmd.h
  • inf20 : mediacmd.h
  • inf21 : mediacmd.h
  • infAuth : mediacmd.h
  • infCC : mediacmd.h
  • infChanAll : mediacmd.h
  • infCopyright : mediacmd.h
  • infLtc : mediacmd.h
  • infOwner : mediacmd.h
  • infProxyName : mediacmd.h
  • infRecDate : mediacmd.h
  • infRecTime : mediacmd.h
  • infSourceName : mediacmd.h
  • infSrcCtl : mediacmd.h
  • infSrcLtc : mediacmd.h
  • infSrcVitc : mediacmd.h
  • infVB0 : mediacmd.h
  • infVB1 : mediacmd.h
  • infVB2 : mediacmd.h
  • infVB3 : mediacmd.h
  • infVB4 : mediacmd.h
  • infVB5 : mediacmd.h
  • infVB6 : mediacmd.h
  • infVB7 : mediacmd.h
  • infVB8 : mediacmd.h
  • infVB9 : mediacmd.h
  • infVitc : mediacmd.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • g
  • i
  • v

- v -

  • vidChan0 : mediacmd.h
  • vidChan1 : mediacmd.h
  • vidChan10 : mediacmd.h
  • vidChan11 : mediacmd.h
  • vidChan12 : mediacmd.h
  • vidChan13 : mediacmd.h
  • vidChan14 : mediacmd.h
  • vidChan15 : mediacmd.h
  • vidChan16 : mediacmd.h
  • vidChan17 : mediacmd.h
  • vidChan18 : mediacmd.h
  • vidChan19 : mediacmd.h
  • vidChan2 : mediacmd.h
  • vidChan20 : mediacmd.h
  • vidChan21 : mediacmd.h
  • vidChan22 : mediacmd.h
  • vidChan23 : mediacmd.h
  • vidChan24 : mediacmd.h
  • vidChan25 : mediacmd.h
  • vidChan26 : mediacmd.h
  • vidChan27 : mediacmd.h
  • vidChan28 : mediacmd.h
  • vidChan29 : mediacmd.h
  • vidChan3 : mediacmd.h
  • vidChan30 : mediacmd.h
  • vidChan31 : mediacmd.h
  • vidChan4 : mediacmd.h
  • vidChan5 : mediacmd.h
  • vidChan6 : mediacmd.h
  • vidChan7 : mediacmd.h
  • vidChan8 : mediacmd.h
  • vidChan9 : mediacmd.h
  • vidChanAll : mediacmd.h
  • vvwiAFrame : vvwtypes.h
  • vvwiAlbum : vvwtypes.h
  • vvwiArtist : vvwtypes.h
  • vvwiAspectRatio : vvwtypes.h
  • vvwiAuthor : vvwtypes.h
  • vvwiBlackGain : vvwtypes.h
  • vvwiBlackPoint : vvwtypes.h
  • vvwiBreakPoint : vvwtypes.h
  • vvwiCamRoll : vvwtypes.h
  • vvwiCategory : vvwtypes.h
  • vvwiChannel : vvwtypes.h
  • vvwiChannelDescription : vvwtypes.h
  • vvwiChannelName : vvwtypes.h
  • vvwiComments : vvwtypes.h
  • vvwiComposer : vvwtypes.h
  • vvwiConversions : vvwtypes.h
  • vvwiCopyright : vvwtypes.h
  • vvwiCreationData : vvwtypes.h
  • vvwiDailyRoll : vvwtypes.h
  • vvwiDescription : vvwtypes.h
  • vvwiDeviceModelNum : vvwtypes.h
  • vvwiDeviceSerialNum : vvwtypes.h
  • vvwiDirector : vvwtypes.h
  • vvwiDisclaimer : vvwtypes.h
  • vvwiEditData1 : vvwtypes.h
  • vvwiEditData2 : vvwtypes.h
  • vvwiEditData3 : vvwtypes.h
  • vvwiEditData4 : vvwtypes.h
  • vvwiEditData5 : vvwtypes.h
  • vvwiEditData6 : vvwtypes.h
  • vvwiEditData7 : vvwtypes.h
  • vvwiEditData8 : vvwtypes.h
  • vvwiEditData9 : vvwtypes.h
  • vvwiEditor : vvwtypes.h
  • vvwiEncodedBy : vvwtypes.h
  • vvwiEND_OF_DWORD_V2 : vvwtypes.h
  • vvwiEND_OF_STRINGS : vvwtypes.h
  • vvwiEpisode : vvwtypes.h
  • vvwiFileDate : vvwtypes.h
  • vvwiFileName : vvwtypes.h
  • vvwiFileSize : vvwtypes.h
  • vvwiFileTime : vvwtypes.h
  • vvwiFilmManufacturerCode : vvwtypes.h
  • vvwiFilmTypeCode : vvwtypes.h
  • vvwiFlags : vvwtypes.h
  • vvwiFormat : vvwtypes.h
  • vvwiFrameAttribute : vvwtypes.h
  • vvwiFullName : vvwtypes.h
  • vvwiGamma1000 : vvwtypes.h
  • vvwiGenre : vvwtypes.h
  • vvwiHostComputer : vvwtypes.h
  • vvwiInformation : vvwtypes.h
  • vvwiInkNumberPrefix : vvwtypes.h
  • vvwiInputDevice : vvwtypes.h
  • vvwiIP : vvwtypes.h
  • vvwiKeyNumberPrefix : vvwtypes.h
  • vvwiKeywords : vvwtypes.h
  • vvwiLabRoll : vvwtypes.h
  • vvwiLanguage : vvwtypes.h
  • vvwiLastElementPlus1 : vvwtypes.h
  • vvwiLTCTimeCodeType : vvwtypes.h
  • vvwiMake : vvwtypes.h
  • vvwiManufacturer : vvwtypes.h
  • vvwiModel : vvwtypes.h
  • vvwiNativeLocator : vvwtypes.h
  • vvwiNumericStart : vvwtypes.h
  • vvwiOriginalArtist : vvwtypes.h
  • vvwiOriginalFormat : vvwtypes.h
  • vvwiOriginalRate : vvwtypes.h
  • vvwiOriginalScale : vvwtypes.h
  • vvwiOwner : vvwtypes.h
  • vvwiPerformers : vvwtypes.h
  • vvwiPictureIcon : vvwtypes.h
  • vvwiPosterFrame : vvwtypes.h
  • vvwiProduced : vvwtypes.h
  • vvwiProducer : vvwtypes.h
  • vvwiProduct : vvwtypes.h
  • vvwiProject : vvwtypes.h
  • vvwiProxyFile : vvwtypes.h
  • vvwiRatings : vvwtypes.h
  • vvwiReel : vvwtypes.h
  • vvwiRevisionNumber : vvwtypes.h
  • vvwiScene : vvwtypes.h
  • vvwiSequenceNumber : vvwtypes.h
  • vvwiShot : vvwtypes.h
  • vvwiSlateInfo : vvwtypes.h
  • vvwiSoftware : vvwtypes.h
  • vvwiSoundRoll : vvwtypes.h
  • vvwiSource : vvwtypes.h
  • vvwiSourceLocator : vvwtypes.h
  • vvwiSpecialPlaybackRequirements : vvwtypes.h
  • vvwiStatus : vvwtypes.h
  • vvwiSubject : vvwtypes.h
  • vvwiSupplier : vvwtypes.h
  • vvwiTagNumber : vvwtypes.h
  • vvwiTake : vvwtypes.h
  • vvwiTimeCode : vvwtypes.h
  • vvwiTimeCodeType : vvwtypes.h
  • vvwiTitle : vvwtypes.h
  • vvwiTotalLength : vvwtypes.h
  • vvwiTotalStreams : vvwtypes.h
  • vvwiTrack : vvwtypes.h
  • vvwiUniversalName : vvwtypes.h
  • vvwiURLLink : vvwtypes.h
  • vvwiUserBits : vvwtypes.h
  • vvwiVersionNumber : vvwtypes.h
  • vvwiVersionString : vvwtypes.h
  • vvwiVideoBitCount : vvwtypes.h
  • vvwiVideoCaps : vvwtypes.h
  • vvwiVideoClrImportant : vvwtypes.h
  • vvwiVideoClrUsed : vvwtypes.h
  • vvwiVideoCompression : vvwtypes.h
  • vvwiVideoDrFlags : vvwtypes.h
  • vvwiVideoEditCount : vvwtypes.h
  • vvwiVideoFccHandler : vvwtypes.h
  • vvwiVideoFccType : vvwtypes.h
  • vvwiVideoFileType : vvwtypes.h
  • vvwiVideoFlags : vvwtypes.h
  • vvwiVideoFormatChangeCount : vvwtypes.h
  • vvwiVideoHeight : vvwtypes.h
  • vvwiVideoInitialFrames : vvwtypes.h
  • vvwiVideoLanguage : vvwtypes.h
  • vvwiVideoLength : vvwtypes.h
  • vvwiVideoPitch : vvwtypes.h
  • vvwiVideoPlanes : vvwtypes.h
  • vvwiVideoPriority : vvwtypes.h
  • vvwiVideoQuality : vvwtypes.h
  • vvwiVideoRate : vvwtypes.h
  • vvwiVideoResDrastic : vvwtypes.h
  • vvwiVideoReserved : vvwtypes.h
  • vvwiVideoSampleSize : vvwtypes.h
  • vvwiVideoScale : vvwtypes.h
  • vvwiVideoSizeImage : vvwtypes.h
  • vvwiVideoStart : vvwtypes.h
  • vvwiVideoSuggestedBufferSize : vvwtypes.h
  • vvwiVideoWidth : vvwtypes.h
  • vvwiVideoXPelsPerMeter : vvwtypes.h
  • vvwiVideoYPelsPeMeter : vvwtypes.h
  • vvwiVITCLine3 : vvwtypes.h
  • vvwiVITCTimeCode : vvwtypes.h
  • vvwiVITCTimeCodeType : vvwtypes.h
  • vvwiVITCUserBits : vvwtypes.h
  • vvwiWarning : vvwtypes.h
  • vvwiWhitePoint : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • t
  • u
  • v

- _ -

  • __vvwInitService() : vvw.h
  • __vvwQuitService() : vvw.h

- t -

  • tc2Frame() : timecode.h
  • tc2Maximum() : timecode.h
  • tc2String() : timecode.h

- u -

  • ub2String() : timecode.h
  • ub2Value() : timecode.h

- v -

  • vvvwLoadDefaultRegistry() : vvw.h
  • vvwBlank() : vvw.h
  • vvwChannelToHandle() : vvw.h
  • vvwClose() : vvw.h
  • vvwCmd() : vvw.h
  • vvwConfigure() : vvw.h
  • vvwCopyClip() : vvw.h
  • vvwDelete() : vvw.h
  • vvwEDLGetEdit() : vvw.h
  • vvwEDLResetToStart() : vvw.h
  • vvwEject() : vvw.h
  • vvwEnableChannels() : vvw.h
  • vvwFastForward() : vvw.h
  • vvwFastRewind() : vvw.h
  • vvwFreeString() : vvw.h
  • vvwGetAudioInput() : vvw.h
  • vvwGetAudioInputLevel() : vvw.h
  • vvwGetAudioOutput() : vvw.h
  • vvwGetAudioOutputLevel() : vvw.h
  • vvwGetAudioPeakRMS() : vvw.h
  • vvwGetAutoMode() : vvw.h
  • vvwGetAvailablePresets() : vvw.h
  • vvwGetChannelCapabilities() : vvw.h
  • vvwGetChannelName() : vvw.h
  • vvwGetChannelType() : vvw.h
  • vvwGetClipInfo() : vvw.h
  • vvwGetClipMode() : vvw.h
  • vvwGetClipName() : vvw.h
  • vvwGetCompressionRate() : vvw.h
  • vvwGetCurMs() : vvw.h
  • vvwGetCurState() : vvw.h
  • vvwGetCurTC() : vvw.h
  • vvwGetEnd() : vvw.h
  • vvwGetError() : vvw.h
  • vvwGetErrorLength() : vvw.h
  • vvwGetErrorLogMs() : vvw.h
  • vvwGetFileName() : vvw.h
  • vvwGetFlags() : vvw.h
  • vvwGetFreeStorage() : vvw.h
  • vvwGetFreeTime() : vvw.h
  • vvwGetLastChangeMs() : vvw.h
  • vvwGetLastChangeXferMs() : vvw.h
  • vvwGetLastMs() : vvw.h
  • vvwGetMaxChannels() : vvw.h
  • vvwGetMRVersion() : vvw.h
  • vvwGetNextClip() : vvw.h
  • vvwGetNextClipEx() : vvw.h
  • vvwGetPiconName() : vvw.h
  • vvwGetPosition() : vvw.h
  • vvwGetSpeed() : vvw.h
  • vvwGetStart() : vvw.h
  • vvwGetState() : vvw.h
  • vvwGetSuperImpose() : vvw.h
  • vvwGetTCSource() : vvw.h
  • vvwGetTCType() : vvw.h
  • vvwGetTotalStorage() : vvw.h
  • vvwGetTotalTime() : vvw.h
  • vvwGetVideoGenlock() : vvw.h
  • vvwGetVideoGenlockSource() : vvw.h
  • vvwGetVideoInput() : vvw.h
  • vvwGetVideoInputChroma() : vvw.h
  • vvwGetVideoInputHue() : vvw.h
  • vvwGetVideoInputSetup() : vvw.h
  • vvwGetVideoInputVideo() : vvw.h
  • vvwGetVideoOutput() : vvw.h
  • vvwGetVideoTBCChroma() : vvw.h
  • vvwGetVideoTBCHue() : vvw.h
  • vvwGetVideoTBCSetup() : vvw.h
  • vvwGetVideoTBCVideo() : vvw.h
  • vvwGetVVWType() : vvw.h
  • vvwGetVVWVersion() : vvw.h
  • vvwHandleToChannel() : vvw.h
  • vvwInit() : vvw.h
  • vvwInitInt() : vvw.h
  • vvwInsert() : vvw.h
  • vvwLoadClip() : vvw.h
  • vvwLoadRegistry() : vvw.h
  • vvwMediaCmd() : vvw.h
  • vvwOpen() : vvw.h
  • vvwPause() : vvw.h
  • vvwPlay() : vvw.h
  • vvwPlayAtSpeed() : vvw.h
  • vvwPlayClip() : vvw.h
  • vvwPlayClipFromTo() : vvw.h
  • vvwPlayFromTo() : vvw.h
  • vvwQuit() : vvw.h
  • vvwRecord() : vvw.h
  • vvwRecordFromTo() : vvw.h
  • vvwRecordStop() : vvw.h
  • vvwReleaseChannels() : vvw.h
  • vvwSaveRegistry() : vvw.h
  • vvwSaveVVWRegistry() : vvw.h
  • vvwSaveWindowsRegistry() : vvw.h
  • vvwSeek() : vvw.h
  • vvwSeekRelative() : vvw.h
  • vvwSetAudioInput() : vvw.h
  • vvwSetAudioInputLevel() : vvw.h
  • vvwSetAudioOutput() : vvw.h
  • vvwSetAudioOutputLevel() : vvw.h
  • vvwSetAutoMode() : vvw.h
  • vvwSetClipMode() : vvw.h
  • vvwSetCompressionRate() : vvw.h
  • vvwSetErrorLog() : vvw.h
  • vvwSetRecordPresets() : vvw.h
  • vvwSetSuperImpose() : vvw.h
  • vvwSetTCSource() : vvw.h
  • vvwSetTCType() : vvw.h
  • vvwSetVideoGenlock() : vvw.h
  • vvwSetVideoGenlockSource() : vvw.h
  • vvwSetVideoInput() : vvw.h
  • vvwSetVideoInputChroma() : vvw.h
  • vvwSetVideoInputHue() : vvw.h
  • vvwSetVideoInputSetup() : vvw.h
  • vvwSetVideoInputVideo() : vvw.h
  • vvwSetVideoOutput() : vvw.h
  • vvwSetVideoTBCChroma() : vvw.h
  • vvwSetVideoTBCHue() : vvw.h
  • vvwSetVideoTBCSetup() : vvw.h
  • vvwSetVideoTBCVideo() : vvw.h
  • vvwShowConfigDialog() : vvw.h
  • vvwStart() : vvw.h
  • vvwStartService() : vvw.h
  • vvwStop() : vvw.h
  • vvwStopService() : vvw.h
  • vvwTransfer() : vvw.h
  • vvwTrim() : vvw.h
  • vvwUpdateStatus() : vvw.h
  • vvwValueGet() : vvw.h
  • vvwValueSet() : vvw.h
  • vvwValueSet2() : vvw.h
  • vvwValueSupported() : vvw.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • FCN_VVW_CLOSE : vvw.h
  • FCN_VVW_CMD : vvw.h
  • FCN_VVW_CONFIGURE : vvw.h
  • FCN_VVW_INIT : vvw.h
  • FCN_VVW_INIT_INT : vvw.h
  • FCN_VVW_OPEN : vvw.h
  • FCN_VVW_QUIT : vvw.h
  • FCN_VVW_SETMEDIACMD : vvw.h
  • FCN_VVW_START : vvw.h
  • PDCLIP : vvwtypes.h
  • PDFRAME : vvwtypes.h
  • pDRASTIC_CHANNEL : vvwtypes.h
  • pFRAME_INFO : vvwtypes.h
  • PMEDIACMD : mediacmd.h
  • pVVWAUDIO : vvwtypes.h
  • pVVWINFO : vvwtypes.h
  • pVVWSYSTEM : vvwtypes.h
  • pVVWVIDEO : vvwtypes.h
Generated on Wed May 17 15:52:36 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: mediacmd.h Source File

  • File List
  • Globals

mediacmd.h

Go to the documentation of this file.
00001 /*******************************************************************
00002  * $Header: /Ass/inc/MediaCmd.h 92    5/25/01 10:13p Administrator $
00003  *
00004  * $Workfile: MediaCmd.h $
00005  * $Author: Administrator $
00006  * $Revision: 92 $
00007  * $Archive: /Ass/inc/MediaCmd.h $
00008  *
00009  * Copyright (C) 1998 Drastic Technologies Ltd. All Rights Reserved.
00010  * 12 Drummond St. Unit 3, Toronto, ON, M8V 1Y8 (416) 255 5636
00011  * engineering@drastictech.com      http://www.drastictech.com
00012  *
00013  ******************************************************************/
00014
00015 //
00016 // Common header describing the command interface between
00017 // media control modules.
00018 //
00019
00020 #ifndef _MEDIACMD_INCLUDED_H
00021 #define _MEDIACMD_INCLUDED_H
00022
00023 // Windows x64
00024 #pragma warning(disable: 4996)  // deprecated security functions
00025
00026 //#include <dlist.h>    // No longer used
00027 //#ifdef _lint  // Test ONLY
00028 //#include <windows.h>
00029 //#endif
00030
00031 // This allows a quick check for the head of the command
00033 #define MEDIACMD_VERSION_MAJOR  0x0101UL
00034
00035 #define MEDIACMD_VERSION_MINOR  0x0003UL
00036
00037 #define MEDIACMD_VERSION_MASK   0xFFFFUL
00038
00039 #define MEDIACMD_CHECK_VER              0xFA250000UL
00040
00041 #define MEDIACMD_CHECK_MASK             0xFFFF0000UL
00042
00043 #define MEDIACMD_CURRENT                (MEDIACMD_VERSION_MAJOR | MEDIACMD_VERSION_MINOR | MEDIACMD_CHECK_VER)
00044
00045 // Various speed limits and definitions
00047 #define SPD_FWD_PLAY                    65520L
00048
00049 #define SPD_PAUSE                               0L
00050
00051 #define SPD_REV_PLAY                    (-SPD_FWD_PLAY)
00052
00053 #define SPD_FWD_MAX                             5896800
00054
00055 #define SPD_REV_MAX                             (-SPD_FWD_MAX)
00056
00057 #define SPD_FAST_BUMP                   114660L //1.75 times play speed
00058
00059 #define SPD_SLOW_BUMP                   32760l  //.5 times play speed
00060
00061 #define SPD_ILLEGAL                             2147483647L
00062
00063 #define TC_ILLEGAL                              0xFFFFFFFFUL
00064
00065 #define CHAN_ILLEGAL                    0xFFFFFFFFUL
00066
00078 #define CMD_MAX_CLIP_ID_LEN             (260+8)
00079
00080 // The possible commands and states of media
00085 enum cmdType {
00090         ctStop,                         // Stop all action
00096         ctPause,                        // Pause, Seek
00106         ctPlay,                         // Play at specified speed (includes pause)
00119         ctRecord,                       // Record at specified speed
00129         ctRecStop,                      // Stop ready for recording
00134         ctEject,                        // Eject the current media
00140         ctTransfer,                     // Transfer source from one channel to another
00156         ctInsert,                       // Insert a new time code area
00168         ctBlank,                        // Erase the specified TC area
00184         ctDelete,                       // Slide segment within the specified TC area
00191         ctTrim,                         // Trim the segment within the specified TC area
00199         ctChanSelect,           // Pass though requested channels
00200
00220         ctGetState,                     // Returns TC and transport state information
00229         ctSetState,                     // Sends a new state per GetState
00237         ctGetValue,                     // Get value of video, audio of internal variable
00245         ctSetValue,                     // Set value of video, audio of internal variable
00253         ctValueSupported,       // Returns true is the specified Get/Set value is supported
00260         ctError,                        // An error has occurred
00267         ctTerminate,            // Terminate the current command and move to the next in the queue, if any
00274         ctAbort                         // Abort any queued commands
00275 };
00276
00281 enum cmdFlags {
00282                 // Normally, commands occur when the delay time is reached
00292         cfDeferred = 1,                         // 0x00000001 This is a delayed command (either at end of prev cmd, or absolute time)
00298         cfOverideDeferred = 1 << 30,// 0x40000000 Overide all previous deferred commands
00306         cfTimeMs = 1 << 1,                      // 0x00000002 Use Millisecond time for delayed time, not fields
00314         cfTimeTarget = 1 << 2,          // 0x00000004 Delayed time is offset from current time code
00325         cfTimeHouseClock = 1 << 3,      // 0x00000008 Delayed time is based on absolute (real) time
00330         cfUseSpeed = 1 << 4,            // 0x00000010 Set the new speed
00335         cfUsePresets = 1 << 5,          // 0x00000020 Use video and audio edit presets
00340         cfUsePosition = 1 << 6,         // 0x00000040 Use the position setting
00346         cfUsePositionOffset = 1 << 7,//0x00000080 Position is an offset
00351         cfUseStart = 1 << 8,            // 0x00000100 Start a new timecode
00357         cfUseStartOffset = 1 << 9,      // 0x00000200 Start is an offset from current tc
00362         cfUseEnd = 1 << 10,                     // 0x00000400 End command as specified
00368         cfUseEndOffset =  1 << 11,      // 0x00000800 End is and offset from current tc
00369
00375         cfUseAllIDs = 1 << 12,          // 0x00001000 Use all clip IDs (usually erase'em)
00380         cfUseClipID = 1 << 13,          // 0x00002000 Use new clip ID, otherwise use last or none
00385         cfCopy = 1 << 14,       // 0x00004000
00390         cfNoClipFiles = cfCopy, // Deprecated
00395         cfConvert = 1 << 15,    // 0x00008000
00400         cfNoTCSpaces = cfConvert,               // Deprecated
00405         cfUseCmdAlt = 1 << 16,          // 0x00010000 Use the dwCmdAlt
00413         cfIsShuttle = 1 << 17,          // 0x00020000 Use speed in play for shuttle
00431         cfUsingCurrent = 1 << 18,       // 0x000400000 any elem not flag'ed is current
00438         cfUseFrameCount = 1 << 19,      // 0x000800000 Position, start and end are fields, not frames
00444         cfFields = 1 << 20,                     // 0x00100000 Position, start and end are fields, not frames
00450         cfRipple = 1 << 21,                     // 0x00200000 Ripple for insert or delete
00457         cfLoop = 1 << 22,                       // 0x00400000 Loop the clip or in out
00463         cfTrigger = 1 << 23,            // 0x00800000 Trigger using dsync class
00471         cfPreview = 1 << 24,            // 0x01000000 Preview set (EE, non rt play)
00479         cfInvert = 1 << 28,                     // 0x10000000 Invert a transfer
00489         cfTest = 1 << 29,                       // 0x20000000 See if the command exists
00490         // NOTE:  1 << 30 in use by cfOverideDeferred
00500         cfNoReturn = 1UL << 31UL                // 0x80000000 No return mediacmd is required
00501 };
00502
00503 // Video channels
00506 enum cmdVidChan {
00507         vidChan0 = 1, vidChan1 = 1 << 1, vidChan2 = 1 << 2, vidChan3 = 1 << 3,
00508         vidChan4 = 1 << 4, vidChan5 = 1 << 5, vidChan6 = 1 << 6, vidChan7 = 1 << 7,
00509         vidChan8 = 1 << 8, vidChan9 = 1 << 9, vidChan10 = 1 << 10, vidChan11 = 1 << 11,
00510         vidChan12 = 1 << 12, vidChan13 = 1 << 13, vidChan14 = 1 << 14, vidChan15 = 1 << 15,
00511         vidChan16 = 1 << 16, vidChan17 = 1 << 17, vidChan18 = 1 << 18, vidChan19 = 1 << 19,
00512         vidChan20 = 1 << 20, vidChan21 = 1 << 21, vidChan22 = 1 << 22, vidChan23 = 1 << 23,
00513         vidChan24 = 1 << 24, vidChan25 = 1 << 25, vidChan26 = 1 << 26, vidChan27 = 1 << 27,
00514         vidChan28 = 1 << 28, vidChan29 = 1 << 29, vidChan30 = 1 << 30, vidChan31 = 1UL << 31UL,
00515 #define vidChanAll 0xFFFFFFFF
00516 };
00518
00521 enum cmdAudChan {
00522         audChan0 = 1, audChan1 = 1 << 1, audChan2 = 1 << 2, audChan3 = 1 << 3,
00523         audChan4 = 1 << 4, audChan5 = 1 << 5, audChan6 = 1 << 6, audChan7 = 1 << 7,
00524         audChan8 = 1 << 8, audChan9 = 1 << 9, audChan10 = 1 << 10, audChan11 = 1 << 11,
00525         audChan12 = 1 << 12, audChan13 = 1 << 13, audChan14 = 1 << 14, audChan15 = 1 << 15,
00526         audChan16 = 1 << 16, audChan17 = 1 << 17, audChan18 = 1 << 18, audChan19 = 1 << 19,
00527         audChan20 = 1 << 20, audChan21 = 1 << 21, audChan22 = 1 << 22, audChan23 = 1 << 23,
00528         audChan24 = 1 << 24, audChan25 = 1 << 25, audChan26 = 1 << 26, audChan27 = 1 << 27,
00529         audChan28 = 1 << 28, audChan29 = 1 << 29, audChan30 = 1 << 30, audChan31 = 1UL << 31UL,
00530 #define audChanAll 0xFFFFFFFF
00531 };
00533
00536 enum cmdinf {
00538         infLtc = 1,
00540         infVitc = 1 << 1,
00542         infSrcCtl = 1 << 2,
00544         infSrcLtc = 1 << 3,
00546         infSrcVitc = 1 << 4,
00548         infRecTime = 1 << 5,
00550         infRecDate = 1 << 6,
00552         infCC = 1 << 7,
00554         infAuth = 1 << 8,
00556         infCopyright = 1 << 9,
00558         infOwner = 1 << 10,
00560         infSourceName = 1 << 11,
00562         infProxyName = 1 << 12,
00564         inf13 = 1 << 13, inf14 = 1 << 14, inf15 = 1 << 15,
00565         inf16 = 1 << 16, inf17 = 1 << 17, inf18 = 1 << 18, inf19 = 1 << 19,
00566         inf20 = 1 << 20, inf21 = 1 << 21, infVB0 = 1 << 22, infVB1 = 1 << 23,
00567         infVB2 = 1 << 24, infVB3 = 1 << 25, infVB4 = 1 << 26, infVB5 = 1 << 27,
00568         infVB6 = 1 << 28, infVB7 = 1 << 29, infVB8 = 1 << 30, infVB9 = 1UL << 31UL,
00569 #define infChanAll 0xFFFFFFFF
00570 };
00571
00573
00597 enum cmdGetSetValue {
00607         gsTc = 1,                               // Current internal TC (dwPosition)
00617         gsUb,                                   // Current user bits (dwPosition)
00628         gsLtcTc,                                // Current LTC TC (dwPosition)
00638         gsLtcUb,                                // Current LTC user bits (dwPosition)
00648         gsVitcTc,                               // Current VITC TC (dwPosition)
00658         gsVitcUb,                               // Current VITC user bits (dwPosition)
00669         gsTcSource,                             // Default Source (dwPosition, supported dwStart)
00680         gsTcType,                               // DF, NDF, PAL or FILM (dwPosition,supported dwStart)
00691         gsStart,                                // Lowest possible TC (current = dwPosition, min = dwStart)
00702         gsEnd,                                  // Highest possible TC (current = dwPosition, max = dwStart)
00712         gsIn,                                   // Current in point (dwPosition)
00722         gsLastIn,                               // Last in point (dwPosition)
00732         gsOut,                                  // Current out point (dwPosition)
00742         gsLastOut,                              // Last out point (dwPosition)
00752         gsEditOn,                               // Time to start an edit
00763         gsEditOff,                              // Time to end an edit
00773         gsPreroll,                              // Edit pre roll time
00783         gsPostroll,                             // Edit post roll time
00784
00796         gsAutoMode,                             // Setup for NL Playback
00806         gsPlayDelay,                    // Time from pause to play
00818         gsLtcTcPreset,
00830         gsLtcUbPreset,
00842         gsVitcTcPreset,
00854         gsVitcUbPreset,
00866         gsFrameData,
00882         gsGetNextClip = 90,             // Get clip name and info (was first/next - send NULL arbID for first)
00892         gsFirstClip,                    // First clip name (arbID - name, dwStart, dwEnd if avail)
00902         gsNextClip,                             // Next clip name, (arbID - name, dwStart, dwEnd if avail)
00921         gsTCSGetTLClipState,
00959         gsTCSGetTLClipInfo,
00976         gsClipInfo,                             // Same as above for named clip or current (arbID - name, dwStart, dwEnd if avail)
00993         gsClipCopy,                             // Copy current clip to specified name
00994
00995
01005         gsAudChan = 100,                // Available audio channels (dwPosition)
01015         gsVidChan,                              // Available video channels (dwPosition)
01025         gsInfChan,                              // Available info channels (dwPosition)
01036         gsAudSelect,                    // Selected audio channels (dwPosition, supported dwStart)
01047         gsVidSelect,                    // Selected video channels (dwPosition, supported dwStart)
01058         gsInfSelect,                    // Selected info channels (dwPosition, supported dwStart)
01069         gsAudEdit,                              // Edit ready audio channels (dwPosition, supported dwStart)
01080         gsVidEdit,                              // Edit ready video channels (dwPosition, supported dwStart)
01091         gsInfEdit,                              // Edit ready info channels (dwPosition, supported dwStart)
01102         gsEditMode,                             // Edit to use assemble or insert
01103
01104         // MetaData set/retieve
01121         gsMetaData = 150,
01136         gsMetaDataDirectory,
01151         gsMetaDataVolume,
01167         gsMetaDataCurrentUser,
01183         gsMetaDataLocalMachine,
01199         gsMetaDataGlobal,
01200
01201         // Audio settings us dwAudioChannels (except ltc)
01218         gsAudInSelect = 200,    // Audio Input Select (dwPosition, available = dwStart)
01235         gsAudOutSelect,                 // Audio Output Select (dwPosition, available = dwStart)
01236
01250         gsAudInputLevel,                // Input level setting (16 bit) (dwPosition, min = dwStart, max = dwEnd)
01264         gsAudOutputLevel,               // Output level setting (16 bit) (dwPosition, min = dwStart, max = dwEnd)
01278         gsAudAdvanceLevel,              // ??? (Not Supported) (dwPosition, min = dwStart, max = dwEnd)
01292         gsAudOutPhase,                  // In samples (dwPosition, min = dwStart, max = dwEnd)
01306         gsAudOutAdvancePhase,   // ??? (Not Supported) in samples (dwPosition, min = dwStart, max = dwEnd)
01318         gsAudCrossFadeTime,             // Audio cross fade duration (dwPosition, min = dwStart, max = dwEnd)
01329         gsAudLtcEnable,                 // Ltc enabled (dwposition)
01341         gsAudInLtcChannel,              // Ltc channel, -1 if disabled (dwPosition, available = dwStart)
01353         gsAudOutLtcChannel,             // Ltc channel, -1 if disabled (dwPosition, available = dwStart)
01364         gsAudDtmfEnable,                // Dtmf enabled (dwposition)
01376         gsAudInDtmfChannel,             // Dtmf channel, -1 if disabled (dwPosition, available = dwStart)
01388         gsAudOutDtmfChannel,    // Dtmf channel, -1 if disabled (dwPosition, available = dwStart)
01402         gsAudWavePeakRMS,               // Current play or in peak|rms 0-(dwStart:HiWord|LoWord), 1-(dwEnd:HiWord|LoWord)
01412         gsAudInputBitRate,                      //Sets the bit rate for audio records (Argus)
01424         gsAudInputSampleRate,
01434         gsAudInputMode,
01446         gsAudInputHeadRoom,
01456         gsAudInputOriginal,
01466         gsAudInputErrorProtect,
01476         gsAudInputCopyright,
01486         gsAudInputSlave,
01498         gsAudInputBass,
01510         gsAudInputTreble,
01511
01512
01523         gsVidFreeze = 300,              // Freeze video 0-un, 1 field, 2 field, 3 both (dwPosition)
01541         gsVidPreReadMode,               // Setup for preread mode (dwPosition = channel, dwStart = used channels, dwEnd = available channels);
01551         gsVidEditField,                 // Starting field for an edit (2=2nd, else 1st) (dwPosition = channel, dwStart = available channels)
01561         gsVidRecFrame,                  // Record frame or field (dwPosition = channel, dwStart = available channels)
01571         gsVidPlayFrame,                 // Play frame or field (dwPosition = channel, dwStart = available channels)
01581         gsVidNoEE,                              // No E to E mode allowed (dwPosition = channel, dwStart = available channels)
01591         gsVidSuperimpose,               // Super tc/state data on monitor output (dwPosition = channel, dwStart = available channels)
01592
01606         gsVidAnalogMonitorSDType,
01616         gsVidAnalogMonitorHDType,
01626         gsVidAnalogMonitorMethod,
01638         gsVidAnalogMonitorUpMode,
01648         gsVidAnalogMonitorDownMode,
01649
01650         // Video settings use dwVideoChannels
01665         gsVidInSelect = 400,    // Select video input source (dwPosition, supported = dwStart)
01676         gsVidInLockType,                // Input channel lock type (1-Broadcast, 0-VTR)
01688         gsVidInSetup,                   // Input channel Setup (16 bit unsigned) (dwPosition, min=dwStart, max=dwEnd)
01700         gsVidInVideo,                   // Input channel Video (16 bit unsigned) (dwPosition, min=dwStart, max=dwEnd)
01712         gsVidInHue,                             // Input channel Hue (16 bit unsigned) (dwPosition, min=dwStart, max=dwEnd)
01724         gsVidInChroma,                  // Input channel Chroma (16 bit unsigned) (dwPosition, min=dwStart, max=dwEnd)
01737         gsVidInUChroma,                 // Input channel U Component Chroma (16 bit unsigned) (dwPosition, min=dwStart, max=dwEnd)
01750         gsVidInVChroma,                 // Input channel V Component Chroma (16 bit unsigned) (dwPosition, min=dwStart, max=dwEnd)
01760         gsVidInColorKiller,             // Kill colour on input (dwPosition bool)
01770         gsVidInAGC,                             // Input channel automatic gain control (dwPosition bool)
01781         gsVidInBandwidth,               // Signal bandwidth (dwPosition, supported = dwStart)
01792         gsVidInBlack,                   // Black level (dwPosition, supported = dwStart)
01803         gsVidInWhite,                   // Max white (dwPosition, supported = dwStart)
01814         gsVidInCoring,                  // Input channel coring 0, 1 or 2 bits (dwPosition, supported = dwStart)
01825         gsVidInPeaking,                 // (dwPosition, supported = dwStart)
01837         gsVidInSharpness,               // (dwPosition, min=dwStart, max=dwEnd)
01849         gsVidInGamma,                   // (dwPosition, min=dwStart, max=dwEnd)
01866         gsVidInSignalFormat,    // Input signal format (-1 for not present or bad setup)
01867
01879         gsVidSetup = 500,               // Video 'Setup' (16 bit signed) (dwPosition, min=dwStart, max=dwEnd)
01891         gsVidVideo,                             // Video 'Video' (16 bit signed) (dwPosition, min=dwStart, max=dwEnd)
01903         gsVidHue,                               // Video 'Hue' (16 bit signed) (dwPosition, min=dwStart, max=dwEnd)
01915         gsVidChroma,                    // Video 'Chroma' (16 bit signed) (dwPosition, min=dwStart, max=dwEnd)
01928         gsVidUChroma,                   // Input channel U Component Chroma (16 bit signed) (dwPosition, min=dwStart, max=dwEnd)
01941         gsVidVChroma,                   // Input channel V Component Chroma (16 bit signed) (dwPosition, min=dwStart, max=dwEnd)
01952         gsVidBandwidth,                 // Signal bandwidth SEE gsVidInBandwidth (dwPosition, supported=dwStart)
01963         gsVidBlackSetup,                // Super black, Crystal Black, NTSC Setup SEE gsVidInBlack (dwPosition, supported=dwStart)
01973         gsVidColor,                             // Color signal or black and white (dwPosition)
01974
01989         gsVidOutSelect = 600,   // Select main out (See gsVidInSelect)
02002         gsVidOutGenlock,                // Genlock enable (dwPosition, dwStart=supported sources)
02017         gsVidOutGenlockSource,
02028         gsVidOutLockType,               // Genlock lock type (0-Broadcast, 1-VTR) (dwPosition )
02040         gsVidOutHPhase,                 // Horizontal Phase (16 bit signed) (dwPosition, min=dwStart, max=dwEnd)
02052         gsVidOutSubCarrier,             // Sub Carrier Phase (16 bit signed) (dwPosition, min=dwStart, max=dwEnd)
02063         gsVidOutCoring,                 // Core 0, 1 or 2 bits from signal (0, 1, 2) (dwPosition, supported=dwStart)
02074         gsVidOutPeaking,                // Peaking (dwPosition, supported=dwStart)
02086         gsVidOutAdjust1,                //
02098         gsVidOutAdjust2,                //
02110         gsVidOutGenlockDelay,   //
02127         gsVidOutLockSignalFormat,       // Genlock input signal format (-1 for not present or bad setup)
02128
02129
02130         // Compression and internal signal parameters
02140         gsCompChVerticalRes = 700,
02142         gsMpegVerticalRes = gsCompChVerticalRes,
02152         gsCompChHorizontalRes,
02154         gsMpegHorizontalRes = gsCompChHorizontalRes,
02166         gsCompChChromaFormat,
02168         gsMpegChromaFormat = gsCompChChromaFormat,
02180         gsCompChDCPrecision,
02182         gsMpegDCPrecision = gsCompChDCPrecision,
02194         gsCompChAspectRatio,
02196         gsMpegAspectRatio = gsCompChAspectRatio,
02208         gsCompChStandard,
02210         gsMpegStandard = gsCompChStandard,
02220         gsCompChLanguageCode,
02222         gsMpegLanguageCode = gsCompChLanguageCode,
02234         gsCompChCCFormat,
02236         gsMpegCCFormat = gsCompChCCFormat,
02246         gsCompChConcealmentVector,
02248         gsMpegConcealmentVector = gsCompChConcealmentVector,
02258         gsCompChClosedGop,
02260         gsMpegClosedGop = gsCompChClosedGop,
02270         gsCompChAdjustGopTC,
02272         gsMpegAdjustGopTC = gsCompChAdjustGopTC,
02282         gsCompChAltCoEffTable,
02284         gsMpegAltCoEffTable = gsCompChAltCoEffTable,
02294         gsCompChNonLinearQuant,
02296         gsMpegNonLinearQuant = gsCompChNonLinearQuant,
02306         gsCompChMuxRate,
02308         gsMpegMuxRate = gsCompChMuxRate,
02318         gsCompChAudPacketSize,
02320         gsMpegAudPacketSize = gsCompChAudPacketSize,
02330         gsCompChVidPacketSize,
02332         gsMpegVidPacketSize = gsCompChVidPacketSize,
02342         gsCompChAudioStreamID,
02344         gsMpegAudioStreamID = gsCompChAudioStreamID,
02354         gsCompChVideoStreamID,
02356         gsMpegVideoStreamID = gsCompChVideoStreamID,
02366         gsCompChAudioStreamPID,
02368         gsMpegAudioStreamPID = gsCompChAudioStreamPID,
02378         gsCompChVideoStreamPID,
02380         gsMpegVideoStreamPID = gsCompChVideoStreamPID,
02391         gsCompChAllowSettings,
02393         gsMpegAllowSettings = gsCompChAllowSettings,
02403         gsCompChFourCC,
02413         gsCompChBitCount,
02423         gsCompChSizeImage,
02433         gsCompChRate,
02443         gsCompChScale,
02453         gsCompChPitch,
02463         gsVideoEncodeFormat,
02473         gsAudioEncodeFormat,
02483         gsCompChannelChangeMs,
02493         gsAlphaChromaSource,
02503         gsCompressionType,
02504 //      gsBitDepth,
02505         gsVideoStandard,
02506         gsResetChannel,
02507         gsEnableHDSDFormat,
02508         gsVBlankEnable,
02509         gsLUTEnable,
02531         gsSignalFormat = 900,   // NTSC CCIR HD 16x9 etc (dwPosition, supported=dwStart)
02532
02573         gsCompType,                             // MJPG, MPEG2, Uncompressed (dwPosition, supported=dwStart)
02574
02586         gsCompRateSize,                 // Total data throughput - frame size (dwPosition, min=dwStart, max=dwEnd)
02598         gsCompRateRatio,                // Total data rate - ratio * 100 (eg 2:1 = 200) (dwPosition, min=dwStart, max=dwEnd)
02610         gsCompRatePercent,              // Total data rate - precentage * 100 (0-10000) of maximum (dwPosition, min=dwStart, max=dwEnd)
02623         gsCompGOPSize,                  // Number of elements in gop
02633         gsCompIFactor,                  // Number of elements in gop
02643         gsCompBFactor,                  // Number of elements in gop
02653         gsCompPFactor,                  // Number of elements in gop
02663         gsCompRefPeriod,                        // Number of elements in gop
02673         gsTotalStorageAvail,    // Total available storage (dwPosition)
02683         gsTotalStorageFree,             // Total free storage (total free space/cur data rate) (dwPosition)
02693         gsTotalTimeAvail,               // Total available time (dwPosition)
02703         gsTotalTimeFree,                // Total free time (total free space/cur data rate) (dwPosition)
02713         gsVtrType,                              // Emulation type (dwPosition)
02714
02724         gsLocal = 1000,                 // Local enable/disable (dwPosition)
02739         gsSupportedFileTypes,   // In order of favorites (dwPosition)
02753         gsIgnoreFileTypes,              // Per above    (dwPosition)
02763         gsRecInhibit,                   // Inhibit recording (dwPosition)
02774         gsRecDrive,                             // Record drives (dwPosition, available=dwStart)
02787         gsRecFileName,                          // Record drives (dwPosition, available=dwStart)
02799         gsRecRate,                              // Default recording rate (dwPosition, default=dwStart)
02809         gsRecFileFormat,                // Type of file to record SEE suppfiletypes (dwPosition, avail=dwStart)
02819         gsRecAudFileFormat,             // Type of audio file, or -1 if embedded (dwPosition, avail=dwStart)
02829         gsDelInhibit,                   // Inhibit deletion (dwPosition)
02839         gsInsInhibit,                   // Inhibit insertion of clips (dwPosition)
02849         gsConvertFileFormat,    // Type of file to convert to (dwPosition, avail = dwStart)
02859         gsConvertAudFileFormat, // Type of audio file, or -1 if embedded (dwPosition, avail = dwStart)
02869         gsDefStillLen,                  // Default still length (dwPosition)
02884         gsSysTime,                              // System Reference time (dwPostion, dwStart, dwEnd)
02895         gsDSyncMs,                              // DSync MS counter for current channel
02907         gsHwPort,                               // Currently only for ext drv (dwPostion = current, dwStart = available)
02918         gsPBEE,                                 // dwPosition
02929         gsServoRefSelect,               // dwPosition
02940         gsHeadSelect,                   // dwPosition
02951         gsColorFrame,                   // dwPosition
02962         gsVidRefDisable,                // dwPosition
02972         gsPlayCountDelay,               //dwPoisition   1022
02985         gsEmulateEditBumping,
02994         cmdaltNearestKeyFrame,
03003         cmdaltNextKeyFrame,
03012         cmdaltPrevKeyFrame,
03021         cmdaltStartOfMessage,
03031         gsVidInputValid,
03041         gsVidGenlockValid,
03042 #if 0   // Reserved
03043
03046         gsChannelAdd = 2000,
03047         gsChannelDel,
03048         gsChannelAddress,
03049         gsChannelPort,
03050         gsChannelTarget,
03051         gsChannelType,
03052         gsChannelEnable,
03053 #endif
03054
03068         gsErrorLog = 10000,
03077         gsErrorLogName,
03084         gsErrorLogStartMs,
03091         gsErrorLogCurrentMs,
03098         gsErrorLogLastChange,
03112         gsErrorLogMessage,
03113
03128         gsSysBufferLevel = 20000,
03140         gsSysMemoryUsage,
03152         gsSysCPUUsage,
03153
03162         gsProxyMode = 50000,
03175         gsProxyStatus,
03190         gsGetNextProxy,
03198         gsAddProxy,
03204         gsPromoteProxy,
03210         gsRemoveProxy,
03221         gsProxyCPUUsage,
03222
03232         gsVVWVersion = 60000,   // VVW Version (dwPosition, arbID = string)
03242         gsMEVersion,                    // Media Reactor Version  (dwPosition, arbID = string)
03252         gsVVWType,                              // Name of vvw model (dwPosition, arbID = string)
03262         gsVVWChannelType,               // Description of channel (dwPosition, arbID = string)
03273         gsVVWChannelName,               // Name of channel (dwPosition, arbID = string)
03274
03275
03291         gsMonitor = 64000,              // Set/Get info on VGA or Secondary NTSC monitor
03305         gsMonitorHwnds,
03307         gsHwnds = gsMonitorHwnds,                               // Get above info
03322         gsMonitorDisplay,
03346         gsMonitorGrab,
03347
03350         gsDirGetList = 64250,
03353         gsDirGetInfo,
03356         gsDirGetFileInfo,
03359         gsDirGetFileGrab,
03360
03372         gsChannelsExist = 65536,// Do the channels exist (dwPosition - used dwvid/aud/inf channels)
03382         gsClipMode,                             // Are we in clip or timecode space mode (dwPosition)
03392         gsRecOffset,                    // Mostly for multi digisuite records
03409         gsChanCapabilities,                     // Return capabilities of vvw channel
03419         gsLastChangeMs,                         // Are we in clip or timecode space mode (dwPosition)
03434         gsGPIIn,                                        // Get/Set GPI inputs
03452         gsGPIOut,                                       // Get/Set GPI outputs
03463         gsCurrentMs,                            // Current ms (dwPosition)
03464
03465
03475         gsSaveCurrent = 100000, // Save the current params
03485         gsLoadClipSpace,        // Load a new clip space
03495         gsLoadTCSpace,  // Load a new ::VTR_TC space
03505         gsLoadFilmSpace,        // Load a new ::Film space
03506
03516         gsUserLogIn = 900000,
03526         gsUserLastChangeMs,
03539         gsUserList,
03550         gsUserAdd,
03560         gsUserDel,
03572         gsUserRights,
03583         gsUserPasswd,
03584
03585
03596         gsPiconFrame = 1000000,
03607         gsJpegFrame,
03616         gsImageDirectory,
03617
03618         gsVVWService  = 1100000,
03619
03620         /*
03621         For clip copy and translation lists set removes an item get returns the list like a cliplist
03622         */
03623         gsInsertQueue,
03624         /*
03625         For clip copy queue manipulation
03626         */
03627         gsXlatQueue
03628
03629 };
03630
03632
03633 #define GS_CLIPMODE_ILLEGAL                             0xFFFFFFFF      // filetypeIllegal
03634 #define GS_CLIPMODE_CLIPSPACE                   0                       // filetypeClipSpace
03635 #define GS_CLIPMODE_TCSPACE                             1                       // filetypeTCSpace
03636 #define GS_CLIPMODE_SINGLE                              2                       // filetypeSingle
03637 #define GS_CLIPMODE_FILM                                3                       // filetypeFilm
03638
03639
03640
03641 // Standard values for Get/Set/Supported commands
03643 #define GS_TCSOURCE_LTC         1
03644
03645 #define GS_TCSOURCE_VITC        2
03646
03647 #define GS_TCSOURCE_CTL         4
03648
03649 #define GS_TCSOURCE_CLIP        7
03650
03652 #define GS_FRAMEDATA_UNKNOWN    0x00000
03653
03654 #define GS_FRAMEDATA_ASCII              0x00001
03655
03656 #define GS_FRAMEDATA_HEX                0x00002
03657
03658 #define GS_FRAMEDATA_TELECINE   0x10001
03659
03660 #define GS_FRAMEDATA_CC_TTEXT   0x10002
03661
03662 #define GS_FRAMEDATA_NAVY               0x10003
03663
03665 #define GS_INSERT_EDIT          0x01
03666
03667 #define GS_ASSEMBLE_EDIT        0x02
03668
03670 #define GS_AUDSELECT_UNBALANCED_10              0x001
03671
03672 #define GS_AUDSELECT_UNBALANCED_4               0x002
03673
03674 #define GS_AUDSELECT_BALANCED_10                0x010
03675
03676 #define GS_AUDSELECT_BALANCED_4                 0x020
03677
03678 #define GS_AUDSELECT_SPDIF                              0x100
03679
03680 #define GS_AUDSELECT_AES_EBU                    0x200
03681
03682 #define GS_AUDSELECT_EMBEDDED                   0x400
03683
03684 #define GS_AUDSELECT_AES_EBU_PRO                0x800
03685
03686 #define GS_AUDSELECT_NONE                               0
03687
03688 #define GS_AUDSELECT_SILENT                             0x040
03689
03690 //Defines for various audio bit rates.
03691 #define GS_AUD_BIT_RATE_32000                   0x0001
03692 #define GS_AUD_BIT_RATE_41100                   0x0002
03693 #define GS_AUD_BIT_RATE_48000                   0x0004
03694 #define GS_AUD_BIT_RATE_56000                   0x0008
03695 #define GS_AUD_BIT_RATE_64000                   0x0010
03696 #define GS_AUD_BIT_RATE_80000                   0x0020
03697 #define GS_AUD_BIT_RATE_96000                   0x0040
03698 #define GS_AUD_BIT_RATE_112000                  0x0080
03699 #define GS_AUD_BIT_RATE_128000                  0x0100
03700 #define GS_AUD_BIT_RATE_160000                  0x0200
03701 #define GS_AUD_BIT_RATE_192000                  0x0400
03702 #define GS_AUD_BIT_RATE_224000                  0x0800
03703 #define GS_AUD_BIT_RATE_256000                  0x1000
03704 #define GS_AUD_BIT_RATE_320000                  0x2000
03705 #define GS_AUD_BIT_RATE_384000                  0x4000
03706
03707 #define GS_AUD_STEREO                                   0x001
03708 #define GS_AUD_JOINT_STEREO                             0x002
03709 #define GS_AUD_DUAL                                             0x004
03710 #define GS_AUD_SINGLE                                   0x008
03711 #define GS_AUD_MULTIPLE                                 0x010
03712 #define GS_AUD_HEADROOM_18                              0x01
03713 #define GS_AUD_HEADROOM_20                              0x02
03714
03716 #define GS_VIDFREEZE_NOT_FROZEN                 0
03717
03718 #define GS_VIDFREEZE_FIELD0                             1
03719
03720 #define GS_VIDFREEZE_FIELD1                             2
03721
03722 #define GS_VIDFREEZE_FRAME                              3
03723
03725 #define GS_VIDSELECT_COMPOSITE                          0x001
03726
03727 #define GS_VIDSELECT_SVIDEO                                     0x002
03728
03729 #define GS_VIDSELECT_COMPOSITE_2                        0x004
03730
03731 #define GS_VIDSELECT_COMPOSITE_3                        0x008
03732
03733 #define GS_VIDSELECT_COMPONENT_YUV                      0x010
03734
03735 #define GS_VIDSELECT_COMPONENT_YUV_M2           0x020
03736
03737 #define GS_VIDSELECT_COMPONENT_YUV_SMPTE        0x040
03738
03739 #define GS_VIDSELECT_COMPONENT_RGB                      0x080
03740
03741 #define GS_VIDSELECT_D1_SERIAL                          0x100
03742
03743 #define GS_VIDSELECT_D1_PARALLEL                        0x200
03744
03745 #define GS_VIDSELECT_SDTI                                       0x400
03748 #define GS_VIDSELECT_COMPOSITE_4                        0x800
03749
03750 #define GS_VIDSELECT_SVIDEO_2                           0x1000
03751
03752 #define GS_VIDSELECT_COMPONENT_YUV_2            0x2000
03753
03754 #define GS_VIDSELECT_D1_SERIAL_2                        0x4000
03755
03756 #define GS_VIDSELECT_COMPOSITE_JAPAN            0x8000
03757
03758 #define GS_VIDSELECT_SVIDEO_JAPAN                       0x10000
03759
03760 #define GS_VIDSELECT_COMPONENT_YUV_JAPAN        0x20000
03761
03762 #define GS_VIDSELECT_COMPONENT_YUV_SMPTE_JAPAN  0x40000
03763
03764 #define GS_VIDSELECT_XVID_RGB                           0x80000
03765
03766 #define GS_VIDSELECT_NONE                                       0
03767
03769 #define GS_VIDLOCKTYPE_VTR                              1
03770
03771 #define GS_VIDLOCKTYPE_BROADCAST                2
03772
03774 #define GS_VIDBAND_STANDARD             0x01
03775
03776 #define GS_VIDBAND_MEDIUM               0x02
03777
03778 #define GS_VIDBAND_HIGH                 0x04
03779
03780 #define GS_VIDBAND_NOTCH                0x08
03781
03783 #define GS_VIDBLACK_SETUP               0x01    // 7.5 ire ntsc, 0 ire pal
03784
03785 #define GS_VIDBLACK_CRYSTAL             0x02    // 0 ire ntsc, 0 ire pal
03786
03787 #define GS_VIDBLACK_SUPER               0x04    // < 0 ire ntsc/pal
03788
03790 #define GS_VIDWHITE_CLAMP               0x01    // 100 IRE white max
03791
03792 #define GS_VIDWHITE_SCALE               0x02    // Scale like AGC
03793
03794 #define GS_VIDWHITE_FREE                0x04    // Any white
03795
03797 #define GS_LOCKSRC_NONE         0x0001  // No genlock (free run master)
03798
03799 #define GS_LOCKSRC_EXTIN        0x0002  // Lock to external in
03800
03801 #define GS_LOCKSRC_INPUT        0x0004  // Lock to current input
03802
03803 #define GS_LOCKSRC_CVBS         0x0008  // Lock to composite ing
03804
03805 #define GS_LOCKSRC_SVIDEO       0x0010  // Lock to S-Video In
03806
03807 #define GS_LOCKSRC_IN_Y         0x0020  // Lock to Y of betacam input
03808
03809 #define GS_LOCKSRC_SDI          0x0040  // Lock to Digital Module Ref In. //DigiSuiteLite
03810
03812 #define GS_ANALOGMONITORMETHOD_DIRECT   0x0000
03813
03814 #define GS_ANALOGMONITORMETHOD_SD               0x0001
03815
03816 #define GS_ANALOGMONITORMETHOD_HD720    0x0002
03817
03818 #define GS_ANALOGMONITORMETHOD_HD1080   0x0003
03819
03820 #define GS_ANALOGMONITORMETHOD_FLIP720  0x0004
03821
03822 #define GS_ANALOGMONITORMETHOD_FLIP1080 0x0005
03823
03825 #define GS_UPCONVERT_ANAMORPHIC                 0x0000
03826
03827 #define GS_UPCONVERT_PILLARBOX                  0x0001
03828
03829 #define GS_UPCONVERT_ZOOM14x9                   0x0002
03830
03831 #define GS_UPCONVERT_LETTERBOX                  0x0004
03832
03833 #define GS_UPCONVERT_ZOOMWIDE                   0x0005
03834
03836 #define GS_DOWNCONVERT_LETTERBOX                0x0000
03837
03838 #define GS_DOWNCONVERT_CROP                             0x0001
03839
03840 #define GS_DOWNCONVERT_ANAMORPHIC               0x0002
03841
03843 #define GS_MPEG_RESOLUTION_120                  0x001
03844 #define GS_MPEG_RESOLUTION_240                  0x002
03845 #define GS_MPEG_RESOLUTION_288                  0x004
03846 #define GS_MPEG_RESOLUTION_352                  0x008
03847 #define GS_MPEG_RESOLUTION_480                  0x010
03848 #define GS_MPEG_RESOLUTION_512                  0x020
03849 #define GS_MPEG_RESOLUTION_544                  0x040
03850 #define GS_MPEG_RESOLUTION_576                  0x080
03851 #define GS_MPEG_RESOLUTION_608                  0x100
03852 #define GS_MPEG_RESOLUTION_704                  0x200
03853 #define GS_MPEG_RESOLUTION_720                  0x400
03854
03855 #define GS_CHROMA_FORMAT_420                    0x1
03856 #define GS_CHROMA_FORMAT_422                    0x2
03857 #define GS_CHROMA_FORMAT_444                    0x4
03858 #define GS_CHROMA_FORMAT_411                    0x8
03859 #define GS_MPEG_CHROMA_FORMAT_420               GS_CHROMA_FORMAT_420
03860 #define GS_MPEG_CHROMA_FORMAT_422               GS_CHROMA_FORMAT_422
03861 #define GS_MPEG_CHROMA_FORMAT_444               GS_CHROMA_FORMAT_444
03862
03863 #define GS_MPEG_DC_PRECISION_8                  0x1
03864 #define GS_MPEG_DC_PRECISION_9                  0x2
03865 #define GS_MPEG_DC_PRECISION_10                 0x4
03866 #define GS_MPEG_DC_PRECISION_11                 0x8
03867
03868 #define GS_ASPECT_RATIO_SQUARE          0x1
03869 #define GS_ASPECT_RATIO_4x3                     0x2
03870 #define GS_ASPECT_RATIO_16x9            0x4
03871 #define GS_ASPECT_RATIO_2_21x1          0x8
03872 #define GS_MPEG_ASPECT_RATIO_SQUARE             GS_ASPECT_RATIO_SQUARE
03873 #define GS_MPEG_ASPECT_RATIO_4x3                GS_ASPECT_RATIO_4x3
03874 #define GS_MPEG_ASPECT_RATIO_16x9               GS_ASPECT_RATIO_16x9
03875 #define GS_MPEG_ASPECT_RATIO_2_21x1             GS_ASPECT_RATIO_2_21x1
03876
03877 #define GS_MPEG_STANDARD_SYSTEM                 0x1
03878 #define GS_MPEG_STANDARD_PROGRAM                0x2
03879 #define GS_MPEG_STANDARD_TRANSPORT              0x4
03880 #define GS_MPEG_STANDARD_ELEMENTARY             0x8
03881 #define GS_MPEG_STANDARD_ELEMENTRY              GS_MPEG_STANDARD_ELEMENTARY
03882
03883 #define GS_MPEG_LANGAUGE_ENGLISH                0x0001
03884 #define GS_MPEG_LANGAUGE_SPANISH                0x0002
03885 #define GS_MPEG_LANGAUGE_FRENCH                 0x0004
03886 #define GS_MPEG_LANGAUGE_GERMAN                 0x0008
03887 #define GS_MPEG_LANGAUGE_JAPANESE               0x0010
03888 #define GS_MPEG_LANGAUGE_DUTCH                  0x0020
03889 #define GS_MPEG_LANGAUGE_DANISH                 0x0040
03890 #define GS_MPEG_LANGAUGE_FINNISH                0x0080
03891 #define GS_MPEG_LANGAUGE_ITALIAN                0x0100
03892 #define GS_MPEG_LANGAUGE_GREEK                  0x0200
03893 #define GS_MPEG_LANGAUGE_PORTUGUESE             0x0400
03894 #define GS_MPEG_LANGAUGE_SWEDISH                0x0800
03895 #define GS_MPEG_LANGAUGE_RUSSIAN                0x1000
03896 #define GS_MPEG_LANGAUGE_CHINESE                0x2000
03897
03898 #define GS_MPEG_CC_FORMAT_CCUBE                 0x1
03899 #define GS_MPEG_CC_FORMAT_ATSC                  0x2
03900 #define GS_MPEG_CC_FORMAT_CCUBE_REORDER 0x4
03901 #define GS_MPEG_CC_FORMAT_ATSC_REORDER  0x8
03902
03903 #define GS_MPEG_ONE_FRAMES                              0x0001
03904 #define GS_MPEG_TWO_FRAMES                              0x0002
03905 #define GS_MPEG_THREE_FRAMES                    0x0004
03906 #define GS_MPEG_FOUR_FRAMES                             0x0008
03907 #define GS_MPEG_FIVE_FRAMES                             0x0010
03908 #define GS_MPEG_SIX_FRAMES                              0x0020
03909 #define GS_MPEG_SEVEN_FRAMES                    0x0040
03910 #define GS_MPEG_EIGHT_FRAMES                    0x0080
03911 #define GS_MPEG_NINE_FRAMES                             0x0100
03912 #define GS_MPEG_TEN_FRAMES                              0x0200
03913 #define GS_MPEG_ELEVEN_FRAMES                   0x0400
03914 #define GS_MPEG_TWELVE_FRAMES                   0x0800
03915 #define GS_MPEG_THIRTEEN_FRAMES                 0x1000
03916 #define GS_MPEG_FOURTEEN_FRAMES                 0x2000
03917 #define GS_MPEG_FIFTEEN_FRAMES                  0x4000
03918 #define GS_MPEG_SIXTEEN_FRAMES                  0x8000
03919
03920 #define VIDEOWRITETYPE_AVI              0x00000001      //standard uncompressed AVI
03921 #define VIDEOWRITETYPE_MOV              0x00000002      //Uncompressed Quicktime
03922 #define VIDEOWRITETYPE_WMV              0x00000004      //uncompressed windows media
03923 #define VIDEOWRITETYPE_GEN              0x00000008      //Avid uncompressed Gen File
03924 #define VIDEOWRITETYPE_JS               0x00000010      //Uncompressed Jaleo
03925 #define VIDEOWRITETYPE_DVS              0x00000020      //
03926 #define VIDEOWRITETYPE_IHSS             0x00000040      //
03927 #define VIDEOWRITETYPE_HDR              0x00000080      //Header YUV
03928 #define VIDEOWRITETYPE_YUV              0x00000100      //YUV still file format
03929 #define VIDEOWRITETYPE_RAW              0x00000200      //uncompressed raw still file format
03930 #define VIDEOWRITETYPE_TGA              0x00000400      //Targa still file format
03931 #define VIDEOWRITETYPE_BMP              0x00000800      //birmap still file format
03932 #define VIDEOWRITETYPE_TIFF             0x00001000      //TIFF still file format
03933 #define VIDEOWRITETYPE_CIN              0x00002000      //cineon still file format
03934 #define VIDEOWRITETYPE_DPX              0x00004000      //dpx still file format
03935 #define VIDEOWRITETYPE_MPG              0x00008000      //mpeg
03936 #define VIDEOWRITETYPE_4224             0x00010000      //4:2:2:4 YCbCr 8/10 bit
03937
03939 #define GS_MONITORGRAB_NONE                     0x0000
03940
03941 #define GS_MONITORGRAB_TYPE_MASK        0x00F0
03942
03943 #define GS_MONITORGRAB_TYPE_BMP         0x0000
03944
03945 #define GS_MONITORGRAB_TYPE_JPG         0x0010
03946
03947 #define GS_MONITORGRAB_SIZE_MASK        0x000F
03948
03949 #define GS_MONITORGRAB_SIZE_FULL        0x0001
03950
03951 #define GS_MONITORGRAB_SIZE_HALF        0x0002
03952
03953 #define GS_MONITORGRAB_SIZE_QUARTER     0x0004
03954
03955 #define GS_MONITORGRAB_TARGET_MASK      0x0F00
03956
03957 #define GS_MONITORGRAB_TO_MEMORY        0x0100
03958
03959 #define GS_MONITORGRAB_TO_UNC_PATH      0x0200
03960
03961 #define GS_MONITORGRAB_TO_HTTP          0x0400
03962
03963 #define GS_MONITORGRAB_TO_NETWORK       0x0800
03964
03966 #define GS_USERRIGHTS_NONE              0x0000
03967 #define GS_USERRIGHTS_READ              0x0001
03968 #define GS_USERRIGHTS_MODIFY    0x0002
03969 #define GS_USERRIGHTS_WRITE             0x0004
03970 #define GS_USERRIGHTS_SETUP             0x0008
03971 #define GS_USERRIGHTS_PLAY              0x0010
03972 #define GS_USERRIGHTS_RECORD    0x0020
03973 #define GS_USERRIGHTS_ADD               0x0100
03974 #define GS_USERRIGHTS_DELETE    0x0200
03975 #define GS_USERRIGHTS_FULL              0x7FFF
03976 #define GS_USERRIGHTS_ADMIN             0x8000
03977
03978
03979 //
03980 // Masks and shifts
03981 //
03983 #define GS_SIGFORMMASK_FRAMERATE        0x000001ff
03984
03985 #define GS_SIGFORMSHIFT_FRAMERATE       0
03986
03987 #define GS_SIGFORMMASK_HORIZONTAL       0x000ffe00
03988
03989 #define GS_SIGFORMSHIFT_HORIZONTAL      9
03990
03991 #define GS_SIGFORMMASK_VERTICAL         0x0ff00000
03992
03993 #define GS_SIGFORMSHIFT_VERTICAL        20
03994
03995 #define GS_SIGFORMMASK_FRAMETYPE        0xF0000000
03996
03997 #define GS_SIGFORMSHIFT_FRAMETYPE       28
03998
03999 //
04000 // Basic frame rate types
04001 //
04002 #define GS_SIGFORMFRAMERATE_5           5
04003 #define GS_SIGFORMFRAMERATE_6           6
04004 #define GS_SIGFORMFRAMERATE_7_5         7
04005 #define GS_SIGFORMFRAMERATE_10          10
04006 #define GS_SIGFORMFRAMERATE_14_98       14
04007 #define GS_SIGFORMFRAMERATE_15          15
04008 #define GS_SIGFORMFRAMERATE_23_98       23
04009 #define GS_SIGFORMFRAMERATE_24          24
04010 #define GS_SIGFORMFRAMERATE_25          25
04011 #define GS_SIGFORMFRAMERATE_29_97       29
04012 #define GS_SIGFORMFRAMERATE_30          30
04013 #define GS_SIGFORMFRAMERATE_47_95       47
04014 #define GS_SIGFORMFRAMERATE_48          48
04015 #define GS_SIGFORMFRAMERATE_50          50
04016 #define GS_SIGFORMFRAMERATE_59_94       59
04017 #define GS_SIGFORMFRAMERATE_60          60
04018 #define GS_SIGFORMFRAMERATE_71_93       71
04019 #define GS_SIGFORMFRAMERATE_72          72
04020 #define GS_SIGFORMFRAMERATE_100         100             // 0x64
04021 #define GS_SIGFORMFRAMERATE_119_88      119             // 0x77
04022 #define GS_SIGFORMFRAMERATE_CUSTOM      0x100
04023
04024 //
04025 // Sizing elements
04026 //
04027 #define GS_SIGFORMSIZE_240                      0x01
04028 #define GS_SIGFORMSIZE_243                      0x02
04029 #define GS_SIGFORMSIZE_288                      0x03    // Gap 4
04030 #define GS_SIGFORMSIZE_320                      0x08
04031 #define GS_SIGFORMSIZE_352                      0x09
04032 #define GS_SIGFORMSIZE_360                      0x0a    // Gap 5
04033 #define GS_SIGFORMSIZE_480                      0x10
04034 #define GS_SIGFORMSIZE_483                      0x11
04035 #define GS_SIGFORMSIZE_486                      0x12    // Gap 1
04036 #define GS_SIGFORMSIZE_496                      0x14    // Gap 2
04037 #define GS_SIGFORMSIZE_504                      0x16
04038 #define GS_SIGFORMSIZE_512                      0x17    // Gap 2
04039 #define GS_SIGFORMSIZE_576                      0x1a
04040 #define GS_SIGFORMSIZE_600                      0x1b
04041 #define GS_SIGFORMSIZE_608                      0x1c    // Gap 3
04042 #define GS_SIGFORMSIZE_640                      0x20
04043 #define GS_SIGFORMSIZE_720                      0x21
04044 #define GS_SIGFORMSIZE_768                      0x22
04045 #define GS_SIGFORMSIZE_800                      0x23
04046 #define GS_SIGFORMSIZE_864                      0x24
04047 #define GS_SIGFORMSIZE_988                      0x25    // Gap 3
04048 #define GS_SIGFORMSIZE_857                      0x26
04049 #define GS_SIGFORMSIZE_960                      0x28
04050 #define GS_SIGFORMSIZE_968                      0x29
04051 #define GS_SIGFORMSIZE_778                      0x2A
04052 #define GS_SIGFORMSIZE_872                      0x2B    // Gap 4
04053 #define GS_SIGFORMSIZE_1024                     0x30
04054 #define GS_SIGFORMSIZE_1035                     0x31
04055 #define GS_SIGFORMSIZE_1044                     0x32
04056 #define GS_SIGFORMSIZE_1052                     0x33
04057 #define GS_SIGFORMSIZE_1050                     0x34    // Gap 4
04058 #define GS_SIGFORMSIZE_1080                     0x38
04059 #define GS_SIGFORMSIZE_1088                     0x39
04060 #define GS_SIGFORMSIZE_1096                     0x3a    // Gap 3
04061 #define GS_SIGFORMSIZE_1102                     0x3E    // Gap 1
04062 #define GS_SIGFORMSIZE_1152                     0x40
04063 #define GS_SIGFORMSIZE_1200                     0x41    // Gap 1
04064 #define GS_SIGFORMSIZE_1234                     0x43    // Gap 6
04065 #define GS_SIGFORMSIZE_1280                     0x48
04066 #define GS_SIGFORMSIZE_1332                     0x49    // Gap 1
04067 #define GS_SIGFORMSIZE_1400                     0x4B
04068 #define GS_SIGFORMSIZE_1440                     0x4C    // Gap 3
04069 #define GS_SIGFORMSIZE_1536                     0x50
04070 #define GS_SIGFORMSIZE_1556                     0x51
04071 #define GS_SIGFORMSIZE_1588                     0x52    // Gap 4
04072 #define GS_SIGFORMSIZE_1828                     0x56
04073 #define GS_SIGFORMSIZE_1714                     0x57
04074 #define GS_SIGFORMSIZE_1600                     0x58
04075 #define GS_SIGFORMSIZE_1920                     0x59    // Gap 7
04076 #define GS_SIGFORMSIZE_2048                     0x60    // Gap 8
04077 #define GS_SIGFORMSIZE_2650                     0x68    // Gap 4
04078 #define GS_SIGFORMSIZE_3112                     0x6b    // Gap 3
04079 #define GS_SIGFORMSIZE_4096                     0x80
04080
04081 //
04082 // Basic Frame Sizes
04083 //
04084 #define GS_SIGFORMSIZE_640x480          ((GS_SIGFORMSIZE_640 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_480 << GS_SIGFORMSHIFT_VERTICAL))
04085 #define GS_SIGFORMSIZE_640x576          ((GS_SIGFORMSIZE_640 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))
04086 #define GS_SIGFORMSIZE_720x480          ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_480 << GS_SIGFORMSHIFT_VERTICAL))
04087 #define GS_SIGFORMSIZE_720x483          ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_483 << GS_SIGFORMSHIFT_VERTICAL))
04088 #define GS_SIGFORMSIZE_720x486          ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_486 << GS_SIGFORMSHIFT_VERTICAL))
04089 #define GS_SIGFORMSIZE_720x512          ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_512 << GS_SIGFORMSHIFT_VERTICAL))
04090 #define GS_SIGFORMSIZE_720x576          ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))
04091 #define GS_SIGFORMSIZE_720x608          ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_608 << GS_SIGFORMSHIFT_VERTICAL))
04092 #define GS_SIGFORMSIZE_720x504          ((GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_504 << GS_SIGFORMSHIFT_VERTICAL))
04093 #define GS_SIGFORMSIZE_800x600          ((GS_SIGFORMSIZE_800 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_600 << GS_SIGFORMSHIFT_VERTICAL))
04094 #define GS_SIGFORMSIZE_960x486          ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_486 << GS_SIGFORMSHIFT_VERTICAL))
04095 #define GS_SIGFORMSIZE_960x576          ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_576 << GS_SIGFORMSHIFT_VERTICAL))
04096 #define GS_SIGFORMSIZE_960x504          ((GS_SIGFORMSIZE_960 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_504 << GS_SIGFORMSHIFT_VERTICAL))
04097 #define GS_SIGFORMSIZE_1024x768         ((GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_768 << GS_SIGFORMSHIFT_VERTICAL))
04098 #define GS_SIGFORMSIZE_1024x1024        ((GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_VERTICAL))
04099 #define GS_SIGFORMSIZE_1152x864         ((GS_SIGFORMSIZE_1152 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_864 << GS_SIGFORMSHIFT_VERTICAL))
04100 #define GS_SIGFORMSIZE_1280x1024        ((GS_SIGFORMSIZE_1280 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1024 << GS_SIGFORMSHIFT_VERTICAL))
04101 #define GS_SIGFORMSIZE_1400x1050        ((GS_SIGFORMSIZE_1400 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1050 << GS_SIGFORMSHIFT_VERTICAL))
04102 #define GS_SIGFORMSIZE_1600x1200        ((GS_SIGFORMSIZE_1600 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1200 << GS_SIGFORMSHIFT_VERTICAL))
04103 #define GS_SIGFORMSIZE_1280x720         ((GS_SIGFORMSIZE_1280 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_720 << GS_SIGFORMSHIFT_VERTICAL))
04104 #define GS_SIGFORMSIZE_1828x778     ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_778 << GS_SIGFORMSHIFT_VERTICAL))
04105 #define GS_SIGFORMSIZE_1828x988     ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_988 << GS_SIGFORMSHIFT_VERTICAL))
04106 #define GS_SIGFORMSIZE_1828x1102    ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1102 << GS_SIGFORMSHIFT_VERTICAL))
04107 #define GS_SIGFORMSIZE_1828x1332    ((GS_SIGFORMSIZE_1828 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1332 << GS_SIGFORMSHIFT_VERTICAL))
04108 #define GS_SIGFORMSIZE_1920x1035        ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1035 << GS_SIGFORMSHIFT_VERTICAL))
04109 #define GS_SIGFORMSIZE_1920x1080        ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))
04110 #define GS_SIGFORMSIZE_1920x1088        ((GS_SIGFORMSIZE_1920 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1088 << GS_SIGFORMSHIFT_VERTICAL))
04111 #define GS_SIGFORMSIZE_2560x1080        ((GS_SIGFORMSIZE_2650 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))
04112 #define GS_SIGFORMSIZE_2048x857     ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_857 << GS_SIGFORMSHIFT_VERTICAL))
04113 #define GS_SIGFORMSIZE_2048x872     ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_872 << GS_SIGFORMSHIFT_VERTICAL))
04114 #define GS_SIGFORMSIZE_2048x1102    ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1102 << GS_SIGFORMSHIFT_VERTICAL))
04115 #define GS_SIGFORMSIZE_2048x1234    ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1234 << GS_SIGFORMSHIFT_VERTICAL))
04116 #define GS_SIGFORMSIZE_2048x1080        ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1080 << GS_SIGFORMSHIFT_VERTICAL))
04117 #define GS_SIGFORMSIZE_2048x1536        ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1536 << GS_SIGFORMSHIFT_VERTICAL))
04118 #define GS_SIGFORMSIZE_2048x1556        ((GS_SIGFORMSIZE_2048 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1556 << GS_SIGFORMSHIFT_VERTICAL))
04119 #define GS_SIGFORMSIZE_4096x1714        ((GS_SIGFORMSIZE_4096 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_1714 << GS_SIGFORMSHIFT_VERTICAL))
04120 #define GS_SIGFORMSIZE_4096x3112        ((GS_SIGFORMSIZE_4096 << GS_SIGFORMSHIFT_HORIZONTAL) | (GS_SIGFORMSIZE_3112 << GS_SIGFORMSHIFT_VERTICAL))
04121
04122 //
04123 // Basic frame types
04124 //
04125 #define GS_SIGFORMTYPE_UNKNOWN                  (0)
04126 #define GS_SIGFORMTYPE_INTERLACED               (1 << GS_SIGFORMSHIFT_FRAMETYPE)
04127 #define GS_SIGFORMTYPE_PROGRESSIVE              (2 << GS_SIGFORMSHIFT_FRAMETYPE)
04128 #define GS_SIGFORMTYPE_SEGMENTEDFRAME   (4 << GS_SIGFORMSHIFT_FRAMETYPE)
04129
04131 #define GS_SIGFORM_NTSC                         (GS_SIGFORMSIZE_640x480 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
04132
04133 #define GS_SIGFORM_PAL                          (GS_SIGFORMSIZE_640x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)
04134
04135 #define GS_SIGFORM_CCIR_NTSC            (GS_SIGFORMSIZE_720x486 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
04136
04137 #define GS_SIGFORM_CCIR_NTSC_P483               (GS_SIGFORMSIZE_720x483 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)
04138
04139 #define GS_SIGFORM_CCIR_PAL                     (GS_SIGFORMSIZE_720x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)
04140
04141 #define GS_SIGFORM_CCIR_PNTSC_30        (GS_SIGFORMSIZE_720x486 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)
04142
04143 #define GS_SIGFORM_CCIR_PPAL_25         (GS_SIGFORMSIZE_720x576 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)
04144
04145 #define GS_SIGFORM_HD360                        (GS_SIGFORMSIZE_960x504 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
04146
04147 #define GS_SIGFORM_ALT_NTSC                     (GS_SIGFORMSIZE_960x486 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
04148
04149 #define GS_SIGFORM_ALT_PAL                      (GS_SIGFORMSIZE_960x576 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25)
04150
04152 #define GS_SIGFORM_1035i_30_260M        (GS_SIGFORMSIZE_1920x1035 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)
04153
04154 #define GS_SIGFORM_1035i_30X_260M       (GS_SIGFORMSIZE_1920x1035 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)
04155
04156 #define GS_SIGFORM_1080i_30                     (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30) /*      (274M-1997 Table1 System 4)     */
04157
04158 #define GS_SIGFORM_1080i_30X            (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_29_97)      /*      (274M-1997 Table1 System 5)     */
04159
04160 #define GS_SIGFORM_1080i_25                     (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_25) /*      (274M-1997 Table1 System 6)     */
04161
04162 #define GS_SIGFORM_1080sf_24            (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)
04163 #define GS_SIGFORM_1080i_24                     (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_24)
04164
04165 #define GS_SIGFORM_1080sf_24X           (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)
04166 #define GS_SIGFORM_1080i_24X            (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_23_98)
04167
04168 #define GS_SIGFORM_1080_30                      (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)        /*      (274M-1997 Table1 System 7)     */
04169
04170 #define GS_SIGFORM_1080_30X                     (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)     /*      (274M-1997 Table1 System 8)     */
04171
04172 #define GS_SIGFORM_1080_25                      (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)        /*      (274M-1997 Table1 System 9)     */
04173
04174 #define GS_SIGFORM_1080_24                      (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)        /*      (274M-1997 Table1 System 10)    */
04175
04176 #define GS_SIGFORM_1080_24X                     (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)     /*      (274M-1997 Table1 System 11)    */
04177
04178
04180 #define GS_SIGFORM_1080_60                      (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_60)
04181
04182 #define GS_SIGFORM_1080_60X                     (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_59_94)
04183
04184 #define GS_SIGFORM_1080_50                      (GS_SIGFORMSIZE_1920x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_50)
04185
04186
04188 #define GS_SIGFORM_720_60                       (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_60) /*      (296M-1996 Table1 System 1)     */
04189
04190 #define GS_SIGFORM_720_60X                      (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_59_94)      /*      (296M-1996 Table1 System 2)     */
04191
04192 #define GS_SIGFORM_720_50                       (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_50) /*      (296M-1996 Table1 System 1)     */
04193
04195 #define GS_SIGFORM_720_30                       (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_30)
04196
04197 #define GS_SIGFORM_720_30X                      (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_29_97)
04198
04199 #define GS_SIGFORM_720_25                       (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25) /*      (296M-1996 Table1 System 1)     */
04200
04201 #define GS_SIGFORM_720_24                       (GS_SIGFORMSIZE_1280x720 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24) /*      (296M-1996 Table1 System 1)     */
04202
04205 #define GS_SIGFORM_VESA_640_72          (GS_SIGFORMSIZE_640x480 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)
04206 #define GS_SIGFORM_VESA_800_71X         (GS_SIGFORMSIZE_800x600 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)
04207 #define GS_SIGFORM_VESA_800_72          (GS_SIGFORMSIZE_800x600 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)
04208 #define GS_SIGFORM_VESA_1024_71X        (GS_SIGFORMSIZE_1024x768 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)
04209 #define GS_SIGFORM_VESA_1024_72         (GS_SIGFORMSIZE_1024x768 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)
04210 #define GS_SIGFORM_VESA_1280_24         (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
04211 #define GS_SIGFORM_VESA_1280i_30        (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)
04212 #define GS_SIGFORM_VESA_1280_71X        (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_71_93)
04213 #define GS_SIGFORM_VESA_1280_72         (GS_SIGFORMSIZE_1280x1024 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_72)
04214 #define GS_SIGFORM_VESA_1600i_30        (GS_SIGFORMSIZE_1600x1200 | GS_SIGFORMTYPE_INTERLACED | GS_SIGFORMFRAMERATE_30)
04215
04218 #define GS_SIGFORM_DVI_1400_1050_24     (GS_SIGFORMSIZE_1400x1050 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
04219 #define GS_SIGFORM_DVI_1400_1050_25     (GS_SIGFORMSIZE_1400x1050 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)
04220 #define GS_SIGFORM_DCIN_2048_25         (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_25)
04221
04224 #define GS_SIGFORM_DCIN_2048sf_24X      (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)
04225 #define GS_SIGFORM_DCIN_2048sf_24       (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)
04226 #define GS_SIGFORM_DCIN_2048_24X        (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
04227 #define GS_SIGFORM_DCIN_2048_24         (GS_SIGFORMSIZE_2048x1080 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
04228
04229 #define GS_SIGFORM_FILM_1828_778_24  (GS_SIGFORMSIZE_1828x778 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
04230 #define GS_SIGFORM_FILM_1828_778_25  (GS_SIGFORMSIZE_1828x778 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
04231 #define GS_SIGFORM_FILM_1828_988_24  (GS_SIGFORMSIZE_1828x988 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
04232 #define GS_SIGFORM_FILM_1828_988_25  (GS_SIGFORMSIZE_1828x988 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
04233 #define GS_SIGFORM_FILM_1828_1102_24 (GS_SIGFORMSIZE_1828x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
04234 #define GS_SIGFORM_FILM_1828_1102_25 (GS_SIGFORMSIZE_1828x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
04235 #define GS_SIGFORM_FILM_1828_1332_24 (GS_SIGFORMSIZE_1828x1332 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
04236 #define GS_SIGFORM_FILM_1828_1332_25 (GS_SIGFORMSIZE_1828x1332 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
04237
04238 #define GS_SIGFORM_FILM_2048_857_24  (GS_SIGFORMSIZE_2048x857 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
04239 #define GS_SIGFORM_FILM_2048_857_25  (GS_SIGFORMSIZE_2048x857 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
04240
04241 #define GS_SIGFORM_FILM_2048_872_24  (GS_SIGFORMSIZE_2048x872 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
04242 #define GS_SIGFORM_FILM_2048_872_25  (GS_SIGFORMSIZE_2048x872 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
04243 #define GS_SIGFORM_FILM_2048_1102_24 (GS_SIGFORMSIZE_2048x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
04244 #define GS_SIGFORM_FILM_2048_1102_25 (GS_SIGFORMSIZE_2048x1102 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
04245 #define GS_SIGFORM_FILM_2048_1234_24 (GS_SIGFORMSIZE_2048x1234 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_24)
04246 #define GS_SIGFORM_FILM_2048_1234_25 (GS_SIGFORMSIZE_2048x1234 Or GS_SIGFORMTYPE_PROGRESSIVE Or GS_SIGFORMFRAMERATE_25)
04247
04250 #define GS_SIGFORM_FILM_2048_15X        (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_14_98)
04251 #define GS_SIGFORM_FILM_2048_14         GS_SIGFORM_FILM_2048_15X        // Deprecated, do not use
04252 #define GS_SIGFORM_FILM_2048_15         (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_15)
04253 #define GS_SIGFORM_FILM_2048sf_15X      (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_14_98)
04254 #define GS_SIGFORM_FILM_2048sf_15               (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_15)
04255 #define GS_SIGFORM_FILM_2048_24X        (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
04256 #define GS_SIGFORM_FILM_2048_24         (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
04257 #define GS_SIGFORM_FILM_2048sf_24X      (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)
04258 #define GS_SIGFORM_FILM_2048sf_24       (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)
04259 #define GS_SIGFORM_FILM_2048_48         (GS_SIGFORMSIZE_2048x1556 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_48)
04260
04261 #define GS_SIGFORM_FILM_2048_1536_15X           (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_14_98)
04262 #define GS_SIGFORM_FILM_2048_1536_15            (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_15)
04263 #define GS_SIGFORM_FILM_2048_1536sf_15X         (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_14_98)
04264 #define GS_SIGFORM_FILM_2048_1536sf_15          (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_15)
04265 #define GS_SIGFORM_FILM_2048_1536_24X           (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
04266 #define GS_SIGFORM_FILM_2048_1536_24            (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
04267 #define GS_SIGFORM_FILM_2048_1536sf_24X         (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_23_98)
04268 #define GS_SIGFORM_FILM_2048_1536sf_24          (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_24)
04269 #define GS_SIGFORM_FILM_2048_1536_48X           (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_47_95)
04270 #define GS_SIGFORM_FILM_2048_1536_48            (GS_SIGFORMSIZE_2048x1536 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_48)
04271
04272 #define GS_SIGFORM_FILM_4096_1714_24            (GS_SIGFORMSIZE_4096x1714 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
04273 #define GS_SIGFORM_FILM_4096_1714_24X           (GS_SIGFORMSIZE_4096x1714 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
04274
04275 #define GS_SIGFORM_FILM_4096_3112sf_5           (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_SEGMENTEDFRAME | GS_SIGFORMFRAMERATE_5)
04276 #define GS_SIGFORM_FILM_4096_3112_24            (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_24)
04277 #define GS_SIGFORM_FILM_4096_3112_24X           (GS_SIGFORMSIZE_4096x3112 | GS_SIGFORMTYPE_PROGRESSIVE | GS_SIGFORMFRAMERATE_23_98)
04278
04279
04281 #define GS_SIGFORM_CUSTOM                       0xFFFFFFFF
04282
04283 #define GS_SIGFORM_NOT_PRESENT          0xFFFFFFFF
04284
04288 #define GS_SIGFORM_SUPPORTS_NTSC        0x00000001
04289 #define GS_SIGFORM_SUPPORTS_PAL         0x00000002
04290 #define GS_SIGFORM_SUPPORTS_HR          0x00000004
04291 #define GS_SIGFORM_SUPPORTS_360         0x00000008
04292 #define GS_SIGFORM_SUPPORTS_720         0x00000010
04293 #define GS_SIGFORM_SUPPORTS_1035        0x00000020
04294 #define GS_SIGFORM_SUPPORTS_1080        0x00000040
04295 #define GS_SIGFORM_SUPPORTS_EXTRA8      0x00000080              // 728, 1044, 1088
04296 #define GS_SIGFORM_SUPPORTS_1536        0x00000100              // 2048x1536
04297 #define GS_SIGFORM_SUPPORTS_1556        0x00000200              // 2048x1556
04298 #define GS_SIGFORM_SUPPORTS_DCIN        0x00000400              // 2048x1080
04299 #define GS_SIGFORM_SUPPORTS_1400        0x00000800              // 1440x1050
04300 #define GS_SIGFORM_SUPPORTS_V480        0x00010000              // Vesa 640x480
04301 #define GS_SIGFORM_SUPPORTS_V600        0x00020000              // Vesa 800x600
04302 #define GS_SIGFORM_SUPPORTS_V768        0x00040000              // Vesa 1024x768
04303 #define GS_SIGFORM_SUPPORTS_V1024       0x00080000              // Vesa 1280x1024
04304 #define GS_SIGFORM_SUPPORTS_V1200       0x00100000              // Vesa 1600x1200
04305 #define GS_SIGFORM_SUPPORTS_V1600       0x00200000              // Vesa 1600x1200
04306 #define GS_SIGFORM_SUPPORTS_X2          0x20000000              // Vesa 1600x1200
04307 #define GS_SIGFORM_SUPPORTS_X3          0x40000000              // Vesa 1600x1200
04308 #define GS_SIGFORM_SUPPORTS_X4          0x80000000              // Vesa 1600x1200
04309
04310
04312 #define GS_COMPTYPE_SOFTWARE    0x00000001
04313
04314 #define GS_COMPTYPE_MJPEG               0x00000002
04315
04316 #define GS_COMPTYPE_WAVELET             0x00000008
04317
04318 #define GS_COMPTYPE_MPEG1               0x00000010
04319
04320 #define GS_COMPTYPE_MPEG2               0x00000020
04321
04322 #define GS_COMPTYPE_MPEG2I              0x00000040
04323
04324 #define GS_COMPTYPE_MPEG2IBP    0x00000080
04325
04326 #define GS_COMPTYPE_DV25                0x00000100              // DV25, DVCPRO. DVCPRO25
04327
04328 #define GS_COMPTYPE_DV50                0x00000200              // DV50, DVCPRO50
04329
04330 #define GS_COMPTYPE_DVSD                0x00000400              // Standard DV Bluebook, DVPRO, DVSD
04331
04332 #define GS_COMPTYPE_DV100               0x00000800
04333
04334 #define GS_COMPTYPE_UN8BIT              0x00001000
04335
04336 #define GS_COMPTYPE_UN10BIT             0x00002000
04337
04338 #define GS_COMPTYPE_HDPAN               0x00010000
04339
04340 #define GS_COMPTYPE_HDSONY              0x00020000
04341
04342 #define GS_COMPTYPE_BGRA_INVERT         0x00040000
04343
04344 #define GS_COMPTYPE_ARGB                0x00100000
04345
04346 #define GS_COMPTYPE_RGBA                0x00200000
04347
04348 #define GS_COMPTYPE_RGB                 0x00300000
04349
04350 #define GS_COMPTYPE_ABGR                0x00400000
04351
04352 #define GS_COMPTYPE_BGRA                0x00800000
04353
04354 #define GS_COMPTYPE_BGR                 0x00C00000
04355
04356 #define GS_COMPTYPE_YCRCB_422   0x01000000
04357
04358 #define GS_COMPTYPE_YCRCB_422A  0x02000000
04359
04360 #define GS_COMPTYPE_YCRCB_444   0x04000000
04361
04362 #define GS_COMPTYPE_YCRCB_444A  0x08000000
04363
04364 #define GS_COMPTYPE_YCRCB_422_STEREO 0x10000000
04365
04366 #define GS_COMPTYPE_YCRCB_420   0x20000000
04367
04371 #define GS_SUPFILE_AVI                  0x00000001
04372
04374 #define GS_SUPFILE_ODML                 0x00000002
04375
04377 #define GS_SUPFILE_QT                   0x00000004
04378
04380 #define GS_SUPFILE_OMFI                 0x00000008
04381
04383 #define GS_SUPFILE_FIX                  0x00000100
04384
04386 #define GS_SUPFILE_AUDONLY              0x00010000
04387
04389 #define GS_SUPFILE_STILLS               0x00100000
04390
04392 #define GS_SUPFILE_UNK                  0x40000000
04393
04395 #define GS_SUPFILE_ANY                  0x80000000
04396
04398
04399 #define GS_PBEE_AUTO                    0x00000000
04400
04401 #define GS_PBEE_PB                              0x00000001
04402
04403 #define GS_PBEE_DEFAULT                 0x000000FF
04404
04406 #define GS_SERVOREF_AUTO                0x00000000
04407
04408 #define GS_SERVOREF_EXT                 0x00000001
04409
04410 #define GS_SERVOREF_DEFAULT             0x000000FF
04411
04413 #define GS_HEADSEL_RECPLAY              0x00000000
04414
04415 #define GS_HEADSEL_PLAY                 0x00000001
04416
04417 #define GS_HEADSEL_DEFAULT              0x000000FF
04418
04420 #define GS_CLRFRM_2FLD                  0x00000000
04421
04422 #define GS_CLRFRM_4FLD                  0x00000001
04423
04424 #define GS_CLRFRM_8FLD                  0x00000002
04425
04426 #define GS_CLRFRM_DEFAULT               0x000000FF
04427
04429 #define GS_VIDREF_DISABLE               0x00000000
04430
04431 #define GS_VIDREF_ENABLE                0x00000001
04432
04434 #define GS_CHANCAP_PLAY                 0x00000001
04435
04436 #define GS_CHANCAP_REVPLAY              0x00000002
04437
04438 #define GS_CHANCAP_PAUSE                0x00000004
04439
04440 #define GS_CHANCAP_JOG                  0x00000008
04441
04442 #define GS_CHANCAP_SHUTTLE              0x00000010
04443
04444 #define GS_CHANCAP_SEEK                 0x00000020
04445
04446 #define GS_CHANCAP_PREVIEW              0x00000040
04447
04448 #define GS_CHANCAP_STOP                 0x00001000
04449
04450 #define GS_CHANCAP_ETOE                 0x00002000
04451
04452 #define GS_CHANCAP_RECORD               0x00004000
04453
04454 #define GS_CHANCAP_EDIT                 0x00008000
04455
04456 #define GS_CHANCAP_RECSTOP              0x00010000
04457
04458 #define GS_CHANCAP_SELECTPRESET 0x00020000
04459
04460 #define GS_CHANCAP_EJECT                0x00040000
04461
04462 #define GS_CHANCAP_LOOP                 0x00100000
04463
04464 #define GS_CHANCAP_VGAPREVIEW   0x00200000
04465
04466 #define GS_CHANCAP_AUDPREVIEW   0x00200000
04467
04468 #define GS_CHANCAP_FILE                 0x01000000
04469
04470 #define GS_CHANCAP_NET                  0x02000000
04471
04472 #define GS_CHANCAP_CLIPSPACE    0x10000000
04473
04474 #define GS_CHANCAP_TCSPACE              0x20000000
04477 #define GS_CHANCAP_MPEG_ENC             0x40000000
04478
04479 #define GS_CHANCAP_ERROR                0x80000000
04480
04481 #define GS_CHANCAP_ALL                  0x3FFFFFFF
04482
04483 #define GS_PROXYMODE_NOTHING            0x000000
04484 #define GS_PROXYMODE_EVERYTHING         0x000002
04485 #define GS_PROXYMODE_RECORD                     0x000001
04486 #define GS_PROXYMODE_AFTERRECORD        0x000010
04487
04489 #define GS_NOT_SUPPORTED 0xFFFFFFFF
04490
04494 #define GS_BAD_PARAM     0xFFFFFFFE
04495
04498 #define GS_FALSE        0x00
04499
04502 #define GS_TRUE         0x01
04503
04506 #define GS_DISABLE      0x00
04507
04510 #define GS_ENABLE       0x01
04511
04514 #define GS_DEFAULT      0xFF    /* Default set by user on device */
04515
04516 #define GS_FIELD        0x00    /* Frame or Field one (gs dependant) */
04517
04518 #define GS_FIELD1       0x01    /* Field 1 - norm editing / single (1) freeze */
04519
04520 #define GS_FIELD2       0x02    /* Field 2 - off editing / single (2) freeze */
04521
04522 #define GS_FRAME        0x03    /* Freeze frame */
04523
04524 #define GS_UNITY         0xFFFFFFFF
04525
04526
04527 #define GS_ALPHACHROMA_SINGLE   0x01
04528 #define GS_ALPHACHROMA_ALPHA    0x02
04529 #define GS_ALPHACHROMA_DUAL             0x04
04530
04531 #define GS_BITCOUNT_8                   0x01
04532 #define GS_BITCOUNT_10                  0x02
04533 #define GS_BITCOUNT_24                  0x04
04534 #define GS_BITCOUNT_30                  0x08
04535 #define GS_BITCOUNT_32                  0x10
04536 #define GS_BITCOUNT_12                  0x20    /* 4:2:0 */
04537 // This is used to send a command to the system from any driver
04538 // Also used for returning current state
04539 // e.g. RS-422, RS-232, Keyboard, User Interface, etc.
04540 #pragma pack(4)
04541 typedef struct /*tagCMD_QUEUE_ELEM*/ {
04542         // NOTE:  Must match D_LNODE
04543 #ifndef __midl
04544
04545    void * pPrev;        // Next lnode
04547    void * pNext;        // Prev lnode
04549    void * pList;        // Parent or List owner
04550 #else
04551    DWORD pPrev, pNext, pList;
04552 #endif
04553
04557         DWORD           dwCmdID;
04566         DWORD           dwStructSize;
04573         DWORD           dwChannel;              //
04581         enum cmdType ctCmd;                     // The command - enum added for ansi 'C' compiles
04590         DWORD           cfFlags;                // Command flags
04615         LONG            lSpeed;                 // '-'Reverse '0'pause '+'forward
04624         DWORD           dwVideoChannels;// Video channels the cmd involves
04633         DWORD           dwAudioChannels;// Audio channels the cmd involves
04638         DWORD           dwInfoChannels; // Info channels the cmd involves
04648         DWORD           dwCmdAlt;               // Time delay, alternate channel
04654         DWORD           dwPosition;             // Current or third edit point position
04660         DWORD           dwStart;                // Command start point in frames,
04666         DWORD           dwEnd;                  // Command end point (exclusive) in frames
04675         BYTE            arbID[CMD_MAX_CLIP_ID_LEN+2+2]; // Odetics/Louth Identifier
04676 } MEDIACMD, *PMEDIACMD;
04677
04679 #define CmdQueueElem MEDIACMD
04680
04681 #define pCmdQueueElem PMEDIACMD
04682
04684 #define DECLARE_MEDIACMD(__mCmd_) MEDIACMD __mCmd_ =    \
04685         {NULL, NULL, NULL,                                                                      \
04686         MEDIACMD_CURRENT, (DWORD)sizeof(MEDIACMD), CHAN_ILLEGAL,        \
04687         ctPause, 0UL, SPD_ILLEGAL,                                                      \
04688         (DWORD)vidChanAll, (DWORD)audChanAll,                           \
04689         (DWORD)infChanAll, (DWORD)gsNextClip,                           \
04690         (DWORD)TC_ILLEGAL, (DWORD)TC_ILLEGAL, (DWORD)TC_ILLEGAL,        \
04691         {0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,        \
04692         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04693         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04694         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04695         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04696         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04697         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04698         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04699                                                                                                                 \
04700         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04701         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04702         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04703         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04704         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04705         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04706         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,         \
04707         0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,            \
04708         }};
04709
04710 #ifdef _WIN32
04711
04712 #define INIT_MEDIACMD(__mCmd_)  {                                               \
04713         ZeroMemory(&__mCmd_, sizeof(MEDIACMD));                         \
04714         __mCmd_.dwCmdID = MEDIACMD_CURRENT;                                     \
04715         __mCmd_.dwStructSize = sizeof(MEDIACMD);                        \
04716         __mCmd_.dwChannel = CHAN_ILLEGAL;                                       \
04717         __mCmd_.lSpeed = SPD_ILLEGAL;                                           \
04718         __mCmd_.dwVideoChannels = (DWORD)vidChanAll;            \
04719         __mCmd_.dwAudioChannels = (DWORD)audChanAll;            \
04720         __mCmd_.dwInfoChannels = (DWORD)infChanAll;                     \
04721         __mCmd_.dwCmdAlt = 0;                                                           \
04722         __mCmd_.dwPosition = TC_ILLEGAL;                                        \
04723         __mCmd_.dwStart = TC_ILLEGAL;                                           \
04724         __mCmd_.dwEnd = TC_ILLEGAL;     }
04725 #else
04726 #define INIT_MEDIACMD(__mCmd_)  {                                               \
04727         memset(&__mCmd_,0, sizeof(MEDIACMD));                           \
04728         __mCmd_.dwCmdID = MEDIACMD_CURRENT;                                     \
04729         __mCmd_.dwStructSize = sizeof(MEDIACMD);                        \
04730         __mCmd_.dwChannel = CHAN_ILLEGAL;                                       \
04731         __mCmd_.lSpeed = SPD_ILLEGAL;                                           \
04732         __mCmd_.dwVideoChannels = (DWORD)vidChanAll;            \
04733         __mCmd_.dwAudioChannels = (DWORD)audChanAll;            \
04734         __mCmd_.dwInfoChannels = (DWORD)infChanAll;                     \
04735         __mCmd_.dwCmdAlt = 0;                                                           \
04736         __mCmd_.dwPosition = TC_ILLEGAL;                                        \
04737         __mCmd_.dwStart = TC_ILLEGAL;                                           \
04738         __mCmd_.dwEnd = TC_ILLEGAL;     }
04739 #endif
04740
04741 #ifdef _WIN32
04742 #define INIT_PMEDIACMD(__mCmd_) {                                                       \
04743         ZeroMemory(__mCmd_, sizeof(MEDIACMD));                                  \
04744         ((PMEDIACMD)__mCmd_)->dwCmdID = MEDIACMD_CURRENT;               \
04745         ((PMEDIACMD)__mCmd_)->dwStructSize = sizeof(MEDIACMD);  \
04746         ((PMEDIACMD)__mCmd_)->dwChannel = CHAN_ILLEGAL;                 \
04747         ((PMEDIACMD)__mCmd_)->lSpeed = SPD_ILLEGAL;                             \
04748         ((PMEDIACMD)__mCmd_)->dwVideoChannels = (DWORD)vidChanAll;              \
04749         ((PMEDIACMD)__mCmd_)->dwAudioChannels = (DWORD)audChanAll;              \
04750         ((PMEDIACMD)__mCmd_)->dwInfoChannels = (DWORD)infChanAll;               \
04751         ((PMEDIACMD)__mCmd_)->dwCmdAlt = CHAN_ILLEGAL;                  \
04752         ((PMEDIACMD)__mCmd_)->dwPosition = TC_ILLEGAL;                  \
04753         ((PMEDIACMD)__mCmd_)->dwStart = TC_ILLEGAL;                             \
04754         ((PMEDIACMD)__mCmd_)->dwEnd = TC_ILLEGAL;       }
04755 #else
04756 #define INIT_PMEDIACMD(__mCmd_) {                                                       \
04757         memset(__mCmd_, 0,sizeof(MEDIACMD));                                    \
04758         ((PMEDIACMD)__mCmd_)->dwCmdID = MEDIACMD_CURRENT;               \
04759         ((PMEDIACMD)__mCmd_)->dwStructSize = sizeof(MEDIACMD);  \
04760         ((PMEDIACMD)__mCmd_)->dwChannel = CHAN_ILLEGAL;                 \
04761         ((PMEDIACMD)__mCmd_)->lSpeed = SPD_ILLEGAL;                             \
04762         ((PMEDIACMD)__mCmd_)->dwVideoChannels = (DWORD)vidChanAll;              \
04763         ((PMEDIACMD)__mCmd_)->dwAudioChannels = (DWORD)audChanAll;              \
04764         ((PMEDIACMD)__mCmd_)->dwInfoChannels = (DWORD)infChanAll;               \
04765         ((PMEDIACMD)__mCmd_)->dwCmdAlt = CHAN_ILLEGAL;                  \
04766         ((PMEDIACMD)__mCmd_)->dwPosition = TC_ILLEGAL;                  \
04767         ((PMEDIACMD)__mCmd_)->dwStart = TC_ILLEGAL;                             \
04768         ((PMEDIACMD)__mCmd_)->dwEnd = TC_ILLEGAL;       }
04769 #endif
04770
04771
04772 #pragma pack()
04773
04775 #define CMD_QUEUE_ELEMSIZE ((size_t)(&((pCmdQueueElem)(0))->arbID[0]))
04776
04777 #define SIZEOF_MEDIACMD_BASE CMD_QUEUE_ELEMSIZE
04778
04779 #define SIZEOF_MEDIACMD_CLIPID (CMD_QUEUE_ELEMSIZE + 9)
04780
04781 #define SIZEOF_MEDIACMD sizeof(MEDIACMD)
04782
05174 #endif //_MEDIACMD_INCLUDED_H
Generated on Wed May 17 15:52:30 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: timecode.h Source File

  • File List
  • Globals

timecode.h

Go to the documentation of this file.
00001
00002 //
00003 // TimeCode.h
00004 //
00006
00007 #ifndef _TIMECODE_DJKLSA7823dsjgfdEDSMKLCWXWCTO_H_INCLUDED
00008 #define _TIMECODE_DJKLSA7823dsjgfdEDSMKLCWXWCTO_H_INCLUDED
00009
00010 #ifdef __cplusplus
00011 extern "C" {          // PREVENT C++ NAME-MANGLING
00012 #endif
00013
00016 #define TC2_MIN_STRING_SIZE     14
00017
00018 // The following values are used in dwFlags
00020 #define TC2_TCTYPE_MASK         0x000000FF
00021
00022 #define TC2_TCTYPE_FILM         0x00000001      // 24 fps
00023 #define TC2_MARK_FILM           '-'
00024 #define TC2_CHAR_FILM           'F'
00025
00026 #define TC2_TCTYPE_NDF          0x00000002      // NTSC Non Drop Frame
00027 #define TC2_MARK_NDF            ':'
00028 #define TC2_CHAR_NDF            'N'
00029
00030 #define TC2_TCTYPE_DF           0x00000004      // NTSC Drop Frame
00031 #define TC2_MARK_DF                     ';'
00032 #define TC2_CHAR_DF                     'D'
00033
00034 #define TC2_TCTYPE_PAL          0x00000008      // PAL
00035 #define TC2_MARK_PAL            '.'
00036 #define TC2_CHAR_PAL            'P'
00037
00038 #define TC2_TCTYPE_50           0x00000010      // PAL 720p (double rate)
00039 #define TC2_MARK_50                     0x27            // its the '
00040 #define TC2_CHAR_50                     'p'
00041
00042 #define TC2_TCTYPE_5994         0x00000020      // NTSC 59.94fps 720p (NTSC DF double)
00043 #define TC2_MARK_5994           ','
00044 #define TC2_CHAR_5994           'd'
00045
00046 #define TC2_TCTYPE_60           0x00000040      // NTSC 60fps 720p (NTSC NDF double)
00047 #define TC2_MARK_60                     '='
00048 #define TC2_CHAR_60                     'n'
00049
00050 #define TC2_TCTYPE_NTSCFILM     0x00000080      // NTSC FILM 23.98
00051 #define TC2_MARK_NTSCFILM       '_'
00052 #define TC2_CHAR_NTSCFILM       'f'
00053
00054 #define TC2_TCTYPE_2398         0x00000084      // TRUE 23.98
00055 #define TC2_MARK_2398           '+'
00056 #define TC2_CHAR_2398           't'
00057
00058 #define TC2_TCTYPE_100          0x00000044      // Hours:Minutes:Seconds:Hundreds
00059 #define TC2_MARK_100            '^'
00060 #define TC2_CHAR_100            '0'
00061
00063 #define TC2_FTYPE_FIELD         0x10000000      // Field based (else frame)
00064
00066 #define TC2_STRTYPE_MASK                        0x00000F00
00067
00068 #define TC2_STRTYPE_ASCII                       0x00000100      // Std ascii string
00069
00070 #define TC2_STRTYPE_BCD                         0x00000200      // RS-422 BCD or Packed DWORD
00071
00072 #define TC2_STRTYPE_HEX                         0x00000400      // Hex packed DWORD
00073
00074 #define TC2_STRTYPE_GOP                         0x00000800      // MPEG Gop TC
00075
00076 #define TC2_STRTYPE_INVERT                      0x00001000      // Frames first
00077
00078 #define TC2_STRTYPE_OVER_24_HOUR        0x00002000
00079
00081 #define TC2_STREXT_MASK         0xFFFF0000
00082
00083 #define TC2_STREXT_MARKS        0x00010000      // Add : marks in string
00084
00085 #define TC2_STREXT_LEADING      0x00020000      // Include leading 0s
00086
00087 #define TC2_STREXT_TYPE         0x00040000      // Add ' N', ' D', ' P' or ' F' at end
00088
00089 #define TC2_STREXT_ALLCOLON     0x00080000      // No -.; just :
00090
00091 #define TC2_STREXT_FLAG         0x00100000      // Add DF Flag in BCD
00092
00093 #define TC2_STREXT_CF           0x00200000      // Add CF Flag in BCD
00094
00095 #define TC2_STREXT_MAX30        0x00400000      // Max 29 frames for output (24 in PAL)
00096
00097 #define TC2_STREXT_REVERSE      0x00800000      // Otherwise forward (default)
00098
00099 #define TC2_STREXT_ISBSTR       0x01000000      // Strings are BSTR (vb mostly)
00100
00101 #define TC2_STREXT_SHIFT7       0x40000000      // GOP Tc is shifted in DWORD
00102
00103 #define TC2_STREXT_SAVEBITS     0x80000000      // GOP Save unused bits
00104
00105 // Time code conversion macros (note: preserve drop frame flag)
00106 // Not nec for TC2
00107 //  drop_flag = input->getbits(1);
00108 //  hour = input->getbits(5);
00109 //  minute = input->getbits(6);
00110 //  input->flushbits(1);
00111 //  sec = input->getbits(6);
00112 //  frame = input->getbits(6);
00115 #define TC2_GOP25TC_TO_HEXINVERT(__dwGOP25Bit_) (((__dwGOP25Bit_ & 0xF80000) << 5) |    ((__dwGOP25Bit_ & 0x07E000) << 3) | ((__dwGOP25Bit_ & 0x000FC0) << 2) | (__dwGOP25Bit_ & 0x00003F));
00116
00119 #define TC2_GOP25TC_TO_HEXINVERT_ADD_DF(__dwGOP25Bit_) (__dwGOP25Bit_ | 0x20000000)
00120
00122 #define TC2_HEXINVERT_TO_GOP25TC(__dwHEXInvert_) (((__dwHEXInvert_ & 0x1F000000) >> 5) | ((__dwHEXInvert_ & 0x003F0000) >> 3) | ((__dwHEXInvert_ & 0x00003F00) >> 2) | (__dwHEXInvert_ & 0x000000003F) | 0x01001000)
00123
00126 #define TC2_HEXINVERT_TO_GOP25TC_ADD_DF(__dwGOP25Bit_) (__dwGOP25Bit_ | 0x1000000)
00127
00128 // The activex interface does not require these
00129 // prototypes as it uses the methods of the control
00130 // to to the same work
00131 #ifndef ACTIVEX_VERSION
00132
00134 #define TC2_ILLEGAL                     0xFFFFFFFF      //
00135
00139 DWORD
00140 __stdcall tc2Maximum(DWORD dwFlags);
00141
00145 DWORD
00146 __stdcall tc2String(DWORD dwTcIn, DWORD dwFlags, LPSTR pszTcOut);
00147
00151 DWORD
00152 __stdcall tc2Frame(LPSTR pszTcIn, DWORD dwFlags, DWORD * pdwTcOut);
00153
00157 DWORD
00158 __stdcall ub2String(DWORD dwUbIn, DWORD dwFlags, LPSTR pszUbOut);
00159
00163 DWORD
00164 __stdcall ub2Value(LPSTR pszUbIn, DWORD dwFlags, DWORD * pdwUbOut);
00165
00166 #endif  //ndef ACTIVEX_VERSION
00167
00168 #ifdef __cplusplus
00169 }
00170 #endif
00171
00172 #endif//ndef _TIMECODE_DJKLSA7823dsjgfdEDSMKLCWXWCTO_H_INCLUDED
Generated on Wed May 17 15:52:30 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: vvw.h Source File

  • File List
  • Globals

vvw.h

Go to the documentation of this file.
00001 /*******************************************************************
00002  * $Header: /Ass/Modules/vvw/vvwIF.h 1     2/08/01 9:26p James $
00003  *
00004  * $Workfile: vvwIF.h $
00005  * $Author: James $
00006  * $Revision: 1 $
00007  * $Archive: /Ass/Modules/vvw/vvwIF.h $
00008  *
00009  * Copyright (C) 1998 Drastic Technologies Ltd. All Rights Reserved.
00010  * 12 Drummond St. Unit 3, Toronto, ON, M8V 1Y8 (416) 255 5636
00011  * engineering@drastictech.com      http://www.drastictech.com
00012  *
00013  ******************************************************************/
00014
00015 #if !defined(_VVW_H_MAINHEADER_INCLUDED)
00016 #define _VVW_H_MAINHEADER_INCLUDED
00017
00018 #if !defined(BUILDING_VVW_DLL) && !defined(BUILDING_DRASTIC_DLL)
00019         #if!defined(__STATICLINK) && !defined(_NO_DRASTIC_LIBS)
00020                 #pragma comment(lib, "vvw.lib")
00021         #endif
00022 #endif
00023
00024
00030 void * __stdcall vvwChannelToHandle(long lChannel);
00031
00037 long __stdcall vvwHandleToChannel(void * hVvw);
00038
00042 long __stdcall vvwEnableChannels(long lInternal0_31,
00043                                                                  long lInternal32_63,
00044                                                                  long lExternal64_95,
00045                                                                  long lExternal96_127,
00046                                                                  long lNetwork128_159,
00047                                                                  long lNetwork160_191);
00051 long __stdcall vvwReleaseChannels(void);
00055 long __stdcall vvwGetMaxChannels(void);
00056
00060 long __stdcall vvwGetChannelName(long lChannel, char * szChannelName);
00061
00069 long __stdcall vvwGetChannelType(long lChannel);
00070
00074 long __stdcall vvwShowConfigDialog(long lChannel, long hWnd);
00075
00076 //
00077 // Transport
00078 //
00079
00084 long __stdcall vvwPlay(long lChannel);
00085
00090 long __stdcall vvwPlayAtSpeed(long lChannel, long lVVWSpeed);
00091
00098 long __stdcall vvwPlayFromTo(long lChannel, long lFrom, long lTo, BOOL fDeferred);
00099
00104 long __stdcall vvwLoadClip(long lChannel, char * sz8CharClipName, long lStartFrame);
00105
00110 long __stdcall vvwPlayClip(long lChannel, char * sz8CharClipName, BOOL fDeferred);
00111
00116 long __stdcall vvwPlayClipFromTo(long lChannel, char * sz8CharClipName, long lFrom, long lTo, BOOL fDeferred);
00117
00122 long __stdcall vvwFastForward(long lChannel);
00123
00128 long __stdcall vvwFastRewind(long lChannel);
00129
00134 long __stdcall vvwPause(long lChannel);
00135
00140 long __stdcall vvwSeek(long lChannel, long lFrame);
00141
00145 long __stdcall vvwSeekRelative(long lChannel, long lFrameOffset);
00146
00151 long __stdcall vvwStop(long lChannel);
00152
00157 long __stdcall vvwRecord(long lChannel);
00158
00163 long __stdcall vvwRecordFromTo(long lChannel, long lFrom, long lTo);
00164
00169 long __stdcall vvwRecordStop(long lChannel, char * sz8CharClipName, long lDuration);
00170
00175 long __stdcall vvwSetRecordPresets(long lChannel, long lVidEdit, long lAudEdit, long lInfEdit);
00176
00181 long __stdcall vvwEject(long lChannel);
00182
00186 long __stdcall vvwMediaCmd(long lChannel, void * pMediaCmd);
00187
00188 //
00189 // Special Commands (lChannel must be vtr type, lTargetChannel must be internal type)
00190 //
00195 long __stdcall vvwTransfer(long lChannel, long lTargetChannel, long lPosition, long lStart, long lEnd, long lVidEdit, long lAudEdit, long lInfEdit, char * szClipName, BOOL fToTape);
00196
00201 long __stdcall vvwUpdateStatus(long lChannel);
00202
00215 long __stdcall vvwGetState(long lChannel);
00216
00248 long __stdcall vvwGetFlags(long lChannel);
00249
00268 long __stdcall vvwGetSpeed(long lChannel);
00269
00273 long __stdcall vvwGetPosition(long lChannel);
00274
00278 long __stdcall vvwGetLastMs(long lChannel);
00279
00283 long __stdcall vvwGetStart(long lChannel);
00284
00288 long __stdcall vvwGetEnd(long lChannel);
00289
00293 long __stdcall vvwGetClipName(long lChannel, char * sz8CharClipName);
00294
00298 long __stdcall vvwGetFileName(long lChannel, char * sz260CharFileName);
00299
00303 long __stdcall vvwGetCurTC(long lChannel, char * sz14ByteTC);
00304
00308 long __stdcall vvwGetCurState(long lChannel, char * sz14ByteState);
00309
00310 //
00311 // Media Operation
00312 //
00313
00314 // Clip Mode
00319 char * __stdcall vvwGetNextClip(long lChannel, char * sz8CharLastClipCurClip);
00320
00325 long __stdcall vvwGetClipInfo (long lChannel, char * sz8CharClipName, long * lStart, long * lEnd, long * lVidEdit, long * lAudEdit, long * lInfEdit, char * szFileName);
00326
00330 long __stdcall vvwGetNextClipEx (long lChannel, char * sz8CharClipName, long * lCreation, long * lLastModification, long * lFileSize, long * lDiskFragments);
00331
00336 long __stdcall vvwCopyClip (long lChannel, char * szSourceClip, char * szDestClip, long lStart, long lEnd);
00337
00338 // VTR Mode
00342 long __stdcall vvwEDLResetToStart(long lChannel);
00343
00348 long __stdcall vvwEDLGetEdit (long lChannel, long * lRecordIn, long * lPlayIn, long * lPlayOut, long * lVidEdit, long * lAudEdit, long * lInfEdit, char * sz8CharClipName, char * sz260CharFileName);
00349
00350
00351
00352 // Shared
00356 long __stdcall vvwGetLastChangeXferMs(long lChannel);
00360 long __stdcall vvwGetLastChangeMs(long lChannel);
00361
00364 long __stdcall vvwInsert (long lChannel, char * szClipName, char * szFileName, long lPosition, long lStart, long lEnd, long lVidEdit, long lAudEdit, long lInfEdit, BOOL fRipple);
00365
00368 long __stdcall vvwBlank (long lChannel, char * szClipName, long lStart, long lEnd, long lVidEdit, long lAudEdit, long lInfEdit, BOOL fRipple);
00369
00372 long __stdcall vvwDelete (long lChannel, char * szClipName, long lStart, long lEnd, long lVidEdit, long lAudEdit, long lInfEdit, BOOL fRipple);
00373
00376 long __stdcall vvwTrim (long lChannel, long lPosition, long lStartOffset, long lEndOffset, long lVidEdit, long lAudEdit, long lInfEdit, BOOL fRipple);
00377
00378 //
00379 // Settings
00380 //
00384 long __stdcall vvwValueSupported(long lChannel, long lValueType);
00385
00389 long __stdcall vvwValueGet(long lChannel, long lValueType, long * plMin, long * plMax);
00390
00394 long __stdcall vvwValueSet(long lChannel, long lValueType, long lSetting);
00395
00399 long __stdcall vvwValueSet2(long lChannel, long lValueType, long lSetting, long lStart, long lEnd, long lVidChan, long lAudChan, long lInfChan);
00400
00404 long __stdcall vvwGetClipMode(long lChannel);
00408 long __stdcall vvwSetClipMode(long lChannel, long lSetting);
00409
00414 long __stdcall vvwGetTCType(long lChannel);
00419 long __stdcall vvwSetTCType(long lChannel, long lSetting);
00420
00425 long __stdcall vvwGetTCSource(long lChannel);
00430 long __stdcall vvwSetTCSource(long lChannel, long lSetting);
00431
00435 long __stdcall vvwGetAutoMode(long lChannel);
00439 long __stdcall vvwSetAutoMode(long lChannel, long lSetting);
00440
00445 long __stdcall vvwGetAvailablePresets(long lChannel, long * plVidEdit, long * plAudEdit, long * plInfEdit);
00446
00454 long __stdcall vvwGetAudioInput(long lChannel);
00462 long __stdcall vvwSetAudioInput(long lChannel, long lSetting);
00463
00467 long __stdcall vvwGetAudioInputLevel(long lChannel);
00471 long __stdcall vvwSetAudioInputLevel(long lChannel, long lSetting);
00472
00479 long __stdcall vvwGetAudioOutput(long lChannel);
00486 long __stdcall vvwSetAudioOutput(long lChannel, long lSetting);
00487
00491 long __stdcall vvwGetAudioOutputLevel(long lChannel);
00495 long __stdcall vvwSetAudioOutputLevel(long lChannel, long lSetting);
00496
00500 long __stdcall vvwGetAudioPeakRMS(long lChannel, long lAudEdit, long * plPeaks);
00501
00508 long __stdcall vvwGetVideoInput(long lChannel);
00515 long __stdcall vvwSetVideoInput(long lChannel, long lSetting);
00516
00523 long __stdcall vvwGetVideoOutput(long lChannel);
00530 long __stdcall vvwSetVideoOutput(long lChannel, long lSetting);
00531
00532
00536 long __stdcall vvwGetVideoInputSetup(long lChannel);
00540 long __stdcall vvwSetVideoInputSetup(long lChannel, long lSetting);
00544 long __stdcall vvwGetVideoInputVideo(long lChannel);
00548 long __stdcall vvwSetVideoInputVideo(long lChannel, long lSetting);
00552 long __stdcall vvwGetVideoInputHue(long lChannel);
00556 long __stdcall vvwSetVideoInputHue(long lChannel, long lSetting);
00560 long __stdcall vvwGetVideoInputChroma(long lChannel);
00564 long __stdcall vvwSetVideoInputChroma(long lChannel, long lSetting);
00565
00569 long __stdcall vvwGetVideoTBCSetup(long lChannel);
00573 long __stdcall vvwSetVideoTBCSetup(long lChannel, long lSetting);
00577 long __stdcall vvwGetVideoTBCVideo(long lChannel);
00581 long __stdcall vvwSetVideoTBCVideo(long lChannel, long lSetting);
00585 long __stdcall vvwGetVideoTBCHue(long lChannel);
00589 long __stdcall vvwSetVideoTBCHue(long lChannel, long lSetting);
00593 long __stdcall vvwGetVideoTBCChroma(long lChannel);
00597 long __stdcall vvwSetVideoTBCChroma(long lChannel, long lSetting);
00598
00602 long __stdcall vvwGetVideoGenlock(long lChannel);
00606 long __stdcall vvwSetVideoGenlock(long lChannel, long lSetting);
00607
00611 long __stdcall vvwGetVideoGenlockSource(long lChannel);
00615 long __stdcall vvwSetVideoGenlockSource(long lChannel, long lSetting);
00616
00620 long __stdcall vvwGetCompressionRate(long lChannel);
00624 long __stdcall vvwSetCompressionRate(long lChannel, long lSetting);
00625
00629 long __stdcall vvwGetSuperImpose(long lChannel);
00633 long __stdcall vvwSetSuperImpose(long lChannel, long lSetting);
00637 long __stdcall vvwGetErrorLogMs();
00641 long __stdcall vvwSetErrorLog(long lSetting);
00645 long __stdcall vvwGetErrorLength(long * plLastError, long * plErrorLength);
00649 long __stdcall vvwGetError(long * plLastError, long * plSeverity, char * szError);
00650
00654 long __stdcall vvwGetTotalTime(long lChannel);
00658 long __stdcall vvwGetFreeTime(long lChannel);
00662 long __stdcall vvwGetTotalStorage(long lChannel);
00666 long __stdcall vvwGetFreeStorage(long lChannel);
00667
00671 long __stdcall vvwGetCurMs(long lChannel);
00672
00676 long __stdcall vvwGetChannelCapabilities(long lChannel);
00677
00681 char * __stdcall vvwGetVVWVersion();
00682
00686 char * __stdcall vvwGetMRVersion();
00687
00691 char * __stdcall vvwGetVVWType(long lChannel);
00692
00696 long __stdcall vvwGetPiconName(char * szFileName);
00697
00698
00699 //
00700 // Utility
00701 //
00705 void __stdcall vvwFreeString(char * szString);
00706
00709 //------------------------------------------------------------------
00710
00713 //
00714 // OLD INTERNAL INTERFACE
00715 //
00716 // DO NOT USE
00717 //
00718 // EVERYTHING BELOW THIS COMMENT TO BE REMOVED
00719 //
00720 //------------------------------------------------------------------
00722 // A handle to a channel group
00723 //
00724 #if !defined(VVWHANDLE) // For internal
00725
00726 #define VVWHANDLE       DWORD
00727 #endif
00728
00730 // Standard function pointer typedefs
00731 //
00733 typedef DWORD (__stdcall * FCN_VVW_INIT)(void);
00735 typedef DWORD (__stdcall * FCN_VVW_START)(void);
00737 typedef DWORD (__stdcall * FCN_VVW_QUIT)(void);
00739 typedef DWORD (__stdcall * FCN_VVW_INIT_INT)(void);
00741 typedef VVWHANDLE (__stdcall * FCN_VVW_OPEN)(DWORD dwChannelIndex);
00743 typedef DWORD (__stdcall * FCN_VVW_CONFIGURE)(DWORD dwChannelIndex, HANDLE hWnd);
00745 typedef DWORD (__stdcall * FCN_VVW_CMD)(VVWHANDLE hVVW, PMEDIACMD pCmd);
00747 typedef DWORD (__stdcall * FCN_VVW_CLOSE)(VVWHANDLE hVVW);
00749 typedef DWORD (__stdcall * FCN_VVW_SETMEDIACMD)(void * pCtlRx, FCN_VVW_CMD pVvwCmd);
00750
00751 // Access functions exported from DLL
00752 #ifdef __cplusplus
00753 extern "C" {
00754 #endif
00755
00756 /* Global functions */
00757
00759
00764 DWORD __stdcall
00765 vvwInit(void);
00766
00768
00773 DWORD __stdcall
00774 vvwInitInt(void);
00775
00777
00781 DWORD __stdcall
00782 vvwStart(void);
00783
00785
00792 DWORD __stdcall
00793 vvwQuit(void);
00794
00795 /* Channel functions */
00796
00798
00801 VVWHANDLE __stdcall
00802 vvwOpen(DWORD dwChannelIndex);
00803
00805
00808 DWORD __stdcall
00809 vvwCmd(VVWHANDLE hVVW, PMEDIACMD pCmd);
00810
00812
00815 DWORD __stdcall
00816 vvwConfigure(DWORD dwChannelIndex, HANDLE hWnd);
00817
00819 // Close a previously opened VVW
00820 //
00821 DWORD __stdcall
00822 vvwClose(VVWHANDLE hVVW);
00823
00824
00825 //
00826 // Internal service calls and
00827 // Public service start stop
00828
00830 DWORD __stdcall
00831 __vvwInitService(void);
00832
00834 DWORD __stdcall
00835 __vvwQuitService(void);
00836
00838 DWORD __stdcall
00839 vvwStartService(void);
00840
00842 DWORD __stdcall
00843 vvwStopService(void);
00844
00846 DWORD __stdcall
00847 vvwSaveRegistry(char * szFileName);
00848
00850 DWORD __stdcall
00851 vvwSaveVVWRegistry(char * szFileName);
00852
00854 DWORD __stdcall
00855 vvwSaveWindowsRegistry(char * szFileName);
00856
00858 DWORD __stdcall
00859 vvwLoadRegistry(char * szFileName);
00860
00862 DWORD __stdcall
00863 vvvwLoadDefaultRegistry(void);
00864
00865 #ifdef __cplusplus
00866 }
00867 #endif
00868
00869 //
00870 // Pipe Network Name
00871 //
00872 #define _VVW_STANDARD_PIPE_NAME "vvwMediaCmd{7D682107-A9F6-40a2-9508-DC02CEF1AA9B}"
00873
00874 #endif
00875
Generated on Wed May 17 15:52:30 2006 for MediaCmd by doxygen 1.4.6-NO


MediaCmd: vvwtypes.h Source File

  • File List
  • Globals

vvwtypes.h

Go to the documentation of this file.
00001 /*******************************************************************
00002  * $Header: /Ass/inc/VvwTypes.h 57    5/23/01 2:04a Brooks $
00003  *
00004  * $Workfile: VvwTypes.h $
00005  * $Author: Brooks $
00006  * $Revision: 57 $
00007  * $Archive: /Ass/inc/VvwTypes.h $
00008  *
00009  * Copyright (C) 1998 Drastic Technologies Ltd. All Rights Reserved.
00010  * 12 Drummond St. Unit 3, Toronto, ON, M8V 1Y8 (416) 255 5636
00011  * engineering@drastictech.com      http://www.drastictech.com
00012  *
00013  ******************************************************************/
00014
00015 #if !defined(_VVW_TYPES_HAVE_ALREADY_BEEN_INCLUDED)
00016 #define _VVW_TYPES_HAVE_ALREADY_BEEN_INCLUDED
00017
00018 //#ifdef _lint
00019 //#include <windows.h>
00020 //#endif
00021
00022 // Windows x64
00023 #pragma warning(disable: 4996)  // deprecated security functions
00024
00025 #include "mediacmd.h"
00026
00039 //
00041
00042
00043 #define MB_FILE_EXT_LEN         200
00044
00045 #define MB_FILE_SHORT_LEN       64
00046
00047 #define MB_FILE_DESC_LEN        255
00048
00049 #define MB_CODEC_SHORT_LEN      64
00050
00051 #define MB_CODEC_DESC_LEN       255
00052
00053
00054 //
00064 #define DTVVW_PREVIEW   0x80000000
00065
00066 //
00067 // Some useful defines
00068 //
00070 #define VVW_INVALID_FRAME 0xFFFFFFFF
00071
00073 #define VVW_ABS_MAX_FRAME 10692000
00074
00076 #define _MAX_CLIP_NAME_SIZE     9
00077
00079
00085 #define _VVW_DSYNC_CHANNEL                      65536
00086
00089 #define _VVW_DSYNC_LTC_CHANNEL          _VVW_DSYNC_CHANNEL + 1
00090
00093 #define _VVW_CONTROL_START_LOCAL 0
00094
00099 #define _VVW_CONTROL_MAX_LOCAL  64U
00100
00105 #define _VVW_CONTROL_START_EXTERNAL _VVW_CONTROL_MAX_LOCAL
00106
00107 #define _VVW_CONTROL_MAX_EXTERNAL 64U
00108
00114 #define _VVW_CONTROL_START_NETWORK (_VVW_CONTROL_MAX_EXTERNAL + _VVW_CONTROL_MAX_EXTERNAL)
00115
00116 #define _VVW_CONTROL_MAX_NETWORK 128U
00117
00118 #define _VVW_CONTROL_MAX_CONTROL _VVW_CONTROL_MAX_LOCAL
00119
00120 #define _VVW_ABS_MAX_CHANNELS   256
00121
00122
00123
00124 // To match windows structures, we need to pack these things
00125 #ifdef _WIN32
00126 #include <pshpack1.h>
00127 #else
00128 #ifndef RC_INVOKED
00129 #pragma pack(1)
00130 #endif
00131 #endif
00132
00140 typedef struct {
00142         SHORT   left;
00144         SHORT   top;
00146         SHORT   right;
00148         SHORT   bottom;
00149 } RECT16;
00150
00151
00153
00160 typedef struct /*tagFRAME_INFO*/ {
00162         DWORD   dwFrame;
00164         DWORD   dwLtcFrame;
00166         DWORD   dwLtcUb;
00168         DWORD   dwVitcFrame;
00170         DWORD   dwVitcUb;
00176         DWORD   dwVitcAux;
00178 #define pFI_DataAreaPtr         dwVITCAux
00179
00182         DWORD   dwCCData;
00184 #define dwFI_DataAreaSize       dwCCData
00185 } FRAME_INFO, * pFRAME_INFO;
00186
00188
00200 typedef struct /*tagDRASTIC_CHANNEL*/
00201 {
00203         DWORD   dwLastUpdate;
00205         FRAME_INFO fi;
00207         MEDIACMD   mCmd;
00209         DWORD*  pdwFrame;
00211         void*   pOwnerHandle;
00213         DWORD   dwChannelID;            // Channel identifier
00214 } DRASTIC_CHANNEL, * pDRASTIC_CHANNEL;
00215
00217 #define DECLARE_DRASTIC_CHANNEL(__x_)   \
00218         { 0xFFFFFFFF, 0, 0, 0, 0, 0, 0, 0,                      \
00219         &__x_.dwFrame, 1, 3, ctStop, 0,         \
00220         0, 0xFFFFFFFF, &__x_, 0};
00221
00222 #define INIT_DRASTIC_CHANNEL(__x_)                                      \
00223         { ZeroMemory(&__x_, sizeof(DRASTIC_CHANNEL));   \
00224         __x_.pdwFrame = &__x_.dwFrame;                                  \
00225         __x_.ctCmd = ctStop;                                                    \
00226         __x_.pOwnerHandle = &__x_; };
00227
00228 #define INIT_PDRASTIC_CHANNEL(__x_)                                     \
00229         { ZeroMemory(__x_, sizeof(DRASTIC_CHANNEL));    \
00230         __x_->pdwFrame = &__x_->dwFrame;                                \
00231         __x_->ctCmd = ctStop;                                                   \
00232         __x_->pOwnerHandle = &__x_; };
00233
00235
00242 typedef struct /*tagDCLIP*/ {
00244         DWORD dwClipIn;
00246         DWORD dwClipOut;
00248         DWORD dwClipStart;
00250         DWORD dwClipEnd;
00252         DWORD dwClipAux;
00254         DWORD dwClipID;
00256         DWORD dwVidChan;
00258         DWORD dwAudChan;
00260         DWORD dwInfChan;
00262         char * szClipName;
00264         char * szName;
00266         char * szComment;
00268         char * szReel;
00269 } DCLIP, * PDCLIP;
00270
00273 #if 0 // commented out for docs !defined(__ICL) //|| defined(_NTDRIVER_)        // Intel compiler does not support base structures
00274 //: D_LNODE
00275 #endif
00278
00288 typedef struct /*tagDFRAME */
00289 {
00291         void* pPrev;    // Next lnode
00293         void* pNext;    // Prev lnode
00295         void* pList;    // Parent or List owner
00297         DWORD dwSize;
00305         DWORD dwType;
00307 #define DFRAME_TYPE_RECORD              0x00000001
00308
00309 #define DFRAME_TYPE_PLAY                0x00000002
00310
00311 #define DFRAME_TYPE_PAUSE               (0x00000004 | DFRAME_TYPE_PLAY) // Play + Pause
00312
00313 #define DFRAME_TYPE_NOTPHYSHEAP 0x00001000
00314
00315 #define DFRAME_TYPE_FI_PTR_DATA 0x00008000
00316
00317 #define DFRAME_TYPE_AUDIO               0x00010000
00318
00319 #define DFRAME_TYPE_VIDEO               0x00020000
00320
00321 #define DFRAME_PROGRESSIVE              0x00100000
00322
00323 #define DFRAME_FIELD_INVERT             0x00200000
00324
00325 #define DFRAME_TIME_INVERT              0x00400000
00326
00327 #define DFRAME_ORIENTATION_INVERT               0x00800000
00328
00329 #define DFRAME_LARGE_AUDIO      0x01000000
00330
00331 #define DFRAME_NEW_FORMAT               0x08000000
00332
00333 #define DFRAME_TYPE_KEYFRAME    0x10000000
00334
00335 #define DFRAME_TYPE_KEYFRAME_I  0x10000000
00336
00337 #define DFRAME_TYPE_KEYFRAME_P  0x00000000
00338
00339 #define DFRAME_TYPE_KEYFRAME_B  0x20000000
00340
00341 #define DFRAME_SKIP_FRAME               0x40000000
00342
00343         DWORD dwReps;
00345         FRAME_INFO fi;
00347         DWORD dwRepIndex;
00349         DWORD dwSpeed;
00351         DWORD dwExpireMS;
00353         DWORD dwPresentationMS;
00354
00362         LPBYTE lpData;                  // Pointer to data buffer below
00370         DWORD dwBufferLength;   // Total length of buffer below
00375         DWORD dwBytesUsed;              // Bytes frame takes up in buffer below
00376                 // above - dwBytesRecorded - in WAVEHEADER
00377         // insert - dwTimeCaptured - for VIDEOHDR only
00379         DWORD dwUser;
00381 #define DTVHDR_DONE             0x00000001
00382
00383 #define DTVHDR_PREPARED 0x00000002
00384
00385 #define DTVHDR_INQUEUE  0x00000004
00386
00387 #define DTVHDR_KEYFRAME 0x00000008
00388         // Audio Flags
00390 #define DTWHDR_DONE             0x00000001
00391
00392 #define DTWHDR_PREPARED 0x00000002
00393
00394 #define DTWHDR_BEGINLOOP 0x00000004
00395
00396 #define DTWHDR_ENDLOOP  0x00000008
00397
00398 #define DTWHDR_INQUEUE  0x00000010
00399
00400 #define _PDFRAMEFLAGS_CLIPSTILL         0x00000001      // Only one buffer in clip
00401
00402 #define _PDFRAMEFLAGS_CLIPSTART         0x00000002      // Start of clip
00403
00404 #define _PDFRAMEFLAGS_CLIPEND           0x00000004      // End of clip
00405
00406 #define _PDFRAMEFLAGS_FIRSTFRAME        0x00000002      // Start of clip
00407
00408 #define _PDFRAMEFLAGS_LASTFRAME         0x00000004      // End of clip
00409
00418         DWORD dwFlags;                  // Internal
00420         DWORD dwReserved[4];    // Hardware specfic
00421                 // struct wavehdr_tag * lpNext - in WAVEHEADER
00422                 // reserved - in WAVEHEADER
00423         // End - taken from VIDEOHDR, WAVEHEADER
00425         WORD resdata;                   // Filler to 100 bytes
00426
00427 } DFRAME, * PDFRAME;
00428
00430 #define SIZEOFDFRAME    (((sizeof(DFRAME) >> 2) + 1) << 2)
00431
00434
00436 #define _VVWXXX_RESERVED_SIZE   256
00437
00438 #define _VVWXXX_NAME_SIZE               64
00439
00440
00442 //
00443 //      The system struct describes a file or harware system
00444 //      as basically as possible.  For more in depth information
00445 //      see the VVWAUDIO/VIDEO/INFO structs below.
00446 //
00447 // 03/13/98 Used By:
00448 //              Modules\AvHal
00449 //              Common\mfFile
00450
00452 #define _VVW_IS_VVWSYSTEM               0x0000
00453
00462 typedef struct /*tagVVWSYSTEM*/ {
00463         // Stolen from MainAVIHeader
00473         DWORD           dwMicroSecPerFrame;     // frame display rate (or 0L)
00479     DWORD               dwMaxBytesPerSec;       // max. transfer rate
00489         DWORD           dwPaddingGranularity;   // pad to multiples of this size; normally 2K.
00500     DWORD               dwFlags;                        // the ever-present flags AVIFILEINFO_
00508     DWORD               dwTotalFrames;          // # frames in file
00515     DWORD               dwInitialFrames;
00520     DWORD               dwStreams;
00528     DWORD               dwSuggestedBufferSize;
00532     DWORD               dwWidth;
00539     DWORD               dwHeight;
00543     DWORD               dwReserved[4];
00544         // End of MainAVIHeader
00545
00546         // Extras for AVIFILEINFO
00557         DWORD           dwCaps;                         // AVIFILECAPS_ . . .
00572         DWORD           dwScale;                        // dwRate/dwScale = samples per second
00587         DWORD           dwRate;                         // as above
00593         DWORD           dwLength;                       // Lendth of file in dwRate/dwScale units
00599         DWORD           dwEditCount;            // Number of streams added or deleted
00604         char            szFileType[_VVWXXX_NAME_SIZE];          // Descriptive info
00608         DWORD   dwType;                                 // MF_TYPE_, AVH_TYPE_
00612         DWORD   dwMfCaps;                               // MF_CAP_, AVH_CAP_
00616         DWORD   dwVidStandard;                  // Best guess at PAL,NTSC,etc
00626         DWORD dwDrFlags;
00628         DWORD dwFileType;
00632         DWORD dwResDrastic;
00633 } VVWSYSTEM, * pVVWSYSTEM;
00634
00635 // Macros       - See /Ass/Modules/MediaFile/Test Patterns/Test Patterns.cpp for "Compile Test"
00637 #define VVWSYS_SET(__pvvwsys_, __pvvwvid_, __pvvwaud_, _granularity, _frames) { \
00638         (__pvvwsys_)->dwMicroSecPerFrame = (DWORD)(1000000.0 / ((double)(__pvvwvid_)->dwRate / (double)(__pvvwvid_)->dwScale)); \
00639         (__pvvwsys_)->dwMaxBytesPerSec = ((__pvvwvid_)->biSizeImage * (__pvvwvid_)->dwScale / (__pvvwvid_)->dwRate) + (__pvvwaud_)->nAvgBytesPerSec;    \
00640         (__pvvwsys_)->dwPaddingGranularity = _granularity;      \
00641         (__pvvwsys_)->dwTotalFrames = _frames;  \
00642         (__pvvwsys_)->dwSuggestedBufferSize = (__pvvwvid_)->dwSuggestedBufferSize + (__pvvwaud_)->dwSuggestedBufferSize;        \
00643         (__pvvwsys_)->dwWidth = (__pvvwvid_)->biWidth;  \
00644         if((__pvvwvid_)->biHeight < 0) (__pvvwsys_)->dwHeight = -(long)(__pvvwvid_)->biHeight; else (__pvvwsys_)->dwHeight = (__pvvwvid_)->biHeight;    \
00645         (__pvvwsys_)->dwScale = (__pvvwvid_)->dwScale;  \
00646         (__pvvwsys_)->dwRate = (__pvvwvid_)->dwRate;    \
00647         (__pvvwsys_)->dwLength= (__pvvwvid_)->dwLength; \
00648         }
00649
00650 #define VVWSYS_SETVIDONLY(__pvvwsys_, __pvvwvid_, _granularity, _frames) {      \
00651         (__pvvwsys_)->dwMicroSecPerFrame = (DWORD)(1000000.0 / ((double)(__pvvwvid_)->dwRate / (double)(__pvvwvid_)->dwScale)); \
00652         (__pvvwsys_)->dwMaxBytesPerSec = ((__pvvwvid_)->biSizeImage * (__pvvwvid_)->dwScale / (__pvvwvid_)->dwRate);    \
00653         (__pvvwsys_)->dwPaddingGranularity = _granularity;      \
00654         (__pvvwsys_)->dwTotalFrames = _frames;  \
00655         (__pvvwsys_)->dwSuggestedBufferSize = (__pvvwvid_)->dwSuggestedBufferSize;      \
00656         (__pvvwsys_)->dwWidth = (__pvvwvid_)->biWidth;  \
00657         if((__pvvwvid_)->biHeight < 0) (__pvvwsys_)->dwHeight = -(long)(__pvvwvid_)->biHeight; else (__pvvwsys_)->dwHeight = (__pvvwvid_)->biHeight;    \
00658         (__pvvwsys_)->dwScale = (__pvvwvid_)->dwScale;  \
00659         (__pvvwsys_)->dwRate = (__pvvwvid_)->dwRate;    \
00660         (__pvvwsys_)->dwLength= (__pvvwvid_)->dwLength; \
00661         }
00662
00663 #define VVWSYS_SETAUDONLY(__pvvwsys_, __pvvwaud_, _granularity, _frames) {      \
00664         (__pvvwsys_)->dwMicroSecPerFrame = (DWORD)(1000000.0 / ((double)(__pvvwaud_)->dwRate / (double)(__pvvwaud_)->dwScale)); \
00665         (__pvvwsys_)->dwMaxBytesPerSec = (__pvvwaud_)->nAvgBytesPerSec; \
00666         (__pvvwsys_)->dwPaddingGranularity = _granularity;      \
00667         (__pvvwsys_)->dwTotalFrames = _frames;  \
00668         (__pvvwsys_)->dwSuggestedBufferSize = (__pvvwaud_)->dwSuggestedBufferSize;      \
00669         (__pvvwsys_)->dwWidth = 0;      \
00670         (__pvvwsys_)->dwHeight = 0;     \
00671         (__pvvwsys_)->dwScale = (__pvvwaud_)->dwScale;  \
00672         (__pvvwsys_)->dwRate = (__pvvwaud_)->dwRate;    \
00673         (__pvvwsys_)->dwLength= (__pvvwaud_)->dwLength; \
00674         }
00675
00676 #define VVWSYS_CLR(__pvvwsys_) {        \
00677         (__pvvwsys_)->dwFlags = 0;      \
00678         (__pvvwsys_)->dwInitialFrames = 0;      \
00679         (__pvvwsys_)->dwReserved[0] = 0;        \
00680         (__pvvwsys_)->dwReserved[1] = 0;        \
00681         (__pvvwsys_)->dwReserved[2] = 0;        \
00682         (__pvvwsys_)->dwReserved[3] = 0;        \
00683         (__pvvwsys_)->dwCaps = 0;       \
00684         (__pvvwsys_)->dwEditCount = 0;  \
00685         (__pvvwsys_)->dwType = 0;       \
00686         (__pvvwsys_)->dwMfCaps = 0;     \
00687         (__pvvwsys_)->dwVidStandard = 0;        \
00688         (__pvvwsys_)->dwDrFlags = 0;    \
00689         (__pvvwsys_)->dwResDrastic = 0; \
00690         }
00691
00692 // Macros (sample/len should work for all types)- See /Ass/Modules/MediaFile/Test Patterns/Test Patterns.cpp for "Compile Test"
00694 #define VVWXXX_SETSAMPLETOLENGTH(__pvvw_, _length) { (__pvvw_)->dwLength = _length * (__pvvw_)->dwScale; }
00695
00696 #define VVWXXX_GETSAMPLEFROMLENGTH(__pvvw_) ((__pvvw_)->dwLength / (__pvvw_)->dwScale)
00697
00699 //
00700 // The video structure provides basic information on the
00701 //      current video format of a channel either on the disk, on
00702 //      the network or in hardware.
00703 //
00704 // 03/13/98 Used By:
00705 //              Modules\AvHal
00706 //              Common\mfFile
00707 //
00709 #define _VVW_IS_VVWVIDEO                0x0010
00710
00718 typedef struct /*tagVVWVIDEO*/ {
00719         // First part is a BITMAPINFOHEADER
00721         DWORD      biSize;                                      // Size Of BITMAPINO + Used dwReserved
00723     LONG       biWidth;                                 // Width of bitmap
00725     LONG       biHeight;                                // Height of bitmap (ALWAYS Positive in VVW/MR)
00727     WORD       biPlanes;                                // Number of bitmaps (ALWAYS 1)
00729     WORD       biBitCount;                              // Bitcount (24 RGB, 16 YUV) (Alpha seperate)
00731     DWORD      biCompression;                   // Should be same as fccHandler
00733     DWORD      biSizeImage;                             // Size of bitmap (biPitch * biHeight) + Alpha
00735     LONG       biXPelsPerMeter;                 // Picture elements per meter
00737     LONG       biYPelsPerMeter;                 // Picture elements per meter
00739     DWORD      biClrUsed;                               // Number of pallette entries used in bitmap
00741     DWORD      biClrImportant;                  // Required entries to display bitmap
00826         DWORD   dwReserved[_VVWXXX_RESERVED_SIZE];      // Pallette or extended bitmap stucture per 98/NT/2K
00827         // End BITMAPINFOHEADER
00828
00829         // Second part is a AVIStreamHeader (AVISTREAMINFO)
00831     DWORD fccType;                                              // streamtypeVIDEO, streamtypeAUDIO, streamtypeMIDI, streamtypeTEXT
00833         DWORD fccHandler;                                       // Codec - should be same as biCompression
00834         /*
00835         * AVISTREAMINFO_ flags such as
00836         \code
00837         AVISTREAMINFO_DISABLED          0x00000001
00838         AVISTREAMINFO_FORMATCHANGES     0x00010000
00839         \endcode
00840         */
00841         DWORD dwFlags;                                          // Pos.  AVISTREAMINFO_FORMATCHANGES or AVISTREAMINFO_DISABLED
00843         DWORD dwCaps;                                           //
00845     WORD  wPriority;                                    //
00847         WORD  wLanguage;                                        //
00849         DWORD dwScale;                                          //  1001  100  1  1  - dwRate / dwScale == frame rate
00851         DWORD dwRate;                                           // 30000 2997 25 24
00857     DWORD dwStart;                                              // Starting sample per dwRate/dwScale
00861         DWORD dwLength;                                         // Length of stream per dwRate/dwScale
00867         DWORD dwInitialFrames;                          // Audio skew, how much startup audio in stream
00872     DWORD dwSuggestedBufferSize;                // Largest chunk in stream, internally one uncompressed frame
00878         DWORD dwQuality;                                        // Codec compression quality
00887         DWORD dwSampleSize;                                     // Largest single sample
00892         RECT/*16*/  rcFrame;                                    // Frame dimensions
00894         DWORD dwEditCount;                                      // Number of time stream has been edited
00896         DWORD dwFormatChangeCount;                      // Number of time format has been changed
00898     char  szName[_VVWXXX_NAME_SIZE];    // Stream identifier
00899         // End of AVIStreamHeader  (AVISTREAMINFO)
00900
00902         LONG biPitch;                                           // Normally biWidth * (biBitCount / 8) - Number of bytes in a row
00903 //
00904 // Check mask bits for free areas
00905 // note: fccmod depends on biCompression/fccHandler
00907 #define MASK___DRFLAGS_FIELD             0x00000001
00908
00909 #define DRFLAGS_ZERO_FIELD_DOMINANT  0x00000000
00910
00911 #define DRFLAGS_FIRST_FIELD_DOMINANT 0x00000001
00912
00913 #define DRFLAGS_NOT_QUICKCLIP           0x00000002
00914
00915 #define MASK___DRFLAGS_KEYFRAME          0x00000010
00916
00917 #define DRFLAGS_HAS_KEYFRAMES            0x00000010
00918
00919 #define MASK___DRFLAGS_VTYPE             0x00000700
00920
00921 #define DRFLAGS_VTYPE_INTERLACED         0x00000100
00922
00923 #define DRFLAGS_VTYPE_PROGRESSIVE        0x00000200
00924
00925 #define DRFLAGS_VTYPE_SEGMENTEDFRAME 0x00000400
00926
00927 #define MASK___FCCMODIFIERS                      0x00FF0000
00928
00929 #define DRFLAGS_FCC_MJPG_DIGISUITE       0x00000000     // resolve 'mjpg' types
00930
00931 #define DRFLAGS_FCC_MJPG_DCx0            0x00010000
00932
00933 #define DRFLAGS_FCC_MJPG_DSEDIT          0x00020000
00934
00935 #define DRFLAGS_FCC_MJPG_JPGDIB          0x00040000
00936
00937 #define DRFLAGS_FCC_MJPG_JFIF            0x00080000
00938
00939 #define DRFLAGS_FCC_USE_INTERN           0x00100000     // which codec dup to use
00940
00941 #define DRFLAGS_FCC_USE_QT                       0x00400000
00942
00943 #define DRFLAGS_FCC_USE_ICM                      0x00800000
00944
00945 #define MASK__CODECPRIVATEDATA           0x0F000000
00946
00947 #define DRFLAGS_CODECPRIVATEDATA_AVI 0x01000000         // Std AVI VVWVIDEO
00948
00949 #define DRFLAGS_CODECPRIVATEDATA_MOV 0x02000000         // ImageDesc in VVWVIDEO (as above)
00950
00951 #define DRFLAGS_CODECPRIVATEDATA_OMF 0x04000000         // OMF Util
00952
00953 #define MASK___PREVIEW                           0xF0000000
00954
00963         DWORD dwDrFlags;                                        // Our internal flags
00965         DWORD dwFileType;
00967         DWORD dwResDrastic;                                     // Always
00968
00969 } VVWVIDEO, * pVVWVIDEO;
00970
00971 // Macros - See /Ass/Modules/MediaFile/Test Patterns/Test Patterns.cpp for "Compile Test"
00973 #define VVWVID_PITCHALIGN1(__pvvwvid_)  { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+  7) / 8 ); }
00974
00975 #define VVWVID_PITCHALIGN4(__pvvwvid_)  { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+ 31) / 32) * 4; }
00976
00977 #define VVWVID_PITCHALIGN8(__pvvwvid_)  { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+ 63) / 64) * 8; }
00978
00979 #define VVWVID_PITCHALIGN16(__pvvwvid_) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+127) / 128) * 16; }
00980
00981 #define VVWVID_PITCHALIGNANY(__pvvwvid_, _align_1_4_8_16) { (__pvvwvid_)->biPitch = (((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount+((_align_1_4_8_16 * 8) - 1)) / (_align_1_4_8_16 * 8)) * _align_1_4_8_16; }
00982
00983 #define VVWVID_PITCHMODULO(__pvvwvid_) ((__pvvwvid_)->biPitch - ((__pvvwvid_)->biWidth * (__pvvwvid_)->biBitCount + 7) / 8)
00984
00985 #define VVWVID_SIZEIMAGE(__pvvwvid_) { if(!(__pvvwvid_)->biPitch) VVWVID_PITCHALIGN1((__pvvwvid_)); (__pvvwvid_)->biSizeImage = (__pvvwvid_)->biPitch * abs((__pvvwvid_)->biHeight); }
00986
00987 #define VVWVID_SUGGESTEDBUFFERSIZE(__pvvwvid_) { if(!(__pvvwvid_)->biPitch) VVWVID_PITCHALIGN1((__pvvwvid_)); (__pvvwvid_)->dwSuggestedBufferSize = (__pvvwvid_)->biPitch * (abs((__pvvwvid_)->biHeight) + (abs((__pvvwvid_)->biHeight) >> 2)); }
00988
00989 #define VVWVID_RATESCALE_NTSC_AVI(__pvvwvid_) { (__pvvwvid_)->dwScale = 1001; (__pvvwvid_)->dwRate = 30000; }
00990
00991 #define VVWVID_RATESCALE_NTSC(__pvvwvid_) { (__pvvwvid_)->dwScale = 100; (__pvvwvid_)->dwRate = 2997; }
00992
00993 #define VVWVID_RATESCALE_PAL(__pvvwvid_) { (__pvvwvid_)->dwScale = 1; (__pvvwvid_)->dwRate = 25; }
00994
00995 #define VVWVID_RATESCALE_FILM(__pvvwvid_) { (__pvvwvid_)->dwScale = 1; (__pvvwvid_)->dwRate = 24; }
00996
00997 #define VVWVID_SET(__pvvwvid_, _bitcount, _width, _height, _pitch_align_1_4_8_16, _fcccodec, _scale, _rate, _frames) {  \
00998         (__pvvwvid_)->biBitCount = _bitcount;   \
00999         if((long)_height < 0) { (__pvvwvid_)->biHeight = -(long)_height; } else { (__pvvwvid_)->biHeight = (long)_height; }     \
01000         (__pvvwvid_)->biWidth = _width; \
01001         (__pvvwvid_)->biCompression = _fcccodec;        \
01002         VVWVID_PITCHALIGNANY(__pvvwvid_, _pitch_align_1_4_8_16);        \
01003         VVWVID_SIZEIMAGE((__pvvwvid_)); \
01004         VVWVID_SUGGESTEDBUFFERSIZE((__pvvwvid_));       \
01005         (__pvvwvid_)->dwScale = _scale; (__pvvwvid_)->dwRate = _rate;   \
01006         VVWXXX_SETSAMPLETOLENGTH((__pvvwvid_), _frames);        \
01007         (__pvvwvid_)->fccHandler = (__pvvwvid_)->biCompression; \
01008         (__pvvwvid_)->rcFrame.top = 0;  \
01009         (__pvvwvid_)->rcFrame.bottom = abs((__pvvwvid_)->biHeight);     \
01010         (__pvvwvid_)->rcFrame.left = 0; \
01011         (__pvvwvid_)->rcFrame.right = (__pvvwvid_)->biWidth;    \
01012         }
01013
01014 #define VVWVID_SETCLR(__pvvwvid_, _bitcount, _width, _height, _pitch_align_1_4_8_16, _fcccodec, _scale, _rate, _frames) {       \
01015         VVWVID_SET((__pvvwvid_), _bitcount, _width, _height, _pitch_align_1_4_8_16, _fcccodec, _scale, _rate, _frames); \
01016         (__pvvwvid_)->biSize = sizeof(BITMAPINFOHEADER);        \
01017         (__pvvwvid_)->biPlanes = 1;     \
01018         (__pvvwvid_)->biXPelsPerMeter = 0;      \
01019         (__pvvwvid_)->biYPelsPerMeter = 0;      \
01020         (__pvvwvid_)->biClrUsed = 0;    \
01021         (__pvvwvid_)->biClrImportant = 0;       \
01022         ZeroMemory((__pvvwvid_)->dwReserved, _VVWXXX_RESERVED_SIZE);    \
01023         (__pvvwvid_)->fccType = streamtypeVIDEO;        \
01024         (__pvvwvid_)->dwFlags = 0;      \
01025         (__pvvwvid_)->dwCaps = 0;       \
01026         (__pvvwvid_)->wPriority = 0;    \
01027         (__pvvwvid_)->wLanguage = 0;    \
01028         (__pvvwvid_)->dwStart = 0;      \
01029         (__pvvwvid_)->dwInitialFrames = 0;      \
01030         (__pvvwvid_)->dwQuality = 0xFFFFFFFF;   \
01031         (__pvvwvid_)->dwSampleSize = 0; \
01032         (__pvvwvid_)->dwEditCount = 0;  \
01033         (__pvvwvid_)->dwFormatChangeCount = 0;  \
01034         ZeroMemory((__pvvwvid_)->szName, _VVWXXX_NAME_SIZE);    \
01035         (__pvvwvid_)->dwDrFlags = 0;    \
01036         (__pvvwvid_)->dwResDrastic = 0; \
01037         }
01038
01040 //
01041 // The audio structure provides basic information on the
01042 //      current audio format of a channel either on the disk, on
01043 //      the network or in hardware.
01044 //
01045 // 03/13/98 Used By:
01046 //              Modules\AvHal
01047 //              Common\mfFile
01048 //
01050 #define _VVW_IS_VVWAUDIO                0x0100
01051
01059 typedef struct /*tagVVWAUDIO*/ {
01061 #define DTWAVE_FORMAT_PCM     1
01062
01063     WORD        wFormatTag;                             /* format type (normally WAVE_FORMAT_PCM == 1) */
01065     WORD        nChannels;                              /* number of channels (i.e. mono=1, stereo=2...) */
01067     DWORD       nSamplesPerSec;                 /* sample rate (i.e. 44100, 48000. 22050) */
01069     DWORD       nAvgBytesPerSec;                /* for buffer estimation (nSamplesPerSec * nBlockAlign) */
01071     WORD        nBlockAlign;                    /* block size of data (nChannels + ((wBitsPerSample + 7) / 8)) */
01073     WORD        wBitsPerSample;                 /* number of bits per sample of mono data (Normally 8, 16, 20, 24 or 32) */
01075     WORD        cbSize;                                 /* the count in bytes of the size of */
01076                                     /* extra information (after cbSize) */
01078         DWORD   dwReserved[_VVWXXX_RESERVED_SIZE];      // Some drivers req more spave
01079         // End of WAVEFORMATEX
01080
01081         // Second part is a AVIStreamHeader (AVISTREAMINFO)
01083     DWORD fccType;                                              // streamtypeVIDEO, streamtypeAUDIO, streamtypeMIDI, streamtypeTEXT
01085         DWORD fccHandler;                                       // Codec - should be same as biCompression
01086         /*
01087         * AVISTREAMINFO_ flags such as
01088         \code
01089         AVISTREAMINFO_DISABLED          0x00000001
01090         AVISTREAMINFO_FORMATCHANGES     0x00010000
01091         \endcode
01092         */
01093         DWORD dwFlags;                                          // Pos.  AVISTREAMINFO_FORMATCHANGES or AVISTREAMINFO_DISABLED
01095         DWORD dwCaps;                                           //
01097     WORD  wPriority;                                    //
01099         WORD  wLanguage;                                        //
01101         DWORD dwScale;                                          //  1001  100  1  1  - dwRate / dwScale == frame rate
01103         DWORD dwRate;                                           // 30000 2997 25 24
01109     DWORD dwStart;                                              // Starting sample per dwRate/dwScale
01113         DWORD dwLength;                                         // Length of stream per dwRate/dwScale
01119         DWORD dwInitialFrames;                          // Audio skew, how much startup audio in stream
01124     DWORD dwSuggestedBufferSize;                // Largest chunk in stream, internally one uncompressed frame
01130         DWORD dwQuality;                                        // Codec compression quality
01139         DWORD dwSampleSize;                                     // Largest single sample
01144         RECT/*16*/  rcFrame;                                    // Frame dimensions
01146         DWORD dwEditCount;                                      // Number of time stream has been edited
01148         DWORD dwFormatChangeCount;                      // Number of time format has been changed
01150     char  szName[_VVWXXX_NAME_SIZE];    // Stream identifier
01151         // End of AVIStreamHeader  (AVISTREAMINFO)
01152
01154         LONG biUnused;                                          //
01162         DWORD dwDrFlags;                                        // Our internal flags
01164         DWORD dwFileType;
01166         DWORD dwResDrastic;                                     // Always
01167
01168 } VVWAUDIO, * pVVWAUDIO;
01169
01179 #define VVWAUD_RECALC(__pvvwaud_) {     \
01180         if((__pvvwaud_)->wFormatTag == DTWAVE_FORMAT_PCM) {     \
01181                 (__pvvwaud_)->nBlockAlign = ((__pvvwaud_)->nChannels * (((__pvvwaud_)->wBitsPerSample + 7) >> 3));      \
01182                 (__pvvwaud_)->nAvgBytesPerSec = (__pvvwaud_)->nBlockAlign * (__pvvwaud_)->nSamplesPerSec;       \
01183                 (__pvvwaud_)->dwSuggestedBufferSize = (__pvvwaud_)->nAvgBytesPerSec >> 1;       \
01184                 (__pvvwaud_)->dwSampleSize = (__pvvwaud_)->nBlockAlign; \
01185                 (__pvvwaud_)->dwScale = (__pvvwaud_)->nBlockAlign;      \
01186                 (__pvvwaud_)->dwRate = (__pvvwaud_)->nAvgBytesPerSec;   \
01187         }       \
01188         }
01189
01190 #define VVWAUD_SET(__pvvwaud_, _formattag, _channels, _samplespersec, _bitspersample, _samples) {       \
01191         (__pvvwaud_)->wFormatTag = _formattag;  \
01192         (__pvvwaud_)->fccHandler = _formattag;  \
01193         (__pvvwaud_)->nChannels = _channels;    \
01194         (__pvvwaud_)->nSamplesPerSec = _samplespersec;  \
01195         (__pvvwaud_)->wBitsPerSample = _bitspersample;  \
01196         (__pvvwaud_)->dwLength = _samples;      \
01197         VVWAUD_RECALC((__pvvwaud_));    \
01198         }
01199
01200 #define VVWAUD_SETCLR(__pvvwaud_, _formattag, _channels, _samplespersec, _bitspersample, _samples) {    \
01201         VVWAUD_SET((__pvvwaud_), _formattag, _channels, _samplespersec, _bitspersample, _samples); \
01202         ZeroMemory((__pvvwaud_)->dwReserved, _VVWXXX_RESERVED_SIZE);    \
01203         (__pvvwaud_)->fccType = streamtypeAUDIO;        \
01204         (__pvvwaud_)->dwFlags = 0;      \
01205         (__pvvwaud_)->dwCaps = 0;       \
01206         (__pvvwaud_)->wPriority = 0;    \
01207         (__pvvwaud_)->wLanguage = 0;    \
01208         (__pvvwaud_)->dwStart = 0;      \
01209         (__pvvwaud_)->dwInitialFrames = 0;      \
01210         (__pvvwaud_)->dwQuality = 0xFFFFFFFF;   \
01211         (__pvvwaud_)->dwEditCount = 0;  \
01212         (__pvvwaud_)->dwFormatChangeCount = 0;  \
01213         ZeroMemory((__pvvwaud_)->szName, _VVWXXX_NAME_SIZE);    \
01214         (__pvvwaud_)->dwDrFlags = 0;    \
01215         (__pvvwaud_)->dwResDrastic = 0; \
01216         }
01217
01219 //
01220 // The info structure provides basic information on the
01221 //      current information channels available.  For now, this
01222 //      is mostly LTC in file, SmpteX LTC info, current time
01223 //      and data, but it leaves from for other VITC readers,
01224 //      close caption decode and comment.
01225 //
01226 // 03/13/98 Used By:
01227 //              Common\mfFile
01228 //
01230 #define _VVW_IS_VVWINFO                 0x1000
01231
01233 enum vvwInfoMetaTypes {
01235         vvwiFileName,
01237         vvwiNativeLocator,
01239         vvwiUniversalName,
01241         vvwiIP,
01243         vvwiSourceLocator,
01244
01246         vvwiChannel,
01248         vvwiChannelName,
01250         vvwiChannelDescription,
01252         vvwiTitle,
01254         vvwiSubject,
01256         vvwiCategory,                   // <-- 10
01258         vvwiKeywords,
01260         vvwiRatings,
01262         vvwiComments,
01264         vvwiOwner,
01266         vvwiEditor,
01268         vvwiSupplier,
01270         vvwiSource,
01272         vvwiProject,
01274         vvwiStatus,
01276         vvwiAuthor,                             // <-- 20
01278         vvwiRevisionNumber,
01280         vvwiProduced,
01282         vvwiAlbum,
01284         vvwiArtist,
01286         vvwiComposer,
01288         vvwiCopyright,
01290         vvwiCreationData,
01292         vvwiDescription,
01294         vvwiDirector,
01296         vvwiDisclaimer,                 // <-- 30
01298         vvwiEncodedBy,
01300         vvwiFullName,
01302         vvwiGenre,
01304         vvwiHostComputer,
01306         vvwiInformation,
01308         vvwiMake,
01310         vvwiModel,
01312         vvwiOriginalArtist,
01314         vvwiOriginalFormat,
01316         vvwiPerformers,                 // <-- 40
01318         vvwiProducer,
01320         vvwiProduct,
01322         vvwiSoftware,
01324         vvwiSpecialPlaybackRequirements,
01326         vvwiTrack,
01328         vvwiWarning,
01330         vvwiURLLink,
01332         vvwiEditData1,
01334         vvwiEditData2,
01336         vvwiEditData3,                  // <-- 50
01338         vvwiEditData4,
01340         vvwiEditData5,
01342         vvwiEditData6,
01344         vvwiEditData7,
01346         vvwiEditData8,
01348         vvwiEditData9,
01350         vvwiVersionString,
01352         vvwiManufacturer,
01354         vvwiLanguage,
01356         vvwiFormat,                             // <-- 60
01358         vvwiInputDevice,
01360         vvwiDeviceModelNum,
01362         vvwiDeviceSerialNum,
01364         vvwiReel,
01366         vvwiShot,
01368         vvwiTake,
01370         vvwiSlateInfo,
01372         vvwiFrameAttribute,
01374         vvwiEpisode,
01376         vvwiScene,                              // <-- 70
01378         vvwiDailyRoll,
01380         vvwiCamRoll,
01382         vvwiSoundRoll,
01384         vvwiLabRoll,
01386         vvwiKeyNumberPrefix,
01388         vvwiInkNumberPrefix,
01390         vvwiPictureIcon,
01392         vvwiProxyFile,
01393
01394         vvwiEND_OF_STRINGS,
01395
01396         vvwiNumericStart = 0x1000,
01398         vvwiTimeCode,
01400         vvwiUserBits,
01402         vvwiVITCTimeCode,
01404         vvwiVITCUserBits,
01406         vvwiVITCLine3,
01408         vvwiPosterFrame,
01410         vvwiAFrame,
01412         vvwiAspectRatio,
01414         vvwiOriginalRate,
01416         vvwiOriginalScale,
01418         vvwiConversions,
01420         vvwiVersionNumber,
01422         vvwiFileSize,
01424         vvwiFileDate,
01426         vvwiFileTime,
01428         vvwiSequenceNumber,
01430         vvwiTotalStreams,
01432         vvwiTotalLength,
01434         vvwiFilmManufacturerCode,
01436         vvwiFilmTypeCode,
01438         vvwiWhitePoint,
01440         vvwiBlackPoint,
01442         vvwiBlackGain,
01444         vvwiBreakPoint,
01446         vvwiGamma1000,
01448         vvwiTagNumber,
01450         vvwiFlags,
01452         vvwiTimeCodeType,
01454         vvwiLTCTimeCodeType,
01456         vvwiVITCTimeCodeType,
01457
01458         vvwiEND_OF_DWORD_V2,
01459         // Add elements here
01460         //VVVID STRUCT
01462         vvwiVideoWidth = 0x10000,
01464 #define VVWINFOTAG_woVideoWidth                         "Width"
01465
01466         vvwiVideoHeight,
01468 #define VVWINFOTAG_woHeight                                     "Height"
01469
01470         vvwiVideoPlanes,
01472 #define VVWINFOTAG_woPlanes                                     "Planes"
01473
01474         vvwiVideoBitCount,
01476 #define VVWINFOTAG_woBitCount                           "BitCount"
01477
01478         vvwiVideoCompression,
01480 #define VVWINFOTAG_woCompression                        "Compression"
01481
01482         vvwiVideoSizeImage,
01484 #define VVWINFOTAG_woSizeImage                          "SizeImage"
01485
01486         vvwiVideoXPelsPerMeter,
01488 #define VVWINFOTAG_woXPelsPerMeter                      "XPelsPerMeter"
01489
01490         vvwiVideoYPelsPeMeter,
01492 #define VVWINFOTAG_woYPelsPerMeter                      "YPelsPerMeter"
01493
01494         vvwiVideoClrUsed,
01496 #define VVWINFOTAG_woClrUsed                            "ClrUsed"
01497
01498         vvwiVideoClrImportant,
01500 #define VVWINFOTAG_woClrImportant                       "ClrImportant"
01501
01502         vvwiVideoReserved,
01504 #define VVWINFOTAG_woReserved                           "Reserved"
01505
01506         vvwiVideoFccType,
01508 #define VVWINFOTAG_woFccType                            "FccType"
01509
01510         vvwiVideoFccHandler,
01512 #define VVWINFOTAG_woFccHandler                         "FccHandler"
01513
01514         vvwiVideoFlags,
01516 #define VVWINFOTAG_woFlags                                      "Flags"
01517
01518         vvwiVideoCaps,
01520 #define VVWINFOTAG_woCaps                                       "Caps"
01521
01522         vvwiVideoPriority,
01524 #define VVWINFOTAG_woPriority                           "Priority"
01525
01526         vvwiVideoLanguage,
01528 #define VVWINFOTAG_woLanguage                           "Language"
01529
01530         vvwiVideoScale,
01532 #define VVWINFOTAG_woScale                                      "Scale"
01533
01534         vvwiVideoRate,
01536 #define VVWINFOTAG_woRate                                       "Rate"
01537
01538     vvwiVideoStart,
01540 #define VVWINFOTAG_woStart                                      "Start"
01541
01542         vvwiVideoLength,
01544 #define VVWINFOTAG_woLength                                     "Length"
01545
01546         vvwiVideoInitialFrames,
01548 #define VVWINFOTAG_woInitialFrames                      "InitialFrames"
01549
01550     vvwiVideoSuggestedBufferSize,
01552 #define VVWINFOTAG_woSuggestedBufferSize        "SuggestedBufferSize"
01553
01554         vvwiVideoQuality,
01556 #define VVWINFOTAG_woQuality                            "Quality"
01557
01558         vvwiVideoSampleSize,
01560 #define VVWINFOTAG_woSampleSize                         "SampleSize"
01561
01562         vvwiVideoEditCount,
01564 #define VVWINFOTAG_woEditCount                          "EditCount"
01565
01566         vvwiVideoFormatChangeCount,
01568 #define VVWINFOTAG_woFormatChangeCount          "FormatChangeCount"
01569
01570         vvwiVideoPitch,
01572 #define VVWINFOTAG_woPitch                                      "Pitch"
01573
01574         vvwiVideoDrFlags,
01576 #define VVWINFOTAG_woDrFlags                            "DrFlags"
01577
01578         vvwiVideoFileType,
01580 #define VVWINFOTAG_woFileType                           "FileType"
01581
01582         vvwiVideoResDrastic,
01584 #define VVWINFOTAG_woResDrastic                         "ResDrastic"
01585         //char  szName[_VVWXXX_NAME_SIZE];      // Stream identifier
01586         //RECT/*16*/  rcFrame;                                  // Frame dimensions
01587         vvwiLastElementPlus1
01588         // DO NOT ADD ANYTHING BELOW vvwiLastElementPlus1
01589 };
01590
01591
01691 typedef struct /*tagVVWINFO*/ {
01697         char * szFileName;
01699 #define VVWINFOTAG_szFileName   "FileName"              // # 1
01700
01706         char * szNativeLocator;
01708 #define VVWINFOTAG_szNativeLocator      "NativeLocator"
01709
01714         char * szUniversalName;
01716 #define VVWINFOTAG_szUniversalName      "UniversalLocator"
01717
01722         char * szIP;
01724 #define VVWINFOTAG_szIP "TCP-IPAddress"
01725
01730         char * szSourceLocator;
01732 #define VVWINFOTAG_szSourceLocator      "SourceLocator"
01733
01738         char * szChannel;
01740 #define VVWINFOTAG_szChannel    "ChannelIdentifier"
01741
01745         char * szChannelName;
01747 #define VVWINFOTAG_szChannelName        "ChannelName"
01748
01752         char * szChannelDescription;
01754 #define VVWINFOTAG_szChannelDescription "ChannelDescription"
01755
01759         char * szTitle;
01761 #define VVWINFOTAG_szTitle      "Title"
01762
01766         char * szSubject;
01768 #define VVWINFOTAG_szSubject    "Subject"       // # 10
01769
01773         char * szCategory;
01775 #define VVWINFOTAG_szCategory   "Category"
01776
01780         char * szKeywords;
01782 #define VVWINFOTAG_szKeywords   "Keywords"
01783
01787         char * szRatings;
01789 #define VVWINFOTAG_szRatings    "Ratings"
01790
01794         char * szComments;
01796 #define VVWINFOTAG_szComments   "Comments"
01797
01802         char * szDoNotUse;      //SequenceNumber;
01804 #define VVWINFOTAG_szDoNotUse   "DoNotUse"
01805
01810         char * szOwner;
01812 #define VVWINFOTAG_szOwner      "Owner"
01813
01818         char * szEditor;
01820 #define VVWINFOTAG_szEditor     "Editor"
01821
01826         char * szSupplier;
01828 #define VVWINFOTAG_szSupplier   "Supplier"
01829
01833         char * szSource;
01835 #define VVWINFOTAG_szSource     "Source"
01836
01841         char * szProject;
01843 #define VVWINFOTAG_szProject    "Project"       // # 20
01844
01848         char * szStatus;
01850 #define VVWINFOTAG_szStatus     "Status"
01851
01856         char * szAuthor;
01858 #define VVWINFOTAG_szAuthor     "Author"
01859
01863         char * szRevisionNumber;
01865 #define VVWINFOTAG_szRevisionNumber     "RevisionNumber"
01866
01870         char * szProduced;
01872 #define VVWINFOTAG_szProduced   "Produced"
01873
01877         char * szAlbum;
01879 #define VVWINFOTAG_szAlbum      "Album"
01880
01884         char * szArtist;
01886 #define VVWINFOTAG_szArtist     "Artist"
01887
01891         char * szComposer;
01893 #define VVWINFOTAG_szComposer   "Composer"
01894
01899         char * szCopyright;
01901 #define VVWINFOTAG_szCopyright  "Copyright"
01902
01906         char * szCreationData;
01908 #define VVWINFOTAG_szCreationData       "CreationData"
01909
01913         char * szDescription;
01915 #define VVWINFOTAG_szDescription        "Description"   // # 30
01916
01920         char * szDirector;
01922 #define VVWINFOTAG_szDirector   "Director"
01923
01927         char * szDisclaimer;
01929 #define VVWINFOTAG_szDisclaimer "Disclaimer"
01930
01935         char * szEncodedBy;
01937 #define VVWINFOTAG_szEncodedBy  "EncodedBy"
01938
01942         char * szFullName;
01944 #define VVWINFOTAG_szFullName   "FullName"
01945
01949         char * szGenre;
01951 #define VVWINFOTAG_szGenre      "Genre"
01952
01956         char * szHostComputer;
01958 #define VVWINFOTAG_szHostComputer       "HostComputer"
01959
01963         char * szInformation;
01965 #define VVWINFOTAG_szInformation        "Information"
01966
01970         char * szMake;
01972 #define VVWINFOTAG_szMake       "Make"
01973
01977         char * szModel;
01979 #define VVWINFOTAG_szModel      "Model"
01980
01984         char * szOriginalArtist;
01986 #define VVWINFOTAG_szOriginalArtist     "OriginalArtist"        // # 40
01987
01991         char * szOriginalFormat;
01993 #define VVWINFOTAG_szOriginalFormat     "OriginalFormat"
01994
01998         char * szPerformers;
02000 #define VVWINFOTAG_szPerformers "Performers"
02001
02005         char * szProducer;
02007 #define VVWINFOTAG_szProducer   "Producer"
02008
02012         char * szProduct;
02014 #define VVWINFOTAG_szProduct    "Product"
02015
02019         char * szSoftware;
02021 #define VVWINFOTAG_szSoftware   "Software"
02022
02026         char * szSpecialPlaybackRequirements;
02028 #define VVWINFOTAG_szSpecialPlaybackRequirements        "SpecialPlaybackRequirements"
02029
02033         char * szTrack;
02035 #define VVWINFOTAG_szTrack      "Track"
02036
02040         char * szWarning;
02042 #define VVWINFOTAG_szWarning    "Warning"
02043
02048         char * szURLLink;
02050 #define VVWINFOTAG_szURLLink    "URL"
02051
02055         char * szEditData1;
02057 #define VVWINFOTAG_szEditData1  "EditData1"             // # 50
02058
02062         char * szEditData2;
02064 #define VVWINFOTAG_szEditData2  "EditData2"
02065
02069         char * szEditData3;
02071 #define VVWINFOTAG_szEditData3  "EditData3"
02072
02076         char * szEditData4;
02078 #define VVWINFOTAG_szEditData4  "EditData4"
02079
02083         char * szEditData5;
02085 #define VVWINFOTAG_szEditData5  "EditData5"
02086
02090         char * szEditData6;
02092 #define VVWINFOTAG_szEditData6  "EditData6"
02093
02097         char * szEditData7;
02099 #define VVWINFOTAG_szEditData7  "EditData7"
02100
02104         char * szEditData8;
02106 #define VVWINFOTAG_szEditData8  "EditData8"
02107
02111         char * szEditData9;
02113 #define VVWINFOTAG_szEditData9  "EditData9"
02114
02118         char * szVersionString;
02120 #define VVWINFOTAG_szVersionString      "VersionString"
02121
02125         char * szManufacturer;
02127 #define VVWINFOTAG_szManufacturer       "Manufacturer"  // # 60
02128
02132         char * szLanguage;
02134 #define VVWINFOTAG_szLanguage   "Language"
02135
02139         char * szFormat;
02141 #define VVWINFOTAG_szFormat     "Format"
02142
02146         char * szInputDevice;
02148 #define VVWINFOTAG_szInputDevice        "InputDevice"
02149
02153         char * szDeviceModelNum;
02155 #define VVWINFOTAG_szDeviceModelNum             "DeviceModelNum"
02156
02160         char * szDeviceSerialNum;
02162 #define VVWINFOTAG_szDeviceSerialNum    "DeviceSerialNum"
02163
02167         char * szReel;
02169 #define VVWINFOTAG_szReel                               "Reel"
02170
02174         char * szShot;
02176 #define VVWINFOTAG_szShot                               "Shot"
02177
02181         char * szTake;
02183 #define VVWINFOTAG_szTake                               "Take"
02184
02188         char * szSlateInfo;
02190 #define VVWINFOTAG_szSlateInfo                  "SlateInfo"
02191
02195         char * szFrameAttribute;
02197 #define VVWINFOTAG_szFrameAttribute             "FrameAttribute"        // # 70
02198
02201         char * szEpisode;
02203 #define VVWINFOTAG_szEpisode                    "Episode"
02204
02207         char * szScene;
02209 #define VVWINFOTAG_szScene                              "Scene"
02210
02213         char * szDailyRoll;
02215 #define VVWINFOTAG_szDailyRoll                  "DailyRoll"
02216
02219         char * szCamRoll;
02221 #define VVWINFOTAG_szCamRoll                    "CamRoll"
02222
02225         char * szSoundRoll;
02227 #define VVWINFOTAG_szSoundRoll                  "SoundRoll"
02228
02231         char * szLabRoll;
02233 #define VVWINFOTAG_szLabRoll                    "LabRoll"
02234
02237         char * szKeyNumberPrefix;
02239 #define VVWINFOTAG_szKeyNumberPrefix    "KeyNumberPrefix"
02240
02243         char * szInkNumberPrefix;
02245 #define VVWINFOTAG_szInkNumberPrefix    "InkNumberPrefix"
02246
02249         char * szPictureIcon;
02251 #define VVWINFOTAG_szPictureIcon                "PictureIcon"
02252
02255         char * szProxyFile;
02257 #define VVWINFOTAG_szProxyFile                  "ProxyFile"     // # 80
02258
02261         char * szNU_81;
02263 #define VVWINFOTAG_szNU_81                              "NotUsed_81"
02264
02267         char * szNU_82;
02269 #define VVWINFOTAG_szNU_82                              "NotUsed_82"
02270
02273         char * szNU_83;
02275 #define VVWINFOTAG_szNU_83                              "NotUsed_83"
02276
02279         char * szNU_84;
02281 #define VVWINFOTAG_szNU_84                              "NotUsed_84"
02282
02285         char * szNU_85;
02287 #define VVWINFOTAG_szNU_85                              "NotUsed_85"
02288
02291         char * szNU_86;
02293 #define VVWINFOTAG_szNU_86                              "NotUsed_86"
02294
02297         char * szNU_87;
02299 #define VVWINFOTAG_szNU_87                              "NotUsed_87"
02300
02303         char * szNU_88;
02305 #define VVWINFOTAG_szNU_88                              "NotUsed_88"
02306
02309         char * szNU_89;
02311 #define VVWINFOTAG_szNU_89                              "NotUsed_89"
02312
02315         char * szNU_90;
02317 #define VVWINFOTAG_szNU_90                              "NotUsed_90"    // # 90
02318
02321         char * szNU_91;
02323 #define VVWINFOTAG_szNU_91                              "NotUsed_91"
02324
02327         char * szNU_92;
02329 #define VVWINFOTAG_szNU_92                              "NotUsed_92"
02330
02333         char * szNU_93;
02335 #define VVWINFOTAG_szNU_93                              "NotUsed_93"
02336
02339         char * szNU_94;
02341 #define VVWINFOTAG_szNU_94                              "NotUsed_94"
02342
02345         char * szNU_95;
02347 #define VVWINFOTAG_szNU_95                              "NotUsed_95"
02348
02351         char * szNU_96;
02353 #define VVWINFOTAG_szNU_96                              "NotUsed_96"
02354
02357         char * szNU_97;
02359 #define VVWINFOTAG_szNU_97                              "NotUsed_97"
02360
02363         char * szNU_98;
02365 #define VVWINFOTAG_szNU_98                              "NotUsed_98"
02366
02369         char * szNU_99;
02371 #define VVWINFOTAG_szNU_99                              "NotUsed_99"    // # 99
02372
02376         DWORD   dwReservedMustBe0;
02377
02382         DWORD dwTimeCode;
02384 #define VVWINFOTAG_dwTimeCode   "TimeCode"
02385
02389         DWORD dwUserBits;
02391 #define VVWINFOTAG_dwUserBits   "UserBits"
02392
02396         DWORD dwVITCTimeCode;
02398 #define VVWINFOTAG_dwVITCTimeCode       "VITCTimeCode"
02399
02403         DWORD dwVITCUserBits;
02405 #define VVWINFOTAG_dwVITCUserBits       "VITCUserBits"
02406
02410         DWORD dwVITCLine3;
02412 #define VVWINFOTAG_dwVITCLine3  "VITCExtraData"
02413
02417         DWORD dwPosterFrame;
02419 #define VVWINFOTAG_dwPosterFrame        "PosterFrame"
02420
02424         DWORD dwAFrame;
02426 #define VVWINFOTAG_dwAFrame     "A-Frame"
02427
02431         DWORD dwAspectRatio;
02433 #define VVWINFOTAG_dwAspectRatio        "AspectRatio"
02434
02438         DWORD dwOriginalRate;
02440 #define VVWINFOTAG_dwOriginalRate       "OriginalRate"
02441
02445         DWORD dwOriginalScale;
02447 #define VVWINFOTAG_dwOriginalScale      "OriginalScale"
02448
02452         DWORD dwConversions;
02454 #define VVWINFOTAG_dwConversions        "TotalConversions"
02455
02459         DWORD dwVersionNumber;
02461 #define VVWINFOTAG_dwVersionNumber      "VersionNumber"
02462
02466         DWORD dwFileSize;
02468 #define VVWINFOTAG_dwFileSize   "FileSize"
02469
02473         DWORD dwFileDate;
02475 #define VVWINFOTAG_dwFileDate   "FileDate"
02476
02480         DWORD dwFileTime;
02482 #define VVWINFOTAG_dwFileTime   "FileTime"
02483
02487         DWORD dwSequenceNumber;
02489 #define VVWINFOTAG_dwSequenceNumber     "SequenceNumber"
02490
02494         DWORD dwTotalStreams;
02496 #define VVWINFOTAG_dwTotalStreams       "TotalStreams"
02497
02501         DWORD dwTotalLength;
02503 #define VVWINFOTAG_dwTotalLength        "TotalLength"
02504
02508         DWORD dwFilmManufacturerCode;
02510 #define VVWINFOTAG_dwFilmManufacturerCode       "FilmManufacturerCode"
02511
02515         DWORD dwFilmTypeCode;
02517 #define VVWINFOTAG_dwFilmTypeCode       "FilmTypeCode"
02518
02522         DWORD dwWhitePoint;
02524 #define VVWINFOTAG_dwWhitePoint "WhitePoint"
02525
02529         DWORD dwBlackPoint;
02531 #define VVWINFOTAG_dwBlackPoint "BlackPoint"
02532
02536         DWORD dwBlackGain;
02538 #define VVWINFOTAG_dwBlackGain  "BlackGain"
02539
02543         DWORD dwBreakPoint;
02545 #define VVWINFOTAG_dwBreakPoint "BreakPoint"
02546
02550         DWORD dwGamma1000;
02552 #define VVWINFOTAG_dwGamma1000  "Gamma1000"
02553
02556         DWORD dwTagNumber;
02558 #define VVWINFOTAG_dwTagNumber  "TagNumber"
02559
02562         DWORD dwFlags;
02564 #define VVWINFOTAG_dwFlags      "Flags"
02565
02569         DWORD dwTimeCodeType;
02571 #define VVWINFOTAG_dwTimeCodeType               "TimeCodeType"
02572
02576         DWORD dwLTCTimeCodeType;
02578 #define VVWINFOTAG_dwLTCTimeCodeType    "LTCTimeCodeType"
02579
02583         DWORD dwVITCTimeCodeType;
02585 #define VVWINFOTAG_dwVITCTimeCodeType   "VITCTimeCodeType"
02586
02589         DWORD dwNU_31;
02591 #define VVWINFOTAG_dwNU_31      "NumericNotUsed_31"
02592
02595         DWORD dwNU_32;
02597 #define VVWINFOTAG_dwNU_32      "NumericNotUsed_32"
02598
02601         DWORD dwNU_33;
02603 #define VVWINFOTAG_dwNU_33      "NumericNotUsed_33"
02604
02607         DWORD dwNU_34;
02609 #define VVWINFOTAG_dwNU_34      "NumericNotUsed_34"
02610
02613         DWORD dwNU_35;
02615 #define VVWINFOTAG_dwNU_35      "NumericNotUsed_35"
02616
02619         DWORD dwNU_36;
02621 #define VVWINFOTAG_dwNU_36      "NumericNotUsed_36"
02622
02625         DWORD dwNU_37;
02627 #define VVWINFOTAG_dwNU_37      "NumericNotUsed_37"
02628
02631         DWORD dwNU_38;
02633 #define VVWINFOTAG_dwNU_38      "NumericNotUsed_38"
02634
02637         DWORD dwNU_39;
02639 #define VVWINFOTAG_dwNU_39      "NumericNotUsed_39"
02640
02643         DWORD dwNU_40;
02645 #define VVWINFOTAG_dwNU_40      "NumericNotUsed_40"
02646
02649         DWORD dwNU_41;
02651 #define VVWINFOTAG_dwNU_41      "NumericNotUsed_41"
02652
02655         DWORD dwNU_42;
02657 #define VVWINFOTAG_dwNU_42      "NumericNotUsed_42"
02658
02661         DWORD dwNU_43;
02663 #define VVWINFOTAG_dwNU_43      "NumericNotUsed_43"
02664
02667         DWORD dwNU_44;
02669 #define VVWINFOTAG_dwNU_44      "NumericNotUsed_44"
02670
02673         DWORD dwNU_45;
02675 #define VVWINFOTAG_dwNU_45      "NumericNotUsed_45"
02676
02679         DWORD dwNU_46;
02681 #define VVWINFOTAG_dwNU_46      "NumericNotUsed_46"
02682
02685         DWORD dwNU_47;
02687 #define VVWINFOTAG_dwNU_47      "NumericNotUsed_47"
02688
02691         DWORD dwNU_48;
02693 #define VVWINFOTAG_dwNU_48      "NumericNotUsed_48"
02694
02697         DWORD dwNU_49;
02699 #define VVWINFOTAG_dwNU_49      "NumericNotUsed_49"
02700
02702         DWORD dwFileType;
02703
02705         DWORD dwResDrastic;                                     // Always
02706
02707 } VVWINFO, * pVVWINFO;
02708
02709
02712 #define GetAudio        0x00000000              // Use audio driver
02713
02714 #define GetVideo        0x00000001              // Use video driver
02715
02716 #define GetInf          0x00000002
02717
02718 #define PutAudio        GetAudio                // As Above
02719
02720 #define PutVideo        GetVideo                // As Above
02721
02722 #define PutInf          GetInf
02723
02724 #define GetNoFail       0x00000100
02725
02726 #define GetCurrent      0x00000000              // Return current info
02727
02728 #define GetQueued       0x00000010              // Return max queued info
02729
02730 #ifdef _WIN32
02731 #include <poppack.h>
02732 #else
02733 #ifndef RC_INVOKED
02734 #pragma pack()
02735 #endif
02736 #endif
02737
02738 #else //defined(_VVW_TYPES_HAVE_ALREADY_BEEN_INCLUDED)
02739
02740         #ifdef _VVW_TYPES_DEFINE_META_DATA_TAG_NAME_ARRAY_DRASTIC
02741                 static char * gsszMetaDataTagName[] =
02742                 {
02743                 VVWINFOTAG_szFileName,  //"FileName"            // # 1
02744                 VVWINFOTAG_szNativeLocator,     //"NativeLocator"
02745                 VVWINFOTAG_szUniversalName,     //"UniversalLocator"
02746                 VVWINFOTAG_szIP,        //"TCP-IPAddress"
02747                 VVWINFOTAG_szSourceLocator,     //"SourceLocator"
02748                 VVWINFOTAG_szChannel,   //"ChannelIdentifier"
02749                 VVWINFOTAG_szChannelName,       //"ChannelName"
02750                 VVWINFOTAG_szChannelDescription,        //"ChannelDescription"
02751                 VVWINFOTAG_szTitle,     //"Title"
02752                 VVWINFOTAG_szSubject,   //"Subject"     // # 10
02753                 VVWINFOTAG_szCategory,  //"Category"
02754                 VVWINFOTAG_szKeywords,  //"Keywords"
02755                 VVWINFOTAG_szRatings,   //"Ratings"
02756                 VVWINFOTAG_szComments,  //"Comments"
02757         //      VVWINFOTAG_szDoNotUse,  //"SequenceNumber"
02758                 VVWINFOTAG_szOwner,     //"Owner"
02759                 VVWINFOTAG_szEditor,    //"Editor"
02760                 VVWINFOTAG_szSupplier,  //"Supplier"
02761                 VVWINFOTAG_szSource,    //"Source"
02762                 VVWINFOTAG_szProject,   //"Project"     // # 20
02763                 VVWINFOTAG_szStatus,    //"Status"
02764                 VVWINFOTAG_szAuthor,    //"Author"
02765                 VVWINFOTAG_szRevisionNumber,    //"RevisionNumber"
02766                 VVWINFOTAG_szProduced,  //"Produced"
02767                 VVWINFOTAG_szAlbum,     //"Album"
02768                 VVWINFOTAG_szArtist,    //"Artist"
02769                 VVWINFOTAG_szComposer,  //"Composer"
02770                 VVWINFOTAG_szCopyright, //"Copyright"
02771                 VVWINFOTAG_szCreationData,      //"CreationData"
02772                 VVWINFOTAG_szDescription,       //"Description" // # 30
02773                 VVWINFOTAG_szDirector,  //"Director"
02774                 VVWINFOTAG_szDisclaimer,        //"Disclaimer"
02775                 VVWINFOTAG_szEncodedBy, //"EncodedBy"
02776                 VVWINFOTAG_szFullName,  //"FullName"
02777                 VVWINFOTAG_szGenre,     //"Genre"
02778                 VVWINFOTAG_szHostComputer,      //"HostComputer"
02779                 VVWINFOTAG_szInformation,       //"Information"
02780                 VVWINFOTAG_szMake,      //"Make"
02781                 VVWINFOTAG_szModel,     //"Model"
02782                 VVWINFOTAG_szOriginalArtist,    //"OriginalArtist"      // # 40
02783                 VVWINFOTAG_szOriginalFormat,    //"OriginalFormat"
02784                 VVWINFOTAG_szPerformers,        //"Performers"
02785                 VVWINFOTAG_szProducer,  //"Producer"
02786                 VVWINFOTAG_szProduct,   //"Product"
02787                 VVWINFOTAG_szSoftware,  //"Software"
02788                 VVWINFOTAG_szSpecialPlaybackRequirements,       //"SpecialPlaybackRequirements"
02789                 VVWINFOTAG_szTrack,     //"Track"
02790                 VVWINFOTAG_szWarning,   //"Warning"
02791                 VVWINFOTAG_szURLLink,   //"URL"
02792                 VVWINFOTAG_szEditData1, //"EditData1"           // # 50
02793                 VVWINFOTAG_szEditData2, //"EditData2"
02794                 VVWINFOTAG_szEditData3, //"EditData3"
02795                 VVWINFOTAG_szEditData4, //"EditData4"
02796                 VVWINFOTAG_szEditData5, //"EditData5"
02797                 VVWINFOTAG_szEditData6, //"EditData6"
02798                 VVWINFOTAG_szEditData7, //"EditData7"
02799                 VVWINFOTAG_szEditData8, //"EditData8"
02800                 VVWINFOTAG_szEditData9, //"EditData9"
02801                 VVWINFOTAG_szVersionString,     //"VersionString"
02802                 VVWINFOTAG_szManufacturer,      //"Manufacturer"        // # 60
02803                 VVWINFOTAG_szLanguage,  //"Language"
02804                 VVWINFOTAG_szFormat,    //"Format"
02805                 VVWINFOTAG_szInputDevice,       //"InputDevice"
02806                 VVWINFOTAG_szDeviceModelNum,    //"DeviceModelNum"
02807                 VVWINFOTAG_szDeviceSerialNum,   //"DeviceSerialNum"
02808                 VVWINFOTAG_szReel,      //"Reel"
02809                 VVWINFOTAG_szShot,      //"Shot"
02810                 VVWINFOTAG_szTake,      //"Take"
02811                 VVWINFOTAG_szSlateInfo, //"SlateInfo"
02812                 VVWINFOTAG_szFrameAttribute     ,       //"FrameAttribute"      // # 70
02813                 VVWINFOTAG_szEpisode            ,       //"Episode"
02814                 VVWINFOTAG_szScene                      ,       //"Scene"
02815                 VVWINFOTAG_szDailyRoll          ,       //"DailyRoll"
02816                 VVWINFOTAG_szCamRoll            ,       //"CamRoll"
02817                 VVWINFOTAG_szSoundRoll          ,       //"SoundRoll"
02818                 VVWINFOTAG_szLabRoll            ,       //"LabRoll"
02819                 VVWINFOTAG_szKeyNumberPrefix    ,       //"KeyNumberPrefix"
02820                 VVWINFOTAG_szInkNumberPrefix    ,       //"InkNumberPrefix"
02821                 VVWINFOTAG_szPictureIcon                ,       //"PictureIcon"
02822                 VVWINFOTAG_szProxyFile          ,       //"ProxyFile"   // # 80
02823                 VVWINFOTAG_szNU_81                      ,       //"NotUsed_81"
02824                 VVWINFOTAG_szNU_82                      ,       //"NotUsed_82"
02825                 VVWINFOTAG_szNU_83                      ,       //"NotUsed_83"
02826                 VVWINFOTAG_szNU_84                      ,       //"NotUsed_84"
02827                 VVWINFOTAG_szNU_85                      ,       //"NotUsed_85"
02828                 VVWINFOTAG_szNU_86                      ,       //"NotUsed_86"
02829                 VVWINFOTAG_szNU_87                      ,       //"NotUsed_87"
02830                 VVWINFOTAG_szNU_88                      ,       //"NotUsed_88"
02831                 VVWINFOTAG_szNU_89                      ,       //"NotUsed_89"
02832                 VVWINFOTAG_szNU_90                      ,       //"NotUsed_90"  // # 90
02833                 VVWINFOTAG_szNU_91                      ,       //"NotUsed_91"
02834                 VVWINFOTAG_szNU_92                      ,       //"NotUsed_92"
02835                 VVWINFOTAG_szNU_93                      ,       //"NotUsed_93"
02836                 VVWINFOTAG_szNU_94                      ,       //"NotUsed_94"
02837                 VVWINFOTAG_szNU_95                      ,       //"NotUsed_95"
02838                 VVWINFOTAG_szNU_96                      ,       //"NotUsed_96"
02839                 VVWINFOTAG_szNU_97                      ,       //"NotUsed_97"
02840                 VVWINFOTAG_szNU_98                      ,       //"NotUsed_98"
02841                 VVWINFOTAG_szNU_99                      ,       //"NotUsed_99"  // # 99
02842                 VVWINFOTAG_dwTimeCode,  //"TimeCode"
02843                 VVWINFOTAG_dwUserBits,  //"UserBits"
02844                 VVWINFOTAG_dwVITCTimeCode,      //"VITCTimeCode"
02845                 VVWINFOTAG_dwVITCUserBits,      //"VITCUserBits"
02846                 VVWINFOTAG_dwVITCLine3, //"VITCExtraData"
02847                 VVWINFOTAG_dwPosterFrame,       //"PosterFrame"
02848                 VVWINFOTAG_dwAFrame,    //"A-Frame"
02849                 VVWINFOTAG_dwAspectRatio,       //"AspectRatio"
02850                 VVWINFOTAG_dwOriginalRate,      //"OriginalRate"
02851                 VVWINFOTAG_dwOriginalScale,     //"OriginalScale"
02852                 VVWINFOTAG_dwConversions,       //"TotalConversions"
02853                 VVWINFOTAG_dwVersionNumber,     //"VersionNumber"
02854                 VVWINFOTAG_dwFileSize,  //"FileSize"
02855                 VVWINFOTAG_dwFileDate,  //"FileDate"
02856                 VVWINFOTAG_dwFileTime,  //"FileTime"
02857                 VVWINFOTAG_dwSequenceNumber,    //"SequenceNumber"
02858                 VVWINFOTAG_dwTotalStreams,      //"TotalStreams"
02859                 VVWINFOTAG_dwTotalLength,       //"TotalLength"
02860                 VVWINFOTAG_dwFilmManufacturerCode,      //"FilmManufacturerCode"
02861                 VVWINFOTAG_dwFilmTypeCode,      //"FilmTypeCode"
02862                 VVWINFOTAG_dwWhitePoint,        //"WhitePoint"
02863                 VVWINFOTAG_dwBlackPoint,        //"BlackPoint"
02864                 VVWINFOTAG_dwBlackGain, //"BlackGain"
02865                 VVWINFOTAG_dwBreakPoint,        //"BreakPoint"
02866                 VVWINFOTAG_dwGamma1000, //"Gamma1000"
02867                 VVWINFOTAG_dwTagNumber, //"TagNumber"
02868                 VVWINFOTAG_dwFlags,     //"Flags"
02869                 VVWINFOTAG_dwTimeCodeType,      //"NumericNotUsed_28"
02870                 VVWINFOTAG_dwLTCTimeCodeType,   //"NumericNotUsed_29"
02871                 VVWINFOTAG_dwVITCTimeCodeType,  //"NumericNotUsed_30"
02872                 VVWINFOTAG_dwNU_31,     //"NumericNotUsed_31"
02873                 VVWINFOTAG_dwNU_32,     //"NumericNotUsed_32"
02874                 VVWINFOTAG_dwNU_33,     //"NumericNotUsed_33"
02875                 VVWINFOTAG_dwNU_34,     //"NumericNotUsed_34"
02876                 VVWINFOTAG_dwNU_35,     //"NumericNotUsed_35"
02877                 VVWINFOTAG_dwNU_36,     //"NumericNotUsed_36"
02878                 VVWINFOTAG_dwNU_37,     //"NumericNotUsed_37"
02879                 VVWINFOTAG_dwNU_38,     //"NumericNotUsed_38"
02880                 VVWINFOTAG_dwNU_39,     //"NumericNotUsed_39"
02881                 VVWINFOTAG_dwNU_40,     //"NumericNotUsed_40"
02882                 VVWINFOTAG_dwNU_41,     //"NumericNotUsed_41"
02883                 VVWINFOTAG_dwNU_42,     //"NumericNotUsed_42"
02884                 VVWINFOTAG_dwNU_43,     //"NumericNotUsed_43"
02885                 VVWINFOTAG_dwNU_44,     //"NumericNotUsed_44"
02886                 VVWINFOTAG_dwNU_45,     //"NumericNotUsed_45"
02887                 VVWINFOTAG_dwNU_46,     //"NumericNotUsed_46"
02888                 VVWINFOTAG_dwNU_47,     //"NumericNotUsed_47"
02889                 VVWINFOTAG_dwNU_48,     //"NumericNotUsed_48"
02890                 VVWINFOTAG_dwNU_49,     //"NumericNotUsed_49"
02891         };
02892         #endif //_VVW_TYPES_DEFINE_META_DATA_TAG_NAME_ARRAY_DRASTIC
02893 #endif
Generated on Wed May 17 15:52:30 2006 for MediaCmd by doxygen 1.4.6-NO